Subject: RE: [Ltru] Re: Note to RFC editor in initial registry

From: "Addison Phillips" <[email-masked]>
Date: Sat, 24 Sep 2005 19:41:09 -0700

Avoid the problem. Use this instead of the first sentence:

--
The initial set of records in the Language Subtag Registry defined by [ltru-registry] were originally defined in this section. This set consists of those records with "Added" field-values no later than the date of publication of this document.
--

Note the use of "records" instead of "subtags": it's important, I think.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Doug Ewell
> Sent: samedi 24 septembre 2005 19:07
> To: LTRU Working Group
> Subject: Re: [Ltru] Re: Note to RFC editor in initial registry
> 
> To summarize, I propose to amend draft-initial-04 by adding the
> following text to the beginning of Section 3:
> 
> [NOTE TO RFC EDITOR: Please remove this note and the rest of this
> section, replacing it with the following comment:
> 
> The initial set of subtags in the registry, which were specified by this
> document, are those records in the IANA registry [IANA-registry] with
> "Added" field-values no later than the date of publication of this
> document.  Note that Section 3.1 of [ltru-registry] requires that an
> "Added" field appear in each registration record and that Section 3.3(1)
> specifies that field must not be changed after registration. Other
> fields in these records may have been modified at a later date, subject
> to the restrictions in Section 3.4 of [ltru-registry].  Because of this,
> it may not be possible to use a future version of the Language Subtag
> Registry to reconstruct an exact copy of the initial registry contents.]
> 
> I would need to know what to put within the square brackets for
> [IANA-registry].  Presumably this would be a normative reference to
> whatever URI is chosen for the Language Subtag Registry.  I would have
> to get this information in time for AUTH48, or the RFC Editor would have
> to plug in the correct value at the time of text substitution.
> 
> The only other amendment to draft-initial-04 would be the addition of
> the following record to the initial registry contents:
> 
> Type: language
> Subtag: rup
> Description: Aromanian
> Description: Arumanian
> Description: Macedo-Romanian
> Added: 2005-09-20
> 
> Note that 'ain' for Ainu is already in draft-initial-04, but not in
> previous versions.
> 
> --
> Doug Ewell
> Fullerton, California
> http://users.adelphia.net/~dewell/
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru
_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Sat, 24 Sep 2005 20:00:45 -0700

Hi -

As a technical contributor...

> From: "Addison Phillips" <[email-masked]>
> To: "Doug Ewell" <[email-masked]>; "LTRU Working Group" <[email-masked]>
> Sent: Saturday, September 24, 2005 7:41 PM
> Subject: RE: [Ltru] Re: Note to RFC editor in initial registry
>

> The initial set of records in the Language Subtag Registry defined
> by [ltru-registry] were originally defined in this section. This

s/were/was/
(verb/subject agreement)

> set consists of those records with "Added" field-values no later
> than the date of publication of this document.
> --
...

I like this proposal.

Randy