Subject: RE: [Ltru] Re: matching comments: use of prefixes

From: "Addison Phillips" <[email-masked]>
Date: Thu, 29 Sep 2005 08:14:41 -0700

+1

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Frank Ellermann
> Sent: jeudi 29 septembre 2005 07:58
> To: [email-masked]
> Subject: [Ltru] Re: matching comments: use of prefixes
> 
> Harald Tveit Alvestrand wrote:
> 
> > RFC 1766, and I still remember the debate that got us there.
> > What it's trying to prevent is dialogues like this:
> 
> > Registrant: I register (or use) sgn-GB and sgn-FR
> > Searcher: I want something in "sgn".
> 
> Now that's immediately clear.  Maybe adding this as example
> to Addison's new wording could help.  It would explain that
> matching was already tricky before 3066bis, so that's not a
> new "bug" introduced by 3066bis, but just as it is.
> 
>                         Bye, Frank
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Addison Phillips" <[email-masked]>
Date: Thu, 29 Sep 2005 20:06:56 -0700

In the first case, I caught the problem when inserting into the editor's copy. It is clearly not 2119 language. In the second case, I think it ought to be (although it is borderline).

Addison

Addison P. Phillips

> Randy Presuhn
> Sent: jeudi 29 septembre 2005 19:39
> To: [email-masked]
> Subject: Re: [Ltru] Re: matching comments: use of prefixes
> 
> Hi -
> 
> > From: "Addison Phillips" <[email-masked]>
> > To: "Randy Presuhn" <[email-masked]>; <[email-masked]>
> > Sent: Thursday, September 29, 2005 3:44 PM
> > Subject: RE: [Ltru] Re: matching comments: use of prefixes
> ...
> > --
> > Users should note that the set of language tags that match a specific
> > language-range MAY NOT be mutually intelligible, although historically
> > this form of matching has proven useful.
> > --
> 
> This is clearly NOT an RFC 2119 "MAY NOT".  Please replace with "may not"
> or "might not".
> 
> ...
> > <t>Users SHOULD avoid subtags that add no distinguishing value to a
> language range.
> >  For example, script subtags SHOULD NOT be used to form a language range
> with
> ...
> 
> This SHOULD and SHOULD NOT are borderline.  I think they're ok (since
> they're about operational considerations), but it would not surprise me if
> others, pickier that I (you know who you are) object.  I suggest:
> 
>    Users are advised to avoid subtags that...
>    For example,  no distinguishing value is normally added by including a
>    subtag matching a language tag's Suppress-Script field from its
>    registry record.  Thus...
> 
> Now, if we were talking about what decisions implementations should make,
> there's a stronger case for SHOULD.
> 
> Randy
> 
> 
> 
>