Subject: RE: [Ltru] Re: matching comments: use of prefixes

From: "Addison Phillips" <[email-masked]>
Date: Thu, 29 Sep 2005 15:44:56 -0700

So then...

--
Users should note that the set of language tags that match a specific language-range MAY NOT be mutually intelligible, although historically this form of matching has proven useful.
--

Note the: s/implementers/users (implementations care not a bit; range-choosing folks using implementations are the ones that care).

There are some problems with removing the full verbosity of the original proposal: it also excludes the examples and it excludes a specific note about Suppress-Script, an issue that I recall some people were quite concerned about. How about (note that this moves the suggested sentence up into a preceding paragraph not previously quoted):

--
<t>That is, a language-range has the same syntax as a language-tag or is the 
single character "*". Basic Language Ranges imply that
there is a semantic relationship between language tags that share the same prefix. While this is often the case, it is not always true and users should note that the set of language tags that match a specific language-range may not be mutually intelligible.</t>

<t>Users SHOULD avoid subtags that add no distinguishing value to a language range. For example, script subtags SHOULD NOT be used to form a language range with language subtags which have a matching Suppress-Script field in their registry record. Thus the language range "en-Latn" is probably inappropriate for most applications (because the vast majority English documents are written in the Latin script and thus the 'en' language subtag has a Suppress-Script field for 'Latn' in the registry).
</t>
--

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Randy Presuhn
> Sent: jeudi 29 septembre 2005 14:01
> To: [email-masked]
> Subject: Re: [Ltru] Re: matching comments: use of prefixes
> 
> Hi -
> 
> > From: "Debbie Garside" <[email-masked]>
> > To: "'Addison Phillips'" <[email-masked]>; "'Frank
> Ellermann'" <[email-masked]>; <[email-masked]>
> > Sent: Thursday, September 29, 2005 12:56 PM
> > Subject: RE: [Ltru] Re: matching comments: use of prefixes
> ...
> > In a nutshell:
> >
> > "Implementers should note that the set of language tags that match a
> > specific language-range prefix MAY not be mutually intelligible;
> although
> > historically this form of matching has proved useful."
> >
> > Debbie
> ...
> 
> s/MAY/may/  -- this is clearly not intended with normative force
> 
> To avoid confusion, we might say "might correspond to
> mutually unintelligible languages"
> 
> s/proved/proven/   --  if the editors prefer.
> 
> Randy
> 
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 29 Sep 2005 19:38:56 -0700

Hi -

> From: "Addison Phillips" <[email-masked]>
> To: "Randy Presuhn" <[email-masked]>; <[email-masked]>
> Sent: Thursday, September 29, 2005 3:44 PM
...
> --
> Users should note that the set of language tags that match a specific
> language-range MAY NOT be mutually intelligible, although historically
> this form of matching has proven useful.
> --

This is clearly NOT an RFC 2119 "MAY NOT".  Please replace with "may not"
or "might not".

...
> <t>Users SHOULD avoid subtags that add no distinguishing value to a language range.
>  For example, script subtags SHOULD NOT be used to form a language range with
...

This SHOULD and SHOULD NOT are borderline.  I think they're ok (since
they're about operational considerations), but it would not surprise me if
others, pickier that I (you know who you are) object.  I suggest:

   Users are advised to avoid subtags that...
   For example,  no distinguishing value is normally added by including a
   subtag matching a language tag's Suppress-Script field from its
   registry record.  Thus...

Now, if we were talking about what decisions implementations should make,
there's a stronger case for SHOULD.

Randy

---

From: "Debbie Garside" <[email-masked]>
Date: Fri, 30 Sep 2005 09:02:09 +0100

Hi Addison

My suggestion was to replace ONLY the first paragraph and to leave the other
paragraphs in place.  Indeed it might be wise to put an example in of a
prefix where it is mutually intelligible and another where it isn't.

Best regards

Debbie

> Addison Phillips
> Sent: 29 September 2005 23:45
> To: Randy Presuhn; [email-masked]
> Note the: s/implementers/users (implementations care not a bit; range-
> choosing folks using implementations are the ones that care).
> 
> There are some problems with removing the full verbosity of the original
> proposal: it also excludes the examples and it excludes a specific note
> about Suppress-Script, an issue that I recall some people were quite
> concerned about. How about (note that this moves the suggested sentence up
> into a preceding paragraph not previously quoted):
> 
> --
> there is a semantic relationship between language tags that share the same
> prefix. While this is often the case, it is not always true and users
> should note that the set of language tags that match a specific language-
> range may not be mutually intelligible.</t>
> 
> <t>Users SHOULD avoid subtags that add no distinguishing value to a
> language range. For example, script subtags SHOULD NOT be used to form a
> language range with language subtags which have a matching Suppress-Script
> field in their registry record. Thus the language range "en-Latn" is
> probably inappropriate for most applications (because the vast majority
> English documents are written in the Latin script and thus the 'en'
> language subtag has a Suppress-Script field for 'Latn' in the registry).
> </t>
> --
> 
> Addison P. Phillips

---

From: Frank Ellermann <[email-masked]>
Date: Fri, 30 Sep 2005 13:50:37 +0200

Randy Presuhn wrote:

> This is clearly NOT an RFC 2119 "MAY NOT".
[...]
> others, pickier that I (you know who you are)

<pickier>  No "MAY NOT" in 2119.  </pickier>