Subject: [Ltru] numeric ranges in the registry (gen-art #11)

From: "Addison Phillips" <[email-masked]>
Date: Thu, 1 Sep 2005 10:30:53 -0700

> > s3.1: para after ABNF: Numeric ranges?  This section talks about 
> > alphabetic ranges such as c..k.  Is this supposed to cover numeric 
> > ranges as well?
> [Addison Phillips]
> 
> Yes. It is an oversight (since there are no numeric ranges initially).

Proposed solution:

Change this:

--
<t>The sequence '..' (%x2E.2E) in a field-body denotes a range of values. Such a range represents all 
 subtags of the same length that are alphabetically within that range, 
 including the values explicitly mentioned. For example 'a..c' denotes the
 values 'a', 'b', and 'c'.</t>
--

To read:

--
<t>The sequence '..' (%x2E.2E) in a field-body denotes a range of values. Such a range represents all 
 subtags of the same length that are in in alphabetic or numeric order within that range, 
 including the values explicitly mentioned. For example 'a..c' denotes the
 values 'a', 'b', and 'c' and '11..13' denotes the values '11', '12', and '13'.</t>
--

Addison

Addison P. Phillips
Globalization Architect, Quest Software
http://www.quest.com

Chair, W3C Internationalization Core Working Group
http://www.w3.org/International

Internationalization is not a feature.
It is an architecture. 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Thu, 01 Sep 2005 22:24:07 +0200

Addison Phillips wrote:

 [...]
>      subtags of the same length that are in in alphabetic or 
> numeric order within that range, including the values
> explicitly mentioned.
                        [...]  ACK, good enough, bye, Frank