Subject: [Ltru] give ABNF for Prefix (gen-art #15)

From: "Addison Phillips" <[email-masked]>
Date: Thu, 1 Sep 2005 10:56:01 -0700

> >
> > s3.1: definition of 'Prefix': I think a more formal (ABNF) 
> > description of the possible values might help. Presumably an 
> > 'extlang' can have a primary language tag and up to 2 other extlangs 
> > and a 'variant' can have a complete language (including up to 3 
> > extlangs)and possibly a script and/or a region.
> [Addison Phillips]
> 
> Would that really add anything to the document? It would be easy to 
> do, yes, but I'm not sure that it is unclear as written.

Proposed Solution:

Although this would be easy enough to do, the ABNF would be somewhat complex and wouldn't add, IMHO, to the content of the document. A registration that proposed an illegal Prefix would be caught by the ietf-languages list (there are at least some humans subscribed to that list) and the meaning of the text is quite clear.

I propose we reject this comment.

Addison P. Phillips
Globalization Architect, Quest Software
http://www.quest.com

Chair, W3C Internationalization Core Working Group
http://www.w3.org/International

Internationalization is not a feature.
It is an architecture. 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Thu, 01 Sep 2005 22:30:47 +0200

> I propose we reject this comment.

Yes, if we'd follow this direction we'd end up with my idea to
specify a proper syntax for each field type, nobody liked this.

                        Bye, Frank

---

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 1 Sep 2005 14:04:46 -0700

Hi -

> From: "Frank Ellermann" <[email-masked]>
> To: <[email-masked]>
> Sent: Thursday, September 01, 2005 1:30 PM
> Subject: [Ltru] Re: give ABNF for Prefix (gen-art #15)
>

> specify a proper syntax for each field type, nobody liked this.
...

If an IESG member chooses to make this a "DISCUSS" comment, I'd like
to be armed with a more persuasive rationale.  At the very least, I'd like to
be able to say *why* "nobody liked this".  So far, Addison's rationale that
the value added by the ABNF would not be commensurate with the
additional complexity is better than "nobody liked this", but it still
doesn't seem terribly persuasive.

Could someone write up the ABNF needed to satisfy this specific comment,
(not necessarily the more generalized issues of providing ABNF for all) so
that we might better judge the extent to which it might obfuscate rather
than enlighten?

Randy

---

From: Frank Ellermann <[email-masked]>
Date: Thu, 01 Sep 2005 23:57:53 +0200

Randy Presuhn wrote:

> Could someone write up the ABNF needed to satisfy this
> specific comment, (not necessarily the more generalized
> issues of providing ABNF for all) so that we might better
> judge the extent to which it might obfuscate rather
> than enlighten?

See Addison's answer.  For the general "nobody liked this"
see below.  But that is really DEAD now.  I only mentioned
it because we already considered it, and it is apparently
in the direction of what Elwyn missed.

                         Bye, Frank

  registry    = file-date *( "%%" CRLF record )
  file-date   = "File-Date:" 1*SP date CRLF     ; first line
  record      = 1*( field CRLF )
  field       = type / tag / timestamp / reference / explanation
  type        = "Type:" 1*SP ( subtag-type / "grandfathered" )
  subtag-type = "language" / "extlang" / "script"
              / "region" / "variant"
  tag         = ( "Subtag:" / "Tag:" ) 1*SP value
  reference   = ( "Canonical:" / "Suppress-Script:"
                / "Recommended-Prefix:" ) 1*SP value
  explanation = ( "Description:" / "Comments:" ) 1*SP text
  timestamp   = ( "Added:" / "Deprecated:" ) 1*SP date
  date        = 4DIGIT "-" 2DIGIT "-" 2DIGIT    ; see RfC 3339
  value       = 1*( ALPHA / DIGIT / "-" )       ; note no WSP
  text        = *( ASC-char / LWSP )            ; note folding WSP
  ASC-char    = %x21-25 / %x27-7E / UNI-char    ; AMPERSAND is %x26
  UNI-char    = "&#x" 2*6HEXDIG ";"