Subject: RE: [Ltru] Re: matching comments: use of prefixes

From: "Addison Phillips" <[email-masked]>
Date: Thu, 29 Sep 2005 12:19:12 -0700

Okay, here's what I have now:

--
<t>In particular, the set of language tags that match a specific language-range might not all be mutually intelligible. Matching a language-range (prefix) to various language tags does not mean that it is always true that if a user understands a language identified by a certain tag, then this user will also understand all of the languages for which this tag is a prefix. The use of prefixes (and thus basic language ranges) allows languages to be selected as if this were always the case. In many cases, the language range and the set of language tags associated with it are mutually intelligible enough to be useful and this form of matching has historically been to most prevalent.
</t>

<t>Cases do exist in which care has to be applied to the selection of the language range. This is especially true when the language range encloses multiple, widely divergent dialects. For example, the language range "sgn" (for Sign Languages) describes a wide range of mutually unintelligible languages. Thus users SHOULD use as many subtags as necessary to describe something which they would understand.</t>

<t>Users SHOULD avoid subtags that add no distinguishing value to a language range. For example, script subtags SHOULD NOT be used to form a language range with language subtags which have a matching Suppress-Script field in their registry record. Thus the language range "en-Latn" is probably inappropriate for most applications (because the vast majority English documents are written in the Latin script and thus the 'en' language subtag has a Suppress-Script field for 'Latn' in the registry).
</t>
--

Comments?

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: Addison Phillips
> Sent: jeudi 29 septembre 2005 08:15
> To: 'Frank Ellermann'; [email-masked]
> Subject: RE: [Ltru] Re: matching comments: use of prefixes
> 
> +1
> 
> Addison P. Phillips
> Globalization Architect, Quest Software
> Chair, W3C Internationalization Core Working Group
> 
> Internationalization is not a feature.
> It is an architecture.
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] On Behalf Of
> > Frank Ellermann
> > Sent: jeudi 29 septembre 2005 07:58
> > To: [email-masked]
> > Subject: [Ltru] Re: matching comments: use of prefixes
> >
> > Harald Tveit Alvestrand wrote:
> >
> > > RFC 1766, and I still remember the debate that got us there.
> > > What it's trying to prevent is dialogues like this:
> >
> > > Registrant: I register (or use) sgn-GB and sgn-FR
> > > Searcher: I want something in "sgn".
> >
> > Now that's immediately clear.  Maybe adding this as example
> > to Addison's new wording could help.  It would explain that
> > matching was already tricky before 3066bis, so that's not a
> > new "bug" introduced by 3066bis, but just as it is.
> >
> >                         Bye, Frank
> >
> >
> >
> > _______________________________________________
> > Ltru mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Debbie Garside" <[email-masked]>
Date: Thu, 29 Sep 2005 20:56:46 +0100

In a nutshell:

"Implementers should note that the set of language tags that match a
specific language-range prefix MAY not be mutually intelligible; although
historically this form of matching has proved useful."

Debbie  

> Addison Phillips
> Sent: 29 September 2005 20:19
> To: Addison Phillips; Frank Ellermann; [email-masked]
> <t>In particular, the set of language tags that match a specific language-
> range might not all be mutually intelligible. Matching a language-range
> (prefix) to various language tags does not mean that it is always true
> that if a user understands a language identified by a certain tag, then
> this user will also understand all of the languages for which this tag is
> a prefix. The use of prefixes (and thus basic language ranges) allows
> languages to be selected as if this were always the case. In many cases,
> the language range and the set of language tags associated with it are
> mutually intelligible enough to be useful and this form of matching has
> historically been to most prevalent.
> </t>
> 
> <t>Cases do exist in which care has to be applied to the selection of the
> language range. This is especially true when the language range encloses
> multiple, widely divergent dialects. For example, the language range "sgn"
> (for Sign Languages) describes a wide range of mutually unintelligible
> languages. Thus users SHOULD use as many subtags as necessary to describe
> something which they would understand.</t>
> 
> <t>Users SHOULD avoid subtags that add no distinguishing value to a
> language range. For example, script subtags SHOULD NOT be used to form a
> language range with language subtags which have a matching Suppress-Script
> field in their registry record. Thus the language range "en-Latn" is
> probably inappropriate for most applications (because the vast majority
> English documents are written in the Latin script and thus the 'en'
> language subtag has a Suppress-Script field for 'Latn' in the registry).
> </t>
> --
> 
> Comments?
> 
> Addison
> 
> Addison P. Phillips

---

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 29 Sep 2005 14:00:44 -0700

Hi -

> From: "Debbie Garside" <[email-masked]>
> To: "'Addison Phillips'" <[email-masked]>; "'Frank Ellermann'" <[email-masked]>; <[email-masked]>
> Sent: Thursday, September 29, 2005 12:56 PM
...
> historically this form of matching has proved useful."
...

s/MAY/may/  -- this is clearly not intended with normative force

To avoid confusion, we might say "might correspond to
mutually unintelligible languages"

s/proved/proven/   --  if the editors prefer.

Randy