Subject: RE: [Ltru] Re: give ABNF for Prefix (gen-art #15)

From: "Addison Phillips" <[email-masked]>
Date: Thu, 1 Sep 2005 16:22:40 -0700

Mark,

This is a new piece of ABNF for the prefix field in the registry ONLY. There is no suggestion that we'll be modifying the ABNF for language tags themselves. 

I'm foursquare against inserting ABNF for Prefix. 

The other change I wouldn't want to insert at this late date unless we're modifying the ABNF for some other purpose.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: Mark Davis [mailto:[email-masked]]
> Sent: 2005年9月1日 15:46
> To: Addison Phillips
> Cc: Randy Presuhn; [email-masked]
> Subject: Re: [Ltru] Re: give ABNF for Prefix (gen-art #15)
> 
> If we are updating the ABNF anyway, then I would suggest that we make
> the following additions, to allow for possible future use of subtags
> that are currently invalid.
> 
> Mark
> 
> Addison Phillips wrote:
> >>Could someone write up the ABNF needed to satisfy this specific comment,
> >>(not necessarily the more generalized issues of providing ABNF for all)
> so
> >>that we might better judge the extent to which it might obfuscate rather
> >>than enlighten?
> >
> >
> > Sure. Here it is:
> >
> > ---
> >
> > Prefix       = Variant-prefix / Extlang-prefix
> >
> > Extlang-prefix = language *2("-" 3ALPHA)
> >
> > Variant-prefix = (language
> >                   ["-" script]
> >                   ["-" region]
> >                   *("-" variant))
> >
> > language      = (2*3ALPHA [ extlang ]) ; shortest ISO 639 code
> >               / 4ALPHA                 ; reserved for future use
> >               / 5*8ALPHA               ; registered language subtag
> >
> > extlang       = *3("-" 3ALPHA)         ; reserved for future use
> >
> > script        = 4ALPHA                 ; ISO 15924 code
>                  / ALPHA 3alphanum        ; reserved for future use
> >
> > region        = 2ALPHA                 ; ISO 3166 code
> >               / 3DIGIT                 ; UN M.49 code
>                  / 2alphanum              ; reserved for future use
>                  / DIGIT 2alphanum        ; reserved for future use
> >
> > variant       = 5*8alphanum            ; registered variants
> >               / (DIGIT 3alphanum)      ;
> >
> >
> > alphanum      = (ALPHA / DIGIT)       ; letters and numbers
> >
> > ---
> >
> > Addison P. Phillips
> > Globalization Architect, Quest Software
> > Chair, W3C Internationalization Core Working Group
> >
> > Internationalization is not a feature.
> > It is an architecture.
> >
> >
> >>-----Original Message-----
> >>From: [email-masked] [mailto:[email-masked]] On Behalf Of
> >>Randy Presuhn
> >>Sent: 2005?9?1? 14:05
> >>To: [email-masked]
> >>Subject: Re: [Ltru] Re: give ABNF for Prefix (gen-art #15)
> >>
> >>Hi -
> >>
> >>
> >>>From: "Frank Ellermann" <[email-masked]>
> >>>To: <[email-masked]>
> >>>Sent: Thursday, September 01, 2005 1:30 PM
> >>>Subject: [Ltru] Re: give ABNF for Prefix (gen-art #15)
> >>>
> >>
> >>>Addison Phillips wrote:
> >>>
> >>>
> >>>>I propose we reject this comment.
> >>>
> >>>Yes, if we'd follow this direction we'd end up with my idea to
> >>>specify a proper syntax for each field type, nobody liked this.
> >>
> >>...
> >>
> >>If an IESG member chooses to make this a "DISCUSS" comment, I'd like
> >>to be armed with a more persuasive rationale.  At the very least, I'd
> like
> >>to
> >>be able to say *why* "nobody liked this".  So far, Addison's rationale
> >>that
> >>the value added by the ABNF would not be commensurate with the
> >>additional complexity is better than "nobody liked this", but it still
> >>doesn't seem terribly persuasive.
> >>
> >>Could someone write up the ABNF needed to satisfy this specific comment,
> >>(not necessarily the more generalized issues of providing ABNF for all)
> so
> >>that we might better judge the extent to which it might obfuscate rather
> >>than enlighten?
> >>
> >>Randy
> >>
> >>
> >>
> >>
> >>_______________________________________________
> >>Ltru mailing list
> >>[email-masked]
> >>https://www1.ietf.org/mailman/listinfo/ltru
> >
> >
> >
> > _______________________________________________
> > Ltru mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ltru
> >
> >
> >

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Mark Davis <[email-masked]>
Date: Thu, 01 Sep 2005 17:02:33 -0700

> The other change I wouldn't want to insert at this late date unless 
we're modifying the ABNF for some other purpose.

I firmly agree; at this late date we shouldn't change anything material 
in the document unless we have to make material changes anyway. My only 
thought is that if we *do* have to make a material change, then it would 
good to add this at the same time.

Mark