Subject: RE: [Ltru] Re: At least one prefix for variant (GenArt) #18

From: "Addison Phillips" <[email-masked]>
Date: Fri, 2 Sep 2005 14:22:08 -0700

So we're saying: leave all other text alone and change this item in Section 3.5:

--
Variant subtags are always registered for use with a particular range of language tags. For example, the subtag 'rozaj' is intended for use with language tags that start with the primary language subtag "sl", since Resian is a dialect of Slovenian. Thus the subtag 'rozaj' could be included in tags such as "sl-Latn-rozaj" or "sl-IT-rozaj". This information is stored in the "Prefix" field in the registry. Variant registration requests are REQUIRED to include at least one "Prefix" field in the registration form.
--

To read like this (changes in /* */):

--
Variant subtags are /*usually*/ registered for use with a particular range of language tags. For example, the subtag 'rozaj' is intended for use with language tags that start with the primary language subtag "sl", since Resian is a dialect of Slovenian. Thus the subtag 'rozaj' /* would be appropriate */ in tags such as "sl-Latn-rozaj" or "sl-IT-rozaj". This information is stored in the "Prefix" field in the registry. Variant registration requests /* SHOULD */ include at least one "Prefix" field in the registration form.
--

Note that the use of the normative SHOULD indicates a strong caveat is in place, but it isn't a MUST and thus not an absolute prohibition.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> John.Cowan
> Sent: 2005?9?2? 14:04
> To: Frank Ellermann
> Cc: [email-masked]
> Subject: Re: [Ltru] Re: At least one prefix for variant (GenArt) #18
> 
> Frank Ellermann scripsit:
> 
> > Let's assume that John likes the concept, and I think that
> > it could be more harmful than useful.  What's your idea,
> > allow it with an explicit CAVEAT for the review list ?
> 
> That would be my idea too.
> 
> > I'd really hate it if we get crappy generic variants like
> > the infamous "presence locations" (bathroom, yacht, in bed,
> > in bed alone, airport, airport toilet, etc.)
> 
> So would I, but ietf-languages folk are sensible and cautious.
> (Except me.)
> 
> --
> John Cowan  www.ccil.org/~cowan  www.reutershealth.com
> [email-masked]
> [T]here is a Darwinian explanation for the refusal to accept Darwin.
> Given the very pessimistic conclusions about moral purpose to which his
> theory drives us, and given the importance of a sense of moral purpose
> in helping us cope with life, a refusal to believe Darwin's theory may
> have important survival value. --Ian Johnston
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "John.Cowan" <[email-masked]>
Date: Fri, 2 Sep 2005 17:55:46 -0400

Addison Phillips scripsit:

> Variant subtags are /*usually*/ registered for use with a particular
> range of language tags. For example, the subtag 'rozaj' is intended
> for use with language tags that start with the primary language
> subtag "sl", since Resian is a dialect of Slovenian. Thus the subtag
> 'rozaj' /* would be appropriate */ in tags such as "sl-Latn-rozaj" or
> "sl-IT-rozaj". This information is stored in the "Prefix" field in
> the registry. Variant registration requests /* SHOULD */ include at
> least one "Prefix" field in the registration form.

+1

-- 
But that, he realized, was a foolish            John Cowan
thought; as no one knew better than he          [email-masked]
that the Wall had no other side.                http://www.ccil.org/~cowan
        --Arthur C. Clarke, "The Wall of Darkness"

---

From: Frank Ellermann <[email-masked]>
Date: Sat, 03 Sep 2005 00:20:55 +0200

Make that +2 ;-)

---

From: Mark Davis <[email-masked]>
Date: Fri, 02 Sep 2005 15:44:18 -0700

+1