Subject: RE: [Ltru] Re: matching comments: use of prefixes

From: "Addison Phillips" <[email-masked]>
Date: Thu, 29 Sep 2005 07:58:54 -0700

> New wording: yes, better, I'm not sure that it's related to the
> old paragraph, but it's clear:  "prefix-matching often worked
> with 3066 tags, but it might be not good enough for 3066bis" -
> if I got your drift.

More like "prefix matching generally works pretty well; it is the most common matching in place as of Date B and generally produces the right results". The health warning above this text (and the impenetrable sentence it replaces) is actually derived direction from HTTP 1.1, RFC 3066, and other references to language negotiation in various RFCs (3282, for example). I think it is well to consider the problem of prefixes that are "mutually unintelligible", but generally it doesn't affect folks too badly.

We should also consider a general warning such as:

--
Users SHOULD also avoid subtags that add no distinguishing value to a language range. For example, script subtags SHOULD NOT be used to form a language range with language subtags which have a matching Suppress-Script field in their registry record. Thus the language range "en-Latn" is probably inappropriate for most applications (because the vast majority English documents are written in the Latin script and thus the 'en' language subtag has a Suppress-Script field for 'Latn' in the registry).
--

This would make the matching draft consonant with the registry document.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Mark Davis <[email-masked]>
Date: Thu, 29 Sep 2005 09:17:53 -0700

+1