Subject: RE: [Ltru] Re: Last call comments on LTRU registry and initializationdocuments

From: "Addison Phillips" <[email-masked]>
Date: Fri, 9 Sep 2005 09:17:02 -0700

Actually, I believe he suggested that IANA get the material from the draft and then the RFC Editor remove the "beef" (the registry copy) and insert the text he proposed. Not you: the RFC Editor, *after* IANA has got the registry.

This thread strikes me as irrelevant. We have a prototype registry, which is a necessary deliverable. What the RFC Editor does later is not our problem: we'll be looking at the IANA registry by then.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Doug Ewell
> Sent: Friday, September 09, 2005 8:07 AM
> To: John C Klensin; Sam Hartman
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: [Ltru] Re: Last call comments on LTRU registry and
> initializationdocuments
> 
> John C Klensin <john dash ietf at jck dot com> wrote:
> 
> > The success or failure of the "foo" registry is
> > not evaluated on how many foos we can put in to it, or its
> > comprehensiveness relative to some external foo-list, but on
> > whether it does the job that the foo-protocol (and maybe foo1,
> > foo2, etc.), requires.  Normally, we don't even write a "create
> > the baz registry" document.  Instead, we write a "baz protocol
> > specification" document and include a more or less long section
> > that instructs IANA to create the registry, what to put in it,
> > and how.
> 
> So, do you propose that we withdraw the specification of the initial
> registry contents, all 963 tags and subtags, and replace it with a set
> of instructions to IAN on how they can duplicate our work?  And cross
> our fingers that they get it right, or prepare to go through
> item-languages for any correctible errors or omissions they may
> introduce, and live with the uncorrectable errors?  Just wondering.
> 
> --
> Doug Ewell
> Fullerton, California
> http://users.adelphia.net/~dewell/
> 
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Fri, 09 Sep 2005 23:01:56 +0200

Addison Phillips wrote:

> This thread strikes me as irrelevant.

Minimally it's one working model for 3066ter.

> What the RFC Editor does later is not our problem

I'm not sure about that.  If we adopt John's proposal
chapter 3 in "initial" could be moved to an appendix A,
with a note to replace it before publication (= after
the creation of the registry) by "X", where "X" is
essentially the URL of the registry.

> we'll be looking at the IANA registry by then.

In theory.  In practice what I have on my box as path
I:\DOKU\RFC\*.txt is a CD ROM with RfCs and similar
texts up to RfC 3195.

With John's proposal we'd be sure that the initial
registry doesn't make it into any "RfC collections"
reflecting a then obsolete state of the real thing.

IMO John's procedural idea is better.  Bye, Frank