Subject: [Ltru] case of the subtag in a registration (gen-art #16)

From: "Addison Phillips" <[email-masked]>
Date: Thu, 1 Sep 2005 11:24:54 -0700

> > s3.2: last para:  the requirement to get the case pattern of a 
> > certain subset of tags right seems an unecessary hurdle - the 
> > registry can enforce this if it seems really desirable.
> [Addison Phillips]
> 
> That requirement could be relaxed to SHOULD.

Proposed Solution:

Change this sentence:

--
Values in the 'Subtag' field MUST be lowercase except as provided for in Section 3.1 (Format of the IANA Language Subtag Registry).
--

To read:

--
<t>Before forwarding a new registration to IANA, the Language Subtag Reviewer MUST ensure that values in the 'Subtag' field match case according to the description in <xref target="ianaformat"></xref>.</t>
--

Addison P. Phillips
Globalization Architect, Quest Software
http://www.quest.com

Chair, W3C Internationalization Core Working Group
http://www.w3.org/International

Internationalization is not a feature.
It is an architecture. 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Thu, 01 Sep 2005 22:49:26 +0200

Addison Phillips wrote:

> <t>Before forwarding a new registration to IANA, the Language
> Subtag Reviewer MUST ensure that values in the 'Subtag' field
> match case according to the description in <xref
> target="ianaformat"></xref>.</t>

Nice.  I also agree with anything else (modulo STRONGLY ;-) you
said, but for John's "generic variants" I'm not convinced that
it's a good idea.  And IIRC all others on the review list were
sure that it's wrong. 
                       Bye, Frank