Subject: RE: [Ltru] Last call comments on LTRU registry andinitialization documents

From: "Peter Constable" <[email-masked]>
Date: Fri, 9 Sep 2005 15:47:08 -0700

> From: [email-masked] [mailto:[email-masked]] On Behalf Of John C
> Klensin

> 	Aside on the example above (LTRU participants can skip
> 	unless they want to check my logic): "en-Hang" and
> 	"en-Hant" would imply writing English in Korean Hangul
> 	or Traditional Chinese characters respectively.  In
> 	addition to those not exactly being common cases, it is
> 	not clear that they are feasible...

> 	Hangul is problematic in a different way.
> 	Unlike Chinese characters, it is definitely phonetic.
> 	But because it is rather carefully designed and
> 	structured around the needs of Korean, it is not clear
> 	to me, in my ignorance, that it could be used to
> 	represent the full range of English phonemes and
> 	syllables with reasonable accuracy.

Actually, that's not quite true. There are Korean linguists who have promoted the idea that Hangul script can be adapted for use for general phonemic transcription of languages. Thus, it is plausible that a user might have English data written with Hangul script.

This really is no different from the da-CO kinds of examples: they are not particularly useful because there is no actual variant of the given language associated with the given country, but only coincidentally, and in principle the state of affairs in human demographics could well change such as such a variant does actually exist. Just as there is no limit to what region a given language can be spoken by a significant population (given sufficient mobility), in principle there is no limit to what script can be used to write a given language (given sufficient ingenuity). 

The *only* difference for these cases in RFC 3066 is that generative use without requiring registration is sanctioned for country IDs ‎but not for script IDs. And that is not so by explicit design; is resulted simply because we weren't yet sure how script IDs should be integrated into the tags and the fact that ISO 15924 wasn't yet published.

Peter Constable

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Addison Phillips" <[email-masked]>
Date: Fri, 9 Sep 2005 21:02:37 -0700

JFC,

You asked why the registry didn't include the alpha3 values: my mistake, as I obviously assumed you meant that the alpha3 values should be included as actual data. You didn't mention them as descriptive information. The draft includes a mechanism for any individual to register descriptive information or comments. Personally, I don't think the information necessary, since ISO 639-2 MA/RA maintains a perfectly good reference for that.

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture.

---

From: "John.Cowan" <[email-masked]>
Date: Tue, 13 Sep 2005 11:43:16 -0400

Peter Constable scripsit:

> This really is no different from the da-CO kinds of examples: they are
> not particularly useful because there is no actual variant of the given
> language associated with the given country, but only coincidentally,
> and in principle the state of affairs in human demographics could well
> change such as such a variant does actually exist.

Just so.  Who knows?  Someday the Dine may walk in beauty in the apple
fields of Fyn or beneath the modern buildings of Copenhagen.  Stranger things
have happened.

-- 
It was impossible to inveigle           John Cowan <[email-masked]>
Georg Wilhelm Friedrich Hegel           http://www.ccil.org/~cowan
Into offering the slightest apology     http://www.reutershealth.com
For his Phenomenology.                      --W. H. Auden, from "People" (1953)