Subject: RE: [Ltru] Re: give ABNF for Prefix (gen-art #15)

From: "Addison Phillips" <[email-masked]>
Date: Thu, 1 Sep 2005 14:44:50 -0700

Okay, I forgot to include my rationale for not doing this, now that I've finally had to write the expletive thing.

I don't believe that this greatly adds to the description, which is:

--
Prefix's field-value contains a language tag with which this subtag MAY be used to form a new language tag, perhaps with other subtags as well. This field MUST only appear in records whose 'Type' field-value is 'variant' or 'extlang'. For example, the 'Prefix' for the variant 'nedis' is 'sl', meaning that the tags "sl-nedis" and "sl-IT-nedis" might be appropriate while the tag "is-nedis" is not.
--

<aside>

Then we go on elsewhere in the same section to say rather repetitiously:

--
The field-value of the 'Prefix' field consists of a language tag whose subtags are appropriate to use with this subtag. For example, the variant subtag '1996' has a Prefix field of "de". This means that tags starting with the sequence "de-" are appropriate with this subtag, so "de-Latg-1996" and "de-CH-1996" are both acceptable, while the tag "fr-1996" is an inappropriate choice.
--

Perhaps we should drop the second instance?

</aside>

The name "Prefix" itself conveys the point pretty well, and this text and the accompanying example I think goes much farther than the ABNF in making it clear what the Prefix is for.

In fact, the ABNF has the opposite effect. People will look at it instead of the text and perhaps get the wrong impression that ONLY the subtags in the prefix may be used with the variant.

I'll admit that the first sentence is syntax-challenged. We could try clarifying it. Perhaps:

--
The field-value of each Prefix field contains a language tag. This tag represents a set of subtags that is RECOMMENDED for use (in combination with other subtags as well) with this record's subtag when forming a language tag. This field MUST only appear in records whose 'Type' field-value is 'variant' or 'extlang'. For example, the 'Prefix' for the variant 'nedis' is "sl", meaning that the tags "sl-nedis" and "sl-IT-nedis" might be appropriate choices while the tag "is-nedis" is not.
--

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Addison Phillips
> Sent: 2005?9?1? 14:22
> To: Randy Presuhn; [email-masked]
> Subject: RE: [Ltru] Re: give ABNF for Prefix (gen-art #15)
> 
> > Could someone write up the ABNF needed to satisfy this specific comment,
> > (not necessarily the more generalized issues of providing ABNF for all)
> so
> > that we might better judge the extent to which it might obfuscate rather
> > than enlighten?
> 
> Sure. Here it is:
> 
> ---
> 
> Prefix       = Variant-prefix / Extlang-prefix
> 
> Extlang-prefix = language *2("-" 3ALPHA)
> 
> Variant-prefix = (language
>                   ["-" script]
>                   ["-" region]
>                   *("-" variant))
> 
> language      = (2*3ALPHA [ extlang ]) ; shortest ISO 639 code
>               / 4ALPHA                 ; reserved for future use
>               / 5*8ALPHA               ; registered language subtag
> 
> extlang       = *3("-" 3ALPHA)         ; reserved for future use
> 
> script        = 4ALPHA                 ; ISO 15924 code
> 
> region        = 2ALPHA                 ; ISO 3166 code
>               / 3DIGIT                 ; UN M.49 code
> 
> variant       = 5*8alphanum            ; registered variants
>               / (DIGIT 3alphanum)      ;
> 
> 
> alphanum      = (ALPHA / DIGIT)       ; letters and numbers
> 
> ---
> 
> Addison P. Phillips
> Globalization Architect, Quest Software
> Chair, W3C Internationalization Core Working Group
> 
> Internationalization is not a feature.
> It is an architecture.
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] On Behalf Of
> > Randy Presuhn
> > Sent: 2005?9?1? 14:05
> > To: [email-masked]
> > Subject: Re: [Ltru] Re: give ABNF for Prefix (gen-art #15)
> >
> > Hi -
> >
> > > From: "Frank Ellermann" <[email-masked]>
> > > To: <[email-masked]>
> > > Sent: Thursday, September 01, 2005 1:30 PM
> > > Subject: [Ltru] Re: give ABNF for Prefix (gen-art #15)
> > >
> >
> > > Addison Phillips wrote:
> > >
> > > > I propose we reject this comment.
> > >
> > > Yes, if we'd follow this direction we'd end up with my idea to
> > > specify a proper syntax for each field type, nobody liked this.
> > ...
> >
> > If an IESG member chooses to make this a "DISCUSS" comment, I'd like
> > to be armed with a more persuasive rationale.  At the very least, I'd
> like
> > to
> > be able to say *why* "nobody liked this".  So far, Addison's rationale
> > that
> > the value added by the ABNF would not be commensurate with the
> > additional complexity is better than "nobody liked this", but it still
> > doesn't seem terribly persuasive.
> >
> > Could someone write up the ABNF needed to satisfy this specific comment,
> > (not necessarily the more generalized issues of providing ABNF for all)
> so
> > that we might better judge the extent to which it might obfuscate rather
> > than enlighten?
> >
> > Randy
> >
> >
> >
> >
> > _______________________________________________
> > Ltru mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/ltru
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Peter Constable" <[email-masked]>
Date: Fri, 2 Sep 2005 08:19:53 -0700

> Okay, I forgot to include my rationale for not doing this, now that
I've
> finally had to write the expletive thing.
> 
> I don't believe that this greatly adds to the description

I agree. It would mostly makes a long doc longer. The intent of the
Prefix field is, IMO, already explained sufficiently clearly.

Peter Constable

---

From: "Addison Phillips" <[email-masked]>
Date: Fri, 2 Sep 2005 08:43:07 -0700

> It seems to me that this sentence conflates two issues:
> 1. Whether a tag is correctly formed or not (not just syntactically).
> 2. Whether a tag is appropriate for some particular data.
>
> Concentrating on the first issue, maybe the sentence should read
> (less confusingly):

Actually, no. The meaning of the Prefix field is actually (2). That is, the tag "zh-nedis" is "valid" and "well-formed", but is a poor choice. That is, Prefix is non-normative for variants.

Addison

Addison P. Phillips

> Kent Karlsson
> Sent: 2005?9?2? 8:07
> > For example, the 'Prefix' for the variant 'nedis' is "sl", meaning that
> > the tags "sl-nedis" and "sl-IT-nedis" might be appropriate choices while
> > the tag "is-nedis" is not.
> > --
> 
> It seems to me that this sentence conflates two issues:
> 1. Whether a tag is correctly formed or not (not just syntactically).
> 2. Whether a tag is appropriate for some particular data.
> 
> Concentrating on the first issue, maybe the sentence should read
> (less confusingly):
> ---
> For example, the 'Prefix' for the variant 'nedis' is "sl", meaning that
> the tags "sl-nedis" and "sl-IT-nedis" are correctly formed tags while
> the tag "is-nedis" is not.
> ---
> 
>    /Kent K
> 
>

---

From: "Addison Phillips" <[email-masked]>
Date: Fri, 2 Sep 2005 08:54:17 -0700

> 
> This would make this a syntactic constraint. I'm not sure that's what's
> intended.
[Addison Phillips] 

I'm quite sure that this was not intended.
> 
> Note that for extlang, the draft states that the specified prefix MUST
> be used. Thus, if "cmn" has a specified prefix "zh", then "fr-cmn" is
> not correctly formed. In contrast, the draft states that the specified
> prefixes for a variant are those that would be suitable. It does not
> suggest that "is-nedis" is ill-formed; it just suggests that it's not
> semantically a good choice (similar to th-MX not being a good choice).
[Addison Phillips] 

Exactly so. This is an example of being parsimonious in what you generate and promiscuous in what you accept. Making the prefix normative would place an unnecessary burden on the accepting processor.
> 
> So, this boils down to whether we want prefixes for variants to be
> constraints on syntactic well-formedness, or rather to be
> recommendations on appropriate semantic collocation. I vaguely recall
> that we discussed this and chose the latter.
> 
Yep. See for example roughly here:

http://article.gmane.org/gmane.ietf.ltru/2082/match=variant+prefix+required

Addison

---

From: "Peter Constable" <[email-masked]>
Date: Fri, 2 Sep 2005 20:11:31 -0700

> From: Mark Davis [mailto:[email-masked]]

> Let me try to be clearer. If we are making no material changes to the
> document, only editorial fixes, then I don't suggest any changes. If
we
> do make any material changes, then I would like to see the addition I
> suggested, to allow for future extensions.

But AFAIK you didn't make a specific suggested. You responded to
Addison's message saying "make the following additions", where the only
following additions were the ABNF Addison drafted for Prefix -- which do
not materially change any possible future extensions.

Unless I've missed something, you still haven't been clear enough about
what you propose for anyone to comment on.

Peter Constable