Subject: [Ltru] ungarble description of Preferred-Value (gen-art #16)

From: "Addison Phillips" <[email-masked]>
Date: Thu, 1 Sep 2005 11:22:32 -0700

> > s3.1: discussion of 'Preferred-Value':  '...SHOULD be preferred when 
> > selected language tags.'  appears to be garbled... I am not sure 
> > exactly what is intended.
> [Addison Phillips]
> 
> The value in the record that contains a 'Preferred-Value' field should 
> be replaced with the value in the Preferred-Value. That is, 
> Preferred-Value is how a subtag is deprecated in favor of a different 
> subtag. The cases where this applies are then enumerated. Some textual 
> tweaking to make this clearer is probably called for.

Proposed Solution:

Replace the following sentence:

--
The field 'Preferred-Value' contains a mapping between the record in which it appears and a tag or subtag which SHOULD be preferred when selected language tags. 
--

With these sentences:

--
The field 'Preferred-Value' contains a mapping between the record in which it appears and another tag or subtag. The value in this field is STRONGLY RECOMMENDED as the best choice to represent the value of this record when selecting a language tag.
--

Addison

Addison P. Phillips
Globalization Architect, Quest Software
http://www.quest.com

Chair, W3C Internationalization Core Working Group
http://www.w3.org/International

Internationalization is not a feature.
It is an architecture. 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Scott Hollenbeck" <[email-masked]>
Date: Thu, 1 Sep 2005 14:31:00 -0400

> -----Original Message-----
> From: Addison Phillips [mailto:[email-masked]] 
> Sent: Thursday, September 01, 2005 2:23 PM
> To: LTRU Working Group
> Cc: Elwyn Davies
> Subject: [Ltru] ungarble description of Preferred-Value (gen-art #16)
> 
> The field 'Preferred-Value' contains a mapping between the 
> record in which it appears and a tag or subtag which SHOULD 
> be preferred when selected language tags. 
> --
> 
> With these sentences:
> 
> --
> The field 'Preferred-Value' contains a mapping between the 
> record in which it appears and another tag or subtag. The 
> value in this field is STRONGLY RECOMMENDED as the best 
> choice to represent the value of this record when selecting a 
> language tag.

While I understand the desire to emphasize "strongly" as "STRONGLY",
"STRONGLY" isn't an RFC 2119 key word.  It's not a good idea to make it look
like one.  "strongly" would be better.

-Scott-