Subject: [Ltru] Comments that refer to "ISO codes"

From: "Doug Ewell" <[email-masked]>
Date: Sun, 10 Sep 2006 22:09:52 -0700

For certain grandfathered tags that have been deprecated in favor of ISO 
639-based tags, we attached a Comments field that indicates the 
ISO-based nature of the Preferred-Value.  (Seems repetitive to me, but 
that's another story.)  Here's an example:

> Type: grandfathered
> Tag: art-lojban
> Description: Lojban
> Added: 2001-11-11
> Preferred-Value: jbo
> Deprecated: 2003-09-02
> Comments: replaced by ISO code jbo

I propose modifying these comments slightly to indicate *which* ISO 
standard begat the replacement tag, like this:

> Comments: replaced by ISO 639-2 code jbo

For consistency, we would then also add this sort of comment to existing 
grandfathered tags that become deprecated by one of the new 639-3-based 
subtags:

> Type: grandfathered
> Tag: zh-xiang
> Description: Xiang or Hunanese
> Added: 1999-12-18
> Preferred-Value: zh-hsn
> Deprecated: xxxx-xx-xx
> Comments: replaced by ISO 639-3 code hsn

Any comments?  So to speak?

--
Doug Ewell
Fullerton, California, USA
http://users.adelphia.net/~dewell/
RFC 4645  *  UTN #14

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Mon, 11 Sep 2006 07:34:22 -0400

> standard begat the replacement tag, like this:

I don't understand why you think this matters; can you explain?  If we
deprecate something in favor of an individual-language or macrolanguage
code element, it'll be in -3, whether or not it's in -2.  I can't imagine
deprecating something in favor of a language-collection code element.

-- 
Even the best of friends cannot                 John Cowan
attend each others' funeral.                    [email-masked]
        --Kehlog Albran, The Profit             http://www.ccil.org/~cowan

---

From: "Doug Ewell" <[email-masked]>
Date: Mon, 11 Sep 2006 07:38:00 -0700

John Cowan <cowan at ccil dot org> wrote:

> deprecate something in favor of an individual-language or 
> macrolanguage code element, it'll be in -3, whether or not it's in -2. 
> I can't imagine deprecating something in favor of a 
> language-collection code element.

"ISO code xx" just seems hopelessly vague to me.  I'm perfectly willing 
to back down on this.

I'd really rather do away with the self-evident comments anyway, but I 
understand other list member like to err on the side of more comments 
rather than fewer, and in any case this is much less repetitive and 
awful than the "hy-western" comments we considered earlier.

---

From: Martin Duerst <[email-masked]>
Date: Mon, 11 Sep 2006 18:56:48 +0900

Do codes sometimes move from 639-3 to 639-2? In that case, it would
mean we have to update the comment, which looks like unnecessary
work to me.

Regards,     Martin.

At 14:09 06/09/11, Doug Ewell wrote:
>For certain grandfathered tags that have been deprecated in favor of ISO 639-based tags, we attached a Comments field that indicates the ISO-based nature of the Preferred-Value.  (Seems repetitive to me, but that's another story.)  Here's an example:
>
>> Type: grandfathered
>> Tag: art-lojban
>> Description: Lojban
>> Added: 2001-11-11
>> Preferred-Value: jbo
>> Deprecated: 2003-09-02
>I propose modifying these comments slightly to indicate *which* ISO standard begat the replacement tag, like this:
>
>For consistency, we would then also add this sort of comment to existing grandfathered tags that become deprecated by one of the new 639-3-based subtags:
>
>> Type: grandfathered
>> Tag: zh-xiang

#-#-#  Martin J. Du"rst, Assoc. Professor, Aoyama Gakuin University
#-#-#  http://www.sw.it.aoyama.ac.jp       mailto:[email-masked]

---

From: John Cowan <[email-masked]>
Date: Mon, 11 Sep 2006 12:43:51 -0400

> mean we have to update the comment, which looks like unnecessary

Codes will be sometimes *copied* from 639-3 to 639-2, but no *moves*
will take place.  639-2 will become a selection of the most widely useful
code elements from 639-3 and the future 639-5 (language collections)

Nevertheless I agree that adding this information as a comment isn't very
useful.

-- 
There is / One art                      John Cowan <[email-masked]>
No more / No less                       http://www.ccil.org/~cowan
To do / All things
With art- / Lessness                     -- Piet Hein