Subject: [Ltru] Re: Updated article: Two-letter or three-letter language codes

From: Frank Ellermann <[email-masked]>
Date: Sat, 23 Sep 2006 03:47:20 +0200

Martin Duerst wrote on w3c.internationalization:

> The rule "if there is a two-letter code and a three-letter
> code, always use the two-letter code" is still very valid,
> and will continue to be valid. The IANA registry is just an
> additional way to find your language (sub)tag.

Is that so for 4646bis ?  I'm a bit lost with say oc, occ,
and oc-prv (oc is on my "missing Suppress-Script" list).

> This is basically not a change of language (sub)tags, but
> just a change in how they are made available (one stop
> shopping at IANA instead of having to check different lists).

Plus the "stable forever" feature no matter what ISO does.

Frank
--
>> http://www.w3.org/International/questions/qa-lang-2or3

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Sat, 23 Sep 2006 03:07:28 -0400

Frank Ellermann scripsit:

> Is that so for 4646bis ?

Definitely.

> I'm a bit lost with say oc, occ, and oc-prv (oc is on my "missing
> Suppress-Script" list).

'oc' is the code element for Occitan, a macrolanguage encompassing
five languages, namely Auvergnat, Gascon, Limousin, Languedocien,
and Provencal.  (The name "Provencal" is also sometimes applied to the
macrolanguage as a whole, one of the confusions to which macrolanguages
are often subject.)  It is entirely valid as a language tag in cases
when it is not necessary or desirable to be more exact.

'occ' is Occidental, an unrelated language.  'oci' is the 639-2 and
639-3 code element for Occitan, not used in IETF language tagging now or
in future.  "oc-prv" will be the 4646bis tag for the specific Provencal
language, in cases where it is important to distinguish it from Occitan
as a whole.

> Plus the "stable forever" feature no matter what ISO does.

Stable forever in the sense: once a valid subtag, always a valid subtag.
Subtags may become deprecated and replaced by other subtags; specifically,
region subtags may be deprecated as countries change their names and
ISO 3166/MA changes tags as a result.

-- 
Even the best of friends cannot                 John Cowan
attend each others' funeral.                    [email-masked]
        --Kehlog Albran, The Profit             http://www.ccil.org/~cowan