Subject: RE: [Ltru] Re: Fw: RFC 4645 on Initial Language Subtag Registry

From: "McDonald, Ira" <[email-masked]>
Date: Mon, 11 Sep 2006 09:14:38 -0700

Hi,

My two cents - any 800-page I-D is BAD - publishing
one is tantamount to saying "don't bother to pay any
attention to the output of this WG".

Squashing the registry format (which may change again
in the RFC464xbis era, perhaps?) into an I-D is an
exercise that diverts attention from the content of
the prototype registry and issues with that content.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

> -----Original Message-----
> From: Doug Ewell [mailto:[email-masked]]
> Sent: Sunday, September 10, 2006 10:59 PM
> To: LTRU Working Group
> Subject: [Ltru] Re: Fw: RFC 4645 on Initial Language Subtag Registry
> 
> 
> Randy Presuhn <randy underscore presuhn at mindspring dot com> wrote:
> 
> > Based on how the last round went, I think the WG's decision 
> to use an 
> > internet draft was correct.
> >
> > I think the WG's decision to publish to send that material 
> through the 
> > RFC publication process was also good, inasmuch as it did elicit 
> > useful comments, and gave us the requisite paper trail to deal with 
> > real or imagined procedural problems.
> 
> Fair enough, then.  But I don't want to hear any complaints 
> from others 
> that an 800-plus-page I-D is too long or unwieldy, or that 
> writing one 
> is an exercise in egotism or self-aggrandizement (I don't 
> remember who 
> said that last time).
> 
> > I think the final decision to elide the interesting parts 
> was perhaps 
> > unfortunate, but also understandable, given the onslaught 
> the IETF has 
> > been suffering.
> 
> Actually I thought that had been the plan for many months.  
> We knew the 
> real Registry would see many updates and didn't want people 
> to use the 
> initial-registry snapshot as a substitute.
> 
> --
> Doug Ewell
> Fullerton, California, USA
> http://users.adelphia.net/~dewell/
> RFC 4645  •  UTN #14
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru
> 

-- 
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.405 / Virus Database: 268.12.2/442 - Release Date: 9/8/2006

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Doug Ewell" <[email-masked]>
Date: Mon, 11 Sep 2006 21:23:59 -0700

McDonald, Ira <imcdonald at sharplabs dot com> wrote:

> My two cents - any 800-page I-D is BAD - publishing one is tantamount 
> to saying "don't bother to pay any attention to the output of this 
> WG".
>
> Squashing the registry format (which may change again in the 
> RFC464xbis era, perhaps?) into an I-D is an exercise that diverts 
> attention from the content of the prototype registry and issues with 
> that content.

Well, we'd better decide this pretty soon since it's one of our 
deliverables, and I'm supposed to submit a first draft within the next 
20 days.

As long as Ira mentions the "format" -- we're also chartered to discuss 
possible "adjustments to... the form of the registry."  Has anyone had 
any thoughts about that?  Any news about the supposed plan to move all 
IANA registries to XML?  Now is probably the best time to talk about 
this.

RFC 4645  *  UTN #14

---

From: Frank Ellermann <[email-masked]>
Date: Tue, 12 Sep 2006 08:45:51 +0200

Doug Ewell wrote:

> we're also chartered to discuss possible "adjustments to...
> the form of the registry."  Has anyone had any thoughts about
> that?

Yes, keep it as is, it's good enough.

> Any news about the supposed plan to move all IANA registries
> to XML?

Was that on a Joint-W3C-Unicode-making-fun-of-the-IETF list ?
The worst I've seen were proposals to use CharMapML, so far
nobody supported that.

Frank

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Tue, 12 Sep 2006 11:18:07 +0200

On Mon, Sep 11, 2006 at 09:23:59PM -0700,
 Doug Ewell <[email-masked]> wrote 
 a message of 32 lines which said:

> As long as Ira mentions the "format" -- we're also chartered to
> discuss possible "adjustments to... the form of the registry."  Has
> anyone had any thoughts about that?

Before writing my parser, I preferred an XML format. Now that I have
written a parser to the registry, I hesitate to continue to support a
change which would destroy my work :-)

> Any news about the supposed plan to move all IANA registries to XML?

No idea. Do you mind if I ping the IANA about that?

---

From: "Doug Ewell" <[email-masked]>
Date: Tue, 12 Sep 2006 07:04:16 -0700

> change which would destroy my work :-)

I'd have to change my program that converts the Registry into a DLL. 
That would be a fair amount of work, and I'm not looking forward to it, 
but we want whatever is best for the Registry and language tagging.

> No idea. Do you mind if I ping the IANA about that?

That would be an excellent idea.  Thanks in advance.

---

From: Addison Phillips <[email-masked]>
Date: Tue, 12 Sep 2006 09:05:26 -0700

> Yes, keep it as is, it's good enough.

+1

> Was that on a Joint-W3C-Unicode-making-fun-of-the-IETF list ?

(laughing) I don't think such a thing has happened, but talking to 
colleagues in one or another forum has certainly produces ample 
opportunity for eye rolling at our choice of record-jar (at least I can 
hide behind John Cowan when the topic is raised).

However... that battle is *over* and we should not revisit it. The only 
change I would willingly support to the registry would be one declaring 
that it uses UTF-8 as an encoding (so we can deprecate use of the NCR 
format). No doubt IANA's servers can emit:

   Content-Type: text/plain;charset=UTF-8

Addison

-- 
Addison Phillips
Globalization Architect -- Yahoo! Inc.

Internationalization is an architecture.
It is not a feature.

---

From: Frank Ellermann <[email-masked]>
Date: Tue, 12 Sep 2006 21:47:18 +0200

Addison Phillips wrote:

> I can hide behind John Cowan when the topic is raised

I also like the format, it's awk-friendly.  If you post
an updated draft record-jar-01 with the 4646 reference
I could create a LTRU-to-XML awk script as an exercise.

> The only change I would willingly support to the 
> registry would be one declaring that it uses UTF-8 as
> an encoding

Hm... :-(  That would be an advantage for XML, I could
change the encoding to say Latin-1 using NCRs for the
rest.  

With plain text it's too easy to get such modifications
wrong, or forget what the state of a modified file is.

> No doubt IANA's servers can emit:

Sure.  With a mandatory signature it wouldn't annoy me
too much, but I need to convert it for my legacy tools.

Frank

---

From: Addison Phillips <[email-masked]>
Date: Tue, 12 Sep 2006 13:04:02 -0700

> I could create a LTRU-to-XML awk script as an exercise.

Yep. Actually, since record-jar-00 isn't submitted, when I get a few 
minutes I intend to clean it up and submit it as an individual submission.
> wrong, or forget what the state of a modified file is.

Changing the encoding might break one or two implementations that expect 
ASCII-with-markup, but UTF-8 is far superior to markup, in my (biased, 
Unicadette) opinion, since it makes the file plain text in a well-known, 
well-declared, highly-desirable encoding.

Actually, the hard part would be sending non-ASCII-bearing registrations 
to IANA. To ensure that the right code points are used, we might have to 
send them ASCII-with-NCRs and have IANA unescape those when constructing 
the file.

Hmm... perhaps we should leave well enough alone.

Addison

---

From: Frank Ellermann <[email-masked]>
Date: Tue, 12 Sep 2006 22:55:54 +0200

Addison Phillips wrote:

> record-jar-00 isn't submitted

Oops, I found a -00pre at your site then.

> UTF-8 is far superior to markup, in my (biased, Unicadette)
> opinion, since it makes the file plain text in a well-known,

Yes.  Not the maximal Latin-1 compatibility IFF you're willing
to spend up to 7 octets.  But apparently the optimal encoding
for maximal ASCII compatibility.

> Actually, the hard part would be sending non-ASCII-bearing
> registrations to IANA. To ensure that the right code points
> are used, we might have to send them ASCII-with-NCRs and
> have IANA unescape those when constructing the file.

MIME allows to send UTF-8, that's not really hard.  If IANA
uses some obscure auto-conversions to windows-1252 they could
(1) please disable this, or (2) get it as attachement.  While
you love Unicode for me MIME is the best standard I know.  It
has a few dark corners, but in practice and for simple tasks
like send "modification / insert request to IANA" it's fine.  
 
> perhaps we should leave well enough alone.

Yes, for other reasons like not annoying folks who implemented
4646 validators (probably there are many more than only Doug,
Stephane, and you).

Frank

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Thu, 14 Sep 2006 22:49:36 +0200

On Mon, Sep 11, 2006 at 09:23:59PM -0700,
 Doug Ewell <[email-masked]> wrote 
 a message of 32 lines which said:

> Has anyone had any thoughts about that?  Any news about the supposed
> plan to move all IANA registries to XML?

Asked about that, Kim Davies (IANA), together with David Conrad (IANA
director) told me that IANA intended to resume this project "in the
next few weeks". So, if this is true (remember that IANA is often
quite busy), this may be an opportunity.