Subject: [Ltru] Suppress-Script batch 1

From: John Cowan <[email-masked]>
Date: Wed, 27 Sep 2006 11:51:43 -0400

Frank Ellermann scripsit:

> Here's a list of 67 differences between LTRU and CLDR 1.4

Okay.  I've taken Frank's list and pruned it as follows: (a) the four
cases where CLDR has multiple scripts and LSR has one; (b) the language
collections; (c) Uighur, which Wikipedia says is written in multiple
scripts.

Please, everyone (especially Michael, when he recovers), review these.
Remember that the criterion for including a Suppress-Script is that the
script is always used for the language except in a few highly restricted
domains, such as writing for the blind, scholarly transliteration,
transcription for use in another language, and when the standard script
is not available.

aa      Afar    		Latn
ak      Akan    		Latn
bo      Tibetan 		Tibt
byn     Blin Bilin      	Ethi
ee      Ewe     		Latn
fil     Filipino Pilipino       Latn
fur     Friulian        	Latn
fy      Western Frisian 	Latn
gaa     Ga      		Latn
gd      Gaelic Scottish Gaelic  Latn
gez     Geez    		Ethi
gsw     Swiss German Alemanic   Latn
haw     Hawaiian        	Latn
ho      Hiri Motu       	Latn
ia      Interlingua de IALA     Latn
ig      Igbo    		Latn
kam     Kamba   		Latn
kpe     Kpelle  		Latn
kw      Cornish 		Latn
mi      Maori   		Latn
oc      Occitan Proven&#xE7;al  Latn
os      Ossetian Ossetic        Latn
rm      Raeto-Romance   	Latn
sa      Sanskrit        	Deva
se      Northern Sami   	Latn
sid     Sidamo  		Latn
sma     Southern Sami   	Latn
smj     Lule Sami       	Latn
smn     Inari Sami      	Latn
sms     Skolt Sami      	Latn
syr     Syriac  		Syrc
tet     Tetum   		Latn
tig     Tigre   		Ethi
tt      Tatar   		Cyrl
wal     Walamo  		Ethi
yo      Yoruba  		Latn

-- 
I am expressing my opinion.  When my            John Cowan
honorable and gallant friend is called,         [email-masked]
he will express his opinion.  This is           http://www.ccil.org/~cowan
the process which we call Debate.                   --Winston Churchill

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Addison Phillips <[email-masked]>
Date: Wed, 27 Sep 2006 09:06:08 -0700

Here's my thought:

    -1 to all of them

I still believe that Suppress-Script was the wrong solution to the 
script subtag problem. Here we are seeing *exactly* the kinds of 
problems with it that I predicted, which is that it is very difficult 
indeed to make a complete, comprehensive, and verifiably correct list. 
Furthermore, the possibility of abuse is clearly present. I see 'tt' on 
the list below, despite someone's vehement belief that Tatar speakers 
wish to write using the Latin script and are being suppressed. 
Suppress-Script would aid that, if that case turns out to be true.

We would be far better off, in my opinion, to have gone down the other 
course: a Require-Script field and strong language in RFC 4646 saying, 
in effect, "You MUST NOT use a script subtag unless the language or 
extlang has a Require-Script matching the script used in the content or 
the script subtag identifies some distinction in the content being tagged."

This latter course would meet all of the objections to Suppress-Script, 
including that it precludes certain kinds of abuse, either premeditated 
or accidental.

Since we didn't do that, I think we should only create Suppress-Script 
fields when there is clear and compelling reason to do so... and I think 
that a clear and compelling reason for me would be someone requesting it 
on purpose.

Addison

-- 
Addison Phillips
Globalization Architect -- Yahoo! Inc.

Internationalization is an architecture.
It is not a feature.

---

From: "Mark Davis" <[email-masked]>
Date: Wed, 27 Sep 2006 15:39:49 -0700

If you are going to do any analysis of the differences, please take a look
also at my message of

From: *Mark Davis <[email-masked]>*Mailed-By: *gmail.com*
Subject: *Re: Languages and Scripts*

which contained a listing of differences between the CLDR data and other
Unicode data that we would like to reconcile. I repeat the data below.

In particular, I had asked on this list if anyone knew anything about the
couple of dozen purported languages at the end for which Magda couldn't find
639-3 language codes. Hearing no response, we will probably just remove them
from the Unicode site as bogus.

[abq] ; Abaza ; [Cyrl] ;
[ady] ; Adygei ;        [Cyrl] ;
[ain] ; Ainu ;  [Kana]; [Latn] ;
[amo] ; Amo ;   [Latn] ;
[av] ;  Avar (Avaric?) ;        [Cyrl] ;
[awa] ; Awadhi ;        [Deva] ;
[ba] ;  Bashkir ;       [Cyrl] ;
[bbc] ; Batak toba ;    [Batk]*; [Latn] ;
[bfq] ; Badaga ;        [Taml] ;
[bft] ; Balti ; [Deva] ;        [Removed Balti]
[bfy] ; Bagheli ;       [Deva] ;
[bh] ;  Bihari ;        [Deva] ;
[bhb] ; Bhili ; [Deva] ;
[bho] ; Bhojpuri ;      [Deva] ;
[bjj] ; Kanauji ;       [Deva] ;
[bku] ; Buhid ; [Buhd] ;
[br] ;  Breton ;        [Latn] ;
[bra] ; Braj bhasha ;   [Deva] ;
[btk] ; Batak ; [Batk]*, [Latn] ;
[btv] ; Bateri (aka Bhatneri)  ;        [Deva] ;
[ccp] ; Chakma ;        [Beng]; ;       [Removed Chakma]
[ce] ;  Chechen ;       [Cyrl] ;
[chm] ; Mari ;  [Cyrl]; [Latn] ;
[cjs] ; Shor ;  [Cyrl] ;
[co] ;  Corsican ;      [Latn] ;
[cop] ; Coptic ;        [Arab]; [Copt] ;        "[Added Grek, but is that
right now?]"
[cr] ;  Cree ;  [Cans]; [Latn] ;
[cv] ;  Chuvash ;       [Cyrl] ;
[dar] ; Dargwa ;        [Cyrl] ;
[en] ;  English ;       [Latn] ;        "[Had Shavian and Deseret, but those
never
had any significant usage]"
[evn] ; Evenki ;        [Cyrl] ;
[gag] ; Gagauz ;        [Cyrl] ;
[gbm] ; Garhwali ;      [Deva]
[gd] ;  Gaelic ;        [Latn]
[gld] ; Nanai ; [Cyrl]
[gon] ; Gondi ; [Deva]; [Telu]
[grt] ; Garo ;  [Beng]
[hmn] ; Hmong ; [Latn]; [Hmng]*
[hnn] ; Hanunóo ;       [Latn]; [Hano]
[hoc] ; Ho ;    [Deva]
[hoj] ; Harauti ;       [Deva]
[hop] ; Hopi ;  [Latn]
[hy] ;  Armenian ;      [Armn]; [Syrc]*
[ibb] ; Ibibio ;        [Latn]
[id] ;  Indonesian ;    "[Arab]*, [Latn]"
[ik] ;  Iñupiaq ;       [Latn]
[inh] ; Ingush ;        [Arab]; [Latn]
[jv] ;  Javanese ;      [Latn]; [Java]*
[kaa] ; Karakalpak ;    [Cyrl]
[kac]? ;        Kachchi ;       [Deva]
[kbd] ; Kabardian ;     [Cyrl]
[kca] ; Khanty ;        [Cyrl]
[kdt] ; Kuy ;   Thai
[kha] ; Khasi ; [Latn]; [Beng]
[kht] ; Khamti ;        [Mymr]
[kr] ;  Kanuri ;        [Latn]
[krc] ; Karachay ;      [Cyrl]
[krl] ; Karelian ;      [Latn]; [Cyrl]
[kv] ;  Komi ;  [Cyrl]; [Latn]
[ky] ;  Kirghiz ;       [Arab]*; [Latn]; [Cyrl]
[lad] ; Ladino ;        [Hebr]
[lbe] ; Lak ;   [Cyrl]
[lcp] ; "Lawa, western" ;       Thai
[lep] ; Lepcha ;        [Lepc]*
[lez] ; Lezghian (Lezghi?) ;    [Cyrl]
[li]? ; Limbu ; [Deva]; [Limb]
[lis] ; Lisu ;  "Lisu (Fraser)*, [Latn]"
[lmn] ; Lambadi ;       [Telu]
[lut] ; Lushootseed ;   [Latn]
[lwl] ; "Lawa, eastern" ;       Thai
[mnc] ; Manchu ;        [Mong]
[mni] ; Meitei ;        "Meetai Mayek*, [Beng]"
[mns] ; Mansi ; [Cyrl]
[mnw] ; Mon ;   [Mymr]
[muw] ; Mundari ;       [Beng]; [Deva]
[mwr] ; Marwari ;       [Deva]
[nbf] ; Naxi ;  Naxi*
[new] ; Newari ;        "[Deva]; Ranjana, Parachalit"
[nog] ; Nogai ; [Cyrl]
[nv] ;  Navajo ;        [Latn]
[om] ;  Oromo ; [Ethi]*; [Latn] ;       "[According to wikipedia, Ethi usage
is old"
[os] ;  Ossetic ;       [Cyrl]; [Latn] ;
[pi] ;  Pali ;  [Sinh]; [Deva]; [Thai] ;
[prd] ; Parsi-dari ;    [Arab] ;
[prg] ; Prussian ;      [Latn] ;
[ro] ;  Romanian ;      [Latn]; [Cyrl]* ;
[rom] ; Romany ;        [Cyrl]; [Latn] ;
[sa] ;  Sanskrit ;      [Sinh]; [Deva]; etc. ;  [CLDR doesn't do 'etc': what
is the exact list: all modern Indic scripts + Sinhala?]
[sah] ; Yakut ; [Cyrl] ;
[sat] ; Santali ;       [Deva]; [Beng]; [Orya]; [Olck]* ;
[sel] ; Selkup ;        [Cyrl] ;
[shn] ; Shan ;  [Mymr] ;
[smi] ; Sami ;  [Cyrl]; [Latn] ;        [Is Cyrl common?]
[smp] ; Samaritan ;     [Hebr] ;        [Removed Samaritan*
[sn] ;  Shona ; [Latn] ;
[syl] ; Sylhetti ;      [Sylo]; [Beng] ;
[tab] ; Tabasaran ;     [Cyrl] ;
[tbw] ; Tagbanwa ;      [Latn];  ;      [Removed Tagbanwa]
[tcy] ; Tulu ;  [Knda] ;
[tl] ;  Tagalog ;       [Latn]; [Tglg] ;        [It appears that Tglg is not
in modern use]
[tru] ; Turoyo ;        [Syrc] ;
[ttt] ; Tat ;   [Cyrl] ;
[tut] ; Altai (Altaic?) ;       [Cyrl] ;
[ty] ;  Tahitian ;      [Latn] ;
[udm] ; Udmurt ;        [Cyrl]; [Latn] ;
[ug] ;  Uighur ;        [Arab]; [Latn]; [Cyrl] ;        "[adds Latn, Cyrl;
is the
latter common?  Removed Uighur]"
[vi] ;  Vietnamese ;    [Latn]; Chu Nom ;       [Chu Nom would be Hani*]
[xal] ; Kalmyk ;        [Cyrl] ;
[xsr] ; Sherpa ;        [Deva] ;
[yrk] ; Nenets ;        [Cyrl] ;

# Missing Language Codes

??? ;   Aisor ; [Cyrl]
??? ;   Assyrian (modern) ;     [Syrc]
??? ;   Bahasa ;        [Latn]
??? ;   Balear ;        [Latn]
??? ;   Balkar ;        [Cyrl]
??? ;   Bugis ; [Bugi]
??? ;   Buryat ;        [Cyrl]
??? ;   Cham ;  [Cham]*
??? ;   Chhattisgarhi ; [Deva]
??? ;   Chukchi ;       [Cyrl]
??? ;   Dungan ;        [Cyrl]
??? ;   Edo ;   [Latn]
??? ;   Garshuni ;      [Syrc]
??? ;   Gascon ;        [Latn]
??? ;   Judezmo ;       [Hebr]
??? ;   Kankan ;        [Deva]
??? ;   Khakass ;       [Cyrl]
??? ;   Koryak ;        [Cyrl]
??? ;   Lapp ;  [Latn]
??? ;   Mordvin ;       [Cyrl]
??? ;   Naga ;  [Latn]; [Beng]
??? ;   Riang ; [Beng]
??? ;   Swadaya ;       [Syrc]
??? ;   Tamazight ;     [Tfng], [Latn]
??? ;   Tsalagi ;       (see Cherokee)
??? ;   Tuva ;  [Cyrl]
??? ;   Udekhe ;        [Cyrl]

On 9/27/06, Frank Ellermann <[email-masked]> wrote:
>
> John Cowan wrote:
>
> > I'll post (some of) the current state of things shortly.
>
> Lines where LTRU has no script and CLDR more than one are
> most probably sane, but anything else should be checked:
>
> lang aa  ltru      cldr Latn
> lang ak  ltru      cldr Latn
> lang az  ltru      cldr Arab Cyrl Latn
> lang bo  ltru      cldr Tibt
> lang cr  ltru      cldr Cans Latn
> lang ee  ltru      cldr Latn
> lang fy  ltru      cldr Latn
> lang gd  ltru      cldr Latn
> lang ha  ltru      cldr Arab Latn
> lang ho  ltru      cldr Latn
> lang ia  ltru      cldr Latn
> lang ig  ltru      cldr Latn
> lang iu  ltru      cldr Cans Cyrl Latn
> lang ja  ltru      cldr Hani Hira Kana
> lang ko  ltru      cldr Hang Hani
> lang ks  ltru      cldr Arab Deva
> lang ku  ltru      cldr Arab Cyrl Latn
> lang kw  ltru      cldr Latn
> lang ky  ltru      cldr Arab Cyrl
> lang mi  ltru      cldr Latn
> lang mn  ltru      cldr Cyrl Mong
> lang mo  ltru Latn cldr Cyrl Latn
> lang ms  ltru Latn cldr Arab Latn
> lang oc  ltru      cldr Latn
> lang os  ltru      cldr Latn
> lang pa  ltru Guru cldr Arab Guru
> lang rm  ltru      cldr Latn
> lang sa  ltru      cldr Deva
> lang sd  ltru      cldr Arab Deva
> lang se  ltru      cldr Latn
> lang sh  ltru      cldr Latn
> lang sr  ltru      cldr Cyrl Latn
> lang tg  ltru      cldr Arab Cyrl Latn
> lang tk  ltru      cldr Arab Cyrl Latn
> lang tr  ltru Latn cldr Arab Latn
> lang tt  ltru      cldr Cyrl
> lang ug  ltru      cldr Arab
> lang uz  ltru      cldr Arab Cyrl Latn
> lang yo  ltru      cldr Latn
> lang zh  ltru      cldr Bopo Hani Hans Hant
> lang bal ltru      cldr Arab Latn
> lang byn ltru      cldr Ethi
> lang cch ltru      cldr Latn
> lang chr ltru      cldr Cher Latn
> lang cop ltru      cldr Arab Copt
> lang fil ltru      cldr Latn
> lang fiu ltru      cldr Latn
> lang fur ltru      cldr Latn
> lang gaa ltru      cldr Latn
> lang gez ltru      cldr Ethi
> lang gsw ltru      cldr Latn
> lang haw ltru      cldr Latn
> lang kaj ltru      cldr Latn
> lang kam ltru      cldr Latn
> lang kcg ltru      cldr Latn
> lang kfo ltru      cldr Latn
> lang kpe ltru      cldr Latn
> lang sid ltru      cldr Latn
> lang sma ltru      cldr Latn
> lang smi ltru      cldr Latn
> lang smj ltru      cldr Latn
> lang smn ltru      cldr Latn
> lang sms ltru      cldr Latn
> lang syr ltru      cldr Syrc
> lang tet ltru      cldr Latn
> lang tig ltru      cldr Ethi
> lang wal ltru      cldr Ethi
>
>
> Ietf-languages mailing list
> [email-masked]
> http://www.alvestrand.no/mailman/listinfo/ietf-languages
>

---

From: John Cowan <[email-masked]>
Date: Wed, 27 Sep 2006 22:57:57 -0400

Mark Davis scripsit:

> In particular, I had asked on this list if anyone knew anything about
> the couple of dozen purported languages at the end for which Magda
> couldn't find 639-3 language codes. Hearing no response, we will
> probably just remove them from the Unicode site as bogus.  

Google search of www.ethnologue.com is your friend.

> ??? ;   Assyrian (modern) ;     [Syrc]

Synonyms for Assyrian Neo-Aramaic (syr-aii).

> ??? ;   Bahasa ;        [Latn]

This is the Malay/Indonesian word for "language", so it's
probably a synonym for either one (they are very similar
but not identical).

> ??? ;   Balear ;        [Latn]

Dialect of Catalan spoken in the Balearic islands.

> ??? ;   Balkar ;        [Cyrl]

Dialect of Karachay-Balkar (krc).

> ??? ;   Bugis ; [Bugi]

Synonym for Buginese (bug)

> ??? ;   Buryat ;        [Cyrl]

Synonym for Russia Buriat (bxr)

> ??? ;   Cham ;  [Cham]*

Could be Western Cham (cja) in Cambodia or Eastern Cham (cjm) in Vietnam.

> ??? ;   Chhattisgarhi ; [Deva]

Code hne.

> ??? ;   Chukchi ;       [Cyrl]

Should be Chukot (ckt).  "Chukchi" is the ethnonym.

> ??? ;   Dungan ;        [Cyrl]

Code dng.  Linguistically part of the Mandarin Chinese dialect
continuum, but sociolinguistically separate because written in
Cyrillic and spoken in Russia.

> ??? ;   Edo ;   [Latn]

Code bin.

> ??? ;   Garshuni ;      [Syrc]

Apparently means ar-Syrc.  See http://en.wikipedia.org/wiki/Garshuni .

> ??? ;   Gascon ;        [Latn]

Code oc-gsc (part of the Occitan macrolanguage).

> ??? ;   Judezmo ;       [Hebr]

Synonym for Ladino (lad).

> ??? ;   Kankan ;        [Deva]

Synonym for Eastern Maninkakan (emk)

> ??? ;   Khakass ;       [Cyrl]

Spelling error or synonym for Khakas (kjh)

> ??? ;   Koryak ;        [Cyrl]

Code kpy.

> ??? ;   Lapp ;  [Latn]

One of the Saami languages ("Lapp" is derogatory).
See http://www.ethnologue.com/show_family.asp?subid=90977 .

> ??? ;   Mordvin ;       [Cyrl]

A genetic grouping comprising Erzya (myv) and Moksha (mdf).

> ??? ;   Naga ;  [Latn]; [Beng]

A genetic grouping comprising 25 languages, most called "X Naga";
see http://www.ethnologue.com/show_family.asp?subid=92044 .
Also Naga Pidgin (nag).

> ??? ;   Riang ; [Beng]

Code ril.

> ??? ;   Swadaya ;       [Syrc]

Dialect of syr-aii (see above).

> ??? ;   Tamazight ;     [Tfng], [Latn]

Probably Central Atlas Tamazight (tzm), but might be intended to include
two other Tamazight languages (tjo, tia).

> ??? ;   Tsalagi ;       (see Cherokee)

Synonym for Cherokee (chr).

> ??? ;   Tuva ;  [Cyrl]

Tuvin (tyv); "Tuva" is the locality name.

> ??? ;   Udekhe ;        [Cyrl]

Synonym for Udihe (ude).

-- 
John Cowan      http://www.ccil.org/~cowan      [email-masked]
Be yourself.  Especially do not feign a working knowledge of RDF where
no such knowledge exists.  Neither be cynical about RELAX NG; for in
the face of all aridity and disenchantment in the world of markup,
James Clark is as perennial as the grass.  --DeXiderata, Sean McGrath

---

From: Martin Duerst <[email-masked]>
Date: Thu, 28 Sep 2006 13:36:54 +0900

>rm      Raeto-Romance          Latn

I can definitely confirm that Raeto-Romance is written in Latin.
Although this was some time ago, I have spent altogether quite a
few weeks in areas where Raeto-Romance was the primary languge.
Never was any other script than Latin used.

Regards,    Martin.

#-#-#  Martin J. Du"rst, Assoc. Professor, Aoyama Gakuin University
#-#-#  http://www.sw.it.aoyama.ac.jp       mailto:[email-masked]

---

From: "Reshat Sabiq (Reşat)"<[email-masked]>
Date: Wed, 27 Sep 2006 22:11:39 -0500

Being a Tatar (OK to call me Bashqort too i guess), and not having lived
in all of these places i'd still like to save a few Languages from
delettion from unicode site, plus a few more comments. Please see my
humble feedback below (i tried to phrase sentences i was less sure about
in a way that wouldn't put my credibility on the line):

Mark Davis yazmış:
> If you are going to do any analysis of the differences, please take a
> look also at my message of
...
> [ba] ;  Bashkir ;       [Cyrl] ;
The native spelling of the language in English would be: Bashqort.
> [ce] ;  Chechen ;       [Cyrl] ;
This gets into politics, but while Chechen republic was de-facto
independent, AFAIK, the official alphabet was Latn.
> [kaa] ; Karakalpak ;    [Cyrl]
The native spelling is: Qaraqalpaq. Latn has been becoming official
sicne 1991, but according to wiki slower than in Uzbekistan in general.
> [krc] ; Karachay ;      [Cyrl]
The native spelling is: Qarachay. I don't know first hand, but what i'm
reading is Qarachay and Balqar (Malqar) are almost the same (two letters
are different in some suffixes or something like that; probably less
differences than between Tatar and Bashqort), and the name that refers
to both of them is Alan language. Also there are projects of adopting
Latin, but not sure if it's just intelligentsia or majority of
electronic usage, etc.
> ??? ;   Balkar ;        [Cyrl]
I tend to think that Balqar is Qarachay spelling, and Malqar is the
native way to say this. See above for references to Alan language, as a
cumulative name, and Latn topic. Both are fairly intelligible to Tatars.
> ??? ;   Buryat ;        [Cyrl]
Is a variation of Mongol.
> ??? ;   Khakass ;       [Cyrl]
Is a Turkic language, but from what i'm reading there's only 65K
speakers left. Might be endangered.
> ??? ;   Tuva ;  [Cyrl]
Is a Turkic language. I tend to think native spelling in English would
be: Tywa.

P.S. I'll try to keep up if there's more discussion on these, but
forgive me in advance if i miss something. ;)

- --
My public GPG key (ID 0x262839AF) is at: http://keyserver.veridis.com:11371

---

From: "Reshat Sabiq (Reşat)"<[email-masked]>
Date: Wed, 27 Sep 2006 22:17:31 -0500

> Google search of www.ethnologue.com is your friend.
...
Looks like my feedback is just a partial confirmation on John's feedback.

- --

---

From: "Reshat Sabiq (Reşat)"<[email-masked]>
Date: Wed, 27 Sep 2006 22:11:39 -0500

...

- --

---

From: "Reshat Sabiq (Reşat)"<[email-masked]>
Date: Wed, 27 Sep 2006 22:17:31 -0500

...

- --

---

From: "Debbie Garside" <[email-masked]>
Date: Thu, 28 Sep 2006 08:38:13 +0100

Hi Mark
 
The following link will take you to the ISO 639-3 code list.  The final
letter in this link can be changed (a-z) to give you the corresponding
languages in alphabetical order.  This makes it very easy to check the data
- assuming the same name has been used. 
 
http://www.sil.org/iso639%2D3/codes.asp?order=name
<http://www.sil.org/iso639%2D3/codes.asp?order=name&name=name&letter=b>
&name=name&letter=b
 
Best regards
 
Debbie

  _____  

From: [email-masked]
[mailto:[email-masked]] On Behalf Of Mark Davis
Sent: 27 September 2006 23:40
To: Frank Ellermann
Cc: Michael Everson; LTRU Working Group; [email-masked]
Subject: Re: frr, fy, ngo, tt

From: Mark Davis <[email-masked]>	 Mailed-By: gmail.com	

Subject: Re: Languages and Scripts

[abq] ; Abaza ; [Cyrl] ;

# Missing Language Codes

??? ;   Aisor ; [Cyrl]

lang aa  ltru      cldr Latn
lang ak  ltru      cldr Latn

<http://www.alvestrand.no/mailman/listinfo/ietf-languages>