Subject: [Ltru] Preferred-Value fun...

From: Addison Phillips <[email-masked]>
Date: Wed, 13 Sep 2006 10:42:04 -0700

I note some problems with Preferred-Value, which I'm cleaning as follows:

1. Currently the definition of P-V says:

--
  o  Preferred-Value

       *  For fields of type 'language', 'extlang', 'script', 'region',
          and 'variant', 'Preferred-Value' contains the subtag of the
          same 'Type' that is preferred for forming the language tag.

       *  For fields of type 'grandfathered' and 'redundant', a canonical
          mapping to a complete language tag.
--

Notice that this won't work for 'language' and 'extlang' subtags in all 
situation. I'm changing to:

--
<t>Preferred-Value<list>

    <t>For fields of type 'script', 'region', and 'variant',
    'Preferred-Value' contains the subtag of the same 'Type'
    that is preferred for forming the language tag.</t>

    <t>For fields of type 'language' and 'extlang',
      'Preferred-Value' contains the language production
      (see <xref target="ABNF"></xref>) that is preferred
      when forming the language tag. This can be simply a
      'language' subtag, or it can be a 'language' subtag
      followed by an extended language sequence.</t>

    <t>For fields of type 'grandfathered' and 'redundant',
       a canonical mapping to a complete language tag.</t>

</list></t>
--

2. Elsewhere in that section it says:

--
    3.  Tags grandfathered from RFC 3066.
--

... which I changed to:

--
    3.  Grandfathered or redundant tags from RFC 3066.
--

3. The prohibition of new Preferred-Values paragraph needs attention, 
per the threads over the past couple of days. Here is the old para:

--
<t>The field 'Preferred-Value' MUST NOT be modified once created in the 
registry. The field MAY be added to records of type "grandfathered" and 
"region" according to the rules in <xref target="maintreg"></xref>. 
Otherwise the field MUST NOT be added to any record already in the 
registry.</t>
--

Here is my proposed new para:

--
<t>The field 'Preferred-Value' MUST NOT be modified once created in the 
registry. The field MAY be added to records according to the rules in 
<xref target="maintreg"></xref>.</t>
--

--

-- 
Addison Phillips
Globalization Architect -- Yahoo! Inc.

Internationalization is an architecture.
It is not a feature.

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Wed, 13 Sep 2006 19:51:18 +0200

Addison Phillips wrote:
 
> some problems with Preferred-Value, which I'm cleaning

Sounds good, and for the identification of redundant sgn-XX
tags their registration forms are still available at IANA:
<http://www.iana.org/assignments/lang-tags/>

Frank

---

From: Addison Phillips <[email-masked]>
Date: Thu, 14 Sep 2006 07:55:41 -0700

Martin Duerst wrote:
> 
> Does this change the meaning, or just make sure normative stuff
> is defined in a single place?
> 

It changes the meaning: Preferred-Value could then be registered for any 
record type, not just grandfathered and region. Formerly, this sentence 
prohibited registrations for the other types.

Addison