Subject: [Ltru] Re: IANA XML registries

From: "Doug Ewell" <[email-masked]>
Date: Tue, 19 Sep 2006 22:31:47 -0700

David Conrad <david dot conrad at icann dot org>  wrote:

> Yes, IANA is undertaking to convert all our registries over to XML. 
> We'll be doing this in an incremental fashion of course, starting with 
> a few of the simpler registries, getting feedback from people, 
> revising and doing more registries, getting feedback, etc. until 
> everything is converted over. Part of this project will also be to 
> generate "legacy" registries from the XML in formats that are as close 
> to what exists now as we can easily manage (in an undoubtedly vain 
> attempt to try to limit the screams of outrage from the poor souls who 
> have hacked software to deal with the existing registries).

Now that we know this, shall we bite the bullet and do this ourselves?

--
Doug Ewell
Fullerton, California, USA
http://users.adelphia.net/~dewell/
RFC 4645  *  UTN #14 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "McDonald, Ira" <[email-masked]>
Date: Wed, 20 Sep 2006 15:11:15 -0700

Hi,

Diffs (actual line-by-line comparisons) aren't really useful.
But an update file that contains _whole_records_ for subtags 
either modified or new would be sufficient, when combined with 
John's good idea for a separate file-date-version HTTP resource.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

> -----Original Message-----
> From: Addison Phillips [mailto:[email-masked]]
> Sent: Wednesday, September 20, 2006 5:50 PM
> To: John Cowan
> Cc: [email-masked]
> Subject: Re: [Ltru] Re: IANA XML registries
> 
> 
> 
> 
> John Cowan wrote:
> > 
> > However, selecting language tags or determining their validity
> > (as opposed to well-formedness) requires a copy of the registry.
> > 
> 
> One small nit: selecting language tags does not necessarily require a 
> copy of the registry. Most implementations I'm aware of just 
> have a list 
> of common (valid) tags for the user to choose from or perform 
> rudimentary well-formedness checks on user input. Validating these 
> requires a registry copy, of course.
> 
> > 
> >> I do not think there is *one* approach to this problem.
> > 
> > +1
> > 
> 
> +1
> 
> Addison
> 
> -- 
> Addison Phillips
> Globalization Architect -- Yahoo! Inc.
> 
> Internationalization is an architecture.
> It is not a feature.
> 

-- 
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.405 / Virus Database: 268.12.5/451 - Release Date: 9/19/2006