Subject: RE: [Ltru] Re: Format of the registry (Was: RFC 4645 on Initial L anguage Subtag Registry

From: "McDonald, Ira" <[email-masked]>
Date: Wed, 13 Sep 2006 07:37:08 -0700

Hi,

I think the main reason Record Jar (modified) was chosen
over XML for the registry format was because XML source
is a pretty terrible format for non-experts to review in
an I-D.

The other reason may have been misunderstanding of best
practices in XML (e.g., using attributes which can't be 
multivalued versus using elements can be multivalued).

Is IANA moving towards XML for IANA registries?  I've seen 
comments to this effect on several IETF WG mailing lists.

XML lets us use things much more powerful than XML Schema
(like Relax NG and Schematron) to enforce consistency.

Record Jar is not going to replace XML as the language
du jour for database-like applications.

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked]

> -----Original Message-----
> From: Doug Ewell [mailto:[email-masked]]
> Sent: Tuesday, September 12, 2006 10:04 AM
> To: LTRU Working Group
> Subject: [Ltru] Re: Format of the registry (Was: RFC 4645 on Initial
> Language Subtag Registry
> 
> 
> Stephane Bortzmeyer <bortzmeyer at nic dot fr> wrote:
> 
> > Before writing my parser, I preferred an XML format. Now 
> that I have 
> > written a parser to the registry, I hesitate to continue to 
> support a 
> > change which would destroy my work :-)
> 
> I'd have to change my program that converts the Registry into a DLL. 
> That would be a fair amount of work, and I'm not looking 
> forward to it, 
> but we want whatever is best for the Registry and language tagging.
> 
> >> Any news about the supposed plan to move all IANA 
> registries to XML?
> >
> > No idea. Do you mind if I ping the IANA about that?
> 
> That would be an excellent idea.  Thanks in advance.
> 
> --
> Doug Ewell
> Fullerton, California, USA
> http://users.adelphia.net/~dewell/
> RFC 4645  *  UTN #14
> 
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/ltru
> 

-- 
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.405 / Virus Database: 268.12.3/446 - Release Date: 9/12/2006

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Frank Ellermann <[email-masked]>
Date: Wed, 13 Sep 2006 19:09:06 +0200

McDonald, Ira wrote:

> XML source is a pretty terrible format for non-experts to
> review in an I-D.

Depends, <http://purl.net/xyzzy/home/test/utf-8.xml> is almost
obvious, for the native ICU format you'd need the rules (ABNF).
 
> (like Relax NG and Schematron) to enforce consistency.

ABNF is also nice, one advantage is that I know it.  Willing
to sign a "4234 to STD" petition (including any "fight it out
with Bruce" obligation).

> Record Jar is not going to replace XML as the language du
> jour for database-like applications.

The SPF folks use something that's called YAML for their test
suite (picked out of XML, JSON, YAML).  It really depends on
what you need.  I read Stephane's Cosmogol draft, this can't
_directly_ replace the <validity> state machine in CharMapML
with its 256 "messages" (= octets) in any state.  

Frank