Subject: [Ltru] Re: Registry Format (was UTF-8)

From: "Doug Ewell" <[email-masked]>
Date: Thu, 14 Sep 2006 23:09:29 -0700

John Cowan <cowan at ccil dot org> wrote:

> (I might have proposed JSON if I'd known about it at the time.)

I'll probably end up providing unofficial XML and JSON versions of the 
Registry.

The multiple-value problem (for example, Description) is one reason we 
abandoned the bar-delimited format.  We would have had to choose one 
ISO-provided description and ignore the rest:

language | es | Spanish | 2005-10-16 | Latn | |

or else use a subfield delimiter and pray it never appeared in real 
descriptions:

language | es | Spanish; Castilian | 2005-10-16 | Latn | |

--
Doug Ewell
Fullerton, California, USA
http://users.adelphia.net/~dewell/
RFC 4645  *  UTN #14

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Fri, 15 Sep 2006 10:13:36 +0200

On Thu, Sep 14, 2006 at 11:09:29PM -0700,
 Doug Ewell <[email-masked]> wrote 

> I'll probably end up providing unofficial XML and JSON versions of the 

This is not the first time that I see a reply to John Cowan's messages
but not the message itself.

His message has been sent to the archives:

http://www1.ietf.org/mail-archive/web/ltru/current/msg05512.html

but not to my servers. I grepped the message ID
([email-masked]) in the logs of all our mail
servers (in case it has been eaten by a too eager anti-spam system)
but I've found nothing.

Some messages from John Cowan do arrive to my mailbox, so the problem
is mysterious.

Does anyone have an idea?

---

From: Frank Ellermann <[email-masked]>
Date: Fri, 15 Sep 2006 10:59:41 +0200

Stephane Bortzmeyer wrote:
 
> I grepped the message ID ([email-masked])
[...]
> Does anyone have an idea?

That's the msg-id in Doug's references.  Doug reads the list
in digest format, it's not John's original msg-id.  Here's
his original article from GMaNe's POV:

news://news.gmane.org/[email-masked]
http://article.gmane.org/gmane.ietf.ltru/5502/raw

Frank

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Fri, 15 Sep 2006 11:12:12 +0200

On Fri, Sep 15, 2006 at 10:59:41AM +0200,
 Frank Ellermann <[email-masked]> wrote 
 a message of 15 lines which said:

> That's the msg-id in Doug's references.  Doug reads the list in
> digest format, it's not John's original msg-id.  Here's his original
> article from GMaNe's POV:

Thanks but it is the same thing for [email-masked], it
was never presented to my mail servers :-( So it does not seem to be
the fault of my anti-spam system.

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Fri, 15 Sep 2006 14:19:45 +0200

> language | es | Spanish; Castilian | 2005-10-16 | Latn | |

Or escape it, which is better than praying :-)

Do note that, if you don't require round-trip perfection, non-escaping
is perfectly valid, for instance:

language | nv | Navajo / Navaho | 2005-10-16 |

cannot be translated back to the record-jar registry (if / appears
somewhere) but it may be a non-issue.