Subject: [Ltru] Re: Preferred-Value fun...

From: "Doug Ewell" <[email-masked]>
Date: Thu, 14 Sep 2006 22:33:24 -0700

Addison Phillips <addison at yahoo dash inc dot com> wrote:

>    <t>For fields of type 'language' and 'extlang',
>      'Preferred-Value' contains the language production
>      (see <xref target="ABNF"></xref>) that is preferred
>      when forming the language tag. This can be simply a
>      'language' subtag, or it can be a 'language' subtag
>      followed by an extended language sequence.</t>

This isn't for the redundant "sgn-XX" tags.  What was the intended use 
for this again?

--
Doug Ewell
Fullerton, California, USA
http://users.adelphia.net/~dewell/
RFC 4645  *  UTN #14

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Fri, 15 Sep 2006 01:49:46 -0400

> This isn't for the redundant "sgn-XX" tags.  What was the intended use 

639 going off the rails: we register the replacement tag with a
Preferred-Value of the existing tag.

-- 
There are three kinds of people in the world:   John Cowan
those who can count,                            [email-masked]
and those who can't.

---

From: "Doug Ewell" <[email-masked]>
Date: Thu, 14 Sep 2006 23:00:42 -0700

John Cowan <cowan at ccil dot org> wrote:

>> This isn't for the redundant "sgn-XX" tags.  What was the intended 
>> use for this again?
>

You mean like "yue" being moved out of the "zh" ("zho") macrolanguage 
umbrella, and/or being added to 639-2?

Type: language
Subtag: yue
Description: Chinese, Yue
Added: xxxx-xx-xx
Preferred-Value: zh-yue
Deprecated: xxxx-xx-xx
%%

---

From: Frank Ellermann <[email-masked]>
Date: Fri, 15 Sep 2006 11:33:31 +0200

> Description: Chinese, Yue

Or vice versa:

Type: extlang
Subtag: bad
Description: Bad Chinese
Prefix: zh
Added: xxxx-xx-xx
Comment: Found to be no Chinese at all
Preferred-Value: bad
Deprecated: xxxx-xx-xx
%%