Subject: [Ltru] Re: Fwd: Re: [OT] DOCTYPE ltru

From: Frank Ellermann <[email-masked]>
Date: Mon, 18 Sep 2006 06:53:15 +0200

Martin Duerst wrote:
 
> Frank, can you post your answer to the list, too?

Date: Sun, 17 Sep 2006 22:22:54 +0200
To: Martin Duerst <[email-masked]>

Martin Duerst wrote:

> As a co-chair, I marked this off-topic, unless I
> misunderstood you to make this as a proposal for
> the actual registry.

It's what we'd get if we drop record-jar, and what
I'd propose if we go for UTF-8.  Actually it belongs
to the thread "Registry-format", where Debbie wrote
that record-jar isn't human readable.  I think it's
fine, that's why I checked my theory "writing an awk
script is trivial".  It really is trivial, finding a
simple DTD for XML output is the most exciting part.

As a side-effect I have now an output format allowing
to validate registries with any XML validator.

> change the DOCTYPE and root element from 'ltru' to
> something like 'LanguageSubtagRegistry'.

Done, see <http://purl.net/xyzzy/home/ltru>

> 'date' attributes should be changed to the more
>informative 'added'.

For now I stick to date, because I use it for all
registry dates, not only Added fields, also for
Deprecated and File-Date.

> I'd done some of the element/attribute decisions
> differently, but that's not a big issue.

Probably a matter of taste, DTD validators are not
very smart, but they can do something with ID, IDREF,
IDREFS, and NMTOKEN.  Some other sanity checks are
in the script.

Actually the script could check references directly,
and also verify dates, but it's nice that the XML
output now works with the W3C validator.

Frank

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Mon, 18 Sep 2006 09:44:09 +0200

On Mon, Sep 18, 2006 at 11:17:38AM +0900,
 Martin Duerst <[email-masked]> wrote 
 a message of 127 lines which said:

> As a co-chair, I marked this off-topic, unless I misunderstood you
> to make this as a proposal for the actual registry.

I do not think that Frank wanted XML to be the official format :-)

Nevertheless, I find quite useful, even if it is officially OT, to
discuss here about alternative formats (my proposal to host somewhere,
in an unofficial site, the translations to other formats) or about
implementations (such as Mark's regexp).

Yes, it is not in the WG charter but tackling practical problems is
also a good way to test the standard and to improve it. 

If the chairs insist :-) may be we could create a dedicated mailing
list, "ltru-implementors" but I would regard this as useless
duplication.

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Mon, 18 Sep 2006 09:46:15 +0200

On Mon, Sep 18, 2006 at 06:53:15AM +0200,
 Frank Ellermann <[email-masked]> wrote 
 a message of 50 lines which said:

> > 'date' attributes should be changed to the more informative
> > 'added'.
> 
> For now I stick to date, because I use it for all registry dates,
> not only Added fields, also for Deprecated and File-Date.

I agree with Martin (<added> is better because it is what's in the
RFC) but, since it is OT and unofficial, we'll just have two different
XML schemas :-) 

If it would be a discussion on the RFC 4646bis standard format, we
would try to reach a consensus, but if it is just testing, debugging
and so on, there is no need to fight over the name of the XML elements
:-)

---

From: Frank Ellermann <[email-masked]>
Date: Mon, 18 Sep 2006 10:51:17 +0200

Stephane Bortzmeyer wrote:

> no need to fight over the name of the XML elements :-)

Yes, maybe different philosophies, in XHTML I don't like the
many names for what's in essence an URL, src=, href=, cite=,
codebase=, maybe more.  Maybe the new W3C Unicorn validator
will support RELAX (?)

Less than 40 hours after writing a first DTD I'm not ready
to throw it away.  After all it does something useful, now
all here can check cross-references in registries with gawk
and the online validator.  With almost 640 KB the 4645bis
registry is a bit too large for manual plausibility checks.

Frank

P.S.:  I really proposed CharMapML for a new charset registry

---

From: Martin Duerst <[email-masked]>
Date: Tue, 19 Sep 2006 18:26:40 +0900

Hello Stephane,

I have explicitly not said that the discussion of an
alternative XML format should be moved off the list,
because I, too, think that it is valuable to have
such discussions. I have just asked that they be
marked with [OT] to help people who are overwhelmed
by the number of mails.

Regards,    Martin.

>list, "ltru-implementors" but I would regard this as useless

#-#-#  Martin J. Du"rst, Assoc. Professor, Aoyama Gakuin University
#-#-#  http://www.sw.it.aoyama.ac.jp       mailto:[email-masked]

---

From: Frank Ellermann <[email-masked]>
Date: Tue, 19 Sep 2006 11:48:19 +0200

Martin Duerst wrote:

> I have just asked that they be marked with [OT] to help
> people who are overwhelmed by the number of mails.

Oops, that wasn't clear for me.  Different net cultures
with different netiquettes - the subject tag [OT] often
implies "ought to be moved to another group or list or
private mail a.s.a.p.".  I've heard that it used to have
your intended meaning in MAUSNET.

Frank