Subject: RE: [Ltru] Errors in prototype 4646bis Registry

From: Peter Constable <[email-masked]>
Date: Mon, 16 Oct 2006 10:25:08 -0700

Re the duplicate "Dimli", it would seem reasonable to me to employ the same mechanism that 639-3 uses: "Dimli (macrolanguage)".

Peter

-----Original Message-----
From: Doug Ewell [mailto:[email-masked]] 
Sent: Tuesday, September 19, 2006 9:58 PM
To: LTRU Working Group
Subject: [Ltru] Errors in prototype 4646bis Registry

There are two problems in the prototype RFC 4646bis Registry I posted a 
few days ago.

The first problem is an extra trailing space-and-asterisk in 13 
Description fields, for the language subtag records that have an extlang 
with the same name.  The group agreed (I think) not to change any 
existing names, although that means we will have (for example) a 
language subtag called "Konkani" and "Konkani (macrolanguage)" and an 
extlang also called "Konkani".  I marked these 13 cases with an asterisk 
so they could be easily removed (or retained) after the decision was 
made, and forgot to rip out the asterisks before posting.

The second problem runs a bit deeper.  ISO 639-2 just added a new code 
element "zza" with six names, one of which is "Dimli".  ISO 639-3 has a 
code element "diq" with the name "Dimli".  If both of these are admitted 
into the Registry, there will be two subtags of the *same type* with the 
same Description.  No matter what anyone says about retaining the 
"official" ISO names, that is not a tolerable situation.

Peter indicated on ietf-languages that the ISO 639 JAC would decide what 
to do about this in due course, but until they do, I need to know what 
to do with the Registry.  I'll post an updated version when a decision 
is reached.

--
Doug Ewell
Fullerton, California, USA
http://users.adelphia.net/~dewell/
RFC 4645  *  UTN #14

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru
_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Kent Karlsson" <[email-masked]>
Date: Mon, 16 Oct 2006 21:40:33 +0200

I still very much dislike a parenthetical "(macrolanguage)" (or "(collection)"
if that is the case, or "(individual)") in a name. "Dimli languages" maybe, or
use an alternate name for the "macrolanguage" if one of the alternatives
already refer more to the "macrolanguage" (Zaza?) than the others, or
similar would be preferable. (But ok, not for LTRU to decide.)

NOBODY except those familiar (to some extent) with 639-3 would even use
the terms "macrolanguage", "individual language", or "language collection".
That's why I dislike seeing those (or similar) terms in language "names".

W.r.t. the new zza code, not only is there already a "Dimli" in the draft 639-3
list (code diq), there is also a "Kirmanjki" (code kiu), *both* of which are
listed among the alternate names for the new zza code (Zaza; Dimili; Dimli;
Kirdki; Kirmanjki; Zazaki).

	/kent k

> From: Peter Constable [mailto:[email-masked]] 
> Sent: Monday, October 16, 2006 7:25 PM
> To: Doug Ewell; LTRU Working Group
> Subject: RE: [Ltru] Errors in prototype 4646bis Registry
> 
> 
> Re the duplicate "Dimli", it would seem reasonable to me to 
> employ the same mechanism that 639-3 uses: "Dimli (macrolanguage)".
> 
> 
> Peter
> 
>

---

From: Peter Constable <[email-masked]>
Date: Mon, 16 Oct 2006 13:46:35 -0700

"Dimli langauges" conveys that the entry is a collection and hence would be misleading and inappropriate. If there were an alternate name for the macrolanguage, that would be used, but that might not always be the case.

I don't particularly like these myself, but we felt it was necessary to make sure the name values are unique: if that value is the primary indicator of the distinct denotation for any given entry, then they need to be distinct.

Note that what is in the draft code table is still just that: draft. It may be that some of the uses of "(macrolanguage)" and "(individual language)" will disappear before publication.

Peter

-----Original Message-----
From: Kent Karlsson [mailto:[email-masked]] 
Sent: Monday, October 16, 2006 12:41 PM
To: 'LTRU Working Group'
Subject: RE: [Ltru] Errors in prototype 4646bis Registry

	/kent k