Subject: Re: [Ltru] Submission: draft-ietf-ltru-4645bis-00

From: Addison Phillips <[email-masked]>
Date: Mon, 02 Oct 2006 08:49:07 -0700

Martin Duerst wrote:
> 
> One point I'm wondering are registrations accepted on ietf-languages between the
> final internet draft and the point in time when IANA does the update.

Already thought of it.

See:

http://www.inter-locale.com/ID/draft-ietf-ltru-4646bis-01alpha.html#ianaconversion

Addison

-- 
Addison Phillips
Globalization Architect -- Yahoo! Inc.

Internationalization is an architecture.
It is not a feature.

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Martin Duerst <[email-masked]>
Date: Tue, 03 Oct 2006 14:31:37 +0900

This, as far as I'm concerned, covers some of the issue with the
sentence:

    "Registrations that are in process under the rules defined in [RFC4646]
     when this document is adopted MUST be completed under the rules
     contained in this document."

But what I'm concerned about are not Registrations that are in process
(e.g. submitted to ietf-languages but not approved yet, or sent
over to IANA but not yet in the registry,...), but Registrations
that have been completed and are in the Registry, but have not been
considered for the latest draft of rfc4645bis.

Regards,    Martin.

> http://www.inter-locale.com/ID/draft-ietf-ltru-4646bis-01alpha.html#ianaconversion

#-#-#  Martin J. Du"rst, Assoc. Professor, Aoyama Gakuin University
#-#-#  http://www.sw.it.aoyama.ac.jp       mailto:[email-masked]

---

From: Martin Duerst <[email-masked]>
Date: Tue, 03 Oct 2006 14:31:37 +0900

Regards,    Martin.

---

From: "Doug Ewell" <[email-masked]>
Date: Tue, 3 Oct 2006 00:14:49 -0700

Martin Duerst <duerst at it dot aoyama dot ac dot jp> wrote:

> (e.g. submitted to ietf-languages but not approved yet, or sent over 
> to IANA but not yet in the registry,...), but Registrations that have 
> been completed and are in the Registry, but have not been considered 
> for the latest draft of rfc4645bis.

That is my concern as well.  I have no solution except:

1.  ask IETF's and IESG's indulgence in allowing minor updates to the 
draft during LC to account for such changes

2.  ask ietf-languages' indulgence in imposing a brief moratorium on 
optional registrations during that time

3.  pray that the ISO MAs are on holiday during that time

4.  pray for a speedy trip through LC and the RFC Editor queue

As you might guess, items 3 and 4 which require divine intervention have 
me the most concerned.

--
Doug Ewell  *  Fullerton, California, USA  *  RFC 4645  *  UTN #14
http://users.adelphia.net/~dewell/
http://www1.ietf.org/html.charters/ltru-charter.html
http://www.alvestrand.no/mailman/listinfo/ietf-languages

---

From: Martin Duerst <[email-masked]>
Date: Tue, 03 Oct 2006 19:31:53 +0900

I see the following two solutions:

a) Have registration discussions proceed, but put the actual
   updates on hold.

b) Have updates proceed, but when 4645bis is approved, do a global
   replace and then redo the updates, more or less in bulk fashion
   (i.e. there is no material discussion anymore, just a check
    of field values to make sure the stuff fits with the new
    registry.)

For a), the problem is that we have to tell ietf-languages and
IANA before 4645bis is approved, which raises the question of
what will happen in case it's not approved, and with what
right we would stop updates.

For b), the problem is that the registry is not progressing
in a linear fashion, which is against our stability guarantees.

I could immagine a variant of b), as follows:

c) Updates proceed. Once 4645bis is approved, the ietf-languages
   list discusses how express the updates they have made since
   the last version of the 4645bis draft as an addition to that
   draft. This addition is then sent to IANA, which combines
   them with the draft before publication.

Regards,    Martin.

At 16:14 06/10/03, Doug Ewell wrote:
>> But what I'm concerned about are not Registrations that are in process (e.g. submitted to ietf-languages but not approved yet, or sent over to IANA but not yet in the registry,...), but Registrjp

---

From: Martin Duerst <[email-masked]>
Date: Tue, 03 Oct 2006 19:31:53 +0900

Regards,    Martin.

At 16:14 06/10/03, Doug Ewell wrote:
>> But what I'm concerned about are not Registrations that are in process (e.g. submitted to ietf-languages but not approved yet, or sent over to IANA but not yet in the registry,...), but Registrations that have been completed and are in the Registry, but have not been considered for the latest draft of rfc4645bis.
>
>1.  ask IETF's and IESG's indulgence in allowing minor updates to the draft during LC to account for such changes
>
>2.  ask ietf-languages' indulgence in imposing a brief moratorium on optional registrations during that time
>
>As you might guess, items 3 and 4 which require divine intervention have me the most concerned.
>
>--

ations that have been completed and are in the Registry, but have not been considered for the latest draft of rfc4645bis.
>1.  ask IETF's and IESG's indulgence in allowing minor updates to the draft during LC to account for such changes
>
>2.  ask ietf-languages' indulgence in imposing a brief moratorium on optional registrations during that time
>
>As you might guess, items 3 and 4 which require divine intervention have me the most concerned.
>
>--