Subject: RE: [Ltru] Re: Proposal: include new "Language-Type:" field

From: "McDonald, Ira" <[email-masked]>
Date: Mon, 9 Oct 2006 14:52:08 -0700

Hi,

How about attacking this proposal based on facts, rather than
unrelated topics or grumpiness (not in good taste, Marion)?

draft-ietf-ltru-4646bis-00.txt gives advice based on the type
of the ISO 639-3 language code.  What possible reason is
there to say "that's the problem of the user to research",
when it's fundamental to the rationale behind every code
in ISO 639-3?

Cheers,
- Ira

Ira McDonald (Musician / Software Architect)
Blue Roof Music / High North Inc
PO Box 221  Grand Marais, MI  49839
phone: +1-906-494-2434
email: [email-masked] 

-----Original Message-----
From: Mark Davis [mailto:[email-masked]]
Sent: Monday, October 09, 2006 11:08 AM
To: Stephane Bortzmeyer
Cc: [email-masked]
Subject: Re: [Ltru] Re: Proposal: include new "Language-Type:" field

-1

I think this is outside of the scope of the registry. Where will this stop?
Population of languages? Geographic area spoken? Population density? .....

The purpose of the registry is to distinguish one language from another. No
more, no less. 

Mark

On 10/9/06, Stephane Bortzmeyer <[email-masked]> wrote:
On Wed, Oct 04, 2006 at 09:42:00AM -0400,
John Cowan <[email-masked]> wrote
a message of 72 lines which said:

> A proposal:

+1

> The 4646bis registry should capture the language type information 
> from ISO 639-3.  Each language, including macrolanguages, is labeled
> in -3 as either living, extinct, ancient, historic, or constructed.

I think the more information, the better (*), IF AND ONLY IF: 

** this new information does not require a new source when building
the registry, (because such a new source would complicate the building
process and would add one more dependency, would add one more standard 
to track, etc),

** this new tag does not bother the existing parsers.

To me, this proposal comply with these two rules, so I agree with.

(*) : I let the UI people decide if this is useful for the specific 
issue of trimming the language list ; but, even if they do not use it,
others may be.

_______________________________________________
Ltru mailing list
[email-masked] 
https://www1.ietf.org/mailman/listinfo/ltru

-- 
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.407 / Virus Database: 268.13.1/466 - Release Date: 10/7/2006

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Addison Phillips <[email-masked]>
Date: Mon, 09 Oct 2006 16:21:36 -0700

> when it's fundamental to the rationale behind every code

Upon further review, I find that I'm more of Mark's persuasion. John's 
proposal appeared, at first, to me to provide some way to distinguish 
"collective" languages and "macro-languages", but, in fact, it only 
distinguishes the former and not the latter. It then goes on to 
distinguish a number of other language characteristics (most of which 
are inherent in the language itself: users of the respective languages 
know that Middle English is "ancient" or "extinct", or that Klingon is 
constructed)

At present, it would be useful to identify which language codes are 
macro-languages, i.e. which ones can "bear" an extlang (and which ones 
cannot) and reflect that in the registry.

The information about extinct, ancient, historic, or constructedness of 
languages is "interesting", but not really necessary to the functions of 
the registry. The ILSR is not a replacement for ISO 639.

I would support John's proposal fully if and only if it distinguished 
collective and macro languages for use in the registration process.

Otherwise, as written:

    -1

Addison

-- 
Addison Phillips
Globalization Architect -- Yahoo! Inc.

Internationalization is an architecture.
It is not a feature.

---

From: John Cowan <[email-masked]>
Date: Mon, 9 Oct 2006 23:14:07 -0400

Addison Phillips scripsit:

> I would support John's proposal fully if and only if it 
> distinguished collective and macro languages for use in the 
> registration process.

I have no problem with adding "macrolanguage" as an additional
type; it's a fine idea.  The information is technically redundant
(a language is a macrolanguage if and only if it appears in the
Prefix field of an extlang), but handy to have on the spot.

-- 
Take two turkeys, one goose, four               John Cowan
cabbages, but no duck, and mix them             http://www.ccil.org/~cowan
together. After one taste, you'll duck          [email-masked]
soup the rest of your life.
        --Groucho

---

From: Peter Constable <[email-masked]>
Date: Mon, 9 Oct 2006 22:55:11 -0700

-----Original Message-----
From: Addison Phillips [mailto:[email-masked]] 

> distinguishes the former and not the latter.

I kind of expect you'll see these attributes carried over into other parts of ISO 639 in the future.

> It then goes on to 

But that's not the only point. If someone is looking at an entry "Foo" and trying to figure out if it's referring to the same language they know as "Phu", which is spoken in New Phuinea, seeing that it's type is Constructed (say), or Ancient (say) would give them a strong clue that it's not.

> collective and macro languages for use in the registration process.

I certainly think we should identify categories with both of these scopes clearly.

Peter Constable

---

From: Marion Gunn <[email-masked]>
Date: Tue, 10 Oct 2006 09:31:24 +0000

On 9 Oct 2006, at 21:52, scríobh McDonald, Ira:

> unrelated topics or grumpiness...

Dismiss it as Monday grumps, if you will.:-)

On 9 Oct 2006, at 23:21, scríobh Addison Phillips:
>
> Upon further review, I find that I'm more of Mark's persuasion.  
> John's proposal appeared, at first, to me to provide some way to  
> distinguish "collective" languages and "macro-languages", but, in  
> fact, it only distinguishes the former and not the latter...
>
> The information about extinct, ancient, historic, or  
> constructedness of languages is "interesting", but not really  
> necessary to the functions of the registry. The ILSR is not a  
> replacement for ISO 639.

Exactly.

On 10 Oct 2006, at 06:51, scríobh Doug Ewell:
> ...
> The proposal requires only what is present in the existing ISO/FDIS  
> 639-3 data files.

It came across to me as a proposal to push closure further away by  
moving the goalposts (in ISO parlance, by changing the agreed scope),  
but if enough people think otherwise, then work away, if time  
permits, with my blessing.
mg

- -
Marion Gunn * EGTeo (Estab.1991)
27 Páirc an Fhéithlinn, Baile an
Bhóthair, Co. Átha Cliath, Éire.
* [email-masked] * [email-masked] *

---

From: Frank Ellermann <[email-masked]>
Date: Tue, 10 Oct 2006 15:00:11 +0200

Peter Constable wrote:
 
> that's not the only point. If someone is looking at an entry "Foo"
> and trying to figure out if it's referring to the same language they
> know as "Phu", which is spoken in New Phuinea, seeing that it's type
> is Constructed (say), or Ancient (say) would give them a strong clue
> that it's not.

That's the job of a comment or description.  For "orq" I found that it
is "colloquial blackspeech" spoken in "no man's land".  Now does that
cover Yrch as spoken by the Uruk Hai in Morannon or not, and why would
anybody look into a IANA registry for such details ?

Maybe "orq" should get Shavian as Suppress-Script and proclaim Sealand
as their micronation.  Seriously, does 639-3 allow to register almost
anything ?  What's the justification to list "orq" except from the fun
aspect ?

Frank

---

From: Peter Constable <[email-masked]>
Date: Tue, 10 Oct 2006 08:25:23 -0700

One can read all my thoughts on this that have been published elsewhere (see http://www.sil.org/silewp/2000/001/). It takes encyclopaedic information to determine with certainty the denotation of a language identifier. But a standard like ISO 639 doesn't have means to provide encyclopaedic information; it just has a table consisting of entries with an ID and one or more names. In 639-3, we extended that with two additional pieces of info, scope and type, in order to help clarify what the intended denotation is for each identifier. That's all I was saying.

Now, we could add comments to entries in the LSR to clarify their denotation. Some questions are immediately raised, though: What should the source for comments be? What determines when comments are added? The source standard isn't going to provide answers to the first question unless what is being added are type or scope values, and John's proposal answers the second by saying, "It's done consistently for all; we don't cherry pick."

I'm not saying I think the type info is needed; I am inclined to think it would be good to include the scope values, though. And as for the source not identifying collections, actually it does: every alpha-3 in 639-2 that is not in 639-3 is a collection.

Peter

> From: Frank Ellermann [mailto:[email-masked]]
> Sent: Tuesday, October 10, 2006 6:00 AM
> To: [email-masked]
> Subject: [Ltru] Is 639-3 bogus ? (was: Proposal: include new"Language-Type:" field)
> 
> Peter Constable wrote:
>

---

From: Addison Phillips <[email-masked]>
Date: Tue, 10 Oct 2006 08:37:34 -0700

Peter Constable wrote:
> 
> I'm not saying I think the type info is needed; 
 > I am inclined to think it would be good to include
 > the scope values, though. And as for the source not
 > identifying collections, actually it does: every
 > alpha-3 in 639-2 that is not in 639-3 is a collection.
> 

The LSR doesn't indicate which alpha3 codes are ISO 639-2 vs. ISO 639-3, 
so collections won't be clear in the registry unless we label them 
somehow, which this proposal does provide. On the other hand, 
"collection" codes are just language subtags that someone may choose or not.

I was hoping that 639-3 would provide the information on what is or is 
not considered a macro-language. But this information isn't it.

I'm against replicating information just to replicate it. It would be 
simpler and more efficient to provide a link to ISO 639-3 and point out 
that there is more information there. Oh. Wait. We already do that. ;-)

Addison

---

From: Frank Ellermann <[email-masked]>
Date: Tue, 10 Oct 2006 18:35:53 +0200

Peter Constable wrote:

> One can read all my thoughts on this that have been published
> elsewhere (see http://www.sil.org/silewp/2000/001/).

That doesn't explain "orq".  And the ethnologue site claims that
"orq" is no SIL code.  So how did it get added to a 639-3 draft ?

There must be some procedure, and if that procedure is broken it
needs to be fixed before nonsense is added to a registry designed
for stability.  There's no way to get rid of "orq" later, at best
it could be deprecated.

Of course one "orq" is harmless and not worse than say "tlh", but
if that's only the tip of an iceberg spammers and criminals will
abuse it as fast as 1-2-3 to create their virtual "Cesidian root"
or "Dominion of Melchizedek" realities.

We can't have IANA servers confiscated in criminal investigations
about DOM.  

Frank

---

From: John Cowan <[email-masked]>
Date: Tue, 10 Oct 2006 14:22:39 -0400

Addison Phillips scripsit:

> I was hoping that 639-3 would provide the information on what is 
> or is not considered a macro-language. But this information isn't 
> it.

"Scope" means "individual language or macrolanguage".  You can
deduce from the registry which are which; a macrolanguage is one
that appears as the Prefix of some extlangs.

But I'm not against including this information at all.

-- 
John Cowan    http://ccil.org/~cowan    [email-masked]
[T]here is a Darwinian explanation for the refusal to accept Darwin.
Given the very pessimistic conclusions about moral purpose to which his
theory drives us, and given the importance of a sense of moral purpose
in helping us cope with life, a refusal to believe Darwin's theory may
have important survival value. --Ian Johnston

---

From: John Cowan <[email-masked]>
Date: Tue, 10 Oct 2006 14:24:31 -0400

> "orq" is no SIL code.  So how did it get added to a 639-3 draft ?

Conlangs come from Language List.  If you go to
http://www.sil.org/iso639-3/documentation.asp?id=orq you can
see the link to the LL page.

That said, I think "orq" doesn't belong there: not a single
word is extant.

-- 
I don't know half of you half as well           John Cowan
as I should like, and I like less than half     [email-masked]
of you half as well as you deserve.             http://www.ccil.org/~cowan
        --Bilbo

---

From: Peter Constable <[email-masked]>
Date: Tue, 10 Oct 2006 11:46:17 -0700

ISO 639-3 is very clear about which items are macrolanguages: it is clear both from the normative scope attribute and from the macrolanguage mapping table.

Peter

-----Original Message-----
From: Addison Phillips [mailto:[email-masked]] 
Sent: Tuesday, October 10, 2006 8:38 AM
To: Peter Constable
Cc: [email-masked]
Subject: Re: [Ltru] Is 639-3 bogus ? (was: Proposal: include new"Language-Type:" field)

Addison

---

From: Peter Constable <[email-masked]>
Date: Tue, 10 Oct 2006 11:51:04 -0700

Whatever on earth does the source of orq in the draft table for 639-3
have to do with how the type attribute of entries in 639-3 are useful?
What point are you getting at? (I really haven't a clue.)

Peter

-----Original Message-----
From: Frank Ellermann [mailto:[email-masked]] 
Sent: Tuesday, October 10, 2006 9:36 AM
To: [email-masked]
Subject: [Ltru] Re: Is 639-3 bogus ?

Frank

---

From: Frank Ellermann <[email-masked]>
Date: Tue, 10 Oct 2006 20:49:34 +0200

> see the link to the LL page.

Yes, I found that yesterday, that's where it says "No man's land"
and "Colloquial blackspeech".
 
> I think "orq" doesn't belong there: not a single word is extant.

<http://www.cs.rice.edu/~ssiyer/minstrels/poems/257.html> says:

| The following is an excerpt from a Tolkien Linguistics site:

| Our sole example of pure Black Speech, then, is the inscription on the
| Ring: Ash nazg durbatulûk, ash nazg gimbatul, ash nazg thrakatulûk agh
| burzum-ishi krimpatul. "One Ring to rule them all, One Ring to find them,
| One Ring to bring them all and in the Darkness bind them." (LotR1/II ch.
| 2) Nazg is "ring", also seen in Nazgûl "Ring-wraith(s)". Ash is the number
| "one", agh is the conjuction "and", disturbingly similar to Scandinavian
| og, och. Burzum is "darkness", evidently incorporating the same element
| búrz, burz- "dark" as in Lugbúrz "Tower-dark", the Black Speech name that
| Sindarin Barad-dûr translates. Hence, the -um of burzum must be an
| abstract suffix like the "-ness" of the corresponding English word
| "darkness". Burzum has a suffix ishi "in". In the transcription it is
| separated from burzum by a hyphen, but there is nothing corresponding in
| the Tengwar inscription on the Ring, so this may be considered either a
| postposition or a locative ending. (It is remarkably similar to Quenya
| -ssë and may support the theory advanced by Robert Foster in his Complete
| Guide to Middle-earth, that the Black Speech was to some extent based on
| Quenya and a perversion of it. The element burz- "dark" is also vaguely
| similar to the Elvish stem for "black", MOR.) Though burzum-ishi is
| translated "in the darkness", there does not seem to be anything
| corresponding to the article "the", unless it is somehow incorporated in
| ishi. But the evidence is that the Black Speech does not mark the
| distinction between definite and indefinite nouns; see below.

For more on that see <http://www.uib.no/People/hnohf/orkish.htm>, I miss
"Yrch" on that page, otherwise it's apparently complete, about 30 words.

The IANA registry cannot list all made-up languages with about 30 words,
for some time any decent science fiction had a glossary with words in
some made-up language(s).  And 26*26*26 is far too limited to waste it
for such constructs in 639.

Frank

---

From: Frank Ellermann <[email-masked]>
Date: Tue, 10 Oct 2006 21:13:05 +0200

> What point are you getting at? (I really haven't a clue.)

How reliable and useful is the info, and should the registry
contain a source indication for alpha-3 language subtags if
there are major differences between 639-2 and 639-3.  Maybe
it's possible to delete "orq" from 639-3 later, but it's not
possible to remove it from the LSR.

The guarantee in RFC 4646 2.2.1 covers only 639-2 and 639-1,
not 639-3.  If "orq" could be _reassigned_ we've dropped the
ball.  I think the statement in 2.2.1 needs to be extended
to cover ISO 639-3 like it covers 639-2 today.

For that I'd propose that we request an official statement
to be added to 4646bis (replacing the old 3066 statement).

Frank

---

From: Addison Phillips <[email-masked]>
Date: Tue, 10 Oct 2006 12:35:44 -0700

> that appears as the Prefix of some extlangs.

What I was looking for was:

   http://www.sil.org/iso639%2D3/macrolanguages.asp

And:

   http://www.sil.org/iso639%2D3/scope.asp#M

Ideally, extended language subtags would be restricted to the list in 
the first link above and 4646bis would reflect that fact. I don't want 
to construct that list from the registry: I would prefer something much 
more cut-and-dried, i.e. getting it from ISO 639-3.

I can see at least one problem with the macro languages list: there are 
at least some languages (the "Serbo-Croatian" family) that will be 
grandfathered into language subtags rather than extlangs.

Now, all that said, I think it would be useful to include a "type" field 
for "collective" languages (with the warnings about their suitability 
proposed by John) and for "macro" languages (defining what can be used 
as a prefix value in an extlang).

However, I can also see that this information does not necessarily need 
to occur in the registry.

Addison

---

From: Peter Constable <[email-masked]>
Date: Tue, 10 Oct 2006 13:50:11 -0700

How reliable and useful in what sense? Is it reliable that orq denotes
Orcish? Modulo that the published table is a *draft* code table, yes. Is
it reliable that orq denotes an individual, constructed language? Yes.
Is it useful to know that orq is an individual, constructed language and
that that language is Orcish? Yes. Is it useful to have an entry for orq
in the first place? That depends on the user, just as it does for all
the other 7000+ entries.

Again, what is the point of these questions? (And explain to me how this
is not a random attack on 639-3, since that is certainly how it appears
to me.)

Items in 639-3 will never be deleted, nor will they be reassigned. It
has a fairly strict stability policy. If this WG feels that is
inadequate for RFC 4646bis, then we can revise 2.2.1 to say whatever we
think is needed.

Peter

-----Original Message-----
From: Frank Ellermann [mailto:[email-masked]] 
Sent: Tuesday, October 10, 2006 12:13 PM
To: [email-masked]
Subject: [Ltru] Re: Is 639-3 bogus ?

Frank

---

From: Peter Constable <[email-masked]>
Date: Tue, 10 Oct 2006 14:15:35 -0700

In ISO 639-3 terms "collection" is a scope, not a type.

_Scope_ refers to how broad is the range of linguistic varieties encompassed in the denotation of an ID, with four possible values considered in 639-3: individual language, macrolanguage, collection and special purpose. (A fifth value, dialect, might be relevant to another part of ISO 639.) The scope attribute is a normative attribute in ISO 639-3.

_Type_ refers to the currency and genetic nature of the language: living, (recently) extinct, historic (precursor of a modern language), ancient (went extinct in non-recent past), constructed. Entries with a special-purpose scope do not have a type value. Type is an informative attribute.

The scope attribute is directly relevant to the LSR if (i) macro-language scope of an ID is relevant for contructing tags with extlang subtags, and if (ii) use if collection or special-purpose IDs is in any way discouraged.

Peter

-----Original Message-----
From: Addison Phillips [mailto:[email-masked]] 
Sent: Tuesday, October 10, 2006 12:36 PM
To: John Cowan
Cc: [email-masked]
Subject: Re: [Ltru] Is 639-3 bogus ?

And:

Addison

---

From: Frank Ellermann <[email-masked]>
Date: Tue, 10 Oct 2006 23:59:27 +0200

Peter Constable wrote:

> Is it useful to know that orq is an individual, constructed language
> and that that language is Orcish? Yes.

alpha-3 is a finite set, if any language of 30 words gets its own code
639-3 is in trouble, and the subtag registry with it.

> Again, what is the point of these questions?

Protecting the subtag registry from bogus entries while it's on a one
way street (nothing ever removed) with a known end (26*26*26).

> And explain to me how this is not a random attack on 639-3, since
> that is certainly how it appears to me.

Of course it's a random attack, I looked into the source, because John
proposed to preserve its Language-Type info, and the "C" attracted my
attention.  There are not many "C", and "orq" is one, and as it happens
I thought (yesterday) I know what "orq" is about.  And today I'm sure.

I can't judge anything else, e.g. why "bet" offers Béte and "bev" Bété,
it could be a typo, it could as well be completely unrelated languages.

The source for the draft is Latin-1 (another detail I didn't know, and
I checked that it's really Latin-1 and not windows-1252).  In some
cases like "aue" =/Kx'au//'ein or "gnk" //Gana I'm not sure if that's
as it should be, it appears to be odd.  Or maybe "//" has a well-known
meaning, and I just don't know what it is.

> we can revise 2.2.1 to say whatever we think is needed.

What the quoted promise already says just adding ISO 639-3 would do it.

Frank

---

From: John Cowan <[email-masked]>
Date: Tue, 10 Oct 2006 21:32:31 -0400

> > I think "orq" doesn't belong there: not a single word is extant.

Well, checking, there is no code for classical Black Speech (spoken
by the Ringwraiths and by Sauron himself), so presumably "orq"
is meant to cover both.  There is a poem in classical Black Speech,
the Ringverse ("ash nazg durbatuluk" etc.), so it marginally counts
as having "a literature", the requirement for conlangs to appear
in 639-3.

> "Yrch" on that page, otherwise it's apparently complete, about 30 words.

"Yrch" is in fact the Sindarin word for "orcs", the plural of "orch";
not Black Speech at all.

> for such constructs in 639.

I agree in general.

> way street (nothing ever removed) with a known end (26*26*26).

I have to agree.  What's the right procedure for getting conlangs removed
from the list, Peter?  639/RA-JAC?  Anthony Aristar?  I think Orkish,
Delason, Jakelimotu, Linga, and perhaps Tceqli (aka Ceqli) should be
removed.  The last four are essentially private languages, and all but
Orkish and Tceqli don't even have a live Web presence, just dead pages.

> I can't judge anything else, e.g. why "bet" offers BÃ©te and "bev" BÃ©tÃ©,

They are in fact very closely related languages, belonging to the Bete
family (no accents).  Beyond that I can't say.

> meaning, and I just don't know what it is.

/, //, and ! are letters representing various clicks in languages of
South Africa and Namibia.

-- 
John Cowan    [email-masked]    http://ccil.org/~cowan
If a traveler were informed that such a man [as Lord John Russell] was
leader of the House of Commons, he may well begin to comprehend how the
Egyptians worshiped an insect.  --Benjamin Disraeli

---

From: Peter Constable <[email-masked]>
Date: Tue, 10 Oct 2006 18:42:59 -0700

Can I suggest that, next time, it would help if you stated clearly at the outset what your concerns are. It's taken me several rounds going back and forth with you to drag out what it is you're going on about.

Re entries in the 639-3 draft code table for ancient and constructed languages, the Linguist List was the source for those, and presumably they had a reason why each of these was deemed to have a need. If you have a question about the usefulness of orq or any other entry, you can contact Anthony Aristar or Debbie Anderson.

Re the characters used in the names, the source for the large inventory of entries of modern and recently-extinct languages came from a database that has a history going back several decades. By the time 639-3 is published, some of the spellings may be revised, or some may be revised over the life of maintenance for the code set. It was not considered a prerequisite to normalize the spellings to conform to any particular expectations prior to initial publication.

If you see two entries -- two distinct IDs -- then the language varieties denoted are deemed to be distinct languages. The fact that they have similar spellings is coincidental. The language names connected with "byj" and "bmn" are even more similar than the pair you cited; that doesn't mean that the entries are suspect.

The source for the majority of new entries in 639-3 has been published for many years -- it's in its fifteenth edition -- and has been widely used and reviewed by linguists throughout the world. 

IMO, there's no particular reason for members of this WG to be second guessing whether the content of ISO 639-3 is good enough for use in the LSR.

Going back to where this started, you responded to comments I made about how the type information in 639-3 may be useful to a user. "That's the job of a comment or description," you said. It's still not clear to me if you had a comment to make wrt John's proposal or not.

Peter

-----Original Message-----
From: Frank Ellermann [mailto:[email-masked]] 
Sent: Tuesday, October 10, 2006 2:59 PM
To: [email-masked]
Subject: [Ltru] Re: Is 639-3 bogus ?

Frank

---

From: Peter Constable <[email-masked]>
Date: Tue, 10 Oct 2006 18:50:34 -0700

From: John Cowan [mailto:[email-masked]] 

> What's the right procedure for getting conlangs removed
> from the list, Peter?  639/RA-JAC?  Anthony Aristar?

If experts in constructed language feel there are entries in the draft
code table for 639-3 that do not warrant inclusion, it would probably be
best if they submitted feedback to Joan Spanne at the 639-3 RA
([email-masked]), and also to the relevant people connected with
Linguist List: Anthony Aristar ([email-masked]) and Debbie
Anderson ([email-masked]).

Peter

---

From: Peter Constable <[email-masked]>
Date: Tue, 10 Oct 2006 18:50:34 -0700

Peter

---

From: Frank Ellermann <[email-masked]>
Date: Wed, 11 Oct 2006 04:07:44 +0200

> "Yrch" is in fact the Sindarin word for "orcs", the plural of "orch";

Oops, I should read it again, I missed that, thanks.

>> In some cases like "aue" =/Kx'au//'ein or "gnk" //Gana I'm not sure
>> if that's as it should be, it appears to be odd.  Or maybe "//" has
>> a well-known meaning, and I just don't know what it is.
 
> South Africa and Namibia.

Is that ! related to u+01C3 ?  Then the others might be u+01C0..u+10C2.

Frank

---

From: Addison Phillips <[email-masked]>
Date: Tue, 10 Oct 2006 19:43:44 -0700

> Is that ! related to u+01C3 ?  Then the others might be u+01C0..u+10C2.

Exactly so. The Unicode characters represent the specific "click" 
characters from those languages and are distinct from the ASCII 
punctuation commonly used to transcribe those languages in the Latin script.

Addison

---

From: Frank Ellermann <[email-masked]>
Date: Wed, 11 Oct 2006 05:50:01 +0200

Peter Constable wrote:
 
> it would help if you stated clearly at the outset what your
> concerns are.

Protecting the registry from bogus subtags, a variation of
<URL:http://en.wikipedia.org/wiki/WP:NFT>

> If you have a question about the usefulness of orq or any 
> other entry, you can contact Anthony Aristar or Debbie Anderson.

From my POV John already answered that, "orq" doesn't make
much sense in an *_Internet_* registry of language subtags.

We'll see if it's removed from the final version, and can
pull the emergency break before an IETF Last Call.  If all
fails we could limit the bulk update to type "L", and allow 
individual registrations of subtags with other types under
the review of the language subtag list, or a similar rule.

> By the time 639-3 is published, some of the spellings may
> be revised

Maybe use Unicode for the descriptions, the reasons why we
didn't limit the registry to Latn (or even Latin-1) should
also be okay for the source standards.  

The Bété vs. Béte question is obvious if you try to sort the
source table by its "inverted name" column.

> If you see two entries -- two distinct IDs -- then the
> language varieties denoted are deemed to be distinct 
> languages.

Yes, that's clear, three languages bet, bev, and btg.  Maybe
two others byf and btt, with three variants of "bete" in the
description.  I stumbled over it because my default codepage
is not windows-1252 (and of course not Latin-1).

> that doesn't mean that the entries are suspect.

As I said I can't judge it, and you asked why I attacked the
one subtag I recognized (= "orq").

> there's no particular reason for members of this WG to be 
> second guessing whether the content of ISO 639-3 is good
> enough for use in the LSR.

IBTD.  If it appears to list "anything" it would hurt the
deployment of 4646bis.  If we ask folks to download 640 KB
the content has to be as good as possible.  

We're operating under a "get it right at the first attempt"
doctrine, we can't change our minds later and remove "orq".

> "That's the job of a comment or description," you said. 
> It's still not clear to me if you had a comment to make wrt
> John's proposal or not.

The "interesting" types A, C, E, H, and S (what's H ?) could
be added to the description, e.g.

Subtag: xzh
Description: Zhang-Zhung (A)

Or preserved as a comment:

Subtag: xzh
Description: Zhang-Zhung
Comment: Ancient

There are only 617 entries with "interesting" types, anything
else is L (living).  The scopes could be handled in the same
way, all 56 M are L, with that we would get at most one marker
per description or comment for now:  A, C, E, H, S, or M.

If later one of the Ms gets type E adding (M,E) to a description
(or saying Macrolanguage, Extinct in a comment) is no problem.

Changing the 4646 syntax adding a completely new field however
is IMNSHO a very bad idea.  We more or less promised that that
won't happen.

Frank

---

From: John Cowan <[email-masked]>
Date: Wed, 11 Oct 2006 00:01:58 -0400

Addison Phillips scripsit:

> the first link above and 4646bis would reflect that fact. 

Just so, except that "sgn" (not in 639-3) is treated as a macrolanguage
encompassing the sign languages, and an encompassed language that has
its own 639-2 or 639-1 tag is not converted to an extlang.

> grandfathered into language subtags rather than extlangs.

I'm not sure what you are calling for here: should Serbo-Croatian
be marked as a macrolanguage in the LSR or not?

-- 
John Cowan   http://ccil.org/~cowan    [email-masked]
In might the Feanorians / that swore the unforgotten oath
brought war into Arvernien / with burning and with broken troth.
and Elwing from her fastness dim / then cast her in the waters wide,
but like a mew was swiftly borne, / uplifted o'er the roaring tide.
        --the Earendillinwe

---

From: Peter Constable <[email-masked]>
Date: Tue, 10 Oct 2006 23:01:54 -0700

> deployment of 4646bis. 

May I suggest that if one is willing to read the FDIS text, it would be reasonably clear that it doesn't aim to list "anything".

> The "interesting" types A, C, E, H, and S (what's H ?) 

The type "historic" refers to historical precursors to modern languages; e.g. Middle English.

Peter

---

From: Martin Duerst <[email-masked]>
Date: Wed, 11 Oct 2006 10:57:48 +0900

Hello Peter,

The group was indeed discussing type and scope and so on, but
Frank made it clear that he was looking at something else by
changing the Subject (the specific term 'bogus' is in my opinion
a bit unfortunate).

In my personal view, Frank is asking some rather stretched,
but in some sense valid question: If entries such as orq,
with existing documented texts of 30 words overall, can get
into ISO 639-3 (draft), then what guarantee, if any, does
ISO 629-3 (and therefore our subtag registry) have against
denial of service attacks where people make up new languages
with a little bit of text?

I'm sure you have a good answer to this question, and I'm
looking forward to see it.

Regards,     Martin.

>I thought (yesterday) I know what "orq" is about.  And today I'm sure.

#-#-#  Martin J. Du"rst, Assoc. Professor, Aoyama Gakuin University
#-#-#  http://www.sw.it.aoyama.ac.jp       mailto:[email-masked]

---

From: Martin Duerst <[email-masked]>
Date: Wed, 11 Oct 2006 19:41:17 +0900

I think adding only the 'interesting' information, in the Description
or Comment field, would be a much more unobtrusive change to
which I could agree (although still not thrilled).

Reagrds,     Martin.

---

From: Martin Duerst <[email-masked]>
Date: Wed, 11 Oct 2006 10:57:48 +0900

Hello Peter,

Regards,     Martin.

---

From: Martin Duerst <[email-masked]>
Date: Wed, 11 Oct 2006 19:41:17 +0900

Reagrds,     Martin.

---

From: John Cowan <[email-masked]>
Date: Wed, 11 Oct 2006 11:43:21 -0400

Addison Phillips scripsit:

> - Serbo-Croatian marked as a macrolanguage.
> - Its constituent languages maintained as type 'language' and not 
> converted to type 'extlang'.

+1

-- 
John Cowan                              [email-masked]
            http://www.ccil.org/~cowan
Humpty Dump Dublin squeaks through his norse
                Humpty Dump Dublin hath a horrible vorse
But for all his kinks English / And his irismanx brogues
                Humpty Dump Dublin's grandada of all rogues.  --Cousin James

---

From: Addison Phillips <[email-masked]>
Date: Wed, 11 Oct 2006 08:31:12 -0700

> its own 639-2 or 639-1 tag is not converted to an extlang.

Yes.

Addison

---

From: Peter Constable <[email-masked]>
Date: Wed, 11 Oct 2006 09:10:53 -0700

Frank responded to a comment I made that was clearly to do with John's proposal, and he did NOT make clear IMO what his concern was until several msgs had been exchanged.

If there are concerns about questionable entries for constructed languages in the draft code table for 639-3, then it is perfectly reasonable (i) to ask a general question as to the criteria for inclusion of such languages or (ii) to submit feedback to the 639-3 RA regarding those entries. 

Frank did neither but rather launched into a vague critique of 639-3 with random potshots: I don't like this entry; those two entries have similar names so must be suspect... And he chose an inflammatory subject line. That's got about as much professionalism as someone saying any project Frank has worked on must be bogus just because they have an upset stomach and are cranky.

The answer to the general question, as John Cowan mentioned, is that there *are* criteria for inclusion and that not just *anything* is accepted. A constructed language must have a body of literature read by members of some community. Requests for an ID from people making up a few words will not be accepted.

Re the second, John Cowan submitted feedback to the RA, and it was agreed that those should not be included.

Peter

> From: Martin Duerst [mailto:[email-masked]]
> Sent: Tuesday, October 10, 2006 6:58 PM
> To: Frank Ellermann; [email-masked]
> Subject: Re: [Ltru] Re: Is 639-3 bogus ?
> 
> Hello Peter,
>