Subject: Re: [Ltru] Re: Suppress-Script batch 1

From: "Mark Davis" <[email-masked]>
Date: Sun, 1 Oct 2006 11:25:59 -0700

I'm all for expanding the guidance to avoid using inappropriate script (or
region, for that matter). I was never against addng more information about
the issue; just against making it a MUST (for the reasons I outlined
earlier).

Mark

On 9/30/06, [email-masked] <[email-masked] > wrote:
>
>
> "Mark Davis" <[email-masked]> wrote on 09/30/2006 12:49:55 PM:
>
> >
> > Let's not make up problems where they don't exist. I see no
> > groundswell, nor any realistic prospect of a groundswell, of people
> > tagging languages with unnecessary scripts.
>
> However, when it comes to tagging audiovisual content, I do see this quite
> frequently -- at least with Chinese language classification. (And I've
> analyzed audiovisual language data from many sources and studios.) The fault
> is not always an ill-informed classifier. Developers often advise against
> having separate or filtered language lists for spoken and written languages
> as they want to be able to do a basic query for all content in Mandarin or
> "Chinese" and don't quite understand the issue. "ISO doesn't make this
> distinction, why should we?"
>
> Or classifiers are stuck with a shrink-wrapped system architecture that
> assumes written content and a single language list. So when a classifier is
> faced with inappropriate choices for a dubbed or spoken work, they often
> choose a "scripted" form of Mandarin over suggesting a system redesign. It's
> not the role of the working group to design systems, but maybe giving this
> issue some attention might help developers who implement RFC 4646bis in
> systems that deal with both spoken and written language.
>
> Regards,
>
> Karen Broome
> Sony Pictures Entertainment
>
>
_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Martin Duerst <[email-masked]>
Date: Mon, 02 Oct 2006 17:37:24 +0900

+1, and very well explained, Doug!      Regards,   Martin.

At 04:46 06/10/01, Doug Ewell wrote:
>Mark Davis wrote:
>
>> "X is not necessary when X is not necessary" is never worth adding to a document, no matter what the X is.
>
>We are talking about "Don't use X when X is not necessary," which is not the same thing.  There are many situations, in computer applications and real life, when it is perfectly OK to do something that is not strictly necessary.  Sometimes it is even preferable for some security or verification reason.
>
>In the C or C++ or C# programming languages, I can write:
>
>if (x == 0)
>{
>    do_something();
>}
>else
>{
>    do_something_else();
>}
>
>or I can write the same thing without the curly braces.  There are certain reasons (stylistic or maintenance) why the version with "unnecessary" braces might be preferable.
>
>I don't see any harm in pointing out that script (and region) subtags do not fall into this category.
>
>--
>Doug Ewell  *  Fullerton, California, USA  *  RFC 4645  *  UTN #14
>http://users.adelphia.net/~dewell/
>http://www1.ietf.org/html.charters/ltru-charter.html
>http://www.alvestrand.no/mailman/listinfo/ietf-languages
>
>

#-#-#  Martin J. Du"rst, Assoc. Professor, Aoyama Gakuin University
#-#-#  http://www.sw.it.aoyama.ac.jp       mailto:[email-masked]