Subject: [Ltru] Forward-Compatibility Issue

From: "Mark Davis" <[email-masked]>
Date: Mon, 18 Dec 2006 13:33:20 -0800

>From a separate conversation, I suggest including the following text. It may
appear to be obvious, but I think helps to clarify the situation.

Future versions of the language subtag registry may add additional fields.
Parsers that are intended to be forward-compatible should ignore fields that
were not defined in the first of the language subtag registry that they were
designed to handle.

Mark
_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Addison Phillips <[email-masked]>
Date: Mon, 18 Dec 2006 13:48:30 -0800

That text doesn't quite parse......

I'm concerned that we make existing fields stable, if we're going to go 
down this path. Personally, I don't mind adding this text. I don't think 
we should add a field at this time, though.

Might I suggest this version of Mark's text:

--
Future versions of this document might add additional fields to the 
registry. Implementations SHOULD ignore fields found in the registry 
that are not defined in this document.
--

Addison

Mark Davis wrote:
>  >From a separate conversation, I suggest including the following text. 
> It may appear to be obvious, but I think helps to clarify the situation.
> 
> Future versions of the language subtag registry may add additional 
> fields. Parsers that are intended to be forward-compatible should ignore 
> fields that were not defined in the first of the language subtag 
> registry that they were designed to handle.
> 
> Mark
> 
> 
> ------------------------------------------------------------------------
> 

-- 
Addison Phillips
Globalization Architect -- Yahoo! Inc.

Internationalization is an architecture.
It is not a feature.

---

From: "Mark Davis" <[email-masked]>
Date: Mon, 18 Dec 2006 14:21:35 -0800

LGTM

Mark