Subject: [Ltru] ABNF woes...

From: Addison Phillips <[email-masked]>
Date: Wed, 07 Mar 2007 12:15:06 -0800

In preparing draft-03, I'm having some trouble with our ABNF. In 
particular, we changed this:

--
singleton     = %x41-57 / %x59-5A / %x61-77 / %x79-7A / DIGIT
               ; "a"-"w" / "y"-"z" / "A"-"W" / "Y"-"Z" / "0"-"9"
               ; Single letters: x/X is reserved for private use
--

to this:

--
singleton     = "a"-"w" / "y"-"z" / "0"-"9"
               ; Single alphanumerics; "x" reserved for private use
               ; NOTE: ABNF is case-insensitive
--

The theory was the ABNF is case-insensitive and this was much clearer 
than the old hex-heavy notation.

The problem is that the ABNF validator is unhappy with the new form and 
a close reading of RFC 4234 suggests that the new form is incorrect.

I'm reverting to the old form (with a correction of the comment from 
"letters" to "alphanumerics") unless someone has a good argument for why 
I can use string literals to form a range and still be "valid".

Addison

-- 
Addison Phillips
Globalization Architect -- Yahoo! Inc.
Chair -- W3C Internationalization Core WG

Internationalization is an architecture.
It is not a feature.

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Wed, 7 Mar 2007 23:08:04 +0100

On Wed, Mar 07, 2007 at 12:15:06PM -0800,
 Addison Phillips <[email-masked]> wrote 
 a message of 41 lines which said:

> The problem is that the ABNF validator is unhappy with the new form
> and a close reading of RFC 4234 suggests that the new form is
> incorrect.

Indeed, all the ABNF tools reject it. Sorry for not reporting the
mistake earlier.
 
> I'm reverting to the old form

OK