Subject: Re: [Ltru] Re: Test suite for language tags?

From: Martin Duerst <[email-masked]>
Date: Wed, 14 Mar 2007 18:44:20 +0900

Hello Mark,

I plan to publish my Ruby implementation of language tags
(well-formed only for the moment) soon, and plan to include
the file you mention below as part of the test suite that
goes with it. If there should be any problem with such a
publication, please tell me.

BTW, everybody, many thanks for all these tests.
And, before you ask, I'll post again to this list
when my implementation is published.

Regards,     Martin.

At 06:54 06/09/18, Mark Davis wrote:
>That's odd. Testing in Java on the file <http://unicode.org/cldr/data/tools/java/org/unicode/cldr/util/data/langtagTest.txt>http://unicode.org/cldr/data/tools/java/org/unicode/cldr/util/data/langtagTest.txt (which includes those cases) the only failures I get are the ones that repeat extensions (like en-a-bbb-a-ccc), which can't be tested for with regex. I don't think I'm using any regex syntax that differs between Java and Perl (there are very few instances). 
>
>Note: I added a number of mechanically generated items to the test file.
>
>Mark

#-#-#  Martin J. Du"rst, Assoc. Professor, Aoyama Gakuin University
#-#-#  http://www.sw.it.aoyama.ac.jp       mailto:[email-masked]     

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Wed, 14 Mar 2007 12:59:29 +0100

On Wed, Mar 14, 2007 at 06:44:20PM +0900,
 Martin Duerst <[email-masked]> wrote 

> BTW, everybody, many thanks for all these tests.

Using automatically generated tags is useful too:

#!/bin/sh

for i in `seq 1 1000`; do
   echo Test $i...
   tag=`abnfgen -s language-tag tests/langtag.abnf`
   YOUR-PROGRAM $tag > /dev/null
   if [ $? != 0 ]; then
       exit 1
   fi
done

---

From: "Mark Davis" <[email-masked]>
Date: Wed, 14 Mar 2007 09:09:39 -0700

No problem at all.

Mark

On 3/14/07, Martin Duerst <[email-masked]> wrote:
> >That's odd. Testing in Java on the file <
> http://unicode.org/cldr/data/tools/java/org/unicode/cldr/util/data/langtagTest.txt
> >
> http://unicode.org/cldr/data/tools/java/org/unicode/cldr/util/data/langtagTest.txt(which includes those cases) the only failures I get are the ones that
> repeat extensions (like en-a-bbb-a-ccc), which can't be tested for with
> regex. I don't think I'm using any regex syntax that differs between Java
> and Perl (there are very few instances).
> >

-- 
Mark