Subject: [Ltru] [[email-masked]: The Language Subtag Reviewer]

From: John Cowan <[email-masked]>
Date: Tue, 6 Mar 2007 11:31:27 -0500

The following message is being forwarded from [email-masked]
as a public service.

----- Forwarded message from Michael Everson <[email-masked]> -----

Date: Tue, 6 Mar 2007 16:17:19 +0100
To: IETF Languages Discussion <[email-masked]>
From: Michael Everson <[email-masked]>
Cc: 
Subject: The Language Subtag Reviewer

It has come to my attention that some people think I ought to be a 
member of the LTRU discussion list.

I do not have time for another high-volume e-mail list. It is 
difficult enough to deal with all the off-topic discussion on the 
IEFTLANG list. It certainly makes it hard to keep track of whether 
there is consensus on actual applications for subtags.

It has also come to my attention that the description of Language 
Subtag Reviewer's role and tasks is being discussed.

In my opinion, the LSR should be a team, including one person who 
knows about languages and linguistics, one person who deals with the 
formatting and protocol matters, and one person to own and moderate 
the discussion list.

We already have this in practice, namely the team of myself, Doug 
Ewell, and Harald Alvestrand.

That team works well as far as I can see.

This message can be conveyed to the LTRU list if someone thinks it 
appropriate.

-- 
Michael Everson * http://www.evertype.com
_______________________________________________
Ietf-languages mailing list
[email-masked]
http://www.alvestrand.no/mailman/listinfo/ietf-languages

----- End forwarded message -----

-- 
But you, Wormtongue, you have done what you could for your true master.  Some
reward you have earned at least.  Yet Saruman is apt to overlook his bargains.
I should advise you to go quickly and remind him, lest he forget your faithful
service.  --Gandalf             John Cowan <[email-masked]>

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Martin Duerst <[email-masked]>
Date: Tue, 13 Mar 2007 15:14:05 +0900

>The following message is being forwarded from [email-masked]

John - Thanks for forwarding.

>That team works well as far as I can see.

I see two problems here:
- Designing the spec to fit the current situation may work very
  well as long as the current situation stays as it is, but may
  break when the situation changes.
- The above proposal does not address the question of who ultimately
  is making the decisions of whether to accept a tag or not.
  Would that still be Michael, or would that change to a majority
  decision?

Regards,     Martin.

#-#-#  Martin J. Du"rst, Assoc. Professor, Aoyama Gakuin University
#-#-#  http://www.sw.it.aoyama.ac.jp       mailto:[email-masked]

---

From: Martin Duerst <[email-masked]>
Date: Tue, 13 Mar 2007 15:14:05 +0900

I see two problems here:

Regards,     Martin.

---

From: John Cowan <[email-masked]>
Date: Tue, 13 Mar 2007 23:02:14 -0400

>   break when the situation changes.

That's why I think the spec should hold the IESG-appointed LSR
accountable, but allow him to delegate any and all duties except
that of sending definitive adds and modifies to IANA.

>   Would that still be Michael, or would that change to a majority

Michael.

-- 
John Cowan          http://www.ccil.org/~cowan        [email-masked]
To say that Bilbo's breath was taken away is no description at all.  There are
no words left to express his staggerment, since Men changed the language that
they learned of elves in the days when all the world was wonderful. --The Hobbit

---

From: Peter Constable <[email-masked]>
Date: Tue, 13 Mar 2007 23:17:26 -0700

From: John Cowan [mailto:[email-masked]]

>>   Would that still be Michael, or would that change to a majority

Well, that appears to me to be a different understanding than I have gotten reading RFCs from 1766 on through 4646: it has always been my impression that the decision process was one of rough consensus (not necessarily unanimous, as happens in ISO and other SDOs), and that the role of the Reviewer was to monitor the discussion and evaluate whether consensus had been reached after the two-week period was up.

That's why I have always found it especially annoying when the Reviewer rejected a request for something like es-americas that everybody else was arguing was legitimate -- it seemed like the Reviewer was making a unilateral decision, which I perceived to be contrary to the intent of the RFC.

Peter

---

From: "Mark Davis" <[email-masked]>
Date: Tue, 13 Mar 2007 23:32:15 -0700

For me as well. And that's why we should make the issue clearer in the text.
At least one step is to have some clearly defined process for picking the
best candidate, instead of simply continuing by inertia.

The goal for the LSR should be to have the best person in that role, as I'm
sure that you all will agree. My proposal was to have a term of 2 years,
with candidates assessed as to to the degree that they are:

   1. Organized, responsive, and timely
   2. Polite and considerate; giving due consideration to all reasoned
   points of view
   3. Completely familiar with all technical aspects and requirements of
   BCP 47
   4. Aware of the usage of BCP 47 tags in practice, in HTML, HTTP, XML,
   &c.
   5. Able to draw upon and assess the contributions of language experts
   in order to come to consensus.

Of course, the same person could serve indefinitely as long as that person
was the best of the available candidates at the start of each term. And that
person might be the current LSR, although off the top of my head, I can
think of a number of people who are better qualified on each of the above
points.

Mark

On 3/13/07, Peter Constable <[email-masked]> wrote:
> Well, that appears to me to be a different understanding than I have
> gotten reading RFCs from 1766 on through 4646: it has always been my
> impression that the decision process was one of rough consensus (not
> necessarily unanimous, as happens in ISO and other SDOs), and that the role
> of the Reviewer was to monitor the discussion and evaluate whether consensus
> had been reached after the two-week period was up.
>
> That's why I have always found it especially annoying when the Reviewer
> rejected a request for something like es-americas that everybody else was
> arguing was legitimate -- it seemed like the Reviewer was making a
> unilateral decision, which I perceived to be contrary to the intent of the
> RFC.
>
>
>
> Peter
>

-- 
Mark

---

From: John Cowan <[email-masked]>
Date: Wed, 14 Mar 2007 03:40:21 -0400

Peter Constable scripsit:

> necessarily unanimous, as happens in ISO and other SDOs), and that
> the role of the Reviewer was to monitor the discussion and evaluate
> whether consensus had been reached after the two-week period was up.

As far as new subtag reservations are concerned, the LSR is free to
reject any proposal against which significant objections have been made,
*including his own*, provided the objections have been raised publicly
on the list.  Obviously the LSR is the judge of what is and what is not
a significant objection.  This process makes no mention of consensus.

For updates, the procedure is said to be the same, except that the LSR
decides whether there is consensus, and allows the update if there is.
It is not explicitly said what the LSR does in the absence of consensus
or if there is consensus to make no change.

-- 
No,  John.  I want formats that are actually       John Cowan
useful, rather than over-featured megaliths that   http://www.ccil.org/~cowan
address all questions by piling on ridiculous      [email-masked]
internal links in forms which are hideously
over-complex. --Simon St. Laurent on xml-dev