Subject: RE: [Ltru] Punjabi

From: "Don Osborn" <[email-masked]>
Date: Wed, 14 Mar 2007 04:31:10 -0400

Not sure if this will have gone out to the list  given that Sarmad is not on
LTRU (unless he just subscribed). So I'll pass it on with one thought. His
question about the intended use is one I also tend to ask - if you're
classifying text, that might imply one kind of categorization of the
language(s); but if you're compiling a locale for localizing software, then
maybe a different and broader (or "macro") conceptualization is appropriate.
In each case, at least for the languages I'm more familiar with, you might
reasonably come up with a different answer and use of language coding.

Don

From: Sarmad Hussain, Dr. [mailto:[email-masked]] 
Sent: Wednesday, March 14, 2007 2:57 AM
To: Don Osborn; 'Mark Davis'; 'LTRU Working Group'; [email-masked];
[email-masked]
Cc: Abbas Malik; Nayyara Karamat
Subject: RE: [Ltru] Punjabi

There are many more dialects of Punjabi, depending on the region within
Punjab in Pakistan.  What is spoken in Sargodha is much different from what
is spoken in Lahore, etc.  However, most agree that they are speaking
Punjabi.  There is some difference in vocabulary but real difference is in
the pronunciation.  If locale is to be sensitive to these dimensions of a
language, then multiple codes need to be put in.  However, if locale is just
identifying the language not the dialect (sub-language? as in some cases the
dialects may not be mutually understandable), then a singular locale would
do.  I am not sure what level locale is designed to serve?  Could anybody
else further elaborate on this?  I am cc:ing a couple of other people, in
case they want to comment.

We had looked at the written version of Punjabi in Pakistan (also called
Shahmukhi) for standardization purposes, and there seems to be less variety
at this level.  

Regards,
Sarmad

  _____  

From: Don Osborn [mailto:[email-masked]] 
Sent: Wednesday, March 14, 2007 12:55 AM
To: 'Mark Davis'; 'LTRU Working Group'; [email-masked]; [email-masked]
Cc: Sarmad Hussain, Dr.
Subject: RE: [Ltru] Punjabi

Hi Mark. An addendum to your question would be what they write. Might there
be a pa-PK written standard? I don't know, just asking. 

I will take the liberty of cc'ing the question to Dr. Sarmad Hussein of the
National University of Computer and Emerging Sciences in Lahore, who also
heads the PAN L10n project in Asia ( http://www.panl10n.net ), in case he
has any thoughts. 

Don

From: Mark Davis [mailto:[email-masked]] 
Sent: Tuesday, March 13, 2007 3:12 PM
To: LTRU Working Group; [email-masked]; [email-masked]
Subject: [Ltru] Punjabi

I have a question about Punjabi. ISO 639-2 gives "pan" as Punjabi. ISO 639-3
divides Punjabi into three separate codes:

pmu    Mirpur Panjabi
pnb    Western Panjabi
pan    Panjabi // called Eastern Panjabi in the Ethnologue. 

It looks from this that according to ISO 639-3, there is no macro language
for Panjabi; Pakistanis don't speak "pan" (= "pa"), even as a macro language
they speak something else. So a language pa-PK (or locale pa_PK) is probably
a mistake. Is this a fair statement? 

-- 
Mark 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Mark Davis" <[email-masked]>
Date: Wed, 14 Mar 2007 09:19:18 -0700

Thanks for your responses The key question we are faced with (in the Unicode
CLDR project) is what language tags (aka locale codes) to use for what is
called "Panjabi" in various regions. It appears that according to the
meaning of the codes as defined by ISO 639 and thus BCP 47, we should be
using:

   - pa-IN for "Panjabi as generally used in India" -- and pa would
   customarily use the Guru (Gurmukhi) script, so that would be suppressed in
   the tag
   - lah-PK for "Panjabi as generally used in Pakistan" -- and lah would
   customarily use the Arab (Arabic) script, so that would be suppressed in the
   tag. (We may need further subdivisions of lah, which we'll be able to
   express once BCP 47 incorporates ISO 639-3 this year.)

This doesn't mean that there aren't pa-PK users or lah-IN users -- we are
just focusing above on the largest groupings, initially. We have been using
variously combinations of 'pa' with 'Arab', 'Guru', 'PK', and 'IN', but want
to make any fixes we need now, since we are starting data submission for the
next version of CLDR: see http://unicode.org/press/pr-cldr1.5s.html.

We don't have a particular axe to grind here; our concern is that we are
using the right codes to denote the right entities, according to the
relevant standards. See also the ISO 639-3 Registration Authority's website:

   - http://www.sil.org/iso639-3/
   - http://www.sil.org/iso639-3/documentation.asp?id=lah
   - http://www.sil.org/iso639-3/documentation.asp?id=pan

See also http://www.w3.org/International/articles/language-tags/ for
information about BCP 47.

Mark

On 3/14/07, Abbas Malik <[email-masked]> wrote:
>
>  Dear All,
>
>
>
> Firstly, if we are going to categorize a language according to the writing
> systems that one language has, then Punjabi can be categorize in two ways.
> One is Gurmukhi (script used for writing Punjabi in India and is derivation
> of the old Indian scripts like SHARDA, LANDHA and TAKRI) and the other is
> Shahmukhi (derivation of Perso-Arabic script for writing Punjabi in
> Pakistan). Gurmukhi is coded as PAN. How Shahmukhi should be coded? For more
> details on the differences of these scripts of Punjabi, please look at the
> paper "Punjabi Machine Transliteration"
> http://www.puran.info/pub/mgam06-01.pdf. For a standard code page for
> Shahmukhi script, please look at the paper "Towards a Unicode Compatible
> Punjabi Character Set" http://www.puran.info/pub/mgam05-01.pdf. Punjabi in
> India is also written in Devanagari (Hinid script). Now in the present day
> on internet, Punjabi has also been started to write in Roman script. Thus,
> this is not a good way to categorize a language that is written in two or
> more different ways. How this phenomenon about a language should be handled
> in standards like ISO 639-3?
>
>
>
> Now come to the question of dialects, one can find different Punjabi
> dialects in Indian Punjab also, like spoken language in Amritsar (a city of
> Indian Punjab on boarder of Pakistan) is little different than language
> spoken in Jhalandhr (a city of Indian Punjab). Spoken Punjabi in Amritsar is
> very close to the spoken Punjabi in Lahore. If we look at the Pakistani
> Punjab, then these dialects are much apart that some time a person who can
> understand one dialect, may not be able to understand the other dialect
> 100%. Major dialects of Punjabi are Majhi (Spoken in central Punjab, main
> city Lahore), Potwari (spoken in northern Punjab, main city Jhehlem),
> Seraiki (spoken in southern Punjab, main city Multan). Interestingly all of
> these main dialects are represented with different code in ISO 639-3
> standard, Majhi with PNB (Punjabi, western), Potwari with PMU (Punjabi,
> Mirpuri) and Seraiki with SKR (Seraiki). All PAN, PNB, PMU, SKR represent
> the language Punjabi. I am not expert on the coding, but I think that it
> does not look good. There should be some way to categorize subcategories
> with in one language.
>
>
>
> I try to make things clear. Please do not hesitate to ask more questions.
> I would be very happy to answer.
>
>
>
> Best regards,
>
>
>
> ---
>
> *M. G. Abbas MALIK*
>
> Doctorant à l'ED MSTII,
>
> Univ. Joseph Fourier
>
> GETALP - LIG, IMAG - campus,
>
> BP53675 385,  rue de la Bibliothèque
>
> 38041 Grenoble Cedex 9, France
>
> Tel:         +33 (0) 4 76 51 48 17
>
> Fax:         +33 (0) 4 76 44 66 75
>
> Mob:      +33 (0) 6 74 50 46 01
>
> Mel:        Abbas.Malik at imag.fr, abbas.malik at gmail.com
>
> Url:         www.puran.info
>

On 3/13/07, Sarmad Hussain, Dr. <[email-masked]> wrote:
>  ------------------------------
>
> *From:* Don Osborn [mailto:[email-masked]]
> *Sent:* Wednesday, March 14, 2007 12:55 AM
> *To:* 'Mark Davis'; 'LTRU Working Group'; [email-masked];
> [email-masked]
> *Cc:* Sarmad Hussain, Dr.
> *Subject:* RE: [Ltru] Punjabi
>
>
>
> Hi Mark. An addendum to your question would be what they write. Might
> there be a pa-PK written standard? I don't know, just asking.
>
>
>
> I will take the liberty of cc'ing the question to Dr. Sarmad Hussein of
> the National University of Computer and Emerging Sciences in Lahore, who
> also heads the PAN L10n project in Asia ( http://www.panl10n.net ), in
> case he has any thoughts.
>
>
>
> Don
>
>
>
>
>
> *From:* Mark Davis [mailto:[email-masked]]
> *Sent:* Tuesday, March 13, 2007 3:12 PM
> *To:* LTRU Working Group; [email-masked]; [email-masked]
> *Subject:* [Ltru] Punjabi
>
>
>
> I have a question about Punjabi. ISO 639-2 gives "pan" as Punjabi. ISO
> 639-3 divides Punjabi into three separate codes:
>
> pmu    Mirpur Panjabi
> pnb    Western Panjabi

---

From: Peter Constable <[email-masked]>
Date: Wed, 14 Mar 2007 10:02:24 -0700

Don:

Please don’t rush to assume that this situation is similar to the kinds of situations you encounter in Africa with language networks that span borders – it’s not clear to me, at least, that this is a comparable situation. All the information I’ve seen (though by no means to I think I have a good understanding at this point) suggests that “Panjabi” spoken in India is significantly different from “Panjabi” spoken in Pakistan. (Of course, the script used is different.) If there is a lot of difference, then a broader conceptualization that encompasses both is probably *not* appropriate for locale data in software implementations.

Of course, the challenge here is the use of a common name. Note that the sharing of a name does not necessarily imply a common language; it may have more to do with ethnic, cultural or regional ties than with language, as is true in the case of “Kachin”. Again, I don’t know what is actually the case for “Panjabi”.

(Btw, I wouldn’t object if the governments of Pakistan or India dictated that the standard English spelling should be specifically “Panjabi” or specifically “Punjabi”.)

Peter

________________________________
From: Don Osborn [mailto:[email-masked]]
Sent: Wednesday, March 14, 2007 1:31 AM
To: 'Sarmad Hussain, Dr.'; 'Mark Davis'; 'LTRU Working Group'; [email-masked]; [email-masked]
Cc: 'Nayyara Karamat'; 'Abbas Malik'
Subject: RE: [Ltru] Punjabi

Not sure if this will have gone out to the list  given that Sarmad is not on LTRU (unless he just subscribed). So I’ll pass it on with one thought. His question about the intended use is one I also tend to ask – if you’re classifying text, that might imply one kind of categorization of the language(s); but if you’re compiling a locale for localizing software, then maybe a different and broader (or “macro”) conceptualization is appropriate. In each case, at least for the languages I’m more familiar with, you might reasonably come up with a different answer and use of language coding.

Don

To: Don Osborn; 'Mark Davis'; 'LTRU Working Group'; [email-masked]; [email-masked]

There are many more dialects of Punjabi, depending on the region within Punjab in Pakistan.  What is spoken in Sargodha is much different from what is spoken in Lahore, etc.  However, most agree that they are speaking Punjabi.  There is some difference in vocabulary but real difference is in the pronunciation.  If locale is to be sensitive to these dimensions of a language, then multiple codes need to be put in.  However, if locale is just identifying the language not the dialect (sub-language? as in some cases the dialects may not be mutually understandable), then a singular locale would do.  I am not sure what level locale is designed to serve?  Could anybody else further elaborate on this?  I am cc:ing a couple of other people, in case they want to comment.

We had looked at the written version of Punjabi in Pakistan (also called Shahmukhi) for standardization purposes, and there seems to be less variety at this level.

Regards,
Sarmad

________________________________

Hi Mark. An addendum to your question would be what they write. Might there be a pa-PK written standard? I don’t know, just asking.

I will take the liberty of cc’ing the question to Dr. Sarmad Hussein of the National University of Computer and Emerging Sciences in Lahore, who also heads the PAN L10n project in Asia ( http://www.panl10n.net ), in case he has any thoughts.

Don

I have a question about Punjabi. ISO 639-2 gives "pan" as Punjabi. ISO 639-3 divides Punjabi into three separate codes:

pmu    Mirpur Panjabi
pnb    Western Panjabi

It looks from this that according to ISO 639-3, there is no macro language for Panjabi; Pakistanis don't speak "pan" (= "pa"), even as a macro language they speak something else. So a language pa-PK (or locale pa_PK) is probably a mistake. Is this a fair statement?

---

From: "Sarmad Hussain, Dr." <[email-masked]>
Date: Wed, 14 Mar 2007 11:56:56 +0500

Regards,
Sarmad

  _____  

I will take the liberty of cc'ing the question to Dr. Sarmad Hussein of the
National University of Computer and Emerging Sciences in Lahore, who also
heads the PAN L10n project in Asia ( http://www.panl10n.net
<http://www.panl10n.net>  ), in case he has any thoughts. 

Don

pmu    Mirpur Panjabi
pnb    Western Panjabi

-- 
Mark