Subject: Re: [Ltru] Re: Proposals for changes to latest draft

From: Martin Duerst <[email-masked]>
Date: Thu, 01 Mar 2007 13:52:14 +0900

[chair hat off]

At 16:44 07/02/28, Doug Ewell wrote:
>John Cowan <cowan at ccil dot org> wrote:
>
>> 2.2.3 bullet 6 adds the notion that the hitherto private tag Qabx is to be usurped to mean "no written content".  I agree that the "unwritten languages" script tag does not do the job here, but I deny that it is proper to steal a private-use tag, and I don't see any need to have such an entity at all.
>
>Using Qabx was my idea, to replace Mark's original proposal to use Zxxx for this purpose.  Zxxx is the ISO 15924 code element meaning "code for unwritten languages."  I take that quite literally to mean "languages that do not have any commonly accepted writing system," which admittedly would be a rather odd piece of information to put in a language tag, and which is very different IMHO from "content that happens not to be in a writing system," such as signed or spoken content.  This was my interpretation, but I confirmed it with Michael, the ISO 15924 Registrar.

If the ISO 15924 Registrar is fine with a tag "code for unwritten languages",
then he should be fine with another tag "code for material not in a particular script". It would be weird if it were possible to tag audio tapes in a
language that doesn't have any way to be written yet, but audio tapes e.g.
in plain English wouldn't be taggable (assuming an old-style tagging system
where you have to fill all fields with some data).

Has such a proposal been made? I don't think it's urgently needed, but it would
be way much better than a private tag.

>When an ISO standard that establishes a coding structure provides for private-use code elements, as ISO 639 and 3166 and 10646 and 15924 do, applications that use those standards are generally permitted to allocate code elements from the private space for their own needs.  For example, CLDR uses the ISO 3166 private-use code element QO for "Outlying Oceania."  We are permitted to do similarly for the Language Subtag Registry.

In theory yes. But it's a very bad idea.

>I intentionally chose the last available ISO 15924 code as the least likely to cause conflict, since users of private codes tend to start at the bottom and work their way up, unless another approach yields better mnemonic value (which is in short supply among the 50 private codes in ISO 15924).

In the sense of minimizing potential damage, that's not too bad.
But using the private use area is still a bad idea.

>Whether there is a need at all for a script subtag meaning "not written" is a battle I'll leave to others, but if there is, it should not be Zxxx.

If there is a need, somebody should convince the registrar.

I don't see any need for us (LTRU) to define anything like this.

Regards,    Martin.

#-#-#  Martin J. Du"rst, Assoc. Professor, Aoyama Gakuin University
#-#-#  http://www.sw.it.aoyama.ac.jp       mailto:[email-masked]     

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: Marion Gunn <[email-masked]>
Date: Thu, 1 Mar 2007 11:53:39 +0000

Is it on to propose a tag simply labelled "audio"?
mg

On 1 Mar 2007, at 04:52, Martin Duerst:

> ...
> then he should be fine with another tag "code for material not in a  
> particular script". It would be weird if it were possible to tag  
> audio tapes in a
> be way much better than a private tag...

- -
Marion Gunn * EGTeo (Estab.1991)
27 Páirc an Fhéithlinn, Baile an
Bhóthair, Co. Átha Cliath, Éire.
* [email-masked] * [email-masked] *

---

From: "Randy Presuhn" <[email-masked]>
Date: Sat, 3 Mar 2007 12:18:18 -0800

Hi -

> From: "Frank Ellermann" <[email-masked]>
> To: <[email-masked]>
> Sent: Wednesday, February 28, 2007 8:11 AM
> Subject: [Ltru] non-written content (was: Proposals for changes to latestdraft)
...
> Tag consumer aren't supposed to interpret the absence of a script
> subtag wrt written vs. not written.  If Karen wants this info within
> the tags maybe she could use something like -x-text and -x-audio (?)
...

Though of course she would be free to do so, as a technical contributor
I think this information is on the very edge, if not beyond the edge, of what
it makes sense to convey in "Tags for Identifying Languages".

In particular, I think one would need to consider very carefully how such
subtags would work with matching, particularly in the presence of legacy
data.  For the cases I've been able to imagine, it seems simpler to treat
this dimension as distinct from the identification of the language itself.

Randy

---

From: Frank Ellermann <[email-masked]>
Date: Sun, 04 Mar 2007 02:27:50 +0100

Randy Presuhn wrote:

>>  maybe she could use something like -x-text and -x-audio (?)
 
> I think this information is on the very edge, if not beyond the edge,
> of what it makes sense to convey in "Tags for Identifying Languages".

Yes.  But "audio" etc. as _variants_ are IMO a horrible idea, while
extensions could do.  RFC 4646bis should have a clear MUST NOT about 
generic variants, and if that means to scrub the "fonipa" cruft, so
be it.

Frank

---

From: [email-masked]
Date: Sun, 4 Mar 2007 16:46:14 -0800

Again, all I'm requesting is stronger language about NOT using script tags 
with audio language, such as the edits I suggested previously. I never 
said I wanted a generic audio tag.

I'm not sure what was so controversial about my previous suggestions. Am I 
missing something? 

Regards,

Karen Broome

"Randy Presuhn" <[email-masked]> 
03/03/2007 12:18 PM

To
"LTRU Working Group" <[email-masked]>
cc

Subject
Re: [Ltru] non-written content (was: Proposals for changes to latestdraft)

Hi -

...
...

Though of course she would be free to do so, as a technical contributor
I think this information is on the very edge, if not beyond the edge, of 
what
it makes sense to convey in "Tags for Identifying Languages".

Randy

---

From: Addison Phillips <[email-masked]>
Date: Sun, 04 Mar 2007 17:41:26 -0800

> I'm not sure what was so controversial about my previous suggestions.
 > Am I missing something?

Nothing was controversial and I don't think you're missing anything. I 
believe we already have several such edits in the current draft. And the 
stronger language that was recently proposed I will put it into the 
draft when I next open it for editing (perhaps tonight, so that we don't 
miss the current deadline for submissions).

Addison

[email-masked] wrote:
> 
> Again, all I'm requesting is stronger language about NOT using script 
> tags with audio language, such as the edits I suggested previously. I 
> never said I wanted a generic audio tag.
> 
> 
> Regards,
> 
> Karen Broome
> 
> 
>  
> *"Randy Presuhn" <[email-masked]>*
> 
> 03/03/2007 12:18 PM
> 
> 	
> To
> ------------------------------------------------------------------------
> 

-- 
Addison Phillips
Globalization Architect -- Yahoo! Inc.
Chair -- W3C Internationalization Core WG

Internationalization is an architecture.
It is not a feature.

---

From: "Randy Presuhn" <[email-masked]>
Date: Sun, 4 Mar 2007 19:21:28 -0800

Hi -

As a technical contributor...

> From: <[email-masked]>
> To: "Randy Presuhn" <[email-masked]>
> Cc: "LTRU Working Group" <[email-masked]>
> Sent: Sunday, March 04, 2007 4:46 PM
> Subject: Re: [Ltru] non-written content (was: Proposals for changes to latestdraft)
>

Your proposal was fine with me.  Others' suggestions to add something like
"-audio" bother me.

Perhaps your comment might be accommodated by way of a "tag wisely"
example.  In section 4.1 of the current i-d, we could insert an example
after the sentence "Subtags SHOULD only be used where they add
useful distinguishing information; extraneous subtags interfere with
the meaning, understanding, and processing of language tags."
Such an example might be "For example, inclusion of a script subtag
would not be helpful in characterizing purely audio data."

Randy