Subject: [Ltru] Punjabi

From: "Mark Davis" <[email-masked]>
Date: Tue, 13 Mar 2007 12:11:51 -0700

I have a question about Punjabi. ISO 639-2 gives "pan" as Punjabi. ISO 639-3
divides Punjabi into three separate codes:

pmu    Mirpur Panjabi
pnb    Western Panjabi
pan    Panjabi // called Eastern Panjabi in the Ethnologue.

It looks from this that according to ISO 639-3, there is no macro language
for Panjabi; Pakistanis don't speak "pan" (= "pa"), even as a macro language
they speak something else. So a language pa-PK (or locale pa_PK) is probably
a mistake. Is this a fair statement?

-- 
Mark
_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Don Osborn" <[email-masked]>
Date: Tue, 13 Mar 2007 15:55:04 -0400

Hi Mark. An addendum to your question would be what they write. Might there be a pa-PK written standard? I don’t know, just asking. 

I will take the liberty of cc’ing the question to Dr. Sarmad Hussein of the National University of Computer and Emerging Sciences in Lahore, who also heads the PAN L10n project in Asia ( http://www.panl10n.net ), in case he has any thoughts. 

Don

From: Mark Davis [mailto:[email-masked]] 
Sent: Tuesday, March 13, 2007 3:12 PM
To: LTRU Working Group; [email-masked]; [email-masked]
Subject: [Ltru] Punjabi

I have a question about Punjabi. ISO 639-2 gives "pan" as Punjabi. ISO 639-3 divides Punjabi into three separate codes:

pmu    Mirpur Panjabi
pnb    Western Panjabi

It looks from this that according to ISO 639-3, there is no macro language for Panjabi; Pakistanis don't speak "pan" (= "pa"), even as a macro language they speak something else. So a language pa-PK (or locale pa_PK) is probably a mistake. Is this a fair statement? 

-- 
Mark

---

From: Peter Constable <[email-masked]>
Date: Tue, 13 Mar 2007 13:57:10 -0700

This seems a bit off-topic for the LTRU list; nevertheless...

The easy part: "pan" in ISO 639-2 denotes the same thing as "pan" in ISO 639-3.

Now the harder part (entailing agreement that pa-PK may not make much sense)...

There's a small handful of remaining open issues that the JAC needs to resolve in how pre-existing entries in 639-1/-2 should relate to what was new in the draft tables for 639-3, all having to do with South Asia; this is one of them. Most (all?) of these cases are messy because names have been used in very inconsistent ways. E.g., it's not uncommon to use a label to mean the vernacular variety spoken in some region, even though there may be several vernaculars, not necessarily closely related, and the same label is applied to any and all of them (e.g., "Bihari").

Here's the info I've compiled on this case:

PROBLEM: ISO 639 has entries [lah] "Lahnda" and [pa/pan] "Panjabi". These two must be ?considered together.?

Corresponding to "Panjabi", Ethnologue lists three languages:

- "Eastern Panjabi", or "Gurmukhi" ?is spoken primarily in the Punjab state of India, pop. est. 27,125,000;

- "Mirpur Panjabi", or ??"Mirpuri", is spoken primarily in Kashmir, pop. est. 30,000; and

- "Western Panjabi", or "Lahnda", ?spoken primarily in the Punjab province of Pakistan, pop. est. 45,000,000.

"Lahnda" is also used in Ethnologue's language classification (derived from the Int'l Ency. of Linguistics) ?as the name of a genetic sub-group that includes Western and Mirpur Panjabi, but not Eastern ?Panjabi. ?In fact, the classification separates these at a higher level:

Indo-European / Indo-Iranian / Indo-Aryan
          Central Zone
                   Bhil sub-group (19 languages)
                   Domari
                   Gujarati sub-group (9)
                   ...
                   Panjabi sub-group
->                         Eastern Panjabi
                   ...
                   Rajasthani sub-group (18)
                   ...
                   Western Hindi sub-group (12)
                   ...
                             Hindi
                   ...
          ...
          Eastern Zone
                   Bengali-Assamese sub-group (16)
                   ...
          Northern Zone
                   Central Pahari sub-group (1)
          Northern Zone
                   Nepali
                   ...
                   Western Pahari sub-group (17)
                   ...
                             Pahari-Potwari
                   ...
          Northwestern Zone
                   Dardic sub-group (27)
                   Lahnda sub-group
->                         Mirpur Panjabi
->                         Western Panjabi
                             ...
                   Sindhi sub-group (5)
          ...
          Sinhalese-Maldivian (3)
          Southern Zone
                   Konkani sub-group (7)
                   ...

That classification suggests that the level of closeness (genetically) between Eastern Panjabi (= Gurmukhi) and Western or Mirpur Panjabi is on an order similar to the difference between any of these and (say) Bengali, Nepali, Konkani or Sinhalese.

Grierson used the term "Panjabi" for varieties spoken in "Eastern Panjab" (what is now the ?Punjab state of India plus the eastern fringe of the Punjab province of Pakistan). This would ?match Ethnologue's "Eastern Panjabi". ?

Grierson introduced the term "Lahnda" (a Punjabi word meaning 'western') for varieties in ??"Western Panjab" (roughly what is now the Punjab province of Pakistan) due to their distinctness ?from "Panjabi", having significant differences from the latter while also much in common with ?Sindhi. "Landha" is not used by speakers of these varieties, though the term caught on among ?many linguists. ?

Following Grierson's usage, "Lahnda" has been described as a cover term for a dialect chain ?between Sindhi in the south and various northern varieties including Western Punjabi, Pahari-?Potwari and Hindko varieties. In terms of the classification scheme referred to in Ethnologue, this ?would likely include the languages of the "Lahnda" sub-group (possibly excluding Khetrani or ?Jakati), plus Pahari-Potwari (which is in a different branch of Indo-Aryan).
 ? ?
Ethnologue lists "Lahnda" as an alternate name for "Western Panjabi". "Western Panjabi" ?appears to correspond to "Shahpuri", which Grierson considered to be "standard Lahnda" ??(Masica 1991, p. 18).?

The MARC Language Code List uses "Lahnda" for Western Panjabi, but also as a collective that ?appears similar to Grierson's usage.? ? Comments from Milicent Wewerka suggest that MARC ?usage of [pa/pan] should be equated with Ethnologue's "Eastern Panjabi".?

I think it's pretty clear that a macrolanguage "Panjabi" that would encompass Eastern P. (Gurmukhi) with either or both of Western P. or Mirpur P. makes little sense linguistically. But language coding doesn't always get applied in ways that make sense linguistically, so perhaps there is some context in which a macrolangauge encompassing all three would make sense (though I don't think so). But note that as soon as you suggest a macrolanguage, then the existing entry lah comes into the picture.

What was done in the draft table for 639-3 - now shipped - is to equate pan with Eastern Panjabi (Gurmukhi) and to treat lah as a macrolanguage corresponding to the Lahnda genetic sub-group that encompasses seven languages - including Western P. and Mirpur P., but not Eastern P. That makes lah close to but not exactly the same as the way Grierson and MARC have used "Lahnda" (e.g. Pahari-Potwari is excluded).

I think that there's little question that the right thing was done for pan, equating it with Ethnologue's Eastern Panjabi (= Gurmukhi). What is right for lah is a little less clear. Given existing MARC usage, it would not be appropriate to use it in the narrowest sense in which it is an alias for Western Panjabi. But it's not clear if a macrolanguage makes sense or if it should be a collection; and if a collection, what it should include.

To come back to your specific question, "pa-PK" would mean Eastern Panjabi (= Gurmukhi) as used in Pakistan. It wouldn't surprise me if that language were used to some extent in Pakistan, but my understanding is that it is not at all the same language that is usually meant when referring to "Panjabi" in the context of Pakistan. If we want a macrolanguage for that, lah is a candidate, though the name may not make that obvious.

That was probably more than you were expecting.

Peter

________________________________
From: Mark Davis [mailto:[email-masked]]
Sent: Tuesday, March 13, 2007 12:12 PM
To: LTRU Working Group; [email-masked]; [email-masked]
Subject: [Ltru] Punjabi

pmu    Mirpur Panjabi
pnb    Western Panjabi

---

From: "Mark Davis" <[email-masked]>
Date: Tue, 13 Mar 2007 22:54:19 -0700

> That was probably more than you were expecting.

More than I expected, or hoped, but great information. Ok, what we'll do is
use pa-IN, with no script, since it is customarily in Guru, and for what we
had as pa-PK, figure out what is most appropriate: I'm guessing pnb_PK once
we have 4646bis.

Mark

On 3/13/07, Peter Constable <[email-masked]> wrote:
>
>  This seems a bit off-topic for the LTRU list; nevertheless…
>
>
>
> Now the harder part (entailing agreement that pa-PK may not make much
> sense)…
>
>
>
> There's a small handful of remaining open issues that the JAC needs to
> resolve in how pre-existing entries in 639-1/-2 should relate to what was
> new in the draft tables for 639-3, all having to do with South Asia; this is
> one of them. Most (all?) of these cases are messy because names have been
> used in very inconsistent ways. E.g., it's not uncommon to use a label to
> mean the vernacular variety spoken in some region, even though there may be
> several vernaculars, not necessarily closely related, and the same label is
> applied to any and all of them (e.g., "Bihari").
>
>
>
> PROBLEM: ISO 639 has entries [lah] "Lahnda" and [pa/pan] "Panjabi". These
> two must be considered together.
>
>
>
> - "Eastern Panjabi", or "Gurmukhi" is spoken primarily in the Punjab state
> of India, pop. est. 27,125,000;
>
>
>
> - "Mirpur Panjabi", or "Mirpuri", is spoken primarily in Kashmir, pop.
> est. 30,000; and
>
>
>
> - "Western Panjabi", or "Lahnda", spoken primarily in the Punjab province
> of Pakistan, pop. est. 45,000,000.
>
>
>
> "Lahnda" is also used in Ethnologue's language classification (derived
> from the Int'l Ency. of Linguistics) as the name of a genetic sub-group
> that includes Western and Mirpur Panjabi, but not Eastern Panjabi. In
> fact, the classification separates these at a higher level:
>
>
>
>                    …
>                    …
>                    …
>                    …
>                    …
>           …
>                    …
>                    …
>                    …
>                    …
>                              …
>           …
>                    …
> That classification suggests that the level of closeness (genetically)
> between Eastern Panjabi (= Gurmukhi) and Western or Mirpur Panjabi is on
> an order similar to the difference between any of these and (say) Bengali,
> Nepali, Konkani or Sinhalese.
>
>
>
> Grierson used the term "Panjabi" for varieties spoken in "Eastern Panjab"
> (what is now the Punjab state of India plus the eastern fringe of the
> Punjab province of Pakistan). This would match Ethnologue's "Eastern
> Panjabi".
>
>
>
> Grierson introduced the term "Lahnda" (a Punjabi word meaning 'western')
> for varieties in "Western Panjab" (roughly what is now the Punjab province
> of Pakistan) due to their distinctness from "Panjabi", having significant
> differences from the latter while also much in common with Sindhi. "Landha"
> is not used by speakers of these varieties, though the term caught on among many
> linguists.
>
>
>
> Following Grierson's usage, "Lahnda" has been described as a cover term
> for a dialect chain between Sindhi in the south and various northern
> varieties including Western Punjabi, Pahari-Potwari and Hindko varieties.
> In terms of the classification scheme referred to in Ethnologue, this would
> likely include the languages of the "Lahnda" sub-group (possibly excluding
> Khetrani or Jakati), plus Pahari-Potwari (which is in a different branch
> of Indo-Aryan).
>
>
>
> Ethnologue lists "Lahnda" as an alternate name for "Western Panjabi".
> "Western Panjabi" appears to correspond to "Shahpuri", which Griersonconsidered to be "standard
> Lahnda" (Masica 1991, p. 18).
>
>
>
> The MARC Language Code List uses "Lahnda" for Western Panjabi, but also as
> a collective that appears similar to Grierson's usage. Comments from
> Milicent Wewerka suggest that MARC usage of [pa/pan] should be equated
> with Ethnologue's "Eastern Panjabi".
>
>
>
>
>
> I think it's pretty clear that a macrolanguage "Panjabi" that would
> encompass Eastern P. (Gurmukhi) with either or both of Western P. or
> Mirpur P. makes little sense linguistically. But language coding doesn't
> always get applied in ways that make sense linguistically, so perhaps there
> is some context in which a macrolangauge encompassing all three would make
> sense (though I don't think so). But note that as soon as you suggest a
> macrolanguage, then the existing entry lah comes into the picture.
>
>
>
> What was done in the draft table for 639-3 – now shipped – is to equate
> pan with Eastern Panjabi (Gurmukhi) and to treat lah as a macrolanguagecorresponding to the
> Lahnda genetic sub-group that encompasses seven languages – including
> Western P. and Mirpur P., but not Eastern P. That makes lah close to but
> not exactly the same as the way Grierson and MARC have used "Lahnda" (e.g.
> Pahari-Potwari is excluded).
>
>
>
> I think that there's little question that the right thing was done for
> pan, equating it with Ethnologue's Eastern Panjabi (= Gurmukhi). What is
> right for lah is a little less clear. Given existing MARC usage, it would
> not be appropriate to use it in the narrowest sense in which it is an alias
> for Western Panjabi. But it's not clear if a macrolanguage makes sense or
> if it should be a collection; and if a collection, what it should include.
>
>
>
> To come back to your specific question, "pa-PK" would mean Eastern Panjabi
> (= Gurmukhi) as used in Pakistan. It wouldn't surprise me if that language
> were used to some extent in Pakistan, but my understanding is that it is not
> at all the same language that is usually meant when referring to "Panjabi"
> in the context of Pakistan. If we want a macrolanguage for that, lah is a
> candidate, though the name may not make that obvious.
>
>
>
>   ------------------------------
>
> *From:* Mark Davis [mailto:[email-masked]]
> *Sent:* Tuesday, March 13, 2007 12:12 PM
> *To:* LTRU Working Group; [email-masked]; [email-masked]
> *Subject:* [Ltru] Punjabi
>
>
>
> I have a question about Punjabi. ISO 639-2 gives "pan" as Punjabi. ISO
> 639-3 divides Punjabi into three separate codes:
>
> pmu    Mirpur Panjabi
> pnb    Western Panjabi

---

From: John Cowan <[email-masked]>
Date: Wed, 14 Mar 2007 02:01:34 -0400

Mark Davis scripsit:

> More than I expected, or hoped, but great information. Ok, what we'll
> do is use pa-IN, with no script, since it is customarily in Guru,
> and for what we had as pa-PK, figure out what is most appropriate:
> I'm guessing pnb_PK once we have 4646bis.

As things now stand, it would be lah-pnb-PK; of course, the 639 RA may
change things around.

-- 
If you have ever wondered if you are in hell,         John Cowan
it has been said, then you are on a well-traveled     http://www.ccil.org/~cowan
road of spiritual inquiry.  If you are absolutely     [email-masked]
sure you are in hell, however, then you must be
on the Cross Bronx Expressway.          --Alan Feuer, NYTimes, 2002-09-20

---

From: Peter Constable <[email-masked]>
Date: Tue, 13 Mar 2007 23:22:06 -0700

If people have informed opinions regarding the entry lah, please let me know.

Peter