Subject: RE: [Ltru] Punjabi

From: Sukhjinder Sidhu <[email-masked]>
Date: Wed, 14 Mar 2007 16:51:08 +0000

Mark, I think I'm going to have to disagree here.  The typical, standard dialect of Punjabi (well, as 'standard' as it has ever gotten) is Maajhi.  This is spoken both in Lahore, and Amritsar.  Lahnda as a description for the language tends to drift more towards Seraiki.  However, if we look at Ethnologue:
 
http://www.ethnologue.com/show_language.asp?code=pan
http://www.ethnologue.com/show_language.asp?code=pnbWe see that Maajhi is mentioned in both Eastern (Gurmukhi) and Western Punjabi (Shahmukhi).  "Standard" Punjabi is the same language both sides of the border.  Dogri (Pahari), Hindko, Mirpuri, Seraiki (Multani) have never been considered standard Punjabi dialects and some of these are already recognised as independent languages (Dogri, Seraiki) for example.
 
I personally think we should keep both pa-IN (pa-Guru), pa-PK (pa-Arab) for standard Punjabi, while allowing for the Lahnda languages (Hindko, Seraiki etc) to be defined later with their own language codes.
 
Regards,
Sukhjinder Sidhu

Date: Wed, 14 Mar 2007 09:19:18 -0700From: [email-masked]: [email-masked]: Re: [Ltru] PunjabiCC: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked] for your responses The key question we are faced with (in the Unicode CLDR project) is what language tags (aka locale codes) to use for what is called "Panjabi" in various regions. It appears that according to the meaning of the codes as defined by ISO 639 and thus BCP 47, we should be using: 

pa-IN for "Panjabi as generally used in India" -- and pa would customarily use the Guru (Gurmukhi) script, so that would be suppressed in the tag
lah-PK for "Panjabi as generally used in Pakistan" -- and lah would customarily use the Arab (Arabic) script, so that would be suppressed in the tag. (We may need further subdivisions of lah, which we'll be able to express once BCP 47 incorporates ISO 639-3 this year.)This doesn't mean that there aren't pa-PK users or lah-IN users -- we are just focusing above on the largest groupings, initially. We have been using variously combinations of 'pa' with 'Arab', 'Guru', 'PK', and 'IN', but want to make any fixes we need now, since we are starting data submission for the next version of CLDR: see http://unicode.org/press/pr-cldr1.5s.html.We don't have a particular axe to grind here; our concern is that we are using the right codes to denote the right entities, according to the relevant standards. See also the ISO 639-3 Registration Authority's website: 

http://www.sil.org/iso639-3/
http://www.sil.org/iso639-3/documentation.asp?id=lah
http://www.sil.org/iso639-3/documentation.asp?id=panSee also http://www.w3.org/International/articles/language-tags/ for information about BCP 47. Mark
On 3/14/07, Abbas Malik <[email-masked]> wrote: 

Dear All,
 
Firstly, if we are going to categorize a language according to the writing systems that one language has, then Punjabi can be categorize in two ways. One is Gurmukhi (script used for writing Punjabi in India and is derivation of the old Indian scripts like SHARDA, LANDHA and TAKRI) and the other is Shahmukhi (derivation of Perso-Arabic script for writing Punjabi in Pakistan). Gurmukhi is coded as PAN. How Shahmukhi should be coded? For more details on the differences of these scripts of Punjabi, please look at the paper "Punjabi Machine Transliteration" http://www.puran.info/pub/mgam06-01.pdf. For a standard code page for Shahmukhi script, please look at the paper "Towards a Unicode Compatible Punjabi Character Set" http://www.puran.info/pub/mgam05-01.pdf. Punjabi in India is also written in Devanagari (Hinid script). Now in the present day on internet, Punjabi has also been started to write in Roman script. Thus, this is not a good way to categorize a language that is written in two or more different ways. How this phenomenon about a language should be handled in standards like ISO 639-3?
 
Now come to the question of dialects, one can find different Punjabi dialects in Indian Punjab also, like spoken language in Amritsar (a city of Indian Punjab on boarder of Pakistan) is little different than language spoken in Jhalandhr (a city of Indian Punjab). Spoken Punjabi in Amritsar is very close to the spoken Punjabi in Lahore. If we look at the Pakistani Punjab, then these dialects are much apart that some time a person who can understand one dialect, may not be able to understand the other dialect 100%. Major dialects of Punjabi are Majhi (Spoken in central Punjab, main city Lahore), Potwari (spoken in northern Punjab, main city Jhehlem), Seraiki (spoken in southern Punjab, main city Multan). Interestingly all of these main dialects are represented with different code in ISO 639-3 standard, Majhi with PNB (Punjabi, western), Potwari with PMU (Punjabi, Mirpuri) and Seraiki with SKR (Seraiki). All PAN, PNB, PMU, SKR represent the language Punjabi. I am not expert on the coding, but I think that it does not look good. There should be some way to categorize subcategories with in one language.
 
I try to make things clear. Please do not hesitate to ask more questions. I would be very happy to answer.
 
Best regards,
 
---
M. G. Abbas MALIK
Doctorant à l'ED MSTII,
Univ. Joseph Fourier
GETALP - LIG, IMAG - campus,
BP53675 385,  rue de la Bibliothèque
38041 Grenoble Cedex 9, France
Tel:         +33 (0) 4 76 51 48 17
Fax:         +33 (0) 4 76 44 66 75
Mob:      +33 (0) 6 74 50 46 01
Mel:        Abbas.Malik at imag.fr , abbas.malik at gmail.com
Url:         www.puran.info 
On 3/13/07, Sarmad Hussain, Dr. <[email-masked]> wrote: 

There are many more dialects of Punjabi, depending on the region within Punjab in Pakistan.  What is spoken in Sargodha is much different from what is spoken in Lahore, etc.  However, most agree that they are speaking Punjabi.  There is some difference in vocabulary but real difference is in the pronunciation.  If locale is to be sensitive to these dimensions of a language, then multiple codes need to be put in.  However, if locale is just identifying the language not the dialect (sub-language? as in some cases the dialects may not be mutually understandable), then a singular locale would do.  I am not sure what level locale is designed to serve?  Could anybody else further elaborate on this?  I am cc:ing a couple of other people, in case they want to comment.
 
We had looked at the written version of Punjabi in Pakistan (also called Shahmukhi) for standardization purposes, and there seems to be less variety at this level.  
 
Regards,Sarmad

From: Don Osborn [mailto:[email-masked]] Sent: Wednesday, March 14, 2007 12:55 AMTo: 'Mark Davis'; 'LTRU Working Group'; [email-masked]; [email-masked]: Sarmad Hussain, Dr.Subject: RE: [Ltru] Punjabi
 
Hi Mark. An addendum to your question would be what they write. Might there be a pa-PK written standard? I don't know, just asking. 
 
I will take the liberty of cc'ing the question to Dr. Sarmad Hussein of the National University of Computer and Emerging Sciences in Lahore, who also heads the PAN L10n project in Asia ( http://www.panl10n.net ), in case he has any thoughts. 
 
Don

From: Mark Davis [mailto:[email-masked]] Sent: Tuesday, March 13, 2007 3:12 PMTo: LTRU Working Group; [email-masked]; [email-masked]: [Ltru] Punjabi
 
I have a question about Punjabi. ISO 639-2 gives "pan" as Punjabi. ISO 639-3 divides Punjabi into three separate codes:pmu    Mirpur Panjabipnb    Western Panjabipan    Panjabi // called Eastern Panjabi in the Ethnologue. It looks from this that according to ISO 639-3, there is no macro language for Panjabi; Pakistanis don't speak "pan" (= "pa"), even as a macro language they speak something else. So a language pa-PK (or locale pa_PK) is probably a mistake. Is this a fair statement? -- Mark -- Mark 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Wed, 14 Mar 2007 18:29:51 -0400

Sukhjinder Sidhu scripsit:

> I personally think we should keep both pa-IN (pa-Guru), pa-PK (pa-Arab)
> for standard Punjabi, while allowing for the Lahnda languages (Hindko,
> Seraiki etc) to be defined later with their own language codes.

Well, we have two standards to harmonize.  One provides two distinct
names (and code elements), "Panjabi" and "Lahnda".  The other provides
the names "Eastern Panjabi", "Western Panjabi", "Mirpur Panjabi",
"Jakati", "Khetrani", "Northern Hindko", "Southern Hindko", "Seraiki",
and "Pahari-Potwari".  The question is, how shall the 9 names of 639-3
be mapped onto the 2 names of 639-2?

The current plan is to map "Eastern Panjabi" onto "Panjabi", and all
the others onto "Lahnda".  It sounds like you are proposing to map
both "Eastern Panjabi" and "Western Panjabi" onto "Panjabi"
and the others onto "Lahnda".  Is that correct?

-- 
While staying with the Asonu, I met a man from      John Cowan
the Candensian plane, which is very much like       [email-masked]
ours, only more of it consists of Toronto.          http://:www.ccil.org/~cowan
        --Ursula K. Le Guin, Changing Planes

---

From: <[email-masked]>
Date: Wed, 14 Mar 2007 22:57:54 -0000

> and the others onto "Lahnda".  Is that correct?

No, I'm saying that a significant number (i.e. millions) of people speak 
"Eastern" Punjabi in Pakistan.  The only major difference between this 
spoken language and that spoken in Indian Punjab is the written script (i.e. 
Shahmukhi/Gurmukhi).  The sources that say that Western Punjabi and Eastern 
Punjabi suddenly stop at the border are simply wrong.  The Maajhi dialect is 
centred on the border - leading to significant portions of the population 
speaking it on either side.  Hence the need for both 'pa-IN' and 'pa-PK'.

"Grierson [in the Linguistic Survey of India] defined Western Punjabi as 
being west of a line running north-south from Montgomery and Gujranwala 
districts." (This is directly from Wikipedia, but I was the original 
contributor for this in the article. If you wish, I can probably track down 
the exact page number for this, but I don't have it at hand at the moment.) 
This is well within present day Pakistan, and Lahore alone has nearly seven 
million people.

Anyway, that is my take on things.  I would be interested to see what NU 
professors/researchers think on this because I've never been to Pakistan so 
I could be way off base here.

Regards,
Sukhjinder Sidhu

---

From: <[email-masked]>
Date: Wed, 14 Mar 2007 23:08:39 -0000

[Sorry for the duplicate mail]

I have actually managed to track down some relevant information from the LSI
faster than I originally thought:

Lahnda in the LSI:

http://www.joao-roiz.jp/cgi-bin/f_LSI_mkpdf.cgi?v=8-1&ff=255&ft=255&TID=7d3770e568052ed9d2e25ba27e29950f

Punjabi in the LSI:

http://www.rosettaproject.org/archive/pan/detail-1/?b_start:int=1&page_view=image_view

Please keep in mind that this is about 100 years old, and was made during 
the British Raj prior to partition.  The dynamics of the area may have 
changes now.

Regards,
Sukhjinder

----- Original Message -----
From: "John Cowan" <[email-masked]>
To: "Sukhjinder Sidhu" <[email-masked]>
Cc: "Mark Davis" <[email-masked]>; "Sarmad Hussain, Dr." 
<[email-masked]>; "LTRU Working Group" <[email-masked]>; "Nayyara 
Karamat" <[email-masked]>; <[email-masked]>; 
<[email-masked]>; <[email-masked]>; "Abbas Malik" 
<[email-masked]>
Sent: Wednesday, March 14, 2007 10:29 PM
Subject: Re: [Ltru] Punjabi

---

From: <[email-masked]>
Date: Wed, 14 Mar 2007 23:07:22 -0000

---

From: "Mark Davis" <[email-masked]>
Date: Wed, 14 Mar 2007 17:26:29 -0700

This got bounced from LTRU for having too many recipients, so am forwarding.

---------- Forwarded message ----------
From: Mark Davis <[email-masked]>
Date: Mar 14, 2007 5:23 PM
Subject: Re: [Ltru] Punjabi
To: "[email-masked]" <[email-masked]>
Cc: John Cowan <[email-masked]>, "Sarmad Hussain, Dr." <
[email-masked]>, LTRU Working Group <[email-masked]>, Nayyara
Karamat <[email-masked]>, [email-masked], [email-masked],
[email-masked], Abbas Malik <[email-masked]>,
[email-masked]

A few points of clarification, since this arose with regard to CLDR. The
CLDR data is divided into linguistic data and non-linguistic data, and what
are called "locales" are only used for linguistic data; so in that sense
CLDR locales are really collections of language data, not locale data in a
POSIX sense. We use inheritance in the data model, so we only need to add
script subtags when necessary (when the language is customarily written in 2
scripts), and only need to add region subtags when the language+script is in
common use in more than one country AND some of the linguistic data differs
between them. (Although sometimes for compatibility we add empty country
locales.) So what we would need at a minimum right now is:

1. pa (containing data appropriate for pa-Guru-IN)

If in the future we get data submitted for pa written in Arabic, we would
add

2. pa-Arab (containing data appropriate for pa-Arab-PK)
3. pa-Guru (containing data appropriate for pa-Guru-IN)

Our policy is to have each parent locale's data be what is appropriate for
the most populous (measured as literate, first or second language speakers)
child locale. So what we'd need to have at that point is the population of
pa users (as opposed to lah) in Pakistan vs India, which would determine
whether we change the contents of pa at that point. It sounds like, from
what you say, that the bulk of the population of pa users (measured as
literate, first or second language speakers) would be in India, while
Pakistan would be more lah users than pa users. Is that the case?

Mark

-- 
Mark

-- 
Mark

---

From: "Mark Davis" <[email-masked]>
Date: Wed, 14 Mar 2007 17:23:39 -0700

Mark

---

From: <[email-masked]>
Date: Thu, 15 Mar 2007 13:52:18 -0000

> Pakistan would be more lah users than pa users. Is that the case?

Yes that's correct.  Neither "Lahnda" nor Punjabi are taught formally in 
Pakistan Punjab.  Only Urdu and English.

Regards,
Sukhjinder