Subject: [Ltru] UTF-8 in which field? (Was: draft-ietf-ltru-4646bis-07

From: Stephane Bortzmeyer <[email-masked]>
Date: Thu, 2 Aug 2007 09:21:41 +0200

On Tue, Jul 31, 2007 at 08:55:50AM -0700,
 Addison Phillips <[email-masked]> wrote 
 a message of 3166 lines which said:

>    Although the file format uses the UTF-8 encoding, unless
>    otherwise indicated, fields are restricted to the printable
>    characters from the US-ASCII [ISO646] repertoire.
...
> The 'Description' field MAY thus include non-ASCII characters.

I would prefer a positive wording:

The 'Description' field MAY thus include UTF-8 characters.

Yes, I know that ASCII characters are UTF-8, too but it seems clearer
that we mention the encoding we allow, rather than the more limited
one.

[I used the Find function of my editor to find out which fields were
authorized to have UTF-8 and I first discovered none.]

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: John Cowan <[email-masked]>
Date: Thu, 2 Aug 2007 08:54:33 -0400

> The 'Description' field MAY thus include UTF-8 characters.

The point is that "ASCII" is both an encoding and a repertoire,
whereas "UTF-8" is only an encoding.  The meaning is that the
Description field may contain characters that are not in the
ASCII repertoire (whereas most other fields must not).  The
whole file is in the UTF-8 encoding.

-- 
John Cowan    [email-masked]    http://ccil.org/~cowan
The whole of Gaul is quartered into three halves.
        -- Julius Caesar

---

From: Addison Phillips <[email-masked]>
Date: Thu, 02 Aug 2007 08:20:29 -0700

> whole file is in the UTF-8 encoding.

+1

If "non-ASCII" isn't sufficiently positive, a proper reformulation would be:

--
The 'Description' field MAY include the full range of Unicode 
characters. At least one of the 'Description' fields MUST be written or 
transcribed into the Latin script; additional 'Description' fields MAY 
also include a description in a non-Latin script.
--

Note that this reverses the existing order. The current text says:

--
At least one of the 'Description' fields MUST be written or transcribed 
into the Latin script; additional 'Description' fields MAY also include 
a description in a non-Latin script. The 'Description' field MAY thus 
include non-ASCII characters.
--

Addison

-- 
Addison Phillips
Globalization Architect -- Yahoo! Inc.
Chair -- W3C Internationalization Core WG

Internationalization is an architecture.
It is not a feature.