Subject: Re: [Ltru] Updated draft-4646bis...

From: Addison Phillips <[email-masked]>
Date: Wed, 01 Aug 2007 14:09:30 -0700

> 
> The syntax of a language sub tag is such that it is possible to create a
> valid subtag where the sum of its component attributes may not represent a
> meaningful combination within actual language usage.  For example, etc.

I think my proposal says that (even allowing for s/subtag/tag/) far more 
nicely than this quite complex sentence. I also like Stephane's original 
proposal (around which mine is based and which was approved by this WG 
previously) in many ways.

> 
> Or
> 
> Validity of a language subtag does not necessarily make it meaningful. A
> subtag can be valid in terms of syntax yet meaningless in terms of real
> language usage. For example, etc.

No. This runs up against what Mark said before. The tag always has a 
meaning. It just might not be a meaningful meaning :-). But saying so in 
a waggish way in an email is not the same as saying so in the document.

I also fail to see how your proposal is any different from the 
equivalent portion of the proposed paragraph:

 >> Validity of a tag is not everything. While every valid tag
 >> has a meaning, it might not represent any real language
 >> usage.

It is very helpful if you look at the text in the context of the 
document and provide full paragraphs of proposal. The difference between 
your proposals and mine (when excluding the examples) are editorial in 
nature.

Addison

-- 
Addison Phillips
Co-Editor -- RFC 4646bis

> 
> 
> Best
> 
> Debbie 
> 
>> -----Original Message-----
>> From: Addison Phillips [mailto:[email-masked]] 
>> Sent: 01 August 2007 16:52
>> To: David Dalby
>> Cc: [email-masked]; 'Marion Gunn'; 'LTRU Working Group'
>> Subject: Re: [Ltru] Updated draft-4646bis...
>>
>> You have to read the document. The terms "valid" and 
>> "well-formed" have a different meaning in the context of RFC 
>> 4646/4646bis. The term "valid" 
>> was chosen carefully in this context.
>>
>> Mark and others are correct that every tag has *a* meaning 
>> (we even spell out the one for the "meaningless" tag in the 
>> example). But that does not mean that every tag is *meaningful*.
>>
>> How about this version instead:
>>
>>
>> <t>Validity of a tag is not everything. While every valid tag 
>> has a meaning, it might not represent any real language 
>> usage. This is unavoidable in a system in which subtags can 
>> be combined freely. For example, tags such as "ar-Cyrl-CO" 
>> (Arabic, Cyrillic script, as used in Colombia ) or 
>> "tlh-Kore-AQ-fonipa" (Klingon, Korean script, as used in 
>> Antarctica, IPA phonetic transcription) are both valid and 
>> unlikely to represent a useful combination of language attributes.</t>
>>
>> Addison
>>
>> David Dalby wrote:
>>> I agree!
>>>
>>> David
>>>
>>>  _____________________________________________________
>>>  
>>> Dr David Dalby
>>> The Linguasphere Observatory
>>> Hebron
>>> Whitland
>>> Wales
>>> SA34 0XT
>>>  
>>> -----Original Message-----
>>> From: Debbie Garside [mailto:[email-masked]]
>>> Sent: 01 August 2007 13:44
>>> To: [email-masked]; 'Marion Gunn'
>>> Cc: 'LTRU Working Group'
>>> Subject: RE: [Ltru] Updated draft-4646bis...
>>>
>>> Addison wrote:
>>>
>>>> A tag can be valid yet meaningless.
>>> I don't really like this as it seems, on the face of it, a 
>>> contradiction in terms.  I would propose one of the following:
>>>
>>> ---
>>> A tag can be well formed yet meaningless.
>>>
>>> A tag can be well formed in terms of syntax, and thus valid, yet 
>>> meaningless in terms of its attributes. For example, ...
>>>
>>> ---
>>>
>>> Best
>>>
>>> Debbie
>>>
>>>> -----Original Message-----
>>>> From: Addison Phillips [mailto:[email-masked]]
>>>> Sent: 31 July 2007 16:52
>>>> To: Marion Gunn
>>>> Cc: LTRU Working Group
>>>> Subject: Re: [Ltru] Updated draft-4646bis...
>>>>
>>>> Marion Gunn wrote:
>>>>  >
>>>>  > However, here goes with one more attempt:
>>>>  >
>>>>  > "For example, although a tag such as 'ar-Cyrl-CO' 
>> (Arabic, as used 
>>>> in  > Columbia,  > written in Cyrillic script) is valid, 
>> it is [most] 
>>>> unlikely to be of  > use, because  > such combination of 
>> attributes 
>>>> is unlikely to occur in actual language  > use."
>>>>  >
>>>>
>>>> I note that it is useful to look at the actual editor's copy when 
>>>> suggesting minor editorial changes. Upon reflection, I found the 
>>>> current sentence to be a bit of a run-on. I've taken your 
>> suggestion 
>>>> of 'unlikely' and edited further such that the paragraph now reads:
>>>>
>>>> <t>Validity of a tag is not everything. A tag can be valid yet 
>>>> meaningless. This is unavoidable with a generative system like the 
>>>> language subtag mechanism. For example, a tag such as "ar-Cyrl-CO"
>>>> (Arabic, Cyrillic script, as used in Colombia) is perfectly valid. 
>>>> However, it is unlikely to be a useful tag, as it represents an 
>>>> unlikely combination of language attributes that is probably 
>>>> unrelated to any real language usage.</t>
>>>>
>>>> After five minutes from now, you will need to comment on draft-08. 
>>>> I'm always happy to consider editorial changes that 
>> improve the text.
>>>> Addison
>>>>
>>>> --
>>>> Addison Phillips
>>>> Globalization Architect -- Yahoo! Inc.
>>>> Chair -- W3C Internationalization Core WG
>>>>
>>>> Internationalization is an architecture.
>>>> It is not a feature.
>>>>
>>>>
>>>> _______________________________________________
>>>> Ltru mailing list
>>>> [email-masked]
>>>> https://www1.ietf.org/mailman/listinfo/ltru
>>>>
>>>>
>>>
>>>
>>>
>>>
>>>
>>> _______________________________________________
>>> Ltru mailing list
>>> [email-masked]
>>> https://www1.ietf.org/mailman/listinfo/ltru
>>>
>>>
>> --
>> Addison Phillips
>> Globalization Architect -- Yahoo! Inc.
>> Chair -- W3C Internationalization Core WG
>>
>> Internationalization is an architecture.
>> It is not a feature.
>>
>>
>>
> 
> 
> 
> 

_______________________________________________
Ltru mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ltru

---

From: "Debbie Garside" <[email-masked]>
Date: Wed, 1 Aug 2007 22:28:55 +0100

Hi Addison

It is this phrase " Validity of a tag is not everything."  that I
particularly dislike. But if the WG wish to adopt it who am I to disagree
;-)

Mine was longwinded though.

As to editorial in nature, is that not, partly, what this is about?  I have
been away from the WG for a while so am playing catch-up.  If you just
require technical comment I will be quiet on this.

Best

Debbie

> Sent: 01 August 2007 22:10
> To: [email-masked]
> Cc: 'David Dalby'; 'Marion Gunn'; 'LTRU Working Group'
> > The syntax of a language sub tag is such that it is 
> possible to create 
> > a valid subtag where the sum of its component attributes may not 
> > represent a meaningful combination within actual language 
> usage.  For example, etc.
> 
> I think my proposal says that (even allowing for 
> s/subtag/tag/) far more nicely than this quite complex 
> sentence. I also like Stephane's original proposal (around 
> which mine is based and which was approved by this WG