Subject: [Ltru] Extensions, Extended Language Subtags (new topic from Some typos . . .)

From: CE Whitehead <[email-masked]>
Date: Thu, 14 Feb 2008 16:14:48 -0500

Hi. 
 
Regarding,
http://www.ietf.org/internet-drafts/draft-ietf-ltru-4646bis-11.txt 
Regarding extensions, 
 
(1), A single digit or character is used for these rfc's--so how many characters/digits are there available for registering extensions?  That is, are you accepting other unicode characters  (I assume that you are not making a real distinction between upper and lower case ascii)? (2), Also, the old extended language tags are deprecated?  grandfathered?   I see the tag zh-gan could be formed when [gan] became an extended language subtag (section 3.4 item 16)  
Is [gan] now deprecated?  zh-gan grandfathered?  (I'm sorry; I don't know; please clarify for dummies).
 
(This example's being deleted because not a good example, fine.)
 
Regarding "Extended Language Subtags,"  On Wed, Feb 13, 2008 at 09:45:28AM +0100,Stephane Bortzmeyer <bortzmeyer at nic.fr> wrote a message of 44 lines which said:> 1) The most important: "extended language subtags" or similar> expressions appear in a lot of places despite extlang removal. Do we> agree they should all be suppressed? (
 I agree that mention of "Extended language" should be suppressed from this document
except maybe (back to my question) to say that these particular tags/subtags grandfathered or deprecated??
 
--C. E. Whitehead
[email-masked] 

_______________________________________________
Ltru mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/ltru

---

From: "Kent Karlsson" <[email-masked]>
Date: Thu, 14 Feb 2008 22:31:47 +0100

See below.

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of CE Whitehead
Sent: Thursday, February 14, 2008 10:15 PM
To: [email-masked]
Cc: Ann Rice
Subject: [Ltru] Extensions, Extended Language Subtags (new topic from Some typos . . .)

Hi. 

Regarding,

 <http://www.ietf.org/internet-drafts/draft-ietf-ltru-4646bis-11.txt>
http://www.ietf.org/internet-drafts/draft-ietf-ltru-4646bis-11.txt

Regarding extensions, 

(1), A single digit or character is used for these rfc's--so how many characters/digits are there available for registering
extensions?  That is, are you accepting other unicode characters  (I assume that you are not making a real distinction between upper
and lower case ascii)?

No, only a-z (except x) and 0-9. There is no registered extension. (I guess it is unlikely that there ever will be any...)

(2), Also, the old extended language tags are deprecated?  grandfathered?  

Non-existent (those that look like they use extlangs don't really).

I see the tag zh-gan could be formed when [gan] became an extended language subtag (section 3.4 item 16)  

That example and others like it are grandfathered, but they will be deprecated (most often with a preferred value). See the 4645bis
draft.

    /kent k

 

Regarding "Extended Language Subtags," 
 On Wed, Feb 13, 2008 at 09:45:28AM +0100,
Stephane Bortzmeyer <bortzmeyer at nic.fr> wrote 
a message of 44 lines which said:

> 1) The most important: "extended language subtags" or similar
> expressions appear in a lot of places despite extlang removal. Do we
> agree they should all be suppressed? (

--C. E. Whitehead

[email-masked]