Subject: [Ltru] [4645bis] How to parse zh-gan?

From: Stephane Bortzmeyer <[email-masked]>
Date: Mon, 18 Feb 2008 16:05:00 +0100

The registry in 4645bis (I used the copy at
http://home.roadrunner.com/~dewell/lstreg-4646bis-draft-04.txt)
contains grandfathered tags like zh-gan or zh-cmn. They were "legal"
in RFC 4646 (a language tag and an extended language subtag).

How should a parser handle them?

1) They are not well-formed because the 'extlang' production has been
removed from the ABNF and they are *not* listed in the 'irregular'
production.

2) They are valid by definition, since they are in the registry
(although deprecated).

What's the best way for a parser to handle them? Should I add them to
the 'irregular' production?

Isn't it a problem that a tag can be valid but not well-formed?
According to 2.2.9 in 4646bis, it is a technical problem because
well-formed tags are a superset of valid tags.

_______________________________________________
Ltru mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/ltru

---

From: "Kent Karlsson" <[email-masked]>
Date: Mon, 18 Feb 2008 16:33:14 +0100

> removed from the ABNF and they are *not* listed in the 'irregular'

They should be listed among the other "irregular" ones in the ABNF.

	/kent k

---

From: "Mark Davis" <[email-masked]>
Date: Mon, 18 Feb 2008 07:38:59 -0800

That's a mistake in the ABNF production: we didn't capture the change when
we removed extlang. Would you like to suggest the list to be added?

On Feb 18, 2008 7:05 AM, Stephane Bortzmeyer <[email-masked]> wrote:

> http://home.roadrunner.com/~dewell/lstreg-4646bis-draft-04.txt<http://home.roadrunner.com/%7Edewell/lstreg-4646bis-draft-04.txt>
> )

-- 
Mark

---

From: 'Stephane Bortzmeyer' <[email-masked]>
Date: Mon, 18 Feb 2008 16:41:02 +0100

On Mon, Feb 18, 2008 at 04:33:14PM +0100,
 Kent Karlsson <[email-masked]> wrote 

> They should be listed among the other "irregular" ones in the ABNF.

Yes, so one more Technical Issue for the WGLC?
_______________________________________________
Ltru mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/ltru

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Mon, 18 Feb 2008 17:05:22 +0100

On Mon, Feb 18, 2008 at 07:38:59AM -0800,
 Mark Davis <[email-masked]> wrote 

> we removed extlang. Would you like to suggest the list to be added?

Apparently, we just have to add norwegian and chinese :-)

"no-bok" / 
"no-nyn" / 
"zh-cmn" / 
"zh-cmn-Hans" / 
"zh-cmn-Hant" / 
"zh-gan" / 
"zh-min" / 
"zh-min-nan" / 
"zh-wuu" / 
"zh-yue"

---

From: "Randy Presuhn" <[email-masked]>
Date: Mon, 18 Feb 2008 10:48:09 -0800

Hi -

> From: "'Stephane Bortzmeyer'" <[email-masked]>
> To: "Kent Karlsson" <[email-masked]>
> Cc: "'LTRU Working Group'" <[email-masked]>
> Sent: Monday, February 18, 2008 7:41 AM
> Subject: Re: [Ltru] [4645bis] How to parse zh-gan?
...
> Yes, so one more Technical Issue for the WGLC?
...

As co-chair:

Sure.  There's nothing wrong with technical issues showing up in a
working group last call.  It's just a sign that people are actually reading
the documents.

As technical contributor:
I'm beginning to think we may have been over-zealous in removing
extlang from the grammar.

Randy

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Mon, 18 Feb 2008 21:17:51 +0100

On Mon, Feb 18, 2008 at 10:48:09AM -0800,
 Randy Presuhn <[email-masked]> wrote 

> extlang from the grammar.

No, this case is not sufficient. After all, it has a simple technical
fix.
_______________________________________________
Ltru mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/ltru

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Mon, 18 Feb 2008 21:28:54 +0100

On Mon, Feb 18, 2008 at 10:48:09AM -0800,
 Randy Presuhn <[email-masked]> wrote 
 a message of 27 lines which said:

> It's just a sign that people are actually reading the documents.

Actually, implementing them. I'm quite bad at spotting problems just
by reading. But implementation forces me to read in detail and
understand the document :-)
_______________________________________________
Ltru mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/ltru