Subject: Re: [Ltru] Uniqueness of variant subtags (Was: BCP47 Appeals process

From: Leif Halvard Silli <[email-masked]>
Date: Wed, 01 Oct 2008 11:34:26 +0200

Randy Presuhn 2008-10-01 08.52:

> As a technical contributor...
>> From: "Mark Davis" <[email-masked]>

>> I'm not opposed to
>> 
>> de-1901
>> uz-1901
>> and so on. These are meaningful and easy for people to understand.
>> 
>> I think that can be encapsulated as:
>> 
>> Type: variant
>> Subtag: 2003
>> Description: Denotes a change in orthography, transliteration, or other
>> usage associated with the publication of a significant standard or other
>> specification in 2003
>> Prefix: de
>> Prefix: uz
>> Prefix: be-ungegn
>> 
>> We can then add prefixes that are known to have such cases over time.
> 
> I'm worried about "fuzziness" creeping in  in cases like this.
> A registration request might provide a very precise definition,
> identifying a particular national or international standard
> for a particular prefix.

"First to mill" doesn't seem the right principle when it comes to 
the right to "occupy" number "2003" - referring to year 2003 AD. 
Therefore, I agree with Mark that this makes sense.

Defining e.g. "2003" the way Mark suggests here, also creates a 
"registration pattern": It shows a way to do it.
-- 
leif halvard silli
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: Martin Duerst <[email-masked]>
Date: Wed, 01 Oct 2008 15:28:02 +0900

I'm not really sure what's wrong, in terms of "figuring it out" with:

Type: variant
Subtag: 1901
Description: German orthography of 1901
Description: Uzbek transliteration of 1901
Prefix: de
Prefix: uz

(it should be clear that the 'de' is German and the 'uz' is Uzbek).
If this isn't clear, then what about the following:

Type: variant
Subtag: 1901
Description: German orthography of 1901
Description: Uzbek transliteration of 1901
Prefix: de
Prefix: uz
Comment: with Prefix de, German orthography of 1901
Comment: with Prefix uz, Uzbek transliteration of 1901

(but it seems kind of silly, doesn't it).

I'm not saying we should do this a lot, but I don't see any
really fundamental problem with it in terms of figuring out
what things mean, which is the most important point.

Regards,    Martin.

At 05:43 08/10/01, Randy Presuhn wrote:
>Hi -
>> From: "Phillips, Addison" <[email-masked]>
>> To: "Stephane Bortzmeyer" <[email-masked]>
>> Cc: "LTRU Working Group" <[email-masked]>; "Ewell" <[email-masked]>; 
><[email-masked]>
>> Sent: Tuesday, September 30, 2008 8:39 AM
>> Subject: Re: [Ltru] Uniqueness of variant subtags (Was: BCP47 Appeals process
>>
>> Let me retry expressing this. Consider this record:
>> 
>> Type: variant
>> Subtag: 1901
>> Description: German orthography of 1901
>> Description: Uzbek transliteration of 1901
>> Prefix: de
>> Prefix: uz
>> Comments: Good luck figuring this out.
>
>This is precisely how the [email-masked] list appears
>to proposing that "pinyin" be handled.
>
>Consider, on the other hand...
>
>Type: variant
>Subtag: 1901
>Description: German orthography of 1901
>Prefix: de
>Comments: Should be clear.
>
>Type: variant
>Subtag: 1901
>Description: Uzbek transliteration of 1901
>Prefix: uz
>Comments: Should be clear.
> 
>We should be clear about whether we want to permit this or not.
>I think there is no problem when the prefix is used.  The problem
>is figuring out what it means when one of these variants is used
>with any other prefix.  (It's also a problem if someone has used the
>subtag as a database key.)
>
>Randy
>

#-#-#  Martin J. Du"rst, Assoc. Professor, Aoyama Gakuin University
#-#-#  http://www.sw.it.aoyama.ac.jp       mailto:[email-masked]

---

From: Martin Duerst <[email-masked]>
Date: Wed, 01 Oct 2008 15:45:49 +0900

At 05:39 08/10/01, Stephane Bortzmeyer wrote:
>On Tue, Sep 30, 2008 at 08:40:36AM -0700,
> Phillips, Addison <[email-masked]> wrote 
> a message of 41 lines which said:
>
>> Since there is no consensus on my proposed change, unless directed
>> by the chairs otherwise, I will removed my proposed text from the
>> editor's copy before incorporating any other changes.
>
>True, there is no consensus yet but the issue is a real one, no? RFC
>4646 does not provide clear guidance (although ietf-languages'
>practice has always been to refuse identical variant
>subtags). Shouldn't we delay the I-D a bit for that?

I hope we can restrict this to the a very short time.
Everybody, please comment quickly and express clearly
what you can absolutely not live with vs. just desirable
stuff, so that we can converge quickly.

Regards,    Martin.

---

From: Martin Duerst <[email-masked]>
Date: Wed, 01 Oct 2008 15:36:34 +0900

At 06:00 08/10/01, Stephane Bortzmeyer wrote:

>Yes. It seems most developers assumed that identical variant subtags
>were forbidden and so allowing your solution would break
>compatibility.
>
>Also, for all other types, duplication of a subtag is forbidden. It
>may be difficult to explain why variants are different.

 From an implementation point of view, it may be very difficult to
explain. From a user point, it's rather easy to explain; variants
are secondary information, whereas others (incl. regions, scipts)
have a primary meaning, even if they are used for secondary
distinctions in language tags.

Regards,   Martin.