Subject: Re: [Ltru] RFC 4646 bis; IANA's Register; Languages, langage and langue

From: CE Whitehead <[email-masked]>
Date: Fri, 17 Oct 2008 13:10:04 -0400

Here you are saying that "langues" is a good choice for a translation of the English word "language" because it distinguishes human languages which the codes here are for (with the exception of the code zxx) from machine languages.  Fine, but I do think we want it to include "sign languages" which I think "langue" includes though I am not a native French speaker.

Thanks.

From: Lang Gérard 
Date: Fri, 17 Oct 2008 12:14:33 +0200

> The title of ISO 639 has been slightly modified (Code for.... becomes Codes for...),
> but the choice of  the french term"langue" and not "langage" as equivalent for the english term "language", has not been modified.
> This choice has also a (partial) justification by the fact that " Languages designed exclusively for machine use, such as computer programming languages" are certainly "langages" and certainly not "langues" in french; so this choice is certainly all but hazardous, it is clearly well-founded and motivated.
I agree so far.  Here you are saying that "langues" is a good choice for a translation of the English word "language" because it distinguishes human languages which the codes here are for (with the exception of the code zxx) from machine languages

> That the scope of ISO 639-2 does not include "Sign languages" seems clear from the intended applications.

??
> Anyway, none of the 430 ISO 639-2 published language names is an entry of this sort.

I think that as you've noted the list is growing; so I do not quite agree with your point here.

Best,

--C. E. Whitehead
[email-masked]
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Fri, 17 Oct 2008 10:40:03 -0700

Hi -

As co-chair:

We're trying to wrap up a working group last call.
Discussion of what may or may not be appropriate
translations for the English word "language" into other
languages is off-topic.  Operational experience with
RFC 4646 adequately demonstrates that the current
use of the word "language" is sufficiently clear, and I've
seen neither persuasive technical justification or any
indication that there is a consensus that a change is
needed in this area.

Randy