Subject: [Ltru] Comments on RFC4646bis

From: "Richard Ishida" <[email-masked]>
Date: Thu, 9 Oct 2008 20:31:47 +0100

Just a couple of editorial comments:

1. I felt like sections 4.1.1 and 4.1.2 ought to be in reverse order.

2. I'm cringing at the text in section 4.2 " a tag such as <meta http-equiv="Content-Language" value="de" />" since it will probably encourage people to think that this is how to declare language in HTML, whereas it is currently not widely interoperable and confuses people wrt attributes in html tag.  Why not change the example to say " For example, in the same HTML document described in the preceding bullet, sending an HTTP header containing Content-Language: de might be a way to indicate..."

Best, 
RI

============
Richard Ishida
Internationalization Lead
W3C (World Wide Web Consortium)

http://www.w3.org/International/
http://rishida.net/

_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Phillips, Addison" <[email-masked]>
Date: Thu, 9 Oct 2008 12:40:58 -0700

> 1. I felt like sections 4.1.1 and 4.1.2 ought to be in reverse

(editor hat OFF)

The order is somewhat arbitrary.

> 
> 2. I'm cringing at the text in section 4.2 " a tag such as <meta
> http-equiv="Content-Language" value="de" />" since it will probably
> encourage people to think that this is how to declare language in
> HTML, whereas it is currently not widely interoperable and confuses
> people wrt attributes in html tag.  Why not change the example to
> say " For example, in the same HTML document described in the
> preceding bullet, sending an HTTP header containing Content-
> Language: de might be a way to indicate..."

<meta> is one way to indicate the intended audience. Nonetheless, I like your version better, since there is a lively discussion about what <meta> means or should mean and cetera.

(editor hat ON)

Unless anyone objects, I will update the editor's copy to include Richard's version of the text for 4.2. 

Addison

---

From: "Mark Davis" <[email-masked]>
Date: Thu, 9 Oct 2008 23:32:53 +0200

No objection.
Mark

On Thu, Oct 9, 2008 at 9:40 PM, Phillips, Addison <[email-masked]>wrote:

> <meta> is one way to indicate the intended audience. Nonetheless, I like
> your version better, since there is a lively discussion about what <meta>
> means or should mean and cetera.
>
> (editor hat ON)
>

---

From: Martin Duerst <[email-masked]>
Date: Fri, 10 Oct 2008 16:43:44 +0900

>version of the text for 4.2. 

[technical contributor hat on]
I support this change, in particular also because there is actually
no 'value' attribute on the <meta> element in HTML
(see http://www.w3.org/TR/html4/struct/global.html#edef-META).

[chair hat on]
If you disagree with this late but minor change, please speek up soon.

Regards,    Martin.

#-#-#  Martin J. Du"rst, Assoc. Professor, Aoyama Gakuin University
#-#-#  http://www.sw.it.aoyama.ac.jp       mailto:[email-masked]