Subject: [Ltru] Language Tag Analyzer

From: "Felix Sasaki" <[email-masked]>
Date: Mon, 20 Oct 2008 00:33:30 +0900 (JST)

I have updated a language tag analyzer I had written a while ago, to the
ANBF and the registry in the last call drafts. See
http://www.w3.org/2008/05/lta/
The tool should help to educate about the form of language tags and
various constraints. Currently only two are tested: validity and
repitition of singleton in extensions. More are about to come at some
point in time. Feedback & suggestions are very welcome. Also: if somebody
wants to localize the (error) messages in
http://www.w3.org/2008/05/lta/02/messages.xml
into further languages: you are very welcome :)

Felix
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Broome, Karen" <[email-masked]>
Date: Mon, 20 Oct 2008 17:45:56 -0700

Felix,

Should it have thrown an error on "zh-cmn-TW"? (It didn't.)

Regards,

Karen Broome
________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Felix Sasaki [[email-masked]]
Sent: Sunday, October 19, 2008 8:33 AM
To: LTRU Working Group
Subject: [Ltru] Language Tag Analyzer

Felix

---

From: John Cowan <[email-masked]>
Date: Mon, 20 Oct 2008 20:51:11 -0400

> Should it have thrown an error on "zh-cmn-TW"? (It didn't.)

Why would it?  Under 3066bis that will be a valid tag.

-- 
The Unicode Standard does not encode            John Cowan
idiosyncratic, personal, novel, or private      http://www.ccil.org/~cowan
use characters, nor does it encode logos
or graphics.                                    [email-masked]
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Phillips, Addison" <[email-masked]>
Date: Mon, 20 Oct 2008 21:03:31 -0700

Recte: 4646bis.

Addison

Addison Phillips
Globalization Architect -- Lab126

Internationalization is not a feature.
It is an architecture.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of John Cowan
> Sent: Monday, October 20, 2008 5:51 PM
> To: Broome, Karen
> Cc: [email-masked]
> Subject: Re: [Ltru] Language Tag Analyzer
> 
> Broome, Karen scripsit:
>

---

From: "Felix Sasaki" <[email-masked]>
Date: Tue, 21 Oct 2008 14:45:13 +0900 (JST)

> Recte: 4646bis.

Exactly. The underlying ABNF and the registry are taken from the last call
drafts.

Felix