Subject: [Ltru] Scope of ISO 3166//// Ltru Digest, Vol 44, Issue 26

From: Lang Gérard <[email-masked]>
Date: Thu, 9 Oct 2008 08:57:15 +0200

Dear Doug,

Let me thank you for this message.

Concerning the link between the title "Codes for the representation of names of countries" and the scope of ISO 3166[-1], I would say that there never was any ambiguity for people that take the time to read the normative text of the standard.

1-The first edition (1974) contains article "3 PRINCIPLES FOR THE ENTITY LIST" , whose 3.1 writes:
 "The list includes entities intended to satisfy the requirements of the broadest range of applications. The entities appearing in sections one and two of this International standard are based on the list included in the "Country Nomenclature for Statistical Use" established by the Statistical Office of the United Nations.":;
And 3.2 adds "In order to satisfy various interchange requirements, the list contains overlaps and the entities listed are not mutually exclusive."
3.4 also writes "Entities listed are intended to rerflect current status. Historical statusd is not reflected in this International Standard."

So, it was clear from the beginning that ISO 3166[-1] was registering overlapping entities, so that some of them coud certainly not be considered as "independant countries"

2-The second edition (1981) clarified still this point and contains article "1 Scope and field of application", whose first paragraph writes:
"This International Standard provides basic two-letter alphabetic codes (ISO alpha-2 coutry code), three-letter codes (ISO alpha-3 country code) for special,purposes and three-digit numerical codes (ISO numeric-3 country code) established by the Statistical Office of the United Nations. The codes represent the names of countries, dependancies and other areas of special interest for purposes of international exchanges...."
Further more, inside "3 Principles for the entity list", 3.2 writes:
"The list contains overlaps in those cases where entities are geographically separated from their main entity and where a resulting interchange requiremzent justifies a separate code; the entities are not mutually exclusive.
Example: FRANCE, FR, FRA, 250;
MARTINIQUE, MQ, MTQ,474."

3-From 1997, when ISO 3166 is splitted into three parts,  the common Introduction of the three parts of the 3166 standard, as in ISO 3166-1:1997, fifth edition, and in ISO 3166-1: 2007, sixth edition, writes:
"International Standard ISO 3166 provides universally applicable coded representations of names of countries (current and non-current), dependancies andother areas of particular geopolitical interest and their subdivision.

ISO 3166-1 (Country codes) establishes codes that represent the current names of countries, dependancies, and other areas of partcular geopolitical interest, on the basis of lists of country names obtained from the United Nations.
.........."
Amicalement.
Gérard LANG
  .
-----Message d'origine-----
De : [email-masked] [mailto:[email-masked]] De la part de [email-masked]
Envoyé : mercredi 8 octobre 2008 21:00
À : [email-masked]
Objet : Ltru Digest, Vol 44, Issue 26

Send Ltru mailing list submissions to
	[email-masked]

To subscribe or unsubscribe via the World Wide Web, visit
	https://www.ietf.org/mailman/listinfo/ltru
or, via email, send a message with subject or body 'help' to
	[email-masked]

You can reach the person managing the list at
	[email-masked]

When replying, please edit your Subject line so it is more specific than "Re: Contents of Ltru digest..."

Today's Topics:

   1. Re: UNGEGN definitions and UNICODe Glossary of terms (Doug Ewell)
   2. Re: UNGEGN definitions and UNICODe Glossary of terms (Doug Ewell)
   3. Re: Ltru Digest, Vol 44, Issue 24 (Peter Constable)

----------------------------------------------------------------------

Message: 1
Date: Wed, 8 Oct 2008 06:59:26 -0600
From: "Doug Ewell" <[email-masked]>
Subject: Re: [Ltru] UNGEGN definitions and UNICODe Glossary of terms
To: "LTRU Working Group" <[email-masked]>
Message-ID: <345F951A79B6473CBF21BF37BC584FED@DGBP7M81>
Content-Type: text/plain; format=flowed; charset="utf-8";
	reply-type=original

Lang G?rard <gerard dot lang at insee dot fr> wrote:

> 1-Let me stress that I have, in fact, no "strenuous objection" with 
> the recent "discover" that "langage des signes" became "langue des 
> signes". But I have very strenuous objection about rewriting history 
> and do not understand the strenuous resistance to the establishment of 
> history. I agree without problem that in the past decade "scientific 
> progress" admitted that "Sign languages" could be assimilated to 
> "languages"
> and registered inside ISO 639-3.

Coding standards, and lists of entities coded to the standard, tend to make poor history books.  Their main purpose is to keep up with changing situations and current needs.  If this was indeed a change in scope for ISO 639, I suggest that looking at it as "rewriting history" is not the correct approach.

Standards do sometimes expand beyond the scope implied by the original title, as the needs of their users change.  You no doubt understand this from your work with ISO 3166, which includes code elements for the names of such non-country entities as Greenland and British Indian Ocean Territory.  I would consider it wholly inappropriate to criticize ISO
3166 for trying to "rewrite history" by claiming that these entities are countries.

> But I want to be clearly understood that this was not in the intended 
> scope of ISO 639 (and of ISO 639-1 and ISO 639-2) until 2000.

Perhaps this is true; perhaps the omission of sign languages was simply an oversight, as Martin suggested.  But whatever the scope was before, it now includes sign languages.

> And I cannot prevent me to think that this "discover" is not 
> completely independant of "political correctness".

You are permitted to think that.

> 2-As "codification of the representation of names of countries names 
> and their subdivisions" is also clearly not independant from 
> "political pressure", ISO 3166 has its share of pressure. So that, to 
> give an example, we accepted the request of ROMANIA to change their
> alpha-3 code element from "ROM" to "ROU".

Yes, that change was well understood as being completely political. 
Those of us who deal with language tags were grateful that only the
alpha-3 code element was changed, and not the alpha-2.  We now have rules in place to ensure stability of language tags in case another such change is approved that does affect the alpha-2.

> This is also the case for the addition of "Letzeburgesh" (lb,ltz) or 
> "Bosnian" (bs,bos); this would also be the case for the language name 
> "Montenegrin" that is now recognized as the official language of 
> MONTENEGRO (Maybe you were thinking to Montenegrin when you wrote 
> Macedonian ?) and is certainly a new "language name" covered by ISO 
> 639..

Yes, I was of course thinking of Montenegrin.  Thank you for the correction.

Newly formed countries want to establish their own national identity. 
This is completely reasonable.  Persuading the registration agency for an international coding standard to register a new code element for "their language," when it is actually a dialect of an existing language and not a separate language with mutual unintelligibility, is not reasonable on linguistic grounds.  It is purely political, much more demonstrably so than including sign languages along with spoken languages in a standard that encodes names of "languages."

--
Doug Ewell  *  Thornton, Colorado, USA  *  RFC 4645  *  UTN #14 http://www.ewellic.org http://www1.ietf.org/html.charters/ltru-charter.html
http://www.alvestrand.no/mailman/listinfo/ietf-languages  ?

------------------------------

Message: 2
Date: Wed, 8 Oct 2008 07:04:38 -0600
From: "Doug Ewell" <[email-masked]>
Subject: Re: [Ltru] UNGEGN definitions and UNICODe Glossary of terms
To: "LTRU Working Group" <[email-masked]>
Message-ID: <8F7E5A3E07374254B5C4B4632FF3CA0C@DGBP7M81>
Content-Type: text/plain; format=flowed; charset="utf-8";
	reply-type=original

I have no problem with including the reference to RFC 3339; I just wanted to point out that it could be omitted, to make the point about ISO 8601.

I also have no problem with not including the bit about notifying the ISO 3166/MA.

--
Doug Ewell  *  Thornton, Colorado, USA  *  RFC 4645  *  UTN #14 http://www.ewellic.org http://www1.ietf.org/html.charters/ltru-charter.html
http://www.alvestrand.no/mailman/listinfo/ietf-languages  ?

------------------------------

Message: 3
Date: Wed, 8 Oct 2008 08:41:21 -0700
From: Peter Constable <[email-masked]>
Subject: Re: [Ltru] Ltru Digest, Vol 44, Issue 24
To: "[email-masked]" <[email-masked]>
Message-ID:
	<[email-masked]>
	
Content-Type: text/plain; charset="iso-8859-1"

From: [email-masked] [mailto:[email-masked]] On Behalf Of Lang G?rard

> 1-Let me stress that I have, in fact, no "strenuous objection"
> with the recent "discover" that "langage des signes" became "langue 
> des signes". But I have very strenuous objection about rewriting 
> history and do not understand the strenuous resistance to the 
> establishment of  history. I agree without problem that in the past 
> decade "scientific progress" admitted that "Sign languages" could be 
> assimilated to "languages"
> and registered inside ISO 639-3. But I want to be clearly understood 
> that this was not in the intended scope of ISO 639 (and of ISO 639-1 
> and ISO 639-2) until 2000.

What is the ultimate point of this argument about history? Suppose we all agree that the creators of the original ISO 639 standard did not intend signed languages to be within the scope of that standard. So what? What bearing does that have on the work of this working group? (None whatsoever that I can see.)

> And I cannot prevent me to think that this "discover" is not 
> completely independant of "political correctness".

Call it "political correctness" if you like. In practical terms -- which I think is all that this WG cares about in this case -- there are real needs to provide language tags for signed-language content, ISO 639-x currently provides identifiers that are useful for that purpose, and the WG intends to make use of those to accommodate those needs in RFC 4646bis.

Peter

------------------------------

_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

End of Ltru Digest, Vol 44, Issue 26
************************************
_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Doug Ewell" <[email-masked]>
Date: Thu, 9 Oct 2008 06:45:53 -0600

Lang Gérard <gerard dot lang at insee dot fr> wrote:

> Concerning the link between the title "Codes for the representation of 
> names of countries" and the scope of ISO 3166[-1], I would say that 
> there never was any ambiguity for people that take the time to read 
> the normative text of the standard.

I don't have a full copy of the text of ISO 639-1 or 639-2.  Perhaps 
someone who does can say whether there is any explicit exclusion of sign 
languages, beyond the etymology of "langue."

Of course, as Peter said, this is of no concern to us (except to satisfy 
curiosity) since we are building RFC 4646bis against what ISO 639 is, 
not what it was once intended to be or what we might like it to be.

N.B.  Please don't copy the entire digest at the bottom of your posts.

--
Doug Ewell  *  Thornton, Colorado, USA  *  RFC 4645  *  UTN #14
http://www.ewellic.org
http://www1.ietf.org/html.charters/ltru-charter.html
http://www.alvestrand.no/mailman/listinfo/ietf-languages  ˆ

---

From: Peter Constable <[email-masked]>
Date: Thu, 9 Oct 2008 09:20:28 -0700

From: [email-masked] [mailto:[email-masked]] On Behalf Of Lang Gérard

Thanks for this information.

> "The list includes entities intended to satisfy the requirements
> of the broadest range of applications.

If that is the case, then the MA should be willing to consider entities for semantics such as "worldwide", "unknown" and "not applicable", which would really be helpful in many IT applications. There's no reason why exception to the norm of having entities established by the UNSO can't be made for such special-purpose entities.

> 2-The second edition (1981) clarified still this point and
> contains article "1 Scope and field of application", whose first
> paragraph writes:
> "This International Standard provides basic two-letter alphabetic
> codes [etc.]... The codes represent the names of countries,
> dependancies and other areas of special interest for purposes of
                   ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> international exchanges...."
  ^^^^^^^^^^^^^^^^^^^^^^^

In that case, why will the MA not encode entities such as Kosovo which many organizations doing business with that region must be able to support? The fact that the MA would consider telling users about other users' private-use code elements in cases such as XK suggests to me that there is a real user need that is in scope for the standard but that the standard, or the MA in its practice, is failing to address.

Peter