Subject: [Ltru] Ticket #41: AD Issue #8: section 3.5 SHOULD vs. MUST

From: "Phillips, Addison" <[email-masked]>
Date: Wed, 29 Apr 2009 15:57:29 -0700

The AD inquires:

--
AD review comment number 8 from
http://www.ietf.org/mail-archive/web/ltru/current/msg12399.html

8). In Section 3.5:

    The fields in the "Record Requested" section SHOULD follow the
    requirements in Section 3.1.

What are the reasons not to follow requirements in Section 3.1?
(I.e. why is SHOULD used instead of MUST?)
--

Good question.

Proposed Resolution: s/SHOULD/MUST/ in this sentence.

Addison Phillips
Globalization Architect -- Lab126

Internationalization is not a feature.
It is an architecture.

---

From: John Cowan <[email-masked]>
Date: Wed, 29 Apr 2009 19:03:25 -0400

> (I.e. why is SHOULD used instead of MUST?)

The reason, as stated in earlier emails, is that we want people to
be able to submit mildly incorrect forms without being REQUIRED
to heave them overboard.  MUST is used further down, when the
forms are sent from the LSR to IANA.

-- 
John Cowan   [email-masked]
    "Mr. Lane, if you ever wish anything that I can do, all you will have
        to do will be to send me a telegram asking and it will be done."
    "Mr. Hearst, if you ever get a telegram from me asking you to do
        anything, you can put the telegram down as a forgery."

---

From: "Phillips, Addison" <[email-masked]>
Date: Wed, 29 Apr 2009 16:21:03 -0700

Either keyword is inappropriate, actually. 

The request, before it is approved, is required (MUST) to meet the various requirements. 

Mistakes at request time can exist, but that does not mean that one is free to knowingly request (and expect to have approved) a record containing something that violates the rules--which is what using SHOULD implies (it implies that there may be "good reasons" to submit a request that is knowingly in violation). This is really "guidance to the form filler".

Perhaps instead say:

--
The fields in the "Record Requested" section need to follow the requirements in <xref target="ianaformat"/> before the record will be approved.
--

Addison Phillips

> -----Original Message-----
> From: John Cowan [mailto:[email-masked]]
> Sent: Wednesday, April 29, 2009 4:03 PM
> To: Phillips, Addison
> Cc: LTRU Working Group
> Subject: Re: [Ltru] Ticket #41: AD Issue #8: section 3.5 SHOULD vs.
> MUST
>

---

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 30 Apr 2009 13:42:13 -0700

Hi -

As co-chair...

> From: "Phillips, Addison" <[email-masked]>
> To: "John Cowan" <[email-masked]>
> Cc: "LTRU Working Group" <[email-masked]>
> Sent: Wednesday, April 29, 2009 4:21 PM
> Subject: Re: [Ltru] Ticket #41: AD Issue #8: section 3.5 SHOULD vs. MUST
...

There was already a lengthy (well, perhaps not length for *this* list)
discussion of this issue on April 11 and 12.

Having re-read that thread, and these more recent postings, I'm
declaring rough consensus for "no change".

HOWEVER, I'm leaving open the possibility of adding a clarification
that the passage in question  is talking about the original request
submitted for review, and not the (potentially) resulting request
forwarded to IANA.  If you believe such an addition would be
helpful, please make your proposals *now*.

Randy