Subject: [Ltru] Ticket #35, AD Issue #2: what is meant by "permanently reserved"

From: "Phillips, Addison" <[email-masked]>
Date: Tue, 28 Apr 2009 21:11:19 -0700

The AD opined:

--
[Unclear text] Clarification on what is meant by "permanently reserved"
here would be appreciated.
("Permanently reserved" == "MUST NOT be registered, unless a future
version of this document changes that"?)
--

The text seems to indicate that additional extlangs are forever banned. I propose to make it clearer by changing this text:

--
That is, the second and third extended language subtag positions in a language tag are permanently reserved and tags that include subtags in that position are invalid.
--

... to read...

--
That is, the second and third extended language subtag positions in a language tag are permanently reserved and tags that include those subtags in that position are, and will always remain, invalid.
--

Addison Phillips
Globalization Architect -- Lab126

Internationalization is not a feature.
It is an architecture.

---

From: "Randy Presuhn" <[email-masked]>
Date: Thu, 30 Apr 2009 09:41:04 -0700

Hi -

As co-chair...

Since there have been no objections to Addison's proposed
replacement text, and it seems to address the AD's concern,
I've included the resolution in the problem report
http://trac.tools.ietf.org/wg/ltru/trac/ticket/35 and closed the issue.

Randy

----- Original Message ----- 
> From: "Phillips, Addison" <[email-masked]>
> To: "LTRU Working Group" <[email-masked]>
> Sent: Tuesday, April 28, 2009 9:11 PM
> Subject: [Ltru] Ticket #35,AD Issue #2: what is meant by "permanently reserved"
>
> The AD opined:
>
> --
> That is, the second and third extended language subtag positions in a language tag are permanently reserved and tags that include
those subtags in that position are, and will always remain, invalid.
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ltru