Subject: [Ltru] Fw: [IANA #235907] Last Call: draft-ietf-ltru-4646bis (Tags for Identifying Languages) to BCP

From: "Randy Presuhn" <[email-masked]>
Date: Tue, 12 May 2009 13:44:13 -0700

Hi -

Forwarded for your information.  Please
note that there are items requiring action.

Randy

----- Original Message ----- 
> From: "Amanda Baber via RT" <[email-masked]>
> Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>; <[email-masked]>
> Sent: Tuesday, May 12, 2009 1:27 PM
> Subject: [IANA #235907] Last Call: draft-ietf-ltru-4646bis (Tags for Identifying Languages) to BCP 
>
> IESG:
> 
> IANA has reviewed draft-ietf-ltru-4646bis-21.txt and has the 
> following questions and comments:
> 
> NOTE: IANA would like to talk to the authors/ADs about other 
> options for announcing registry updates (as opposed to the 
> proposed "[email-masked]" mailing list). 
> 
> IANA understands that, upon publication of this document, no 
> IMMEDIATE actions need to be completed. However, IANA has two 
> questions about the existing templates and extensions registries 
> currently published by IANA.
> 
> IANA understands that the current document provides a procedure 
> for inserting or replacing whole records in the Language Subtag 
> Registry located at
> http://www.iana.org/assignments/language-subtag-registry.
> 
> IANA further understands that all future modifications to the 
> Language Subtag Registry will be done through the template 
> defined in section 3.5 (Figure 5). Review of the template will be 
> completed by an IESG-appointed Language Subtag Reviewer. When 
> IANA is asked to update this registry in the future, IANA 
> understands that it will be given preformatted content to insert in 
> the registry according to the instructions in section 3.3.
> 
> IANA further understands that any template submitted and 
> approved in this manner will be archived and made publicly 
> available at
> http://www.iana.org/assignments/lang-subtags-templates/. IANA 
> understands that multiple registrations can pertain to the same 
> record in the registry.
> 
> Furthermore, IANA understands that, at a future date, the IESG may 
> request that new records be inserted into the Language Tag 
> Extensions Registry located at
> http://www.iana.org/assignments/language-tag-extensions-registry
> 
> If this happens the IESG will provide the record to be inserted in the exact
> format described in section 3.7.
> 
> IANA also notes that there may be occasional requests from the 
> maintaining authority for a specific extension to update the contact 
> information or URLs in the records located at 
> http://www.iana.org/assignments/language-tag-extensions-
> registry.
> 
> If this happens, the requests will include the complete, updated 
> record. IANA understands that it is not responsible for validating 
> the information provided, only its format. IANA will make an effort 
> to ascertain that the request comes from the maintaining authority 
> named in the record present in the registry.
> 
> IANA has the following questions for the authors:
> 
> 1] What should be done with the existing registry of templates at
> http://www.iana.org/assignments/lang-subtags-templates/index.html?
> 
> 2] What should be done with the existing (but empty) Language Tag 
> Extension Registry at
> http://www.iana.org/assignments/language-tag-extensions-registry?
> 
> Thank you.
> 
> Amanda Baber
> (on behalf of IANA)
> 
> 
> > The IESG has received a request from the Language Tag Registry Update
> > WG
> > (ltru) to consider the following document:
> > 
> > - 'Tags for Identifying Languages '
> >    <draft-ietf-ltru-4646bis-21.txt> as a BCP
> > 
> > The IESG plans to make a decision in the next few weeks, and solicits
> > final comments on this action.  Please send substantive comments to
> > the
> > [email-masked] mailing lists by 2009-04-27. Exceptionally,
> > comments may be sent to [email-masked] instead. In either case, please
> > retain the beginning of the Subject line to allow automated sorting.
> > 
> > The file can be obtained via
> > http://www.ietf.org/internet-drafts/draft-ietf-ltru-4646bis-21.txt
> > 
> > 
> > IESG discussion can be tracked via
> >
> https://datatracker.ietf.org/public/pidtracker.cgi?command=view_id&dTag=15152&rfc_flag=0
> > 
> 
> 
>

---

From: John Cowan <[email-masked]>
Date: Tue, 12 May 2009 16:46:58 -0400

> > http://www.iana.org/assignments/lang-subtags-templates/index.html?

Nothing.  It will grow as new subtags are registered.

> > http://www.iana.org/assignments/language-tag-extensions-registry?

Nothing.  It will grow if extensions are registered.

-- 
A rose by any other name                            John Cowan
may smell as sweet,                                 http://www.ccil.org/~cowan
but if you called it an onion                       [email-masked]
you'd get cooks very confused.          --RMS

---

From: "Phillips, Addison" <[email-masked]>
Date: Tue, 12 May 2009 14:09:07 -0700

I concur (FWIW).

Addison Phillips
Globalization Architect -- Lab126

Internationalization is not a feature.
It is an architecture.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of John Cowan
> Sent: Tuesday, May 12, 2009 1:47 PM
> To: Randy Presuhn
> Cc: LTRU Working Group
> Subject: Re: [Ltru] Fw: [IANA #235907] Last Call: draft-ietf-ltru-
> 4646bis (Tags for Identifying Languages) to BCP
> 
> Randy Presuhn scripsit:
> 
> registry?
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ltru