Subject: [Ltru] In the interest of moving faster...

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 27 May 2009 11:27:14 -0700

Hi -

As someone who's been doing IETF stuff for a long long time,
rather than as co-chair or as a technical contributor...

At this stage of the process, the fastest way to resolve
review comments is to look carefully at the proposed resolution.
If it's something you could live with, just say "ok" and
make no further comment.  If the reviewer doesn't make
a specific proposal, propose minimal-change text that
*directly* addresses the thrust of the comment.

The next-quickest path is to say "no, we already considered
this alternative and rejected it."

Word-smithing the proposal will slow things down, and should
only be done if there's significant problems with the
proposal (ambiguities or lack of clarity).

If you want to bring things to a grinding halt, drag
in peripheral issues not directly raised by the review
comment.

Ironically, total silence also slows things down.

Don't forget that after we're finished with it, the RFC
editor gets a chance to fix English usage, punctuation,
etc.

Randy

---

From: Peter Constable <[email-masked]>
Date: Wed, 27 May 2009 16:44:04 -0700

In the interest of moving faster, we should choose *not* to discuss purely editorial issues and leave them to the editors to resolve at their discretion.

Peter

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Randy Presuhn
Sent: Wednesday, May 27, 2009 11:27 AM
To: LTRU Working Group
Subject: [Ltru] In the interest of moving faster...

Hi -

Randy

_______________________________________________
Ltru mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 27 May 2009 17:07:07 -0700

Hi -

> From: "Peter Constable" <[email-masked]>
> To: "Randy Presuhn" <[email-masked]>; "LTRU Working Group" <[email-masked]>
> Sent: Wednesday, May 27, 2009 4:44 PM
> Subject: RE: [Ltru] In the interest of moving faster...
>
> In the interest of moving faster, we should choose *not* to discuss
> purely editorial issues and leave them to the editors to resolve at their discretion.

That's fine during earlier stages, but that approach generally
doesn't fly at this stage of the process in groups with a history
like ours.

We really need to keep the AD and (in this case) the
apps area reviewer in the loop and address the feedback
we've received from them.  Carte blanche to the editors
is not something I'm willing to consider, given the the history
of the text and this WG.   No one should be surprised by
the text that shows up in the RFCs.

Randy

---

From: Peter Constable <[email-masked]>
Date: Wed, 27 May 2009 17:49:41 -0700

> doesn't fly at this stage of the process in groups with a history

It is precisely because of the stage that we're at that we should simply let *editorial* changes be handled by the editors and not as issues that require consensus decisions from a committee of editors.

> we've received from them.

Fair enough. Reporting on the resolution is one thing. Using a committee consensus process to resolve the disposition of those issues is quite another.

> Carte blanche to the editors
> is not something I'm willing to consider

I didn't mean to suggest that. Let the editors _be_ editors, make editorial changes and then they can report to us what changes they make. If they step over the bounds of editorial content, we'll surely catch them.

We just do not have to bog every single decision down in a committee, consensus decision. Some issues just aren't worth it. It is far more important to bring this project to closure.

Peter

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 27 May 2009 20:01:11 -0700

Hi Peter -

As co-chair...

If you object to the way the co-chairs have chosen to conduct the
process, you are free to appeal our decisions to the responsible AD.

Randy

----- Original Message ----- 
From: "Peter Constable" <[email-masked]>
To: "Randy Presuhn" <[email-masked]>; "LTRU Working Group" <[email-masked]>
Sent: Wednesday, May 27, 2009 5:49 PM
Subject: RE: [Ltru] In the interest of moving faster...

> doesn't fly at this stage of the process in groups with a history

It is precisely because of the stage that we're at that we should simply let *editorial* changes be handled by the editors and not
as issues that require consensus decisions from a committee of editors.

> we've received from them.

Fair enough. Reporting on the resolution is one thing. Using a committee consensus process to resolve the disposition of those
issues is quite another.

> is not something I'm willing to consider

I didn't mean to suggest that. Let the editors _be_ editors, make editorial changes and then they can report to us what changes they
make. If they step over the bounds of editorial content, we'll surely catch them.

We just do not have to bog every single decision down in a committee, consensus decision. Some issues just aren't worth it. It is
far more important to bring this project to closure.

Peter

---

From: Peter Constable <[email-masked]>
Date: Wed, 27 May 2009 21:24:11 -0700

I am not objecting to how the co-chairs are conducting the process. You asked that we move faster, and commented on the best way to do that at this point. I simply took what you suggested a step further. 

I will suggest that, IMO, the co-chairs could be a bit more directive if pointless discussions start up, particularly when there is nothing technical at stake. That's not an objection but a suggestion to get us to closure more quickly. If people start discussing whether a certain bit of inconsequential text was inherited from an earlier version or whether passive voice is the most appropriate way to express something, step in and politely suggest that that those considerations will not have any practical positive impact on use of this spec but that each additional day we delay completion has real, negative impact. 

There are eight active items in the issue tracker, one of which has been open for over six weeks. Is there anything standing in the way from having all of these closed within the next five days?

Peter

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Randy Presuhn
Sent: Wednesday, May 27, 2009 8:01 PM
To: LTRU Working Group
Subject: Re: [Ltru] In the interest of moving faster...

Hi Peter -

As co-chair...

Randy

----- Original Message ----- 
From: "Peter Constable" <[email-masked]>
To: "Randy Presuhn" <[email-masked]>; "LTRU Working Group" <[email-masked]>
Sent: Wednesday, May 27, 2009 5:49 PM
Subject: RE: [Ltru] In the interest of moving faster...

Peter

---

From: "Randy Presuhn" <[email-masked]>
Date: Wed, 27 May 2009 22:02:06 -0700

Hi -

> Sent: Wednesday, May 27, 2009 9:24 PM
...
> There are eight active items in the issue tracker, one of which has
> been open for over six weeks. Is there anything standing in the way
> from having all of these closed within the next five days?
...

As a technical contributor I've already commented on all of the issues.
In many cases I've made specific proposals for resolving/rejecting
the comments or indicated that I could live with the proposal supplied
by the reviewer.  So I've done my part as a technical contributor.

If we could simply have declared consensus on those proposals,
we'd already be done.  But that obviously was not to be.

I'll be off-line (attending a meeting I'm actually interested in) until late
Sunday, so do not expect any further contributions from me during this
time.  Martin will be making the consensus calls and wrapping things
up as document shepherd, as he's already indicated, when and how
he sees fit.

Randy

---

From: "Phillips, Addison" <[email-masked]>
Date: Thu, 28 May 2009 08:10:55 -0700

Okay.

:-)

Addison Phillips
Globalization Architect -- Lab126

Internationalization is not a feature.
It is an architecture.

---

From: Peter Constable <[email-masked]>
Date: Thu, 28 May 2009 14:41:05 -0700

> Martin will be making the consensus calls and wrapping things

Then, Martin, I will encourage you to wrap things up quickly.

Peter