Subject: Re: [Ltru] Issue 53: Section 2.2.3 (2) is murky (Apps #6)

From: "Randy Presuhn" <[email-masked]>
Date: Sun, 24 May 2009 15:23:42 -0700

Hi -

> From: "Alexey Melnikov" <[email-masked]>
> To: "LTRU Working Group" <[email-masked]>
> Cc: "Martin J. Dürst" <[email-masked]>; "Randy Presuhn" <[email-masked]>
> Sent: Sunday, May 24, 2009 5:23 AM
> Subject: Additional issues with 4646bis raised by an Apps Review Team review
...
> 6). In Section 2.2.3:
>
> >    2.  Script subtags consist of four letters and were defined according
> >        to [ISO15924]--"Codes for the representation of the names of
> >        scripts": alpha-4 script codes, or subsequently assigned by the
> >        ISO 15924 registration authority or governing standardization
> >        bodies, denoting the script or writing system used in conjunction
> >        with this language.  Only codes assigned by ISO 15924 will be
> >        considered for registration.
>
> The first sentence is hard to understand. It looks like it has misplaced
> punctuation.
...

As a technical contributor:  Yes.

First: either
s/": alpha-4 script codes,/: alpha-4 script codes,"/
or, better still,
s/]--"Codes for the representation of the names of scripts": alpha-4 script codes//

Secondly,
s/bodies, denoting the/ bodies.  A script subtag denotes a/

Propose replacement text, with additional edits, would be:
   2.  Script subtags consist of four letters and are defined according
        to [ISO15924] or subsequently assigned by the ISO 15924
        registration authority or governing standardization bodies.
       A script subtag denotes a script or writing system used in
       conjunction with a language.  Only codes assigned by ISO
      15924 will be considered for registration.

Randy

---

From: "Phillips, Addison" <[email-masked]>
Date: Tue, 26 May 2009 16:39:39 -0700

The problem here is partly with the way the reference is rendered. The format of this paragraph mirrors similar paragraphs in the various other subtag types. What is different here is that the name of ISO 15924 is not parenthesized and so makes the sentence difficult to parse (in addition to being a run-on).

I would suggest, in place of Randy's proposal, the following replacement text:

--
       Script subtags consist of four letters and were defined according
       to [ISO15924] ("Codes for the representation of the names of
       scripts: alpha-4 script codes"), or subsequently assigned by the
       ISO 15924 registration authority or governing standardization
       bodies. Script subtags denote the script or writing system used in conjunction
       with this language.
--

Addison Phillips
Globalization Architect -- Lab126

Internationalization is not a feature.
It is an architecture.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Randy Presuhn
> Sent: Sunday, May 24, 2009 3:24 PM
> To: LTRU Working Group
> Subject: Re: [Ltru] Issue 53: Section 2.2.3 (2) is murky (Apps #6)
> 
> Hi -
> 
> _______________________________________________
> Ltru mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ltru

---

From: "Randy Presuhn" <[email-masked]>
Date: Tue, 26 May 2009 17:25:06 -0700

Hi -

> From: "Phillips, Addison" <[email-masked]>
> To: "Randy Presuhn" <[email-masked]>; "LTRU Working Group" <[email-masked]>
> Sent: Tuesday, May 26, 2009 4:39 PM
> Subject: RE: [Ltru] Issue 53: Section 2.2.3 (2) is murky (Apps #6)
...
> I would suggest, in place of Randy's proposal, the following replacement text:

As a technical contributor...

(1) I don't find the parenthetic material helpful.
(2) I have a problem with "denote *the* script".  "denote *a* script"
    would be fine with me.
(3) I assume your omission of "Only codes assigned by ISO
    15924 will be considered for registration." was unintentional,
    since dropping that sentence would seem to be a technical change
    from the I-D that was last-called.

Randy

---

From: Mark Davis <[email-masked]>
Date: Tue, 26 May 2009 17:49:18 -0700

Addison is right about *the* script. In a language tag such as "az-Latn" the
script subtag *is* denoting the script for the language. But I agree that
the language is a bit awkward. You're right about the omission later.

My suggestion:

Script subtags consist of four letters and are defined according to
[ISO15924] "Codes for the representation of the names of scripts: alpha-4
script codes". They are either defined directly in [ISO15924], or
subsequently assigned by the ISO 15924 registration authority or governing
standardization bodies. The presence of a script subtag in a language tag
indicates associated content being in a writing system corresponding to that
script. Only codes assigned by ISO 15924 will be considered for
registration.

Mark

---

From: "Phillips, Addison" <[email-masked]>
Date: Tue, 26 May 2009 18:02:07 -0700

> (1) I don't find the parenthetic material helpful.

I include the title because we include the formal title for the other standards (cf. ISO3166, ISO 639, etc) in the other section 2.2 subtags. It isn't that helpful there either. What I'm proposing is to make it consistent, which also makes it clearer.

> (2) I have a problem with "denote *the* script".  "denote *a*
> script" would be fine with me.

I agree with Mark here: it should be "the".

>     since dropping that sentence would seem to be a technical
> change from the I-D that was last-called.

Actually, I omitted it because, as noted, it was only the one sentence that we were considering. I didn't quote the whole paragraph; I don't believe you did either (although I have not looked). I agree that the sentence you note must appear.

Addison

---

From: Kent Karlsson <[email-masked]>
Date: Wed, 27 May 2009 10:11:03 +0200

> (1) I don't find the parenthetic material helpful.

If the title is kept here (in parentheses), the title should be the
actual title of that standard:

Information and documentation -- Codes for the representation of names of
scripts

See 
http://www.iso.org/iso/search.htm?qt=15924&searchSubmit=Search&sort=rel&type
=simple&published=on.

The references section has it right.

    /kent k

---

From: Marion Gunn <[email-masked]>
Date: Wed, 27 May 2009 18:39:56 +0100

That is simply a question a question of fixing bad and/or unclear 
English. The straight way to fix this is to refer in the first instance 
to the Standard by its ISO number AND title (without the clumsy use of 
parenthesis) and in the second instance (a line or two further down) by 
its number only (the reference being to its RA). BTW, I'd expect 
Registration Authority to be in title case, but that is less important 
than fixing bad English style.

Hope this helps,
mg

-- 

Marion Gunn * eGteo (Estab.1991)

27 Páirc an Fhéithlinn, Baile an

Bhóthair, An Charraig Dhubh,

Co. Átha Cliath, Éire/Ireland

* [email-masked] * [email-masked] *

---

From: "Martin J. Dürst" <[email-masked]>
Date: Fri, 29 May 2009 19:27:39 +0900

[co-chair hat on] This one was a bit more complicated :-(.

I think we have consensus for the following version of point 2 of 
Section 2.2.3.

   2.  Script subtags consist of four letters and were defined according
       to [ISO15924] ("Information and documentation -- Codes for the
       representation of names of scripts"), or subsequently assigned by
       the ISO 15924 registration authority or governing standardization
       bodies. Script subtags denote the script or writing system used
       in conjunction with this language. Only codes assigned by ISO
       15924 will be considered for registration.

This is mostly Addison's version, with the last sentence of the 
paragraph added back in, and with the title fixed as pointed out by Kent.

I hope this should address the concern of the commenter, and will be 
acceptable to everybody on the WG.

Regards,    Martin.

On 2009/05/25 7:23, Randy Presuhn wrote:
> Hi -
>
>> From: "Alexey Melnikov"<[email-masked]>
>> To: "LTRU Working Group"<[email-masked]>
>> Cc: "Martin J. Dürst"<[email-masked]>; "Randy Presuhn"<[email-masked]>

-- 
#-# Martin J. Dürst, Professor, Aoyama Gakuin University
#-# http://www.sw.it.aoyama.ac.jp   mailto:[email-masked]

---

From: Peter Constable <[email-masked]>
Date: Fri, 29 May 2009 08:03:40 -0700

+1

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of "Martin J. Dürst"
Sent: Friday, May 29, 2009 3:28 AM
To: Randy Presuhn
Cc: LTRU Working Group
Subject: Re: [Ltru] Issue 53: Section 2.2.3 (2) is murky (Apps #6)

Regards,    Martin.

---

From: "Phillips, Addison" <[email-masked]>
Date: Fri, 29 May 2009 08:36:15 -0700

(editor hat on)

I have placed this text, with the following changes. 

1. This sentence has problems with count agreement:

> Script subtags denote the script or writing system
> used in conjunction with this language.

I note that the first paragraph of this section, introducing the bullet list in which this item appears, already says what script subtags are. It reads:

--
<t>Script subtags are used to indicate the script or writing system variations that distinguish the written forms of a language or its dialects. The following rules apply to the script subtags:</t>
--

Therefore I removed this sentence. 

2. I added the phrase "the assignments found in" to make the first sentence consistent with other "ISO-assignments" sentences.

The paragraph now reads:

--
<t>Script subtags consist of four letters and were defined according
to the assignments found in <xref target="ISO15924"></xref> ("Information and documentation -- Codes for the
representation of names of scripts"), or subsequently assigned by
the ISO 15924 registration authority or governing standardization
bodies. Only codes assigned by ISO 15924 will be considered for registration.</t>
--

Note: I also checked that our other references to ISO15924 used the correct title, which they do.

Addison 

Addison Phillips

> Behalf Of "Martin J. Dürst"

---

From: Mark Davis <[email-masked]>
Date: Fri, 29 May 2009 09:01:31 -0700

+1

Mark

2009/5/29 Phillips, Addison <[email-masked]>

> I note that the first paragraph of this section, introducing the bullet
> list in which this item appears, already says what script subtags are. It
> reads:
>
> --
> <t>Script subtags are used to indicate the script or writing system
> variations that distinguish the written forms of a language or its dialects.
> The following rules apply to the script subtags:</t>
> --
>
> 2. I added the phrase "the assignments found in" to make the first sentence
> consistent with other "ISO-assignments" sentences.
>
> The paragraph now reads:
>
> --