Subject: [Ltru] Fw: I-D Action:draft-burnett-pronunciation-alphabet-registry-00.txt

From: "Randy Presuhn" <[email-masked]>
Date: Sun, 13 Dec 2009 20:22:18 -0800

Hi -

This i-d might be of interest to folks who participated in the ltru effort.

Randy

----- Original Message ----- 
> From: <[email-masked]>
> To: <[email-masked]>
> Sent: Friday, December 04, 2009 5:00 AM
> Subject: I-D Action:draft-burnett-pronunciation-alphabet-registry-00.txt 
>
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> Title           : Pronunciation Alphabet Registry
> Author(s)       : D. Burnett, Z. Shuang
> Filename        : draft-burnett-pronunciation-alphabet-registry-00.txt
> Pages           : 16
> Date            : 2009-12-04
> 
> This document describes a new registry for Pronunciation Alphabets,
> such as pinyin, that can be used to describe pronunciations of words
> and phrases in a particular language.
> 
> Status of this Memo
> 
> This Internet-Draft is submitted to IETF in full conformance with the
> provisions of BCP 78 and BCP 79.
> 
> Internet-Drafts are working documents of the Internet Engineering
> Task Force (IETF), its areas, and its working groups.  Note that
> other groups may also distribute working documents as Internet-
> Drafts.
> 
> Internet-Drafts are draft documents valid for a maximum of six months
> and may be updated, replaced, or obsoleted by other documents at any
> time.  It is inappropriate to use Internet-Drafts as reference
> material or to cite them other than as "work in progress."
> 
> The list of current Internet-Drafts can be accessed at
> http://www.ietf.org/ietf/1id-abstracts.txt.
> 
> The list of Internet-Draft Shadow Directories can be accessed at
> http://www.ietf.org/shadow.html.
> 
> This Internet-Draft will expire on June 7, 2010.
> 
> Copyright Notice
> 
> Copyright (c) 2009 IETF Trust and the persons identified as the
> document authors.  All rights reserved.
> 
> This document is subject to BCP 78 and the IETF Trust's Legal
> Provisions Relating to IETF Documents
> (http://trustee.ietf.org/license-info) in effect on the date of
> publication of this document.  Please review these documents
> carefully, as they describe your rights and restrictions with respect
> to this document.  Code Components extracted from this document must
> include Simplified BSD License text as described in Section 4.e of
> the Trust Legal Provisions and are provided without warranty as
> described in the BSD License.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-burnett-pronunciation-alphabet-registry-00.txt
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.
> 

--------------------------------------------------------------------------------

> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>

---

From: John Cowan <[email-masked]>
Date: Tue, 15 Dec 2009 16:02:29 -0500

> This i-d might be of interest to folks who participated in the ltru effort.

This effort seems singularly pointless and duplicative, since these
Pronouncing Alphabets are just romanization systems, and we already
register those as variant subtags.

Is there any IETF-ly organizational method of discouraging this?

-- 
But that, he realized, was a foolish            John Cowan
thought; as no one knew better than he          [email-masked]
that the Wall had no other side.                http://www.ccil.org/~cowan
        --Arthur C. Clarke, "The Wall of Darkness"

---

From: "Randy Presuhn" <[email-masked]>
Date: Tue, 15 Dec 2009 22:44:34 -0800

Hi -

> From: "John Cowan" <[email-masked]>
> To: "Randy Presuhn" <[email-masked]>
> Cc: "LTRU Working Group" <[email-masked]>
> Sent: Tuesday, December 15, 2009 1:02 PM
> Subject: Re: [Ltru] Fw: I-D Action:draft-burnett-pronunciation-alphabet-registry-00.txt
...
> Is there any IETF-ly organizational method of discouraging this?
...

My suggestion would be to engage directly with the authors,
and to perhaps request use cases (for potential inclusion in
the document) to clarify whether these are in fact "just romanization
systems", and whether a (select subset of) language tags could
provide the same functionality or not.  It's really important to
get clarification (and to make the draft clear) about this point.

(FWIW, I don't see why a pronouncing alphavet would *necessarily*
be a romanization system.)

The next point of input would be to alert an Area Diretor (e.g.
Alexey Melnikov) so that the IESG would be aware of potential
concerns, particularly potential overlap with existing IETF BCP.

Randy

---

From: Peter Constable <[email-masked]>
Date: Wed, 16 Dec 2009 08:59:49 +0000

From: [email-masked] [mailto:[email-masked]] On Behalf Of Randy Presuhn

> (FWIW, I don't see why a pronouncing alphavet would *necessarily* be a romanization system.)

Indeed: I met a Korean linguist about 10 years ago who was promoting use of Hangul for general phonetic transcription.

Peter

---

From: Kent Karlsson <[email-masked]>
Date: Wed, 16 Dec 2009 10:38:24 +0100

I don't know who you are referring to... But I know of a book partly on the
subject of using Hangul as a phonetic alphabet (OPA, Othophonic alphabet):

The Korean alphabet of 1446  Expositions, OPA, The visible speech sounds,
Annotated translation, Future applicability; Sek Yen Kim-Cho, Humanity Books
and AC Press, New York, 2002, ISBN 89-428-1587-1.

http://www.amazon.com/Korean-Alphabet-1446-Expositions-Applicability/dp/1591
02000X

    /kent k

Den 2009-12-16 09.59, skrev "Peter Constable" <[email-masked]>:

> Indeed: I met a Korean linguist about 10 years ago who was promoting use of
> Hangul for general phonetic transcription.
> 
> 
> 
> Peter
> Ltru mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ltru

---

From: Leif Halvard Silli <[email-masked]>
Date: Wed, 16 Dec 2009 14:28:04 +0100

Peter Constable, Wed, 16 Dec 2009 08:59:49 +0000:
> Indeed: I met a Korean linguist about 10 years ago who was promoting 
> use of Hangul for general phonetic transcription.

Indeed. But whether we talk about Romanization or a form of 
transliteration/transcription into a non-Roman script - such as 
Cyrillic, seems besides the point. Or? 

The pronunciation alphabet registry is meant to be used in documents 
crafted according to the Pronunciation Lexicon Specification or the 
Speech Synthesis Markup Language, which both of them reckon IPA as one 
of the possible pronunciation alphabets. As code for IPA, they both use 
"ipa'. However, 'ipa' is not registered in the pronunciation alphabet 
registry. As we know, the LTR tag for IPA is 'fonipa'.

The real question is: Should they have relied on the language tag 
registry or on their own registry?

The Pronunication Lexicon spec includes xml:lang as part of its 
language: [1]

 ]]
The required xml:lang attribute allows identification of the language 
for which the pronunciation lexicon is relevant. IETF Best Current 
Practice 47 [BCP47] is the normative reference on the values of the 
xml:lang attribute.
Note that xml:lang specifies a single unique language for the entire 
PLS document. This does not limit the ability to create multilingual 
SRGS [SRGS] and SSML [SSML] documents. These documents may reference 
multiple pronunciation lexicons, possibly written for different 
languages.
 [[

Here is a simplification of one example in the PLS spec: [2]

<lexicon alphabet="ipa" xml:lang="en-US">
  <lexeme>
    <grapheme>tomato</grapheme>
    <phoneme>təmei̥ɾou̥</phoneme>
    <!-- IPA string is: "t&#x0259;mei&#x325;&#x027E;ou&#x325;" -->
  </lexeme>
</lexicon>

I guess, in theory, they could have skipped the alphabet attribute and 
used a language tag in the phoneme element instead - though it could be 
very 
impractical and perhaps error prone:

<lexicon xml:lang="en-US">
  <lexeme>
    <grapheme>tomato</grapheme>
    <phoneme xml:lang="en-US-fonipa" >təmei̥ɾou̥</phoneme>
    <!-- IPA string is: "t&#x0259;mei&#x325;&#x027E;ou&#x325;" -->
  </lexeme>
</lexicon>

But may be they could have changed alphabet="ipa" to 
alphabet="en-US-fonipa"? That would at least require a rewrite of the 
spec. But I think this also would have been impractical and also prone 
to errors. E.g. what if the xml:lang said "en-us" and the alphabet 
attribute said "ru-ru-fonipa"?

[1] http://www.w3.org/TR/pronunciation-lexicon/#S4.1
[2] http://www.w3.org/TR/pronunciation-lexicon/#S4.1.1
-- 
leif halvard silli

---

From: "Phillips, Addison" <[email-masked]>
Date: Wed, 16 Dec 2009 11:08:07 -0500

Hi,

Actually, I spoke with the authors (they represent the W3C SSML [Speech Synthesis Markup Language] Working Group) last month at W3C TPAC in Santa Clara. The problem they are trying to solve looks superficially like a job for language tags and my first advice to them was to consider registration of subtags, use of language tags, or creation of an extension. However they had reasons to seek a separate registry which didn't seem unreasonable to me at the time.

The main thing is that pronunciation schemes tend to be vendor specific and are not necessarily transcriptions or, in fact, even useful outside the speech synthesis process. It seems unlikely to me that the language subtag registry would take in a wide variety of these things, especially the vendor-specific variations.

I am in receipt of a request to discuss this at today's W3C Internationalization WG call, a non-IETF organization may (or may not) discourage this or at least look further into it.

Addison

Addison Phillips
Globalization Architect -- Lab126

Internationalization is not a feature.
It is an architecture.

> -----Original Message-----
> Sent: Tuesday, December 15, 2009 10:45 PM
> To: LTRU Working Group

---

From: Leif Halvard Silli <[email-masked]>
Date: Wed, 16 Dec 2009 20:56:31 +0100

Phillips, Addison, Wed, 16 Dec 2009 11:08:07 -0500:

> [..] the authors (they represent the W3C SSML [..] had reasons to seek
>  a  separate registry which didn't seem unreasonable to me at the time.
> 
> The main thing is that pronunciation schemes tend to be vendor 
> specific and are not necessarily transcriptions or, in fact, even 
> useful outside the speech synthesis process. It seems unlikely to me 
> that the language subtag registry would take in a wide variety of 
> these things, especially the vendor-specific variations.

They cease to be vendor specific when registered in the Pronunciation 
Registry (PR), just as windows-1252 has long ago ceased to be Windows 
specific. PR obviously should exist on its own. But perhaps it would be 
useful if there were cooperation between the PR and LTR:

* PR could be shaped more like LTR is. What about recommending 
"pinyin-2001" instead of "pinyin2001"? Then it would be easy to reuse 
'2001' in LTR, if requested. And 'fonipa' could be registered in the PR 
as an alias for 'ipa', to reflect the LTRU registry. 
* Many pronunciations alphabets are unregistered, and regardless of 
where they would registered first, the tag they would get in the first 
registration, could be a candidate for reuse in the other registry.

Examples of unregistered (anywhere) pronunciation alphabets that I am 
aware of:

* the Russian phonetic/pronunciation alphabet for use in education and 
teaching of Russian. It only uses a subset of the usual Russian 
Cyrillic letters + diacritical marks.
* Norvegia, for the notation of spoken/dialect Norwegian (in use since 
19th century) [1][2]
* Danish has the Danica alphabet and Swedish has a similar thing.[2]

I can already say that we ourselves in our teaching material efforts 
would have found it practical if there existed a LTR variant subtag for 
the Russian pronunciation alphabet.

[1] http://no.wikipedia.org/wiki/Norvegia_(lydskrift)
[2] http://www.hum.uit.no/Forproven/Fagpresentasjoner/lydskrift.html
-- 
leif halvard silli

---

From: Peter Constable <[email-masked]>
Date: Wed, 16 Dec 2009 21:20:20 +0000

From: Leif Halvard Silli [mailto:[email-masked]] 

> Speech Synthesis Markup Language...

It would have be helpful if that had been clear in the introduction. I looked for indicators of the intended applications and didn't see anything I recognized as such.

Peter

---

From: Leif Halvard Silli <[email-masked]>
Date: Wed, 16 Dec 2009 23:35:03 +0100

Peter Constable, Wed, 16 Dec 2009 21:20:20 +0000:
> It would have be helpful if that had been clear in the introduction. 
> I looked for indicators of the intended applications and didn't see 
> anything I recognized as such.

Second paragraph of the introduction:

]]
   Pronunciation Alphabet tags can be used in the alphabet attribute of
   the phoneme element in the Speech Synthesis Markup Language
   [W3C.CR-speech-synthesis11-20090827].  At some point in the future
   they may also be usable within the alphabet attribute of the phoneme
   and lexicon elements in the Pronunciation Lexicon Specification
   [W3C.REC-pronunciation-lexicon-20081014].
[[
-- 
leif halvard silli