Subject: [Lwip] questions on LWIG

From: "Yan Wang" <[email-masked]>
Date: Thu, 17 May 2012 14:37:46 +0800

Hi all,

I am interested in LWIG group. I read draft-bormann-lwig-guidance-01, and
the Section 3 is much helpful to my work. But I saw that most chapters in
the Section 4 only have the title/outline. I don’t know whether there is
nobody interested in them, or they just follow the conventional ways and
don’t need much explanation, or somebody are working on them.

My current work is focus on DNS, and I know IETF does not want DNS to take
duties of non-DNS. So what is the defined range of DNS in Section 4.4 in
this draft? I think it shouldn’t be defining a simplified DNS protocol. Is
it the implementation experience on constrained networks similar to
dnsmasq/mdns? Please give your kind advices.

Best regards, 

Yan Wang

---

From: "Dijk, Esko" <[email-masked]>
Date: Tue, 22 May 2012 09:57:48 +0000

Hello Yan,

the empty sections in the document are currently still open to contributions.  As far as I know, nobody is working on these sections now. The scope of DNS is indeed not a simplified DNS protocol, but rather light-weight implementation techniques of DNS.  In my view that includes DNS client used for "typical DNS duties"; and also multicast-DNS (mDNS).

regards,
Esko

From: [email-masked] [mailto:[email-masked]] On Behalf Of Yan Wang
Sent: Thursday 17 May 2012 8:38
To: [email-masked]
Subject: [Lwip] questions on LWIG

Hi all,

I am interested in LWIG group. I read draft-bormann-lwig-guidance-01, and the Section 3 is much helpful to my work. But I saw that most chapters in the Section 4 only have the title/outline. I don't know whether there is nobody interested in them, or they just follow the conventional ways and don't need much explanation, or somebody are working on them.

My current work is focus on DNS, and I know IETF does not want DNS to take duties of non-DNS. So what is the defined range of DNS in Section 4.4 in this draft? I think it shouldn't be defining a simplified DNS protocol. Is it the implementation experience on constrained networks similar to dnsmasq/mdns? Please give your kind advices.

Best regards,
Yan Wang

________________________________
The information contained in this message may be confidential and legally protected under applicable law. The message is intended solely for the addressee(s). If you are not the intended recipient, you are hereby notified that any use, forwarding, dissemination, or reproduction of this message is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender by return e-mail and destroy all copies of the original message.