Subject: Re: [magma] IP multicast and Ethernet multicast

From: "Beatriz Silva" <[email-masked]>
Date: Fri, 28 Jun 2002 04:47:21 -0500

Thanks Brian and Frank : )

>the sender would need to keep track of which
>nodes are members of the group and then send individual >copies out

Now I understand that the sender does not do that. But it has to send IGMP messages to the multicast router to inform it when it joins or leaves a group.
Does then the router do this kind of multicast ip - mac addresses of the group members mapping and forwards individual copies out (for each member)
or 
it just knows the attached networks which contains members of a group and forwards messages with a ethernet multicast address to this networks ?

If the second option is true, it means the router does not keep detailed information of all of the members (mac or ip addresses) of a determined group ?
Is that mapping of IP multicast addres to mac addresses of the group members done at some point, at any device ?
And, last , the membership report message is sent by the host directly to the ip of the multicast router or to the ip multicast address of the group ?

I hope I did not ask too much ...
Thank you very much,
Beatriz

----- Original Message -----
From: Brian Haberman <[email-masked]>
Date: Thu, 27 Jun 2002 11:18:33 -0400
To: Beatriz Silva <[email-masked]>
Subject: Re: [magma] IP multicast and Ethernet multicast

> 
> Frank Solensky wrote:
> > 
> > On Thu, 2002-06-27 at 06:36, Beatriz Silva wrote:
> > > And also, I do not understand why there is this map to an ethernet
> > > address. I thought that IP multicast addresses would be mapped to the
> > > mac addresses of the members of the group ?
> > 
> > In order to do it this way, the sender would need to keep track of which
> > nodes are members of the group and then send individual copies out.
> > That defeats the purpose of multicasting: send one out that gets picked
> > up by only the interested parties.  The way the hardware makes this
> > distinction is by looking at only the first bit of the MAC address: a
> > '0' indicates only one receiver and '1' indicates a group address (the
> > special case of all 1s being a broadcast).
> 
> To expand a little on Frank's answer.  When a node decides to join
> an IP multicast group, it must also register with its NIC that it
> wants to listen for the corresponding L2 group address.
> 
> Brian
> 

-- 
__________________________________________________________
Sign-up for your own FREE Personalized E-mail at Mail.com
http://www.mail.com/?sr=signup

Save up to $160 by signing up for NetZero Platinum Internet service.
http://www.netzero.net/?refcd=N2P0602NEP8

_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: Brian Haberman <[email-masked]>
Date: Fri, 28 Jun 2002 07:30:18 -0400

Beatriz,

> Does then the router do this kind of multicast ip - mac addresses of the group members mapping and forwards individual copies out (for each member)

no.

> it just knows the attached networks which contains members of a group and forwards messages with a ethernet multicast address to this networks ?

yes.

> If the second option is true, it means the router does not keep detailed information of all of the members (mac or ip addresses) of a determined group ?

In general true.  IGMPv3 has slightly different processing rules.
See section A.2 point 1 of the IGMPv3 spec for discussion.

> Is that mapping of IP multicast addres to mac addresses of the group members done at some point, at any device ?

no.

> And, last , the membership report message is sent by the host directly to the ip of the multicast router or to the ip multicast address of the group ?

IGMPv1 and IGMPv2 send the joins to the multicast group.  IGMPv3 sends
the joins to the IGMPv3-Routers address (224.0.0.22).

Brian