Subject: RE: [magma] How to implement IP multicast on a fully LAN-switched enterprise network

From: "Ben Carter" <[email-masked]>
Date: Wed, 15 Jan 2003 12:48:38 -0800

Ehhui:
Are you saying that your transmitter and your receivers are on the same 
network segment with no layer 3 infrastructure between them? In this 
scenario snooping may not function correctly without a router to act as
IGMP 
querier, or with IGMP snooping switches that flood unsolicited IP
multicast 
traffic.

Ben Carter
Network Analyst
Douglas County PUD
1151 Valley mall Parkway
East Wenatchee WA, 98802
Voice: (509) 884-7191
Fax:    (509) 884-0553

>  Hi,
> 
>  I have a problem. How to deploy IP multicast on an enterprise network
>  built with L:2 switches as backbone and L3 switches / routers as
>  egress? It means that transmitters and receivers all in a large LAN.
> 
>  thanks,
>  Enhui Liu
>  _______________________________________________
>  magma mailing list
>  [email-masked]
>  https://www1.ietf.org/mailman/listinfo/magma
> 
_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: Enhui Liu <[email-masked]>
Date: Thu, 16 Jan 2003 11:04:36 +0800

Ben and Bill,

Yes, I means that there is  no layer 3 device between transmitters and receivers.
L2 switches are layed hierarchically and convergently. L3 switches  is the egress devices of such network.
If  these L3 switches  act as IGMP querier, it is inefficient. Because multicast is just internal.
Though, if L2 switches flood  unsolicited IP multicast traffic, it actually is broadcast.

So,  Is there no way to deploy multicast not broadcast in such network?

My test application is IP TV. There are about several hundreds or one thousand of internal hosts. 

Enhui

---

From: Enhui Liu <[email-masked]>
Date: Thu, 16 Jan 2003 11:04:36 +0800

Ben and Bill,

Enhui