Subject: RE: [magma] msf state transition using BLK to UNBLK

From: "Dave Thaler" <[email-masked]>
Date: Thu, 7 Aug 2003 17:31:01 -0700

I'm not sure what you mean about "kernel must return error"...
Are you asking about what state a router should be in if it gets
those messages from a given host? 

If so, then following the tables in RFC 3376, we get
    Message     Router state
1. IN{null}     INCLUDE{null}
   IS_EX{null}  EXCLUDE(null,null}
   BLOCK{a}     EXCLUDE{a,null}
After group timer expires -> EXCLUDE(null,null)
   ALLOW{a}     EXCLUDE{a,null}

2. IN{null}     INCLUDE{null}
   BLOCK{a}     INCLUDE{null}
   ALLOW{a}     INCLUDE{a}

-Dave

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Hitoshi Asaeda
> Sent: Monday, July 28, 2003 9:35 AM
> To: [email-masked]
> Subject: [magma] msf state transition using BLK to UNBLK
> 
> Hi all.
> 
> Can you compare following two operations and tell me the correct
> MSF status?
> 
> 1. IN{null} -> IS_EX{null} -> BLOCK{a} -> UNBLOCK{a} -> X
>    What is the state of "X"? Is it EX{null}?
> 2. IN{null} -> BLOCK{a} -> UNBLOCK{a} -> Y
>    What is the state of "Y"? Is it EX{null}, or IN{null}?
>    Or it's not permitted? (i.e. Kernel must return error when BL{a} is
>    given?)
> 
> Thanks.
> --
> Hitoshi Asaeda
> 
> _______________________________________________
> magma mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/magma

_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: Hitoshi Asaeda <[email-masked]>
Date: Fri, 08 Aug 2003 11:34:34 +0200 (MEST)

> those messages from a given host? 

Ah, I'm sorry. I had asked about *host state* after some application
changed MSF state by using *Basic APIs*.
So, the questions should be more precise situation as below.

This means the application joins (*,G) (i.e. EX{null,G}) and then
changes EX{a,G} by BLOCK{a,G}. After that, it requests UNBLOCK{a,G}.
In this case, the kernel's MSF state is changed to "EX{null,G}". Is it
correct? (Yes, I believe it's correct. This is just the premise of
next question.)

This means the application sets up EX{a,G} by BLOCK{a,G} with no (*,G)
join. After that, it requests UNBLOCK{a,G}.
In this case, the kernel's MSF state should be changed to what?
It should be "EX{null,G}" or "IN{null,null}"?
Or some of above requests should not be permitted, which means kernel
should return error for it?

Thanks.
--
Hitoshi Asaeda

---

From: Hitoshi Asaeda <[email-masked]>
Date: Fri, 08 Aug 2003 11:34:34 +0200 (MEST)

Thanks.
--
Hitoshi Asaeda