Subject: [magma] Multicast Router Discovery - consistency between v4 and v6

From: Brian Haberman <[email-masked]>
Date: Wed, 10 Sep 2003 12:42:25 -0400

One of the IETF Last Call comments I received on this issue
had to deal with the differences in functionality of MRD
between IPv4 and IPv6.  IPv4 creates a new IGMP message
while IPv6 utilized bits in the Neighbor Discovery messages.

My plan is to overhaul the IPv6 in the following way:

1. Define a Multicast Router Advert message
2. Define a Multicast Router Solicit message
3. Define a Multicast Router Terminate message
4. Remove use of NDP messages
5. Separate message formats and message processing so that
   processing can be protocol agnostic
6. Define consistent format for options (if needed)

Are there objections to this approach?  Other features that
people feel need changing?

Regards,
Brian

_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: Pekka Savola <[email-masked]>
Date: Fri, 12 Sep 2003 01:37:44 +0300 (EEST)

> people feel need changing?

You don't explictly state whether you intend to create 1-3 to run over 
MLD, or what?  Something else?  Independent protocol?

-- 
Pekka Savola                 "You each name yourselves king, yet the
Netcore Oy                    kingdom bleeds."
Systems. Networks. Security. -- George R.R. Martin: A Clash of Kings

---

From: Pekka Savola <[email-masked]>
Date: Fri, 12 Sep 2003 01:37:44 +0300 (EEST)

---

From: Brian Haberman <[email-masked]>
Date: Fri, 12 Sep 2003 06:13:57 -0400

>MLD, or what?  Something else?  Independent protocol?

The intent is to move the IPv6 support into the group management 
protocol so that it
behaves the same way as the current IPv4 version.  For example, the 
Multicast Router
Advertisement message in IPv6 will follow the same operational rules as 
the IPv4
message defined in section 3 of the current draft.

Regards,
Brian

---

From: Brian Haberman <[email-masked]>
Date: Fri, 12 Sep 2003 06:13:57 -0400

Regards,
Brian