Subject: Re: [magma] I-D ACTION:draft-ietf-magma-mgmd-mib-01.txt

From: Julian Chesterfield <[email-masked]>
Date: Tue, 11 Nov 2003 02:14:00 +0000

Sam,

Thanks for the comments, a few replies inline.

Samanvitha Rao wrote:

> Hello,
>
> I had some comments/questions:
>
> ** mgmdHostInterfaceStatus OBJECT-TYPE
> - description is missing in this version. 

This is a typo, I actually meant to delete this from the object list. It 
was suggested that HostInterface table entries should not be writeable 
so I was removing it from the spec.

>
>
> ** mgmdHostInterfaceVersion OBJECT-TYPE
> - The version running on the interface is
> min(configured_version, querier_version)
> - The version running can be inferred as IGMPv1 if
> mgmdHostInterfaceVersion1QuerierTimer is non-zero,
> - IGMPv2 or MLDv1 if mgmdHostInterfaceVersion2QuerierTimer
> is non-zero.
> - Else its the same as the configured value.
> If this is the case the description can say
> "The version of MGMD which is configured on this interface." 

Good points, I will add text to clarify that queriertimer objects 
overide the version variable, and which values should apply under those 
circumstances.

>
>
> ** mgmdRouterInterfaceVersion OBJECT-TYPE
>    DESCRIPTION
>            "The version of MGMD which is running on this interface.
>            Value 1 applies to IGMPv1 routers only. Value 2 applies
>            To IGMPv2 and MLDv1 routers, and value 3 applies to IGMPv3
>            and MLDv2 hosts.
>                      ^^^^^^ should be routers.
>
>
> ** mgmdRouterInterfaceQueryMaxResponseTime OBJECT-TYPE
> ** mgmdRouterInterfaceRobustness OBJECT-TYPE
> ** mgmdRouterInterfaceLastMembQueryIntvl OBJECT-TYPE
> SYNTAX     Unsigned32 (0..255)
> - Why are these range of values suggested? 

I'll have a read over the spec again and see which values might more 
usefully be assigned here...

>
>
> ** mgmdHostCacheStatus OBJECT-TYPE
>    SYNTAX     RowStatus
>    MAX-ACCESS read-create
>    STATUS     current
>    DESCRIPTION
>            "The status of this entry."
>    ::= { mgmdHostCacheEntry 5 }
> - Not sure what the above means? 

Isn't this the standard description for a rowstatus object? I'm happy to 
clarify the text if you have another suggestion...

>
>
> ** Since we have a mgmdRouterCacheUpTime object
> should we also have a mgmdHostCacheUpTime object? 

I'll add one.

>
>
> ** mgmdRouterCacheExpiryTime OBJECT-TYPE
>    DESCRIPTION
>            "The minimum amount of time remaining before this entry
>            will be aged out.  A value of 0 indicates that the entry is
>            only present because mgmdRouterCacheSelf is true and that 
> if the
> - I believe mgmdRouterCacheSelf was removed from the spec. So we should
> not refer to it.
>
> ** mgmdRouterCacheStatus OBJECT-TYPE
>    SYNTAX     RowStatus
>    MAX-ACCESS read-create
>    STATUS     current
>    DESCRIPTION
>            "The status of this entry."
>    ::= { mgmdRouterCacheEntry 7 }
> - Not sure what this is?
>
> ** mgmdHostSrcListHostAddress OBJECT-TYPE
>    SYNTAX     InetAddress
>    MAX-ACCESS not-accessible
>    STATUS     current
>    DESCRIPTION
>            "The host address to which this entry
>            corresponds. The HostCacheSourceFilterMode value for this 
> Group
> - Can change this to mgmdHostCacheSourceFilterMode
>
> ** mgmdRouterSrcListHostAddress OBJECT-TYPE
>    SYNTAX     InetAddress
>    MAX-ACCESS not-accessible
>    STATUS     current
>    DESCRIPTION
>            "The host address to which this entry
>            corresponds. The RouterCacheSourceFilterMode value for this 
> Group
> - Can change to mgmdRouterCacheSourceFilterMode
>
> ** mgmdMldV2HostMIBCompliance MODULE-COMPLIANCE
> ** mgmdMldV2RouterMIBCompliance MODULE-COMPLIANCE
> - Typo.. MLDv2 hosts must support the IPv6 address type.
>
> ** 5. Security Considerations
>
>   This MIB contains readable objects whose values provide information
>   related to multicast sessions.  Some of these objects could contain
>   sensitive information.  In particular, the mgmdCacheSelf and
> - I believe mgmdCacheSelf Object was removed. So references to
> it should also be removed. 

I'll add this in to the security considerations. This is a section that 
was on my 'todo' list anyway, so updates most welcome...

> Thanks,
> Sam

Many Thanks,
Julian

_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: Julian Chesterfield <[email-masked]>
Date: Tue, 11 Nov 2003 02:14:00 +0000

Sam,

I'll add one.

Many Thanks,
Julian