Subject: [magma] IGMP/MLD Proxying

From: Koen Vermeulen <[email-masked]>
Date: Tue, 30 Mar 2004 13:47:53 +0200

Hello all,

In the 'IGMP/MLD Proxying' draft, in section 4.1. 'Membership Database', 
a description is
given about how to build the membership database. Concerning this 
section I have some
questions:
- A membership record is of the form (multicast address, filter-mode, 
source-list). Is this
source-list just a plain list of sources, or is there also a timer 
maintained per source?
- It is written that the preprocessed subscriptions per interface are 
merged using the merging
rules specified in the IGMPv3 RFC. About what merging rules are we 
talking here? Are these
the ones described in 6.4.1. 'Reception of Current-State Records'?

All information more than written in the draft would be helpful.

Thanks,
Koen

_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: Haixiang He <[email-masked]>
Date: Tue, 30 Mar 2004 16:55:19 -0500

Koen,

Comments inline.

Koen Vermeulen wrote:

> Hello all,
>
> In the 'IGMP/MLD Proxying' draft, in section 4.1. 'Membership 
> Database', a description is
> given about how to build the membership database. 

The purpose to build the membership database is facilitate the IGMP/MLD 
Host portion.

> Concerning this section I have some
> questions:

The source-list is a plain list of sources. This is similar to the 
interface state of a host as described in section 3.2 of IGMPv3.

> the ones described in 6.4.1. 'Reception of Current-State Records'? 

The merging rules are described in section 3.2 of IGMPv3 RFC. We decided 
not to repeat the information from IGMPv3 RFC.

But after reading your email, I think it would be clearer to identify 
which section. How about the following editorial change?

"....merging rules specified in section 3.2 of the IGMPv3 RFC."

regards,
haixiang

---

From: Haixiang He <[email-masked]>
Date: Tue, 30 Mar 2004 16:55:19 -0500

Koen,

Comments inline.

regards,
haixiang