Subject: RE: [magma] I-D ACTION:draft-ietf-magma-mgmd-mib-02.txt

From: "Dave Thaler" <[email-masked]>
Date: Mon, 1 Mar 2004 21:18:51 -0800

The current draft is not implementable as is.
The problem is that it reuses the OIDs from RFC 2933 but changes the
syntax of objects.  This is not legal.  It is fine to keep the
MIB rooted at mib-2 85, but for each table where the INDEX is changed,
a new subid is needed.  So for example, mgmdHostInterfaceEntry
must change to use a new OID.

-Dave

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: Thursday, February 19, 2004 12:00 AM
> Cc: [email-masked]
> Subject: [magma] I-D ACTION:draft-ietf-magma-mgmd-mib-02.txt
> 
> A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
> This draft is a work item of the Multicast & Anycast Group Membership
> Working Group of the IETF.
> 
> 	Title		: Multicast Group Membership Discovery MIB
> 	Author(s)	: J. Chesterfield
> 	Filename	: draft-ietf-magma-mgmd-mib-02.txt
> 	Pages		: 29
> 	Date		: 2004-2-18
> 
> This memo defines a portion of the Management Information Base (MIB)
> for use with network management protocols in the Internet community.
> In particular, it describes objects used for managing the Internet
> Group Management Protocol (IGMP) and the Multicast Listener
> Discovery (MLD) protocol.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-ietf-magma-mgmd-mib-02.txt
> 
> To remove yourself from the IETF Announcement list, send a message to
> ietf-announce-request with the word unsubscribe in the body of the
> message.
> 
> Internet-Drafts are also available by anonymous FTP. Login with the
> username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
> 	"get draft-ietf-magma-mgmd-mib-02.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-ietf-magma-mgmd-mib-02.txt".
> 
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant mail
readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 
> 
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.

_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: Julian Chesterfield <[email-masked]>
Date: Wed, 10 Mar 2004 15:51:43 +0000

This is perhaps more of a typo since I had always assumed based on 
earlier discussions that the new MIB would be assigned a new OID. This 
was part of the motivation for renaming the objects so that they would 
be distinct from existing IGMP or MLD objects. The reference to mib-2 85 
would therefore be changed to something suitable.

Is this an acceptable solution? If yes, then what OID should be assigned...

Thanks,
- Julian

---

From: Julian Chesterfield <[email-masked]>
Date: Wed, 10 Mar 2004 15:51:43 +0000

Thanks,
- Julian