Subject: [magma] MRDISC Terminate Messages?

From: Gregory Daley <[email-masked]>
Date: Tue, 30 Mar 2004 11:19:49 +1000

Hi, 

I was just wondering why multicast router discovery
has separate terminate messages when it already has
advertisement messages which are able to be sent with
0 Advertisement Interval and 0 Query Interval?

It just seems like a waste of an ICMPv6/IGMP Message type.

Greg

_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: Brian Haberman <[email-masked]>
Date: Tue, 30 Mar 2004 06:20:26 -0500

Hi Greg,
      The Terminate message was added to the original spec
way back when.  The main purpose was to avoid overloading
the semantics of the AdvertisementInterval and the
QueryInterval.  We wanted to keep them identical to the
IGMP/MLD uses.

      However, I don't see any problems that would arise
if we eliminated the Terminate message and utilized new
semantics of the Query message to indicate termination
of multicast routing capability.

      Any others have thoughts on the issue?

Regards,
Brian

---

From: Brian Haberman <[email-masked]>
Date: Tue, 30 Mar 2004 06:20:26 -0500

Hi Greg,

Regards,
Brian