Subject: [magma] Questions with IGMP Snooping

From: [email-masked]
Date: Thu, 16 Dec 2004 18:57:04 +0530

Hello,
I have the following doubt regarding IGMP Snooping. 
 
1)Once the IGMP Snooping is completed and a mapping is done between the
IP multicast Address and the MAC Multicast address, will the switch with
the IGMP Snooping code also snoop the Multicast IP packets coming from
the Multicast router to the switch? I am asking this because that the
Multicast IP packets will contain the IP multicast address and how will
the switch(which is a layer 2 device) know the IP Multicast address for
the data coming to the switch? 
2)Will IGMP snooping not work on a switch which does not have a VLAN
configured to it and instead has just LAN setup?
Thanks in advance,
regards
Keerthi
_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: [email-masked]
Date: Fri, 17 Dec 2004 09:46:37 +0530

Thanks Bryan for the response.
regards
Keerthi

________________________________

From: Bryan McLaughlin (brmclaug) [mailto:[email-masked]] 
Sent: Thursday, December 16, 2004 10:04 PM
To: Keerthi Jayaram (WT01 - TELECOM SOLUTIONS); [email-masked]
Subject: RE: [magma] Questions with IGMP Snooping

Keerthi
 
Inline
 
________________________________

From: [email-masked] [mailto:[email-masked]] On Behalf
Of [email-masked]
Sent: 16 December 2004 13:27
To: [email-masked]
Subject: [magma] Questions with IGMP Snooping

Hello,
 
1)Once the IGMP Snooping is completed and a mapping is done between the
IP multicast Address and the MAC Multicast address, will the switch with
the IGMP Snooping code also snoop the Multicast IP packets coming from
the Multicast router to the switch? 
[BMc>] a snooping switch will look at IGMP packets only.
 
 I am asking this because that the Multicast IP packets will contain the
IP multicast address and how will the switch(which is a layer 2 device)
know the IP Multicast address for the data coming to the switch? 
[BMc>]  Snooping is done to look for IGMP reports. IGMP is protocol 2,
so easily identified by the switch . A router will receive all IPmc data
streams anyway, unless PIM snooping is used.

2)Will IGMP snooping not work on a switch which does not have a VLAN
configured to it and instead has just LAN setup?
[BMc>] 
IGMP snooping is no limited by or to Vlans. 
 
Bryan 
Thanks in advance,
regards
Keerthi