Subject: Re: [magma] IGMP Snooping Vs STP

From: Marshall Eubanks <[email-masked]>
Date: Wed, 1 Dec 2004 13:08:52 -0500

If by STP you mean SPT (Shortest Path Tree), and if you are
talking about IGMP snooping, then, no.

I don't even know how the IGMP snooping switch would even know about this,
assuming it really is remote (i.e., not on the LAN). This is
done by PIM, not by IGMP.

Regards
Marshall

On Tue, 30 Nov 2004 09:37:47 -0800, Nageswara Soma
<[email-masked]> wrote:
>  
> 
> I understand that a snooping switch should trigger 
> queries to solicit joins whenever there is a layer 2 
> topology change. One thing I am not very sure about 
> is do we really need to act on STP changes at a remote 
> place? This is different from STP changes on local box. 
> 
> Appreciate any response. 
> Nageswara 
> _______________________________________________
> magma mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/magma
> 
> 
>

_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: "Tiago Duarte (Ext_PDM&FC LDA)" <[email-masked]>
Date: Thu, 2 Dec 2004 10:19:11 -0000

IGMP is intended to use only in LAN environments! However, there are
solutions in production, located at the access area that have a tree of
switch. The first router is only located many hops away of the receiver!
Multicast in this case is done by switches by doing IGMP snooping and
proxy on every switch, avoiding the massive broadcast of packet. So,
only the intended ports receive multicast traffic.

Responding now to Nageswara, STP is independent from the protocol that
is above! STP is the same for multicast, unicast or what ever! Are you
using MSTP? In that case, it could be diferent!
If one link change in STP, all the STP domaind have to know that change.

Tiago Duarte
........................................................................
.
SIEMENS

> -----Original Message-----
> From: Marshall Eubanks [mailto:[email-masked]] 
> Sent: quarta-feira, 1 de Dezembro de 2004 18:09
> To: Nageswara Soma
> Cc: [email-masked]
> Subject: Re: [magma] IGMP Snooping Vs STP
> 
>