Subject: RE: [magma] IGMP Snooping Vs STP

From: "Nageswara Soma" <[email-masked]>
Date: Wed, 1 Dec 2004 11:14:17 -0800

Please forgive me for not posting the question clearly.
* STP - Spanning Tree Protocol
My question was how do we act on topology change notification
received on local box as a result of STP change on a remote
box?

Thanks Again
Nageswara

> -----Original Message-----
> From: Marshall Eubanks [mailto:[email-masked]]
> Sent: Wednesday, December 01, 2004 10:09 AM
> To: Nageswara Soma
> Cc: [email-masked]
> Subject: Re: [magma] IGMP Snooping Vs STP
> 
> 
> If by STP you mean SPT (Shortest Path Tree), and if you are
> talking about IGMP snooping, then, no.
> 
> I don't even know how the IGMP snooping switch would even 
> know about this,
> assuming it really is remote (i.e., not on the LAN). This is
> done by PIM, not by IGMP.
> 
> Regards
> Marshall
> 
> On Tue, 30 Nov 2004 09:37:47 -0800, Nageswara Soma
> <[email-masked]> wrote:
> >  
> > 
> > I understand that a snooping switch should trigger 
> > queries to solicit joins whenever there is a layer 2 
> > topology change. One thing I am not very sure about 
> > is do we really need to act on STP changes at a remote 
> > place? This is different from STP changes on local box. 
> > 
> > Appreciate any response. 
> > Nageswara 
> > _______________________________________________
> > magma mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/magma
> > 
> > 
> >
> 

_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: Marshall Eubanks <[email-masked]>
Date: Thu, 2 Dec 2004 09:52:27 -0500

Dear Nageswara;

That makes more sense. Please excuse my confusion.

I think that you do need to act on remote Layer 2 topology changes. 
Relevant protocols include 802.1d and 802.1w 

802.1D allows for automatic reconfiguration but I would guess that
this is not much of   an issue for the older protocol, as it can take
tens of seconds or more and basically the network is down while it's
going on. 802.1w allows for fast reconfiguration, taking something
like the packet propagation time throughout the network.

Here is why I think 802.1w needs to know about remote layer two changes : 

Consider a switched LAN like (numbers refer to bridges)

    |--2-----|----5---|
  -1         4       7
    |--3-----|----6---|

Suppose that 7 includes a multicast receiver, and the source (and the multicast
router) is behind 1. Snooping switches need to get membership reports
from 7 to 1 and data from 1 to 7.

The spanning tree could go from

    |--2-----|----5---|
  -1        4        7
    |---3         6---|

to

    |--2           5--|
  -1         4       7
    |--3------|----6--|

(say if the root bridge changed  from 2 to 3 ).
So data will have to be forwarded to "2" in the first case and "3" in
the second, even though the active ports at "1" have not changed. Likewise,
membership reports
have got to go from 7 to 5 in the first case, and 7 to 6 in the
second, again though
nothing has changed locally at 7.

The draft-11 addresses this twice - see 2.1.1 (4) and Question 9 :

     4)  An IGMP snooping switch should be aware of link layer topology
         changes caused by Spanning Tree operation. When a port is
         enabled or disabled by Spanning Tree, a General Query may be
         sent on all active non-router ports in order to reduce network
         convergence time.

    Q9  Can topology changes (for example spanning tree configuration
         changes) be detected by the IGMP snooping functionality so that
         for example new queries can be sent or tables can be updated to
         ensure robustness? (5 out of 6 switch vendors say yes now or soon)

So I guess this should be  a SHOULD but not a MUST.

Regards
Marshall Eubanks