Subject: [magma] IGMP Report Msg

From: "Rajasekaran R" <[email-masked]>
Date: 4 Jun 2005 16:03:46 -0000

Please help me in getting the clarify the following doubt regarding IGMP.

Will the number of sources field in IGMP Report Message be 0 for IS_INC, IS_EXC, ALLOW, BLOCK, TO_INC and TO_EXC ?  If so on what case.

Please help in getting this.

- R. Rajasekaran.  
   
_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: "Rolland Vida" <[email-masked]>
Date: Sat, 4 Jun 2005 18:45:12 +0200

Hi,
 
An IS_INC record is never sent with an empty source list. It would mean
that the receiver does not listen to any source for a specific group. If
it has never listened to that group, then it has no meaning to keep such
a reception state. If it has listened to it previously but it has
stopped since, then a corresponding state change report should have been
sent.
 
An IS_EXC record can be sent with an empty source list. That means that
one listens to all sources for that address.
 
An Allow or Block record is not sent with an empty source list, it does
not make sense as it does not change anything.
 
TO_INC can be sent with an empty list, it means that one wishes to leave
the group altogether.
 
TO_EXC can have an empty list as well, that means that one wishes to
listen to all the sources for a particular address.
 
Cheers,
Rolland 

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Rajasekaran R
Sent: Saturday, June 04, 2005 6:04 PM
To: [email-masked]
Subject: [magma] IGMP Report Msg
 
Please help me in getting the clarify the following doubt regarding
IGMP.

Will the number of sources field in IGMP Report Message be 0 for IS_INC,
IS_EXC, ALLOW, BLOCK, TO_INC and TO_EXC ?  If so on what case.

- R. Rajasekaran.  

 <http://clients.rediff.com/signature/track_sig.asp> 
_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma