Subject: [magma] IGMPv2 group-specific-query

From: "Mike Chartier" <[email-masked]>
Date: Fri, 24 Jun 2005 16:34:27 -0700

What is the proper way to map a group-specific-query into an IP packet.

Specifically, what is the proper IP-DA for a group-specific-query?  

Should I be looking somewhere besides RFC2236 for this info? 

My assumptions are here:

           General Query       Group-Specific Query

   ------------------------------------------------------

   L2-DA = 01:00:5e:00:00:01   (based on L3-DA)

   L2-SA = normal              normal

   L3-DA = 224.0.0.1           group-address

   L3-SA = normal              normal

   GROUP = 0.0.0.0             group-address

           Join                Leave

   ------------------------------------------------------

   L2-DA = (based on L3-DA)    01:00:5e:00:00:02

   L2-SA = normal              normal

   L3-DA = group-address       224.0.0.2

   L3-SA = normal              normal

   GROUP = group-address       group-address

 

Mike Chartier

Staff Software Engineer

World Wide Packets

(509) 242-9235

[email-masked]

_______________________________________________
magma mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/magma

---

From: Brian Haberman <[email-masked]>
Date: Mon, 27 Jun 2005 09:14:20 -0400

> What is the proper way to map a group-specific-query into an IP packet.

Your table below is correct based on RFC 2236.

> Should I be looking somewhere besides RFC2236 for this info?

I believe section 3 of 2236 identifies all of the cases.  It is a little
terse, but contains the info contained in your table.

>            General Query       Group-Specific Query

Regards,
Brian