Subject: Re: Terminology draft

From: Charles Perkins <[email-masked]>
Date: Wed, 8 Oct 1997 19:35:52 -0700 (PDT)

> In a MANET without full connectivity, there is a need to refer to those 
> nodes that are within transmission range. They are normally referred to 
> as neighbors, I presume the term 'neighborhood' covers this aspect, but 
> why not 'neighbor'.

O.K.  We should have the word "neighbor".

> Similarly, I think the term 'semicast' refers to the fact that when a 
> node transmits, only his neighbors will get the message as opposed to 
> broadcast, which refers to the fact that the intended destination is all 
> the nodes in the MANET. I presume these are covered under 'system wide 
> broadcast' and 'local broadcast', but why not use shorter terms.

I've never heard the word "semicast" before, but if other working
group members want it, I'll be glad to include it.
 
> BTW, what is 'goodput'. Regards.

Goodput is a measure of how much actual data is transmitted
in a session.  For instance, if TCP has to perform a lot of
retransmissions on a crowded medium, network utilization may
increase but goodput will probably decrease.

Charlie P.

---

From: [email-masked] (Joseph P. Macker)
Date: Thu, 9 Oct 1997 11:18:45 -0400

Charlie, good start on the terminology. A couple of quick inputs on semicast and goodput terms.

>group members want it, I'll be glad to include it.

While the point was well taken on localized broadcasts.  I, for one, don't think we should define this term as I think its confusing and somewhat redundant.

>increase but goodput will probably decrease.

Just some clarification here on verbage.  I usually see 'goodput' defined as a measure of end system data throughput for a session.  In this case, goodput is a measure of how much actual end system data is successfully transferred (or received) in a session.  I think you really meant this by saying transmitted above..right?  I think the problem is the verb "transmit" which doesn't usually imply received.  Sorry for the nitpick .. but it is terminology time.

---

From: Charles Perkins <[email-masked]>
Date: Thu, 9 Oct 1997 08:39:51 -0700 (PDT)

> Just some clarification here on verbage.  I usually see 'goodput' defined as
> a measure of end system data throughput for a session.  In this case,
> goodput is a measure of how much actual end system data is successfully
> transferred (or received) in a session.  I think you really meant this by
> saying transmitted above..right?  I think the problem is the verb "transmit"
> which doesn't usually imply received.  Sorry for the nitpick .. but it is
> terminology time.
>  

Yes, I agree with your correction.  The word "transmitted" should
be replaced by "transferred".  In a terminology draft, nitpickiness
is a virtue.

Regards,
Charlie P.

---

From: Charles Perkins <[email-masked]>
Date: Thu, 9 Oct 1997 10:44:34 -0700 (PDT)

> Ad Hoc networks (yes, this needs to be defined for dissemination purpose)

Yes!
 
> channel allocation

Yes.
 
> medium access protocol (rather than channel access protocol :-))

I understand that you suggest the latter require definition.  O.K.
 
> channel efficiency (rather than goodput :-))

Aren't both important?
 
> mobile (or mobile terminal) 
> power level (or power control) 
> energy conservation 
> sleep mode (I suggest to include this one for energy conservation) 
> fading
> diversity 
> linkage maintenance (describing the situation that a link is setup 
>                      and has to be maintained somehow) 
> neighbor (better than neighborhood when we talk about multihop networks) 
> multihop

All of these might be good to include, except that I'm not
sure about "energy conservation" since that is unlikely to be
misunderstood.  The list wasn't intended to be a lexicon of all
_useful_ terminology, only a collection of things that needed
definition for the purposes of the working group.

> Yuguang 

Charlie P.

---

From: Charles Perkins <[email-masked]>
Date: Thu, 9 Oct 1997 11:51:42 -0700 (PDT)

Unfortunately, I see that I made a typo or a mistake-o in the following
reply to Yuguang...

> I understand that you suggest the latter          require definition.  O.K.
                                           ^^^^^^^^
                                           DOES NOT

Sorry for the confusion.

Regards,
Charlie P.