Subject: Terminology draft

From: Charles Perkins <[email-masked]>
Date: Tue, 7 Oct 1997 13:59:05 -0700 (PDT)

At the last IETF working group meeting in August, I volunteered
to create a draft defining various terms of interest.  Here is
the list of terms I have come up with.  If I have missed some,
please let me know.

channel
channel access protocol
bandwidth
bandwidth utilization
control message
payload
convergence
convergence time
loop-free
system-wide broadcast
local broadcast
hidden-terminal problem
MAC-layer address
scalability
throughput {IP, TCP, MAC}
goodput
distance vector
link state
source route
neighborhood
cluster
signal strength
base station
forwarding node
asymmetric link
flooding
next hop

Other possibilities which I don't expect to include:

QoS
multicast
connectionless
sleep mode

---

From: Lee Chee Jwai <[email-masked]>
Date: Thu, 9 Oct 1997 10:18:33 +0800 (SGT)

My comments:

In a MANET without full connectivity, there is a need to refer to those 
nodes that are within transmission range. They are normally referred to 
as neighbors, I presume the term 'neighborhood' covers this aspect, but 
why not 'neighbor'.

Similarly, I think the term 'semicast' refers to the fact that when a 
node transmits, only his neighbors will get the message as opposed to 
broadcast, which refers to the fact that the intended destination is all 
the nodes in the MANET. I presume these are covered under 'system wide 
broadcast' and 'local broadcast', but why not use shorter terms. 

BTW, what is 'goodput'. Regards.

_____________________________________________________________________
Dr. Cheejwai LEE  			 Email: [email-masked]		   	 		
DSO National Laboratories			Tel  : (65) 3732061
24th Storey, Defence Technology Tower A,	Fax  : (65) 2728418	 
Depot Road					
Singapore 109679 

Mailing Address: DSO National Laboratories
		 20 Science Park Drive, Singapore 118230 
_____________________________________________________________________

---

From: Yugang Fang <[email-masked]>
Date: Thu, 9 Oct 1997 10:56:15 -0500 (CDT)

Charles Perkins writes:
|>
|>
|>At the last IETF working group meeting in August, I volunteered
|>to create a draft defining various terms of interest.  Here is
|>the list of terms I have come up with.  If I have missed some,
|>please let me know.

I have a few possible additions and comments: 

Ad Hoc networks (yes, this needs to be defined for dissemination purpose) 
channel allocation 
medium access protocol (rather than channel access protocol :-)) 
channel efficiency (rather than goodput :-)) 
mobile (or mobile terminal) 
power level (or power control) 
energy conservation 
sleep mode (I suggest to include this one for energy conservation) 
fading
diversity 
linkage maintenance (describing the situation that a link is setup 
                     and has to be maintained somehow) 
neighbor (better than neighborhood when we talk about multihop networks) 
multihop 

What do you think? 

Yuguang 

--
*************************************
Yuguang Fang, Ph.D  
Department of Electrical Engineering
The University of Texas at Dallas 
Mail Station EC33
P.O.Box 830688
Richardson, Texas 75083-0688 
Phone: (972)883-2132 (office)
Fax: (972)883-2710
Email: [email-masked]
URL: http://www.utdallas.edu/~yfang 
*************************************

|>channel
|>channel access protocol
|>bandwidth
|>bandwidth utilization
|>control message
|>payload
|>convergence
|>convergence time
|>loop-free
|>system-wide broadcast
|>local broadcast
|>hidden-terminal problem
|>MAC-layer address
|>scalability
|>throughput {IP, TCP, MAC}
|>goodput
|>distance vector
|>link state
|>source route
|>neighborhood
|>cluster
|>signal strength
|>base station
|>forwarding node
|>asymmetric link
|>flooding
|>next hop
|>
|>Other possibilities which I don't expect to include:
|>
|>QoS
|>multicast
|>connectionless
|>sleep mode
|>
|>