Subject: RE: OPNET simulation model for ad-hoc network

From: "Strater, Jay" <[email-masked]>
Date: Thu, 3 Dec 1998 10:04:50 -0500

Vishal

We have conducted simulations of routing protocols for ad-hoc military
networks using OPNET's radio Modeler.  We have preliminary results of WIRP,
LS variant, TORA, and ZRP performance comparisons.

Jay Strater
MITRE Corp.

> -----Original Message-----
> From:	Vishal Kothari [SMTP:[email-masked]]
> Sent:	Wednesday, December 02, 1998 3:22 PM
> To:	[email-masked]
> Subject:	OPNET simulation model for ad-hoc network
> 
> Has anyone done any simulations for ad-hoc network using the OPNET
> simulation package?
> 
> Thank you in advance
> 
> Vishal Kothari
> University of Toronto

---

From: Katia Obraczka <[email-masked]>
Date: Thu, 3 Dec 1998 09:38:47 -0800 (PST)

From: "Strater, Jay" <[email-masked]>
   Date: Thu, 3 Dec 1998 10:04:50 -0500 
   MIME-Version: 1.0
   X-Mailer: Internet Mail Service (5.0.1461.28)
   Content-Type: text/plain
   Sender: [email-masked]
   Precedence: bulk

   Vishal

   Jay Strater
   MITRE Corp.

   > Has anyone done any simulations for ad-hoc network using the OPNET

Jay,

Do you have some kind of report on your results that is available? I
am particularly interested in the kinds of scenarios (mobility
patterns) you used to drive your simulations.

Thanks,

					Katia Obraczka

---

From: "Strater, Jay" <[email-masked]>
Date: Thu, 3 Dec 1998 15:13:44 -0500

Katia

We have a report ... I'll send you a copy when I can (release expected for
next week).  Also, I plan on attending the MANET meeting next week and will
give an overview of the scenarios we used in our simulations.  

Jay

> From:	Katia Obraczka [SMTP:[email-masked]]
> Sent:	Thursday, December 03, 1998 12:39 PM
> To:	[email-masked]
> Cc:	[email-masked]
> Subject:	Re: OPNET simulation model for ad-hoc network
> 
>

---

From: Chip Elliott <[email-masked]>
Date: Fri, 04 Dec 1998 10:15:11 -0500

Hi Vishal,

We run our models in two different ways: with a "quick and dirty"
MAC layer that has very little realism, and in a highly realistic
mode that does a very thorough job of emulating our radios and
their propagation, contention, etc. We're using special military
radios which are quite fancy. In spirit, however, they are
roughly like 802.11 for channel access, etc.

I'd definitely recommend the 802.11 MAC for your model.
If you can do it, you should also try to make a decent
propagation model. r**2 or r**4 don't really cut it, and
you'll get exceedingly wrong results (in our experience).

Alas, we cannot share our models, as they are for military
radios. You might have better luck with the MITRE model.
Although OPNET has something of a bad reputation, I
think it's actually a very good modeling environment.
The license fees are really the main problem, IMHO.

The major problem with setup are the usual ones for
modeling, I think -- to properly segment the model so
that one can swap in "quick and dirty" components instead
of realistic ones. Compute time is always an issue,
and you need careful design up front so you can
tailor your model's components to the task at hand.

Cheers,

-- Chip

At 01:18 PM 12/03/1998 -0500, you wrote:
>Hi Chip,
>
>Could you tell me what MAC layer did you use for your simulations? I was
thinking of using the 802.11 MAC layer - any recommendations/suggestions?
Also, would it be possible for me to have a look at one of your models, as
it may reduce my simulation time :)  Also, what were some of the setup
issues that you had?
>Thanks for all the help
>From:	Chip Elliott [SMTP:[email-masked]]
>Sent:	Wednesday, December 02, 1998 4:29 PM
>To:	Vishal Kothari
>Hi Vishal,
>We've had a few projects here at BBN where we've done
>quite a bit of such simulations. OPNET seems to work pretty
>well for this, given that you're careful in how you
>set things up.
>
>-- Chip
>
>
>At 03:21 PM 12/02/1998 -0500, you wrote: