Subject: Size of RTS, CTS and MAC frame size in IEEE 802.11 ??

From: "Chih-fan Hsin" <[email-masked]>
Date: Mon, 6 Aug 2001 11:30:14 -0300

I am checking the size of RTS, CTS, and data packets in IEEE 802.11.
From the manual, I got RTS=20 bytes, CTS=14 bytes, MAC frame size = 34 bytes + frame body.
however, from some other literature, I found different sizes.
Could anyone give me a hand?

Charles

---

From: [email-masked]
Date: Mon, 6 Aug 2001 14:57:52 -0500

Hi Charles,

The sizes of RTS and CTS are correct.
However, the overhead of the data frame depends.
Typically, the overhead is 28 bytes (24 byte long MAC header and 4 byte long CRC), not 34 bytes.
The comes from the fact that address 4 (of 6 octets) in the MAC header is not typically used.
Hope that this will help.

Sunghyun

------------
Sunghyun Choi, Ph.D.
Senior Member Research Staff
WiCAN - Wireless Communications and Networking Department
Philips Research-USA, Briarcliff Manor, New York, USA
Tel: (914) 945 6506    Fax: (914) 945 6580
E-mail: [email-masked]
URL 1: http://www.philabs.research.philips.com/~szc - Philips internal
URL 2: http://www.eecs.umich.edu/~shchoi - Personal Homepage
** My opinions do not necessarily reflect those of my employer **

"Chih-fan Hsin" <[email-masked]>@itd.nrl.navy.mil on 08/06/2001 11:00:14 AM

Please respond to <[email-masked]>

Sent by:  [email-masked]

To:     "'Manet" <[email-masked]>
cc:      (bcc: Sunghyun Choi/BRQ/RESEARCH/PHILIPS)
Subject:  Size of RTS, CTS and MAC frame size in IEEE 802.11 ??
Classification:

Charles

---

From: Lars Viklund <[email-masked]>
Date: Wed, 22 Aug 2001 11:47:37 +0200

> From the manual, I got RTS=20 bytes, CTS=14 bytes, 

Correct.

> MAC frame size = 34 bytes + frame body.

Correct only if using WDS. Normally addr4 is omitted, 
which means that the size is 28 bytes + frame body.

Of course, this is the size of the MAC frame.
In addition different PHYs add different amount of PLCP framing.