Subject: [manet] 802.11 and AODV

From: g-egel <[email-masked]>
Date: Wed, 14 Aug 2002 10:22:50 +0200

Hi, 
I have read somewhere that broadcasting in 802.11b is done at a 
lower 
bit rate than unicasting, thus making HELLO messages in AODV travel 
further than data.
 
Does anyone know if this is correct, and if yes, can this be fixed 
by 
modifying the 802.11 driver?
 
Geir

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Ian Chakeres" <[email-masked]>
Date: Wed, 14 Aug 2002 08:20:02 -0700

Even during faster unicast transmission the RTS-CTS (broadcast control
messages) are performed at a lower rate as per the 802.11 & 802.11b
standards.

From the 802.11 & 802.11b standards
"
The set of data transfer rates that all the stations in a BSS will be
capable of using to receive and transmit frames to/from the wireless
medium. The BSS basic rate set data rates are preset for all stations in
the BSS.

All Control frames shall be transmitted at one of the rates in the BSS
basic rate set (see 10.3.10.1), or at one of the rates in the PHY
mandatory rate set so that they will be understood by all STAs in the
BSS.

All frames with multicast and broadcast RA shall be transmitted at one
of the rates included in the BSS basic rate set, regardless of their
type or subtype.
"

Ian Chakeres

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
g-
> egel
> Sent: Wednesday, August 14, 2002 1:23 AM
> To: [email-masked]
> Subject: [manet] 802.11 and AODV
> 
> 
> Hi,

---

From: "Ian Chakeres" <[email-masked]>
Date: Wed, 14 Aug 2002 08:20:02 -0700

Ian Chakeres

g-

---

From: Riadh Marrakchi <[email-masked]>
Date: Thu, 22 Aug 2002 16:01:08 +0200

Hello everybody,
i found two versions (implementations) of AODV under ns-2:
the first aodv version is included in NS-2.1b9
i downloaded the second version from
http://www.ececs.uc.edu/~mmarina/aodv/  (from Mahesh Marina)
both packages are implementing the aodv-v6 but i don't know if they are
similar or if there is any differences!!
does anyone have an idea?
Thanks in advance

Riadh

---

From: Riadh Marrakchi <[email-masked]>
Date: Thu, 22 Aug 2002 16:01:08 +0200

Hello everybody,

Riadh

---

From: Erik Nordström <[email-masked]>
Date: 22 Aug 2002 16:06:04 +0200

I believe the two implementations you mentioned are the same, but
possibly at different versions. Might be wrong though...

AODV-UU, a real-world implementaion of AODV that also runs in ns-2 is
available at http://www.docs.uu.se/~henrikl/aodv/. It is implemented
according to AODV draft 10.

/Erik Nordström

-- 
Erik Nordström <[email-masked]>

---

From: Erik Nordström <[email-masked]>
Date: 22 Aug 2002 16:06:04 +0200

/Erik Nordström

---

From: Riadh Marrakchi <[email-masked]>
Date: Thu, 22 Aug 2002 16:27:39 +0200

Hi Erik,
thank you for this information! can you tell me where to get the  AODV draft
10 because the link in the mensioned page is broken.
Thanks
Riadh

--
+++++++++++++++++++++++++++++++++
+  Riadh Marrakchi              +
+  Siemens Corporate Technology +
+  Tel: +49 89 12012143         +
+  Handy: +49 179 4836794       +
+++++++++++++++++++++++++++++++++

---

From: Riadh Marrakchi <[email-masked]>
Date: Thu, 22 Aug 2002 16:27:39 +0200

Hi Erik,

---

From: "Sudarshan N Raghavan" <[email-masked]>
Date: Thu, 22 Aug 2002 11:32:13 -0400

Most on-demand routing protocols for ad hoc networks use two phases for route establishment; Route Request and Route Reply. This seems analogous to a connection oriented framework. The route request can be treated as a Route Setup message and the route reply is similar to a Setup Acknowledge. If we are implementing an ad hoc network using the IP framework and an on-demand protocol, are we trying to fit a connection oriented mechanism into a connectionless framework ??

Regards,
Sudarshan N Raghavan
Graduate Student, Computer Science
NC State University

---

From: "Sudarshan N Raghavan" <[email-masked]>
Date: Thu, 22 Aug 2002 11:32:13 -0400

Regards,
Sudarshan N Raghavan