Subject: RE: [manet] why IP address in ad hoc networks

From: "Alvin C Valera Alvin" <[email-masked]>
Date: Tue, 06 Aug 2002 10:58:43 +0800

>>> "Naidu, Venkata" <[email-masked]> 08/05/02 23:44 PM >>>

More cons...
  - You may lose the power of IP routing.
  - Interworking between different networks will become
    tough.
  - IP is so matured, in a way, that it can work eventually
    on any layer 2 technology (homogeneity).
  - If in future if you want to tunnel the packet from
    wireless network to/from wired network, you may have
    to face lot more issues if you are not using IP addresses
    [when compared to the Pros you are getting by not 
     converting Layer 3 (IP) <-> Layer 2 (MAC) addresses]

  Finally, naming, addressing and routing go side by side.
  If the addressing is not chosen properly then the potential
  routing issues will be unpredictable.

  Look at IP addressing history and how that impacted 
  routing protocols - subnetting, supernetting, CIDR etc 
  etc.

--
Venkata.  

Thanks for adding a list of cons. However, if I may, isn't it that those cons are _not_ apparently present if one is considering a single mobile ad hoc network?

Take for example subnetting. In the Internet, the advantage of subnetting is that one need not specify a next hop entry for every address. You only need to specify the network address + the mask and all packets to that address are taken cared of, saving lots of space in the routing table. 

But in a single mobile ad hoc network, does subnetting make sense? Let's suppose the network has 50 nodes. Then I create, let's say 5 subnets. Do I get the benefits as in the Internet? No, because the nodes can move. 

As for naming, well that is a totally different area. Actually, if we cannot impose some sort of hierarchy, then our naming system cannot also be hierarchical. But for one manet "domain", perhaps we can assign unique names to every host.

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Chip Elliott <[email-masked]>
Date: Tue, 06 Aug 2002 06:53:23 -0400

Dear fellow Manet-ers,

But just stop and contemplate for a moment. Following the train
of some recent arguments, Ethernets and 802.11 (etc) would be terribly
foolish mistakes - instead all addressing and routing should be IP layer.

My view is that the way we currently build real IP networks is not some
terrible mistake. Link layers do part of the work, very often running
across multiple physical layers; IP does another part of the work -
the inter-net part; and a convergence layer binds the two.

Consider a campus-wide 802.11 system as a case in point. I'm
somewhat familiar with the one at Dartmouth College. It has ~600 access
points, with 802.11 style handoffs between them. This is far bigger
than most IP autonomous systems (600 routers is a lot), but works OK.
In short, it's a simple, clear example of a fairly large Layer 2 switching
and addressing system, which works just fine in the Internet context.

cheers,

-- Chip

---

From: Chip Elliott <[email-masked]>
Date: Tue, 06 Aug 2002 06:53:23 -0400

Dear fellow Manet-ers,

cheers,

-- Chip

---

From: "Phil Neumiller" <[email-masked]>
Date: Tue, 6 Aug 2002 15:18:18 -0400

Hi Chip,

A few thoughts on this.  

1).  If using mobile IP, it seems pretty logical to do ad hoc routing with the home address
      asssuming you don't have some kind of clustering or aggragation or CIDR for MANET
      thing going.

2).  The example you provide below is not that of a MANET.  As you know, when 802.11b
       networks are operated in PCF (AP centric) mode, they are single hop wireless networks.
       I don't think the Dartmouth example is appropriate here.

3).  Routing with MAC addresses is known art and can be very effective in many circumstances.
      You get the benefit of packets not entering the host, i.e. a PCMCIA card can function
      as a very light weight router with no host involvement (saves battery etc).

4).  When you get into end-to-end arguments, QoS, and security, and interoperability, it makes
       much more sense to route at the IP layer.  L2 layers come and go, IP always stays there.

It is quite easy to "tunnel IP over" a MANET routing at the MAC layer.  However, when you 
wish to introduce QoS and multi-homing, etc., things are more complicated. In the long run,
it is a far better idea to do MANET's at the IP layer.  The only exception I can see is for
tiny embedded sensor networks running on solar power or other such applications.

Thanks,

Phil

---

From: "Phil Neumiller" <[email-masked]>
Date: Tue, 6 Aug 2002 15:18:18 -0400

Hi Chip,

A few thoughts on this.  

Thanks,

Phil