Subject: [manet] why IP address in ad hoc network

From: zb <[email-masked]>
Date: Fri, 02 Aug 2002 11:17:33 +0900

Hi, all

Maybe it is a stupid question. Forgive me. My question is "Is IP address necessary in ad hoc network? Can I change it with another, e.g. MAC address?".
The reason I ask this question is that many handold device, e.g. bluetooth device, will not have a permant IP address. In the wired network, the IP address means an node ID and a route to the node. But, in case of ad hoc node, the IP address is only a node ID. The IP address allocation in ad hoc network need a lot of broadcast. Therefore, a lot of radio resources, e.g. nattery power and frequency bandwidth, have to be used. IMO, the question can be resolved into three questions: 
 1) whether the IP address can be replaced by another node ID or not
 2) in which case it works and in which case it does not works

 3) the pros and cons use another node ID

Thanx in advance.

bin
*************************************
Zhen Bin
 
i-Networking lab,
Samsung Advanced Institute of Technology,
San14-1, NongSeo-ri, Kiheung-Eup, 
Yongin, Kyungki-do, 440600, Korea

82-31-2809569 (fax)
82-31-2809534 (o)
82-31-2122268 (h)
*************************************

---

From: [email-masked]
Date: Fri, 2 Aug 2002 18:02:37 -0500

I agree with Chip Elliott who (in response to Zhen Bin's message) suggested
that
ad hoc networks should be treated as sub-networks below IP and hence have
their
own addressing and routing below IP.   Thus, I would suggest that a lot of
what the
MANET working group is trying to do should look more like

     (1) an IEEE 802.x working group dedicated to defining a mobile ad hoc
subnetwork

together with

     (2) an IETF working group to specifiy how to carry IP over that mobile
ad hoc
      subnetwork (things like IP address resolution, QOS mappings, etc).

If, however, the MANET group chooses to perform ad hoc addressing and
routing at
the IP layer, then my fall-back suggestion would be that the ad hoc
addressing and
routing should look like an IP domain with its own unique interior routing
protocol that
does not have to be the same as other IP wired routing protocols like OSPR,
EGP,
BGP, etc.

    If my reading of the MANET discussions and documents are accurate, then
this
    is the approach the MANET community seems to be taking, right?

Jim Stevens

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: [email-masked]
Date: Fri, 2 Aug 2002 18:02:37 -0500

together with

Jim Stevens

---

From: "Manfredi, Albert E" <[email-masked]>
Date: Sun, 4 Aug 2002 18:55:38 -0400

Charlie Perkins wrote:

> I think that there are other good reasons for using IP that
> do not depend on connecting inhomogeneous media.

(Although that reason is mentioned rather prominently in RFC 2501.)

> As one simple example, finding paths is a natural operation
> to think about at the network-layer.  Then it's a relatively
> simple exercise (should someone wish to have more work
> to do) to translate the algorithms to the underlying link layer.
> Going the other way is a lot harder, and the important parts
> are likely to be obscured by details that should not have been
> part of the solution.

Agreed, except that using the network layer address to facilitate finding paths, which is the whole point of network layer addresses after all, assumes that this network layer address has meaning to this MANET host in this location, at this time.

If the network layer address is in fact an arbitrary, although unique number for this host in this MANET, then routes have to be computed using the same techniques as are used in switched Ethernets.

If the network layer address is to have meaning at Layer 3, then this assumes a means of assigning these addresses periodically to the hosts, location-specific. Which suggests re-assignment as the hosts move about.

> I don't think it has to be a religious issue.  Instead, we can try to
> identify the best algorithms for establishing communications, and
> then try to map the algorithms into either network-layer addressing
> or MAC-layer addressing.  I definitely don't say that it's impossible,
> just like I don't say that having huge bridged networks is impossible.

Agreed. Sticking with network layer addresses leaves more options open for a wide range of solutions.

Bert

---

From: "Manfredi, Albert E" <[email-masked]>
Date: Sun, 4 Aug 2002 18:55:38 -0400

Bert