Subject: RE: [manet] why IP address in ad hoc networks

From: "Naidu, Venkata" <[email-masked]>
Date: Mon, 5 Aug 2002 11:35:38 -0400

-> >  3) the pros and cons use another node ID
-> 
-> Pros: 
-> - No need for address resolution (e.g. ARP) and IP->MAC 
-> mapping table.
-> 
-> 
-> Cons:
-> - You may have larger routing tables due to longer 
-> addresses. (However, since you don't need a separate IP->MAC 
-> mapping table, you may actually
-> still save memory)
-> - Routing protocol is network-dependent.
-> 
-> Can't think of others... 

  More cons...
  - You may lose the power of IP routing.
  - Interworking between different networks will become
    tough.
  - IP is so matured, in a way, that it can work eventually
    on any layer 2 technology (homogeneity).
  - If in future if you want to tunnel the packet from
    wireless network to/from wired network, you may have
    to face lot more issues if you are not using IP addresses
    [when compared to the Pros you are getting by not 
     converting Layer 3 (IP) <-> Layer 2 (MAC) addresses]

  Finally, naming, addressing and routing go side by side.
  If the addressing is not chosen properly then the potential
  routing issues will be unpredictable.

  Look at IP addressing history and how that impacted 
  routing protocols - subnetting, supernetting, CIDR etc 
  etc.

--
Venkata.  

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: zb <[email-masked]>
Date: Tue, 06 Aug 2002 09:53:22 +0900

see my inline reply.

bin
----- Original Message ----- 
From: "Naidu, Venkata" <[email-masked]>
To: "'Alvin C Valera Alvin'" <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, August 06, 2002 12:35 AM
Subject: RE: [manet] why IP address in ad hoc networks

>      converting Layer 3 (IP) <-> Layer 2 (MAC) addresses]
I agree with you, the main benefit of IP routing is multi-interface device, scalability and easy connection with wired network. But, IMO, in most case, an ad hoc network are expected to be very simple, like Bluetooth. Most of them are handhold device which have limited resource, e.g. memory, CPU, battery. Should we have a simplified version to run over the simple ad hoc network?

---

From: zb <[email-masked]>
Date: Tue, 06 Aug 2002 09:53:22 +0900

see my inline reply.

bin