Subject: [manet] why IP address in ad hoc network

From: zb <[email-masked]>
Date: Fri, 02 Aug 2002 11:17:33 +0900

Hi, all

Maybe it is a stupid question. Forgive me. My question is "Is IP address necessary in ad hoc network? Can I change it with another, e.g. MAC address?".
The reason I ask this question is that many handold device, e.g. bluetooth device, will not have a permant IP address. In the wired network, the IP address means an node ID and a route to the node. But, in case of ad hoc node, the IP address is only a node ID. The IP address allocation in ad hoc network need a lot of broadcast. Therefore, a lot of radio resources, e.g. nattery power and frequency bandwidth, have to be used. IMO, the question can be resolved into three questions: 
 1) whether the IP address can be replaced by another node ID or not
 2) in which case it works and in which case it does not works

 3) the pros and cons use another node ID

Thanx in advance.

bin
*************************************
Zhen Bin
 
i-Networking lab,
Samsung Advanced Institute of Technology,
San14-1, NongSeo-ri, Kiheung-Eup, 
Yongin, Kyungki-do, 440600, Korea

82-31-2809569 (fax)
82-31-2809534 (o)
82-31-2122268 (h)
*************************************

---

From: Chip Elliott <[email-masked]>
Date: Fri, 02 Aug 2002 09:30:03 -0400

Bin,

This has been a long-running but low-intensity discussion.
Many people argue that it is highly desirable to use IP level
addressing, routing, etc, in an ad hoc network because their
may be multiple technologies involved in such a network -
ie, it looks more like an Internet than like a single homogenous
sub-network (link) like an Ethernet.

However, others of us, including me, argue that many ad hoc
networks come out more smoothly when treated as sub-networks,
ie, their is a layer of addressing and routing, etc, below the IP
layer. This is analogous to bridged or switched Ethernets, which
may in fact be rather large networks consisting of quite
different kinds of underlying technology (multi-access coax,
point to point fiber, etc). Our view is that this approach fits very
neatly into the Internet architecture without any need for
"ad hoc specials" in packet forwarding rules, what broadcast
means, routing protocols etc. Then one just runs normal IP over this
particular kind of (ad hoc) sub-network.

On the whole, however, I think most people do not agree with
this general approach.

cheers,

-- Chip

Chip Elliott
Principal Engineer, BBN

At 10:17 PM 8/1/02, zb wrote:
>Hi, all
>
>Maybe it is a stupid question. Forgive me. My question is "Is IP address 
>necessary in ad hoc network? Can I change it with another, e.g. MAC address?".
>The reason I ask this question is that many handold device, e.g. bluetooth 
>device, will not have a permant IP address. In the wired network, the IP 
>address means an node ID and a route to the node. But, in case of ad hoc 
>node, the IP address is only a node ID. The IP address allocation in ad 
>hoc network need a lot of broadcast. Therefore, a lot of radio resources, 
>e.g. nattery power and frequency bandwidth, have to be used. IMO, the 
>question can be resolved into three questions:

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Chip Elliott <[email-masked]>
Date: Fri, 02 Aug 2002 09:30:03 -0400

Bin,

cheers,

-- Chip

Chip Elliott
Principal Engineer, BBN

---

From: Charlie Perkins <[email-masked]>
Date: Fri, 02 Aug 2002 16:30:12 -0700

Hello Chip,

IP is good at forwarding packets.  Bridging has been
built up as a way to give more extent to links than
they would otherwise be able to sustain.  If one
takes away the ability of routers to aggregate addresses,
then I don't think the addressing at the IP layer offers
direct advantages to addressing at the MAC layer.

However...

> sub-network (link) like an Ethernet.

I think that there are other good reasons for using IP that
do not depend on connecting inhomogeneous media.
As one simple example, finding paths is a natural operation
to think about at the network-layer.  Then it's a relatively
simple exercise (should someone wish to have more work
to do) to translate the algorithms to the underlying link layer.
Going the other way is a lot harder, and the important parts
are likely to be obscured by details that should not have been
part of the solution.

> particular kind of (ad hoc) sub-network.

What part is smoother?  I don't see that there are any inherent
advantages.  In fact, unless you want to bring something specifically
about the physical layer into the bridging algorithm, it seems to me
that doing things below IP really obscures the best way to do
route discovery (or whatever it would be called), multipoint
relay selection, QoS, security, or whatever.

Plus, making a huge ad hoc network into a single hop seems
almost guaranteed to be bad from the standpoint of any routing
protocol that operates by including the ad hoc network as a
part of a larger network.

How do you manage to resolve an IP address into a MAC
address, if you don't already have a path to the IP address?

> On the whole, however, I think most people do not agree with

I don't think it has to be a religious issue.  Instead, we can try to
identify the best algorithms for establishing communications, and
then try to map the algorithms into either network-layer addressing
or MAC-layer addressing.  I definitely don't say that it's impossible,
just like I don't say that having huge bridged networks is impossible.

Regards,
Charlie P.

---

From: Charlie Perkins <[email-masked]>
Date: Fri, 02 Aug 2002 16:30:12 -0700

Hello Chip,

However...

Regards,
Charlie P.

---

From: [email-masked]
Date: Sat, 03 Aug 2002 11:43:31 -0400 (EDT)

Hi Charlie,

I agree. If I add a comment, we may view the addressing issue in view of 
scalability and performance. For scalability our practice is to use 
hierarchical schemes. Current MANET's approach is essentially based on two 
level hierarchy: IP higher level and MAC low level. But if the number of nodes 
we are dealing with is not big (the term "big" may be another issue), we may 
use flat address approach, like bridged LAN, for performance reason. For 
example, the packet has to invoke two layer services (MAC frame and IP packet)
in two level hierachy, while for bridged LAN it involves only MAC layer which 
is expected to be more efficient.    

Regards,

Myung
[email-masked]

> just like I don't say that having huge bridged networks is impossible.

-------------------------------------------------
This mail sent through IMP: 134.74.16.141

---

From: [email-masked]
Date: Sat, 03 Aug 2002 11:43:31 -0400 (EDT)

Hi Charlie,

Regards,

Myung
[email-masked]