Subject: RE: [manet] On demand protocols

From: "Manfredi, Albert E" <[email-masked]>
Date: Thu, 22 Aug 2002 13:12:26 -0400

Venkata,

I agree about maintaining state as an attribute of connection-oriented protocols. I also agree that you can be connection-oriented at the Transport Layer, for example, but connectionless at the Network Layer.

Take a situation where each host of a MANET must determine the complete path before forwarding packets, as (I believe) Raghavan postulates. To me, the fact that each host must keep an explicit list of hops to reach a destination means that the host is maintaining Network Layer state information. So I believe you have created a connection-oriented Network Layer, in effect. If one of the hops disappears, you need to establish a new path, just as you would in an ATM network, if a switch along your ATM SVC fails. No?

Bert

> -----Original Message-----
> From: Naidu, Venkata [mailto:[email-masked]]
> Sent: Thursday, August 22, 2002 12:27 PM
> To: 'Sudarshan N Raghavan'; [email-masked]
> Subject: RE: [manet] On demand protocols
> 
> 
> Raghavan,
> 
>  IMHO, you are mixing different things here. 
>  Connection-oriented vs Connection-less is applicable
>  to the forwarding plane (in a broader sense). Control 
>  plane is responsible to achieve the desired result. 
> 
>  If you want a connection oriented network, then you 
>  may have to signal some information along that path
>  to establish/maintain the *state* along the path to
>  destination (the state information is not necessarily
>  maintained at every hop to the destination)
> 
>  In other words, you can't just compare message types
>  (Request/Reply/Indiation/Confiration etc) and allege
>  that the system is connection-oriented or vice versa.
> 
>  Let me ask you a question, TCP is connection-oriented,
>  But it runs on connection-less as well as connection-
>  oriented L3 frameworks. 
> 
>  Now ask the same question w.r.t TCP - "If we are 
>  implementing a connection using the IP framework and 
>  a transport protocol like TCP, are we trying to fit 
>  a connection oriented mechanism into a connectionless 
>  framework ?"
> 
>  The answer is simple: it's relative. End-to-end vs
>  hop-by-hop _or_ on which layer it is connection 
>  oriented.
> 
> --
> Venkata. 
> 
> -----Original Message-----
> From: Sudarshan N Raghavan [mailto:[email-masked]]
> Sent: Thursday, August 22, 2002 11:32 AM
> To: [email-masked]
> Subject: [manet] On demand protocols
> 
> 
> Most on-demand routing protocols for ad hoc networks use two 
> phases for
> route establishment; Route Request and Route Reply. This 
> seems analogous to
> a connection oriented framework. The route request can be 
> treated as a Route
> Setup message and the route reply is similar to a Setup 
> Acknowledge. If we
> are implementing an ad hoc network using the IP framework and 
> an on-demand
> protocol, are we trying to fit a connection oriented mechanism into a
> connectionless framework ??
> 
> Regards,
> Sudarshan N Raghavan
> Graduate Student, Computer Science
> NC State University 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/manet
> 
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Sudarshan N Raghavan" <[email-masked]>
Date: Thu, 22 Aug 2002 14:52:45 -0400

Thats right ... When we bring TCP into the picture, we are comparing two
different layers. TCP indeed tries to fit a connection oriented mechanism
into a connectionless framework to provide reliability to an unrelaible
network layer. When we consider MANETs we seem to be bringing down this
connection oriented mechanism from the transport layer to the network layer.
We can postulate that we need to do this because the nodes are mobile and
wireless links are inherently unreliable. However, the essence of the fact
that IP is a connectionless protocol is lost. IP just becomes an addressing
scheme for identifying the nodes.

Regards,
Sudarshan N Raghavan

----- Original Message -----
From: "Manfredi, Albert E" <[email-masked]>
To: "'Naidu, Venkata'" <[email-masked]>; <[email-masked]>
Sent: Thursday, August 22, 2002 1:12 PM
Subject: RE: [manet] On demand protocols

> Venkata,
>
> I agree about maintaining state as an attribute of connection-oriented
protocols. I also agree that you can be connection-oriented at the Transport
Layer, for example, but connectionless at the Network Layer.
>
> Take a situation where each host of a MANET must determine the complete
path before forwarding packets, as (I believe) Raghavan postulates. To me,
the fact that each host must keep an explicit list of hops to reach a
destination means that the host is maintaining Network Layer state
information. So I believe you have created a connection-oriented Network
Layer, in effect. If one of the hops disappears, you need to establish a new
path, just as you would in an ATM network, if a switch along your ATM SVC
fails. No?

---

From: "Sudarshan N Raghavan" <[email-masked]>
Date: Thu, 22 Aug 2002 14:52:45 -0400

Regards,
Sudarshan N Raghavan

---

From: Matt Miller <[email-masked]>
Date: Thu, 22 Aug 2002 14:22:14 -0500 (CDT)

In on-demand routing, IP is still connectionless with respect to data
packets.  By your argument, proactive routing would lose the
connectionless nature of IP as well because routes are continually being
"setup".  On-demand routing just tries to be more efficient by setting up
routes as needed instead of continually.

-Matt

---

From: Matt Miller <[email-masked]>
Date: Thu, 22 Aug 2002 14:22:14 -0500 (CDT)

-Matt

---

From: Joe Macker <[email-masked]>
Date: Thu, 22 Aug 2002 15:54:21 -0400

>connection oriented mechanism from the transport layer to the network layer.

This is not generally true for MANET protocols as you imply (which ones are you talking about), but could be argued for those that maintain path state at the endpoints (and must perform end-to-end repairing).  Only, a subset of the considered IDs do this (and in those cases there are often optional modes as well to act more distributed) so please be more specific in your conjecturing.

---

From: Joe Macker <[email-masked]>
Date: Thu, 22 Aug 2002 15:54:21 -0400