Subject: RE: [manet] On demand protocols

From: "Naidu, Venkata" <[email-masked]>
Date: Thu, 22 Aug 2002 12:26:59 -0400

Raghavan,

 IMHO, you are mixing different things here. 
 Connection-oriented vs Connection-less is applicable
 to the forwarding plane (in a broader sense). Control 
 plane is responsible to achieve the desired result. 

 If you want a connection oriented network, then you 
 may have to signal some information along that path
 to establish/maintain the *state* along the path to
 destination (the state information is not necessarily
 maintained at every hop to the destination)

 In other words, you can't just compare message types
 (Request/Reply/Indiation/Confiration etc) and allege
 that the system is connection-oriented or vice versa.

 Let me ask you a question, TCP is connection-oriented,
 But it runs on connection-less as well as connection-
 oriented L3 frameworks. 

 Now ask the same question w.r.t TCP - "If we are 
 implementing a connection using the IP framework and 
 a transport protocol like TCP, are we trying to fit 
 a connection oriented mechanism into a connectionless 
 framework ?"

 The answer is simple: it's relative. End-to-end vs
 hop-by-hop _or_ on which layer it is connection 
 oriented.

--
Venkata. 

-----Original Message-----
From: Sudarshan N Raghavan [mailto:[email-masked]]
Sent: Thursday, August 22, 2002 11:32 AM
To: [email-masked]
Subject: [manet] On demand protocols

Most on-demand routing protocols for ad hoc networks use two phases for
route establishment; Route Request and Route Reply. This seems analogous to
a connection oriented framework. The route request can be treated as a Route
Setup message and the route reply is similar to a Setup Acknowledge. If we
are implementing an ad hoc network using the IP framework and an on-demand
protocol, are we trying to fit a connection oriented mechanism into a
connectionless framework ??

Regards,
Sudarshan N Raghavan
Graduate Student, Computer Science
NC State University 
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Naidu, Venkata" <[email-masked]>
Date: Thu, 22 Aug 2002 12:26:59 -0400

Raghavan,

--
Venkata. 

-----Original Message-----
From: Sudarshan N Raghavan [mailto:[email-masked]]
Sent: Thursday, August 22, 2002 11:32 AM
To: [email-masked]
Subject: [manet] On demand protocols

Regards,
Sudarshan N Raghavan

---

From: "Manfredi, Albert E" <[email-masked]>
Date: Thu, 22 Aug 2002 13:12:26 -0400

Venkata,

I agree about maintaining state as an attribute of connection-oriented protocols. I also agree that you can be connection-oriented at the Transport Layer, for example, but connectionless at the Network Layer.

Take a situation where each host of a MANET must determine the complete path before forwarding packets, as (I believe) Raghavan postulates. To me, the fact that each host must keep an explicit list of hops to reach a destination means that the host is maintaining Network Layer state information. So I believe you have created a connection-oriented Network Layer, in effect. If one of the hops disappears, you need to establish a new path, just as you would in an ATM network, if a switch along your ATM SVC fails. No?

Bert

> From: Naidu, Venkata [mailto:[email-masked]]
> Sent: Thursday, August 22, 2002 12:27 PM
> To: 'Sudarshan N Raghavan'; [email-masked]
> Subject: RE: [manet] On demand protocols
> 
> 
> Raghavan,
>

---

From: "Manfredi, Albert E" <[email-masked]>
Date: Thu, 22 Aug 2002 15:16:53 -0400

In fact, I think, two things are lost in the general case:

1. The fact that the IP Layer is connectionless, and

2. The fact that IP addresses are hierarchical.

In the past, others and I have expressed #2 by suggesting that the IP addresses of the MANET hosts are in a flat address space, just like MAC addresses. In the most general case of a MANET.

Bert

> Sent: Thursday, August 22, 2002 2:53 PM
> To: Manfredi, Albert E; 'Naidu, Venkata'; [email-masked]
> Subject: Re: [manet] On demand protocols
> 
> 
> Thats right ... When we bring TCP into the picture, we are 
> comparing two
> different layers. TCP indeed tries to fit a connection 
> oriented mechanism
> into a connectionless framework to provide reliability to an 
> unrelaible
> network layer. When we consider MANETs we seem to be bringing 
> down this
> connection oriented mechanism from the transport layer to the 
> network layer.
> We can postulate that we need to do this because the nodes 
> are mobile and
> wireless links are inherently unreliable. However, the 
> essence of the fact
> that IP is a connectionless protocol is lost. IP just becomes 
> an addressing
> scheme for identifying the nodes.
> 
> Regards,
> Sudarshan N Raghavan
> ----- Original Message -----
> From: "Manfredi, Albert E" <[email-masked]>
> To: "'Naidu, Venkata'" <[email-masked]>; <[email-masked]>
> Sent: Thursday, August 22, 2002 1:12 PM
> > I agree about maintaining state as an attribute of 
> connection-oriented
> protocols. I also agree that you can be connection-oriented 
> at the Transport
> Layer, for example, but connectionless at the Network Layer.
> >
> > Take a situation where each host of a MANET must determine 
> the complete
> path before forwarding packets, as (I believe) Raghavan 
> postulates. To me,
> the fact that each host must keep an explicit list of hops to reach a
> destination means that the host is maintaining Network Layer state
> information. So I believe you have created a 
> connection-oriented Network
> Layer, in effect. If one of the hops disappears, you need to 
> establish a new
> path, just as you would in an ATM network, if a switch along 
> your ATM SVC
> fails. No?
> >
> > Bert
> >
> >

---

From: "Mullen, John P. (Contractor)" <[email-masked]>
Date: Thu, 22 Aug 2002 13:26:44 -0600

Hi Sudarshan,
 
The short answer is "yes."
 
More detail.
 
First of all, not all messages are sent via routes.  Unacknowledged Data
Packets (UDPs) can be used for a number of purposes.  There is still the
problem of suppressing redundant retransmissions, but there is no need for
route requests or replies.
 
However, some messages are intended for just certain destinations.  In this
case, it is best that only the nodes necessary to move the message to the
recipient(s) rebroadcast.  The route achieves that purpose.
 
It is a virtual connection imposed on an unstable connectionless (actually,
over connected) network.  However, this is not a matter of simply trying to
shoehorn the IP framework onto the MANET situation.  The suppression of
redundant node retransmissions is an important goal in the MANET since it
reduces the channel utilization.  
 
It is also important to remember that the typical problem in MANETs is not a
lack of connections, but a surplus.  If there are not enough connections, no
protocol can produce them.  You simply have to either increase transmitter
power or introduce more nodes.  The protocol earns its pay when the reverse
problem exists.  That is, there are more nodes than needed and the problem
is how to have just the nodes that are needed rebroadcast and the rest shut
up.  Protocols differ in how they attempt to achieve this and have other
tasks, but keeping the extra retransmissions down is one aspect all of the
protocols have to deal with.
 
Hope this helps,
 
John Mullen

-----Original Message-----
From: Sudarshan N Raghavan [mailto:[email-masked]]
Sent: Thursday, August 22, 2002 9:32 AM
To: [email-masked]
Subject: [manet] On demand protocols

Regards,
Sudarshan N Raghavan

---

From: "Mullen, John P. (Contractor)" <[email-masked]>
Date: Thu, 22 Aug 2002 13:26:44 -0600

Hi Sudarshan,

More detail.

 

Hope this helps,
 
John Mullen

-----Original Message-----
From: Sudarshan N Raghavan [mailto:[email-masked]]
Sent: Thursday, August 22, 2002 9:32 AM
To: [email-masked]
Subject: [manet] On demand protocols

Regards,
Sudarshan N Raghavan

---

From: "Manfredi, Albert E" <[email-masked]>
Date: Thu, 22 Aug 2002 15:33:08 -0400

I don't know about on-demand routing, but it does seem to me that if each hop must know what its reachable neighbors are at any time, and each source must know specifically what path each packet must take, there is a lot of Layer 3 state being maintained.

I believe you can make the case that MPLS or RSVP also maintain state at the Network Layer, or a shim just below it. I think certainly RSVP can be considered connection-oriented at the Network Layer? The only significant difference I see here is that no resources are being reserved along the path in a MANET. Then again, ATM doesn't reserve any resources for UBR VCs either, yet those are considered connection oriented.

Perhaps this is a subject teetering on the edge of the religious slippery slope.

Bert

> From: Matt Miller [mailto:[email-masked]]
> Sent: Thursday, August 22, 2002 3:22 PM
> To: Sudarshan N Raghavan
> Cc: Manfredi, Albert E; 'Naidu, Venkata'; [email-masked]
> In on-demand routing, IP is still connectionless with respect to data
> packets.  By your argument, proactive routing would lose the
> connectionless nature of IP as well because routes are 
> continually being
> "setup".  On-demand routing just tries to be more efficient 
> by setting up
> routes as needed instead of continually.
> 
> -Matt

---

From: "Manfredi, Albert E" <[email-masked]>
Date: Thu, 22 Aug 2002 15:33:08 -0400

Bert