Subject: RE: [manet] MANET - List of routing protocols

From: "Raoni Timo de Castro" <[email-masked]>
Date: Fri, 1 Nov 2002 14:58:33 -0300

Hello Everyone,

I'd like to use this subject to ask another question. Does anybody know which of these routing protocols are available in ns-2 for simulation of a mobile ad hoc network? I know that AODV, DSR, TORA, and DSDV were implemented by the monarch research project.

TIA,
Raoni Castro.

-----Original Message-----
From: David Lundberg [mailto:[email-masked]]
Sent: Friday, November 01, 2002 6:46 AM
To: [email-masked]
Subject: [manet] MANET - List of routing protocols

Hi all!

During the summer I published a list of the existing I had found on the
net and asked for comments. I got great response and added the changes to
my "little" list. Now I have realized that I won't have time to keep it
updated and thought that I should try to add it to one of these Wiki-sites
to let other interested people use/update it. Now I have published the
list along with the references I had. PSE have a look and feel free to
correct/change the list. I don't claim that I have sorted them correctly..
That could be something for people to discuss. :)

The list itself:

http://www.wikipedia.org/wiki/Ad_hoc_protocol_list

Short summary of implementations, pse add more:

http://www.wikipedia.org/wiki/Ad_hoc_protocols_implementations

Comments are as always very welcome!

Regards,

// David //

--------------------------------------------------------------
David Lundberg            Phone: Home(Uppsala)   +46-18-460356
Mail: [email-masked]        Home(Gävle)     +46-26-146743
Http: www.update.uu.se/~davidl   Cellular       +46-70-3531696
ICQ:  13440550                   IT-Dept. @ UU  +46-18-4716231
--------------------------------------------------------------

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: [email-masked]
Date: Fri, 1 Nov 2002 14:42:03 -0500 (EST)

Hi Raoni,

Can't speak for the rest, but we have just recently revised our NS2
implementation and it is ready for distribution.

We also have OPNET implementation as well.

Ciao,

Zygmunt.
==-=-=-=-==
~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-
Prof. Zygmunt J. Haas                    http://people.ece.cornell.edu/haas 
Wireless Networks Laboratory		 http://wnl.ece.cornell.edu
School of Electrical Engineering         
Cornell University			 tel: +1-607-255-3454
323 Frank Rhodes Hall			 fax: +1-607-255-9072
Ithaca, NY 14853			 e-mail: [email-masked]
U.S.A                             
	WNL web page: http://wnl.ece.cornell.edu
~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-~-

---

From: [email-masked]
Date: Fri, 1 Nov 2002 14:42:03 -0500 (EST)

Hi Raoni,

Ciao,

Zygmunt.
==-=-=-=-==

---

From: Shahriar Rahman <[email-masked]>
Date: Fri, 1 Nov 2002 12:02:12 -0800 (PST)

While on this thread, let me ask a further Q. Do you any of you have CGSR
implementation in either NS-2 or OPNET? Comparing these two, which one is
more straigthforward?

regards,
Shahriar

---

From: Shahriar Rahman <[email-masked]>
Date: Fri, 1 Nov 2002 12:02:12 -0800 (PST)

regards,
Shahriar

---

From: Joe Macker <[email-masked]>
Date: Fri, 01 Nov 2002 16:48:26 -0500

>implementation in either NS-2 or OPNET? Comparing these two, which one is

Let's keep list discussions related to manet IETF work.

wikipedia is freely editable by all so have at it!
If something is missing add it yourself.

This may be a better general method than the previously managed implementation page I was keeping for IETF manet protocols which is out-of-date.

-Joe

---

From: Joe Macker <[email-masked]>
Date: Fri, 01 Nov 2002 16:48:26 -0500

-Joe