Subject: [manet] (no subject)

From: "yang weihua" <[email-masked]>
Date: Mon, 11 Nov 2002 11:30:39 +0800

hi，
	I have one question to refer to you. I modified the common header of AODV 
by adding a variable. I did it like this in "aodv_packet.h"
    struct hdr_aodfv {
        ...
        double ah_energy;    // added by myself, what else shoud i do?
        ...
		}
     
    What relevant changes shoud do in order to get it work?
Because I found nowhere to indicate the size change of the header to compiler,
it does not work correctly.
    Thanks in advance.

Best regards! 				

yang weihua
[email-masked]
2002-11-11

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Vikram Kanodia <[email-masked]>
Date: Tue, 12 Nov 2002 15:06:54 -0600 (CST)

Hi,

This question is with regard to all the directional antennae work going on
in the community. Most of the works I have seen depend on the capability
of a node to detect the Angle-of-Arrival for an incoming beam
correctly. Does anybody have an idea how hard it is to do this in an
indoor environment where there is no single line-of-sight component and
multipath is the order of the day ?

Thanks,
-Vikram

------
Department of ECE, Rice University | 713 348 3786 (O)| 713 664 5650(H)
WWW: http://www.ece.rice.edu/~kanodia

---

From: Vikram Kanodia <[email-masked]>
Date: Tue, 12 Nov 2002 15:06:54 -0600 (CST)

Hi,

Thanks,
-Vikram

------

---

From: Mineo Takai <[email-masked]>
Date: Tue, 12 Nov 2002 20:42:49 -0800

Hello Vikram,

(I would use "antennas" rather than "antennae" for wireless
communications.)

If AOAs of multipath components are equally spread over 360 degrees, and
no ray is significantly stronger than the others, it is difficult to
identify an effective AOA for beamforming. However, the antenna system
does not need to estimate AOA if the pattern adaptation objective
function is the maximization of SIR (Signal to Interference Ratio). Some
of the proposed ideas (like DNAV) can be adapted to support these kinds
of adaptive antenna systems.

Mineo

---

From: Mineo Takai <[email-masked]>
Date: Tue, 12 Nov 2002 20:42:49 -0800

Hello Vikram,

Mineo

---

From: prashanth kumar <[email-masked]>
Date: Wed, 13 Nov 2002 11:21:15 -0800 (PST)

The DOA of the strongest multipath is the direction of
the virtual node which corresponds to the real node
whose signal is received over this multipath. So, I
think, one can treat multipaths as if that were the
LOS path.

> > WWW: http://www.ece.rice.edu/~kanodia

__________________________________________________
Do you Yahoo!?
U2 on LAUNCH - Exclusive greatest hits videos
http://launch.yahoo.com/u2
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: prashanth kumar <[email-masked]>
Date: Wed, 13 Nov 2002 11:21:15 -0800 (PST)

---

From: Vikram Kanodia <[email-masked]>
Date: Wed, 13 Nov 2002 16:35:13 -0600 (CST)

This would assume that if the node were to beamform towards this virtual
node, it would be able to reach the real node (that is the reflection off
surfaces resulting in the multipath is symmetric).......not a bad
assumption but one which might now work in certain environments. Moreover,
for certain directional MAC protocols this might result in a larger
deferrring region which may offset some of the spatial reuse gain....

-Vikram

--

---

From: Vikram Kanodia <[email-masked]>
Date: Wed, 13 Nov 2002 16:35:13 -0600 (CST)

-Vikram

--

---

From: romit roychoudhury <[email-masked]>
Date: Wed, 13 Nov 2002 17:24:05 -0800 (PST)

Hi Vikram,

A few comments:
Yes, I agree that with multipath, a node that receives
several signal components, would have to set up
multiple DNAVs.
But, the DNAVs now can be more aggresive.
More clearly, the deferring region can now be several
narrower regions around the direction of arrival (DoA)
of each signal component.
Ideally, if the relative strengths of each of the
signal components are available, we could set up the
DNAV angles accordingly - wider DNAV angle for a
stronger signal and the vice versa.

Now, the new problem that arises because of this may
be as follows:
If a node has fragmented-DNAVs set up in different
directions, the regions in which the node need not
defer may no longer be wide enough to fit in a
beamwidth. In such cases, spatial reuse may indeed get
affected.
Observe that this happens not because the total
deferring region has increased, but because the
deferring region is now fragmented into several
narrower regions.

hope i made some sense there :)

regards,
romit

--------------------------------------------------
Romit Roy Choudhury
Graduate Student, UIUC.
www.crhc.uiuc.edu/~croy
---------------------------------------------------

--- Vikram Kanodia <[email-masked]> wrote:
> > > > in the community. Most of the works I have
> seen
> > > depend on the capability
> > > > of a node to detect the Angle-of-Arrival for
> an
> > > incoming beam
> > > > correctly. Does anybody have an idea how hard
> it
> > > is to do this in an
> > > > Department of ECE, Rice University | 713 348
> 3786
> > > (O)| 713 664 5650(H)

---

From: romit roychoudhury <[email-masked]>
Date: Wed, 13 Nov 2002 17:24:05 -0800 (PST)

Hi Vikram,

A few comments:

regards,
romit

---

From: Vikram Kanodia <[email-masked]>
Date: Thu, 14 Nov 2002 11:29:22 -0600 (CST)

Mineo,

> (I would use "antennas" rather than "antennae" for wireless

whoops ...I did not realize that antennas was the correct plural
here...live and learn, I guess :)

> of adaptive antenna systems.

I am not sure I totally understand what you mean here. I am guessing that
whay you mean is that the antenna should beamform towards the strongest
component (among all the multipath components) - which obviously maximizes
the SIR (right?). However this still requires one to select the direction
of strongest component and beamform towrads it etc etc....or am i totally
out of tune with what you said ?

-Vikram

---

From: Vikram Kanodia <[email-masked]>
Date: Thu, 14 Nov 2002 11:29:22 -0600 (CST)

Mineo,

-Vikram

---

From: Mineo Takai <[email-masked]>
Date: Thu, 14 Nov 2002 21:00:42 -0800

Vikram:

Beamforming towards the strongest multipath (or LOS) component does not always
maximize SIR. It would probably maximize (S)ignal power, but you may be
increasing (I)nterference power at the same time (e.g., a strong interfering
signal coming from the same direction).

Since your original question was about the AOA estimation, I wanted to mention
beam adaptation algorithms called "blind" that do not estimate AOA of the
desired signal for beamforming. It adapts the beam pattern to maximize SIR
rather than estimating AOA and beamforming towards the estimated direction,
because the reception quality is ultimately determined by SIR. Blind algorithms
may end up creating the same patterns as other non-blind algorithms, but again,
they do not estimate AOA for beamforming.

Mineo

---

From: Mineo Takai <[email-masked]>
Date: Thu, 14 Nov 2002 21:00:42 -0800

Vikram:

Mineo