Subject: Re: [manet] Simulating AODV in NS

From: Bernardo Antunes Maciel Villela <[email-masked]>
Date: Tue, 19 Nov 2002 08:44:18 -0200 (BRST)

On Tue, 19 Nov 2002, Moustafa Hasnaa wrote:

Hello,

Sorry, I didn't mention the version. The version I'm using is 
ns 2.1b7. Then I'm probably using AODV with hello message ...
I wonder anyway if they've built in ns distribution
a version for AODV with hello message and without hello message.

Thanks,
Bernardo.

> Hello,
>  I need to know you are talking about which Ns version, as i work with ns
> version7
>  And it contains AODV simulated with hello message...;
> 
> Regards.
> Hasnaa Moustafa
> ----- Original Message -----
> From: "Bernardo Antunes Maciel Villela" <[email-masked]>
> To: <[email-masked]>
> Sent: Monday, November 18, 2002 8:50 PM
> Subject: [manet] Simulating AODV in NS
> 
> 
> > Hi,
> >
> > I have this question: the AODV version implemented in NS today is the
> > version made by Monarch and called AODV-LL in their paper "A
> > Performance Comparison of Multi-hop Wireless Ad Hoc Network Routing
> > Protocols" (by J. Broch, D. Maltz, D. Johnson, Y. Hu and J. Jetcheva)?
> >
> > I'd like to be sure about that because this AODV-LL version uses
> > no hello AODV mechanism. Instead it utilizes link layer
> > feedback from 802.11. BUT SUCH APPROACH CHANGES AODV PROTOCOL, because
> >  this way all link breakage is only on-demand and we only know about
> > a broken link when we have a packet to send through this link.
> >
> > If anyone knows this answer, please let me know.
> > Thanks.
> > Bernardo.
> >
> > _______________________________________________
> > manet mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/manet
> >
> 
> 
> --
> This message has been scanned for viruses and
> dangerous content by MailScanner, and is
> believed to be clean.
> 

--
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Bernardo Antunes Maciel Villela <[email-masked]>
Date: Tue, 19 Nov 2002 08:44:18 -0200 (BRST)

Hello,

Thanks,
Bernardo.

---

From: Alex Hamidian <[email-masked]>
Date: Tue, 19 Nov 2002 13:44:41 +0100

Hi!

I think it's better if you search the mailing list of ns: 
http://www.isi.edu/nsnam/htdig/search.html for finding the answer to 
these questions. You could also mail the ns users: [email-masked] .

The AODV implementation in ns-2 (from ns-2.1b6 to ns-2.1b9; I don't know 
about earlier ns versions) can be run both with and without Hello 
messages. In aodv.h you can find:
/*
  Allows AODV to use link-layer (802.11) feedback in determining when
  links are up/down.
*/
#define AODV_LINK_LAYER_DETECTION

So you can choose between using link-layer feedback and Hello messages. 
For Hello messages you must comment the line  #define 
AODV_LINK_LAYER_DETECTION ; otherwise link-layer feedback is used.

Hope it helps
Ali Hamidian

---

From: Alex Hamidian <[email-masked]>
Date: Tue, 19 Nov 2002 13:44:41 +0100

Hi!

Hope it helps
Ali Hamidian