Subject: [manet] RTS/CTS in wireless MAC

From: Francois Cartegnie <[email-masked]>
Date: Mon, 4 Nov 2002 15:45:21 +0000

Hi,

I got a question about the 802.11b behaviour in adhoc wireless networks.
How does the RTS/CTS is done when sending broadcast data over 802.11b ?
I mean, who replies to the RTS ?

Thanks
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: <[email-masked]>
Date: Mon, 4 Nov 2002 16:37:56 -0800

DCF (RTS-CTS-Data-ACK) is used only for unicast data.  CSMA/CA is used
for broadcast packets.

Ian Chakeres

---

From: <[email-masked]>
Date: Mon, 4 Nov 2002 16:37:56 -0800

Ian Chakeres

---

From: Francois Cartegnie <[email-masked]>
Date: Mon, 4 Nov 2002 15:45:21 +0000

Hi,

Thanks

---

From: Justin Lipman <[email-masked]>
Date: Tue, 5 Nov 2002 11:52:48 +1100

Hi,

When performing a broadcast there is no RTS/CTS mechanism used in 802.11.
This is only done in with unicasting.

regards,
Justin

-- 
Telecommunications & Information Technology Research Institute
University of Wollongong, Australia 
http://www.titr.uow.edu.au

---

From: Justin Lipman <[email-masked]>
Date: Tue, 5 Nov 2002 11:52:48 +1100

Hi,

regards,
Justin

---

From: Grzegorz Banasiak <[email-masked]>
Date: Tue, 5 Nov 2002 14:52:06 +0100

> DCF (RTS-CTS-Data-ACK) is used only for unicast data.  CSMA/CA is used
DCF is a kind of CSMA/CA scheme (and so do PCF). I presume that broadcast
packets are sent with CSMA/CD (i.e.  without any RTS/CTS/ACK handshake). Am I
right?

-- 
Grzegorz Banasiak

---

From: Grzegorz Banasiak <[email-masked]>
Date: Tue, 5 Nov 2002 14:52:06 +0100

---

From: Sachin Ganu <[email-masked]>
Date: Tue, 5 Nov 2002 10:04:30 -0500 (EST)

I do not think CSMA/CD is possible in MANET

---

From: Sachin Ganu <[email-masked]>
Date: Tue, 5 Nov 2002 10:04:30 -0500 (EST)

---

From: Sumeeth Nagaraj <[email-masked]>
Date: Tue, 05 Nov 2002 14:01:07 -0700

CSMA/ CD is used in the Ethernet, Collision Detection is not possible
because of the Half-Duplex nature of the nodes. The wireless nodes can
either transmit or receive and hence cannot detect collisions at the
destination(receiver). CSMA/CA is used and not CSMA/CD.

Best Regards,
Sumeeth

---

From: Sumeeth Nagaraj <[email-masked]>
Date: Tue, 05 Nov 2002 14:01:07 -0700

Best Regards,
Sumeeth