Subject: [manet] Emulate MANET

From: "Harry" <[email-masked]>
Date: Fri, 8 Nov 2002 9:10:14 +0800

hi,all！
	I want to emulate MANET in a wired network environment. Who could recommend some softwares to me? I konw NS2 do. Are there anything else?
	Thank u in advance.

best regards 				
　　　　　　　　Harry
　　　　　　　　　　2002-11-08

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Ankur Jain" <[email-masked]>
Date: Fri, 8 Nov 2002 09:44:51 +0800

Hi harry,

For emulating MANET in a wired environment, MobiEmu is the best software. I
think it will satisfy all your needs of emulating the adhoc in a lab
setting.

You can find it at http://mobiemu.sourceforge.net/

Regards
Ankur

----- Original Message -----
From: Harry <[email-masked]>
To: MANET mail list <[email-masked]>
Sent: Friday, November 08, 2002 9:10 AM
Subject: [manet] Emulate MANET

> hi,all！
> I want to emulate MANET in a wired network environment. Who could
recommend some softwares to me? I konw NS2 do. Are there anything else?

---

From: "Ankur Jain" <[email-masked]>
Date: Fri, 8 Nov 2002 09:44:51 +0800

Hi harry,

Regards
Ankur

---

From: "Sherif E. Mohamed Khattab" <[email-masked]>
Date: Fri, 8 Nov 2002 05:45:11 -0500 (EST)

Hi All,

   Regarding the problem of a node participating in routing functions
(e.g., route discovery and maintenance) but failing to perform packet
forwarding (dropping packets), due to malice or selfishness. Is
there any routing protocol that addresses this problem?

Thanks,

Sherif
*---------------------------------*
    Sherif E. Mohamed Khattab       
         Ph.D. Student		      
   Department of Computer Science  
     University of Pittsburgh        
 http://www.cs.pitt.edu/~skhattab
*---------------------------------*

---

From: "Sherif E. Mohamed Khattab" <[email-masked]>
Date: Fri, 8 Nov 2002 05:45:11 -0500 (EST)

Hi All,

Thanks,

Sherif

---

From: "Einar Vollset" <[email-masked]>
Date: Fri, 8 Nov 2002 11:05:20 -0000

If my memory serves me right, I think the CONFIDANT protocol presented
at this year's MobiHoc deals with it.

Cheers,

Einar

---------------------------- 
Einar Vollset
PhD Student
University of Newcastle, UK
http://vollset.org
---------------------------- 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Sherif E. Mohamed Khattab
> Sent: 08 November 2002 10:45
> To: [email-masked]
> Subject: [manet] Node misbehavior
> 
> 
> Hi All,
> 
>    Regarding the problem of a node participating in routing 
> functions (e.g., route discovery and maintenance) but failing 
> to perform packet forwarding (dropping packets), due to 
> malice or selfishness. Is there any routing protocol that 
> addresses this problem?
> 
> Thanks,
> 
> Sherif

---

From: "Einar Vollset" <[email-masked]>
Date: Fri, 8 Nov 2002 11:05:20 -0000

Cheers,

Einar

---

From: "Herbert Rubens" <[email-masked]>
Date: Fri, 8 Nov 2002 08:11:03 -0500

You may also want to take a look at our paper from the security workshop
at MobiCom 2002.

http://www.cnds.jhu.edu/pub/papers/wise2002_sec_routing.pdf

Hope this helps,

-Herb

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Sherif E. Mohamed Khattab
Sent: Friday, November 08, 2002 5:45 AM
To: [email-masked]
Subject: [manet] Node misbehavior

Hi All,

Thanks,

Sherif

---

From: "Herbert Rubens" <[email-masked]>
Date: Fri, 8 Nov 2002 08:11:03 -0500

Hope this helps,

-Herb

-----Original Message-----

Hi All,

Thanks,

Sherif

---

From: Sonja Buchegger <[email-masked]>
Date: 08 Nov 2002 15:23:26 +0100

Hi,
yes, Einar's memory is correct. CONFIDANT (Cooperation of Nodes,
Fairness in Dynamic Ad-hoc NeTworks) works as an extension to a routing
protocol, in the MobiHOC 2002 paper we applied it to DSR and showed
simulation results for the "no forwarding" type of misbehavior. You can
download the paper (and also a short survey paper on related work) from
my website at http://www.zurich.ibm.com/~sob/books.html . 

To get an overview of some other solutions, have a look at the current
issue  of ACM SIGMOBILE's Mobile Computing and Communications Review
volume 6 number 4 containing a report edited by Levente Buttyan and
Jean-Pierre Hubaux on a working session on security in mobile ad-hoc
networks held at EPFL in June. You can download the report and
presentation slides from http://icawww.epfl.ch/buttyan/June12/index.html

As posted previously on this list, Feng Zhu maintains a list of papers
dealing with security/cooperation/malice/selfishness at
http://www.ccs.neu.edu/home/zhufeng/security_manet.html .

best regards,
sonja
-- 
_/  _/  _/  _/  _/  _/  _/  _/  _/  _/  _/  _/  _/  _/  _/  _/  _/  _/  

 Sonja Buchegger
 IBM Zurich Research Lab    email: [email-masked]
 Saeumerstr. 4              phone: +41/1/724 82 37
 CH-8803 Rueschlikon        fax : +41/1/724 89 55
 Switzerland                http://www.zurich.ibm.com/~sob

---

From: Sonja Buchegger <[email-masked]>
Date: 08 Nov 2002 15:23:26 +0100

Hi,

best regards,
sonja

 Sonja Buchegger