Subject: [manet] Re: manet digest, Vol 1 #252 - 1 msg

From: lijuan zhu <[email-masked]>
Date: Mon, 11 Nov 2002 18:30:24 -0800 (PST)

hihi 
in aodv.h, AODV_HDR_LEN indicate the length of the header to the compiler and used in aodv.cc, but this size is much bigger than the acutall size needed, so u need not change it
what u need to change is to add the same line to the similar place of hdr_aodv_request, hdr_aodv_reply, because they share the same structure (hdr_aodv is the common section of all the header)

hope this can help u

Rgds

Dr. Lijuan Zhu

 [email-masked] wrote: 
Send manet mailing list submissions to
[email-masked]

To subscribe or unsubscribe via the World Wide Web, visit
https://www1.ietf.org/mailman/listinfo/manet
or, via email, send a message with subject or body 'help' to
[email-masked]

You can reach the person managing the list at
[email-masked]

When replying, please edit your Subject line so it is more specific
than "Re: Contents of manet digest..."

Today's Topics:

1. (no subject) (yang weihua)

--__--__--

Message: 1
Date: Mon, 11 Nov 2002 11:30:39 +0800
From: "yang weihua" 
To: "[email-masked]" 
Subject: [manet] (no subject)

hi£¬
I have one question to refer to you. I modified the common header of AODV 
by adding a variable. I did it like this in "aodv_packet.h"
struct hdr_aodfv {
...
double ah_energy; // added by myself, what else shoud i do?
...
}

What relevant changes shoud do in order to get it work?
Because I found nowhere to indicate the size change of the header to 

compiler,
it does not work correctly.
Thanks in advance.

Best regards! 

yang weihua
[email-masked]
2002-11-11

--__--__--

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

End of manet Digest

---------------------------------
Do you Yahoo!?
U2 on LAUNCH - Exclusive medley & videos from Greatest Hits CD

---

From: lijuan zhu <[email-masked]>
Date: Mon, 11 Nov 2002 18:30:24 -0800 (PST)

hihi 

hope this can help u

Rgds

Dr. Lijuan Zhu

Today's Topics:

--__--__--

Message: 1

hi£¬

compiler,

Best regards! 

yang weihua

--__--__--

End of manet Digest