Subject: [manet] diverting huge trace files to another location

From: gikaru <[email-masked]>
Date: Thu, 20 Feb 2003 14:57:16 +0100

I am during simulation of ad-hoc routing protocols and have been generating 
very huge files leading to shortage of space on the hard-disk. I am 
wondering how possible it is to store these files on a different location 
(different server that has enough space). I tried initiating in the 
protocols tcl script with the line:
set val(out_file)   "http://server-name/folder"
then i set the tracefile name as:
set val(tracefile) "$val(out_file)/outputfl.tr"
and created the object
set tracefd [open $val(tracefile) w]
.... i received an error message: couldn't 
open  "http://server-name/filder/outputfl.tr"
How do i go about solving this?
Any suggestion especially from those good in otcl language will be highly 
appreciated.
Thank you in advance....

Gikaru
TU-Dresden, Department of Computer Science

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Casey Carter <[email-masked]>
Date: Thu, 20 Feb 2003 08:43:17 -0600

You can transparently pipe your tracefile into another command by 
starting the filename with "|".  My favorite is
set tracefd [open "| gzip --best > $val(tracefile).gz"]
to compress traces.  If you have a program that can send its stdin to 
another host, like ncftpput from ncftp, then you are in good shape.

gikaru wrote:

>
> I am during simulation of ad-hoc routing protocols and have been 
> generating very huge files leading to shortage of space on the 
> hard-disk. I am wondering how possible it is to store these files on a 
> different location (different server that has enough space). I tried 
> initiating in the protocols tcl script with the line:
> .... i received an error message: couldn't open  
> "http://server-name/filder/outputfl.tr"
> Any suggestion especially from those good in otcl language will be 
> highly appreciated.
> Thank you in advance....
>
>
> Gikaru

-- 
Casey Carter
[email-masked]
[email-masked]
AIM: cartec69