Subject: [manet] Autoconfiguration protocols

From: Fábio Buiati <[email-masked]>
Date: Mon, 10 Feb 2003 15:13:32 -0300

Hi all,

I would like to know which Autoconfiguration protocol would have the best
concept based on performance taking into account the following issues:

Initialization of network
New node joining a network
Concurrent initiation of address allocation
Departure of nodes (graceful and abrupt)
Network partition and merger
Message losses
Broadcast storm

Would it be viable to implement it on a real environment?
---------------------------------------------------
Fábio Mesquita Buiati
Universidade de Brasília - UnB - Brazil
email - [email-masked]
---------------------------------------------------

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Mansoor Mohsin" <[email-masked]>
Date: Mon, 10 Feb 2003 17:01:12 -0600

Hi,

Sanket Nasergi and Ravi Prakash have a paper in INFOCOM 2002 on node autoconfiguration in MANETs. There is another paper in MILCOM 2002 by myself and Ravi Prakash on the same topic but with a different approach. Both the papers give distributed algorithms for node autoconfiguration taking into account network initialization, arrival of new node, node departure, network partitioing and merging, and message losses, etc.

The papers can be downloaded using the following links:
http://www.utdallas.edu/~ravip/papers/infocom2002.pdf
http://www.utdallas.edu/~mmohsin/publications/IPAssignment.pdf

--------------------------------------------------------------------------------
Mansoor Mohsin

---

From: "Charles E. Perkins" <[email-masked]>
Date: Mon, 10 Feb 2003 15:39:38 -0800

Hello folks,

We had a draft on address autoconfiguration,
currently available at the following URL:
	http://people.nokia.net/charliep/txt/aodvid/autoconf.txt
It was expected to be a working group item, but recently
the manet group has not been adding new work.

The autoconfiguration ideas have been implemented,
are known to work, and have been published in various
papers at technical conferences.

Regards,
Charlie P.

> Mansoor Mohsin wrote:
> 
> Hi,
> 
> Sanket  Nasergi  and  Ravi  Prakash have  a  paper  in  INFOCOM  2002 on  node
> autoconfiguration in  MANETs. There is another paper  in MILCOM 2002 by myself
> and Ravi  Prakash on  the same topic  but with a  different approach. Both the
> papers give distributed  algorithms  for  node  autoconfiguration taking  into
> account network  initialization, arrival of new  node, node departure, network
> partitioing and merging, and message losses, etc.
> 
> http://wwwutdallas.edu/~ravip/papers/infocom2002.pdf
> ------------------------------------------------------------------------------
> Mansoor Mohsin
> 
> 
> From: "Fabio Buiati" <[email-masked]>
> To: <[email-masked]>
> > Fabio Mesquita Buiati
> > Universidade de Brasmlia - UnB - Brazil

---

From: "Zhou, Hongbo" <[email-masked]>
Date: Mon, 10 Feb 2003 19:35:18 -0500

Hi,
     There is another paper in INFOMCOM'03 on autoconfiguration. We used a
different idea to assign IP addresses to the nodes in the MANET. You can
download it at http://www.cse.msu.edu/~zhouhon1/doc/prophetaddressalloc.pdf.

     Best regards,

Sincerely yours,
Zhou, Hongbo (Bernie)

=========================================
Ph.D. student
ELANS
Dept. of Computer Science & Engineering
Michigan State Univ.

Tel: (517) 353-4633
Email: [email-masked]
URL: http://www.cse.msu.edu/~zhouhon1
=========================================
----- Original Message -----
From: "Fábio Buiati" <[email-masked]>
To: <[email-masked]>
Sent: Monday, February 10, 2003 1:13 PM
Subject: [manet] Autoconfiguration protocols

Hi all,