Subject: [manet] formal verification of ad hoc networks

From: Grzegorz Jablonski <[email-masked]>
Date: Thu, 20 Feb 2003 10:55:31 -0000

Hi,

I'm doing research on formal verification of algorithms for ad-hoc networks.
I'm trying to apply transition systems (process algebras etc.) in modelling
and verification of the reactive algorithms running in ad-hoc environment.

 Does anyone do research in this area?

 Cheers
Greg

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Chip Elliott <[email-masked]>
Date: Thu, 20 Feb 2003 08:57:04 -0500

Dear Greg,

I have seen some excellent work from Irfan Zakkiudin
at Qinetiq, teamed with an Oxford formal verification group.
Last I knew, though, he was analyzing pro-active forms
of ad hoc routing.

Zak can be reached at:

     Irfan Zakiuddin <[email-masked]>

Cheers,

-- Chip

Chip Elliott
Principal Engineer, BBN

---

From: "Tao Lin" <[email-masked]>
Date: Thu, 20 Feb 2003 10:20:52 -0500

FYI.

"K. Bhargavan, C. Gunter, M. Kim, I. Lee, D. Obradovic,O. Sokolsky, and M.
Viswanathan. Verisim: Formal  analysis of network simulations. In Int.
Symposium on Software Testing and Analysis, pages 2-13, 2000. "

They have other papers on the similar topic published in IEEE transaction on
software engineering 2002 and in ACM journal.

Basically, their work focuses on DSDV and AODV.

  Tao Lin
  Ph. D.
  ECE Dept.
  Virginia Tech.
  USA