Subject: [manet] generating trace files ....

From: gikaru <[email-masked]>
Date: Thu, 27 Feb 2003 15:23:31 +0100

hello MANET researchers,
I am trying to run a modified aodv protocol on ns2. My problem is that the 
trace files generated are not baring the name of my protocol 
"modif_aodv"....Instead it is having IMEP... i.e.
s -t 2.556838879 -Hs 1 -Hd -2 -Ni 1 -Nx 179.72 -Ny 58.84 -Nz 0.00 -Ne 
-1.000000  -Nl RTR -Nw --- -Ma 0 -Md 0 -Ms 0 -Mt 0 -Is 1.255 -Id -    1.255 
-It IMEP -Il 48  -If 0 -Ii 0 -Iv 30 -P imep -Pa - -Ph - -Po - -Pl 0x0000 ]
i expected something like......
s -t 2.556838879 -Hs 1 -Hd -2 -Ni 1 -Nx 179.72 -Ny 58.84 -Nz 0.00 -Ne 
-1.000000  -Nl RTR -Nw --- -Ma 0 -Md 0 -Ms 0 -Mt 0 -Is 1.255 -Id -1.255 -It 
MODIF_AODV -Il 48
   -If 0 -Ii 0 -Iv 30 -P mofif_aodv -Pa - -Ph - -Po - -Pl 0x0000 ]
where do i need to change so as to get the expected.
I am running on ns-2.1b9
If someone can spot the mistake, please guide me through....i am not very 
experienced in ns....:)...I sent this to the ns users and no-one seems to 
have an idea..

Thanks in advance

  Gikaru
TU-Dresden, Department of Computer Science

---

From: "Tao Lin" <[email-masked]>
Date: Thu, 27 Feb 2003 10:54:08 -0500

Did you register your own packet type in packet.cc?

You can check whether all files that contain your own packet type match those for AODV.  In other words, you can grep all files that contain AODV in ns directory (not in aodv directory). For the files that contain the AODV packet type definition, add your own packet type there.

Hope this helps,
 
 Tao Lin
 Ph.D. Candidate
 ECE Dept.
 Virginia Tech.
 USA

----- Original Message ----- 
  From: gikaru 
  To: [email-masked] 
  Sent: Thursday, February 27, 2003 9:23 AM
  Subject: [manet] generating trace files ....

  hello MANET researchers,
  I am trying to run a modified aodv protocol on ns2. My problem is that the trace files generated are not baring the name of my protocol "modif_aodv"....Instead it is having IMEP... i.e. 
  s -t 2.556838879 -Hs 1 -Hd -2 -Ni 1 -Nx 179.72 -Ny 58.84 -Nz 0.00 -Ne -1.000000  -Nl RTR -Nw --- -Ma 0 -Md 0 -Ms 0 -Mt 0 -Is 1.255 -Id -    1.255 -It IMEP -Il 48  -If 0 -Ii 0 -Iv 30 -P imep -Pa - -Ph - -Po - -Pl 0x0000 ] 
  i expected something like......
  s -t 2.556838879 -Hs 1 -Hd -2 -Ni 1 -Nx 179.72 -Ny 58.84 -Nz 0.00 -Ne -1.000000  -Nl RTR -Nw --- -Ma 0 -Md 0 -Ms 0 -Mt 0 -Is 1.255 -Id -1.255 -It MODIF_AODV -Il 48
    -If 0 -Ii 0 -Iv 30 -P mofif_aodv -Pa - -Ph - -Po - -Pl 0x0000 ] 
  where do i need to change so as to get the expected. 
  I am running on ns-2.1b9
  If someone can spot the mistake, please guide me through....i am not very experienced in ns....:)...I sent this to the ns users and no-one seems to have an idea..

  Thanks in advance

   Gikaru

---

From: Val Naoumov <[email-masked]>
Date: Thu, 27 Feb 2003 17:22:31 +0100

Hello Gikaru,

Check the following:

1) in <ns>/common/packet.h
	- add your packet type (MODIF_AODV) in enum packet_t;
	- add `name_[PT_MODIF_AODV]="modif_aodv"` in p_info::p_info()

2) in <ns>/tcl/lib/ns_packet.tcl
	- insert `MODIF_AODV` in the loop "foreach prot { ... }"

3) in <ns>/trace/cmu_trace.cc
	- insert `case MODIF_AODV: ...` in CMUTrace::format(Packet* p, const char *why)

Best wishes,
Val
-- 
Valeri Naoumov                                  e-mail:
Computer Systems Institute                      [email-masked]
Swiss Federal Institute of Technology Zurich    web:
Switzerland                                     http://www.inf.ethz.ch/~naoumov

gikaru wrote:
> 
> hello MANET researchers,
> I am trying to run a modified aodv protocol on ns2. My problem is that 
> the trace files generated are not baring the name of my protocol 
> -1.000000  -Nl RTR -Nw --- -Ma 0 -Md 0 -Ms 0 -Mt 0 -Is 1.255 -Id -    
> 1.255 -It _IMEP_ -Il 48  -If 0 -Ii 0 -Iv 30 -P _imep_ -Pa - -Ph - -Po - 
> -Pl 0x0000 ]
> -1.000000  -Nl RTR -Nw --- -Ma 0 -Md 0 -Ms 0 -Mt 0 -Is 1.255 -Id -1.255 
> -It MODIF_AODV -Il 48
> If someone can spot the mistake, please guide me through....i am not 
> very experienced in ns....:)...I sent this to the ns users and no-one 
> seems to have an idea..
> 
> Thanks in advance
> 
>  Gikaru

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: gikaru <[email-masked]>
Date: Thu, 27 Feb 2003 17:49:32 +0100

Thanks Valeri for the quick responce.....

I have actually added the three you mentioned. The only slight difference 
is that i used "PT_MODIF_AODV" in enum packet_t and in CMUTrace::format()..
Any more hints?...

---

From: gikaru <[email-masked]>
Date: Thu, 27 Feb 2003 17:53:36 +0100

Thanks for the advise Tao Lin,
... I'll try that...but not a very easy task....
I'll see how it goes....

At 10:54 AM 2/27/2003 -0500, you wrote:
>You can check whether all files that contain your own packet type match 
>those for AODV.  In other words, you can grep all files that contain AODV 
>in ns directory (not in aodv directory). For the files that contain the 
>AODV packet type definition, add your own packet type there.
>
>Hope this helps,
>
>  Tao Lin
>  Ph.D. Candidate
>  ECE Dept.
>  Virginia Tech.
>  USA
>
>
>From: <mailto:[email-masked]>gikaru
>To: <mailto:[email-masked]>[email-masked]
>-1.000000  -Nl RTR -Nw --- -Ma 0 -Md 0 -Ms 0 -Mt 0 -Is 1.255 -Id 
>-    1.255 -It IMEP -Il 48  -If 0 -Ii 0 -Iv 30 -P imep -Pa - -Ph - -Po - 
>-Pl 0x0000 ]

Wilfred Githuka Gikaru
Hans-Grundig Strasse 25,
01062 - Dresden
tel +49-351-463-38557
fax +49-351-463-38251

---

From: "Tao Lin" <[email-masked]>
Date: Thu, 27 Feb 2003 11:56:55 -0500

If you use "grep -r -n PT_AODV *", you won't find a lot of lines.  For
example, in ns 2.1b7a, only 13 lines, including some document files.  Check
them one by one and make sure your packet is defined as AODV does.  I think
it is not that difficult. :)

BTW: If you tried what Valeri suggested, you may need to check your
definition of your routing agent.

 Tao Lin
 Ph.D. Candidate
 ECE Dept.
 Virginia Tech.
 USA

----- Original Message -----
From: gikaru
To: Tao Lin
Cc: [email-masked]
Sent: Thursday, February 27, 2003 11:53 AM
Subject: Re: [manet] generating trace files ....

You can check whether all files that contain your own packet type match
those for AODV.  In other words, you can grep all files that contain AODV in
ns directory (not in aodv directory). For the files that contain the AODV
packet type definition, add your own packet type there.

Hope this helps,

 Tao Lin
 Ph.D. Candidate
 ECE Dept.
 Virginia Tech.
 USA

----- Original Message -----
From: gikaru
To: [email-masked]
Sent: Thursday, February 27, 2003 9:23 AM
Subject: [manet] generating trace files ....

hello MANET researchers,
I am trying to run a modified aodv protocol on ns2. My problem is that the
trace files generated are not baring the name of my protocol
"modif_aodv"....Instead it is having IMEP... i.e.
s -t 2.556838879 -Hs 1 -Hd -2 -Ni 1 -Nx 179.72 -Ny 58.84 -Nz
0.00 -Ne -1.000000  -Nl RTR -Nw --- -Ma 0 -Md 0 -Ms 0 -Mt 0 -Is 1.255 -Id -
1.255 -It IMEP -Il 48  -If 0 -Ii 0 -Iv 30 -P imep -Pa - -Ph - -Po - -Pl
0x0000 ]
i expected something like......
s -t 2.556838879 -Hs 1 -Hd -2 -Ni 1 -Nx 179.72 -Ny 58.84 -Nz
0.00 -Ne -1.000000  -Nl RTR -Nw --- -Ma 0 -Md 0 -Ms 0 -Mt 0 -Is
1.255 -Id -1.255 -It MODIF_AODV -Il 48
  -If 0 -Ii 0 -Iv 30 -P mofif_aodv -Pa - -Ph - -Po - -Pl 0x0000 ]
where do i need to change so as to get the expected.
I am running on ns-2.1b9
If someone can spot the mistake, please guide me through....i am not very
experienced in ns....:)...I sent this to the ns users and no-one seems to
have an idea..

Thanks in advance

 Gikaru

---

From: gikaru <[email-masked]>
Date: Thu, 27 Feb 2003 18:14:34 +0100

ja... i said :
       set val(adhocRouting) MODIF_AODV

At 06:01 PM 2/27/2003 +0100, you wrote:
>Did you say
>         set opt(adhocRouting)   MODIF_AODV
>in your tcl file?
>
>Val
>
>
>
>gikaru wrote: