Subject: [manet] Anycast routing

From: "ayman ghazi" <[email-masked]>
Date: Wed, 12 Feb 2003 12:03:35 +0000

Hello,

do AODV and DSR Routing protocol support a Anycast routing ?

thanks

Ayman

Help STOP SPAM with the new MSN 8 and get 2 months FREE*
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: l s <[email-masked]>
Date: Wed, 12 Feb 2003 12:32:53 +0000 (GMT)

General MANET question, with a setup using IP, TCP and
AODV routing:

In Glomosim there are functions in the IP layer (in
nwip.pc) that state 'The Message is sent
WITHOUT an IP header', when passing from the Transport
and Routing layers, through the IP, to the MAC layer
beneath.  How can this be and why is no IP header
needed?

If it has no IP header then surely a higher level
packet, such as TCP or AODV cannot be put into IP
packets?

The way I understood it was that all packets had to be
put onto IP, is this not so?  If not then what are the
rules for what needs to be put onto IP and what
doesn't?

When the receiving node gets a message and passes it
up from the MAC to the IP layer, then how does it know
it should pass it to the AODV routing, given that
there are no instructions as there is no IP header?

Please, if anyone could help.

Lee -S-
CCSR, University of Surrey

__________________________________________________
Do You Yahoo!?
Everything you'll ever need on one web page
from News and Sport to Email and Music Charts
http://uk.my.yahoo.com
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Ankur Jain" <[email-masked]>
Date: Thu, 13 Feb 2003 23:57:28 +0530

Well, if you are using AODV, DSR or any other exisiting routing protocol for
ad hoc networks, then you have to include the IP header in the packet.
Otherwise, they won't be routed in our present architecture.

The feautre that you mentioned in Glomosim - 'The Message is sent without an
IP header" - possibly it is just for testing purposes when doing experiments
with header compression. Refer to ROHC group for more on header compression.

Regards
Ankur

---

From: "Mesut Ali Ergin" <[email-masked]>
Date: Fri, 14 Feb 2003 00:07:08 +0200

Dear All Those Interested,

The mentioned nwip.pc homes the IP layer code in GloMoSim and the  'The
Message is sent without an IP header" comment belongs to
"NetworkIpSendRawGlomoMessage" function (and its delayed variant). IP
header-less packet exists just for a short time and those mentioned
functions immediately add IP headers to the packets. (In short, no data
packet is actually sent out from nwip.pc to MAC without an IP header) The
simple snippet is given below. Hope it helps.

void NetworkIpSendRawGlomoMessage(
   GlomoNode* node,
   Message* rawMessage,
   NODE_ADDR destinationAddress,
   NetworkQueueingPriorityType priority,
   unsigned char protocol,
   unsigned int ttl)
{
   AddIpHeader(node, rawMessage, destinationAddress, priority, protocol,
ttl);
   RoutePacketAndSendToMac(node, rawMessage);
}

--
Mesut Ali Ergin
[email-masked]

Department of Computer Engineering,
Yeditepe University, Kayisdagi,
81120, Istanbul, Turkey
Tel:   +90 216 578 0429
        +90 216 578 0420
Fax: +90 216 578 0400