Subject: RE: [manet] Error simulating with AODV, DSR and TORA

From: "Liaw, Yong Shyang - LIAYS001" <[email-masked]>
Date: Sun, 2 Feb 2003 11:33:07 +1030

Hi,

From my own experience with DSR model in opnet, it is possible that DSR reports
Route_Error even in a single flow scenario, which I think it is likely due to
contention in the MAC (as suggested by Alvin). But I am surprised at the large
detection time of 10-20 seconds. Is this detection time for the source or for a
node with a broken link? If it is for the source, one possible reasons is that
ROUTE_ERROR message is lost on its way back to the source.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Saturday, 1 February 2003 1:39
> To: Alvin Valera
> Cc: [email-masked]
> Subject: Re: [manet] Error simulating with AODV, DSR and TORA
> 
> 
> Hi Alvin,
> 
> Thank you for your comments on this subject.
> 
> My opinion is that, since I created a very simple scenario 
> with just 6 ones and
> 1 traffic flow, we can't blame collisions for the behaviour 
> observed. Also, it's
> true that the sender retries several times (I think 4 times), 
> but I guess that
> 10 or 20 seconds to detect a broken link is too much, don't 
> you? If link-level
> aware protocols were supposed to behave that bad, we would 
> conform to just
> sending "Hellos"!
> 
> It's curious to notice that the problems are not the same for 
> all: the worst
> performance can be seen with DSR but TORA suddenly stops 
> sending packets and
> everything is still!
> 
> Please comment the "ns-random 0" line and you'll see exactly 
> what I see.
> 
> Best regards,
> 
> Carlos
> 
> 
> 
> Mensaje citado por: Alvin Valera <[email-masked]>:
> 
> > Hi Carlos Miguel,
> > 
> > I performed many simulations in ns-2.1b8 specifically
> > on the reaction of routing protocols to link failures.
> > I haven't encountered your problem, though.
> > 
> > Could it be that the delay in detecting a link failure
> > is due to link layer retransmissions? In 802.11, as
> > far as ns-2.1b8 is concerned, a sender retries several
> > times (I could not remember the exact value) before
> > informing the routing protocol that a data packet is
> > undeliverable?
> > 
> > Another possible reason is congestion. In my studies,
> > I encountered many instances where 802.11 reports a
> > link layer failure even though the receiver is within
> > range. This is due to the fact that in highly
> > congested environment, the MAC of the sender may fail
> > to acquire the channel or complete the
> > RTS-CTS-DATA-ACK.
> > 
> > 
> > Best regards,
> > Alvin
> > 
> 
> 
> _________________________________________________
> Carlos Miguel Tavares de Araújo Cesariny Calafate
> Becário de la Universidad Politécnica de Valencia
> e-mail: [email-masked]
> http://reptar.grc.upv.es/~calafate/
> Tel: +34 963879703 ext. 77977
> _________________________________________________
> \\\\\\\"In an open world without walls and fences who needs 
> Windows and
> Gates?\\\\\\\"
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/manet
> 
> 
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: [email-masked]
Date: Mon, 03 Feb 2003 11:41:38 +0100 (CET)

Yes, collisions are possible even in a single flow scenario, but the problem is
that upper layer protocols (such as DSR) do not detect the broken link at all,
even after a long time and a lot of packets lost.
In my scenario, nodes are positioned like this:

     B     C

A                D

     E     F

And the flow initially goes A-B-C-D. Suddenly, I make node C go away and node B
is not able to detect that the link to C is broken, and so the flow does not
change to the route A-E-F-D! (Sometimes it does, but after a long time.)

Mensaje citado por: "Liaw, Yong Shyang - LIAYS001"

\\\\\\\"In an open world without walls and fences who needs Windows and