Subject: [manet] Convergence time for MANET protocols versus traditional routing protocols

From: "Berner Vegge" <[email-masked]>
Date: Tue, 18 Feb 2003 14:09:31 +0100

Hello all!
In Norway we have made some measurements of convergence
time for OLSR and AODV. When a relay-node is
suddenly turned off it takes about 12 seconds
for OLSR and 3 seconds for AODV until traffic
is moved to an other relay node (located close
to the node that was turned off).

I find these values as being rather high and wonder
how long time traditional routing protocols would have
used in a similar situation...

Anyone who has any idea on how long time RIP or OSPF
would have used to move the traffic when traffic is sent
from node A to node D via node B and node B suddenly is
turned off, so that traffic must be re-routed via node C
instead?

Thanks!
Best Regards  Berner

_________________________________________________________________
MSN Messenger http://www.msn.no/messenger - Den korteste veien mellom deg og 
dine venner

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Joe Macker <[email-masked]>
Date: Tue, 18 Feb 2003 11:59:49 -0500

>used in a similar situation...

I think the question you asked may be dominated by link status detection methods and protocol timers and not necessarily the routing algorithms used.  Thus, some of these issues might be seen as protocol agnostic. In OSPF,etc, much of this would be dominated by the hello interval, LSA transmission intervales, router dead intervals, etc.  Eg.., a router dead interval for OSPF may be around 40 seconds (the time it takes to decide a neighbor is down after a HELLO is sent).  The point is this can be changed.  BUT if you took off-the-shelf values as you did here, it would be quite long.

(1) What was the link status detection methods used for the experiment.

        - HELLOs are slow and non-robust (without additional processing e.g., hysteresis) but they  are the most heterogeneous of approaches.
        - 802.11 lack of unicast ACKs methods can be problematic, but often envisioned for decreasing detection delay
        - Don't forget time-varying wireless channels are common (if you may too quick a decision on quality you might be wrong), but link S/N with some smoothing would probably be the best approach (if ONLY there were standard interface mechanisms).. These aren't wired links with only 2 states (on/off).
        - also older OLSR  implementations (v3 code) has been improved in terms of repair time and has been reported at various meetings (e.g., MPR switiching)
        - alot of issues here that may be implementation dependent.

2) Timers
        - there is usually a tradeoff between timers (increasing overhead vs. decreasing delay).
        - faster intervals == faster detection/faster reaction..
        - with better link sensing mechanisms one has less reliance on hello intervals,etc for detection this is true for both reactive and proactive protocol.

>MSN Messenger http://www.msn.no/messenger - Den korteste veien mellom deg og dine venner
>

---

From: "Efrayim Metin" <[email-masked]>
Date: Wed, 19 Feb 2003 09:34:04 +0100

Hi Berner,

In your scenario the time required for Router A to convergence is the
detection + holddown time + update time.

The default values are:
In                           RIP         IGRP
detection time         30s         30s
route update           30s         90s
hold-down time      180s       280s

Efrayim

----- Original Message -----
From: "Berner Vegge" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, February 18, 2003 2:09 PM
Subject: [manet] Convergence time for MANET protocols versus traditional
routing protocols