Subject: [manet] Multirate Capabilities in Ad Hoc Networks

From: "Ankur Jain" <[email-masked]>
Date: Sun, 9 Feb 2003 23:55:58 +0530

Hello,

Is anybody working on providing multirate services in ad hoc networks at the MAC layer level? What I mean from multirate is that we can use rate adaptation according to the channel conditions and then process our MAC packets accordingly. Right now, in 802.11b, there are four modes available - 1Mbps, 2 Mpbs, 5.5 Mbps (or 6 Mpbs) and 11 Mbps. 

Everybody would like to send the data at 11 Mbps. But there could be some scenarios where we don't need to send at such high speed e.g. control packets, reply to signal packets while in sleep mode. Besides saving limited bandwidth, it will be very useful in saving power. Here, we can have two types of adpatation - either sender based or receiver based. 

Has anybody doing research on providing multirate capabilities together with a good power-saving protocol. 

Best Regards
Ankur 

************************************************
[email-masked]
http://www.geocities.com/ankurjain009/

************************************************

------------------------------------------------------------------------------------------------------------------------------------------------
Dr. Kalpana Chawla, Indian born astronaut said in an email from Columbia Space Shuttle - STS 107

" The paths from dreams to success does exist,
   May you have the vision to find it, 
   the courage to get on to it, 
  and the perseverance to follow it. 
   Wishing you a great journey !"
------------------------------------------------------------------------------------------------------------------------------------------------

---

From: Vikram Kanodia <[email-masked]>
Date: Sun, 9 Feb 2003 18:27:35 -0600 (CST)

Check out:
@InProceedings{SKSK02,
  author = 	 {B. Sadeghi and V. Kanodia and A. Sabdharwal and
E. Knightly},
  title = 	 {Opportunistic Media Access for Multirate Ad Hoc
Networks},
  booktitle = 	 {Proceedings of {ACM} MOBICOM 2002},
  year = 	 {2002},
  address = 	 {Atlanta, Georgia},
  month = 	 {sept},
}

and

@Inproceedings{HVB01,
author = {G. Holland and N. Vaidya and P. Bahl},
title = {A Rate-adaptive {MAC} protocol for multi-hop wireless networks},
booktitle = {Proceedings of ACM {MobiCom} 2001},
year = 2001,
address = {Rome, Italy},
}

-Vikram

-- 

Department of ECE, Rice University | 713 348 3786 (O)| 713 664 5650(H)
WWW: http://www.ece.rice.edu/~kanodia 

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Gavin Holland" <[email-masked]>
Date: Mon, 10 Feb 2003 14:29:48 -0800

Ankur,

You can get a copy of our Mobicom '01 paper from here:
http://citeseer.nj.nec.com/446806.html

We will also have a paper shortly on routing over multirate links.
The problem we identified is that routing protocols commonly discover
routes by broadcasting; which, in 802.11, must go out at one of the
rates in the basic rate set.  However, because of the range/rate
tradeoff, routes discovered at the broadcast rate may not be optimal.
For instance, a route request broadcast at a low rate may discover
a one hop route that is unusable at a higher rate, forcing all traffic
on that route to use the low rate.  Whereas, broadcasting the same
route request at a higher rate may discover a multiple hop route with
higher capacity.

Thus, our approach is to make route discovery rate dependent.  We are
evaluating two protocols, one is to broadcast multiple route requests
at different rates (ensuring that each rebroadcast goes out at the
initial rate), the other is to broadcast at the lowest rate and have
each intermediate node annotate the route with the best rate for the
preceding link.  Once the rates are known, routes can be selected
according to whatever desirable criterion (e.g. highest capacity,
highest reliability).

-Gavin

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Ankur
Jain
Sent: Sunday, February 09, 2003 10:26 AM
To: [email-masked]
Subject: [manet] Multirate Capabilities in Ad Hoc Networks

Hello,

Is anybody working on providing multirate services in ad hoc networks at the
MAC layer level? What I mean from multirate is that we can use rate
adaptation according to the channel conditions and then process our MAC
packets accordingly. Right now, in 802.11b, there are four modes available -
1Mbps, 2 Mpbs, 5.5 Mbps (or 6 Mpbs) and 11 Mbps.

Everybody would like to send the data at 11 Mbps. But there could be some
scenarios where we don't need to send at such high speed e.g. control
packets, reply to signal packets while in sleep mode. Besides saving limited
bandwidth, it will be very useful in saving power. Here, we can have two
types of adpatation - either sender based or receiver based.

Has anybody doing research on providing multirate capabilities together with
a good power-saving protocol.

Best Regards
Ankur

----------------------------------------------------------------------------
--------------------------------------------------------------------
Dr. Kalpana Chawla, Indian born astronaut said in an email from Columbia
Space Shuttle - STS 107

" The paths from dreams to success does exist,
   May you have the vision to find it,
   the courage to get on to it,
  and the perseverance to follow it.
   Wishing you a great journey !"
----------------------------------------------------------------------------
--------------------------------------------------------------------