Subject: [manet] MANET testing in realistic environment

From: "Berner Vegge" <[email-masked]>
Date: Wed, 26 Feb 2003 11:25:00 +0100

Hello all!
I have made some testing on AODV, OLSR and LUNAR in a realistic
environment (i.e. not simulations). The tests are performed
within an office building with ORINOCO GOLD WLAN cards. I have
used WLAN IEEE802.11b as physical/link layer. The testing has
very often revealed problems and constraints in the WLAN
technology, such as interference when several nodes are close
to each other so that the throughput drops dramatically.
Changes in signal/noise relation leading do links that drop out
etc has also been a problem. Finally we have seen that
routing messages are lost very often at high load, so that
the connections are taken down for that reason (this is probably
due to lack of priority on routing packets, and as these are
broadcasted with no ack and resending, they are very easily lost).
I know that a lot of work is ongoing within IEEE to improve WLAN,
so hopefully MANET over WLAN will be possible in a year or so.

My question is if anyone else has performed realistic tests by
running MANET over WLAN and if anyone has any experiences,
documented results etc, that they would share with me.

Thanks a lot!
Best Regards  Berner

_________________________________________________________________
MSN Messenger http://www.msn.no/messenger - Den korteste veien mellom deg og 
dine venner

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Philippe Jacquet" <[email-masked]>
Date: Wed, 26 Feb 2003 20:33:55 +0100

We have run many realistic testing with IEEE 802.11 in the past. We
experienced several link instabilities due to frequent variation in link
quality from remote nodes. Similar effects were also reported in NRL. This
is the reason why advanced neighbor sensing has been introduced in OLSR.
This kind of effect were never detected in ns-2 simulations.

Philippe

---

From: Joe Macker <[email-masked]>
Date: Wed, 26 Feb 2003 16:20:13 -0500

Berner you raise salient engineering points that are reasonably protocol agnostic. We have done significant realistic test outdoors and indoors (and with an emulation environment using 802.11) with working systems and have achieved significant imrpovements with some minor modifications..  We modified older INRIA OLSR code to add a link sensing hysteresis algorithm to improve robustness and it works reasonably well for us in many trials to date including highly congested ones (better link layer sensing info --lower layer triggers, etc-- would be a further plus for any neighbor management algorithm).  We are dealing with naturally time-varying channels and highly unpredictable anomalies in many wireless scenarios not wired behavior and we should be cognizant of that fact.  Also, related to your noticing routing message being lost, for Linux (RH dists) we quickly added ToS packet markings that improved the priority under network congestion for routing control packets (we tested!
 that this actually did improve things for the OS and queueing engine we were using).  This code is available at http://pf.itd.nrl.navy.mil under the project INRIA OLSR with NRL mods.    Packet jittering for distributed control events,etc may also be important this was also added and parameterized in the above experimental prototype code (very important in a simulation)..We also have newer code developments that should be released in the near future that we feel further improve the link sensing process,etc.

-Joe