Subject: [manet] a Question on RTS/CTS

From: Seki Lau <[email-masked]>
Date: Fri, 25 Apr 2003 06:02:35 +0800 (CST)

Dear All,
I am thinking such case and I don't sure will it
happened or not.

Two nodes (X and Y) operating in Ad Hoc mode. X can
hear Y and Y can hear X. X has just received a RTS
from someone (let's call it H) and X is going to reply
a CTS. In almost the same time, Y backoff counter
already expire and it will transit from receiving mode
to transmitting mode and it is going to transmit a
RTS.
According to IEEE 802.11 standard, RTS is longer than
CTS in length.

So, the CTS signal from X will arrive Y. But at that
time , Y is in transmission mode, it can't hear(or
even not notice) a CTS arrive. The signal of RTS from
Y arrive X . Because RTS is longer than CTS, after X
transmitted its CTS, it notice something on the media.
It can't find it is meaningful. X back off and assume
it is noice. However, H can receive the CTS from X to
itself clearly. H decides to send a data packet to X.
In the mean time, Y's RTS gets response. Y receives a
CTS and it is going to send a Data packet. When both H
and Y send their data packet, the packets collide on
node X. 

My first question is , does what I said valid or not?
Althought the probability for it to happen is not
large, but I want to know will it be possible to
occur?

Ok , if what I said is possible, I would like to ask,
if we extent the size of CTS , the new length of the
CTS is the original length plus the length of RTS. If
so, the node Y in the case I said before will hear
some noice on channel after it finished transmitting
the RTS and after it transit from transmission mode to
receiving mode. It will back-off for eifs. Because
sifs is small. When the signal of CTS arrive node Y,
the CTS signal from X still in the hear-able from node
Y. Node Y keeps on hearing noice for a period of time.
So it will not be able to notice its RTS has been
responded. It will not send out data later on.

Can any one give me some hint on it?

Regards
Seki Lau
CityU HK

_______________________________________________________________________
Do You Yahoo!?
Get your free @yahoo.com.hk address at http://mail.english.yahoo.com.hk
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Dr. Brahim BENSAOU" <[email-masked]>
Date: Fri, 25 Apr 2003 13:21:29 +0800

Seki,

What you said is valid and can occur and what you "proposed"
does also solve the problem.
However, both the problem and the solution you discuss
are the subject of the PhD Thesis of Chane Fullmer
at UCSC some years ago and was called FAMA  for Floor acquisition
Multiple Access.

- B.

-- 
Brahim Bensaou             | Computer Science Department.
Assistant Professor        | Hong Kong University of Science & Technology
[email-masked]           | Clear Water Bay, Kowloon, Hong Kong.
http://www.cs.ust.hk/~csbb | Ph: +852 23587014, Fax: +852 23581477