Subject: [manet] Adaptive routing protocol based on network/node load

From: "Tan Kean Soon" <[email-masked]>
Date: Tue, 08 Apr 2003 12:12:06 +0800

Hi,
Is there any protocol that does smart routing decisions by taking the  traffic load in the network  into consideration. Normally, route selection criteria uses metric such as shortest number of hops and quickest response time to a request. Such decision making  can lead to the situation where all packets are routed through the same node even if there exist better routes where the traffic load is not as large. Could somebody shed some light on this issue?

Thanks.

Regards,
Kean Soon

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: [email-masked]
Date: Tue, 08 Apr 2003 11:43:00 -0700

> Hi,
> Is there any protocol that does smart routing decisions by taking the  tra
ffic load in the network  into consideration. Normally, route selection crit
eria uses metric such as shortest number of hops and quickest response time 
to a request. Such decision making  can lead to the situation where all pack
ets are routed through the same node even if there exist better routes where
 the traffic load is not as large. Could somebody shed some light on this is
sue?

Hi Kean,

There are several such protocols.  Here is one of them:

P. Gupta and P. R. Kumar, ``A system and traffic dependent adaptive 
routing algorithm for ad hoc networks,'' Proceedings of the 36th 
IEEE Conference on Decision and Control, pp. 2375-2380, San Diego, Dec. 1997. 
Even before that, I designed such a protocol (with John Hight, 
Dave Beyer, and others) called STIP (Secure Tactical Internet Protocol) 
in 1993, which was not published but can be found in the following 
project report:

J. Hight, E. Costa, D. Lee, R. Ogier, J. Wong. 
"Evaluation and Development of Multimedia Networks in Dynamic
Stress (EDMUNDS): Final Technical Report",
SRI Technical Report ITAD-8558-FR-93-277, October 1993.

I know there are more recent routing protocols that take traffic 
load into account, but I wanted to point out that such protocols
were developed 10 years ago.

Richard

---

From: Prince Samar <[email-masked]>
Date: Tue, 8 Apr 2003 16:04:21 -0400 (EDT)

Hi Kean,

We have extended the concept of ZRP to develop the Independent Zone 
Routing (IZR) framework, where each node has the capability to maintain an 
independently sized routing zone. This allows each node in the network to 
adaptively configure its own optimal zone radius in a distributed fashion. 
This ability of a node to provide fine-tuned adaptation to variations in 
network characteristics (like mobility, calling patterns and load) over 
time and space enables the framework to perform well in any kind of ad hoc 
network. The following paper is currently under review.

  P. Samar, M.R. Pearlman, Z.J. Haas, "Independent Zone Routing: An 
  Adaptive Hybrid Routing Framework for Ad Hoc Wireless Networks," under 
  review.

Regards,
Prince

On Tue, 8 Apr 2003, Tan Kean Soon wrote:

>Hi, 
>Is there any protocol that does smart routing decisions by taking the
>traffic load in the network into consideration. Normally, route selection
>criteria uses metric such as shortest number of hops and quickest
>response time to a request. Such decision making can lead to the
>situation where all packets are routed through the same node even if
>there exist better routes where the traffic load is not as large. Could
>somebody shed some light on this issue?
>
>Thanks.
>
>Regards,
>Kean Soon
>

---

From: Jitesh Shah <[email-masked]>
Date: Tue, 8 Apr 2003 21:35:51 +0100 (BST)

Hi,

Just to add to the list of the various Adaptive
protocols based on the network/node load, we have
developed the following routing protocol, which has
incorporated the concept of cost function. Not only is
it adaptive but also a secure routing scheme. Please
download the paper from the following link:

http://www.iitg.ernet.in/engfac/ece/~jshah/papers/adhoc/adapsec.pdf

 --- Prince Samar <[email-masked]> wrote: > 
> >somebody shed some light on this issue?

________________________________________________________________________
Missed your favourite TV serial last night? Try the new, Yahoo! TV.
       visit http://in.tv.yahoo.com
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Krishna Prabhala <[email-masked]>
Date: Tue, 8 Apr 2003 17:16:43 -0400 (EDT)

Hi,

The link seems to be broken.

Krishna.

On Tue, 8 Apr 2003, Jitesh Shah wrote:

- Hi,
- 
- Just to add to the list of the various Adaptive
- protocols based on the network/node load, we have
- developed the following routing protocol, which has
- incorporated the concept of cost function. Not only is
- it adaptive but also a secure routing scheme. Please
- download the paper from the following link:
- 
- http://www.iitg.ernet.in/engfac/ece/~jshah/papers/adhoc/adapsec.pdf
- 
-  --- Prince Samar <[email-masked]> wrote: > 
- > Hi Kean,
- > 
- > We have extended the concept of ZRP to develop the
- > Independent Zone 
- > Routing (IZR) framework, where each node has the
- > capability to maintain an 
- > independently sized routing zone. This allows each
- > node in the network to 
- > adaptively configure its own optimal zone radius in
- > a distributed fashion. 
- > This ability of a node to provide fine-tuned
- > adaptation to variations in 
- > network characteristics (like mobility, calling
- > patterns and load) over 
- > time and space enables the framework to perform well
- > in any kind of ad hoc 
- > network. The following paper is currently under
- > review.
- > 
- >   P. Samar, M.R. Pearlman, Z.J. Haas, "Independent
- > Zone Routing: An 
- >   Adaptive Hybrid Routing Framework for Ad Hoc
- > Wireless Networks," under 
- >   review.
- > 
- > Regards,
- > Prince
- > 
- > 
- > On Tue, 8 Apr 2003, Tan Kean Soon wrote:
- > 
- > >Hi, 
- > >Is there any protocol that does smart routing
- > decisions by taking the
- > >traffic load in the network into consideration.
- > Normally, route selection
- > >criteria uses metric such as shortest number of
- > hops and quickest
- > >response time to a request. Such decision making
- > can lead to the
- > >situation where all packets are routed through the
- > same node even if
- > >there exist better routes where the traffic load is
- > not as large. Could
- > >somebody shed some light on this issue?
- > >
- > >Thanks.
- > >
- > >Regards,
- > >Kean Soon
- > >
- > >_______________________________________________
- > >manet mailing list
- > >[email-masked]
- > >https://www1.ietf.org/mailman/listinfo/manet
- > >
- > 
- > 
- > 
- > 
- > 
- > _______________________________________________
- > manet mailing list
- > [email-masked]
- > https://www1.ietf.org/mailman/listinfo/manet 
- 
- ________________________________________________________________________
- Missed your favourite TV serial last night? Try the new, Yahoo! TV.
-        visit http://in.tv.yahoo.com
- _______________________________________________
- manet mailing list
- [email-masked]
- https://www1.ietf.org/mailman/listinfo/manet
-

---

From: [email-masked]
Date: Tue, 08 Apr 2003 15:18:47 -0700

> Hi,
> Is there any protocol that does smart routing decisions by taking the  traffic load in 
the network  into consideration. Normally, route selection criteria uses metric such as s
hortest number of hops and quickest response time to a request. Such decision making  can
 lead to the situation where all packets are routed through the same node even if there e
xist better routes where the traffic load is not as large. Could somebody shed some light
 on this issue?

I understand that you are talking about selecting routes that avoid
congestion, and possibly dividing traffic among multiple routes.
The protocols I mentioned in my previous message address this.

I want to point this out because the two recent posts from Cornell 
address a different problem: deciding the degree of proactive vs.
reactive routing. 

Richard

---

From: Dinesh Dharmaraju <[email-masked]>
Date: Tue, 8 Apr 2003 23:23:56 -0400 (EDT)

Hi Tan,
  We have a QoS protocol called INORA, (which uses INSIGNIA signaling and
TORA routing protocol) and choses routes based on the QoS requirements.
This adjusts adaptively to the traffic load at different nodes.

Please take a look at the following paper:
D. Dharmaraju, A. Roy-Chowdhury, P. Hovareshti, J. S. Baras , "INORA- A
Unified Signaling and Routing Protocol in Mobile AdHoc networks"  IWAHN '02

http://techreports.isr.umd.edu/TechReports/ISR/2002/TR_2002-33/TR_2002-33.phtml

Thank you.
Regards,
Dinesh