Subject: RE: [manet] Adaptive routing protocol based on network/node load

From: "Marwaha Shivanajay" <[email-masked]>
Date: Tue, 8 Apr 2003 13:32:50 +0800

Hi,
 
There are adaptive routing techniques for MANETs like:

1.	http://w3.antd.nist.gov/pubs/roux_m2000.pdf <http://w3.antd.nist.gov/pubs/roux_m2000.pdf>   "COST ADAPTIVE MECHANISM TO PROVIDE NETWORK DIVERSITY FOR MANET REACTIVE ROUTING PROTOCOLS"
2.	A fuzzy-decision-based routing protocol for mobile ad hoc networks,  ICON 2002

Regards,

Shivanajay

-----Original Message----- 
From: Tan Kean Soon [mailto:[email-masked]] 
Sent: Tue 4/8/2003 12:12 PM 
To: < 
Cc: 
Subject: [manet] Adaptive routing protocol based on network/node load

	Hi,
	Is there any protocol that does smart routing decisions by taking the  traffic load in the network  into consideration. Normally, route selection criteria uses metric such as shortest number of hops and quickest response time to a request. Such decision making  can lead to the situation where all packets are routed through the same node even if there exist better routes where the traffic load is not as large. Could somebody shed some light on this issue?
	
	Thanks.
	
	Regards,
	Kean Soon
	
	_______________________________________________
	manet mailing list
	[email-masked]
	https://www1.ietf.org/mailman/listinfo/manet

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Venu Ramasubramanian" <[email-masked]>
Date: Tue, 8 Apr 2003 17:52:13 -0400

Hi,
  We have developed a hybrid and adaptive routing protocol called SHARP for mobile ad hoc networks.  SHARP combines a proactive and a reactive routing algorithm and adapts the extent of proactive versus reactive routing based on observed network characteristics, such as link failure rate and node degree, and traffic characteristics, such as number of sources transmitting data to a destination and length of routes.  SHARP enables each destination node to independently adjust the amount of hybridization in order to control the routing performance based on application requirements. 
Currently, SHARP based protocols enable nodes to achieve three different application-specific goals, namely, minimal routing overhead, bounded loss rate, and bounded delay jitter.

  A paper on SHARP would be presented in MobiHoc 2003.

Venugopalan Ramasubramanian, Zygmunt J Haas, and Emin Gun Sirer.  SHARP: A Hybrid Adaptive Routing Protocol for Mobile Ad Hoc Networks. In Proceedings of the Fourth International Symposium on Mobile Ad Hoc Networking and Computing (MobiHoc) 2003, Annapolis, MD, June 3-6, 2003.

yours,
rama

----------------------------------------------------------------------------------------------------------------------------
Ramasubramanian, Venugopalan (Rama)
Dept. of Computer Science,	
Cornell University,
Ithaca, NY 14853.
Ph: 607-254-5075.   
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Pete Sholander" <[email-masked]>
Date: Tue, 08 Apr 2003 18:29:37 -0400

Kean,

Useful info on dynamic routing can also be gleaned from the canonic
Telco routing book "Dynamic Routing in Telecommunications Networks", by
Gerald R. Ash.  That text covers some of the really "old-school"
dynamic-routing algorithms for wired networks :)

--Pete Sholander

>>> <[email-masked]> 04/08/03 02:43PM >>>

> Hi,
> Is there any protocol that does smart routing decisions by taking the
 tra
ffic load in the network  into consideration. Normally, route selection
crit
eria uses metric such as shortest number of hops and quickest response
time 
to a request. Such decision making  can lead to the situation where all
pack
ets are routed through the same node even if there exist better routes
where
 the traffic load is not as large. Could somebody shed some light on
this is
sue?

Hi Kean,

There are several such protocols.  Here is one of them:

P. Gupta and P. R. Kumar, ``A system and traffic dependent adaptive 
routing algorithm for ad hoc networks,'' Proceedings of the 36th 
IEEE Conference on Decision and Control, pp. 2375-2380, San Diego, Dec.
1997. 
Even before that, I designed such a protocol (with John Hight, 
Dave Beyer, and others) called STIP (Secure Tactical Internet Protocol)

in 1993, which was not published but can be found in the following 
project report:

J. Hight, E. Costa, D. Lee, R. Ogier, J. Wong. 
"Evaluation and Development of Multimedia Networks in Dynamic
Stress (EDMUNDS): Final Technical Report",
SRI Technical Report ITAD-8558-FR-93-277, October 1993.

I know there are more recent routing protocols that take traffic 
load into account, but I wanted to point out that such protocols
were developed 10 years ago.

Richard