Subject: Re: [manet] Neighbor addresses in OLSR HELLO messages

From: [email-masked]
Date: Mon, 14 Apr 2003 12:27:16 -0400 (EDT)

>Few of the manet protocols have directly addressed security issues as 
>raised in 
>http://www.ietf.org/internet-drafts/draft-ietf-rpsec-routing-threats-00.txt. 

For those who have not visited the rpsec mailing list, I should note that
this draft is still very much a work in progress.  In particular, I think
that some of the language shows a wired world focus and would not fit
a wireless world.  As I've said in various comments to the rpsec list.
I invite anyone interested in the security of manet protocols to visit
the rpsec list to add an informed voice to the discussion.

--Sandy
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Manfredi, Albert E" <[email-masked]>
Date: Tue, 15 Apr 2003 14:31:50 -0400

Fred Baker wrote:

> The issue I am raising is in the following vein. In a manet 
> network, for 
> example, a truck (which has an internal wired LAN with some number of 
> computers and a router connecting it to the manet) might 
> drive into a yard 
> and jack into the local network, becoming both a mobile and a 
> fixed node.

I understand your sentiment that a single protocol for mobile hosts and the fixed Internet would be preferable. But ...

Somehow, that's not a scenario I would postulate for a MANET. The truck can park in a yard and plug into a fixed network as you describe. If the IP addresses inside the truck are globally unique, then I would think a standard IGP outside the truck will have time to announce routes to the trucks hosts, and the IGP inside the truck ditto. No? No need for any MANET here, that I can see.

If the IP addresses inside the truck, and all other similar trucks, are NOT globally unique, e.g. they are taken from the private address space (extremely likely), then a NAT will have to be used between truck and fixed Internet. Again, no need for any MANET. This is just like connecting a home with multiple PCs to an ISP.

I think the MANET part would only come into play if many of these trucks were running around a large battlefield, for instance, and wanted to remain in constant communications among each other and hopefully also with the wired Internet. AND if this were to be by means of wireless links *between trucks* only. One or more trucks would also have to be within range of a fixed Internet AP. I emphasize large battlefield, because again, if each truck were within range of the AP, then no MANET is needed.

The problem here is that the topology changes too fast for traditional IGPs to keep up. And there's very little likelihood that route aggregation can be used to make this beast scale. So a poorly scaling but rapidly updating routing protocol would be used between trucks, but you wouldn't want to burden the fixed Internet this way. The presumption is that there won't be too many trucks in this MANET.

The easy way out of this one is to connect each truck to a satellite link, and let both truck-truck and truck-Internet comms occur via that link. In which case, once again, no MANET needed. In this example, functionally, every truck here is within range of the fixed Internet AP. The satellite link is the AP.

> Now, by military rules, the truck is supposed to have an 
> address assigned 
> by its unit, so what it probably does is generate a local 
> address in the 
> fixed network using DHCP and then advertise reachability to 
> its mobile 
> prefix. Hence, the mobile prefix is now floating in both IGPs. If the 
> *intended* router between the IGPs now leaks the prefix back 
> in either 
> direction, problems can develop.

Yes, but I just don't see THIS as being a MANET candidate. If the truck is parked in that yard for any length of time at all, OSPF should stabilize. Especially if a NAT is used, so that the truck's temporary prefix to the outside world is a well-known prefix for that particular location.

Bert