Subject: [manet] Possible error in mac-802_11.cc

From: Carlos Miguel Calafate <[email-masked]>
Date: Wed, 30 Apr 2003 10:38:25 +0200

Hi everyone,

I think I have discovered a possible error applying to ns-2.26.
In the mac-802_11.cc file you have:

if((u_int32_t) ch->size() <= macmib_->RTSThreshold)
                ssrc_ = 0;
        else
                slrc_ = 0;

In a previous e-mail, I have reported an error occurring while 
performing FTP transfers between 2 nodes using AODV and AODV-UU.
I have solved it adding;
 ssrc_ = 0;

to the "else" section too.

Is this correct? Should additional changes be performed on that file?

Best regards,

-- 
_________________________________________________
Carlos Miguel Tavares de Araújo Cesariny Calafate
Becário de la Universidad Politécnica de Valencia
e-mail: [email-masked]
http://reptar.grc.upv.es/~calafate/
_________________________________________________
\"In an open world without walls and fences who 
needs Windows and Gates?\"

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Carlos Miguel Calafate <[email-masked]>
Date: Wed, 30 Apr 2003 11:49:27 +0200

Oops, sorry, wrong mailing list!