Subject: [manet] monotoring of ad hoc

From: "[email-masked]" <[email-masked]>
Date: Thu, 17 Apr 2003 17:12:33 +0200

hi every body ,

I am a student in computer engineering, I prepare my memory 
about implementation of a monotoring tool for ad hoc networks! 
I still search how can we compute the batterry life, the power 
consumption, the SNR signal noise ratio and how we can 
estimate the effective bandwith and delai betwen neigbors.

if anyone know any information about this topic, please send 
me 
thank you

Accédez au courrier électronique de La Poste : www.laposte.net ; 
3615 LAPOSTENET (0,34€/mn) ; tél : 08 92 68 13 50 (0,34€/mn)"

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Pete Sholander" <[email-masked]>
Date: Thu, 17 Apr 2003 12:27:12 -0400

On Red Hat Linux, some *simplistic* approaches are:

a) Battery and Power consumption: use the info from /proc/apm
b) Bandwidth: count bytes using Traffic Control
c) SNR/BER: estimate it from the Hello Packet loss rate or get it from
the NIC
d) Delay: ping works ;-)  The other technique is something like NRL's
mgen which time-stamps test traffic.

Hope this helps.  Finally, you might summarize back to the list the
various suggestions and tools that you get/find.

>>> "[email-masked]" <[email-masked]> 04/17/03
11:12AM >>>
hi every body ,