Subject: RE: [manet] Re: [BAWUG] I have a dream

From: "Manfredi, Albert E" <[email-masked]>
Date: Wed, 2 Apr 2003 16:46:40 -0500

Whether the scheme is geographically-based or provider-based, the important thing is to be able to aggregate routes. MANET does nothing to solve this routing scale problem, in a *global* sense. You still have to tie the MANET to the wired Internet efficiently.

Bert

> -----Original Message-----
> From: S Woodside [mailto:[email-masked]]
> Sent: Wednesday, April 02, 2003 2:09 PM
> To: Joel Jaeggli
> Cc: [email-masked]; [email-masked]; 
> [email-masked];
> Tony Hain
> Subject: [manet] Re: [BAWUG] I have a dream
> 
> 
> On Wednesday, April 2, 2003, at 01:02  AM, Joel Jaeggli wrote:
> 
> > um... the internet routing architecture didn't explode in 
> 1997 becuase
> > we'd didn't do this. meshed network edges need an igp, some 
> sanity and
> > cooperative upstreams, otherwise you'll just have a very 
> large very  
> > messy
> > subnet with not external routing.
> 
> Not true at all. With IPv6 there's plenty of ways to solve 
> the problem.  
> This is one:
> 
>     http://www.ietf.org/internet-drafts/draft-hain-ipv6-pi-addr-03.txt
>      
> http://www.ietf.org/internet-drafts/draft-hain-ipv6-pi-addr-use-03.txt
> 
>          It is frequently assumed that any address format 
> that is not  
> based
>          on provider aggregation will degenerate into the 
> 'swamp' that  
> came
>          to describe pre-CIDR IPv4, with the result that the routing  
> table
>          grows unabated. The goal of this scheme is to allow 
> sites to be
>          independent of any provider, while still allowing 
> aggregation  
> for
>          those who do not require explicit global routing policy. As a
>          result, there will need to be consistently applied 
> rules for  
> when a
>          prefix gets aggregated and when it doesn't. These will be  
> discussed
>          in the recommendations section.
> 
> simon
> 
> > joelja
> >
> >
> > On Wed, 2 Apr 2003, S Woodside wrote:
> >
> >> Well, it's a fairly minor dream. What I imagine is this: I 
> have DSL.  
> >> My
> >> neighbour has DSL. We also both have WiFi APs that can reach each
> >> other, and connect at order-of-magnitude faster than the DSL links.
> >> What I dream is this: That we start routing internet 
> across the link.
> >> When I start pulling packets off the internet, they can 
> come to me not
> >> only through my own DSL but from hers as well. I think 
> this boils down
> >> to an ultimate simplicity what all FN / CWNers want to achieve.
> >>
> >> What needs to happen before I can realize my dream. I need 
> to get an
> >> IPv6 address ... at least one ... for free. I need to be 
> able to set  
> >> up
> >> multi-homing in my home router. I need to be able to advertise my
> >> routing path to the internet. The internet needs to be 
> able to handle
> >> at a massive scale (since every neighbour connects...). We need a  
> >> /lot/
> >> more IP addresses than we have now. I need to use a /real/ 
> IP address
> >> because I can't route internet traffic through a NAT/site-local
> >> address. I need to have an ad-hoc routing algorithm that can set up
> >> this bridge and route across it really easily (because I'm not a
> >> trained network admin). Forget about BGP, AS, etc., we 
> need a way to
> >> handle the massive overload of routes at local scale, at a regional
> >> scale, at a global scale -- something that will scale 
> gracefully as  
> >> the
> >> internet topology shifts from a tree to a massively connected mesh.
> >>
> >> Please comment ... tell me what you think.
> >>
> >> Simon
> >>
> >> PS I'm cross-posting this to a bunch of lists because I 
> don't know one
> >> it belongs on. If you think you know which is best, please tell me!
> >>
> >> --
> >> general wireless list, a bawug thing <http://www.bawug.org/>
> >> [un]subscribe: http://lists.bawug.org/mailman/listinfo/wireless
> >>
> >
> > --  
> > 
> --------------------------------------------------------------
> --------- 
> > ---
> > Joel Jaeggli	      Academic User Services   
> [email-masked]
> > --    PGP Key Fingerprint: 1DE9 8FCA 51FB 4195 B42A 9C32 
> A30D 121E      
> >  --
> >   In Dr. Johnson's famous dictionary patriotism is defined 
> as the last
> >   resort of the scoundrel.  With all due respect to an 
> enlightened but
> >   inferior lexicographer I beg to submit that it is the first.
> > 	   	            -- Ambrose Bierce, "The Devil's Dictionary"
> >
> >
> > --
> > general wireless list, a bawug thing <http://www.bawug.org/>
> > [un]subscribe: http://lists.bawug.org/mailman/listinfo/wireless
> >
> >
> --
>       anti-spam: do not post this address publicly
> www.simonwoodside.com -- 99% Devil, 1% Angel
> 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/manet
> 
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 09 Apr 2003 09:12:49 -0700

Hello Bert,

"Manfredi, Albert E" wrote:

> Whether the scheme is geographically-based or provider-based,
> the important thing is to be able to aggregate routes.

Check.

> MANET does nothing to solve this routing scale problem,
> in a *global* sense. You still have to tie the MANET to
> the wired Internet efficiently.

Since we aren't demanding any internal route aggregation
within the ad-hoc network, the only answer is to somehow
shield the "wired" (<--maybe not for long) Internet from
the internal (and dynamic!) routing arrangements inside
the ad hoc network.

Regards,
Charlie P.