Subject: [manet] Re: manet digest, Vol 1 #348 - 4 msgs

From: Siddharth Ray <[email-masked]>
Date: Sat, 5 Apr 2003 15:38:39 -0800 (PST)

Hi All,
I am trying to simulate routing misbehavior in
glomosim on top of DSR. I want 
to know where the nodes that are actually getting
allocated in glomosim. I want
to read from a configuration file the behavior and
assign it to each node
before simulation starts in DSR. Where exactly to make
this change...
-Siddharth

__________________________________________________
Do you Yahoo!?
Yahoo! Tax Center - File online, calculators, forms, and more
http://tax.yahoo.com
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Manoj K Pandey <[email-masked]>
Date: Sat, 5 Apr 2003 17:43:05 -0800 (PST)

hi Siddharth,

the nodes are assigned their initial configuration in
"driver.pc" file [position, uniform/random, which partition etc].
Also, Each of the layer has an "Init"
component. For example, if you are using a combination of
CBR-DSR, there would be an cbrInit(), udpInit, dsrInit()
and simliar Mac and Radio layer Inits.
You could call the routing misbehavior from the dsrInit().

Hope it helps else if you can get a little more specific,
we might be able to help you more on this.

thnx,
manoj

******************************
Manoj Pandey, PhD student,
#226, Deschutes, Computer and Information Science,
University of Oregon, Phone# 541-346-1381 [Office],
www.cs.uoregon.edu/~manoj
******************************