Subject: [manet] routing protocols-- spoofed IP

From: "George Hadjichristofi" <[email-masked]>
Date: Wed, 23 Jul 2003 12:43:02 -0400

Hi,

Are there any routing protocols that can detect or provide protection
against spoofed IP addresses?

Thanks
George

***********************************************************
George C. Hadjichristofi
Graduate Student
Bradley Department of Electrical and Computer Engineering
Virginia Tech,Blacksburg,VA 24061,U.S.A
TEL:(540)-951-8936
***********************************************************

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Joe Macker <[email-masked]>
Date: Wed, 23 Jul 2003 13:44:46 -0400

>against spoofed IP addresses?

There are authentication methods one can think of applying to messaging.
Hopefully ones that also protect against replay,etc.

Is this what you mean?

You might want to check the routing security working group which 
is working the more general problem of routing security.

---

From: [email-masked]
Date: Wed, 23 Jul 2003 21:07:18 +0200

> against spoofed IP addresses?

Hello,

One solution is to use Crypto. Generated Addresses...
CGA are currently being used to secure MIPv6 and ND. They
can also be used in MANET to secure the routing protocol.
We actually applied them to secure AODVv6 but they can actually be
used with any protocols...
You can read:
  ¨Protecting AODV against impersonation attacks¨
http://portal.acm.org/citation.cfm?id=581313&coll=portal&dl=ACM&ret=1#Fulltext

hope this help...
Claude.

---

From: Fred Templin <[email-masked]>
Date: Wed, 23 Jul 2003 13:12:49 -0700

>CGA are currently being used to secure MIPv6 and ND. They
CGA is one alternative; see the IETF SEND wg for more info.

>used with any protocols...
Agreed; we touched on this briefly in the TBRPF spec.

Fred
[email-masked]