Subject: RE: [manet] how to detect the type of sensing range frame

From: "#LI ZHIFEI#" <[email-masked]>
Date: Tue, 15 Jul 2003 15:29:47 +0800

Thank you for your response. 

But I am still not clear about the method your mentioned (i.e., "frame length analysis") . Could you please explain it more clearly or give me 
some links/examples. We can simply assume that there is only one  interferer.

Best regards

Li zhifei

-----Original Message-----
From: Miguel S¨¢nchez [mailto:[email-masked]]
Sent: dimarts, 15 / juliol / 2003 15:25
To: #LI ZHIFEI#
Cc: [email-masked]
Subject: Re: [manet] how to detect the type of sensing range frame

Hi Li,

While not sure you can get this info from the device driver, it seems
that frame length analysis, when possible, it would allow you to learn
if your interferer is sending RTS/CTS, data or ACK.

However, if you have multiple interferers then this idea could not be
applied.

Best,

Miguel Sánchez
Polytechnic University of Valencia, Spain

#LI ZHIFEI# wrote:

>Hi,
>
>In the IEEE 802.11, when the sensing range (SR) is assumed to be greater than the transmission range, 
>is there any methods for a node that detects an SR frame to identify the type (i.e., RTS/CTS/Data/ACK) of this frame?
>Note that the node cannot interpret the content of the SR frame.
>
>Best regards 
>Li ZhiFei 
>PhD candidate,  
>Center For Multimedia And Network Technology
>School Of Computer Engineering
>Nanyang Technological University
>N4-b2c-08, Nanyang Avenue
>Singapore 639798
>tel:(65)67906579 
>website: <http://www.ntu.edu.sg/home5/pg03802331> 
>
>
>_______________________________________________
>manet mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/manet
>
>
>  
>

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Miguel Sánchez <[email-masked]>
Date: Tue, 15 Jul 2003 10:08:08 +0200

Hi Li,

What I mean is that given that RTS, CTS, data and ACK frames have
different frame lengths (only data has a variable size), then by looking
at the length of the "interference you cannot receive as a frame" you
could figure out what kind of frame caused it (even when you cannot
successfully decode it).

Regards,

Miguel Sánchez