Subject: [manet] About changing bandwidth

From: skame <[email-masked]>
Date: Mon, 7 Jul 2003 18:18:54 +0900

Hi,all.

I want to know the way of changing bandwidth.
The defalut bandwidth in ns2 is 2[Mb/s].
I suppose 802.11b in maclayer.
Now bandwidth in 802.11b is 11[Mb/s].
So I want to change the bandwidth from 2[Mb/s] to 11[Mb/s].
Please tell me how to change bandwidth.

Thank you.
skame

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Fethi Filali <[email-masked]>
Date: Mon, 07 Jul 2003 11:59:45 +0200

skmae,

The default rate in ns2 seems to be 1Mb.

See file ns-2.26/tcl/lan/mac.tcl , u can find the line:

   Mac/802_11 set dataRate_ 1Mb   ;# both control and data pkts

the tcl variable dataRate_ is binded to the c++ variable dataRate_ in 
the mac-802_11.cc file

you can change the default value in mac.tcl and recompiling ns.

Fethi.