Subject: RE: [manet] Carrier sense threshold/range control

From: "#LI ZHIFEI#" <[email-masked]>
Date: Fri, 11 Jul 2003 16:12:30 +0800

Is there any formal definition about the "interference range"?

The definition of  "interference range" in the following paper is some confusing to me.

How effective is the IEEE 802.11 RTS/CTS handshake in ad hoc networks? 
Kaixin Xu; Gerla, M.; Sang Bae; 
Global Telecommunications Conference, 2002. GLOBECOM '02. IEEE , Volume: 1 , Nov 17-21, 2002 
Page(s): 72 -76

However, I do believe that when SR is increased, the spatial reuse in multi-hop networks will be substantially reduced, which is also pointed out in the above paper.

Best regards 
Li ZhiFei 
PhD candidate,  
Center For Multimedia And Network Technology
School Of Computer Engineering
Nanyang Technological University
N4-b2c-08, Nanyang Avenue
Singapore 639798
tel:(65)67906579 
website: <http://www.ntu.edu.sg/home5/pg03802331> 

-----Original Message-----
From: Chi-Hsiang Yeh [mailto:[email-masked]]
Sent: divendres, 11 / juliol / 2003 12:09
To: #LI ZHIFEI#; [email-masked]
Cc: 'Vikram Dham'
Subject: RE: [manet] Carrier sense threshold/range control

Hi, Zhifei,

> > Though we may not be elminating all the hidden terminals but we may 
> >decrease
> >the probability of occurence of hidden terminals by 
> extending sensing range to 
> >2SR.            ????  >2TR
>
> The objective of elminating the hidden terminal problem is to 
> reduce collisions and thus 
> increase the channel utilization. However, if you increase 
> the sensing range, the interfering range is 
> also increased and thus the spatial reuse is greatly reduced. 

This is not true. Besides SR and TR, there is another parameter
"interference range (IR)", which is not necessarily equal to SR. By
lowering the threshold for sensing, increasing SR does not affect IR.
Instead, IR is increased when the associated transmission power level is
increased.

Also, when SR >= IR + TR, topology 2 (in your previous e-mail) and other
topologies without obstacles would not suffer from the hidden terminal
problem (without considering collisions of control messages and
propagation characteristics/delays etc. of course).

Chihsiang

> Of course, if capture is enabled, it may be a different 
> story. However, with capture, fairness becomse worse (which 
> is my main concern). 
> Moreover, as I have mentioned, when the sensing range (SR) is 
> made greater than transmission range (TR), 
> how long a node should defer its transmission when it detects 
> a SR frame is a very difficult job as 
> the node cannot interpret the conent of a SR frame.
> 
> 
> 
> Li zhifei
> 
> 
> -----Original Message-----
> From: Vikram Dham [mailto:[email-masked]]
> Sent: dijous, 10 / juliol / 2003 23:02
> To: #LI ZHIFEI#; manet
> Subject: RE: [manet] Carrier sense threshold/range control
> 
> 
> Hello Zhifei Li,
> 
> Though topology 2 also may have scenarios with hidden 
> terminal, but in a 
> wireless network,
> 
> probability (distance between nodes > 2SR) =< probability 
> (distance between 
> nodes > SR ).
> 
>  Though we may not be elminating all the hidden terminals but 
> we may decrease 
> the probability of occurence of hidden terminals by extending 
> sensing range to 
> 2SR.
> 
> Regards
> 
> Vikram Dham
> >===== Original Message From #LI ZHIFEI# <[email-masked]> 
> >===== Hi, Ram
> >
> >In my view, even the Carrier Sensing Range (SR) is two times of the
> Transmission Range (TR ), the hidden-termianl problem is still there.
> >This can be illustrated as the following two topologies:
> >
> >Topology 1:                                               Topology 2:
> >
> >A -> B <- C                                                A -> B
C<- D
> >
> >(note that the distance between two neighboring nodes are 
> equal to the
> transmission range, i.e., one hop)
> >
> >The first topology is tipycally used to illustrate the well-known
> hidden-terminal problem, but with an implicit assumption, i.e., SR=TR.
> >If SR=2*TR, the hidden-terminal problem seems not exist any more in 
> >this
> topology as the nodes A and C can sense the transmission of 
> each other.
> >
> >However, even SR=2*TR, the problem will arise in the second topology.
> Specically, when node A starts to transmit to node B, since node D
> >is out of the SR of node A, it cannot detect the transmission. 
> >Therefore,
> node D may also start to transmit to node C, resulting in 
> collision (or 
> capture).
> >In such case, we can say that nodes A and D are hidden 
> terminal of each
> other. We do find the similarities of the performance between 
> the two cases:
> >topology 1 when SR=TR; and topology 2 when SR=2*TR
> >
> >
> >When SR>TR, another problem is that how a node should defer its 
> >transmission
> when it detects a SR frame. This is not an easy job since the 
> node cannot
> >interpret the content of the SR frame. In the IEEE 802.11, 
> whenever a 
> >node
> detects a SR frame, it will defer by a fixed EFIS value. 
> However, our results 
> show
> >this fixed value will cause many problems, e.g., unfairness. 
> Moreover, 
> >the
> capture ability will also greatly affect the performace when SR>TR.
> >For a detailed descrition of these issues, please refer to 
> the attached
> references:
> >
> >Zhifei Li, Sukumar Nandi, Anil K. Gupta,
> >"Improving Fairness in IEEE 802.11 based MANETs using 
> Enhanced Carrier
> Sensing", submitted to conference, April 2003
> >http://www.ntu.edu.sg/home5/pg03802331/papers/ecs.pdf
> >
> >
> >Zhifei Li, Sukumar Nandi, Anil K. Gupta,
> >"Study of IEEE 802.11 Fairness and its Interaction with Routing 
> >Mechanism",
> accepted by IEEE MWCN 2003 Singapore, May 2003
> >http://www.ntu.edu.sg/home5/pg03802331/papers/mwcn03.pdf
> >
> >
> >Though the above papers mainly focus on the the fairness issue when 
> >SR>TR,
> the descirtion should also apply to the analysis of the 
> channel utilization.
> >I hope that they will  relate to your work and help you.
> >
> >
> >Best regards
> >Li ZhiFei
> >PhD candidate,
> >Center For Multimedia And Network Technology
> >School Of Computer Engineering
> >Nanyang Technological University
> >N4-b2c-08, Nanyang Avenue
> >Singapore 639798
> >tel:(65)67906579
> >website: <http://www.ntu.edu.sg/home5/pg03802331>
> >
> >
> >-----Original Message-----
> >From: Ram Ramanathan [mailto:[email-masked]]
> >Sent: dijous, 10 / juliol / 2003 00:09
> >To: [email-masked]
> >Cc: [email-masked]
> >Subject: [manet] Carrier sense threshold/range control
> >
> >
> >
> >I am looking for pointers to research on the control of 
> carrier sensing 
> >range in lieu of using RTS/CTS to address the hidden node problem?
> >
> >To elaborate, the threshold for when carrier is declared to 
> be "sensed" 
> >can be adjusted in many radios. Using this facility, one 
> could possibly 
> >make the "carrier sense range" approximately twice the 
> "communication 
> >range" (successful packet reception), and detect hidden nodes.
> >
> >This is by no means a new idea, and I vaguely recally some 
> mention of 
> >it on this list. Of course, there are a number of factors 
> that make the 
> >problem far more complex than the simple statement above 
> indicates, and 
> >it is not immediately clear whether it will be effective at all.
> >
> >I am looking for papers, tech reports, or any publicly available 
> >material
> >(non-proprietary) on this issue.
> >
> >Many thanks in advance,
> >
> >-Ram.
> >
> >_______________________________________________
> >manet mailing list
> >[email-masked]
> >https://www1.ietf.org/mailman/listinfo/manet
> >
> >
> >
> >
> >_______________________________________________
> >manet mailing list
> >[email-masked]
> >https://www1.ietf.org/mailman/listinfo/manet
> 
> 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/manet
> 
> 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/manet
> 

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Chi-Hsiang Yeh" <[email-masked]>
Date: Fri, 11 Jul 2003 16:53:33 -0400

Hi, Zhifei,

> However, I do believe that when SR is increased, the spatial 
> reuse in multi-hop networks will be substantially reduced, 
> which is also pointed out in the above paper.

You are right when SR is too large so that CSMA becomes too conservative
(and the exposed terminal problem deteriorates). But such reduction in
throughput is not caused by increase in IR (and in fact IR is not
increased in such a case). SR >= IR + TR is just a condition to solve
the hidden terminal problem in open space (as I was pointing out that
this was possible when there were no obstacles). It is not necessarily a
condition optimized for throughput, collision rate, or other metrics.

Best regards,

Chihsiang

> From: #LI ZHIFEI# [mailto:[email-masked]] 
> Sent: Friday, July 11, 2003 4:13 AM
> To: Chi-Hsiang Yeh; [email-masked]
> However, I do believe that when SR is increased, the spatial 
> reuse in multi-hop networks will be substantially reduced, 
> which is also pointed out in the above paper.
> 
> 
> Best regards 
> Li ZhiFei 
> PhD candidate,  
> This is not true. Besides SR and TR, there is another 
> parameter "interference range (IR)", which is not necessarily 
> equal to SR. By lowering the threshold for sensing, 
> increasing SR does not affect IR. Instead, IR is increased 
> when the associated transmission power level is increased.
> 
> Also, when SR >= IR + TR, topology 2 (in your previous 
> e-mail) and other topologies without obstacles would not 
> suffer from the hidden terminal problem (without considering 
> collisions of control messages and propagation 
> characteristics/delays etc. of course).
> 
> Chihsiang
> 
> > >Topology 1:                                               
> Topology 2: