Subject: RE: [manet] MANET real time applications

From: Michael Rauf <[email-masked]>
Date: Thu, 24 Jul 2003 09:40:23 -0400

I respectfully disagree as this is a General Discussion Group for MANET. I
would also like to hear anyone's input to Reham's question. 

_________________________________
Michael Rauf  
Nova Engineering  

-----Original Message-----
From: Jitesh Shah [mailto:[email-masked]] 
Sent: Thursday, July 24, 2003 8:20 AM
To: [email-masked]
Subject: Re: [manet] MANET real time applications

Hi,

I think such questions should not be addressed to this
group. You may please refer to some basic Manet book
or   on internet for that matter.

Regards
Jitesh

 --- reham elmayet <[email-masked]> wrote: 
---------------------------------
hi all,
I want to know what'sa the real time applications for
MANETs.
Also, what's the points for research in this
direction.
Regards,
Reham

________________________________________________________________________
Send free SMS using the Yahoo! Messenger. Go to
http://in.mobile.yahoo.com/new/pc/

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Lawrence MacIntyre <[email-masked]>
Date: 24 Jul 2003 10:03:15 -0400

I would say that the obvious real-time app for wireless is
videoconferencing and the obvious research direction would be providing
QOS.

Another application would be wireless sensors and activators.

-- 
    Lawrence MacIntyre     865.574.8696     [email-masked]
               Oak Ridge National Laboratory
High Performance Information Infrastructure Technology Group

---

From: Jon Zeeff <[email-masked]>
Date: Thu, 24 Jul 2003 11:07:51 -0400

>videoconferencing and the obvious research direction would be providing

I agree that real-time video is a demanding application and thus a good 
test case.  Also that
QOS (in it's broadest definition - ie, including multipath routing, fair 
queuing, non hop-count
metric based routing, etc) is needed.

---

From: "BRIAN McBride" <[email-masked]>
Date: Thu, 24 Jul 2003 12:23:26 -0400

I have been doing QoS (ATM, diffserv etc.) for quite sometime, but yet have
to find a necessary application other than leased lines and simple "real
time" vs non-real time.  However it does make good research work.

I am interested in understanding why QoS is important, separating research
from standards development.  Is there some work on the applications of
ad-hoc networking someone could point me to as a starting point?

I have my theories and the common ones I think, but do not know of any that
require QoS other than pure fairness amongst all active users.  Seems to me
the nature of ad-hoc is all are fairly treated, to introduce bias would
imply some central authority to manage the bias.  I always considered ad-hoc
in the context of free-roaming, independent, individuals in a network.

Qos leads to guaranteed Qos that inevitably will lead to a claim that MPLS
and TE must then be applied to mobile ad-hoc networking ;-).

The obvious app for real-time to me is voice, but it is my choice of how I
use the bits I am allocated in the network, the network just needs to offer
me fair access to the bits.

Thanks,
Brian McBride

---

From: Rex Buddenberg <[email-masked]>
Date: 24 Jul 2003 10:42:17 -0700

Brian,

There are lots of applications where, in the macro, we have legitimate
needs to make some pigs more equal than others.  But ... TANSTAFL.

Consider these parameters as metrics of qos:
	- bandwidth efficiency
	- latency
	- jitter
	- interactivity
	- determinism

At layer 3, IP optimizes bandwidth efficiency and trades all the other
parameters to get it.  Somehow that usually gets warped into 'not real
time' is discussion.  QoS control, at least within the MANET context,
means changing the layer 3 handling to optimize one or more of the other
parameters.  But always at the expense of bandwidth efficiency.
	Diff-serv, RSVP, MPLS are all methods to change this optimization
default in some way.  

At layer 2, we have two qos models.  Ethernet (CSMA/CD) and it's
offspring in 802.11, optimize interactivity (and min latency comes along
with it) and does so at the expense of bandwidth efficiency.	
	By contrast, token MACs optimize bandwidth efficiency, throw in
determinism and do it at the expense of the other three parameters.

Oh, TANSAFL?  There aint no such thing as free lunch.

-- 
b

---

From: "BRIAN McBride" <[email-masked]>
Date: Mon, 28 Jul 2003 16:14:04 -0400

Harpreet, Rex, Albert

Thanks, I did not mean to sound skeptical, just wanted to understand which
applications people are considering QoS for.  I favour ad-hoc for a communal,
hostile and decentralized network of fairly simple devices, ie not mobile IP.
As such only fair access to the medium is expected and nodes are assumed to be
misbehaving.  My skepticism is limited to enforcing any global QoS policies in
an ad-hoc network using connection-like methods.

I am doing a study to show how a well connected network of simple devices can
achieve good QoS without reservation of bandwidth for a decentralized, dynamic
and hostile network.  Good QoS, even for voice and video, does not require
reservation.

I agree there are flows that are more important and current TCP/IP and MAC do
not work.  However I believe flow importance can only be defined in a host to
host manner, rather than globally, in a hostile wireless network.  This is
different than the current networking where it is difficult for a device to tap
into your fibre/wire and do bad things.

The problem with TCP is that the end stations, not the intermediaries, define
the fairness, therefore the network is exposed to malicious end stations.  IMHO
a simple distributed mechanism all intermediaries enforce is required to achieve
any QoS in an ad-hoc network.  This does not require any reservation mechanisms
however.

Brian

"Harpreet S. Arora" wrote:

> Hi Brian,
>
> I have been studying QoS for MANETs for quite some time now. I feel that QoS
> is essentially important for MANETs because of the kinds of applications
> that are projected from them. Most common among them are in the defence
> sector and disaster relief operations (comemrcial applications are also
> being developed like an ad hoc network of a group of cars). This implies
> that MANETs are going to be used widely for voice communications (between
> soldiers and rescue workers etc). Here, best effort delivery would not work.
> Simulations show that one new flow can easily influence the existing flows
> in terms of their end-to-end latency, packet delivery ratio etc. Also in
> situtations like war some flows WILL be more important that others and it is
> necessary that nodes are aware of such differentiation. Current TCP/IP model
> and MAC 802.11 which aim at being fair to all participating nodes wont work
> here. I think this is sufficient reason to consider QoS as an important
> aspect of ad hoc networks.
>
> regards,
> Harpreet
>
> ----- Original Message -----
> From: "BRIAN McBride" <[email-masked]>
> To: "Jon Zeeff" <[email-masked]>
> Cc: "Lawrence MacIntyre" <[email-masked]>; "Michael Rauf"
> <[email-masked]>; "'Jitesh Shah'" <[email-masked]>;
> <[email-masked]>
> Sent: Thursday, July 24, 2003 12:23 PM

--
Cheers,
Brian M

"It is not worth an intelligent man's time to be in the majority. By definition,
there are already enough people to do that." G. H. Hardy (1877 - 1947)

---

From: Ash Mohammad Abbas <[email-masked]>
Date: Tue, 29 Jul 2003 05:51:50 +0100 (BST)

Dear BRIAN McBride
My suggestion is, continue your good work, if you deem so. Different people will have different arguments and suggestions, and it's natural. When your work is complete, let peer researchers in your area analyze your work. I mean, after completion, you may send your work to reputed conferences and/or journals, where your work might be reviewed by the experts in the field. Either your work will be accepted or at least you will receive their comments. In the light of those you can further continue your work. As I told, in research, views are different. After my work, somebody may come forward and say " These ...  were the omissions in Mr. Abbas work..., and these are our solutions regarding these omissions."  What is the harm in this. I should be happy, that people did spent thier valuable time in finding my mistakes and ommissions, and are coming with better solutions than me. It should be a thing of great pride for me.  So, one should continue his work and let others analyze !
 it.
After all, it's also one kind of view by a researcher like me. 
With best wishes,
Abbas
http://www.cse.iitd.ernet.in/~abbas

  BRIAN McBride &lt;[email-masked]&gt; wrote: Harpreet, Rex, Albert

Brian

"Harpreet S. Arora" wrote:

> From: "BRIAN McBride" 

> To: "Jon Zeeff" 
> Cc: "Lawrence MacIntyre" ; "Michael Rauf"
> ; "'Jitesh Shah'" ;
> 

--
Cheers,
Brian M

begin:vcard 
n:McBride;Brian
tel;work:613-784-3010
x-mozilla-html:FALSE
org:Alcatel;Research and Innovation
adr:;;;Ottawa;;;Canada
version:2.1
email;internet:[email-masked]
title:Senior Researcher
fn:Brian McBride
end:vcard

SMS using the Yahoo! Messenger;Download latest version.