Subject: [manet] NIST/AODV Problem

From: [email-masked]
Date: Fri, 25 Jul 2003 18:02:48 +0200

Hi,

I have installed the NIST/AODV implementation for OPNET, however each time I run the simulation, I get either a segmentation violation or a bus error.  Has anyone encountered this problem, or is there something I need to set in the simulation preferences
or environment?

Any help would be appreciated,

Regards,
Mei-Ling

<<< Program Fault >>>
* Time:      17:00:11 Fri Jul 25 2003
* Product:   modeler
* Program:   op_runsim (Version 8.0.C PL7 Build 1252)
* System:    SunOS eniac 5.6 Generic_105181-30 sun4u
* Package:   process (aodv_routing) at module (top.sn.mobile_node_0.aodv_routing)
* Function:  aodv_routing () [Handle_Breakage enter execs]
* Error:     program abort -- bus error
             T (272.55), EV (293234), MOD (top.sn.mobile_node_0.aodv_routing), PROC (aodv_routing)
* Function call stack: (builds down)
------------------------------------------------------------
Call   Block             Count  Line#  Function
------------------------------------------------------------
0)          1    125  m3_main (argc, argv)
1)          1    519  sim_main (prog_name, argc, argv, dynamic_sim, def_net_name, num_procs, ...)
2)          1    937  sim_ev_loop ()
3)     107074    481  sim_obj_qps_intrpt (simev_ptr)
4)      24888   3576  aodv_routing () [Handle_Breakage enter execs]
------------------------------------------------------------

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Jay J Lee <[email-masked]>
Date: Fri, 25 Jul 2003 14:10:54 -0400

Hmm, looks like a problem due to the difference in the version of Modeler 
the model was created and the version you are using to run them.  You 
should contact the OPNET technical support.  They will not be able to debug 
this problem for you since it is a contributed model but they will 
certainly help you on debugging process models in general.
BTW, I believe several MANET models will be released as a part of OPNET 
standard model library soon.  I am not sure if AODV will be one of them thou.

Hope this helps, - Jay

At 06:02 PM 7/25/2003 +0200, [email-masked] wrote:
>Hi,
>
>I have installed the NIST/AODV implementation for OPNET, however each time 
>I run the simulation, I get either a segmentation violation or a bus 
>error.  Has anyone encountered this problem, or is there something I need 
>to set in the simulation preferences
>or environment?
>
>              T (272.55), EV (293234), MOD 
> (top.sn.mobile_node_0.aodv_routing), PROC (aodv_routing)

---

From: "Liaw, Yong Shyang - LIAYS001" <[email-masked]>
Date: Sat, 26 Jul 2003 13:57:26 +0930

As jay point out, the version of the model you use may need a particular
version of Opnet. Check which version of Opnet the model is developed for and
try to run on that version of Opnet. This is one bad thing about Opnet.

> -----Original Message-----
> From: Jay J Lee [mailto:[email-masked]]
> Sent: Saturday, 26 July 2003 3:41
> To: [email-masked]; [email-masked]
> Subject: Re: [manet] NIST/AODV Problem
> 
>