Subject: Re: [manet] About changing bandwidth

From: "Mona" <[email-masked]>
Date: Mon, 7 Jul 2003 17:22:07 +0100

Dear Fathi,

I have tried to change this value in ns2. However it seems if I changed it, all the wireless link bandwidths will change.
I want to have different wireless link bandwidths between mobile nodes. Do you have any idea how I can make this scenario? 
Any comment would be appreciated.

Kind Regards, Mona

Date: Mon, 07 Jul 2003 11:59:45 +0200
From: Fethi Filali <[email-masked]>
Organization: INRIA Sophia-Antipolis (http://www.inria.fr)
To: skame <[email-masked]>
CC: [email-masked], [email-masked]
Subject: Re: [manet] About changing bandwidth

skmae,

The default rate in ns2 seems to be 1Mb.

See file ns-2.26/tcl/lan/mac.tcl , u can find the line:

   Mac/802_11 set dataRate_ 1Mb   ;# both control and data pkts

the tcl variable dataRate_ is binded to the c++ variable dataRate_ in 
the mac-802_11.cc file

you can change the default value in mac.tcl and recompiling ns.

Fethi.

skame wrote:
> Hi,all.
> 
> I want to know the way of changing bandwidth.
> The defalut bandwidth in ns2 is 2[Mb/s].
> I suppose 802.11b in maclayer.
> Now bandwidth in 802.11b is 11[Mb/s].
> So I want to change the bandwidth from 2[Mb/s] to 11[Mb/s].
> Please tell me how to change bandwidth.
> 
> Thank you.
> skame
> 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/manet
> 

-----------------------------------------------------------
Mona Ghassemian, PhD student
Centre for Telecommunications Research
Kings College London
Strand, London WC2R 2LS
UK
TEL: +44 20 7848 2596
FAX: +44 20 7848 2664
[email-masked]
[email-masked]

---

From: "Tao Lin" <[email-masked]>
Date: Mon, 7 Jul 2003 12:17:50 -0400

You may set this value according to the end node IDs in ns2.  In this way, you can assign different bandwidths to different links.

 Tao Lin
 PhD Candidate
 ECE Dept.
 Virginia Tech

  ----- Original Message ----- 
  From: Mona 
  To: [email-masked] 
  Cc: [email-masked] 
  Sent: Monday, July 07, 2003 12:22 PM
  Subject: Re: [manet] About changing bandwidth

  Dear Fathi,

  Kind Regards, Mona

  skmae,

  Fethi.