Subject: [manet] Help!!...Glomosim installation on LINUX

From: ruchir sinha <[email-masked]>
Date: Sat, 19 Jul 2003 09:14:11 -0700 (PDT)

Hi,
    I am new to LINUX and Glomosim....and having
problems with Glomosim Installation on LINUX..
      I followed the following steps.....

       After unzipping and doing an untar ( which was
successfully done) i did the following 
-------------------------------------------------------------------------------------------------------------------------------------------
bash-2.05b$ pwd
/ruchir/glomosim-2.03/glomosim/main
bash-2.05b$ setenv PCC_DIRECTORY
/ruchir/glomosim-2.03/parsec/redhat-7.2
bash: setenv: command not found
bash-2.05b$

As you can see i got this error message.....
-------------------------------------------------------------------------------------------------------------------------------------------
I then searched on google and found the following
information about setenv...

Setenv is C shell. Red Hat defaults to the Bash
> shell.
> 
> The Bash equivalent of the C shell
> 
> setenv VARIABLE value
> 
> is
> 
> export VARIABLE=value
> 
> or
> 
> VARIABLE=value; export VARIABLE
> 
> the latter being more portable as it will also work
> in the older Bourne
> shell. Either will also work in the K shell.
> 
> Both the csh setenv and the sh/bash/ksh export are
> built in commands, so
> they do not have associated binaries. The setenv man
> page you found is,
> as "karlp" pointed out, for the subroutine for use
> in programs. Shell
> builtins are documented in the man pages for the
> shells themselves (e.g.
> "man bash").
--------------------------------------------------------------------------------------------------------------------------------------------
So I tried export and this is what i got......

bash-2.05b$ pwd
/ruchir
bash-2.05b$ export
PCC_DIRECTORY=/ruchir/glomosim-2.03/redhat-7.2
bash-2.05b$ pwd
/ruchir
bash-2.05b$ cd glomosim-2.03
bash-2.05b$ cd glomosim
bash-2.05b$ cd main
bash-2.05b$ pwd
/ruchir/glomosim-2.03/glomosim/main
bash-2.05b$ make
pcc -g -O3 -I../include/ -I../transport
-I../transport/tcp -I../application -I../mac -I../main
-I../network -I../radio -clock longlong -lm -c
../main/glomo.pc
make: pcc: Command not found
make: *** [../main/glomo.o] Error 127
bash-2.05b$
--------------------------------------------------------------------------------------------------------------------------------------

I then copied the files parsecc and pcc from      

/ruchir/glomosim-2.03/glomosim/parsec/redhat-7.2   to
/ruchir/glomosim-2.03/glomosim/main

and tried a make again ( from main) but did not work(
same error message as above..

Can anyone help me out......

Regards
Ruchir

__________________________________
Do you Yahoo!?
SBC Yahoo! DSL - Now only $29.95 per month!
http://sbc.yahoo.com

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Anshul Gupta <[email-masked]>
Date: 20 Jul 2003 02:50:24 +1000

setenv works only in C shell.

Do "export PCC_DIRECTORY=value" before you type any command.

On Sun, 2003-07-20 at 02:14, ruchir sinha wrote:
> .../main/glomo.pc
-- 
Anshul Gupta <[email-masked]>