Subject: [manet] AODV and packet delivery ratio

From: Lamia Romdhani <[email-masked]>
Date: Tue, 22 Jul 2003 10:43:34 +0200

Hi ,
 I 'm doing some simulations on AODV protocol. I use ns-2.1b9a version 
that contains the same files of aodv code online in
 
 http://www.cs.sunysb.edu/~mahesh/aodv/
 
 I get a low delivery fraction (%) with AODV when I use 20 or 30 node 
 sources, about 55 %
 and 45 %, but with 10 sources I get 90 %. The causes are due to Drop IFQ 
 and Drop route.
 However, in  "Energy-Aware On-demand Routing for mobile Ad Hoc 
 Networks"paper, the results are greater than 80% even for 20 or 30 sources.
 Is there any modifications that I should add in that code to get the 
 same results.
 i'm waiting for  any suggestions.
 Thank you.
 Lamia.
 PhD student.

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Ash Mohammad Abbas <[email-masked]>
Date: Tue, 22 Jul 2003 12:55:42 +0100 (BST)

This depends on how many runs you are having. If you
keep no. of runs equal to 1, delivery ratio might be
lower, but it may not a correct simulation result. For
averaging purposes one should have around 10 runs for
a single point.
Wish you best,
Abbas
http://www.cse.iitd.ernet.in/~abbas

>  i'm waiting for  any suggestions.

________________________________________________________________________
Send free SMS using the Yahoo! Messenger. Go to http://in.mobile.yahoo.com/new/pc/

---

From: Lamia Romdhani <[email-masked]>
Date: Tue, 22 Jul 2003 17:00:10 +0200

Thank you for your response,
Of course the results that I have are the average of 10 runs.

---

From: Elizabeth Belding-Royer <[email-masked]>
Date: 22 Jul 2003 12:58:13 -0700

I recommend you use the AODV-UU NS-2 code for simulating AODV.
The code you are using is a bit outdated (though that doesn't
really explain why your results are so poor).

The AODV_UU code can be found on the AODV website:
http://moment.cs.ucsb.edu/AODV

Elizabeth