Subject: [manet] Where to put on-demand routing protocol

From: Young-Jun Lee <[email-masked]>
Date: Fri, 11 Jul 2003 15:28:20 -0400 (EDT)

All,

In the INFOCOM paper 'Performance comparison of two on-demand routing
protocols for ad hoc networks' (S. Das, C. Perkins, and E. Royer),
the simulation model section says

"The routing model sees all data packets transmitted or forwarded, and
responds by invoking routing activities as appropriate".

Does it mean that on-demand routing protocol like AODV is between L3
and L4, or somewhere else?
Where exactly can on-demand protocols be in the protocol stack?

Young

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Ash Mohammad Abbas <[email-masked]>
Date: Tue, 15 Jul 2003 06:33:16 +0100 (BST)

Sir,
Irrespective of the fact that a protocol is on-demand or pro-active, a routing protocol will remain layer-3( Network Layer of OSI model) protocol. After a route has been established, ofcourse, the protocol might be used to send data packets.
With best regards,
Ash Mohammad Abbas
http://www.cse.iitd.ernet.in/~abbas
  Young-Jun Lee &lt;[email-masked]&gt; wrote: All,

Young

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet
SMS using the Yahoo! Messenger;Download latest version.

---

From: "Youngmin Kim" <[email-masked]>
Date: Tue, 15 Jul 2003 19:23:29 +0900

I know that forwarding is separated from routing in wired network.
Then.. why is not so in adhoc network? 
 
Thanks..

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Ash Mohammad Abbas
Sent: Tuesday, July 15, 2003 2:33 PM
To: Young-Jun Lee; [email-masked]
Subject: Re: [manet] Where to put on-demand routing protocol
 
Sir, 
Irrespective of the fact that a protocol is on-demand or pro-active, a
routing protocol will remain layer-3( Network Layer of OSI model)
protocol. After a route has been established, ofcourse, the protocol
might be used to send data packets. 
With best regards, 
Ash Mohammad Abbas 
http://www.cse.iitd.ernet.in/~abbas 
  Young-Jun Lee &lt;[email-masked]&gt; wrote: 
All,

Young

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet
 Yahoo! India Mobile <http://in.yimg.com/i/in/mobile/pctomob.gif>
<http://in.mobile.yahoo.com/new/pc/> SMS using the Yahoo!
<http://in.mobile.yahoo.com/new/pc/> Messenger; Download
<http://in.messenger.yahoo.com/>  latest version.