Subject: [manet] MANET real time applications

From: "reham elmayet" <[email-masked]>
Date: Thu, 24 Jul 2003 11:28:17 +0000

hi all,

I want to know what'sa the real time applications for MANETs.

Also, what's the points for research in this direction.

Regards,

Reham

MSN 8 helps ELIMINATE E-MAIL VIRUSES. Get 2 months FREE*.

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Jitesh Shah <[email-masked]>
Date: Thu, 24 Jul 2003 13:19:55 +0100 (BST)

Hi,

I think such questions should not be addressed to this
group. You may please refer to some basic Manet book
or   on internet for that matter.

Regards
Jitesh

 --- reham elmayet <[email-masked]> wrote: 
---------------------------------
hi all,
I want to know what'sa the real time applications for
MANETs.
Also, what's the points for research in this
direction.
Regards,
Reham

________________________________________________________________________
Send free SMS using the Yahoo! Messenger. Go to http://in.mobile.yahoo.com/new/pc/

---

From: "Manfredi, Albert E" <[email-masked]>
Date: Thu, 24 Jul 2003 12:55:05 -0400

BRIAN McBride wrote:

> I have been doing QoS (ATM, diffserv etc.) for quite 
> sometime, but yet have
> to find a necessary application other than leased lines and 
> simple "real
> time" vs non-real time.  However it does make good research work.

I don't disagree with the skepticism entirely, but voice telephony and even one-way streaming media over non QoS guaranteed nets are proof enough that something is needed that ain't usually there.

The problem with voice telephony over non-QoS IP nets is obvious. What typically happens, especially over long distances, is unacceptable delay, caused by the essential large buffers, and frequent drop-outs. Far, far worse than voice calls used to be over satellite links.

One way streaming media sessions are also frequently affected by buffer starvation and session drop-outs. I usually listen to streaming media during my lunch hour, over a broadband network of course, and the idea that in principle large buffers can easily accommodate non-interactive streaming traffic is simply not always the case. These services are *not* ready for prime time.

> Qos leads to guaranteed Qos that inevitably will lead to a 
> claim that MPLS
> and TE must then be applied to mobile ad-hoc networking ;-).

Yup. Sounds unlikely, I agree.

> The obvious app for real-time to me is voice, but it is my 
> choice of how I
> use the bits I am allocated in the network, the network just 
> needs to offer
> me fair access to the bits.

But that's not enough.

Bert

---

From: [email-masked]
Date: Fri, 25 Jul 2003 12:24:47 -0400

Hi Brian,

I have been studying QoS for MANETs for quite some time now. I feel that QoS is essentially important for MANETs because of the kinds of applications that are projected from them. Most common among them are in the defence sector and disaster relief operations (comemrcial applications are also being developed like an ad hoc network of a group of cars). This implies that MANETs are going to be widely used for voice communications (between soldiers and rescue workers etc). Here, best effort delivery would not work. Simulations show that one new flow can easily influence the existing flows in terms of their end-to-end latency, packet delivery ratio etc. Also in situtations like war some flows WILL be more important that others and it is necessary that nodes are aware of such differentiation. Current TCP/IP model and MAC 802.11 which aim at being fair to all participating nodes wont work here. I think this is sufficient reason to consider QoS as an important
aspect of ad hoc networks.

regards,
Harpreet

----- Original Message -----
From: BRIAN McBride <[email-masked]>
Date: Thursday, July 24, 2003 12:23 pm
Subject: Re: [manet] MANET real time applications

> I have been doing QoS (ATM, diffserv etc.) for quite sometime, but 
> yet have
> to find a necessary application other than leased lines and simple 
> "realtime" vs non-real time.  However it does make good research work.
> 
> I am interested in understanding why QoS is important, separating 
> researchfrom standards development.  Is there some work on the 
> applications of
> ad-hoc networking someone could point me to as a starting point?
> 
> I have my theories and the common ones I think, but do not know of 
> any that
> require QoS other than pure fairness amongst all active users.  
> Seems to me
> the nature of ad-hoc is all are fairly treated, to introduce bias 
> wouldimply some central authority to manage the bias.  I always 
> considered ad-hoc
> in the context of free-roaming, independent, individuals in a network.
> 
> Qos leads to guaranteed Qos that inevitably will lead to a claim 
> that MPLS
> The obvious app for real-time to me is voice, but it is my choice 
> of how I
> use the bits I am allocated in the network, the network just needs 
> to offer
> Thanks,
> Brian McBride
> Jon Zeeff wrote:
> > At 10:03 AM 7/24/2003 -0400, Lawrence MacIntyre wrote:
> > >I would say that the obvious real-time app for wireless is
> > >videoconferencing and the obvious research direction would be 
> providing> >QOS.
> >
> > I agree that real-time video is a demanding application and thus 
> a good
> > test case.  Also that
> > QOS (in it's broadest definition - ie, including multipath 
> routing, fair
> > queuing, non hop-count
> > metric based routing, etc) is needed.
> >