Subject: RE: [manet] Carrier sense threshold/range control

From: "#LI ZHIFEI#" <[email-masked]>
Date: Fri, 11 Jul 2003 16:44:33 +0800

>Also, when SR >= IR + TR, topology 2 (in your previous e-mail) and other
>topologies without obstacles would not suffer from the hidden terminal
>problem (without considering collisions of control messages and
>propagation characteristics/delays etc. of course).

That is true but at the cost of capacity.  Moreover, if SR >= IR + TR, it seems that the RTS/CTS do not have much meaning 
any more. However, as pointed out by some work, whether the SR can be set to greater than (IR + TR) depends upon the antenna's sensitivity.

-----Original Message-----
From: Chi-Hsiang Yeh [mailto:[email-masked]]
Sent: divendres, 11 / juliol / 2003 12:09
To: #LI ZHIFEI#; [email-masked]
Cc: 'Vikram Dham'
Subject: RE: [manet] Carrier sense threshold/range control

Hi, Zhifei,

> > Though we may not be elminating all the hidden terminals but we may 
> >decrease
> >the probability of occurence of hidden terminals by 
> extending sensing range to 
> >2SR.            ????  >2TR
>
> The objective of elminating the hidden terminal problem is to 
> reduce collisions and thus 
> increase the channel utilization. However, if you increase 
> the sensing range, the interfering range is 
> also increased and thus the spatial reuse is greatly reduced. 

This is not true. Besides SR and TR, there is another parameter
"interference range (IR)", which is not necessarily equal to SR. By
lowering the threshold for sensing, increasing SR does not affect IR.
Instead, IR is increased when the associated transmission power level is
increased.

Also, when SR >= IR + TR, topology 2 (in your previous e-mail) and other
topologies without obstacles would not suffer from the hidden terminal
problem (without considering collisions of control messages and
propagation characteristics/delays etc. of course).

Chihsiang

> Of course, if capture is enabled, it may be a different 
> story. However, with capture, fairness becomse worse (which 
> is my main concern). 
> Moreover, as I have mentioned, when the sensing range (SR) is 
> made greater than transmission range (TR), 
> how long a node should defer its transmission when it detects 
> a SR frame is a very difficult job as 
> the node cannot interpret the conent of a SR frame.
> 
> 
> 
> Li zhifei
> 
> 
> -----Original Message-----
> From: Vikram Dham [mailto:[email-masked]]
> Sent: dijous, 10 / juliol / 2003 23:02
> To: #LI ZHIFEI#; manet
> Subject: RE: [manet] Carrier sense threshold/range control
> 
> 
> Hello Zhifei Li,
> 
> Though topology 2 also may have scenarios with hidden 
> terminal, but in a 
> wireless network,
> 
> probability (distance between nodes > 2SR) =< probability 
> (distance between 
> nodes > SR ).
> 
>  Though we may not be elminating all the hidden terminals but 
> we may decrease 
> the probability of occurence of hidden terminals by extending 
> sensing range to 
> 2SR.
> 
> Regards
> 
> Vikram Dham
> >===== Original Message From #LI ZHIFEI# <[email-masked]> 
> >===== Hi, Ram
> >
> >In my view, even the Carrier Sensing Range (SR) is two times of the
> Transmission Range (TR ), the hidden-termianl problem is still there.
> >This can be illustrated as the following two topologies:
> >
> >Topology 1:                                               Topology 2:
> >
> >A -> B <- C                                                A -> B
C<- D
> >
> >(note that the distance between two neighboring nodes are 
> equal to the
> transmission range, i.e., one hop)
> >
> >The first topology is tipycally used to illustrate the well-known
> hidden-terminal problem, but with an implicit assumption, i.e., SR=TR.
> >If SR=2*TR, the hidden-terminal problem seems not exist any more in 
> >this
> topology as the nodes A and C can sense the transmission of 
> each other.
> >
> >However, even SR=2*TR, the problem will arise in the second topology.
> Specically, when node A starts to transmit to node B, since node D
> >is out of the SR of node A, it cannot detect the transmission. 
> >Therefore,
> node D may also start to transmit to node C, resulting in 
> collision (or 
> capture).
> >In such case, we can say that nodes A and D are hidden 
> terminal of each
> other. We do find the similarities of the performance between 
> the two cases:
> >topology 1 when SR=TR; and topology 2 when SR=2*TR
> >
> >
> >When SR>TR, another problem is that how a node should defer its 
> >transmission
> when it detects a SR frame. This is not an easy job since the 
> node cannot
> >interpret the content of the SR frame. In the IEEE 802.11, 
> whenever a 
> >node
> detects a SR frame, it will defer by a fixed EFIS value. 
> However, our results 
> show
> >this fixed value will cause many problems, e.g., unfairness. 
> Moreover, 
> >the
> capture ability will also greatly affect the performace when SR>TR.
> >For a detailed descrition of these issues, please refer to 
> the attached
> references:
> >
> >Zhifei Li, Sukumar Nandi, Anil K. Gupta,
> >"Improving Fairness in IEEE 802.11 based MANETs using 
> Enhanced Carrier
> Sensing", submitted to conference, April 2003
> >http://www.ntu.edu.sg/home5/pg03802331/papers/ecs.pdf
> >
> >
> >Zhifei Li, Sukumar Nandi, Anil K. Gupta,
> >"Study of IEEE 802.11 Fairness and its Interaction with Routing 
> >Mechanism",
> accepted by IEEE MWCN 2003 Singapore, May 2003
> >http://www.ntu.edu.sg/home5/pg03802331/papers/mwcn03.pdf
> >
> >
> >Though the above papers mainly focus on the the fairness issue when 
> >SR>TR,
> the descirtion should also apply to the analysis of the 
> channel utilization.
> >I hope that they will  relate to your work and help you.
> >
> >
> >Best regards
> >Li ZhiFei
> >PhD candidate,
> >Center For Multimedia And Network Technology
> >School Of Computer Engineering
> >Nanyang Technological University
> >N4-b2c-08, Nanyang Avenue
> >Singapore 639798
> >tel:(65)67906579
> >website: <http://www.ntu.edu.sg/home5/pg03802331>
> >
> >
> >-----Original Message-----
> >From: Ram Ramanathan [mailto:[email-masked]]
> >Sent: dijous, 10 / juliol / 2003 00:09
> >To: [email-masked]
> >Cc: [email-masked]
> >Subject: [manet] Carrier sense threshold/range control
> >
> >
> >
> >I am looking for pointers to research on the control of 
> carrier sensing 
> >range in lieu of using RTS/CTS to address the hidden node problem?
> >
> >To elaborate, the threshold for when carrier is declared to 
> be "sensed" 
> >can be adjusted in many radios. Using this facility, one 
> could possibly 
> >make the "carrier sense range" approximately twice the 
> "communication 
> >range" (successful packet reception), and detect hidden nodes.
> >
> >This is by no means a new idea, and I vaguely recally some 
> mention of 
> >it on this list. Of course, there are a number of factors 
> that make the 
> >problem far more complex than the simple statement above 
> indicates, and 
> >it is not immediately clear whether it will be effective at all.
> >
> >I am looking for papers, tech reports, or any publicly available 
> >material
> >(non-proprietary) on this issue.
> >
> >Many thanks in advance,
> >
> >-Ram.
> >
> >_______________________________________________
> >manet mailing list
> >[email-masked]
> >https://www1.ietf.org/mailman/listinfo/manet
> >
> >
> >
> >
> >_______________________________________________
> >manet mailing list
> >[email-masked]
> >https://www1.ietf.org/mailman/listinfo/manet
> 
> 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/manet
> 
> 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/manet
> 

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Chi-Hsiang Yeh" <[email-masked]>
Date: Fri, 11 Jul 2003 12:36:16 -0400

> From: #LI ZHIFEI# [mailto:[email-masked]] 
> Sent: Friday, July 11, 2003 4:45 AM
> To: Chi-Hsiang Yeh
> Cc: [email-masked]
> >Also, when SR >= IR + TR, topology 2 (in your previous e-mail) and 
> >other topologies without obstacles would not suffer from the hidden 
> >terminal problem (without considering collisions of control messages 
> >and propagation characteristics/delays etc. of course).
> 
> That is true but at the cost of capacity.  Moreover, if SR >= 
> IR + TR, it seems that the RTS/CTS do not have much meaning 
> any more. 

You are right, for free space. For indoor environments, strategies using
large SR alone do not work well due to obstacles. If anyone has or know
experiements on this issue (indoor + large SR), I'll appreciate it if
you could give me a pointer.

> However, as pointed out by some work, whether the 
> SR can be set to greater than (IR + TR) depends upon the 
> antenna's sensitivity.

You are right. And it also depends on path loss etc. There is always a
limit on SR, and in reality it may not be easy to know these parameter
values directly or to make SR=IR+TR.

Chihsiang

> This is not true. Besides SR and TR, there is another 
> parameter "interference range (IR)", which is not necessarily 
> equal to SR. By lowering the threshold for sensing, 
> increasing SR does not affect IR. Instead, IR is increased 
> when the associated transmission power level is increased.
> 
> Also, when SR >= IR + TR, topology 2 (in your previous 
> e-mail) and other topologies without obstacles would not 
> suffer from the hidden terminal problem (without considering 
> collisions of control messages and propagation 
> characteristics/delays etc. of course).
> 
> Chihsiang
> 
> > >Topology 1:                                               
> Topology 2:

---

From: "Alaa Muqattash" <[email-masked]>
Date: Fri, 11 Jul 2003 09:54:55 -0700

Could you please explain what do you mean by the "interference range"? I
don't think that this range is fixed. Instead, it depends on:

1- The transmission power
2- The channel gain between the transmitter & receiver
3- The minimum SNR threshold required for reliable communication

For example, fixing all other parameters, if the required SNR is increased,
then your interference range is increased.

Any thoughts?

regards,
Alaa

---

From: "John Mullen" <[email-masked]>
Date: Fri, 11 Jul 2003 11:49:37 -0600

Hi Alaa,

As I use it, the IR is the distance at which a transmitted signal from a
terminal interferes with that of another at the receiver.  You are
correct in that the distance is not fixed.  If A is sending to B in the
presence of a signal from C, whether or not B can successfully decode
A's transmission depends on the signal strength from A, that from C, and
the noise level at B.

A simple approximation is to treat the transmission from C as noise and
to look at the ratio of SN(A) / [SN(C)+N].  However, this is inexact.
Because C's signal is actually a valid transmission, it would be more
difficult for the receiver to ignore. (I'm assuming C is using the same
channel, waveform, etc. as A and B).

To illustrate, if you had a signal from C that was just marginally
rejectable by B, reducing A's signal strength, by any means, e.g.
antenna gain, distance, xmitter power, etc., would cause that signal to
cause a data collision at B.  On the other hand, if the signal from A
increases, then that of C would become less and less significant.

I think most people consider the IR to that which would cause
interference at an extreme A-B range, but this is misleading in that
when A&B are closer, the interference source can also be closer without
causing difficulty.

John Mullen

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Alaa Muqattash
Sent: Friday, July 11, 2003 9:55 AM
To: Chi-Hsiang Yeh; '#LI ZHIFEI#'
Cc: [email-masked]
Subject: Re: [manet] Carrier sense threshold/range control

For example, fixing all other parameters, if the required SNR is
increased, then your interference range is increased.

Any thoughts?

regards,
Alaa
----- Original Message -----
From: "Chi-Hsiang Yeh" <[email-masked]>
To: "'#LI ZHIFEI#'" <[email-masked]>
Cc: <[email-masked]>
Sent: Friday, July 11, 2003 9:36 AM
Subject: RE: [manet] Carrier sense threshold/range control

> > >terminal problem (without considering collisions of control 
> > >messages and propagation characteristics/delays etc. of course).
> >
> > That is true but at the cost of capacity.  Moreover, if SR >= IR + 
> > TR, it seems that the RTS/CTS do not have much meaning any more.
>
> You are right, for free space. For indoor environments, strategies 
> using large SR alone do not work well due to obstacles. If anyone has 
> or know experiements on this issue (indoor + large SR), I'll 
> appreciate it if you could give me a pointer.
>
> > SR can be set to greater than (IR + TR) depends upon the antenna's 
> > sensitivity.
>

> > > reduce collisions and thus increase the channel utilization. 
> > > However, if you increase the sensing range, the interfering range 
> > > is also increased and thus the spatial reuse is greatly reduced.
> >
> > lowering the threshold for sensing, increasing SR does not affect 
> > IR. Instead, IR is increased when the associated transmission power 
> > level is increased.
> >
> > e-mail) and other topologies without obstacles would not suffer from

> > the hidden terminal problem (without considering collisions of 
> > control messages and propagation characteristics/delays etc. of 
> > course).
> >
> > Chihsiang
> >
> > > Of course, if capture is enabled, it may be a different story. 
> > > However, with capture, fairness becomse worse (which is my main 
> > > concern). Moreover, as I have mentioned, when the sensing range 
> > > (SR) is made greater than transmission range (TR),
> > > Though topology 2 also may have scenarios with hidden terminal, 
> > > but in a wireless network,
> > >
> > > (distance between nodes > SR ).
> > >
> > >  Though we may not be elminating all the hidden terminals but we 
> > > may decrease the probability of occurence of hidden terminals by 
> > > >===== Original Message From #LI ZHIFEI# 
> > > ><[email-masked]> ===== Hi, Ram
> > > >
> > > >If SR=2*TR, the hidden-terminal problem seems not exist any more 
> > > >in this
> > > topology as the nodes A and C can sense the transmission of each 
> > > other.
> > > >
> > > collision (or capture).
> > > other. We do find the similarities of the performance between the 
> > > two cases:
> > > when it detects a SR frame. This is not an easy job since the node

> > > cannot
> > > detects a SR frame, it will defer by a fixed EFIS value. However, 
> > > our results show
> > > the descirtion should also apply to the analysis of the channel 
> > > utilization.
> > > >[email-masked] https://www1.ietf.org/mailman/listinfo/manet
> > > >
> > > >
> > > >
> > > >
> > > >[email-masked] https://www1.ietf.org/mailman/listinfo/manet
> > >
> > >
> > > [email-masked] https://www1.ietf.org/mailman/listinfo/manet
> > >
> > >

---

From: "Chi-Hsiang Yeh" <[email-masked]>
Date: Fri, 11 Jul 2003 16:31:04 -0400

Hi, Alaa,

The Globecom'02 paper of Xu, Gerla, and Bae defined interference range
as
 "the range within which stations in receive mode will be "interfered
with" by an unrelated transmitter and thus suffer a loss."

This paper assumes that wireless stations are transmitting at a fixed
power level, using the same modulation etc...

I myself usually assume that there is a minimum interference threshold
every receiver needs to be able to tolerate, where the resultant
collision probability is sufficiently small when the cumulative
interference is smaller than that threshold. If you have lower gain or
need higher SINR, the associated transmitter needs to transmit at a
power level that is sufficiently high. I call a related parameter
"maximum interfered range". This value is fixed for a certain
transmission, but different transmissions have different values. For a
receiver, there is another parameter "maximum interfering range". My
protocols need them to determine the power levels for transmitting RTS
and CTS messages respectively.

You may also look at 

J. L. Sobrinho and A. S. Krishnakumar, "Quality-of-Service in ad hoc
carrier sense multiple access networks," IEEE Journal on Selected Areas
in Communications, 17(8), August 1999, pp. 1353-1368.

Regards,

Chihsiang

> From: Alaa Muqattash [mailto:[email-masked]] 
> Sent: Friday, July 11, 2003 12:55 PM
> Could you please explain what do you mean by the 
> "interference range"? I don't think that this range is fixed. 
> Instead, it depends on:
> 
> For example, fixing all other parameters, if the required SNR 
> is increased, then your interference range is increased.
> 
> Any thoughts?
> 
> regards,
> Alaa
> e-mail) and 
> antenna's 
> suffer from 
> > > > >In my view, even the Carrier Sensing Range (SR) is two 
> times of 
> > > > >the
> > > > >A -> B <- C                                            
>     A -> B