Subject: [manet] Glomosim

From: Siddharth Ray <[email-masked]>
Date: Fri, 11 Jul 2003 07:23:49 -0700 (PDT)

Hi Markus,
Well, I wanted to clarify something about glomosim. I
have heard that glomosim is not supported and hence,
there are a lot of bugs in it. The papers which I have
gone through in ACM etc, none of them have used
glomosim for simulation. I have a friend in UCBerkely
who says that glomosim can be used when people are
just starting to learn simulation but cannot be really
used for some serious simulations. Can anybody clarify
this for me.
Thanks,
Siddharth

=====
"Keep me away from the wisdom which does not cry, the philosophy which does not laugh and the greatness which
does not bow before children."
- Kahlil Gibran

MS, Department of Computer Sc. & Engg,
Pond Lab, State College,
PA - 16802, USA.
http://www.cse.psu.edu/~sray

__________________________________
Do you Yahoo!?
SBC Yahoo! DSL - Now only $29.95 per month!
http://sbc.yahoo.com

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Sonny Rajagopalan <[email-masked]>
Date: Fri, 11 Jul 2003 15:21:49 -0400 (EDT)

> used for some serious simulations. Can anybody clarify

That is definitely untrue. GlomoSim can be, and indeed is being, used for
very serious simulations. In my view, given a choice between the use of
Glomosim and NS2, I would much rather use GlomoSim -- some people in the
community feel NS-2's MAC layer and below are too simplistic.

Cheers,
Sonny.
----
>From the desk of Sonny Rajagopalan @ http://www.cis.udel.edu/~rajagopa
                                                                  ----

---

From: Manoj K Pandey <[email-masked]>
Date: Fri, 11 Jul 2003 12:31:02 -0700 (PDT)

just to add to what Sonny said:
the design of radio and mobility layers are really nice in glomosim.

also, there are lot of publications based on glomosim simulations...
you could go to citeseer and search glomosim... the list
is pretty big... including papers from Infocom!

and finally, it can be tuned for parallel simulation
based on multiple partitioning of the field size [using the underlying
parsec platform].

thnx
manoj

******************************
Manoj Pandey, PhD student,
#226, Deschutes, Computer and Information Science,
University of Oregon, Phone# 541-346-1381 [Office],
www.cs.uoregon.edu/~manoj
******************************

---

From: Young-Jun Lee <[email-masked]>
Date: Fri, 11 Jul 2003 15:40:42 -0400 (EDT)

What about the scalability?
Is it reasonal to do simulation using Glomosim for a large scale
ad hoc network with a size of a few hundred or one thousand?