Subject: [manet] (no subject)

From: [email-masked]
Date: Tue, 15 Jul 2003 17:10:10 +0200

Le Tue, 15 Jul 2003 06:40:46 -0700 (PDT)
Jaehoon Jeong a écrit:

> You are right. The sentence should be corrected as
> follows;
>  whose virtual address are the same that in its cache
> ->     ^^^^^^^^^^^^^^^
>       ~ IP address are the same ~
>        

Yes! But in this case, I have still a problem. Let suppose a node leaves
sudently the network.
Its IP address can be re-aloted to another node. However the key this node will
choose will probably be different
from the key that will be associated with its address in routing table of other
nodes, because those routing table or cache will not have been updated since the
node is not aware of the re-alocation of the adress.
Consequently, if a node leaves the network sudently, I think its address can not
be re-used.

Is this right?
Thank you for your preceding answer.

Cordially, Jean-Marie Orset

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Ash Mohammad Abbas <[email-masked]>
Date: Wed, 16 Jul 2003 05:49:23 +0100 (BST)

If a node leaves suddenly, we should not worry about the reuse of its IP address. The incoming node should be assignrd an IP address, which is not currenly in use by other (remaining) active nodes. Let the incoming node chhose a different key ( or the same key which is left by the leaving node ). This will be a simpler solution. I aggree that some of the IP addresses may not be used. Can we not have number of IP addresses more than number of participating nodes. If not in IPv4, then IPv6 addresses ( there is a huge amount of addresses ).
Wish you best,
Ash Mohammad Abbas
http://www.cse.iitd.ernet.in/~abbas 

[email-masked] wrote:

Is this right?

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet
SMS using the Yahoo! Messenger;Download latest version.

---

From: Jaehoon Jeong <[email-masked]>
Date: Tue, 15 Jul 2003 23:10:25 -0700 (PDT)

--- Ash Mohammad Abbas <[email-masked]>
wrote:
> If a node leaves suddenly, we should not worry about
> the reuse of its IP address. The incoming node
> should be assignrd an IP address, which is not
> currenly in use by other (remaining) active nodes.
> Let the incoming node choose a different key ( or
> the same key which is left by the leaving node ).
> This will be a simpler solution. I aggree that some
> of the IP addresses may not be used. Can we not have
> number of IP addresses more than number of
> participating nodes. If not in IPv4, then IPv6
> addresses ( there is a huge amount of addresses ).

IMHO, For IPv4, it is valuable to consider the reuse
of IP addresses further.
Thanks for your opinion.

/Jaehoon Paul

> Jaehoon Jeong a ?rit:

__________________________________
Do you Yahoo!?
SBC Yahoo! DSL - Now only $29.95 per month!
http://sbc.yahoo.com