Subject: Re: [Re] [manet] Re: Ad Hoc IP Address Autoconfiguration

From: "Jaehoon Jeong" <[email-masked]>
Date: Sat, 5 Jul 2003 09:59:53 +0900

Hi, Jean-Marie.

----- Original Message ----- 
From: "Jean-Marie ORSET" <[email-masked]>
To: <[email-masked]>
Sent: Friday, July 04, 2003 6:01 PM
Subject: Re: [Re] [manet] Re: Ad Hoc IP Address Autoconfiguration

> 
> Le Fri, 4 Jul 2003 17:14:39 +0900 
> [email-masked] a écrit:
> 
> 
> > 1)Doesn't The fact that a node chooses randomly its address affect the 
> > hierarchical aspect of IP adressing? 
> > Because there is no more relation between the ip address of a node and the 
> > network it belongs to. 
> > 
> >   -> No, my addressing scheme is only for ad hoc network, 
> >       using /64 IPV6_MANET_PREFIX, which usually has flat architecture.
> 
> In fact, I wanted to say within the same ad hoc network.
> Broadcasts in Ad Hoc networks are quiet expensive and we could consider that there should sometimes be several subnet
> forming the ad hoc network. Then a node could wish, for an unspecified reason, to broadcast just to a limited subnet.
> But I know that allocation of IP address while taking into account some possible subnets wouls be very difficult.
> 

The subnet in MANET is very difficult problem, I think.
If a group of mobile nodes move together, the subnet in MANET may be possible.

> 
> 
> > 2) What happens when 2 networks of 100 nodes or more, each one, merge to
> > form a 
> > new network? 
> > I suppose that all nodes of both networks must reconfigure their IP
> > address. 
> > This will result in a lot of control traffic in the both?
> 
> >   -> There is no control traffic's storm, 
> >       because the check of address duplication is performed in routing
> > level.
> 
> Mhh, I suppose that i any event we can not prevent increase of the overhead.
> 

Yeah, there may be some overhead, not much overhead.
If there are many address duplications, there will be much control traffic.

> 
> 
> > 3) For security reasons, couldn't we consider that a node join a public key
> > with 
> > its request:
> > 
> >   ->  Of course not, we can consider it.
> >  
> > 
> >     a) The node sends AREQ and join its public key 
> >     b) The direct neighbours send him a "challenge", i mean a nonce
> > ciphered with the 
> > public key at witch the node should answer by increasing it, in order to
> > verify 
> > that it is really the owner of the key 
> >     c) The node answers and only if this is correct, the neighbours
> > accept to forward 
> > the request. if not, the request is discarded.
> > Thus, we could avoid the Denial of service attack which would consist to
> > always 
> > send AREQ through the network, in order to flood it with control packets. 
> > Moreover the public key could then be used to sign the messages.
> > 
> > 
> >    -> Good suggestion! 
> >        I think your idea is a useful way of announcing its own public key
> > to other nodes.
> >        In my draft, WEAK DAD needs a key for differentiating duplicate
> > addressses.
> >        The key can be a public key of the node.
> >        During STRONG DAD, the annoucement of public key can be useful 
> >        in the authentication and digital signature.
> 
> Thanks, but unfortunately, we will have then to solve the problem of very expensive cost of public key techniques.
> but this is another problem...
> 

I agree with you that the public cryptography is very expensive, especially in MANET.
In my scheme, a key is used for identifying the address duplication. 
So, key's uniqueness is important.
In order to guarantee the uniqueness of public key, 
We should use a certificate for a public key?
How about?

/Jaehoon

> Cordially, Jean-Marie Orset
> &jw™¨¥Šx%ŠËfjw‰ë_¢¸!¶Úlÿü0ÃXžµú+ƒùšŠYšŸùb²Ø§~æjw

---

From: "Jaehoon Jeong" <[email-masked]>
Date: Tue, 8 Jul 2003 18:03:18 +0900

Hi, Jean-Marie.

----- Original Message ----- 
From: "Jean-Marie ORSET" <[email-masked]>
To: "Jaehoon Jeong" <[email-masked]>
Sent: Tuesday, July 08, 2003 1:32 AM
Subject: Re: [Re] [manet] Re: Ad Hoc IP Address Autoconfiguration

> 
> Le Sat, 5 Jul 2003 09:59:53 +0900
> Jaehoon Jeong a écrit:
> 
> Yes, a certificate seems to be essential while using public key cryptography.
> In fact, the problem is who will be used to certificate the key, since we can not emply centralized certification authotity? Zhou and Haas did write a very good paper on the distribution of trust in Manet. The schemes could
> be used complementary.

   Could you tell me the URL of the paper?

> However, even if it is important to guarantee the non address duplication
> I'm not sure public key cryptography could be used to sign each packet.
>
   That will need more discussion, I think.
   Anyway, I hope  this manet wg meeting starts to discuss ad hoc address autoconfiguration.
   Thanks.

   /Jaehoon

> 	šëfj)bž	b²Ùšëbz×è®m¶›?ÿ0Ö'~Šàþf¢–f§þX¬¶)ß£ùšë

---

From: Kilian Weniger <[email-masked]>
Date: Tue, 15 Jul 2003 12:02:49 +0200

Hi Jaehoon,

we are also working on Duplicate Address Detection in mobile ad hoc networks. 

In our approach, which is called "Passive Duplicate Address Detection" (PDAD) 
and which was presented at IEEE WCNC, New Orleans, March 2003 (K.Weniger, 
"Passive Duplicate Address Detection in Mobile Ad Hoc Networks"), all nodes 
continuously monitor the routing protocol traffic and seeks for anomalies in 
order to find duplicate addresses in the network. Thus, PDAD supports network 
partitioning and merging as Weak DAD does.

One advantage of our approach is, that it does not consume any additional 
protocol overhead (as WDAD does: one keys for each address). Another 
advantage is, that the routing protocol message format does not need to be 
modified (as it is for WDAD). Thus, it is even possible to use existing 
routing protocol implementations, e.g. by implementing PDAD as a linux 
netfilter module (we are currently working on that).

We have done detailed simulations using PDAD with FSR and OLSR. For each of 
these protocols, a combination of schemes was able to resolve all conflicts. 
The results will be published soon. Since the publication mentioned above 
only discusses proactive link state routing protocols, support for reactive 
routing protocols is another issue we are currently working on.

Summarizing, PDAD could also be an option for your draft, in addition or as an 
alternative to WDAD.

Regards,

Kilian Weniger

> > > I agree with you that the public cryptography is very expensive,
 In my scheme, a key is used for identifying the
> > > address duplication. So, key's uniqueness is important.
 In fact, the problem is who will be used to certificate
> > the key, since we can not emply centralized certification authotity? Zhou
> > and Haas did write a very good paper on the distribution of trust in
> > Manet. The schemes could be used complementary.
>
> 
 I'm not sure public key cryptography could be used to sign
> > each packet. 
 Thanks.

-- 
Dipl.-Ing. Kilian Weniger	
Institute of Telematics, Universitaet Karlsruhe (TH)
Zirkel 2, 76128 Karlsruhe, Germany
Phone: +49 721 608 6415, Fax: +49 721 388097
Email: [email-masked], HP: http://www.tm.uka.de/~weniger

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Jaehoon Jeong <[email-masked]>
Date: Tue, 15 Jul 2003 05:35:30 -0700 (PDT)

Hi Kilian,
I welcome your suggestion.
Would you show me the link of your paper?
After reading your paper, I am going to think over how
to include your idea in my draft.
In tomorrow manet meeting, the most important is that
Ad Hoc IP Addressing should be selected as a new manet
item. I only reinitiates the issue after Charlie. I
need many comments from manet guys including you and
Charlie. 
I would like to make a good ad hoc address
autoconfiguration scheme with others.
Thanks.

/Jaehoon Paul

--- Kilian Weniger <[email-masked]> wrote:
> > > Jaehoon Jeong a ?rit:
> > > > I agree with you that the public cryptography
> is very expensive,
> > > > especially in MANET.
 In my scheme, a key is
> used for identifying the
> > > Yes, a certificate seems to be essential while
> using public key
> > > cryptography.
 In fact, the problem is who will
> be used to certificate
> > > However, even if it is important to guarantee
> the non address
> > > duplication
 I'm not sure public key
> cryptography could be used to sign
> > > each packet. 
> >
> >    Anyway, I hope  this manet wg meeting starts to
> discuss ad hoc address
> > autoconfiguration.
 Thanks.
> > > Cordially, Jean-Marie Orset

__________________________________
Do you Yahoo!?
SBC Yahoo! DSL - Now only $29.95 per month!
http://sbc.yahoo.com