Subject: RE: [manet] Re: Carrier sense threshold/range control

From: "#LI ZHIFEI#" <[email-masked]>
Date: Fri, 11 Jul 2003 10:12:24 +0800

hi, prof. Nitin

> If B and C above were closer though, one could conceive
>a bit smarter MAC -- for instance, if C hears the RTS received
>by B from A, then C can overlap its RTS with the CTS it expects B to
>send to A. Too complex for this time of the day ...

The problem for me is as follows:

If node C can overhear the transmission of the RTS from node A to node B,  then, any transmission from 
node C will interfere the frame reception at node A.  Of course, we hold the symmetry assumption. 

So how could the transmission of RTS (from C) and the transmission of CTS (from B ) can overlap?

li zhifei

-----Original Message-----
From: Nitin H. Vaidya [mailto:[email-masked]]
Sent: dijous, 10 / juliol / 2003 07:40
To: Alaa Muqattash
Cc: MANET mailing list
Subject: Re: [manet] Re: Carrier sense threshold/range control

On Wed, 9 Jul 2003, Alaa Muqattash wrote:

.  >>----- Original Message -----
.  >>
.  >>> The gains could be much more interesting in the scenario below, which
.  >>> simply reverses directions of the data transmissions (provided that
.  >>> A does not pose too much interference at C, and D at B).
.  >>>
.  >>>    A --------> B         C <----------- D
.  >>>
.  >>> - nitin
.  >>
.  >>
.  >>This is exactly what PCMA  and PCDC do (see reference below); they allow

Not quite the same as PCMA ... since the basic RTS/CTS mechanisms
do not explicitly look at SNR, unlike PCMA.

In any case, I think I got the example wrong in that it may not
be any more interesting than the example with the flows in opposite
directions. If B and C above were closer though, one could conceive
a bit smarter MAC -- for instance, if C hears the RTS received
by B from A, then C can overlap its RTS with the CTS it expects B to
send to A. Too complex for this time of the day ...

- nitin

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Chi-Hsiang Yeh" <[email-masked]>
Date: Fri, 11 Jul 2003 02:51:41 -0400

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of #LI ZHIFEI#
> Sent: Thursday, July 10, 2003 10:12 PM
> To: Nitin H. Vaidya
> Cc: [email-masked]
> Subject: RE: [manet] Re: Carrier sense threshold/range control
> 
> 
> hi, prof. Nitin
> 
> 
> >a bit smarter MAC -- for instance, if C hears the RTS received by B 
> >from A, then C can overlap its RTS with the CTS it expects B 
> to send to 
> >A. Too complex for this time of the day ...
> 
> So how could the transmission of RTS (from C) and the 
> transmission of CTS (from B ) can overlap?

Another problem: When C is close to B and C is really a transmitter
(rather than being mistaken due to typos in the original e-mail), the
data reception at B will be collided by the data transmission from C
even if the above dialogues work due to capture.

Chihsiang

> .  >>> The gains could be much more interesting in the 
> scenario below, which .  >>> simply reverses directions of 
> the data transmissions (provided that .  >>> A does not pose 
> too much interference at C, and D at B). .  >>>
> Not quite the same as PCMA ... since the basic RTS/CTS 
> mechanisms do not explicitly look at SNR, unlike PCMA.
> 
> In any case, I think I got the example wrong in that it may 
> not be any more interesting than the example with the flows 
> in opposite directions. If B and C above were closer though, 
> one could conceive a bit smarter MAC -- for instance, if C 
> hears the RTS received by B from A, then C can overlap its 
> RTS with the CTS it expects B to send to A. Too complex for 
> this time of the day ...
> 
> - nitin
> 
>