Subject: [manet] Re: Ad Hoc IP Address Autoconfiguration

From: [email-masked]
Date: Thu, 3 Jul 2003 14:20:38 +0200

Hi, i've just read your draft and i find it very interesting. However, i wonder
myself some questions:

1)Doesn't The fact that a node chooses randomly its address affect the
hierarchical aspect of IP adressing?
Because there is no more relation between the ip address of a node and the
network it belongs to.
Then if a node have to perform a broadcast it is obliged of flood the entire
network.

2) What happens when 2 networks of 100 nodes or more, each one, merge to form a
new network?
I suppose that all nodes of both networks must reconfigure their IP address.
This will result in 
a lot of control traffic in the both?

3) For security reasons, couldn't we consider that a node join a public key with
its request:
	a) The node sends AREQ and join its public key
	b) The direct neighbours send him a "challenge", i mean a nonce ciphered with the
public key at witch the node
	   should answer by increasing it, in order to verify that it is really the owner
of the key
	c) The node answers and only if this is correct, the neighbours accept to forward
the request. if not
	   The request is discarded.

Thus, we could avoid the Denial of service attack wich would consist to always
send AREQ through the network, in order
to flood it with control paquets. Moreover the public key could then be used to
sign the messages.

I'll wait for your comments.

Cordially, Jean-Marie Orset

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Jaehoon Jeong <[email-masked]>
Date: Tue, 15 Jul 2003 07:15:53 -0700 (PDT)

Thanks.

/Jaehoon

--- Kilian Weniger <[email-masked]> wrote:
> Hi Jaehoon,
> 
> you can find the paper at
> 
>
http://www.tm.uka.de/~weniger/passive_dad_lsr_wcnc03.pdf
> 
> 
> Regards,
> 
> Kilian Weniger
> 
> 
> Am Dienstag, 15. Juli 2003 14:35 schrieb Jaehoon
> Jeong:
> > Hi Kilian,
> > I welcome your suggestion.
> > Would you show me the link of your paper?
> > After reading your paper, I am going to think over
> how
> > to include your idea in my draft.
> > In tomorrow manet meeting, the most important is
> that
> > Ad Hoc IP Addressing should be selected as a new
> manet
> > item. I only reinitiates the issue after Charlie.
> I
> > need many comments from manet guys including you
> and
> > Charlie.
> > I would like to make a good ad hoc address
> > autoconfiguration scheme with others.
> > Thanks.
> >
> > /Jaehoon Paul
> >
> > --- Kilian Weniger <[email-masked]> wrote:
> > > Hi Jaehoon,
> > >
> > > we are also working on Duplicate Address
> Detection
> > > in mobile ad hoc networks.
> > >
> > > In our approach, which is called "Passive
> Duplicate
> > > Address Detection" (PDAD)
> > > and which was presented at IEEE WCNC, New
> Orleans,
> > > March 2003 (K.Weniger,
> > > "Passive Duplicate Address Detection in Mobile
> Ad
> > > Hoc Networks"), all nodes
> > > continuously monitor the routing protocol
> traffic
> > > and seeks for anomalies in
> > > order to find duplicate addresses in the
> network.
> > > Thus, PDAD supports network
> > > partitioning and merging as Weak DAD does.
> > >
> > > One advantage of our approach is, that it does
> not
> > > consume any additional
> > > protocol overhead (as WDAD does: one keys for
> each
> > > address). Another
> > > advantage is, that the routing protocol message
> > > format does not need to be
> > > modified (as it is for WDAD). Thus, it is even
> > > possible to use existing
> > > routing protocol implementations, e.g. by
> > > implementing PDAD as a linux
> > > netfilter module (we are currently working on
> that).
> > >
> > > We have done detailed simulations using PDAD
> with
> > > FSR and OLSR. For each of
> > > these protocols, a combination of schemes was
> able
> > > to resolve all conflicts.
> > > The results will be published soon. Since the
> > > publication mentioned above
> > > only discusses proactive link state routing
> > > protocols, support for reactive
> > > routing protocols is another issue we are
> currently
> > > working on.
> > >
> > > Summarizing, PDAD could also be an option for
> your
> > > draft, in addition or as an
> > > alternative to WDAD.
> > >
> > >
> > > Regards,
> > >
> > > Kilian Weniger
> > >
> > >
> > > Am Dienstag, 8. Juli 2003 11:03 schrieb Jaehoon
> > >
> > > Jeong:
> > > > Hi, Jean-Marie.
> > > >
> > > > ----- Original Message -----
> > > > From: "Jean-Marie ORSET"
> > >
> > > <[email-masked]>
> > >
> > > > To: "Jaehoon Jeong" <[email-masked]>
> > > > Sent: Tuesday, July 08, 2003 1:32 AM
> > > > Subject: Re: [Re] [manet] Re: Ad Hoc IP
> Address
> > >
> > > Autoconfiguration
> > >
> > > > > Le Sat, 5 Jul 2003 09:59:53 +0900
> > > > >
> > > > > Jaehoon Jeong a ?rit:
> > > > > > I agree with you that the public
> cryptography
> > >
> > > is very expensive,
> > >
> > > > > > especially in MANET.
> >
> >  In my scheme, a key is
> >
> > > used for identifying the
> > >
> > > > > > address duplication. So, key's uniqueness
> is
> > >
> > > important.
> > >
> > > > > > In order to guarantee the uniqueness of
> public
> > >
> > > key,
> > >
> > > > > > We should use a certificate for a public
> key?
> > > > > > How about?
> > > > >
> > > > > Yes, a certificate seems to be essential
> while
> > >
> > > using public key
> > >
> > > > > cryptography.
> >
> >  In fact, the problem is who will
> >
> > > be used to certificate
> > >
> > > > > the key, since we can not emply centralized
> > >
> > > certification authotity? Zhou
> > >
> > > > > and Haas did write a very good paper on the
> > >
> > > distribution of trust in
> > >
> > > > > Manet. The schemes could be used
> complementary.
> > > >
> > > >    Could you tell me the URL of the paper?
> > > >
> > > > > However, even if it is important to
> guarantee
> > >
> > > the non address
> > >
> > > > > duplication
> >
> >  I'm not sure public key
> >
> > > cryptography could be used to sign
> > >
> > > > > each packet.
> > > >
> > > >    That will need more discussion, I think.
> > > >    Anyway, I hope  this manet wg meeting
> starts to
> > >
> > > discuss ad hoc address
> > >
> > > > autoconfiguration.
> >
> >  Thanks.
> >
> > > >    /Jaehoon
> > > >
> > > --
> > > Dipl.-Ing. Kilian Weniger
> > > Institute of Telematics, Universitaet Karlsruhe
> (TH)
> > > Zirkel 2, 76128 Karlsruhe, Germany
> > > Phone: +49 721 608 6415, Fax: +49 721 388097
> 
=== message truncated ===

__________________________________
Do you Yahoo!?
SBC Yahoo! DSL - Now only $29.95 per month!
http://sbc.yahoo.com