Subject: [manet] Replication in wireless ad hoc networks

From: "Alistair Harris" <[email-masked]>
Date: Fri, 22 Aug 2003 10:36:16 +0100

Hello everyone,
I'm a new research student focussing on broadly on the area of data 
replication in wireless ad hoc networks. Specifically, I would like to 
investigate issues concerning the management of mutiple copies of a document 
and the subsequent requirement to reconcile any changes to produce a 'final' 
document.

I would like to know if anyone is doing related work in this area or know of 
any good sources of information.

Thanks

Regards

_________________________________________________________________
Find a cheaper internet access deal - choose one to suit you. 
http://www.msn.co.uk/internetaccess

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Takahiro HARA <[email-masked]>
Date: Fri, 22 Aug 2003 18:55:11 +0900

Hello Harris,

I know several previous works focusing consistency management among replicas in ad hoc networks:

   Karumanchi, G., Muralidharan, S., and Prakash, R.: 
   Information Dissemination in Partitionable Mobile Ad Hoc Networks, 
   Proc. Symposium on Reliable Distributed Systems (SRDS'99), 
   pp.4-13 (1999).

   Rothermel, K., Becker, C., and Hahner, J.: 
   Consistent Update Diffusion in Mobile Ad Hoc Networks, 
   Technical Report 2002/04, Computer Science Department, 
   University of Stuttgart (2002).

   Luo, J., Hubaux, J.P., and Eugster, P.: 
   PAN: Providing Reliable Storage in Mobile Ad Hoc Networks 
   with Probabilistic Quorum Systems, Proc. ACM MobiHoc 2003, 
   pp.1-12 (2003).

Also, I am working on data replication in ad hoc networks.
The followings are my related papers.
(But, they do not consider the consistency among replicas.) 

   Hara, T.: 
   Effective Replica Allocation in Ad Hoc Networks for Improving Data     Accessibility, Proc. of IEEE Infocom 2001, Vol.3, pp.1568-1576 
   (Apr. 2001).

   Hara, T.: 
   Replica Allocation Methods in Ad Hoc Networks with Data Update,
   ACM-Kluwer Journal on Mobile Networks and Applications (MONET), 
   Vol.8, No.4, pp.343-354 (Aug. 2003).

   Hayashi, H., Hara, T., and Nishio, S.: 
   Cache Invalidation for Updated Data in Ad Hoc Networks, 
   Proc. of Int'l Conf. on Cooperative Information Systems (CoopIS'03)
   (Nov. 2003, to appear).

Regards,

Takahiro Hara

===============================================
| Takahiro HARA, Dr. Eng.                     |
| Dept. of Multimedia Engieering              |
| Grad. Sch. of Info. Science and Technology  |
| Osaka University                            |
| 2-1 Yamadaoka, Suita, Osaka 565-0871, JAPAN |
| E-mail: [email-masked]              |
| Tel: +81-6-6879-7818, Fax: +81-6-6879-7815  |
===============================================

---

From: Christoph Lindemann <[email-masked]>
Date: Fri, 22 Aug 2003 12:06:25 +0200

Hello Harris,

we have a recent paper at MobiDE which might be of interest to you:

C. Lindemann, O. Waldhorst, Consistency Mechanisms for a Distributed Lookup 
Service supporting Mobile Applications, 3rd Int. ACM Workshop on Data 
Engineering for Wireless and Mobile Access (MobiDE 2003), San Diego, CA, 
September 2003. To appear.

The paper is available at our web site.
Regards, Christoph

At 10:36 22.08.2003 +0100, you wrote:

>investigate issues concerning the management of mutiple copies of a 
>document and the subsequent requirement to reconcile any changes to 
>produce a 'final' document.
>
>I would like to know if anyone is doing related work in this area or know 
>of any good sources of information.
>
>Thanks
>
>Regards
>
__________________________________________________________________________________
Dr. Christoph Lindemann  -  Associate Professor
University of Dortmund
Department of Computer Science                          Phone: (+49231) 
755-2410
-Computer Systems and Performance Evaluation-   Fax:   (+49231) 755-2417
August-Schmidt-Str. 12                                  E-mail: 
[email-masked]
44227 Dortmund, Germany
WWW: http://www4.cs.uni-dortmund.de/~Lindemann/
_________________________________________________________________________________

---

From: Einar Vollset <[email-masked]>
Date: Fri, 22 Aug 2003 12:02:47 +0100

Also perhaps of interest:

S. Chessa and P.Maestrini,
Dependable and Secure Data Storage and Retrieval in Mobile, Wireless 
Networks,
International Conference on Dependable Systems and Networks 2003 
(DSN2003)
San Francisco, USA
pp.207-217.

On Friday, Aug 22, 2003, at 10:36 Europe/London, Alistair Harris wrote:

> I would like to know if anyone is doing related work in this area or 
> know of any good sources of information.
>
> Thanks
>
> Regards
>

----------------------------------------
Einar Vollset
PhD Student
School of Computing Science
University of Newcastle, UK
http://vollset.org
-----------------------------------------

---

From: Rex Buddenberg <[email-masked]>
Date: 22 Aug 2003 08:54:51 -0700

you're on the wrong list; look up 'cvs' and 'rsynch'

-- 
b