Subject: [manet] interference problem

From: [email-masked]
Date: Mon, 18 Aug 2003 02:33:50 -0400

Hi,

Forgive me if this problem has already been discussed on the list.

Consider a simple scenario of 6 nodes in a chain :

0 -- 1 -- 2 -- 3 -- 4 -- 5

Each node is at a distance of 150 m from each other. The reception range of each node is 250 m and the interference range/sensing range  is 500 m. Node 0 is the source node transmitting UPD packets at a constant rate (say  x packets/sec) and node 5 is the sink node or destination node. The link layer is based on CSMA/CA. Node 4 is thus at a distance of 450 m from node 1 and 600 m from node 0. Hence, node 0 cannot hear any transmissions from node 4 (out of interference/sensing range), but transmissions from node 4 can interfere with reception at node 1. Since node 0 cannot hear node 4 transmitting (hence CSMA/CA doesnt work here), it transmits to node 1 even when node 4 is transmitting. This results in collisions at node 1 and the throughput of the network drops drastically. The CTS-RTS-DATA-ACK scheme doesnt work here. Has this problem been addressed anywhere? Are there any papers that suggest solutions to this problem?

thanks,
Harpreet S. Arora 
Research Assistant, ITCSL
Drexel University
Philadelphia, PA-19104
Ph : 215-895-6198

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Chi-Hsiang Yeh" <[email-masked]>
Date: Mon, 18 Aug 2003 05:14:51 -0400

Hi, Harpreet,

There are a number of solutions to this problem:

(1) Reduce the threshold for sensing so that node 1 and node 4 can hear
each other.

  Problem 1: This is not always feasible, especially when 
      (A) the path loss exponent is large (e.g., 3-4) or unknown,
      (B) when power-controlled MAC protocols are employed.
  Problem 2: This introduces inefficiency due to the "interference-range
exposed terminal problem". For various unique problems concerning MAC
protocols in ad hoc networks, see

  [1] Yeh, C.-H., "The advance access mechanism for differentiated
service, power control, and radio efficiency in ad hoc MAC protocols,"
Proc. IEEE Vehicular Technology Conf., Oct. 2003, to appear.

(2) An intended receiver replies with a CTS only when the signal
strength from the intended transmitter is sufficiently strong. See

  [2] Kaixin Xu, M. Gerla, and Sang Bae, "How effective is the IEEE
802.11 RTS/CTS handshake in ad hoc networks?" IEEE Globecom'02, 2002,
pp. 72 -76.

  Problem 1: Power-controlled MAC protocols are more efficient than this
fixed-power solution in terms of both throughput and power consumption.
  Problem 2: Some nodes that can transmit to each other without causing
collisions are forbidden to transmit. This can be viewed as another form
of the exposed terminal problem.

(3) The RTS-CTS-DATA-ACK scheme actually works if control messages are
sent in a separate control channels and RTS/CTS messages are sent to
nodes within the interference range (or an enlarged "protection range"
as assumed in most of my papers on ad hoc MAC protocols). 

  Problem: RTS/CTS messages have to be sent to a large
interference/protection range. One way to solve it is to relay them, but
this is not perfect nor efficient. For more details, see

  [3] Yeh, C.-H., "High-throughput Interference-aware MAC Protocols for
Heterogeneous Ad Hoc Networks and Multihop Wireless LANs," Proc. IEEE
Globecom'03, Dec. 2003, to appear.

(4) Use busy tone with a very large range. See
  
  [4] Monks, J.P., V. Bharghavan, W.-M.W. Hwu, "A power controlled
multiple access protocol for wireless packet networks," IEEE INFOCOM'01,
2001, pp. 219-228.

  Problem: Busy tone consumes power, while the time required for
detecting "periodical busy tone" (as in PCMA) reduces throughput.

Chihsiang
___________________________________________________________

Chi-Hsiang Yeh (Mr./Dr./Prof.)
Dept. of Electrical & Computer Eng.
Queen's University
Kingston, Ontario, K7L 3N6
Canada

phone:  +1 613-533-6368
fax:    +1 613-533-6615
e-mail: [email-masked] , [email-masked]
URL:    http://www.ece.queensu.ca/hpages/faculty/yeh/
___________________________________________________________

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of [email-masked]
> Sent: Monday, August 18, 2003 2:34 AM
> To: [email-masked]
> Subject: [manet] interference problem
> 
> 
> Hi,
> 
> Each node is at a distance of 150 m from each other. The 
> reception range of each node is 250 m and the interference 
> range/sensing range  is 500 m. Node 0 is the source node 
> transmitting UPD packets at a constant rate (say  x 
> packets/sec) and node 5 is the sink node or destination node. 
> The link layer is based on CSMA/CA. Node 4 is thus at a 
> distance of 450 m from node 1 and 600 m from node 0. Hence, 
> node 0 cannot hear any transmissions from node 4 (out of 
> interference/sensing range), but transmissions from node 4 
> can interfere with reception at node 1. Since node 0 cannot 
> hear node 4 transmitting (hence CSMA/CA doesnt work here), it 
> transmits to node 1 even when node 4 is transmitting. This 
> results in collisions at node 1 and the throughput of the 
> network drops drastically. The CTS-RTS-DATA-ACK scheme doesnt 
> work here. Has this problem been addressed anywhere? Are 
> there any papers that suggest solutions to this problem?
> 
> thanks,
> Harpreet S. Arora