Subject: [manet] Problem in running OPNET model simulation

From: Jianqiang Zeng <[email-masked]>
Date: Fri, 15 Aug 2003 12:10:58 -0700

hi, everybody, I am using OPNET to simulate the MANETs. I downloaded some routing protocol models , when I tried to run simulation on my PC, the simulation was terminated. It seems that there are some problems in rebuilding repository. Does this kind of problem caused by using different platform or different version of OPNET?  Any advice will be most appreciately! Thanks  

Best Regards
Jianqiang zeng

the message was displayed as 
-----
<<< Recoverable Error >>>
Object repository construction failed
due to errors encountered by the binder program (bind_so_msvc)
-----
<<< Program Abort >>>
Error encountered rebuilding repository -- unable to proceed
And following is the bind_err file:
BRP.i0.pr.o : error LNK2005: _print_simple_Link_State_Tree already defined in IARP_LS_timer.i0.pr.o
BRP.i0.pr.o : error LNK2005: _print_simple_Link_State_Table already defined in IARP_LS_timer.i0.pr.o
BRP.i0.pr.o : error LNK2005: _print_Link_State_Tree already defined in IARP_LS_timer.i0.pr.o
BRP.i0.pr.o : error LNK2005: _print_Link_State_Table already defined in IARP_LS_timer.i0.pr.o
BRP.i0.pr.o : error LNK2005: _init_Link_State_Table already defined in IARP_LS_timer.i0.pr.o
BRP.i0.pr.o : error LNK2005: _new_Link_State_Tree already defined in IARP_LS_timer.i0.pr.o
BRP.i0.pr.o : error LNK2005: _add_to_Link_State_Tree already defined in IARP_LS_timer.i0.pr.o
BRP.i0.pr.o : error LNK2005: _add_to_Link_State_Table already defined in IARP_LS_timer.i0.pr.o
BRP.i0.pr.o : error LNK2005: _insert_node_in_Link_State_Tree already defined in IARP_LS_timer.i0.pr.o
BRP.i0.pr.o : error LNK2005: _delete_Link_State_Tree already defined in IARP_LS_timer.i0.pr.o
BRP.i0.pr.o : error LNK2005: _receive_link_state_packet already defined in IARP_LS_timer.i0.pr.o
BRP.i0.pr.o : error LNK2005: _send_link_state_packet already defined in IARP_LS_timer.i0.pr.o
BRP.i0.pr.o : error LNK2005: _construct_Routing_Table_from_Net_Node already defined in IARP_LS_timer.i0.pr.o
BRP.i0.pr.o : error LNK2005: _construct_Routing_Table_from_Net_Graph already defined in IARP_LS_timer.i0.pr.o
BRP.i0.pr.o : error LNK2005: _construct_Routing_Table_from_Link_State_Table already defined in IARP_LS_timer.i0.pr.o
BRP.i0.pr.o : error LNK2005: _update_Link_State_Tree already defined in IARP_LS_timer.i0.pr.o
BRP.i0.pr.o : error LNK2005: _update_Link_State_Table already defined in IARP_LS_timer.i0.pr.o
BRP.i0.pr.o : error LNK2005: _transfer_Link_State_Tree already defined in IARP_LS_timer.i0.pr.o
BRP.i0.pr.o : error LNK2005: _transfer_Link_State_Table already defined in IARP_LS_timer.i0.pr.o
beacon.i0.pr.o : error LNK2005: _print_Beacon_List already defined in app.i0.pr.o
beacon.i0.pr.o : error LNK2005: _print_Beacon_Table already defined in app.i0.pr.o
beacon.i0.pr.o : error LNK2005: _new_Beacon_List already defined in app.i0.pr.o
beacon.i0.pr.o : error LNK2005: _init_Beacon_Table already defined in app.i0.pr.o
beacon.i0.pr.o : error LNK2005: _add_to_Beacon_List already defined in app.i0.pr.o
beacon.i0.pr.o : error LNK2005: _add_to_Beacon_Table already defined in app.i0.pr.o
beacon.i0.pr.o : error LNK2005: _remove_from_Beacon_List already defined in app.i0.pr.o
beacon.i0.pr.o : error LNK2005: _remove_from_Beacon_Table already defined in app.i0.pr.o
beacon.i0.pr.o : error LNK2005: _delete_Beacon_List already defined in app.i0.pr.o
beacon.i0.pr.o : error LNK2005: _clear_Beacon_Table already defined in app.i0.pr.o
beacon.i0.pr.o : error LNK2005: _get_current_event_in_Beacon_List already defined in app.i0.pr.o
beacon.i0.pr.o : error LNK2005: _get_current_event_in_Beacon_Table already defined in app.i0.pr.o
BRP.i0.pr.o : warning LNK4006: _print_simple_Link_State_Tree already defined in IARP_LS_timer.i0.pr.o; second definition ignored
BRP.i0.pr.o : warning LNK4006: _print_simple_Link_State_Table already defined in IARP_LS_timer.i0.pr.o; second definition ignored
BRP.i0.pr.o : warning LNK4006: _print_Link_State_Tree already defined in IARP_LS_timer.i0.pr.o; second definition ignored
BRP.i0.pr.o : warning LNK4006: _print_Link_State_Table already defined in IARP_LS_timer.i0.pr.o; second definition ignored
BRP.i0.pr.o : warning LNK4006: _init_Link_State_Table already defined in IARP_LS_timer.i0.pr.o; second definition ignored
BRP.i0.pr.o : warning LNK4006: _new_Link_State_Tree already defined in IARP_LS_timer.i0.pr.o; second definition ignored
BRP.i0.pr.o : warning LNK4006: _add_to_Link_State_Tree already defined in IARP_LS_timer.i0.pr.o; second definition ignored
BRP.i0.pr.o : warning LNK4006: _add_to_Link_State_Table already defined in IARP_LS_timer.i0.pr.o; second definition ignored
BRP.i0.pr.o : warning LNK4006: _insert_node_in_Link_State_Tree already defined in IARP_LS_timer.i0.pr.o; second definition ignored
BRP.i0.pr.o : warning LNK4006: _delete_Link_State_Tree already defined in IARP_LS_timer.i0.pr.o; second definition ignored
BRP.i0.pr.o : warning LNK4006: _receive_link_state_packet already defined in IARP_LS_timer.i0.pr.o; second definition ignored
BRP.i0.pr.o : warning LNK4006: _send_link_state_packet already defined in IARP_LS_timer.i0.pr.o; second definition ignored
BRP.i0.pr.o : warning LNK4006: _construct_Routing_Table_from_Net_Node already defined in IARP_LS_timer.i0.pr.o; second definition ignored
BRP.i0.pr.o : warning LNK4006: _construct_Routing_Table_from_Net_Graph already defined in IARP_LS_timer.i0.pr.o; second definition ignored
BRP.i0.pr.o : warning LNK4006: _construct_Routing_Table_from_Link_State_Table already defined in IARP_LS_timer.i0.pr.o; second definition ignored
BRP.i0.pr.o : warning LNK4006: _update_Link_State_Tree already defined in IARP_LS_timer.i0.pr.o; second definition ignored
BRP.i0.pr.o : warning LNK4006: _update_Link_State_Table already defined in IARP_LS_timer.i0.pr.o; second definition ignored
BRP.i0.pr.o : warning LNK4006: _transfer_Link_State_Tree already defined in IARP_LS_timer.i0.pr.o; second definition ignored
BRP.i0.pr.o : warning LNK4006: _transfer_Link_State_Table already defined in IARP_LS_timer.i0.pr.o; second definition ignored
beacon.i0.pr.o : warning LNK4006: _print_Beacon_List already defined in app.i0.pr.o; second definition ignored
beacon.i0.pr.o : warning LNK4006: _print_Beacon_Table already defined in app.i0.pr.o; second definition ignored
beacon.i0.pr.o : warning LNK4006: _new_Beacon_List already defined in app.i0.pr.o; second definition ignored
beacon.i0.pr.o : warning LNK4006: _init_Beacon_Table already defined in app.i0.pr.o; second definition ignored
beacon.i0.pr.o : warning LNK4006: _add_to_Beacon_List already defined in app.i0.pr.o; second definition ignored
beacon.i0.pr.o : warning LNK4006: _add_to_Beacon_Table already defined in app.i0.pr.o; second definition ignored
beacon.i0.pr.o : warning LNK4006: _remove_from_Beacon_List already defined in app.i0.pr.o; second definition ignored
beacon.i0.pr.o : warning LNK4006: _remove_from_Beacon_Table already defined in app.i0.pr.o; second definition ignored
beacon.i0.pr.o : warning LNK4006: _delete_Beacon_List already defined in app.i0.pr.o; second definition ignored
beacon.i0.pr.o : warning LNK4006: _clear_Beacon_Table already defined in app.i0.pr.o; second definition ignored
beacon.i0.pr.o : warning LNK4006: _get_current_event_in_Beacon_List already defined in app.i0.pr.o; second definition ignored
beacon.i0.pr.o : warning LNK4006: _get_current_event_in_Beacon_Table already defined in app.i0.pr.o; second definition ignored
   Creating library C:\Program Files\OPNET\9.1.A\models\std\mzrp_doc\zrp-50_node.i0.nt.lib and object C:\Program Files\OPNET\9.1.A\models\std\mzrp_doc\zrp-50_node.i0.nt.exp
C:\Program Files\OPNET\9.1.A\models\std\mzrp_doc\zrp-50_node.i0.nt.so : fatal error LNK1169: one or more multiply defined symbols found

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Jay J Lee <[email-masked]>
Date: Fri, 15 Aug 2003 16:33:57 -0400

It seems that the two process models have two functions with the same 
name.  One of these two process models was probably created by renaming the 
other one.

I would first check whether the two processes were meant to work in a same 
simulation or not.  Did the model come with the instruction on running 
simulations?

Secondly you can bypass this linking error by declaring these functions as 
static.  For example you would open the BRP and IARP_LS_timer process 
models and declare the function prototype of 
"print_simple_Link_State_Tree()" as "static" in the header block as well as 
the function definition in the function block.

Hope this helps, - Jay

At 12:10 PM 8/15/2003 -0700, Jianqiang Zeng wrote:
>hi, everybody, I am using OPNET to simulate the MANETs. I downloaded some 
>routing protocol models , when I tried to run simulation on my PC, the 
>simulation was terminated. It seems that there are some problems in 
>rebuilding repository. Does this kind of problem caused by using different 
>platform or different version of OPNET?  Any advice will be most 
>appreciately! Thanks
>
>Best Regards
>Jianqiang zeng
>
>BRP.i0.pr.o : error LNK2005: 
>_construct_Routing_Table_from_Link_State_Table already defined in 
>IARP_LS_timer.i0.pr.o
>BRP.i0.pr.o : warning LNK4006: _print_simple_Link_State_Tree already 
>defined in IARP_LS_timer.i0.pr.o; second definition ignored
>BRP.i0.pr.o : warning LNK4006: _print_simple_Link_State_Table already 
>defined in IARP_LS_timer.i0.pr.o; second definition ignored
>BRP.i0.pr.o : warning LNK4006: _print_Link_State_Tree already defined in 
>IARP_LS_timer.i0.pr.o; second definition ignored
>BRP.i0.pr.o : warning LNK4006: _print_Link_State_Table already defined in 
>IARP_LS_timer.i0.pr.o; second definition ignored
>BRP.i0.pr.o : warning LNK4006: _init_Link_State_Table already defined in 
>IARP_LS_timer.i0.pr.o; second definition ignored
>BRP.i0.pr.o : warning LNK4006: _new_Link_State_Tree already defined in 
>IARP_LS_timer.i0.pr.o; second definition ignored
>BRP.i0.pr.o : warning LNK4006: _add_to_Link_State_Tree already defined in 
>IARP_LS_timer.i0.pr.o; second definition ignored
>BRP.i0.pr.o : warning LNK4006: _add_to_Link_State_Table already defined in 
>IARP_LS_timer.i0.pr.o; second definition ignored
>BRP.i0.pr.o : warning LNK4006: _insert_node_in_Link_State_Tree already 
>defined in IARP_LS_timer.i0.pr.o; second definition ignored
>BRP.i0.pr.o : warning LNK4006: _delete_Link_State_Tree already defined in 
>IARP_LS_timer.i0.pr.o; second definition ignored
>BRP.i0.pr.o : warning LNK4006: _receive_link_state_packet already defined 
>in IARP_LS_timer.i0.pr.o; second definition ignored
>BRP.i0.pr.o : warning LNK4006: _send_link_state_packet already defined in 
>IARP_LS_timer.i0.pr.o; second definition ignored
>BRP.i0.pr.o : warning LNK4006: _construct_Routing_Table_from_Net_Node 
>already defined in IARP_LS_timer.i0.pr.o; second definition ignored
>BRP.i0.pr.o : warning LNK4006: _construct_Routing_Table_from_Net_Graph 
>already defined in IARP_LS_timer.i0.pr.o; second definition ignored
>BRP.i0.pr.o : warning LNK4006: 
>_construct_Routing_Table_from_Link_State_Table already defined in 
>IARP_LS_timer.i0.pr.o; second definition ignored
>BRP.i0.pr.o : warning LNK4006: _update_Link_State_Tree already defined in 
>IARP_LS_timer.i0.pr.o; second definition ignored
>BRP.i0.pr.o : warning LNK4006: _update_Link_State_Table already defined in 
>IARP_LS_timer.i0.pr.o; second definition ignored
>BRP.i0.pr.o : warning LNK4006: _transfer_Link_State_Tree already defined 
>in IARP_LS_timer.i0.pr.o; second definition ignored
>BRP.i0.pr.o : warning LNK4006: _transfer_Link_State_Table already defined 
>in IARP_LS_timer.i0.pr.o; second definition ignored
>beacon.i0.pr.o : warning LNK4006: _remove_from_Beacon_List already defined 
>in app.i0.pr.o; second definition ignored
>beacon.i0.pr.o : warning LNK4006: _remove_from_Beacon_Table already 
>defined in app.i0.pr.o; second definition ignored
>beacon.i0.pr.o : warning LNK4006: _get_current_event_in_Beacon_List 
>already defined in app.i0.pr.o; second definition ignored
>beacon.i0.pr.o : warning LNK4006: _get_current_event_in_Beacon_Table 
>already defined in app.i0.pr.o; second definition ignored
>    Creating library C:\Program 
> Files\OPNET\9.1.A\models\std\mzrp_doc\zrp-50_node.i0.nt.lib and object 
> C:\Program Files\OPNET\9.1.A\models\std\mzrp_doc\zrp-50_node.i0.nt.exp
>C:\Program Files\OPNET\9.1.A\models\std\mzrp_doc\zrp-50_node.i0.nt.so : 
>fatal error LNK1169: one or more multiply defined symbols found
>
>
>