Subject: RE: [manet] The Problem of Alien Node

From: "Yasser A. Lotfy" <[email-masked]>
Date: Mon, 08 Sep 2003 13:50:49 -0400

Hi Manish,
you are generaly right, please read my comments below.
yasser
-----Original Message-----

>Hi Yasser,
>Please see inline comments.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Yasser A. Lotfy
> Sent: Monday, September 08, 2003 12:46 AM
> To: [email-masked]
> Subject: RE: [manet] The Problem of Alien Node
> 
> 
> 
> Great replies from both of you. I have three points to make:
> 1) The "alien node problem" may exist on proactive routing 
> algorithm. Since the gateway is associated with generic 
> addresses, a node will search it's lookup table for 
> destination address, then it finds the destination (alien 
> address) and the gateway (generic address). Based on the 
> decision src node will make, we may have the "alien node problem"

In proactive routing protocol, sourc looks up its routing table to forward its packets and it will use default route for a Internet gateway if the corresponding host route entry (/128) does not exist.
If you are focusing on the static global ip which is not globally reachable,  it has same semantic as manet local ip with MANET_PREFIX.
Anyway, if source node can not discover host route for the static global ip, it can not but forward toward its default gateway since it only knows that destination ip is global one. As I said in my
previous reply, after receiving ICMP, souce node does host route discovery in case of reactive routing protocols or simply discards packets with the static global destination ip until it finally finds host route for the destination or some timer is expired in case of proactive ones.
IMO, this is enough for "alien node problem" that you defined. The "registration" scheme can be also helpful because time and some packet loss which is taken until src node is notified that destination is not globally reachable can be reduced. But, it can not be the ultimate solution. Manet nodes may have different sets of gateways because of partitions. 
So, the gateway chosen by src node may not have "the registration entry" for the static global destination ip. 
[Yasser] Agree.

> 2) By registration I mean that an alien node (a node that 
> doesn't follow the MANET_PREFIX address) will have to 
> register it's address with the gateway. Then periodically 
> refresh this registration, otherwise, the gateway will 
> periodically remove unrefreshed registration. In this way, 
> The gateway will have to check destination address of pkts, 
> and forward out of the network only pkts with unregistered 
> address at alien table. In case of partition, the 
> registration will be removed after a while. In multiple 
> gateways, all of them will receive the registration msg.

Because of frequent partitioning in MANET, you cannot guarantee that all nodes with static global ip can 
register its address with all gateways.

[Yasser] Not really, all gateways reachable by destination will be updated by alien node registration in timely manner (please re-read).
 
> 3) Iagree it is confusing, because if an alien node (with 
> globaly routable static ip) needs to be reachable from the 
> Internet, it has to use a gateway as a c/o address. This the 
> dynamics of the MANET environment, it is hard to maintain 
> this info. Some co-ordination between the gateways (multiple 
> gw) has to be done.

You seem to consider cases like mip-manet. I do not want to see this case as special one because the only
difference is "home registration" through which the node registers its CoA with the prefix from a gateway
with its HA. Difficulty caused by the nature of MANET also exists in incoming traffic packets of the communication between a manet node(not MIP node) and
Internet node.
For optimization using multiple gateways, some co-ordination or other methods can be applied.

[Yasser] I agree, and think we need to start talking about gateway issues.

> 
> Well, for now, there seem to be an agreement on a missing 
> role the gw has to do on registration. The assumptions of the 
> ad-hoc environment is still vague in this respect. I believe 
> we need to define the basic assumptions of the ad-hoc 
> gateways, and how they may connect to the Internet.
> 

Basically, I do not think that "the registaration" you meant is not essential for the reason which is mentioned repeatedly. I think route informations obtained by routing protocols and ICMP messages are enough for "the alien node problem".
For the communication between a manet node and Internet one, I propose a manet node registers its permanent(or quite stable) ip with MANET_PREFIX and its dynamically configured global IP with prefix from a gateway with the corresponding gateway. 
As I said in the previouse reply, this information can be useful for incoming traffic from Internet to MANET.
What do you think about this?

[Yasser] I agree, and believe manet node has to register with all reachable gateways, not with a selected one. 

Regards,
Hyunwook Cha.

> Regards,
> yasser
> ---------------------------------------------
> Hi Yasser,
> I think "registration" is necessary for communications which 
> are not only manet local but also across Internet. I 
> mentioned this point at my previous posting. But I think the 
> "registration" can not be an solution for the "Alien Node 
> Problem". Please think about this case. There are multiple 
> gateways and a manet. Manet nodes may have different sets of 
> gateways because of partitions. And, if a gateway chosen by 
> souce node does not belong to the gateway set of destination 
> node, it will forward packets destined to desination toward 
> Internet. I think a global static ip which you are 
> considering is not globally routable(reachable) since a manet 
> node with globally routable global ip is also reachable 
> across Internet althogh it is local manet node. If so, 
> evenually souce node will be notified by ICMP destination 
> unreachable and do route discovery again in case of reactive 
> protocols. I think this is enough for destination node with 
> the "global static ip" which is not globally routable.
> 
> Regards,
> 
> ++++++++++++++++++++++++++++++++++++++++++++++++++++
> 
> HyunWook Cha
> 
> Researcher  
> NGI Standards Research Team
> Protocol Engineering Center, ETRI
> 161 Kajong-Dong, Yusong-Gu, Taejon, 305-350, KOREA
> (Tel) +82-42-860-1076
> 
> ++++++++++++++++++++++++++++++++++++++++++++++++++++
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] On
> > Behalf Of Yasser A. Lotfy
> > Sent: Tuesday, September 02, 2003 12:25 AM
> > To: [email-masked]; Manish Karir
> > Subject: Re: [manet] The Problem of Alien Node
> > 
> > 
> > 
> > Hi,
> > That is exactly my point. Ad-hoc nodes may not always have a
> > MANET_PREFIX IP address due to possibilities of nodes roaming 
> > with a static IP, and the chances of ad-hoc network getting 
> > partitioned or merged.
> > 
> > Therefore, it is not possible for ad-hoc nodes to rely merely
> > on MANET_PREFIX IP address to distinguish local nodes (LAA). 
> > The gateway also will asume nodes that don't have 
> > MANET_PREFIX IP address are external, and will forward 
> > packets outside the ad-hoc. While in fact some nodes that 
> > don't have MANET_PREFIX IP address are local nodes, with 
> > global static IP (I call it alien nodes).
> > 
> > Therefore, I believe, there should be a registration
> > mechanism for all alien nodes at the gateway.
> > 
> > Any comments? any reason why not?
> > 
> > yasser
> > ----------------------------------------------
> > I'm sorry but the point that you are trying to get across 
> is not very
> > clear, and your terminology is quite confusing...
> > perhaps it would become clearer if we knew what your references 
> > were...[047-01] and [048-01].
> > 
> > when building a scenario that incorportes both terrestrial
> > and ad hoc nodes, it is best to use address in MANET_PREFIX 
> > to identify ad hoc nodes.  this way the gateway knows which 
> > address are in manet and which are in terrestrial network.  
> > These address spaces should be mutually exclusive, or you are 
> > going to run into the problems that you describe(atleast 
> > thats what I think you are talking about).
> > 
> > alternately, if you decide that the two address spaces can
> > intermingle, then you need to run complex 
> > registration/deregistration protocols at the gateway to 
> > inform the gateway which addresses(nodes) are in the 
> > manet.(some hybrid form of MIP).
> > 
> > -manish
> > 
> > 
> > 
> > Yasser A. Lotfy wrote:
> > > Hi,
> > > 
> > > I hope you read the attached (word) document which raises
> > awareness of
> > > the
> > 
> > > problem of alien node. Sorry I have to make it in MS-Word
> > since some
> > > of the symbols
> > 
> > > can not be done as text.
> > > 
> > > The problem is simply due to the confusion that takes place when
> > > gateways announce
> > 
> > > there ability to forward packets to generic addresses. Some local
> > > ad-hoc nodes may fall
> > 
> > > in this generic address range. Therefore, packets may
> > (incorrectly) be
> > > forwarded to GW.
> > 
> > > I hope to get feedback if any solution currently exist to this
> > > problem.
> > > 
> > > yasser
> > > ---
> > ***********************************************
> > A train station is the place where trains stop,
> > A bus station is the place where buses stop,
> > On my desk they installed a workstation !!
> > ***********************************************
> > 
> > 
> > 
> > 
> > 
> > 
> > 
> 

____________________________________________________________
Get advanced SPAM filtering on Webmail or POP Mail ... Get Lycos Mail!
http://login.mail.lycos.com/r/referral?aid=27005

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Charlie Perkins <[email-masked]>
Date: Mon, 08 Sep 2003 11:09:29 -0700

Hello folks,

It seems to me that if a gateway offers a prefix, then the
mobile node could configure an address from that prefix.
In particular:

Yasser A. Lotfy wrote:

>>Internet, it has to use a gateway as a c/o address.
>>
Not if it's running in co-located mode with the care-of address it 
derived from
the gateway's prefix.  This is especially true for IPv6.

>> This the 
Not necessarily.  Not any more than in any other case where two routers
advertise reachability to the same prefix.  If only one gateway offers 
reachability
to a particular prefix, then I don't think there is a problem.

>[Yasser] I agree, and believe manet node has to register with all reachable gateways, not with a selected one.
I would not agree with that.  Plus, it leads to major headaches as gateways
come and go.

Regards,
Charlie P.

---

From: "HyunWook Cha" <[email-masked]>
Date: Tue, 9 Sep 2003 18:09:57 +0900

Hi, Yasser.
Please, see my further comments.

> From: Yasser A. Lotfy [mailto:[email-masked]] 
> Sent: Tuesday, September 09, 2003 2:51 AM
> To: [email-masked]; [email-masked]

You made a big mistake. I am not Manish, but Hyunwook. :-)

> Because of frequent partitioning in MANET, you cannot 
> guarantee that all nodes with static global ip can 
> [Yasser] Not really, all gateways reachable by destination 
> will be updated by alien node registration in timely manner 
> (please re-read).

Yeah, I read your explanation again. 
But I don't agree for the same reason. 
Although all gateways reachable by destination will be updated by alien
node registration in timely manner, 
partitioning in the MANET can cause the expiration of "registration
entry" for the dst in some of the gateways.
Then, "The Alien node problem" may happen again.

> Basically, I do not think that "the registaration" you meant 
> is not essential for the reason which is mentioned 
> repeatedly. I think route informations obtained by routing 
> protocols and ICMP messages are enough for "the alien node problem".
> For the communication between a manet node and Internet one, 
> I propose a manet node registers its permanent(or quite 
> stable) ip with MANET_PREFIX and its dynamically configured 
> global IP with prefix from a gateway with the corresponding gateway. 
> As I said in the previouse reply, this information can be 
> useful for incoming traffic from Internet to MANET.
> [Yasser] I agree, and believe manet node has to register with 
> all reachable gateways, not with a selected one. 

Registration that I mentioned is different from your scheme in following
points.
What does a manet node register with Which gateway?
In my "registration", a node registers keyed address i.e one with
MANET_PREFIX and its autoconfigured global IP with the gateway 
who advertised the prefix of the global IP or assigned the global IP.
This is very natural with stateful IP autoconfiguration.
But in your scheme, a manet node registers its static global IP with all
reachable gateways.

"The Alien Node Problem" you defined arises because of the usage of
static global IPs which are indistinguishable from globally routable
global IPs in MANETs.
IMO, global ip assigned to a manet node should be verified as unique
like those assigned to non-manet nodes,
because global IPs which are statically assinged without considering
"duplidate address problem" can cause DoS atteck unintentionally in
MANET with Internet connectivity.
Please think about this case. Src node wants to communicate with an
Internet server and address of another node is set to a static global IP
which is same as the Internet server. Then, the traffic from src to the
Internet server may be intercepted if src obtains host route for
destination address through RREQ of the manet node possessing same 
address or any other means and src can not receive the service of the
server any more.
In order to avoid this problem, DAD for any global IP assigned to a
manet node should be performed no matter how the address may assinged,
too.
In case of autoconfigured global IPs and HoA of MIP-node, DAD is
required to be performed.
IMO, manet node in MANET with Internet connectivity should not use
static global IP except that it is MIP-node and static address is HoA
since DAD for the static global IP
can not be done.
If we consider only MANET without Internet connectivity, DAD for any
address can be performed in the same way i.e strong DAD, weak DAD etc.
Then, what will happen when some nodes running routing protocol daemon
which supports Internet connectivity and other nodes running daemon
which does not coexist in MANET? 
Let's assume that node D in latter group is given a static global IP. 
Although its ip is unique in latter group, an Internet node D'
communicating with node S in former group may have same ip. 
Then, the route entry for D' in S can be overwritten with the host route
info for D by RREQ, RREP etc.
How can we solve this problem? What do you think about this?

Regards,

Hyunwook Cha.

---

From: Bin Lu <[email-masked]>
Date: Fri, 12 Sep 2003 14:58:27 -0500 (CDT)

Hi,

I'm doing research in intrusion detection in ad hoc networks. Basically
what I'm doing is to collect some data and then make a classifier to
distinguish benign behaviors from intrusion.

Due to the fact that we don't have access to a real ad hoc network,
the only way for me to obtain data is to do some simulation. Based on the
fact that real data is much more meaningful than simulated data,
I'm wondering if there is a way for me to get some real data?
It would also be fine if the data are not related to security stuff...

I'd be very grateful if you can refer me to something...

Regards,

Bin Lu