Subject: [manet] Value for CTSTimeout

From: jhchauhan <[email-masked]>
Date: Mon, 01 Sep 2003 16:43:32 -0500

Hello,

The IEEE 802.11 PHY and MAC Specifications state that "After transmitting an 
RTS frame, the STA shall wait for a CTSTimeout interval, starting at the 
PHYTXEND.confirm." If the station does not receive a CTS frame within this 
time period, it considers that the transmission of RTS has failed and starts 
retransmitting the RTS.

I am looking for a typical value for the CTSTimeout interval. It would be 
helpful if someone can inform me about it or tell me a mathematical equation 
in terms of aSIFSTime or aSlotTime or some other parameter. 
Any suggestions are appreciated.

Regards,
Jasmina

Jasmina Chauhan
Graduate Assistant
Wichita State University
Kansas.

Voice : 316-682-6133 (Res)

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Zhenqiang(Frank) Ye" <[email-masked]>
Date: Tue, 2 Sep 2003 09:41:43 -0700 (PDT)

Hi Jasmina,
  If the RTS-CTS handshake is successful, the RTS sender should recieve
a CTS frame after it sends out its RTS and waits for SIFS +
tranmission time of a CTS. Otherwise, it means the RTS fails. By the
way, you need to include some propagation delay. In ns-2 802.11 code,
the RTS timeout value is set to be:
 propagation dalay (of RTS) + SIFS +Tx(CTS) + propagation delay (of CTS).

-- 

****************************************
Zhenqiang(Frank) Ye
Ph.D Student
Department of Electrical Engineering
University of California, Riverside
Phone: (909)-787-2434
email: [email-masked]
****************************************