Subject: [manet] help on 802.11

From: "Peter Pham" <[email-masked]>
Date: Mon, 15 Sep 2003 10:46:43 +0950

Hi  all

I am working on the effect of RTS and CTS of 802.11 in ad hoc network using NS2. I read some papers and their results on the effect or RTS/CTS are controversial...Some said having RTS/CTS improved the performance. Others said the opposite.

Can anyone tell me how to turn on/off the RTS/CTS operation in 802.11.

>From my understanding through the first look of the code, there is no mechanism. However, I might be wrong...If this is the case, what can I do to turn it off...

Cheers 
Peter Pham
Peter Phuc Pham
University of South Australia
Institute for Telecommunication Research
Phone: 61-883023869
Email: [email-masked]
WWW:   www.itr.unisa.edu.au/~ppham

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Apichet Chayabejara" <[email-masked]>
Date: Sun, 21 Sep 2003 08:31:54 +0900

Dear Pham,

IEEE 802.11 only applies RTS/CTS handshakes to frames larger than
RTSThreshold. So an easy way to turn it of is to set the RTSThreshold to a
very large value. You may have to take a look in mac-802_11.h.

Hope it helps.
Apichet.

----- Original Message ----- 
From: "Peter Pham" <[email-masked]>
To: <[email-masked]>
Sent: Monday, September 15, 2003 9:56 AM
Subject: [manet] help on 802.11

Hi  all

I am working on the effect of RTS and CTS of 802.11 in ad hoc network using
NS2. I read some papers and their results on the effect or RTS/CTS are
controversial...Some said having RTS/CTS improved the performance. Others
said the opposite.

>From my understanding through the first look of the code, there is no
mechanism. However, I might be wrong...If this is the case, what can I do to
turn it off...

Cheers
Peter Pham
Peter Phuc Pham