Subject: [manet] Size of network for a propoer flooding in ad hoc networks?

From: "Mona" <[email-masked]>
Date: Fri, 24 Oct 2003 15:11:09 +0100

Hello,

I want to ask what the relation is between number of nodes in an ad hoc 
network and the network diameter.

I use ns2 for simulation and the default value assigned to the network size in "aodv.h" is as follow:

#define NETWORK_DIAMETER        30      // hops

To broadcast a message in the network, NETWORK_DIAMETER is assigned to 
ttl of the header in "aodv.cc".

   // network-wide broadcast
     ih->ttl_ = NETWORK_DIAMETER;

Now should I change this value according to number of mobile nodes in 
my simulation? What is the relation between these two parameters?

Thanks,

Kind Regards,
Mona

-----------------------------------------------------------
Mona Ghassemian, PhD student
Centre for Telecommunications Research
King's College London
Strand, London WC2R 2LS
T: +44 20 7848 2596
F: +44 20 7848 2664
E: [email-masked]
-----------------------------------------------------------

---

From: "Mona" <[email-masked]>
Date: Fri, 24 Oct 2003 19:38:05 +0100

Hello,

Thanks for your help. To my knowledge:

Average_hop_length = 1/(n-1) * sum(from i=2 to i=n)[ h(i)] ;

where n= number of mobile nodes in an ad hoc network and h(i) is the number of hops between source and node i.

h(i) in turn is related to power transmission of the nodes. 

However I am not clear about your point on " a side of your simulation area". Do you mean number of mobile nodes in the network?
Can you explain more detail on calculation of average_hop_length if I haven't got it right?

Kind Regards,

Mona
  ----- Original Message ----- 
  From: Val Naoumov 
  To: Mona 
  Sent: Friday, October 24, 2003 3:48 PM
  Subject: Re: [manet] Size of network for a propoer flooding in ad hoc networks?

  You should change (increase) it only if a side of your simulation area 
  is larger than NETWORK_DIAMETER * average_hop_length, where 
  average_hop_length depends on your simulation parameters, such as 
  transmission power, CST, etc (it's not set somewhere in the code of 
  aodv, you should estimate this value yourself).

  Otherwise, if the simulation area is smaller than
  NETWORK_DIAMETER * average_hop_length, then the RREQ flooding should 
  stop by itself, once every node forwarded the request.

  Cheers,
  Val
  --
  Valeri Naoumov                                e-mail:
  Computer Systems Institute                    [email-masked]
  Swiss Federal Institute of Technology Zurich  web:
  Switzerland                                   www.inf.ethz.ch/~naoumov

  Mona wrote:
  > E: [email-masked] <mailto:[email-masked]>