Subject: [manet] 802.11 throughput analysis

From: "Peter Pham" <[email-masked]>
Date: Thu, 09 Oct 2003 14:16:31 +0950

Hi all 
I have spent sometimes reading the paper(s) on performance/throughput analysis of IEEE 802.11. In "Bianchi"  paper, he analyse the "sarturation throughput" by assuming that there are always packet for sending.

What I am interested is to know with the sending rate \lambda (not in saturation), with probablity of collision p,  what is the rate that will be sent as a function of \lambda. 

Has anyone done any work on this issue ? 

Please let me know ?

Thanks 
Peter Pham
Peter Phuc Pham

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Zhenqiang(Frank) Ye" <[email-masked]>
Date: Wed, 8 Oct 2003 22:00:50 -0700 (PDT)

Hi, Peter,
  One way to do this is changing the number of nodes (participating in
the contention) from n to n':
   n' = n * \lambda * T
 where T is the transmission time of data packet (including RTS, CTS,
DATA and ACK plus some IFSs).

Zhenqiang (Frank) Ye

-- 

****************************************
Zhenqiang(Frank) Ye
Ph.D Student
Department of Electrical Engineering
University of California, Riverside
Phone: (909)-787-2434
email: [email-masked]
****************************************

---

From: bjkwak <[email-masked]>
Date: Thu, 09 Oct 2003 12:14:03 -0400

Hi Frank,

> DATA and ACK plus some IFSs).

It may be a little bit more complicated than that.  Because IEEE 802.11
node behaves differently depending on the status of the Queue when a
packet arrives.  For example, if the Queue is empty when a packet
arrives,
the packet is transmitted right away without any backoff.  But if the
Queue is not empty, the packet enters backoff procedure when it is its
turn for transmission.  Under saturation condition, the Queue is never
empty and the analysis becomes simple.

Thanks!

Byung-Jae

> > I have spent sometimes reading the paper(s) on performance/throughput
> > analysis of IEEE 802.11. In "Bianchi"  paper, he analyse the
> > "sarturation throughput" by assuming that there are always packet for
> > sending.
> >
> > What I am interested is to know with the sending rate \lambda
> > (not in saturation), with probablity of collision p,  what is the rate
> > that will be sent as a function of \lambda.
> >

---

From: [email-masked]
Date: Fri, 10 Oct 2003 00:07:50 +0200

> DATA and ACK plus some IFSs).

I think it is not that easy, consider this:
- a network with just one node, with \lambda=1, has a total throughput = 1
- a network with two nodes, each with \lambda=0.5, has a collision
probability>0, therefore a total throughput <1

(it applies for other values of n of course)

there was a paper/poster in WiOpt last year, dealing with finite load in
analytical model for IEEE802.11 MAC, check it out:

http://www-sop.inria.fr/mistral/personnel/K.Avrachenkov/WiOpt/PDFfiles/Alizadeh50.pdf

hope this helps

imad