Subject: [manet] NEMO or MANET?

From: Wanrong Yu <[email-masked]>
Date: Wed, 8 Oct 2003 17:25:06 +0800 (HKT)

Hi,all
  I have read some drafts of NEMO and MANET, but I 
have some doubts. If there are several mobile networks,
each has one or more MRs(we can imagine several cars), 
these cars meet and want to communication with each 
other, if the fixed infrastructure is unsable for some 
reasons, does the communication possible? and how?
  From the aspect of NEMO, we can loose the restrict 
of the existence of fixed infrastructure, from the 
aspect of MANET, we can extend the single node in the 
ad hoc to a subnet, both will point to the scenario 
above. I think this maybe a new scenario neithor NEMO 
or MANET has covered, and there are new issues arise 
such as routing and security.
   Does there any researchs on this scenario, or some 
current technology have solve the problem perfectly?
   Any comments or advices are welcomed, thanks a lot!

 Wanrong Yu

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Lawrence MacIntyre <[email-masked]>
Date: Wed, 08 Oct 2003 08:11:06 -0400

For MANET, this is no problem at all.  The Mobile Routers (cars) will
discover each other and communicate directly.  There is no need for any
fixed infrastructure.

-- 
    Lawrence MacIntyre     865.574.8696     [email-masked]
               Oak Ridge National Laboratory
High Performance Information Infrastructure Technology Group

---

From: Wanrong Yu <[email-masked]>
Date: Wed, 8 Oct 2003 20:35:07 +0800 (HKT)

> discover each other and communicate directly.  There 
is no need for any
communicate between MR is OK, but how about the nodes 
behinds the MR(there are a LAN), they may don't run an 
ad hoc protocol at all,how could they communicate with 
each other? 
 Wanrong Yu

---

From: Lawrence MacIntyre <[email-masked]>
Date: Wed, 08 Oct 2003 08:59:40 -0400

If the nodes are behind the MR, then the MR should be their default
route.  Therefore, they can communicate via the MRs with the nodes
behind the other MR.

---

From: "Tao Lin" <[email-masked]>
Date: Wed, 8 Oct 2003 09:12:57 -0400

We did an integration study on this topic.  The subnets behind MRs can use
the corresponding MRs as their default gateways.  MRs use a MANET routing
protocol.  Therefore, the hosts in one subnet can reach other nodes in other
subnets.  IPSec was used provide security between MRs.

---

From: Wanrong Yu <[email-masked]>
Date: Wed, 8 Oct 2003 23:41:36 +0800 (HKT)

> subnets.  IPSec was used provide security between MRs.

Would you please offer more information about your 
study on this topic, such as public articles or web 
site,thanks a lot. 
I think the MANET routing protocol running on the MR 
maybe special bacause the MR should maintain the 
network prefix information, just as NEMO extends the 
stardard MIP.

 Wanrong Yu

---

From: Lawrence MacIntyre <[email-masked]>
Date: Wed, 08 Oct 2003 11:42:51 -0400

Depending on the MANET protocol used, the MRs may advertise routes to
subnets that they have behind them, just as they can with
infrastructured protocols, such as OSPF or BGP.  It is easier, of
course, if the MR is a member of the same IP subnet as the hosts behind
it.