Subject: Re: [manet] Re: [manet] NEMO or MANET?

From: "Tao Lin" <[email-masked]>
Date: Wed, 8 Oct 2003 11:58:45 -0400

Hi, Wu Wanrong,

Our integration study is summarized in a paper and currently under review.
So we cannot release the paper now.

As Lawrance pointed out, the scheme we used for subnet hosts is similar to
the scenarios in wired networks.  You can consider one MR and the subnet
behind it as a node in a MANET.  MRs run MANET routing protocols to provide
onnectivities in the backbone network and they also declare subnets behind
them.  One can manually configure or use some other protocols to maintain
the routing tables in those end hosts behind MRs.  Thus, end hosts can
communicate with other hosts in other subnets.

 Tao Lin
 Ph.D. Candidate
 Laboratory for Advanced Networking (LAN)
 ECE Department
 Virginia Tech

----- Original Message ----- 
From: "Wanrong Yu" <[email-masked]>
To: "Tao Lin" <[email-masked]>
Cc: <[email-masked]>
Sent: Wednesday, October 08, 2003 11:41 AM
Subject: [manet] Re: [manet] NEMO or MANET?

> > We did an integration study on this topic.  The
> subnets behind MRs can use
> > the corresponding MRs as their default gateways.  MRs
> use a MANET routing
> > protocol.  Therefore, the hosts in one subnet can
> reach other nodes in other
> >
> > subnets.  IPSec was used provide security between MRs.
>
> Would you please offer more information about your
> study on this topic, such as public articles or web
> site,thanks a lot.
> I think the MANET routing protocol running on the MR
> maybe special bacause the MR should maintain the
> network prefix information, just as NEMO extends the
> stardard MIP.
>
>
>  Wanrong Yu
>
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/manet

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "HyunWook Cha" <[email-masked]>
Date: Wed, 15 Oct 2003 15:30:44 +0900

Hi all,

I re-post my reply about this overwraped issue to two mailing list since
it seems to be rejected as a spam mail because of non-english character.

If I have misunderstood, please enlighten me.

Regards,
HyunWook Cha
 
-----Original Message-----
From: HyunWook Cha [mailto:[email-masked]] 
Sent: Wednesday, October 15, 2003 2:51 PM
To: 'Alexandru Petrescu'
Cc: [email-masked]'; [email-masked]'
Subject: FW: [manet] RE: NEMO or MANET?

Hi Alex,
I apologize that my second comment on A-C-B seems to be repeated. Please
ignore that. 
And, I modify my first comment.
Since an MR which does not have global prefixes requests prefix
delegation, MR_B delegates its prefix to MR_A in case A-(B-C) that I
mentioned below. How about this case where one group(cluster or partion
in terms of MANET) of mobile networks is connected to another group of
mobile netwroks? 
(A->B)-(C->D)
I think prefix delegation should be extended to propagate route
information for prefix of one group to other group although prefix
delegation is not needed.  
If so, why don't you use MANET routing protcols?
If I have misunderstood, please enlighten me.

Thank you in advance.

HyunWook Cha

[Previous discussion is as following. ]

Hi Alex,
Ok, Since the scenario which we are considering is with no
infrastructure, we do not need to mention issue like "HoA expiration".
Please see inline comments.
 
> If A delegates 2002:aaaa:aaaa:b::/52 to B and B delegates 
> 2002:aaaa:aaaa:bc::/54 to C then MR_A will use its usual default route

> to everything different than 2002:aaaa:aaaa::/52 through its usual 
> default route.  MR_A does not need to change its default route.
> 
> It is sufficient for MR_A to a have a route towards the delegated 
> prefix 2002:aaaa:aaaa:b::/52 towards MR_B and MR_B to have a route 
> towards the delegated prefix 2002:aaaa:aaaa:bc::54 towards MR_C.
> 

I agree partially. You assume that MR_C is connected to MR_B after MR_B
is connected to MR_A and configure a prefix delegated from MR_A.
However, let's consider another scenario. 
What happens if MR_C is connected to MR_B before MR_B is connected to
MR_A and configure a prefix delegated from MR_A. In this case, the
prefix which MR_C is delegated from MR_B is not 2002:aaaa:aaaa:bc::56
but 2002:bbbb:bbbb:c/52. 
If a node in network A wants to communicate one with 2002:bbbb:bbbb:c/52
as prefix in network C, it is not possible if default route entry of
MR_A is not changed to MR_B  
or  route entry for 2002:bbbb:bbbb/48 is not added in MR_A when MR_A
delegates its prefix to MR_B. 
If the latter is perfomed, it satisfies this scenario.
But, how about the case where 4 mobile networks are connected in
direction of bottem_up, that is D is connected to C, C to B, and B to A
and a node in A starts to communicate one( 2002:cccc:cccc:d::/52)  in D.
Routing protocls including manet protocols is necessary to do this.

---

From: "HyunWook Cha" <[email-masked]>
Date: Thu, 23 Oct 2003 15:55:13 +0900

Alex,
I am glad to receive your reply though it seems a bit late.
Anyway, please see inline comments.

> 
> HyunWook Cha wrote:
> > Hi Alex, I apologize that my second comment on A-C-B seems to be
> > repeated. Please ignore that. And, I modify my first comment. Since 
> > an MR which does not have global prefixes requests prefix 
> delegation,
> 
> As long as manets or partitions (clusters?) of manets stay 
> separated from the Internet, they don't quite need global 
> prefixes, no?
> 

Right. However, I assume that at least one mobile network prefix be
assingned for a mobile network statically 
for normal nodes in a mobile network to be enable to communicate with
normal nodes in another mobile network.
In this case, duplicate address problem can occur. After all, without
gateways, each MR should configure its global prefix autonomously.
This is not considered in the MANET wg, though. 

> > MR_B delegates its prefix to MR_A in case A-(B-C) that I mentioned
> > below. How about this case where one group(cluster or partion in 
> > terms of MANET) of mobile networks is connected to another group of 
> > mobile netwroks? (A->B)-(C->D) I think prefix delegation should be 
> > extended to propagate route information for prefix of one group to 
> > other group although prefix delegation is not needed.
> 
> I would say that before extending prefix delegation to 
> propagate groups of prefixes in the form of routing 
> information, let's see first how prefix delegation works in 
> simple cases, draft-droms-nemo-dhcpv6-pd-00.txt
> 
> Yes, using MANET routing protocols when there are many manets 
> or many manet partitions makes a lot of sense.  I am not 
> knowledgeable enough on the manet protocols to know whether 
> any does address assignment (or address autoconfiguration), 
> and if not, maybe manet protocols couldl be extended to do 
> that too with DHCP.
> 
Basically, any unique id or prefix for a MR is applicable since manet
routing protocol exists.
MANET wg views topology of a manet more unreliable than you NEMO guys
do.
Thus, address renumbering according to change of the topology is not
suitable. 

> Thanks for comments,
> Alex
> GBU