Subject: [manet] Glomosim -AODV Multi Interface

From: Shiv Mehra <[email-masked]>
Date: Tue, 7 Oct 2003 12:36:26 -0700 (PDT)

Hello friends,

I am using Glomosim 2.03 and trying to modify the AODV Draft version 13 compliant code by Vrishali Wagle to support multiple interfaces.

Broadcasting RREQ’s (Initiating RREQ’s) on multiple interfaces is not a problem but I am having problems in Relaying RREQ’s where the following function is been called

NetworkIpSendRawGlomoMessageWithDelay(). 

I am using the simple multi-mac example shipped with glomosim, which is as follows

Node 0 – Two interfaces (0 and 1)

Node 1 – One Interface (0)

Node 2 – One Interface (0)

Node 0(Interfaace 0) and Node 1 are on frequency 2.4e9

Node 0(Interface 1) and Node 2 are on frequency 2.41e9

Node 10------------------0Node 01 ----------------------0Node2 

When packets are sent from Node 2 – Node 1 everything works fine (RREQ is relayed to Interface 0 of Node 0). But when packets are sent from Node 1 – Node 2 it does not work. (The RREQ seems to be relayed back on interface 0 and not on interface 1 of Node 0). I could not figure out where to make changes even after tracing the function NetworkIpSendRawGlomoMessageWithDelay(). Any kind of help will be highly appreciated.

Best regards,

Shiv

---------------------------------
Do you Yahoo!?
The New Yahoo! Shopping - with improved product search

---

From: "Vrishali P. Wagle" <[email-masked]>
Date: Wed, 8 Oct 2003 11:40:04 -0700 (PDT)

Hello Shiv,

You may want to repalce the calls to NetworkIpSendRawGlomoMessage and the 
NetworkIpSendRawGlomoMessageWithDelay functions with calls to 
NetworkIpSendRawGlomoMessageToMacLayer and 
NetworkIpSendRawGlomoMessageToMacLayerWithDelay respectively and specify  
your corresponding interfaces in these calls.

Kindly let me know.

Vrishali

> When packets are sent from Node 2 – Node 1 everything works fine (RREQ is relayed to Interface 0 of Node 0). But when packets are sent from Node 1 – Node 2 it does not work. (The RREQ seems to be r…

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Shiv Mehra <[email-masked]>
Date: Wed, 8 Oct 2003 15:30:18 -0700 (PDT)

Hello Vrishali,
Thank you for the prompt response. I proceeded as you
had mentioned and everything seems to be working fine.
Thank you once again.
Best regards,
Shiv
--- "Vrishali P. Wagle" <[email-masked]> wrote:
> > I am using Glomosim 2.03 and trying to modify the
> AODV Draft version 13 compliant code by Vrishali
> Wagle to support multiple interfaces.
> > 
> >  
> > 
> > Broadcasting RREQs (Initiating RREQs) on
> multiple interfaces is not a problem but I am having
> problems in Relaying RREQs where the following
> function is been called
> > 
> > Node 0  Two interfaces (0 and 1)
> > 
> > Node 1  One Interface (0)
> > 
> > Node 2  One Interface (0)
> > 
> > When packets are sent from Node 2  Node 1
> everything works fine (RREQ is relayed to Interface
> 0 of Node 0). But when packets are sent from Node 1
>  Node 2 it does not work. (The RREQ seems to be
> relayed back on interface 0 and not on interface 1
> of Node 0). I could not figure out where to make
> changes even after tracing the function
> NetworkIpSendRawGlomoMessageWithDelay(). Any kind of
> help will be highly appreciated.
> > 
> > Best regards,
> > 
> > Shiv
> > 
> > 
> > 

__________________________________
Do you Yahoo!?
The New Yahoo! Shopping - with improved product search
http://shopping.yahoo.com