Subject: [manet] [DSR] problem with click DSR

From: "Carlo Spagoni" <[email-masked]>
Date: Fri, 31 Oct 2003 18:35:08 +0100

Hi,

i'm trying to install and use DSR router of pecolab but there is a few
problem
my configuration....
redhat 9 with kernel 2.4.20 recompiled with support TUN/TAP (source kernel
downloaded from www.kernel.org not include src of redhat)
create a device dev/tap0
device eth1 wireless pcmcia dlink 650 with driver orinoco_cs
click 1.2.4 with dsr support installed with option CC=gcc296 CXX=g++296
./configure --prefix=/usr
and used in user-level mode

my file configuration

./configure-dsr eth1 192.138.198.93
---- confiugre-dsr-----

ifconfig $1 up
ifconfig tap0  $2 netmask 255.255.255.0 mtu 1452
iwconfig $1 essid test mode ad-hoc rate 11M
cd conf
sed 's/AddressInfo(me0 / AddressInfo(me0 '$2');/g' template>temp
sed 's/ethX/'$1'/g' temp>dsr-router.click

after the configuration file i start click
userlevel/click conf/dsr-router.click

-----dsr-router.click---------
 AddressInfo(me0 192.138.198.93);
AddressInfo(my_ether eth1:eth);

ktap :: KernelTap(me0/8);

out0:: Queue->Print(to_kernel)->EtherEncap(0x0800,my_ether,my_ether)->ktap;
out1::Queue->EtherEncap(0x0800,my_ether,ff:ff:ff:ff:ff:ff)
 ->ToDevice(eth1);

dsr_class0::Classifier( 12/0800 0/FFFFFFFFFFFF,12/0800);

dsr_class1::Classifier(09/C8 24/02, -);

dsr_class2::Classifier(09/C8 24/03, -);

dsr_class4::Classifier(09/C8, -);

dsr_class3::Classifier(09/C8 24/06, -);

dsr_class6::Classifier(0/FFFFFFFFFFFF, -);

dsr_rt::RouteTable(IPADDRESS me0);
dsr_reqt::RequestTable(IPADDRESS me0);
dsr_ack::ACKTable;
dsr_arp::ArpTable(IPADDRESS me0,ETHADDRESS my_ether);

in1::FromDevice(eth1,1);

in1->Print(Packet_in_device)->dsr_class6;
dsr_class6[0]->Print(BroadHack)->GetEtherAddress->Strip(14)->Print(To_ARP)->
[1]dsr_arp;
dsr_arp[1]->dsr_class0;
dsr_class6[1]->Discard;

dsr_filter::HostEtherFilter(my_ether,1);

dsr_class0[0]->GetEtherAddress
   ->Strip(14)
   ->Print(Broadcast_Packet_in)
   ->CheckIPHeader()
   ->MarkIPHeader()
   ->GetIPAddress(16)
   ->MarkAdhocHeader(20)
   ->dsr_class1;

dsr_class1[0]->Print(DSR_RouteRequest)->[2]dsr_rt;
dsr_class1[1]->Print(Other_Bcast)->Discard;

dsr_class0[1]->dsr_filter;

dsr_filter[1]->Print(Drop_other)->Discard;
dsr_filter[0] ->Print(My_packet)->GetEtherAddress
   ->Strip(14)
   ->Print(Packet_in)
   ->CheckIPHeader()
   ->MarkIPHeader()
   ->GetIPAddress(16)
   ->MarkAdhocHeader(20)
   ->dsr_class3;

dsr_class3[0]->Print(Recvd_ACK)->[1]dsr_ack;
dsr_class3[1]->dsr_class2;

dsr_class2[0]->Print(dsr_rrep)->[1]dsr_reqt;
dsr_class2[1]->Print(other)->dsr_class4;

dsr_class4[0]->[1]dsr_rt;
dsr_class4[1]->Discard;

dsr_rt[3]->[2]dsr_reqt;

dsr_reqt[1]->[1]dsr_rt;
dsr_rt[1]->out0;

dsr_rt[2]->[0]dsr_reqt;

ktap -> Print(from_kernel)
     ->Strip(14)
     -> Print(from_kernel)
     -> CheckIPHeader
     -> MarkIPHeader
     -> GetIPAddress(16)
     -> [0]dsr_rt;

dsr_rt[0]->Print(out_rtable)
         ->[0]dsr_ack;

dsr_ack[0] ->[0]dsr_arp;
dsr_arp[0]->out1;

dsr_ack[1]->[3]dsr_rt;

dsr_reqt[0]->EtherEncap(0x0800,my_ether,ff:ff:ff:ff:ff:ff)
           ->out1;

------------------------

after this i tested all test in conf directory and it's all ok

i tried to ping two pc with 192.138.198.92-3 and it's ok
i tried to transfer file in scp or ftp but the router do not responded, so i
changed after configuration and before start click mtu to 1452 in tap0
device
typing ifconfig tap0 mtu 1452

now i can ping, transfer file in scp, ftp and http mode, but after i
transfered about 10mb the router stalled and the receiver pc crash with
error
"eth1: ERROR-110 Writing Tx descriptor to BAP" and i must restart.

can you help me!!!

regards,

        Carlo

the use of my cpu is always 100%

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Henrik Lundgren <[email-masked]>
Date: Fri, 31 Oct 2003 22:58:55 +0100 (MET)

On Fri, 31 Oct 2003, Carlo Spagoni wrote:

<SNIP>...

> device eth1 wireless pcmcia dlink 650 with driver orinoco_cs

<SNIP>...

> "eth1: ERROR-110 Writing Tx descriptor to BAP" and i must restart.

This is an error reported by the firmware but is triggered by the
driver. If I remember correctly BAP stands for Buffer Access Path
and has something to do with shuffling data in and out of the
card's memory. Try upgrading to the latest driver (some of the
"BAP-errors" should have been solved in later versions).

cheers,
Henrik