Subject: [manet] Question Regarding Power Consumption

From: "Peter Pham" <[email-masked]>
Date: Thu, 02 Oct 2003 12:05:21 +0950

Hi all 

I have a question regarding the power consumption model (energy model) for ad hoc network.
Does the mobile node takes a fixed amount of energy to transmit a packet ? or different amount for different packet ? (RTS, CTS, DATA)..

The same question is applied for receiving the different packet ?.
Same enery consumption is applied ? 

How about in real life ?

Any advice will be greatly appreciated.

Peter Pham
Peter Phuc Pham

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Justin Lipman <[email-masked]>
Date: Thu, 2 Oct 2003 13:09:57 +1000

Hi Peter,

In my papers I always use a simple first order radio model:

E_tx (k,d) = E_elec * k + E_amp * k * d^2
E_rx (k) = E_elec * k

where

E_elec = 50 nJ/bit
E_amp = 100 pJ/(bit*m^2)

as described in:

Wendi Rabiner Heinzelman and Anantha Chandrakasan and Hari Balakrishnan, 
"Energy-Efficient Communication Protocol for Wireless Microsensor Networks",
Proceedings of the Hawaii International Conference on System Sciences, 2000.

The amount of energy consumed for transmission and reception of frames is 
therefore different depending on frame size in bits (k) and the distance (d).
It should be noted that its not necessarily "d^2" as this should be d^L where 
L may be greater than or equal to 2 depending on propagation environment.

Im not quite sure how the various simulators calculate energy consumption.
Also, not too sure how realistic this is. Perhaps someone in the list can 
provide some additional insight or references to other models that may be 
more useful/accurate.

Hope this helps,
Justin

-- 
PhD Candidate
Telecommunications & Information Technology Research Institute
School of Computer, Electrical & Telecommunications Engineering
University of Wollongong, Australia 
http://www.titr.uow.edu.au/~justin

On Thu, 2 Oct 2003 12:15 pm, Peter Pham wrote:
> Hi all
>
> I have a question regarding the power consumption model (energy model) for
> ad hoc network. Does the mobile node takes a fixed amount of energy to
> transmit a packet ? or different amount for different packet ? (RTS, CTS,
> DATA)..
>

---

From: John Stine <[email-masked]>
Date: Thu, 02 Oct 2003 07:28:03 -0400

Peter,

    Energy consumption is hardware dependent and so specific values will depend on what wireless modem you use.  Since most people use
802.11 modems and I assume the same for you since you mention the control packets of the 802.11 MAC, here are some interesting points that
you should consider.

1. Transmitted power is regulated by a local spectrum management administration.  Since most modems are used to communicate to access
points, where there is not as great a concern for spatial reuse, they tend to operate at there regulated maximum for all transmissions.  I
am unaware of any protocol implemented within these devices that adaptively adjusts power to optimize network performance.  Some devices
have the ability to adjust power but the transition times involved if implemented as an external protocol would probably make this
impractical for a packet wise adjustment.  Also, only a small portion of the total energy consumed in this state can be saved by adjusting
the transmit power since most energy is consumed in powering the modem rather than driving the transmitter.   So, energy consumption for
transmitting a packet will depend almost exclusively on how long (in time) the transmission is.

2.  Energy consumption is based on the state of the receiver.  When not transmitting, the receiver is in a receive state and the rate of
energy consumption is the same whether it is receiving a packet or not.  Paradoxically, it has been observed that the modem may consume less
energy when receiving a packet.  This occurs when a packet not intended for the destination can be dropped.  This observation was made in

Investigating the energy consumption of a wireless network interface in an ad hoc networking environment
                  Feeney, L.M.; Nilsson, M.;
                  INFOCOM 2001. Twentieth Annual Joint Conference of the IEEE Computer and Communications
                  Societies. Proceedings. IEEE , Volume: 3 , 22-26 April 2001
                  Page(s): 1548 -1557 vol.3

3.  These modems have a low energy doze state.  Entering that state means physically disconnecting the node from the network since the node
will not receive any transmissions.  Transition times out of these states can be relatively long and will drive how this capability is
exploited.  By the way, the 802.11 MAC has two energy conservation protocols, one for the DCF and one for the PCF.  I am unaware of any
cases where they are actually used.  The DCF energy conservation protocol would certainly have a negative impact on the performance of an ad
hoc network.

4.  In my own review of specifications of various 802.11 modems a couple of years ago, I found that the relative power of the three states,
transmitting, receiving, and dozing, are in the ranges 1/0.5-0.7/0.04-0.1 with the power in the transmit state ranging from 1.7 to ~2.5
Watts.

With this said, I will restate my first point.  Energy consumption is hardware dependent and so any and all of this information can be wrong
for the modems you use.

John