Subject: RE: [nemo] Re: [manet] NEMO or MANET?

From: "Manfredi, Albert E" <[email-masked]>
Date: Thu, 16 Oct 2003 14:20:51 -0400

If the auto-configured address is good for only seconds, then how would a host in the MANET know how to reach another host in the MANET? Worse, a host outside the MANET find a host inside the MANET? Mobile IP won't work in these circumstances. Nor would the DHCP model, in which the host with the autoconfigured address is expected to initiate the session.

Do you assign names, and have a very rapid DNS associated with each MANET? (Even that seems inplausible, especially if the address of the DNS servers keeps changing.)

Bert

> -----Original Message-----
> From: Christophe Jelger [mailto:[email-masked]]
> Sent: Thursday, October 16, 2003 8:02 AM
> To: [email-masked]
> Subject: Re: [nemo] Re: [manet] NEMO or MANET?
> 
> 
> Hi all,
> 
> I agree with Charlie Perkins, i.e. a short lifetime should be 
> assigned 
> to addresses being autoconfigured. The main reason is that (I 
> believe) 
> an inherent feature of an address autoconfiguration protocol 
> must be its 
> reactiveness to topological changes. The only way of doing this is to 
> periodically refresh the address assignment, whatever method 
> is used to 
> perform it.
> 
> Therefore if the address is refreshed frequently (say, every 
> 2s), there 
> is no need for the address lifetime to be much longer than 2s. In any 
> case, if an address is not refreshed in time, it probably 
> means there is 
> a problem (e.g. network partitioning) and the address should 
> therefore 
> no be used any longer --> with a short lifetime, the adress would be 
> removed automatically by the host OS.
> 
> Regards,
> Christophe Jelger
> 
> 
> > I can make one suggestion that hasn't been
> > discussed very much.  Perhaps we should assign
> > a lifetime to all autoconfigured addresses in
> > an ad hoc network.  That way, it is less likely
> > that two nodes would have the same address for any
> > extended period of time.  Of course, the lifetime
> > requires periodic revalidation, not necessarily
> > relinquishing an address that is currently
> > configured, as long as the revalidation does
> > not fail.
> > 
> > Regards,
> > Charlie P.

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Charlie Perkins <[email-masked]>
Date: Thu, 16 Oct 2003 14:13:50 -0700

Hello folks,

The address could be good for tens of minutes, not just 2 seconds.
Maybe some analysis is possible whereby one could show the probabiliy
of address collision as a function of network size, network density, average
speed, and address lifetime.  Faster networks would experience partitions
more often, as would sparser networks.

Then we could make the lifetime selection depend on the needs of the
network, reducing guesswork.

Regards,
Charlie P.

---

From: Einar Vollset <[email-masked]>
Date: Fri, 17 Oct 2003 09:33:21 +0100

Even if you don't consider the (possible) overhead of assigning new 
addresses, wouldn't
changing the addresses of the network leave it in a rather dynamic 
state, particularly if the
address lifetime was small compared to the number of nodes in the 
network?
What I mean is, the network would never reach a "steady-state" even if 
there at one point in
time seized to be any more partitions or membership changes.

Cheers,

Einar

On Thursday, Oct 16, 2003, at 22:13 Europe/London, Charlie Perkins 
wrote:

>> If the auto-configured address is good for only seconds, then how 
>> would a host in the MANET know how to reach another host in the 
>> MANET? Worse, a host outside the MANET find a host inside the MANET? 
>> Mobile IP won't work in these circumstances. Nor would the DHCP 
>> model, in which the host with the autoconfigured address is expected 
>> to initiate the session.
>>
>> Do you assign names, and have a very rapid DNS associated with each 
>> MANET? (Even that seems inplausible, especially if the address of the 
>> DNS servers keeps changing.)
>>
>> Bert
>>
>>
>>
>>> assigned to addresses being autoconfigured. The main reason is that 
>>> (I believe) an inherent feature of an address autoconfiguration 
>>> protocol must be its reactiveness to topological changes. The only 
>>> way of doing this is to periodically refresh the address assignment, 
>>> whatever method is used to perform it.
>>>
>>> Therefore if the address is refreshed frequently (say, every 2s), 
>>> there is no need for the address lifetime to be much longer than 2s. 
>>> In any case, if an address is not refreshed in time, it probably 
>>> means there is a problem (e.g. network partitioning) and the address 
>>> should therefore no be used any longer --> with a short lifetime, 
>>> the adress would be removed automatically by the host OS.
>>>
>>> Regards,
>>> Christophe Jelger
>>>
>>>
>>>

----------------------------------------
Einar Vollset
PhD Student
School of Computing Science
University of Newcastle, UK
http://vollset.org
-----------------------------------------

---

From: Christophe Jelger <[email-masked]>
Date: Fri, 17 Oct 2003 14:23:37 +0200

Hi,

Well indeed the network would stay in a quite dynamic state, but isn't 
that the inherent nature of an ad hoc network ? ;-)

About Charlie Perkins comments, I think even if we consider that address 
collisions (almost) never occur (as it will probably be the case with 
IPv6), address assignment should still be very dynamic for different 
reasons :

1. If a network partition occurs, a node may become unreachable via its 
current Internet gateway : the node has to change its address (if 
possible) with a prefix of a reachable gateway.
2. The current gateway of a node becomes unreachable : node has to 
choose another gateway and therefore another address
3. If shortest path routing is favored, and/or minimal routing via the 
ad hoc network is prefered, then a node would keep changing its address 
to be reachable via the closest gateway (with respect to its current 
position).

Of course, address "unstability" leads to many problems, especially with 
DNS. I have to admit that DNS issues in ad hoc networking are not very 
clear to me ... in particular I don't know if the MANET WG has reached 
some consensus on these issues, such as :

1. How can a MANET node be "DNS reachable" from outside the MANET ?
2. If some sort of automatic registration is used, what DNS server would 
be in charge of a node's name ?

Regards,
Christophe

Einar Vollset wrote:
> address lifetime was small compared to the number of nodes in the network?
> On Thursday, Oct 16, 2003, at 22:13 Europe/London, Charlie Perkins wrote:
> 
>>
>> Hello folks,
>>

---

From: "Marcin Michalak" <[email-masked]>
Date: Fri, 17 Oct 2003 15:20:21 +0200

On 17 Oct 2003 at 14:23, Christophe Jelger wrote:

...cut...
> be in charge of a node's name ?

Hello,
 I believe this problem can be solved by Mobile IP. Home address 
being registered in the DNS server, and Home Agent taking care of 
redirecting the connections. Of course, when a node is changing the 
address rapidly there can be a problem, but I don't believe this 
issue should be solved in the DNS server.
 Regards,
  Marcin
----------------------------------------------------------
Marcin Michalak		Research Engineer
Mobile: +41 79 330 83 51	Telscom AG

---

From: Manish Karir <[email-masked]>
Date: Fri, 17 Oct 2003 10:03:54 -0400

Joe, Scott,

Are address (auto)configuration issues on the manet charter/recharter??
What about issues related with gateway operation (manet-terrestrial)??

-manish

---

From: Christophe Jelger <[email-masked]>
Date: Thu, 23 Oct 2003 17:08:40 +0200

To the chairs,

Is this subject (address autoconf) going to be discussed at the next WG 
meeting in Mineapolis ? What about multicast routing in ad hoc networks ?

Regards
Christophe