Subject: [manet] Performance Evaluation of MANET Protocols in NS: Help!!

From: "Karun Verma" <[email-masked]>
Date: Thu, 09 Oct 2003 11:19:37 +0530

Dear Friends,

Please help me how can i make a simulation that can evaluate various MANET Protocols. How can i measure the features of each protocol described in NS. i have installed ns 2.26 on Linux 7.2.

Thanx in Advance

Karun Verma

Attention all artisans! Sell Diwali creations online. Register now!

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Daniel Lang <[email-masked]>
Date: Thu, 9 Oct 2003 10:57:08 +0200

Dear Karun,

(please send Emails as plain text, not HTML attachment.)

Karun Verma wrote on Thu, Oct 09, 2003 at 11:19:37AM +0530:
[ HTML code snipped ]

Performance evaluation is a complex field, especially with MANETs.
It depends on what you are looking for. There is no simple instruction,
how to do this (with NS-2 or other simulators).

A rough overview would be:

- Decide in which kind of application context you want to evaluate
  the routing protocols.
- Design a set of simulation scenarios, that closely model your
  application context. A scenario consist of at least movement
	behaviour and traffic behaviour of the nodes.
- Implement the scenarios with the methods given by the simulation
  software you are going to use (e.g. NS-2/otcl).
- For each scenario create a number of variants possibly based on
  different random seed to get good statistical dissemination.
- Run the simulations for each scenario variant and for each
  routing protocol to evaluate.
- Process the simulation results. If you have to deal with NS-2
  tracefiles, this could be an ugly task.
- Evaluate the simulation results.
- Draw a conclusion.

I am currently writing my dissertation about this subject.
I hope to be able to publish it by the end of this year.

HTH,
 Daniel
-- 
IRCnet: Mr-Spock  - My name is Pentium of Borg, division is futile, you
                                                will be approximated. - 
 Daniel Lang * [email-masked] * +49 89 289 18532 * http://www.leo.org/~dl/