Subject: [manet] Path cache in DSR

From: Young-Jun Lee <[email-masked]>
Date: Wed, 29 Oct 2003 20:25:21 -0500 (EST)

Hello all,

I have a question about the DSR route cache.
Suppose that the route cache is implemented in form of "path cache"
not "link cache".
Then, what happens if a node A receives a RREP for target D saying
B -> C -> D ?

Obviously, the node A will cache a route A -> B -> C -> D.
What about the paths to each intermediate node?
Should A also cache the routes for paths
A -> B
A -> B -> C
or does it cache the path A -> B -> C -> D only?

Does anybody have an idea of this?
Thanks in advance.

Young

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Dave Maltz <[email-masked]>
Date: Thu, 30 Oct 2003 07:38:28 -0500

In message <[email-masked]>, Young-J
>or does it cache the path A -> B -> C -> D only?

The DSR spec allows either implementation.  In mine, I store only one
route, A,B,C,D, but when I query the cache for a route I search for
subroutes as well as full routes, so Query(C) will return A,B,C.  The
externally observed behaviour of the cache is the same for either
implementation.

Note that we also experimented with the "mobicache," where inserting
the routes A,B,C,D and A,C results in the creation of (A,B) (A,C,D).
My recollection is that the pathcache worked about as well as the
mobicache on the scenarios we were using.

Cheers,
 -dam

---

From: Young-Jun Lee <[email-masked]>
Date: Fri, 31 Oct 2003 14:46:21 -0500 (EST)

Thanks for the reply.
I have one more question.
If the DSR route cache is implemented as you explain,
and if a node wishes to select the shorted (hop count) route
to a destination, it should search the entire route cache every time,
which is not efficient especially in case there are huge amount of
route caches.
Is this true?
Thanks.

Young