Subject: [manet] aodv from ns-2.1b9 to ns-2.26

From: Vin <[email-masked]>
Date: Wed, 4 Feb 2004 07:22:01 -0800 (PST)

Hi all. This is a question i want to address to people
who have used aodv on both ns 2.1b9 and ns 2.26 and i
think there would be many on this forum.

I have a modified AODV protocol for the 2.1b9 version
which i acquired from someone else. To evaluate it, i
replaced the aodv related files in my ns 2.26
installation with these modified aodv files which were
written for ns 2.1b9. I had to do a couple of simple
hacks to get it running.

According to the person who implemented it, this
modified aodv gave better performance for the inputs
he used. But when i run it, i find only degradation of
performance. so my question is are the results itself
invalid or is it because of running 2.1b9 code on ns
2.26? Maybe ns 2.26 has done some modifications to
improve performance and at the sametime penalizing old
version code.
I am not much familiar with the evolution of aodv over
these two versions and would appreciate some insight
from someone who does.

Thanks in advance,
Vin

__________________________________
Do you Yahoo!?
Yahoo! SiteBuilder - Free web site building tool. Try it!
http://webhosting.yahoo.com/ps/sb/

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Ali Hamidian <[email-masked]>
Date: Fri, 13 Feb 2004 11:10:56 +0100

Hi Vin,

Vin wrote:

>2.26?
The 802.11 implementation in ns2.26 (mac-802.11.cc) contains some bugs 
(there was a discussion about it on the mailing list) so running a 
wireless simulation in ns-2.26 gives worse results compared to ns-2.1b9 
(which has a better 802.11 implementation). I think they have fixed the 
802.11 problems of ns-2.26 in the latest release ns-2.27.

> Maybe ns 2.26 has done some modifications to
Regards
Ali