Subject: Re: [manet] AODV Collision Avoidance

From: [email-masked]
Date: Thu, 5 Feb 2004 10:31:19 +1100

Hi Jeffrey,

AODV uses a broadcast jitter during RREQ propagation to 
minimize collisions. You can also randomize the RREQ packet 
propagation time with the Jitter (as is done in GlomoSim), to 
also reduce collisions.

Hope That helped.

Mehran 

---- Original message ----
>Date: Wed, 04 Feb 2004 16:59:17 -0500
>From: "Schwentner, Jeffrey" <[email-masked]>  
>Subject: [manet] AODV Collision Avoidance  
>To: [email-masked]
>
>I am working on a project which requires a very low-level 
implementation of an Ad-Hoc routing mechanism.  I found the 
AODV concept to be quite interesting, and had a question 
regarding the transmission of packets.
> 
>Consider the case when a node transmits a RREQ to it's 
neighbors.  When the neighbors receive the packet and prepare 
to send it on to their neighbors collisions might occur if 
they transmit at the same time.  Has there been any thought 
in the group to incorporating some kind of delay scheme to 
avoid simultaneous transmission following packet reception?  
My implementation requires the use of a half-duplex RF 
transceiver, which is why I cannot detect collisions during 
transmission!
>
>Any suggestions would be greatly appreciated,
>
>Jeff Schwentner
>> Lockheed Martin Simulation, Training & Support
>email: [email-masked]
>
>
>_______________________________________________
>manet mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/manet
>
Mehran Abolhasan 
B.E Computer, PhD
Research Fellow -- Smart Internet Technology CRC  (SITCRC)
Telecommunications and IT Research Institute (TITR)
University of Wollongong, Northfields Ave, NSW 2522, Australia
Phone: +61 2 4221 5491
Fax: +61 2 4221 3277
Email:[email-masked]

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Schwentner, Jeffrey" <[email-masked]>
Date: Fri, 06 Feb 2004 10:00:58 -0500

Philippe,

I think that is my fundamental problem, I have no MAC or Link Layer.  I am using a simple transceiver (Half-Duplex) and a microcontroller with limited resources.  I will have to implement a collision avoidance mechanism directly.  I think my best approach is to adopt the 802.11 CSMA-CA implementation, ultimately incorporating some random back off time.  Thanks for the input.

Regards,

Jeff

-----Original Message-----
From: Philippe Jacquet [mailto:[email-masked]]
Sent: Thursday, February 05, 2004 10:31 AM
To: Schwentner, Jeffrey; [email-masked]
Subject: Re: [manet] AODV Collision Avoidance

Hi, Jeff,

If the MAC layer provides its service in "best effort" (like with CSMA-CA),
it is preferable not to stress the link layer. Why not you use a random time
jitter before retransmission? Tests show  significant reduction in collision
rate when flooding are too frequent. There is no need to implement it at low
level. We have specified a time jitter in OLSR RFC, but there are many other
equivalent way and I don't see any problem to adapt them to AODV
implementation.

Best regards,
Philippe
----- Original Message -----
From: Schwentner, Jeffrey <[email-masked]>
To: <[email-masked]>
Sent: Wednesday, February 04, 2004 10:59 PM
Subject: [manet] AODV Collision Avoidance

> I am working on a project which requires a very low-level implementation
of an Ad-Hoc routing mechanism.  I found the AODV concept to be quite
interesting, and had a question regarding the transmission of packets.
>
> Consider the case when a node transmits a RREQ to it's neighbors.  When
the neighbors receive the packet and prepare to send it on to their
neighbors collisions might occur if they transmit at the same time.  Has
there been any thought in the group to incorporating some kind of delay
scheme to avoid simultaneous transmission following packet reception?  My
implementation requires the use of a half-duplex RF transceiver, which is
why I cannot detect collisions during transmission!