Subject: [manet] ACTIVE_ROUTE_TIMEOUT in AODV (RFC 3561)

From: [email-masked]
Date: Wed, 25 Feb 2004 11:50:12 +0100

Hi,

I did some GloMoSim simulations with AODV and experimented with the setting of the ACTIVE_ROUTE_TIMEOUT value. For the scenarios that I tested, I was surprised to see how little the performance degraded when I chose very large timeout values. I have obviously done something wrong - either not selected the right simulation scenarios or not measured the right things.

To help me on the way, could someone please tell me the most important networking aspects that prohibits the choice of a large ACTIVE_ROUTE_TIMEOUT. What are the main trade-offs when setting this value? Or could someone give me a pointer to relevant publications.

Thanks,
Paal

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Erik Nordström <[email-masked]>
Date: Wed, 25 Feb 2004 12:56:09 +0100

hi,

Isn't it the case that routes are often preempted by other events, such
as link break (link layer feedback or HELLO messages), with the result
that ACTIVE_ROUTE_TIMEOUT doesn't really matter that much?

//Erik

---

From: "Sukanta K. Hazra" <[email-masked]>
Date: Wed, 25 Feb 2004 20:13:50 +0800

Hi!

Unless its a static network with very stable conditions, route
information changes even before ACTIVE_ROUTE_TIMEOUT has a chance to
come into play.

- Sukanta

----- Original Message -----
From: "[email-masked]"
Date: Wed, 25 Feb, 2004 18:50 SGT
Subject: [manet] ACTIVE_ROUTE_TIMEOUT in AODV (RFC 3561)

-- 
Sukanta K. Hazra (Mr.)	<[email-masked]>
Institute for Infocomm Research
Tel: +65 6874-1953 Fax: +65 6776-8109
Homepage: http://www1.i2r.a-star.edu.sg/~sukanta/

---

From: Erik Nordström <[email-masked]>
Date: Wed, 25 Feb 2004 13:51:03 +0100

Just wanted to add that ACTIVE_ROUTE_TIMEOUT probably just works as a
garbage collection timer, making sure that there is no stale information
in the network.

/Erik

---

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 25 Feb 2004 08:23:48 -0800

Hello folks,

ACTIVE_ROUTE_TIMEOUT was designed to reduce the
effect of useless routes on the rest of the protocol.
I expect that as nodes move faster, its value should
decrease.  Expiring old routes is valuable, for
two reasons:
- Reduce latency by avoiding the attempt to use
  broken routes, and
- Reduce extraneous route repair operations

I would like to see an in-depth study of the
route timeout values versus performance versus
relative node speeds.  It would be especially
nice if the value could be adaptive, so that
the characteristics of the route would depend
upon the movement characteristics of the nodes
offering the route to the endpoints.

Regards,
Charlie P.

---

From: Vin <[email-masked]>
Date: Wed, 25 Feb 2004 09:54:24 -0800 (PST)

I also think that your traffic model plays a part.If
you send packets continously from a starting point in
time, ACTIVE_ROUTE_TIMEOUT never gets a chance to come
into play.It should come into play only if that route
has been unused for that period of time.many
simulations done on ns-2 are based on cbr traffic
starting at a certain time and going on till end of
simulation which isnt a good way to study the effect
of  ACTIVE_ROUTE_TIMEOUT.
Regards,
Vinod
 
--- [email-masked] wrote:
> Hi,
> 
> I did some GloMoSim simulations with AODV and
> experimented with the setting of the
> ACTIVE_ROUTE_TIMEOUT value. For the scenarios that I
> tested, I was surprised to see how little the
> performance degraded when I chose very large timeout
> values. I have obviously done something wrong -
> either not selected the right simulation scenarios
> or not measured the right things.
> 
> To help me on the way, could someone please tell me
> the most important networking aspects that prohibits
> the choice of a large ACTIVE_ROUTE_TIMEOUT. What are
> the main trade-offs when setting this value? Or
> could someone give me a pointer to relevant
> publications.
> 
> Thanks,
> Paal
> 

=====
Vinod Namboodiri

Graduate Student
Department of Electrical and Computer Engineering
University of Massachusetts, Amherst

__________________________________
Do you Yahoo!?
Yahoo! Mail SpamGuard - Read only the mail you want.
http://antispam.yahoo.com/tools