Subject: [manet] How to simulate one or more malicious node(s) in NS-2

From: "#LI ZHUOWEI#" <[email-masked]>
Date: Mon, 9 Feb 2004 20:07:37 +0800

Hi,

I am doing some research to provide security to MANET. However, I am stuck by the way how to simulate one or more malicious node(s) in one MANET scenario, such the nodes that drops the forwarding packets intentively, or absorbs all packets to it, or duplicates the forwarding packets. Is there any solution to this problem. Any suggestion is welcome.

Regards!

Sincerely yours,
Li Zhuowei
-----------------------------------------------------------------------------
Ph.D. candidate
Email: [email-masked]                           
More: http://www.cais.ntu.edu.sg/~zhuowei
　

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Peter Pham <[email-masked]>
Date: Mon, 9 Feb 2004 23:03:09 +1030 (CST)

Hi 
I think that you can do it without much of pain from modifying codes in 
the mac and wireless-phy. 

Another way is to insert a thin layer to do this job. 

Best Regards.

Peter Phuc Pham
==========================================

---

From: [email-masked]
Date: Mon, 9 Feb 2004 13:09:07 -0600 (CST)

Hi,

As Peter mentions, you have to just change the code in the protocol layer,
in which you want to implement. Set some nodes as malisious, and when
processing the packets from such nodes, write code to drop them.

I have implemented malisious nodes, that drop data packets, in the network
layer for AODV, in Glomosim. If you are interested in it, mail me and I
can forward the code.

Sanjay

>> I am doing some research to provide security to MANET. However, I am
>> stuck by the way how to simulate one or more malicious node(s) in one
>> MANET scenario, such the nodes that drops the forwarding packets
>> intentively, or absorbs all packets to it, or duplicates the
>> forwarding packets. Is there any solution to this problem. Any
>> suggestion is welcome.
>>
>>
>> Regards!
>>
>> Sincerely yours,
>> Li Zhuowei

---

From: Bryan Hogan <[email-masked]>
Date: Fri, 20 Feb 2004 01:54:24 +0000 (GMT)

Hi,

If you were to use DSR, you can do it by modifying the recv() method
such that packets meeting certain critera are droped or corrupted.

more info on this can be found at the below address

Bryan
Bryan's DSR FAQ - http://www.geocities.com/b_j_hogan

On Mon,
9 Feb 2004, #LI ZHUOWEI# wrote:

> ¡¡