Subject: [manet] Very basic questions

From: [email-masked]
Date: Tue, 24 Feb 2004 10:49:49 -0700

Hello all,

I have some very basic questions about routing in MANETs. 
I have some experience with IPv4 routing in fixed systems
which may be causing me some confusion when it comes to MANETs.

My stick figure below is intended to represent two systems,
X and Y.  Each system has an Ethernet LAN interface and 
a Wireless interface.  

The Ethernet LAN on system X is subnet A, the wireless
interface has an address on subnet B.

The Ethernet LAN on system Y is subnet D, the wireless
interface has an address on subnet C.

                      B          C                       
                                                       
                      V          V
                      |          |
              ------- |          | -------      D
      A       |     |--          --|     |__ _|_ _|_ _
  _ _|_ _|_ __|  X  |              |  Y  |  |   |   |
   |   |   |  |     |              |     |
              -------              -------

I don't see how systems X and Y can communicate over the 
wireless interfaces unless these interfaces are on the same
subnet.  Furthermore, if a similar system, Z, moves into the
area how can it communicate unless its wireless interface is
also on the same subnet?

I have read that in a MANET the address is tied to the device
not a topological location and that subnets don't really have
a meaning in a MANET.  Does this mean that the wireless
interfaces all have vastly different IP addresses and can be
arbitrarily assigned?

What would the route table entry on system X look like
to route a packet to system Y?  What would the route entry
on system X look like in order to route packets to a
system on Ethernet LAN D attached to system Y?

Finally, do the answers depend on which MANET protocol is
being used?

I have read several papers about DSR, AODV and OLSR and I am
still missing this concept.  

I would greatly appreciate any help this group can give.

Thanks,

Richard Herron
L-3 Communications

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Sukanta K. Hazra" <[email-masked]>
Date: Wed, 25 Feb 2004 14:29:15 +0800

Hi Richard,

Most MANET routing protocols use host based routing, each node's routing
table keeps an entry to a host. On the other hand in traditional IP
routing, the nodes have routing table have entries  to networks. That
is where the subnet concept comes into play, its a mean of aggregation.

Regards,
Sukanta
----- Original Message -----
From: "[email-masked]"
Date: Wed, 25 Feb, 2004 01:49 SGT
Subject: [manet] Very basic questions

-- 
Sukanta K. Hazra (Mr.)	<[email-masked]>
Institute for Infocomm Research
Tel: +65 6874-1953 Fax: +65 6776-8109
Homepage: http://www1.i2r.a-star.edu.sg/~sukanta/

---

From: Joe Macker <[email-masked]>
Date: Wed, 25 Feb 2004 09:59:21 -0500

>is where the subnet concept comes into play, its a mean of aggregation.

Most MANET Routing can support prefixes as well just like normal IP routing.
there is often a misconception that MANETs do not allow for attached networks. 
So there's no problem here.

What is different is that unlike "some" wired protocols..
MANET protocol neighbor interface associations do not require 
the interfaces to be from some preconfigured subnet space.

More recent wired protocols (e.g., OSPFv3) also allow this too.