Subject: RE: [manet] New draft on connectivity scenarios and autoconfigura tion issues

From: [email-masked]
Date: Mon, 1 Nov 2004 09:54:14 -0600

First of all some comments (nothing personal of course). 

Overall I think this will help to serve as an architectural starting point, a 10,000 foot view if you will. It does need to be cleaned up from an editorial perspective (grammar and spelling errors mostly). Since the group probably does not want to read my spelling nitpicks, I will leave those in a private follow up email. Besides, I'm an engineer, not an English professor.

Technical Discussion
--------------------

Section 2. Node: Do we want to tie ourselves to IPv4/IPv6 as a node definition. Perhaps IP-Based would be best here. After all, we never know if someone will come up with some sort of IPvWireless in the distant future.

Section 3.2.1 Surveillance networks: I do not think the generalization that nodes will remain stationary is a good one. Surveillance (or preferably called Sensor networks), can have a dynamic nature to them depending on the application. Take, for example, a gas monitoring van (often used by gas companies) with several sensors on it. The van is in constant motion throughout the network. Perhaps a 3rd case should be added here. In addition a "Heavyweight" node scenario should probably be added where each node can act as a gateway/router if necessary.

Section 4.1 I think a scenario needs to be addressed in this section that discusses the transient/isolated MANET issue. Take for example a MANET that periodically comes into contact with a gateway. That MANET will transition between an isolated MANET and a connected MANET. The potential for this happening in a mobile environment is high.

Section 4.1.3 Volatile network scenario: What happens when the MANET is volatile? Let's take this case into consideration... 2 MANETs join with say x nodes that have the same address. The MANETs separate into two different networks with one MANET getting several of the duplicate addresses. Capability will have to exist in each MANET "sub-network" to broker network addresses.

Section 4.2.4 Multiple Gateway routing and addressing issues (first paragraph): Isn't this issue solved by the various ad-hoc routing protocols out there. Do we really need this to be part of a dynamic configuration protocol?

Section 4.2.4 Paragraph 3 It is desirable that traffic follows the same path uplink and downlink within the MANET: this is because the uplink path towards the default gateway is guaranteed to be optimal by routing the protocol.
The follow up statement doesn't really prove anything. Just because an uplink path is optimal, doesn't always mean the downlink is. Take for example mobile nodes that have different transmit power levels, antenna heights, etc...

Section 4.2.9 Paragraph 2. Expand on this. More discussion on source routing would be nice :)

Section 5 Nodes with specific functionalities: It might be good to distribute the services across the MANET network. Or better yet, actually have "back-up" services. Nodes should have the capability to "jump in" if connectivity is lost.

Section 6. I think something needs to be considered here. There are potential security issues that could arise (such as malicious nodes on a network). Perhaps a discussion on dynamic network configuration security would be good.

I'm sure I will get some comments on some these points (after all, the morning coffee is only now kicking in so my mind is not fully revved up yet :)) but I just thought I would share some thoughts.

-Mac Stevens

---------------------------------------------
McLanahan Stevens
Sr. Software Engineer
General Dynamics Advanced Information Systems

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of
Ruffino Simone
Sent: Monday, November 01, 2004 3:29 AM
To: [email-masked]
Subject: [manet] New draft on connectivity scenarios and
autoconfiguration issues

Hi to all,

a new draft was submitted as individual submission, titled
"Autoconfiguration in a MANET: connectivity scenarios and technical
issues". 

Goal of the draft is to describe the scenarios, in which a MANET can be
connected to an external network (by means of either wired of wireless
links) and to list some of the technical issues, which are related to
autoconfiguration and global connectivity, that arise in such scenarios.

Comments welcome and appreciated !

Thanks in advance,
Simone Ruffino

> A New Internet-Draft is available from the on-line Internet-Drafts
directories.
>
>
> Title: Autoconfiguration in a MANET: connectivity scenarios and 
>   technical issues
> Author(s): S. Ruffino, et al.
> Filename: draft-ruffino-manet-autoconf-scenarios-00.txt
> Pages: 26
> Date: 2004-10-19
>
> MANET interconnection with external networks enables a number of
>    usage scenarios, but generates also a number of technical issues,
>    mainly related with node autoconfiguration and global connectivity.
>    This Internet Draft aims at characterizing global connectivity
>    scenarios and listing technical issues related to IP address
>    autoconfiguration which are implied by such scenarios and should be
>    addressed by a generic solution.
>
> A URL for this Internet-Draft is:
>
http://www.ietf.org/internet-drafts/draft-ruffino-manet-autoconf-scenari
os-00.txt

Gruppo Telecom Italia - Direzione e coordinamento di Telecom Italia S.p.A.

====================================================================
CONFIDENTIALITY NOTICE
This message and its attachments are addressed solely to the persons
above and may contain confidential information. If you have received
the message in error, be informed that any use of the content hereof
is prohibited. Please return it immediately to the sender and delete
the message. Should you have any questions, please send an e_mail to 
[email-masked]. Thank you
====================================================================

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Ruffino Simone <[email-masked]>
Date: Fri, 05 Nov 2004 17:43:43 +0100

Dear Mac Stevens,

Thanks a lot for your review. A lot of useful and interesting observations. See below for inline comments (on your comments). 
Will you attend IETF meeting next week ?

Best Regards,
Simone

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: lunedì 1 novembre 2004 16.54
> To: [email-masked]
> Subject: RE: [manet] New draft on connectivity scenarios and autoconfigura
> tion issues
> 
> Overall I think this will help to serve as an architectural starting point,
> a 10,000 foot view if you will. 

[Ruff] Yes, it is a starting point, aimed at defining both reference scenarios and problem statement. As a matter of fact, we don't think that our draft is a complete problem statement, which, in our opinion, should be addressed in a future version of the draft (or maybe in a different one). 

> It does need to be cleaned up from an
> editorial perspective (grammar and spelling errors mostly). Since the
> group probably does not want to read my spelling nitpicks, I will leave
> those in a private follow up email. Besides, I'm an engineer, not an
> English professor.

[Ruff] Sorry for that. Next version will be polished.... :)

> 
> Technical Discussion
> --------------------
> 
> Section 2. Node: Do we want to tie ourselves to IPv4/IPv6 as a node
> definition. Perhaps IP-Based would be best here. After all, we never know
> if someone will come up with some sort of IPvWireless in the distant
> future.
> 
> Section 3.2.1 Surveillance networks: I do not think the generalization
> that nodes will remain stationary is a good one. Surveillance (or
> preferably called Sensor networks), can have a dynamic nature to them
> depending on the application. Take, for example, a gas monitoring van
> (often used by gas companies) with several sensors on it. The van is in
> constant motion throughout the network. Perhaps a 3rd case should be added
> here. In addition a "Heavyweight" node scenario should probably be added
> where each node can act as a gateway/router if necessary.
> 

[Ruff] We were not aware of applications of this kind. For sure this could bring to a new scenario, or maybe we could expand one of the already described scenarios.

> Section 4.1 I think a scenario needs to be addressed in this section that
> discusses the transient/isolated MANET issue. Take for example a MANET
> that periodically comes into contact with a gateway. That MANET will
> transition between an isolated MANET and a connected MANET. The potential
> for this happening in a mobile environment is high.
> 

[Ruff] From our point of view, this could be an addition to sec. 3.2 "MANET connected to an external network". Actually, the loss of connectivity of the gateway can be classified to the scenario addressed in 3.2.2 "Mobile Gateways"
 
> Section 4.1.3 Volatile network scenario: What happens when the MANET is
> volatile? Let's take this case into consideration... 2 MANETs join with
> say x nodes that have the same address. The MANETs separate into two
> different networks with one MANET getting several of the duplicate
> addresses. Capability will have to exist in each MANET "sub-network" to
> broker network addresses.

[Ruff] Maybe I don't get your point here, but I think this is an issue a DAD mechanism must solve as soon as the two MANETs join for the first time. If this is the case, when the 2 MANETs separate there are no duplicate addresses.

> 
> Section 4.2.4 Multiple Gateway routing and addressing issues (first
> paragraph): Isn't this issue solved by the various ad-hoc routing
> protocols out there. Do we really need this to be part of a dynamic
> configuration protocol?

[Ruff] Yes, this is not an issue, it's a feature! For example, proactive routing protocols already handle it. We meant to give emphasis to the benefits this feature can bring.

> 
> Section 4.2.4 Paragraph 3 It is desirable that traffic follows the same
> path uplink and downlink within the MANET: this is because the uplink path
> towards the default gateway is guaranteed to be optimal by routing the
> protocol.
> The follow up statement doesn't really prove anything. Just because an
> uplink path is optimal, doesn't always mean the downlink is. Take for
> example mobile nodes that have different transmit power levels, antenna
> heights, etc...
> 

[Ruff] OK, we based our statement considering only hop-count metric. If different kinds of metric are available, then you're right.

> Section 5 Nodes with specific functionalities: It might be good to
> distribute the services across the MANET network. Or better yet, actually
> have "back-up" services. Nodes should have the capability to "jump in" if
> connectivity is lost.
> 
> Section 6. I think something needs to be considered here. There are
> potential security issues that could arise (such as malicious nodes on a
> network). Perhaps a discussion on dynamic network configuration security
> would be good.
> 

[Ruff] Yes, I agree, a security consideration section could be helpful. Let me say that a malicious node located within a MANET can do many many other bad things, e.g. to the routing protocols...really too many to enumerate here.

> 
> 
> I'm sure I will get some comments on some these points (after all, the
> morning coffee is only now kicking in so my mind is not fully revved up
> yet :)) but I just thought I would share some thoughts.
> 
> -Mac Stevens
>