Subject: [manet] Focus for next DC MANET meeting

From: Joe Macker <[email-masked]>
Date: Thu, 04 Nov 2004 11:35:50 -0500

The DC MANET meeting is presently Nov. 10, Wed afternoon 1300-1500.
Unfortunately this got moved and now collides with NEMO.

As a heads up, I am still discussing charter update details with the ADs.
We should be wrapping this up soon. In meantime, here is the intended scope for the upcomging meeting.

The main discussion for the upcoming meeting will be on the following routing area work items.
These are intended to be proposed standard track work items

- common framework for a proactive MANET protocol
- common framework for a reactive MANET protocol
- common framework for a simplified MANET multicast forwarding protocol

Other related MANET items may need to be handled via BOF,etc exploration..or discussed more with the ADs and WG chairs.

-Joe

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Jaehoon Jeong" <[email-masked]>
Date: Fri, 5 Nov 2004 21:30:22 -0500

Hi Joe,

As you know, many people want MANET address autoconf to be standardized in the IETF.
ETRI has already implemented MANET address autoconf based on my draft:
http://www.ietf.org/internet-drafts/draft-jeong-manet-aodv-addr-autoconf-01.txt
http://www.ietf.org/internet-drafts/draft-jeong-adhoc-ip-addr-autoconf-03.txt
http://www.ietf.org/internet-drafts/draft-jeong-manet-addr-autoconf-reqts-03.txt

Also, recently, Prof. Kilian Weniger announced the implementation of Passive DAD:
http://pacman-autoconf.sourceforge.net
http://sourceforge.net/projects/pacman-autoconf/

Since MANET addressing is prerequisite for MANET routing, I think it can be handled at our MANET wg.
First, we can make the requirements for MANET address autoconf as Informational RFC.
After that, if a simple MANET autoconf scheme gets a consensus, we can make it as another Information RFC.

I would like to ask you to discuss it with ADs.

Thanks.

Regards,

Paul

========================================================================
Jaehoon Paul Jeong,
Ph.D. Student,
Department of Computer Science
University of Minnesota at Twin Cities
Email: [email-masked]
Homepage: http://www.cs.umn.edu/~jjeong/
Phone: +1-612-624-6208(Office), 651-587-7774(Cell)

---

From: Christophe Jelger <[email-masked]>
Date: Fri, 05 Nov 2004 16:48:24 +0100

Hello,

There is also our implementations based on prefix continuity for ad hoc 
networks connected to the Internet via gateway nodes.

http://www-r2.u-strasbg.fr/~frey/safari/autoconf.html

Regards,
Christophe

Jaehoon Jeong wrote:

>>------------------------------------------------------------------------
>>

---

From: Christophe Jelger <[email-masked]>
Date: Fri, 05 Nov 2004 16:49:30 +0100

Hello,

Regards,
Christophe

---

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 05 Nov 2004 09:11:39 -0800

Hello Jaehoon,

As you probably know, we also have had drafts for autoconfiguration
of addresses in ad hoc networks.  These drafts have not been resubmitted
recently, because the working group has not had autoconfiguration on
its charter.  Nevertheless, the specification is good and compatible with
on-demand routing protocols.  If the working group decides to charter
new work on this activity, I would like our previous drafts to be
considered for adoption by the working group.  Alternatively, it might
make sense to investigate some combined approach.

Regards,
Charlie P.

---

From: "Jaehoon Jeong" <[email-masked]>
Date: Fri, 5 Nov 2004 23:57:11 -0500

Hi Charlie,

If MANET chairs decide to work on this activity, I think that your previous drafts
can be used as base documents.
For developing specific machanism draft(s), we seem to have to reach a consensus on
the requirements of MANET address autoconf.
I appreciate your previous work.

Thanks.

Jaehoon

---

From: Joe Macker <[email-masked]>
Date: Fri, 05 Nov 2004 13:30:02 -0500

> I would like to ask you to discuss it with ADs.

I assure you I have been discussing this with the ADs and there has been some resistance to expanding MANET WG scope in this area.
I am cc'ing them so they have your input.

I would agree that even in addition to the above work, there are many others that implement autoconf approaches and have shown them to work. We may wish to plan an MANET autoconf BOF for the next IETF.

Secondly, since MANET (in the WB context) is just IP routing it can be applied in many different scenarios with many ways of performing address management. I would encourage you to promote this not a requirements discussion but perhaps a best known practices formulation exercise with some applicability discussion.

-Joe

---

From: "Jaehoon Jeong" <[email-masked]>
Date: Fri, 5 Nov 2004 16:42:50 -0500

Thanks for your work. :-)

I hope to see the direction of MANET autoconf at this meeting:
a new item at MANET wg or the development through MANET Autoconf Bof.

Jaehoon