Subject: RE: [manet] Are there protocols that are like SIP or H.323 that couldprovide session or peer-peer sceesions in MANETS for Voice or Multimedia?

From: "srgopal" <[email-masked]>
Date: Tue, 02 Nov 2004 00:20:19 -0600

Dear Daniel and christopher,

Are you saying that this SIP protocol can be used to
generate VoIP packets like packet voice in Mobile  Ad Hoc
networks to see the performance of Ad Hoc networks when
supporting VoIp and/or multimedia? I mean can it be used
with ns-2 simulator and see its affect on ad hoc network
performance. Please clarify this. If not, how can one
generate packet voice while simulating Ad Hoc network using
ns-2 simulator?

I would appreciate your time and patience in this regard.

Regards,
Raja.

> Greetings Daniel,
> In your MANET architecture, do all the nodes act as
> Location Services, Proxies, User Agent Clients (UACs) and
> User Agent Server (UASs)?
>
> Thanks and regards,
>
> Chris
>
> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]] On Behalf Of Daniel Henkel
> Sent: Saturday, October 30, 2004 11:13 AM
> To: [email-masked]
> Subject: Re: [manet] Are there protocols that are like SIP
> or H.323 that couldprovide session or peer-peer sceesions
> in MANETS for Voice or Multimedia?
>
> Hi Christopher,
>
> We have successfully used SIP to initiate VoIP sessions
> over several hops in our testbed. Using Linphone on both
> laptops and iPAQs we were able to have very reliable
> communication with our DSR implementation. You can
> possibly use a much more stripped down version of SIP and
> achieve same results if footprint is an issue; try oSIP:
> http://www.gnu.org/software/osip/osip.html
>
> Regards,
> Daniel Henkel
> University of Colorado at Boulder
> http://AUGNet.colorado.edu
>
>
> ---- Original Message ----
> From: Christopher P. Rigano
> To: <[email-masked]>
> Subject: [manet] Are there protocols that are like SIP or
> H.323 that could provide session or peer-peer sceesions in
> MANETS for Voice or Multimedia?
>
> Friday, October 29, 2004, 1:59:34 PM, you wrote:
>
> CPR>  
>
>
>
>
>
>
>
>
>
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/manet
>
>
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/manet
>
>

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Li Li <[email-masked]>
Date: Tue, 02 Nov 2004 07:58:52 -0500

We did the SIP over MANET simulation using OPNET, generating SIP voice
packets over an OLSR MANET to evaluate service performance. It should be
possible with ns-2 simulator. 

You can find our work and paper at
http://www.crc.ca/en/html/manetsensor/home/research_area/support

li li

>> Friday, October 29, 2004, 1:59:34 PM, you wrote:
Li Li, Ph.D
Communications Research Centre, Industry Canada
3701 Carling avenue 
P.O. box 11490 
Station H, Ottawa, 
Ontario, Canada K2H 8S2 
Tel: (613) 990-5246 
Email: [email-masked]

---

From: Raja Sombhotla <[email-masked]>
Date: Sun, 7 Nov 2004 21:57:50 -0800 (PST)

Dear all,
 
First of all thank you very much for answering my questions.
 
Li Li, in your paper why have you considered the interarrival time is exponentially distributed with a mean value of 600 sec and the call duration time is also exponentially distributed with a mean value of 180 sec? What is the criteria for choosing these parameters in a mobile ad hoc network simulation evaluating the service carrying capacity?

Li Li <[email-masked]> wrote:
We did the SIP over MANET simulation using OPNET, generating SIP voice
packets over an OLSR MANET to evaluate service performance. It should be
possible with ns-2 simulator. 

li li

At 12:20 AM 11/2/2004 -0600, srgopal wrote:
>> To: 
Li Li, Ph.D

---------------------------------
Do you Yahoo!?
 Check out the new Yahoo! Front Page. www.yahoo.com