Subject: [manet] (null) - invalid packet type (exp).error in simulating ad hoc network!

From: "srgopal" <[email-masked]>
Date: Tue, 23 Nov 2004 16:51:40 -0600

Dear All,

I was simulating a network in ns-2 network simulator with
two nodes with packet voice being generated from one node
using exponential traffic generator and the other node is
used as a null. I encountered the following problem: (null)
- invalid packet type (exp).

Basically, i ran the simulation for the example4.tcl in Marc
Greis' tutorial available on the ns-2 webpage (8th one
creating output files for X-graph) with wired network
scenario and obtained good results. Next, i tried the same
with wireless nodes and i encountered the above problem. I
could not fix it.
I even tried changing the CMUTrace.cc and CMUTrace.h files
for adding my packet type(both null type and exp also). But
it did not work out.
Please help me figure it at the earliest. Any help will be
appreciated.

Regards,
raja.

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Ali Hamidian <[email-masked]>
Date: Wed, 24 Nov 2004 09:28:52 +0100

Hi Raja,

Have you tried the advice here? 
http://mailman.isi.edu/pipermail/ns-users/2003-January/029130.html
Which version of ns-2 are you using?

Ali