Subject: [manet] how can I simulate multicast in ad hoc WLANs?

From: Marcos Ferreyra <[email-masked]>
Date: Mon, 8 Nov 2004 13:30:56 -0300

Hi everyone,

Does NS (ns-allinone-2.27) support multicast traffic in ad hoc WLANs?
If it does
   please tell me how, give me a link, whatever!
else
   can you please suggest an alternative simulator?

Marcos

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: YangWoo Ko <[email-masked]>
Date: Tue, 9 Nov 2004 02:51:12 +0900

Dear Marcos,

I don't know what options are available with 2.27 version. I usually
used maodv implementaion with 2.26 verion, You can get it from the
following URL.

http://www.sce.carleton.ca/wmc/code.html

Or you can also find odmrp impelmentation with older versions of ns.

Good luck

-- 
/*------------------------------------------------
  The ones doing their job, doing what they were 
  meant to do, are invisible. -- Matrix Reloaded
  Ko, YangWoo / Searcher / [email-masked]
------------------------------------------------*/

---

From: Kevin Walsh <[email-masked]>
Date: Mon, 08 Nov 2004 14:17:39 -0500

Along with the suggestion of maodv, I would add that you should be able to 
run maodv under the SNS simulator, available at:

         http://www.cs.cornell.edu/People/egs/sns/

SNS is fully compatible with sns-allinone-2.1b9a (it is an extension of the 
ns2 simulator, and shares most of the code base), but is quite a bit 
faster, and can simulate much larger wireless networks.

Regards,
Kevin W.

---

From: Marcos Ferreyra <[email-masked]>
Date: Mon, 8 Nov 2004 16:27:07 -0300

Hi

> Or you can also find odmrp impelmentation with older versions of ns.

Hmm, what I want is to get srm (or at least rtp) running in an ad
hoc WLAN. I am not talking about multihop routing in ad hoc nets.
I guess I did not make the correct question. I am sorry. Anyway,
would any of these multicast routing protocols make srm work
on ad hoc nets? When I use mobilenodes and srm I get:

$ns wsrm.tcl
num_nodes is set 1
INITIALIZE THE LIST xListHead
Starting Simulation...
channel.cc:sendUp - Calc highestAntennaZ_ and distCST_
highestAntennaZ_ = 1.5,  distCST_ = 550.0
SORTING LISTS ...DONE!
ns: _o19 new-group 0 -2147483648 -1 cache-miss: can't read
"protocols_(-1)": no such variable
    while executing
"$protocols_($iface) upcall $code $source $group $iface"
    (procedure "_o20" line 9)
    (mrtObject upcall line 9)
    invoked from within
"$mrtObject_ upcall $code $src $group $iface"
    (procedure "_o14" line 3)
    (Node new-group line 3)
    invoked from within
"$node_ new-group $src $group $iface $code"
    (procedure "_o19" line 3)
    (Classifier/Multicast new-group line 3)
    invoked from within
"_o19 new-group 0 -2147483648 -1 cache-miss"

I grepped for "protocols_" and found many entries in
ns-2.27/tcl/mcast/McastProto.tcl, but nowhere else.

I have found  at least 6 other posts since 2001 reporting the
same or very similar problems. Any ideas? Would maodv or 
odrmp solve this problem?

---

From: YangWoo Ko <[email-masked]>
Date: Tue, 9 Nov 2004 04:50:26 +0900

On Tue, Nov 09, 2004 at 04:18:54AM +0900, Marcos Ferreyra wrote:
> on ad hoc nets? 

Yes. If my memory is not wrong, I ran a few ad hoc networking
simulations with srm + maodv patch + ns 2.26.

> When I use mobilenodes and srm I get:
> 
> $ns wsrm.tcl
> num_nodes is set 1

---

From: Marcos Ferreyra <[email-masked]>
Date: Mon, 8 Nov 2004 18:37:40 -0300

> simulations with srm + maodv patch + ns 2.26.

Well, well, this is Bach to my years. I will try right now. If you happen to
find that piece of code, and wish to share it, please let me know.
Thank you very much for your time.