Subject: [manet] DSR: only getting 1 route out of 2 possible

From: Vítor Jesus <[email-masked]>
Date: Thu, 4 Nov 2004 10:08:37 +0000 (GMT)

Hi all,

I have this very simple script (ns-2.27) with a fixed
(nodes don't move) adhoc running DSR. Imagine source
and destination, with two possible routes (2
branches). The only difference is that one branch has
one more hop.

When I look for RREP, I get only one route (shortest).
The only way I get the 2nd one, is by forcing some
traffic (ftp) in the inner nodes of the non-used
branch. Even so, if I stop traffic, soon the route is
taken out of the cache.

I understand DSR using the sortest one but I was
expecting to see the alternate one.

Has anyone a simple explanation for this?

Thanks in advance.
--Vítor

___________________________________________________________ALL-NEW Yahoo! Messenger - all new features - even more fun! http://uk.messenger.yahoo.com

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Vítor Jesus <[email-masked]>
Date: Fri, 5 Nov 2004 11:46:00 +0000 (GMT)

Thanks for your help but I didn't state my problem as
clear as I should. The problem is not why DSR chooses
which route. It is why the 2nd route doesn't appear
via RREP.

Anyway, I solved it, though I still have some doubts
on exactly what happened. But it was related to the
distance between the nodes (some MAC effects I was not
counting on when placing the nodes).

Thanks again,
--vítor

 --- roneel z <[email-masked]> wrote: 
> You answered your question.
> 
> "I understand DSR using the shortest one".
> 
> Try sending more data from your source than the link
> from your intermediate 
> node to the destination could handle. That way it
> might opt to use alternate 
> route.
> 
> Best of luck
> 
>
_________________________________________________________________
> Express yourself instantly with MSN Messenger!
> Download today - it's FREE! 
>
http://messenger.msn.click-url.com/go/onm00200471ave/direct/01/

___________________________________________________________ 
How much free photo storage do you get? Store your holiday 
snaps for FREE with Yahoo! Photos http://uk.photos.yahoo.com