Subject: Re: [manet] where does OLSR loss most occur in lightly loaded networks?

From: "Tao Lin" <[email-masked]>
Date: Thu, 25 Nov 2004 09:21:21 -0500

One reason is that in AODV, there is a data packet queue which holds packets
up to 10 seconds if there is no valid route or the original route fails.  In
OLSR, there is no such queue.  Once the packet delivery to neighboring node
fails, that packet is discarded immediately.  Therefore, the data packet
queue is kind of "unfair" comparison condition (which is required by
reactive protocols).  My suggestion is to implement the same queue for OLSR
as well when compare it with AODV.

Of course, another important reason is that AODV reacts faster than OLSR
since it tries to find a new route once a route broken is detected.  OLSR's
link state requires a longer converge time when a topology change occurs due
to constant hello interval and propagation delay of MPRS control messages.
However, on the other hands, AODV does have increasing control overhead when
the network topology changes faster.

You can refer to one of my paper or PhD dissertation for more details on
discussion on different MANET leading protocols from a general relay node
set framework's point of view.

Best,

 Tao Lin, Post-doc
 ECE Department, McMaster University
 Hamilton, ON, Canada
El Jueves, 25 de Noviembre de 2004 01:42, l s escribió:
> Dear researchers,
>
> I have a question for those most familiar with OLSR.
>
> I am comparing AODV and OLSR in lightly loaded
> networks.  I am much less familiar with how OLSR
> internally operates than I am with AODV.
>
> I have 20 applications running (CBR 4 packets per sec)
> in the network of 50 nodes moving Random Way Point in
> 1500x300.  There is no loss from Queue Overflow.
>
> AODV has 3% Transport Loss (loss occuring somewhere
> between departure from the source's transport layer
> and arrival at the distination's transport layer)
> whilst OLSR has 36% Transport Loss.
> The number of Radio Collisions are 3 times lower in
> OLSR than in AODV, so where and how is the most likely
> way in which the OLSR loss is occuring.
>
> Thanks in advance for your thoughts.
>
> Cheers,
>    Lee -S-
>    CCSR, Uni of Surrey, UK.
>
>
>
>

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: l s <[email-masked]>
Date: Thu, 25 Nov 2004 17:41:11 +0000 (GMT)

Thanks Everyone,

indeed, OLSR seems to be just dropping the
datagrams, compared to AODV holding the packets,
being more familiar with AODV I found the
OLSR results unbelievable.  What you describe
can completely explain my results.  Thank you.

Hakim, the apps start 100s after sim start.
Thanks for the detail, and also reference to
Fast-OLSR, I'll have a closer look at this.

Francisco, Philippe, I've just become aware
there are extensions to the glomosim
implementation I am using to reduce this with
the link notification you mention, which I'll
consider along with buffering changes to either
AODV or OLSR depending on the application
requirements.

Tao Lin, with the up to 10s buffering in AODV
then datagrams may take a significant amount of
time to get across the network, and may then be
useless if they are say VoIP datagrams etc.
I'll have a think about this.

Cheers,
   Lee -S-
   CCSR, Uni of Surrey, UK.

___________________________________________________________ 
Win a castle for NYE with your mates and Yahoo! Messenger 
http://uk.messenger.yahoo.com