Subject: [manet] How to get codes?

From: Deng Xiaoping <[email-masked]>
Date: Mon, 23 May 2005 02:45:52 -0700 (PDT)

Hi all,
The work I am planning to do now is to compare some ad hoc secure routing protocols'
performance with ns2. I would like to know how can I get the codes of these protocols.
Does ns2 support them or I have to write these codes myself? Is there some server to 
download those codes? Have them been published by the designer of these protocols?
Thank you very much.

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: sanjeev barala <[email-masked]>
Date: Mon, 23 May 2005 21:57:33 -0700 (PDT)

HI All 
Can anybody help me in this

Basic Project Specification
You are the Senior Engineer for a telecommunications equipment manufacturer in
charge of the design of a new Voice over IP (VoIP) capable router. The router is
intended for use by small ISPs with customers on multiple ADSL links or cable
modems. It will be capable of giving priority to voice traffic over data traffic.
Small ISPs typically have access to a limited range of uplink speeds. This router is to
have options for 2.048 Mbps and 34 Mbps.
The main design issues you need to resolve are buffer sizing and buffer management.
Because large buffers add to the cost and delay through the router, the buffer needs to
be as small as possible while still providing adequate service.
Your initial investigations into Voice over IP show the following:
•&#61472;Voice traffic is transmitted using the UDP protocol while data traffic is
transmitted using the TCP protocol.
•&#61472;Each voice stream generates a constant bit rate stream of packets with a fixed
packet size of 40 bytes (including UDP and IP headers and trailers) arriving at the
input buffer every 2.5 milliseconds.
•&#61472;The maximum tolerable delay for voice traffic end to end is 500 milliseconds. For
your router, the maximum delay is 100 milliseconds.
•&#61472;Data traffic is mostly made up of web page requests and emails. An average user
generates messages according to an exponential distribution with an average
interarrival time of 10 seconds with an exponentially distributed size of 40 kbytes.
•&#61472;Most households comprise one or two data users and one or two VoIP users who
are active at any one time.
•&#61472;Data traffic is fragmented into 8 kbyte packets.
•&#61472;Most subscribers have a duplex link speed of 256 kbps.
•&#61472;The Internet ‘diffserv’ architecture allows for a choice of scheduling – either FIFO
server schedule or a schedule giving priority to constant bit rate packets. The
priority scheme is to service the oldest voice packet, or service the oldest data
packet only if there are no voice packets in the queue.
You decide to develop a simulation program to help with the router design. The
typical scenario you wish to understand is where there are one or two concurrent VoIP
users and one or two data traffic users on each line.
Your router is to support as many lines as possible, subject to 99.9% of voice packets
being delayed less than 100 milliseconds.
You report on the following:
•&#61472;Comparison of delay for different number of users user type (VoIP, data)
•&#61472;Buffer size necessary to provide a loss probability for data traffic of 10-6
•&#61472;Comparison of delay for voice traffic with FIFO queueing and with priority
queueing.

Extension 1
You decide that it is important for the board to have confidence in your
simulation. You choose a number of techniques to verify it and include the results
of them in your report.
Extension 2
You decide to experiment with different levels of packet fragmentation to see
what effect it has on voice delay. The IP standard specifies a maximum packet
size of 64 kilobytes per packet. You are using 8 kbyte packets. You report on the
effect on voice traffic delay of fragmenting the data traffic into packet sizes
ranging from 512 bytes up to the maximum of 64 kbytes. You are to report on the
effect of fragmentation with both FIFO and priority queueing.
Extension 3
There is the possibility that link speeds will dramatically improve over the next
few years. Consequently, the board is undecided as to whether they should
produce a number of products with different buffer sizes and different uplink data
rates or whether a single buffer size with different interfaces will be satisfactory.
To help them make this decision, you decide to produce an extensive set of
simulation results for different household uplink speeds (256 bps, 512 bps and
1024 bps), number of users and buffer sizes. You use the results to make a
recommendation as to which option should be chosen.
Extension 4
Voice over IP across WLAN interface is becoming more popular. However, the
Board is concerned that the additional delay of the WLAN interface may have an
impact on the router design. You decide to investigate the effect of using VoIP
across an 802.11b wireless interface and how it affects delay from the user to the
ISP through the new router.
Households
Router
Internet

Sanjeev

__________________________________ 
Do you Yahoo!? 
Yahoo! Small Business - Try our new Resources site
http://smallbusiness.yahoo.com/resources/

---

From: Brown Tim <[email-masked]>
Date: Tue, 24 May 2005 09:09:02 -0600 (MDT)

Sanjeev:
Are you asking us to do your homework assignment for you?
If so, this is the wrong forum.

> ISP through the new router.

Timothy X Brown
Interdisciplinary Telecommunications
Electrical and Computer Engineering
ECOT 256 Campus Box 530
University of Colorado
Boulder, CO 80309
Tel: (303) 492-1630
Fax: (303) 492-1112
http://ece.colorado.edu/~timxb

---

From: sanjeev barala <[email-masked]>
Date: Tue, 24 May 2005 22:26:23 -0700 (PDT)

Dear All
This is not what I am asking. I have done most of it but the extension 4 and 5 are bit problem. I
am not asking for script or something but suggestions if you guys have any . 
regards
Sanjeev

---

From: sanjeev barala <[email-masked]>
Date: Tue, 31 May 2005 01:24:47 -0700 (PDT)

Hi 
I am running a simple ns script with 128 nodes sending traffic(TCP)
when it reaches 128 nodes it gives me following error.
can somebody help me with possible solutions

C:\tcl>ns 128node2v0d.tcl
Number of nodes exceeds node-field-size of 7 bits
    while executing
"error "Number of nodes exceeds node-field-size of $nodebits_ bits"
    (procedure "_o3" line 4)
    (Simulator check-node-num line 4)
    invoked from within
"$self check-node-num"
    (procedure "_o3" line 18)
    (Simulator node line 18)
    invoked from within
"$ns node"
    (file "128node2v0d.tcl" line 42)

--- sanjeev barala <[email-masked]> wrote:

> &#8226;&#61472;Voice traffic is transmitted using the UDP protocol while data traffic is
> &#8226;&#61472;Each voice stream generates a constant bit rate stream of packets with a fixed
> &#8226;&#61472;The maximum tolerable delay for voice traffic end to end is 500 milliseconds. For
> &#8226;&#61472;Data traffic is mostly made up of web page requests and emails. An average user
> &#8226;&#61472;Most households comprise one or two data users and one or two VoIP users who
> &#8226;&#61472;Data traffic is fragmented into 8 kbyte packets.
> &#8226;&#61472;Most subscribers have a duplex link speed of 256 kbps.
> &#8226;&#61472;The Internet &#8216;diffserv&#8217; architecture allows for a choice of
scheduling &#8211; either FIFO
> &#8226;&#61472;Comparison of delay for different number of users user type (VoIP, data)
> &#8226;&#61472;Buffer size necessary to provide a loss probability for data traffic of 10-6
> &#8226;&#61472;Comparison of delay for voice traffic with FIFO queueing and with priority
> queueing.
> 
> Extension 1

__________________________________ 
Discover Yahoo! 
Use Yahoo! to plan a weekend, have fun online and more. Check it out! 
http://discover.yahoo.com/