Subject: [manet] Doubt regarding setdest

From: aravind rao <[email-masked]>
Date: Tue, 24 May 2005 09:49:54 +0100 (BST)

hi,

I have been using the setdest tool available in
ns-2.28 to generate scenarios with different number of
nodes, pause time ...etc In the output, information
regarding the number of hops between the nodes is fed
to to the central object "GOD". How is this used by
GOD? What is its importance? How does it affect the
scenarios generated?any expaination will be helpful

thanks in advance,

Aravind Rao
Wireless Networking Lab
M. S. Ramaiah Institute of Technology
Bangalore, India

___________________________________________________________ 
How much free photo storage do you get? Store your holiday 
snaps for FREE with Yahoo! Photos http://uk.photos.yahoo.com

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: amr hassan <[email-masked]>
Date: Wed, 25 May 2005 05:48:53 -0700 (PDT)

Hi Aravind,
GOD (Global Operations Director) is an object. As the name implies, GOD directs operations that you want to do in setdest. For e.g.: If you want to record the performance of a metric, a set of counters and tables can be initialized inside GOD. Every time the trace file changes (i.e. a new value is written in the trace file), the GOD is updated via the cmu-trace module (if you are using the cmu extensions for ex.) and the proper counter or table is now updated.
I hope this is helpful.
 
Regards,
Amr M. Hassan
M.Sc. Student,
Electronics & Communications Department,
Faculty of Engineering,
Al-Azhar University, Cairo, Egypt.

------------------------------

Message: 4
Date: Tue, 24 May 2005 09:49:54 +0100 (BST)
From: aravind rao 
Subject: [manet] Doubt regarding setdest
To: manet 
Message-ID: <[email-masked]>
Content-Type: text/plain; charset=iso-8859-1

hi,

thanks in advance,

Aravind Rao
Wireless Networking Lab

---------------------------------
Yahoo! Mail Mobile
 Take Yahoo! Mail with you! Check email on your mobile phone.

---

From: amr hassan <[email-masked]>
Date: Mon, 30 May 2005 09:32:58 -0700 (PDT)

Hi aravind

Well, I think you are right. you can ignore it and it will has no considerable effect on the simulations. But I didn't try that.
To be sure, run a small test with & without GOD and see the results. this way you can be sure. 
Plz keep the manet updated with your results.
 
Regards,
Amr

aravind rao <[email-masked]> wrote:
hi,

thanks for replying.

i am not using god to monitor any parameters. i donot
need to. does this mesn that i can completely ignore
the instructions to GOD. does it have any effect on
the way the simulation runs, will it vary the results
i get for my simulations?

regards,
aravind

___________________________________________________________ 
Yahoo! Messenger - NEW crystal clear PC to PC calling worldwide with voicemail http://uk.messenger.yahoo.com

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com