Subject: [manet] DYMO-01 Available

From: Ian Chakeres <[email-masked]>
Date: Mon, 9 May 2005 11:25:15 -0700

We recently finished the DYMO revision.  There are a lot of changes, 
but most are editorial.  I hope the new revision is much clearer. 
Please peruse it and let me know if you have new comments.

The updated ID is available at http://moment.cs.ucsb.edu/dymo in txt 
and html format.

Thanks to everyone for all your comments and suggestions about DYMO-00.

Ian Chakeres

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Christian Tschudin <[email-masked]>
Date: Tue, 10 May 2005 10:13:15 +0200 (MET DST)

> Please peruse it and let me know if you have new comments.

At the text level, DYMO looks like a fresh start, but structurally
it remains in the old world with strong implicit ties. I suggest
to spend some header bits to make it more futureproof and
reusable namely to

- separate transport from target address type

- prepare for address variety.

This can easily be achieved by explicit flagging of address types for
- destination (e.g., IPv4, IPv6, but also HIT or eth),
- and forwarding addresses (IPv4, IPv6, ethernet, sensorid etc)

Currently the single address type (IPv4 or IPv6) is "infered"
from the envelope that carries DYMO messages.
This prevents a reuse of DYMO in slightly modified contexts
like nodes with small address spaces (sensornets) or upcoming
true node identifiers like those used in HIP.

With the proposed change, DYMO could incorporate elements of
LUNAR as well as the LLSR variant of DSR used in Microsoft's
mesh connectivity layer.

regards, christian.

---
Christian Tschudin, University of Basel       http://cn.cs.unibas.ch/
Computer Science Dept, Bernoullistr. 16, CH - 4056 Basel, Switzerland