Subject: Re: [manet] QoS issue in routing

From: "yasser lotfy" <[email-masked]>
Date: Sun, 19 Jun 2005 14:52:32 -0500

Hi,
There is nothing in MANET or even in wire-line networks that classifies packets into realtime and besteffort. The tenet that all QoS approaches follow is to let the application define its needs. While this approach in fact is very impractical, its hard at the IP layer to assume application needs.

Therefore, a much needed middleware can take the role of brokering bandwidth at the source host. If in your particular study you don't see the need or don't have the will to hack such a middleware, an alternatibe (and common) solution is to assume that all udp traffic is a realtime traffic, and all tcp is a besteffort.

Hope this covers your question well. 

Regards,

***********************************************
A train station is the place where trains stop,
A bus station is the place where buses stop,
On my desk they installed a workstation !!
***********************************************

-- 
_______________________________________________
NEW! Lycos Dating Search. The only place to search multiple dating sites at once.
http://datingsearch.lycos.com

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Fred Baker <[email-masked]>
Date: Sun, 19 Jun 2005 23:14:03 -0700

On Jun 19, 2005, at 12:52 PM, yasser lotfy wrote:

> There is nothing in MANET or even in wire-line networks that 
> classifies packets into realtime and besteffort. The tenet that all 
> QoS approaches follow is to let the application define its needs. 
> While this approach in fact is very impractical, its hard at the IP 
> layer to assume application needs.

you might consider draft-ietf-tsvwg-diffserv-service-classes-00.txt