Subject: [manet] Problem with AODV in OPNET v 11

From: "Mullen, John" <[email-masked]>
Date: Wed, 15 Jun 2005 12:40:42 -0600

H i,
 
I'm having a problem with AODV in version 11 of OPNET.  I did not have
the problem with v 10.5 and I don't have in in v 11 with DSR.  Also, if
I use the AODV example model, I don't have the problem, just when I use
the AODV standard model.
 
The problem is that the transmitting node does a route search once at
the start of the simulation, but doesn't initiate a new one if that
initial route later fails. Anyone have an idea on this?
 
Thanks,
 
John Mullen

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: manet user <[email-masked]>
Date: Thu, 23 Jun 2005 07:37:01 -0700 (PDT)

John,
 
I believe, if you make "AODV Hello Efficiency" global attribute "Disabled" while running AODV simulations, you'll not see this problem. AODV Hello Efficiency when enabled, will not allow Hello message exchange. This should be typically used when the network is static or when one is using lower layer feedback to detect link breaks. In 11.0, this attribute is "Enabled" by default.
 
Hope this helps.

"Mullen, John" <[email-masked]> wrote:
H i,
 
I'm having a problem with AODV in version 11 of OPNET.  I did not have the problem with v 10.5 and I don't have in in v 11 with DSR.  Also, if I use the AODV example model, I don't have the problem, just when I use the AODV standard model.
 
The problem is that the transmitting node does a route search once at the start of the simulation, but doesn't initiate a new one if that initial route later fails. Anyone have an idea on this?
 
Thanks,
 
John Mullen

---------------------------------
Yahoo! Sports
 Rekindle the Rivalries. Sign up for Fantasy Football