Subject: Re: [manet] Cross-layer design in Ad hoc networks

From: Ali Khayam <[email-masked]>
Date: Thu, 2 Jun 2005 10:26:15 -0700 (PDT)

Hi Jan,

The following paper provides capacity deductions for
cross-layer channels:

Shirish Karande and Hayder Radha, "Does Relay of
Corrupted Packets Lead to Capacity Improvement?," IEEE
Wireless Communications and Networking Conference
(WCNC), March 2005.

Thanks.

  -- ali

--- [email-masked] wrote:

> Send manet mailing list submissions to
> 	[email-masked]
> 
> To subscribe or unsubscribe via the World Wide Web,
> visit
> 	https://www1.ietf.org/mailman/listinfo/manet
> or, via email, send a message with subject or body
> 'help' to
> 	[email-masked]
> 
> You can reach the person managing the list at
> 	[email-masked]
> 
> When replying, please edit your Subject line so it
> is more specific
> than "Re: Contents of manet digest..."
> 
> 
> Today's Topics:
> 
>    1. Cross-layer design in Ad hoc networks (Mobile
> Ad hoc)
> 
> 
>
----------------------------------------------------------------------
> 
> Message: 1
> Date: Wed, 1 Jun 2005 12:06:10 -0700 (PDT)
> From: Mobile Ad hoc <[email-masked]>
> Subject: [manet] Cross-layer design in Ad hoc
> networks
> To: [email-masked]
> Message-ID:
>
<[email-masked]>
> Content-Type: text/plain; charset="iso-8859-1"
> 
> Hi everybody,
>  
> I have worked with MANET for a few months. My
> research interest is about cross-layer design issues
> in ad hoc networks. I have read many papers but most
> of them are based on simulation. I wonder if you
> know any work which provides mathematical models for
> multi-hop ad hoc networks. Any help will be
> appreciated.
>  
> Thank you,
> Jan
> 
> 		
> ---------------------------------
> Yahoo! Mail Mobile
>  Take Yahoo! Mail with you! Check email on your
> mobile phone.
> -------------- next part --------------
> An HTML attachment was scrubbed...
> URL:
>
http://www1.ietf.org/pipermail/manet/attachments/20050601/48bb4a61/attachment.htm
> 
> ------------------------------
> 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/manet
> 
> 
> End of manet Digest, Vol 14, Issue 2
> ************************************
> 

__________________________________ 
Discover Yahoo! 
Stay in touch with email, IM, photo sharing and more. Check it out! 
http://discover.yahoo.com/stayintouch.html

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Sonny Rajagopalan <[email-masked]>
Date: Fri, 3 Jun 2005 14:58:40 -0400 (EDT)

Many distributed protocols assume that messaging between nodes in a MANET 
is guaranteed -- i.e., so long as the network remains unpartitioned during 
the course of the algorithm, the protocol packets will eventually reach 
the intended recepient.

Of course, in practice and in simulations, this is never the case. All 
levels of the protocol stack in ad hoc networks drop packets, and 
sometimes, even when there is no mobility.

Yet, a large number of us make similar assumptions when we design 
distributed protocols. Sometimes, when messages are not delivered, some of 
our protocols will indeed not work at all (that is, won't work as 
expected, but unexpected behavior may be catastrophic for some protocols, 
but not affect others so much. For leader election algorithms, the effect 
is catastrophic (too many leaders!)). My question is, how, as protocol 
engineers, do you justify the above assumption? Specifically, how do you 
justify it in your own research?

Please note that I am familiar with the usual justifications (it only 
happens rarely, and when it happens, it causes minimal "damage" to the 
protocol, etc.).

Perhaps I can reposition my question differently:

Fundamentally speaking, in a distributed protocol, we have to deal with 
messaging information from one node to another, and ergo, deal with 
messaging imperfections in the protocol stack(s). So, unless we have 
addressed these imperfections, the assumption on which distributedness 
sits on needs justification specific to the protocol designed.

Of course, this problem is not just a wireless network problem, but in the 
wired world, we have more options...

What are your thoughts/frustrations on the topic?

Cheers,
Sonny.

+-----------
>From the desk of Sonny Rajagopalan,  http://www.cis.udel.edu/~rajagopa
                                                         --------------+

---

From: Einar Vollset <[email-masked]>
Date: Sat, 4 Jun 2005 15:54:24 +0100

Sonny,

In general, there are two ways to handle losing packets or (sometimes 
even worse) getting packets out of order; (1) you
use a reliable communication protocol or (2) you let the application 
handle the loss.

Support for the second approach can be seen as an extreme version of 
the classic end-to-end argument made
for wired networks (See http://www.reed.com/Papers/EndtoEnd.html ).

My view is that if your application requires reliability and ordering 
of messages you are better of using a reliable
(possibly atomic) broadcast protocol than to let the application 
developer handle it at what is usually much higher
cost and with less chance of getting it right.
This is a pretty lonely view sometimes however ;-)

(Of course, reliable broadcast protocols (and I'm here using the word 
reliable as actually meaning reliable = guaranteed delivery, not
better than best effort) has a cost associated in terms of additional 
bandwidth and possibly additional memory at each node. For
that reason you should probably use a best-effort protocol when this is 
good enough.)

Cheers,

Einar

p.s. If you are interested in reliable group communication you should 
take a look at Roy Friedman's work at Technion:
http://www.cs.technion.ac.il/Labs/dsl/projects/JazzEnsemble/ or UIUC's 
work: http://cairo.cs.uiuc.edu/adhoc/multicast/
or even ours: 
http://homepages.cs.ncl.ac.uk/einar.vollset/home.formal/pace/index.html 
here at Newcastle.

On 3 Jun 2005, at 19:58, Sonny Rajagopalan wrote:

>
> Many distributed protocols assume that messaging between nodes in a 
> MANET is guaranteed -- i.e., so long as the network remains 
> unpartitioned during the course of the algorithm, the protocol packets 
> will eventually reach the intended recepient.
>
> distributed protocols. Sometimes, when messages are not delivered, 
> some of our protocols will indeed not work at all (that is, won't work 
> as expected, but unexpected behavior may be catastrophic for some 
> protocols, but not affect others so much. For leader election 
> algorithms, the effect is catastrophic (too many leaders!)). My 
> question is, how, as protocol engineers, do you justify the above 
> assumption? Specifically, how do you justify it in your own research?
>
> Fundamentally speaking, in a distributed protocol, we have to deal 
> with messaging information from one node to another, and ergo, deal 
> with messaging imperfections in the protocol stack(s). So, unless we 
> have addressed these imperfections, the assumption on which 
> distributedness sits on needs justification specific to the protocol 
> designed.
>
> Of course, this problem is not just a wireless network problem, but in 
> the wired world, we have more options...
>

----------------------------------------
Einar Vollset
PhD Student
School of Computing Science
University of Newcastle, UK
http://vollset.org
-----------------------------------------