Subject: [manet] QoS issue in routing

From: "gokina " <[email-masked]>
Date: 18 Jun 2005 04:57:30 -0000

Is there any publication which discusses about packet prioritization. I want to know "how to distinguish between real time packets and non real time packets for routing purpose in MANET" 

 If you have came across any such work please give me reference or related link. 

Thanking you,
Gokina.

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Roy, Radhika \(AEAD\)" <[email-masked]>
Date: Sun, 19 Jun 2005 17:50:27 -0400

Hi, Yasser:
 
Yes, you right that IP layer can NOT assume any needs of applications. Also, all real-time applications (e.g., Audio, Video) will send RTP media-over-UDP. The way they will work are as follows:
 
1. The real-time applications (e.g., audio, video) will express their QoS needs at the time of the call setup using application layer signaling (e.g., SIP) messages.
2. The call admission control (CAC)/QoS server/router will then signal the IP layer about the QoS needs of the applications before acceptance of the call.
3. IP layer will then transfer the media-over-UDP in accordance to QoS scheme/policy satisfying the needs as indicated at the time of the acceptance of the call.
 
In this respect, MANET is also no different from the usual IP network.
 
So, it is expected that there will be a communications between the upper application/middle layer to the IP layer related to QoS needs. However, the interface for this inter-layer communications related to QoS can be realized in many ways. There are couple of separate alternatives that have been proposed in the IETF. It can be a separate thread outside the MANET WG.
 
Best regards,
Radhika R. Roy

________________________________

From: [email-masked] on behalf of yasser lotfy
Sent: Sun 6/19/2005 3:52 PM
To: gokina; [email-masked]
Subject: Re: [manet] QoS issue in routing

Hi,
There is nothing in MANET or even in wire-line networks that classifies packets into realtime and besteffort. The tenet that all QoS approaches follow is to let the application define its needs. While this approach in fact is very impractical, its hard at the IP layer to assume application needs.

Therefore, a much needed middleware can take the role of brokering bandwidth at the source host. If in your particular study you don't see the need or don't have the will to hack such a middleware, an alternatibe (and common) solution is to assume that all udp traffic is a realtime traffic, and all tcp is a besteffort.

Hope this covers your question well.

Regards,

***********************************************
A train station is the place where trains stop,
A bus station is the place where buses stop,
On my desk they installed a workstation !!
***********************************************