Subject: [manet] AODV ACTIVE_ROUTE_TIMEOUT

From: "Sigit B. Wibowo" <[email-masked]>
Date: Wed, 10 Aug 2005 01:59:38 -0700 (PDT)

Dear All,

I am confused about updating ACTIVE_ROUTE_TIMEOUT in
the source. Suppose that I data which need longer time
than ACTIVE_ROUTE_TIMEOUT. How can I update the
ACTIVE_ROUTE_TIMEOUT ? Without doing that, the source
always tries to initiate RREQ.

Thank you.
Regards,
Sigit

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: manet user <[email-masked]>
Date: Wed, 10 Aug 2005 10:46:43 -0700 (PDT)

ACTIVE_ROUTE_TIMEOUT is the timer value attached with each route entry in AODV. If a route is not used or refreshed within this time period, the route is considered stale and purged. If your traffic is such that the interarrival time between two consecutive data packets from application layer is more than ACTIVE_ROUTE_TIMEOUT default value, source will start Route discovery for each instance of data packet.
 
Active_route_timeout value is user configurable. Typically this value should be large for static or less mobile network, whereas small for highly mobile scenarios. One should consider increasing or decreasing Active route timeout value depending on mobility in the network and not the data packet interarrival time. If your network is static or less mobile, you can adjust this value to suite your data traffic interarrival times (in case you do not want RREQ for each packet).
 
Hope this helps.

"Sigit B. Wibowo" <[email-masked]> wrote:
Dear All,

Thank you.
Regards,
Sigit