Subject: RE: [manet] Highest priority flow in DiffServ model

From: "Roy, Radhika \(AEAD\)" <[email-masked]>
Date: Sun, 28 Aug 2005 20:34:39 -0400

H, Susan:
 
Please feel free to continue your explanations related to QOS as I am working on Army's 21-century worldwide network whose MANET-based networking is the key foundation. 
 
Also, I am in the middle of M&S works of the MANET-based network and will continue participating in technical discussions especially related to QOS as far as practicable publicly.
 
Definitely, as you have put, QOS is about some calls will get what they are supposed to get related to bandwidth and other resources, while others will get less.
 
The other thing is that the topology is changing in MANET networks. MANET-based routing protocols will have the layer-3 topology information for example. So, here are some probable scenarios:
 
1. Applications will express their QOS needs at the time of the call set-up (e.g., SIP).
 
2. Servers like QOS policy/CAC admission need to get involved to bridge the inter-layer information related to QOS and topology (application layer-to-IP layer) to indicate what needs to be done related to QOS in end-to-end path.
 
3. Servers like Bandwidth Broker/CAC need to signal IP routers what need to be done across the network including DiffServ and RSVP. (Simplified model from top to down - instead of end-to-end.)
 
4. If the MANET network changes topology after establishment of the calls, QOS policy/BB/CAC servers need to take care of QOS with changes in topology without involving call layer's call control servers. It is expected that this situation may cause some problems initially for the real-time traffic for delays in setting up the new paths, but it will be OK eventually.
 
5. For multicast in MANET environment, there are a lot of other things need to be taken care of.
 
Anyway, these are couple of observations as inputs to stimulate discussions.
 
Best regards,
 
Radhika R. Roy

________________________________

From: Susan Hares [mailto:[email-masked]]
Sent: Sun 8/28/2005 9:23 AM
To: Roy, Radhika (AEAD); Frye, Robert J (US SSA); [email-masked]
Subject: RE: [manet] Highest priority flow in DiffServ model

Roy and Robert:

Correctly put - QoS is about some devices getting less of the bandwidth. 

In 1999, internet-2 Bandwidth broker (BB) sub-group did some work on a BB to BB protocol. We experimented with TE based on OSPF, Radius/Diameter and RSVP-TE.  [Yes I am admitting I ran some of the early trials.]   Only a few routers (such as the Hitachi router) passed the early Diff-Serv field trials in 1999-2000 to provide high quality QoS based on the Diff-Serv routing.

In the subsequent years, cisco and a host of routers have put the hardware and software in line to guarantee QoS.

Hitachi put the effort in to work on the multi-media (Video, data, etc). 

In the 6 years since 1999,

-        TWEG working group - has championed TE pipes over IP,

-        MPLS has champion off-line CSPF for traffic engineered pathway selection, and the

-        PCE work is trying communicate between a path-calculation box and the node.

Other alternatives are using RSVP-A and RSVP-TE pathways that walk the path obtaining the information.  

So - there is a significant body of work that exists in the IETF and in research journals on traffic engineered path.

I have hit only the highlights of the work in the last 7-10 years. 

The key issues around QoS for Manet are extremely interesting.  Not only do you have less bandwidth, but the delay issues due to varying convergence impact any delay sensitive traffic services.

So - the key point is to utilize fast-convergence or pre-calculation of paths.

The difficult point is bandwidth brokering multicast.  

So.. before I launch into more details.  Let me know if you are still interested.

Sue Hares

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Marshall Eubanks <[email-masked]>
Date: Tue, 30 Aug 2005 12:29:53 -0400

Hello;

On 8/28/05, Roy, Radhika (AEAD) <[email-masked]> wrote:
>  
>   
>  
> H, Susan: 
>   
> Please feel free to continue your explanations related to QOS as I am
> working on Army's 21-century worldwide network whose MANET-based networking
> is the key foundation. 
>   
> Also, I am in the middle of M&S works of the MANET-based network and will
> continue participating in technical discussions especially related to QOS as
> far as practicable publicly. 
>   
> Definitely, as you have put, QOS is about some calls will get what they are
> supposed to get related to bandwidth and other resources, while others will
> get less. 
>   
> The other thing is that the topology is changing in MANET networks.
> MANET-based routing protocols will have the layer-3 topology information for
> example. So, here are some probable scenarios: 
>   
> 2. Servers like QOS policy/CAC admission need to get involved to bridge the
> inter-layer information related to QOS and topology (application layer-to-IP
> layer) to indicate what needs to be done related to QOS in end-to-end path. 
>   
> 3. Servers like Bandwidth Broker/CAC need to signal IP routers what need to
> be done across the network including DiffServ and RSVP. (Simplified model
> from top to down - instead of end-to-end.) 
>   
> 4. If the MANET network changes topology after establishment of the calls,
> QOS policy/BB/CAC servers need to take care of QOS with changes in topology
> without involving call layer's call control servers. It is expected that
> this situation may cause some problems initially for the real-time traffic
> for delays in setting up the new paths, but it will be OK eventually. 
>   
 
If I may ask, how important is multicast to your worldwide network ? Is this
something that you rate as very important for Manet ?

Regards
Marshall Eubanks

> Correctly put – QoS is about some devices getting less of the bandwidth. 
> 
>   
> 
> In 1999, internet-2 Bandwidth broker (BB) sub-group did some work on a BB to
> BB protocol. We experimented with TE based on OSPF, Radius/Diameter and
> RSVP-TE.  [Yes I am admitting I ran some of the early trials.]   Only a few
> routers (such as the Hitachi router) passed the early Diff-Serv field trials
> in 1999-2000 to provide high quality QoS based on the Diff-Serv routing. 
> 
> -        TWEG working group – has championed TE pipes over IP, 
> 
> So – there is a significant body of work that exists in the IETF and in
> research journals on traffic engineered path. 
> 
> The key issues around QoS for Manet are extremely interesting.  Not only do
> you have less bandwidth, but the delay issues due to varying convergence
> impact any delay sensitive traffic services. 
> 
>   
> 
> So – the key point is to utilize fast-convergence or pre-calculation of
> paths. 
>