Subject: [manet] AODV destination sequence number

From: "amit saxena" <[email-masked]>
Date: 9 Aug 2005 08:51:29 -0000

hi 

i've been thinking about the effect of destination sequence 
number in AODV routing protocol, and wanna make something 
more clear about it.

according to the RFC 3651 page 17, when an forwarding node 
received a RREQ, but does not generate a RREP (does not have 
an active route towards the destination, or the "destination 
only" flag is set, the forwarding node will update the 
destination sequence number in RREQ by "set to the maximum 
of the corresponding value received in the RREQ message, and 
the destination sequence value currently maintained by the 
node for the requested destination". 

so, does this mean the destination sequence number in RREQ 
might be changed during the transmission? but what the 
effect of updating the destination sequence number during 
the transmission of RREQ, since all the forwarding node will 
no update their route table entry regarding to that 
destination untill the RREP is sent back?

I'll really appreciate quick answers. 
Thanks a lot!

Amit   
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Venkatesan Balakrishnan" <[email-masked]>
Date: Tue, 9 Aug 2005 21:47:05 +1000

Hi All,

The DSR draft (draft-dsr-10) specifies in page 81 as, 
 
  "When a node receives a packet with both an Acknowledgement option
   and an Acknowledgement Request option, if that node is not the
   destination of the Acknowledgement option (the IP Destination Address
   of the packet), then the Acknowledgement Request option MUST
   be ignored.  Otherwise (that node is the destination of the
   Acknowledgement option), that node MUST process the Acknowledgement
   Request option by returning an Acknowledgement option according to
   the following sequence of steps: "

I could not visualize when a node will recieve a packet with both the above mentioned options. Can anyone please educate me?

Thanks
Venkat

---

From: "Maged Salah" <[email-masked]>
Date: Wed, 10 Aug 2005 10:21:28 +0300

Hi Amit,
 
I think changing the destination sequence number to the maximum of
forwarding node and RREQ destination sequence number  will increase the
probability of finding  a fresh route.
 
Maged

  _____  

From: [email-masked] [mailto:[email-masked]] On Behalf Of
amit saxena
Sent: Tuesday, August 09, 2005 11:51 AM
To: [email-masked]
Subject: [manet] AODV destination sequence number

hi 

Amit   

<http://adworks.rediff.com/cgi-bin/AdWorks/sigclick.cgi/www.rediff.com/signa
ture-home.htm/1507191490@Middle5?PARTNER=3>  
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet