Subject: FW: [manet] graphical display of wireless networks

From: "Gabi Kliot" <[email-masked]>
Date: Mon, 28 Nov 2005 19:53:51 +0200

Hello

Yes, there are Nam and Javis.

NAM is a packet flow and network animator used with NS simulator. NAM
accepts NS trace files, and based on them presents the animation of the
simulation. It can show up a network topology, nodes locations, links
between nodes. Its advanced features include actually demonstrating the flow
of messages send upon links, topology evolution over time, etc...

Javis is a Java based version of NAM -  it also accepts trace files in NAM
format . Till now Javis was mainly used with JNS, which is a Java version of
NS.

In my Ad Hoc networks research I am working with Jist/Swans simulator
developed in Cornell (http://jist.ece.cornell.edu/index.html). So I have
adapted Javis to work with Swans (I took the code that was used by JNS to
create Javis trace file in NAM format and adapted it into Swans code).

----------------------------------------------------------------------------
--------------

You can read about Javis and Nam at
http://warriors.eecs.umich.edu/viz_tools/nam.html
NAM trace format definition can be found here:
http://www.isi.edu/nsnam/ns/doc-stable/node228.html
JNS and more on Javis here: http://jns.sourceforge.net/

Regards,

Gabi Kliot

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Leon Martin
Sent: Monday, November 28, 2005 7:13 PM
To: [email-masked]
Subject: [manet] graphical display of wireless networks

Does anyone know of any existing work on graphical
display of wireless networks?

Thanks!

- Leon 

		
__________________________________ 
Yahoo! Mail - PC Magazine Editors' Choice 2005 
http://mail.yahoo.com

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Leon Martin <[email-masked]>
Date: Mon, 28 Nov 2005 10:38:23 -0800 (PST)

Gabi,

Thanks for the information. 

But Nam and Javis work only if you have _FULL_
knowledge of the network topology and traffic, which
are easily obtained in a simulation environment. What
I actually wanted is a tool that work on _REAL_
wireless networks in real time. I am sorry that I did
not make it come through. Do you have any idea about
that?

Thanks!

- Leon 

--- Gabi Kliot <[email-masked]> wrote:

> developed in Cornell
> (http://jist.ece.cornell.edu/index.html). So I have
> From: [email-masked]
> [mailto:[email-masked]] On Behalf Of
> Leon Martin

__________________________________ 
Yahoo! Music Unlimited 
Access over 1 million songs. Try it free. 
http://music.yahoo.com/unlimited/