Subject: Re: [manet] ARP in MANETS

From: "yasser lotfy" <[email-masked]>
Date: Tue, 25 Apr 2006 08:12:58 -0500

Hi All,
I don't see any point in having ARP in MANET.

MANET relies on 2 fundamental technologies:
1) The use of IP layer routing to relay packets to destination.
2) The use of ppp to discover nodes at 1 hop distance

Therefore, you need only to know the MAAC address of your immediate neighbor. Typically, listening to the wireless media is good enough for that.

All distant neighbors are reachable via IP routing layer.

Does this make sense?

***********************************************
A train station is the place where trains stop,
A bus station is the place where buses stop,
On my desk they installed a workstation !!
***********************************************

-- 
_______________________________________________

Search for businesses by name, location, or phone number.  -Lycos Yellow Pages

http://r.lycos.com/r/yp_emailfooter/http://yellowpages.lycos.com/default.asp?SRC=lycos10

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Ali Hamidian <[email-masked]>
Date: Tue, 25 Apr 2006 18:37:56 +0200

>Therefore, you need only to know the MAAC address of your immediate neighbor. Typically, listening to the wireless media is good enough for that.
And if you want to send to a station that is quiet? Then I think you 
somehow must request its MAC address.

Kind regards
Ali

---

From: "Yi, Seung" <[email-masked]>
Date: Tue, 25 Apr 2006 10:16:41 -0700

Hi all,

I did a small project on this issue when I was in the graduate school
and 
this paper came out as the result. You might find it interesting.

ARP Considered Harmful: Manycast Transactions in Ad Hoc Networks
C. Carter, S. Yi and R. Kravets
IEEE WCNC 2003 
http://mobius.cs.uiuc.edu/publications/WCNC03-CC.pdf

Regards,

- Seung

Abstract
ARP handles neighbor discovery and address resolution
in infrastructure networks, but is inadequate for Mobile Ad
Hoc Networks (MANETs). Thus, many MANET routing 
protocols include a neighbor discovery mechanism. This 
separation of neighbor discovery and address resolution 
is a fundamental design problem that causes packet loss, 
particularly when the communication is manycast, a novel
variant of multicast communication. Our approach, automatic 
address resolution, moves address resolution into the routing 
protocol along with neighbor discovery, correcting these problems.

> -----Original Message-----
> From: Ali Hamidian [mailto:[email-masked]] 
> Sent: Tuesday, April 25, 2006 9:38 AM
> To: yasser lotfy
> Cc: Rex Buddenberg; fxbaloch; manet
> Subject: Re: [manet] ARP in MANETS
> 
> 
> 
> yasser lotfy wrote:
> 
> >Hi All,
> >Therefore, you need only to know the MAAC address of your 
> immediate neighbor. Typically, listening to the wireless 
> media is good enough for that.
> >  
> >
> And if you want to send to a station that is quiet? Then I 
> think you somehow must request its MAC address.
> 
> Kind regards
> Ali
> 
> >A train station is the place where trains stop, A bus station is the 
> >place where buses stop, On my desk they installed a workstation !!

---

From: "Lei Luo" <[email-masked]>
Date: Tue, 25 Apr 2006 22:29:05 -0400

Hi All,

I am studying some kinds of attacks on MANET and the countermeasures. So I just wonder to what extent I can hack the MAC layer. I think the MAC address can be faked. What else can I fake? Particularly, if I suppose 802.11 device is used, can I send a long packet without receiving CTS from the receiver? In other words, can I make the MAC layer send a RTS and then send the packet even though it does not receive the CTS? Here I assume real devices, not simulations such as QualNet.

Thanks a lot!

Lei Luo