Subject: [manet] Re: Neighbors

From: <[email-masked]>
Date: Thu, 4 May 2006 13:59:56 -0500

Ken, you said that

>  So the real question is who are your neighbors
>  as a function of time in a MANET. A MANET protocol
>  should try to determine this so it can deliver 
>  messages when they are presented to the network.
>
>  My paper deals with point to point satellites, 
>  but you have the never ending list of protocols, 
>  DSR, ABR, ZRP, OLSR, etc. all of which try to deal 
>  with this problem, how to track topology changes."

The difficult problem in MANETs is not tracking the network topology per 
se (e.g. the never ending list of routing protocols), instead the 
difficult problem in MANETs is reliably & stably knowing who your 
neighbors are.

So, I agree with John that

>  ... if we knew who our neighbors are, we could set
>  up the network.  The problem is that in practice, 
>  we know nothing and need to proceed on the basis 
>  of intelligent guesses.  I think that a bigger 
>  problem is that so much work is done in MANET 
>  protocol design that completely ignores this problem.

Jim

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
James A. Stevens, PhD
Chief Network Architect
Rockwell Collins Government Systems
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Kenneth Brayer <[email-masked]>
Date: Thu, 04 May 2006 15:10:34 -0400

Jim
For all the reasons that John gave the network may not be stable. I 
think reliably knowing who your neighbors are is the same as tracking 
the network topology. I agree that MANET designers should seek to do this.
Ken

[email-masked] wrote:

> The difficult problem in MANETs is not tracking the network topology 
> per se (e.g. the never ending list of routing protocols), instead the 
>------------------------------------------------------------------------
>

-- 
Kenneth Brayer
Fellow of the IEEE
M/S M370
The MITRE Corporation
202 Burlington Road
Bedford, MA 01730

e-mail: [email-masked]
tele: 781-271-5254
fax: 781-271-2841