Subject: [manet] Curious about how to evaluate the performance of ad hoc network protocols

From: "Luo.Gang" <[email-masked]>
Date: Fri, 5 May 2006 00:48:11 +0800

Hi all,

	Many routing protocol have been proposed to MANET WG, such as AODV, DSR, OLSR, even RMP, PMP. People usuall evaluate the protocol performance by simulation in their literatures.

	I believe that the antena model, the mobility model and the traffic model have a large effect on the performance evaluation of an ad hoc network protocol.
	I wonder is there any performance evaluation test-suit/benchmark/standard or something similar have been proposed for evaluate these protocols in some specific scenarios?

	Does MANET WG concern about this problem? (How to evaluate the performance of ad hoc network protocols without bias)
	I am sorry if I've asked a stupid question.:)
	Any Information, opinion and recommands will be helpful to me, thanks in advance.

Regards,
--
Luo Gang

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: Vítor Jesus <[email-masked]>
Date: Thu, 04 May 2006 18:25:41 +0100

Hi Luo,

Actually, your question is extremelly pertinent and I have thought of it
many many times and sometimes I just wished there were some kind of a
template or guidelaines for simulations in MANETs.

>From my own experience, it can be very hard to compare two solutions for
the same problem in MANETs. When it comes to routing, it can be a
nightmare, since you end up wondering how a routing protocol evaluation
can be so much subjective.

Part of the problem is... defining the problem. Even a routing protocol
can be analysed in multiples ways, each with its own performance metrics.
The other problem is the conditions under which the performance is
evaluated. Take a look at a paper called "MANET Simulation Studies: The
Incredibles" by Kurkowski and others.

Best regards,
--vítor jesus