Subject: RE: [manet] the definition of neighbor

From: "Mullen, John" <[email-masked]>
Date: Wed, 3 May 2006 10:32:40 -0600

Hi,
 
Generally, a neighbors are considered nodes that can communicate with each other.  However, when it gets to modeling and implementation, this definition can be a bit iffy.  I've seen terms like "two-hop neighbors," which would include nodes that cannot connect with the node in question directly, but can connect with a one-hop neighbor.  "Neighborness" also depends on the data rate.  Two nodes that can communicate at 1Mb/s may not be able to at 10Mb/s, so two nodes that can exchange Hello messages may not be able to exchange data packets.
 
The situation gets even messier when fine-grained variations in signal strength are taken into account.  Then, a neighbor definition would include som minimum service quality.
 
In simulation, one sometimes assumes that there is a range, within which nodes can communicate and beyond which they cannot.  This is a simplifying assumption.  The value of that range will depend on what other assumptions you are making, such as the type of transmitter, allowances for fading and shadowing, the channel, the nature of the receiver, the waveform you are using, engoding, error correction, etc.  If you look into the background of the model you are using, you will probably find a statement of why 250 was selected.  

John P. Mullen, Ph.D.
(505) 646-2958
[email-masked]

________________________________

From: www triste [mailto:[email-masked]] 
Sent: Wednesday, May 03, 2006 5:35 AM
To: [email-masked]
Subject: [manet] the definition of neighbor

Hello everybody
i want to know what is the real definition of neighbor?
x is neighbor of y = distance between x and y < 250 (and why exactly 250)
 
or
 
x is neighbor of y=y can receive hello paquets
 
(i discuss in general,with olsr,aodv,dsdv .... routing protocols)
 
Thanks for help or indication, 

________________________________

Faites de Yahoo! votre page d'accueil sur le web pour retrouver directement vos services préférés : vérifiez vos nouveaux mails, lancez vos recherches et suivez l'actualité en temps réel. Cliquez ici <http://us.rd.yahoo.com/mail/mail_taglines/yahoofr/*http://fr.yahoo.com/set> .
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: amr hassan <[email-masked]>
Date: Thu, 4 May 2006 01:44:28 -0700 (PDT)

Hi,
   
  A neighbor is a node that you can reach with a single hop. Of course this depends on the value of the radio TX power (so it is not absolutely 250m, it depends).

If you apply this to the hello messages being sent in AODV. Then yes, nodes receiving the hello messages are neighbors.
   
  Kind regards,
  Amr
  
Message: 4
Date: Wed, 3 May 2006 13:35:11 +0200 (CEST)
From: www triste 
Subject: [manet] the definition of neighbor
To: [email-masked]
Message-ID: <[email-masked]>
Content-Type: text/plain; charset="iso-8859-1"

Hello everybody

or

---------------------------------
New Yahoo! Messenger with Voice. Call regular phones from your PC and save big.