Subject: RE: [manet] Square neighborhood question

From: [email-masked]
Date: Wed, 25 Oct 2006 11:19:17 +0200

Hi Eduardo,

My thanks for you reply.

You have written :
> |V(i)| >= 1, because it counts the number of a node's neighbors and also the node itself.
Yes.

> So for the node j: sum ( 1/|V(Nj) ) <= 1 !
You can't write that.
if |V(i)| >= 1 then 1/|V(i)| <= 1.
le Nj and Nk be the nodes belonging to V(i).
Then |V(j)| >= 1 and |V(k)| >= 1, implying 1/|V(j)| <= 1 and 1/|V(k)| <= 1.
So 1/|V(i)| + 1/|V(j)| + 1/|V(k)| <= 3 (not <= 1).

Also, please note that square neighborhood is two hops neighborhood.

	Raphaël

> -----Message d'origine-----
> De : Eduardo Silva [mailto:[email-masked]]
> Envoyé : mercredi 25 octobre 2006 11:10
> À : [email-masked]
> Cc : [email-masked]
> Objet : Re: [manet] Square neighborhood question
> 
> 
> Hi,
> 
> If V(Ni) is the set of nodes in the neighborhood for the Ni node, 
> admitting the it is containing the node itself, the cardinality of 
> V(Ni), |V(i)|, will always be equal or bigger to 1, |V(i)| >= 
> 1, because 
> it counts the number of a node's neighbors and also the node itself.
> 
> So for the node j: sum ( 1/|V(Nj) ) <= 1 !
> 
> I think this might answer your question.
> 
> All the best,
> 
> /edu
> 
> 
> [email-masked] wrote:
> > Hello all,
> > 
> > Let G be a network, and Ni any node from this network.
> > Let V²(Ni) be set containing all nodes in the square 
> neighborhood of node Ni and |V²(Ni)| its cardinality.
> > Note that V²(Ni) contains Ni.
> > Does anybody knows how to demonstrate that the following 
> inequality holds :
> > 
> > sum of 1/|V²(Nj)| for Nj in V²(Ni) <= 1 ?
> > 
> > Thank you for any answer.
> > 
> > 	Raphaël
> > 
> > 
> > 
> > 
> > 
> > 
> > _______________________________________________
> > manet mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/manet
> > 
> 

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: [email-masked]
Date: Wed, 25 Oct 2006 17:30:23 +0200

Tim,

Thank you for your time, and your reply.
I notice that my notation V² is confusing.
In fact I did not mean V*V but rather the two hops neighborhood.

Anyhow Philippe has provided a conter-example.

	Raphaël

> De : Brown Tim [mailto:[email-masked]]
> Envoyé : mercredi 25 octobre 2006 17:24
> Consider a square neighborhood around node c:
>      -------------
>     |a           b|
>     |             |
>     |      c      |
>     |             |
>     |d           e|
>      -------------
> 
> |V(c)|=5
> |V(x)|=2 for all x != c
> So sum of 1/|V(x)| = 2.2
> 
> Sum of 1/|V(x)|^2 for x!=c = 1 in this case
> so perhaps this is what you are looking for.
> 
> 	Regards,
> 		Tim
> 
> On Wed, 25 Oct 2006 [email-masked] wrote:
> 
> > Hello all,
> >
> Timothy X Brown
> Interdisciplinary Telecommunications
> Electrical and Computer Engineering
> ECOT 256 Campus Box 530
> University of Colorado
> Boulder, CO 80309
> Tel: (303) 492-1630
> Fax: (303) 492-1112
> http://ece.colorado.edu/~timxb
>