Subject: Re: [manet] routing protocol in Mesh

From: "Nguyen Lan" <[email-masked]>
Date: Fri, 21 Sep 2007 10:02:56 +0900

Hello,

Thank you for your reply.
My question is that what is the most appropriate routing protocol for Mesh
(stationary nodes). Some authors claimed that routing protocols for ad-hoc
network is not good to apply to Mesh. Than I found that IEEE 802.11 even
have recommended for routing in Mesh HWMP (AODV-based) and RA-OLSR. I would
like to make a survey about routing in Mesh (pros/cons).

Susan Hares wrote:

By way - 1MT is the name of a Wurlitzer juke box that plays CDs. It's
resembles the past juke boxes – but its really cool.

It is nice to hear that. Should I try it.

HWMP has some very cool additions to do pro-active loading of routes from
portals (interfaces to non-wimesh LANs). The collaboration put in some nice
goodies (just like the CD juke box).

If you'd like a detailed summary (with or without humor), let me know.

Yes, If you don't mind plz enlighten me somehow.

I've been working on this for the last few years with the IEEE 802.11s. Don
Fedyk (Nortel) and I put together something for the IEEE 802.11s on this
topic. If you give a day or two, I'll find the IEEE site reference so you
can down load it. You can scan the IEEE web site for something that we
submitted during 2005.

I would very appreciate

The scenario link-state has clear wins over HWMP – is in the voice fast
fail-over times in 12-50 nodes.

Where can I find the matterials

Bests
Nguyen.

Sue

* From: * Nguyen Lan [mailto:[email-masked]<[email-masked]>]

*Sent:* Monday, September 17, 2007 1:35 AM
*To:* [email-masked]
*Subject:* [manet] routing protocol in Mesh

Dear all,

I have a question related to routing in Wireless Mesh Networks:

802.11s define HWMP as a mandatory routing protocol for WMN and another
alternate protocol is RA-OLSR. Can you inlighten me when using HWMP is more
preferable to the other.

Thank you very much.

Cheers,
Nguyen.
_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 21 Sep 2007 12:50:17 -0700

Hello Nguyen,

I expect you will get a lot of different opinions about this.

First, if everything is truly static, then the need for a
routing protocol is reduced to the need for a good
initialization program, which would not have to run
again.

If the nodes are truly stationary and available in the
mesh, then you may still have some route decisions
to make that depend on current link conditions (such
as congestion and so on).  In this case, your choice
would be dictated by the needs of your application.
If the nodes are not so stationary, then it could make
a big difference in how you will decide.

Are you only interested in choosing between the
two variations of 802.11s, or are you interested in
other protocols that are running in mesh networks?
Are you only interested in 802.11?  Are you interested
in mesh networks that admit interoperation with
adjoined ad hoc networks?  Are you interested in
mesh networks that are operating without any
connection to the global Internet?  Are you only
interested in protocols that are available as free
downloads for your platform?

All of these will strongly influence your choice!

Regards,
Charlie P.

ext Nguyen Lan wrote:
> My question is that what is the most appropriate routing protocol for 
> Mesh (stationary nodes). Some authors claimed that routing protocols 
> for ad-hoc network is not good to apply to Mesh. Than I found that 
> IEEE 802.11 even have recommended for routing in Mesh HWMP 
> (AODV-based) and RA-OLSR. I would like to make a survey about routing 
> in Mesh (pros/cons).
>
> Susan Hares wrote:
>>
>> HWMP has some very cool additions to do pro-active loading of routes 
>> from portals (interfaces to non-wimesh LANs). The collaboration put 
>> in some nice goodies (just like the CD juke box).
>>
>> I've been working on this for the last few years with the IEEE 
>> 802.11s. Don Fedyk (Nortel) and I put together something for the IEEE 
>> 802.11s on this topic. If you give a day or two, I'll find the IEEE 
>> site reference so you can down load it. You can scan the IEEE web 
>> site for something that we submitted during 2005.
>>
> I would very appreciate
>>
>> The scenario link-state has clear wins over HWMP – is in the voice 
>> fast fail-over times in 12-50 nodes.
>>
>> * From: * Nguyen Lan [mailto:[email-masked]]
>> 802.11s define HWMP as a mandatory routing protocol for WMN and 
>> another alternate protocol is RA-OLSR. Can you inlighten me when 
>> using HWMP is more preferable to the other.
>>
>> Thank you very much.
>>
>> Cheers,
>> Nguyen.
>>
>
>
> ------------------------------------------------------------------------
>

---

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 28 Sep 2007 10:00:03 -0700

Hello Nguyen,

I thought about your problem and I really
think the best answer is either that it does not
matter, or else it depends on things that you
did not mention.

However, I would myself prefer the reactive
approach, with long route timeouts.  It's just
that the savings would be one-time savings
instead of continual savings since initialization
is a one-time event.

For the failover case mentioned by Sue, there
are again various dependencies but I think
the RERR facility works well.  If augmented
by local route repair and/or various trigger
conditions, I reckon we could get almost
real-time failovers still with the low reactive
overhead.  However, I should point out that
failover handling is something not within the use
case scenario of truly static operation as was
suggested in your earlier request.

If your need is only for initialization, and it
is not targeted towards a product, then I think
the best choice would be just whatever is
easier for you to develop and install.

Regards,
Charlie P.

ext Nguyen Lan Tien wrote:
> Hello Charles,
> Thank you for hints.
> Do you think OLSR is a good start point in this case. If not, which 
> routing protocol do you recommend.
>
> Best regards,
> Nguyen.
>
>
>>
>>> My question is that what is the most appropriate routing protocol 
>>> for Mesh (stationary nodes). Some authors claimed that routing 
>>> protocols for ad-hoc network is not good to apply to Mesh. Than I 
>>> found that IEEE 802.11 even have recommended for routing in Mesh 
>>> HWMP (AODV-based) and RA-OLSR. I would like to make a survey about 
>>> routing in Mesh (pros/cons).
>>>
>>> Susan Hares wrote:
>>>>
>>>> By way - 1MT is the name of a Wurlitzer juke box that plays CDs. 
>>>> It's resembles the past juke boxes – but its really cool.
>>>>
>>>> HWMP has some very cool additions to do pro-active loading of 
>>>> routes from portals (interfaces to non-wimesh LANs). The 
>>>> collaboration put in some nice goodies (just like the CD juke box).
>>>>
>>>> 802.11s. Don Fedyk (Nortel) and I put together something for the 
>>>> IEEE 802.11s on this topic. If you give a day or two, I'll find the 
>>>> IEEE site reference so you can down load it. You can scan the IEEE 
>>>> web site for something that we submitted during 2005.
>>>>
>>> I would very appreciate
>>>>