Subject: RE: [manet] Distance Maximum Size 8-bits or 16-bits?

From: "Teco Boot" <[email-masked]>
Date: Wed, 5 Sep 2007 19:21:29 +0200

I thought about using 8-bit exponential link metrics combined with a 8-bit
distance, used as exponential path metric. I used the (16+a)*2^b-15 format,
as I still highly prefer this one for being used by OLSR.

I performed all possible calculations and checked the outcome. I used the
following algorithm:
 1) Uncompress IncomingDistance
 2) Add (linear) link metric 
 2) Compress outcome into exponential path metric
 4) The AdvertizedDistance is maximum of:
    - IncomingDistance + 1
    - CalculatedDistance (step 3)
Although is seems to work, there are some problems.

One problem is the decreased number of hops supported. This problem occurs
when nodes use increments larger than one, which is allowed in the current
DYMO draft text also.
Supporting 255 hops, each with a link metric of 254, the linear path metric
is 250.671.375, using (16+a)*2^b-15 the value 381 is needed. So an
exponential 9-bit distance would handle this, using a 5-bit exponent.
Many hops with such a high link metric would not be needed, but what about 2
links with metric 557.041 (exponential value: 241)? Or one link with metric
557.041 and 15 high speed links?

Another problem is defining the in- or outbound interface link metric. When
not specified, one implementation would select inbound, another
implementation selects outbound. In the same MANET, one direction would have
a double counted high metric link; the opposite direction does not use the
metric for this link at all. 
We have a similar discussion on OLSR inbound or outbound interface metrics
for path calculation.

And another problem is the loss of accuracy. When in the path a high metric
link is present, path calculation before this link is accurate, after
passing the link it is not. In the opposite direction, loss of accuracy is
on the other part of the path. 

                +----+       321      +----+ 
                | R1 |----------------| R4 |
                +----+                +----+    
                /  |                    | \
              1/   |                    |  \1
              /    |                    |   \
           +----+  |                    |  +----+
           | R2 |  |11                11|  | R5 |
           +----+  |                    |  +----+
               \   |                    |   /
               1\  |                    |  /1
                 \ |                    | /
                +----+                +----+
                | R3 |                | R6 |
                +----+                +----+

In this example, the path from R3 to R6 is R3-R2-R1-R4-R6. Opposite
direction is R6-R5-R4-R1-R3. Note that the WPF path is chosen after the high
metric link. Link state protocols would select the best path:
R3-R2-R1-R4-R5-R6. 
In practice, the effect of the problem would not be that annoying, as the
metric is to be used to select a path around the "real bad link" in the
first place. But IMHO it is a bad behavior of the protocol and it needs to
be solved.

Teco.

> -----Original Message-----
> From: Ian Chakeres [mailto:[email-masked]]
> Sent: vrijdag 17 augustus 2007 19:20
> To: manet
> Subject: [manet] Distance Maximum Size 8-bits or 16-bits?
> 
> I wanted to ask everyone if they have an opinion about the maximum
> distance size in DYMO.
> 
> Do you think 8-bits are sufficient (i.e. 256 values)? Or are 16-bits
> required?
> 
> Please let me know your opinion. In the absence of responses I will
> assume 8-bits are enough.
> Ian Chakeres
> 
> 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/manet

_______________________________________________
manet mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/manet

---

From: "Dearlove, Christopher \(UK\)" <[email-masked]>
Date: Thu, 6 Sep 2007 13:28:54 +0100

From: Teco Boot [mailto:[email-masked]] 
> We have a similar discussion on OLSR inbound or outbound interface
metrics

No to the latter point (I don't know about DYMO). The whole
rationale for having directional link metrics in the first
place (in draft-dearlove-olsrv2-metrics-00) is that which
direction link metric must be (and in that document is)
specified.

Of course you may end up selecting different paths A to B
and B to A, but that can and does happen with minimum hop
paths too.

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************