Subject: Re: [manet] [Roll] Discussion on draft

From: JP Vasseur <[email-masked]>
Date: Wed, 09 Apr 2008 15:01:54 -0400

> From: Zachary Smith <[email-masked]>
> Date: Wed, 9 Apr 2008 11:54:27 -0700
> To: Chandrashekhar Appanna <[email-masked]>
> Cc: <[email-masked]>, manet manet <[email-masked]>
> Subject: Re: [Roll] Discussion on draft
> 
> 
> On Apr 9, 2008, at 11:14 AM, Chandrashekhar Appanna wrote:
> 
>>> Let's start with 1), as it's probably the simplest. Are there any
>>> protocols that we should be including that aren't there?
> 
> 
> I was struck by the lack of simple hierarchical protocols for the
> wireless domain - in the style of Cluster Tree. These have the
> benefits of generally requiring low resources on the device and low
> discovery overhead but, of course, when things go wrong they can be
> hard to repair.

With the usual trade-off between "optimality" and "scalability". Yes,
hierarchy will definitely be discussed in the Routing Architecture document.

Thanks.

JP 

> 
> Just a thought.
> 
>    z
> 
> Zachary Smith - CTO
> http://www.daintree.net/
> [email-masked]
> 
> 
> 
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

_______________________________________________
manet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/manet

---

From: Philip Levis <[email-masked]>
Date: Wed, 9 Apr 2008 13:41:55 -0700

On Apr 9, 2008, at 11:14 AM, Chandrashekhar Appanna wrote:
> Hi,
>
> The big elephant, BGP is missing. I think we should add it in
> if especially you want to cover all IETF protocols. There have
> been instances of folks tinkering with BGP for such applications
> too.
>
> I can provide some text to cover BGP.. let me know.

Whoops! I guess I didn't add enough qualifications to my statement.  
Understandably, the document is trying to address internal routing  
protocols (within an administrative domain, i.e., IGPs), not gateway  
protocols between administrative domains (BGP, EGP, etc.). The  
requirements for the latter are sufficiently different that it's a bit  
of apples and oranges.

Phil

---

From: Zachary Smith <[email-masked]>
Date: Wed, 9 Apr 2008 11:54:27 -0700

Just a thought.

   z

Zachary Smith - CTO
http://www.daintree.net/
[email-masked]

---

From: Chandrashekhar Appanna <[email-masked]>
Date: Wed, 9 Apr 2008 16:37:11 -0700

> requirements for the latter are sufficiently different that it's a bit  

  I do not think it comes out like that.. esp that you have
  a section of distance vector protocols and BGP is used a lot
  in many such scenarios too. I have personally been involved
  in discussions about using BGP in many of scenarios we have
  discussed in the requirements.. so even if it is to prevent
  further propagation of that it would be good to list it in
  there. BGP is used as both iBGP and eBGP.. 

  However, your angle is also ok in that it is consistent..
  though I have not seen that mentioned till date and to me
  is was not obvious.

  Chandra.

---

From: Chandrashekhar Appanna <[email-masked]>
Date: Wed, 9 Apr 2008 11:14:28 -0700

Hi,

Rgds,
Chandra.

On Thu, Mar 27, 2008 at 08:43:12PM -0700, Philip Levis wrote:
> I'd like to start a discussion on draft-levis-roll-overview-protocols.  
> In particular, Section 5.8 has a table of several existing protocols  
> and their properties. This table is really going to be critical in  
> ROLL's assessment of existing technologies and protocols, so we want  
> to make sure that
> 
> 1) It has the relevant data points to compare (protocols/rows)
> 2) It distills what the important properties are(columns)
> 3) It accurately captures the properties of the values in question  
> (cells are accurate)
> 
> protocols that we should be including that aren't there? Trying to  
> cover every single minor protocol tweak is a recipe for disaster, but  
> protocols that differ significantly from those currently there, either  
> in mechanism or in properties, are important to include.
> 
> Phil