Subject: Re: [manet] route maintenance module in manet

From: msharil abdullah <[email-masked]>
Date: Sat, 30 Aug 2008 19:05:34 -0700 (PDT)

have a great day mr abbas...
 
thank your for your responds to my problem 
 
actually Q-DIR is Quadrant based Directional Routing, one of reactive routing protocol, how it work? based on restricted flooding principle, so, only intermediate nodes in same quadrant to destination nodes from soure node will participate. Q-DIR is new routing protocol in manet introduced by Latiff.A.L (2007) and enhancement of AODVbis, this routing protocol was successful in test bed and simulation but it's only in static node topology.
 
so, my interest are :
 
to develop route maintenance module based on Q-DIR, when 
1. route break i n

mohd sharil bin abdullah
> Faculty Of Electrical Engineering
> University Technology of Malaysia
> Skudai, Johor, Malaysia
> 

--- On Sat, 8/30/08, Ash Mohammad Abbas <[email-masked]> wrote:

From: Ash Mohammad Abbas <[email-masked]>
Subject: Re: [manet] route maintenance module in manet
To: [email-masked], [email-masked]
Date: Saturday, August 30, 2008, 9:42 AM

Dear Sharil

I don't know what exactly you are doing in Q-DIR.

However, I anticipate that in Q-DIR you might be sending a query packet (such
as a Route Request (RREQ) packet). A node might be sending an RREQ to the
neighboring nodes in the quadrant. Ultimately, the RREQ arrives at the
destination. Also, I anticipate that (correct me if I am wrong) the destination
might be responsible to send the Route Replies (RREP) to the node from which it
has received the RREQ. The node, in turn, sends the RREP to next node towards
the source. This can be done easily since the  nodes might be having location
information of next hop nodes (upstream for RREP and downstream for RREQ). 

For route maintenance, nodes sense whether the link to a neighbouring  node is
broken. If that is so, the sensing node informs the next hop   nodes upstream
about the link failure by sending a Route Error (RERR) packet. Since you are
using a quadrant based routing, therefore, a node may send the RERR packet to
neighbouring nodes that are part of the upstream quadrant (or to specific
upstream nodes based their locations).
I don't know whether in Q-DIR you identify a single path (may be a shortest
path in terms number of hops from source to destination) or multiple paths. The
route maintenance procedure will be modified accordingly.

You may refer to some papers dealing with location based routing.
 
I hope this helps.

Ash Mohammad Abbas   
http://www.cse.iitd.ernet.in/~abbas   

--- On Sat, 30/8/08, msharil abdullah <[email-masked]> wrote:

> From: msharil abdullah <[email-masked]>
> Subject: [manet] route maintenance module in manet
> To: [email-masked]
> Date: Saturday, 30 August, 2008, 3:29 PM
> hi... and have a great day to all
>  
>  
> my name is mohd sharil bin abdullah from Malaysia, My
> research field is to develop route maintenance based
> on Q-DIR
>   
> Q-DIR is an enhancement of AODVbis 
>   
> Q-DIR is a limited flooding routing protocol that
> concentrates on a specified 
> zone using location information provided by a location
> service
>  
> Q-DIR determines the quadrant of the current node based on
> the coordinates 
> of source, destination and the current node that will
> direct the packet towards the 
> destination
>  
>  
> so that, may i get some advice from you all regrading route
> maintenance in mobile topology and i really appreciate, if
> you can share with me...any title of book or website
> regarding this issue
>  
> thank you in advance....
>  
> mohd sharil bin abdullah
> Faculty Of Electrical Engineering
> University Technology of Malaysia
> Skudai, Johor, Malaysia
> 
> 
> 
>       _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

      Add more friends to your messenger and enjoy! Go to
http://in.messenger.yahoo.com/invite/

_______________________________________________
manet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/manet

---

From: msharil abdullah <[email-masked]>
Date: Sat, 30 Aug 2008 19:05:36 -0700 (PDT)

so, my interest are :
 
1. route break in 

mohd sharil bin abdullah

Dear Sharil

 
I hope this helps.

Ash Mohammad Abbas