Subject: [manet] route maintenance module in manet

From: msharil abdullah <[email-masked]>
Date: Sat, 30 Aug 2008 02:59:17 -0700 (PDT)

hi... and have a great day to all

my name is mohd sharil bin abdullah from Malaysia, My research field is to develop route maintenance based on Q-DIR
  
Q-DIR is an enhancement of AODVbis 
  
Q-DIR is a limited flooding routing protocol that concentrates on a specified 
zone using location information provided by a location service
 
Q-DIR determines the quadrant of the current node based on the coordinates 
of source, destination and the current node that will direct the packet towards the 
destination

so that, may i get some advice from you all regrading route maintenance in mobile topology and i really appreciate, if you can share with me...any title of book or website regarding this issue
 
thank you in advance....
 
mohd sharil bin abdullah
Faculty Of Electrical Engineering
University Technology of Malaysia
Skudai, Johor, Malaysia

_______________________________________________
manet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/manet

---

From: Ash Mohammad Abbas <[email-masked]>
Date: Sat, 30 Aug 2008 22:12:57 +0530 (IST)

Dear Sharil

I don't know what exactly you are doing in Q-DIR.

However, I anticipate that in Q-DIR you might be sending a query packet (such as a Route Request (RREQ) packet). A node might be sending an RREQ to the neighboring nodes in the quadrant. Ultimately, the RREQ arrives at the destination. Also, I anticipate that (correct me if I am wrong) the destination might be responsible to send the Route Replies (RREP) to the node from which it has received the RREQ. The node, in turn, sends the RREP to next node towards the source. This can be done easily since the  nodes might be having location information of next hop nodes (upstream for RREP and downstream for RREQ). 

For route maintenance, nodes sense whether the link to a neighbouring  node is broken. If that is so, the sensing node informs the next hop   nodes upstream about the link failure by sending a Route Error (RERR) packet. Since you are using a quadrant based routing, therefore, a node may send the RERR packet to neighbouring nodes that are part of the upstream quadrant (or to specific upstream nodes based their locations).
I don't know whether in Q-DIR you identify a single path (may be a shortest path in terms number of hops from source to destination) or multiple paths. The route maintenance procedure will be modified accordingly.

You may refer to some papers dealing with location based routing.
 
I hope this helps.

Ash Mohammad Abbas   
http://www.cse.iitd.ernet.in/~abbas   

--- On Sat, 30/8/08, msharil abdullah <[email-masked]> wrote:

> From: msharil abdullah <[email-masked]>
> Subject: [manet] route maintenance module in manet
> To: [email-masked]
> Date: Saturday, 30 August, 2008, 3:29 PM
> my name is mohd sharil bin abdullah from Malaysia, My
> research field is to develop route maintenance based
> on Q-DIR
>   
> so that, may i get some advice from you all regrading route
> maintenance in mobile topology and i really appreciate, if
> you can share with me...any title of book or website
> regarding this issue
>  
> thank you in advance....
>  
> mohd sharil bin abdullah

      Add more friends to your messenger and enjoy! Go to http://in.messenger.yahoo.com/invite/
_______________________________________________
manet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/manet

---

From: msharil abdullah <[email-masked]>
Date: Sat, 30 Aug 2008 19:30:17 -0700 (PDT)

have a great day mr abbas...
 
thank your for your responds to my problem 
 
For your futher information, Q-DIR is Quadrant based Directional Routing, one of reactive routing protocol, how it work? based on restricted flooding principle, so, only intermediate nodes in same quadrant to destination nodes from soure node will participate. Q-DIR is new routing protocol in manet introduced by L.A. Latiff (2007) and enhancement of AODVbis, this routing protocol was successful in test bed and simulation but it's only in static node topology.
 
so, my interest are :
 
to simulate Q-DIR in mobile topology and develop route maintenance module based on Q-DIR, when 
1. route break between intermediate nodes
2. route break between intermediate node and source node
3. route break between intermediate node and destination node
 
When, i tried simulated sparse topology, several problem occurs :
 
1. By example, packet forwarded from node source A to node B to node destination C, when node B move of tranmission 
   range of node C, route break between B and C, then after life time, RERR send to node A, after received RERR, node A start new route discovery.... so how to make node B do route repair?
 
mr abbas... again thank you for your suggestion before, it help me a lot.... i really appreciate ur next assistance and advice, tq sir

mohd sharil bin abdullah
> University Technology of Malaysia

--- On Sat, 8/30/08, Ash Mohammad Abbas <[email-masked]> wrote:

From: Ash Mohammad Abbas <[email-masked]>
Subject: Re: [manet] route maintenance module in manet
To: [email-masked], [email-masked]
Date: Saturday, August 30, 2008, 9:42 AM

Dear Sharil

However, I anticipate that in Q-DIR you might be sending a query packet (such
as a Route Request (RREQ) packet). A node might be sending an RREQ to the
neighboring nodes in the quadrant. Ultimately, the RREQ arrives at the
destination. Also, I anticipate that (correct me if I am wrong) the destination
might be responsible to send the Route Replies (RREP) to the node from which it
has received the RREQ. The node, in turn, sends the RREP to next node towards
the source. This can be done easily since the  nodes might be having location
information of next hop nodes (upstream for RREP and downstream for RREQ). 

For route maintenance, nodes sense whether the link to a neighbouring  node is
broken. If that is so, the sensing node informs the next hop   nodes upstream
about the link failure by sending a Route Error (RERR) packet. Since you are
using a quadrant based routing, therefore, a node may send the RERR packet to
neighbouring nodes that are part of the upstream quadrant (or to specific
upstream nodes based their locations).
I don't know whether in Q-DIR you identify a single path (may be a shortest
path in terms number of hops from source to destination) or multiple paths. The
route maintenance procedure will be modified accordingly.

I hope this helps.

Ash Mohammad Abbas   

> University Technology of Malaysia

      Add more friends to your messenger and enjoy! Go to
http://in.messenger.yahoo.com/invite/

---

From: Ash Mohammad Abbas <[email-masked]>
Date: Sun, 31 Aug 2008 08:52:50 +0530 (IST)

Dear Sharil
If the topology is too sparse there may be a very few nodes (may be a single node or may not be a node at all-- routing won't be possible, then) in the next quadrant. As a result, choices for repair of routes will be limited. If there is only a single node in the next quadrant, and if this node either fails or moves out of the transmission range of either of its upstream or downstream nighbor, there will be a link break, and there won't be a choice for route repair because it was the only node in the next quadrants of its upstream or downstream neighbors.

In general, you may simulate a topology which is not so sparse. Too sparse, and too dense topologies may be special cases. On an average, there may be more than one nodes in the next quadrants, therefore, if a node that is part of the quadrant either fails or moves, the route is established through a node in the same quadrant (i.e. the route is repaired). If the route cannot be repaired, there will be no choice other than rediscovring the routes.

Other part of your question about route maintenance: (2) and (3) are special cases of (1). The routing table entries may contain the information about the source and destination.   

You may refer to the following paper (although, it is not about quadrant based directional routing, it describes a bit about routing using directional antennas), that you can download from ACM Digital Library.

Ash Mohammad Abbas, Mansoor Alam, Bijendra Nath Jain, "Alleviating Path Correlation Using Directional Antenna in Node-Disjoint Multipath Routing for Mobile Ad hoc Networks", In Proceedings of 3rd ACM International Wireless Communication and Mobile Computing Conference (IWCMC 2007), pp. 405-410, Honululu, Hawaii, U.S.A., August 12-14, 2007.

Hope it helps,
Abbas  

Ash Mohammad Abbas   

--- On Sun, 31/8/08, msharil abdullah <[email-masked]> wrote:

> To: [email-masked]
> Cc: [email-masked]
> Date: Sunday, 31 August, 2008, 8:00 AM
> For your futher information, Q-DIR is Quadrant based
> Directional Routing, one of reactive routing protocol, how
> it work? based on restricted flooding principle, so, only
> intermediate nodes in same quadrant to destination nodes
> from soure node will participate. Q-DIR is new routing
> protocol in manet introduced by L.A. Latiff (2007) and
> enhancement of AODVbis, this routing protocol was
> successful in test bed and simulation but it's only in
> static node topology.
>  
> so, my interest are :
>  
> 1. By example, packet forwarded from node source A to node
> B to node destination C, when node B move of tranmission 
>    range of node C, route break between B and C, then
> after life time, RERR send to node A, after received RERR,
> node A start new route discovery.... so how to make node B
> do route repair?
>  
> mr abbas... again thank you for your suggestion before, it
> help me a lot.... i really appreciate ur next assistance and
> advice, tq sir
>  
>  
>  
>  
>  
> 
> 
> mohd sharil bin abdullah
> > Q-DIR determines the quadrant of the current node
> based on
> > the coordinates 

      Unlimited freedom, unlimited storage. Get it now, on http://help.yahoo.com/l/in/yahoo/mail/yahoomail/tools/tools-08.html/
_______________________________________________
manet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/manet