Subject: Re: [manet] [Editorial Errata Reported] RFC5444 (1790)

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Wed, 3 Jun 2009 09:33:39 +0100

This should be accepted.

-- 
Christopher Dearlove
Technology Leader, Communications Group
Networks, Security and Information Systems Department
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194  Fax: +44 1245 242124

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87,
Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

-----Original Message-----
From: RFC Errata System [mailto:[email-masked]] 
Sent: 02 June 2009 19:56
To: [email-masked]; Dearlove, Christopher (UK);
[email-masked]; [email-masked]; [email-masked];
[email-masked]; [email-masked];
[email-masked]
Cc: [email-masked]; [email-masked];
[email-masked]
Subject: [Editorial Errata Reported] RFC5444 (1790)

The following errata report has been submitted for RFC5444,
"Generalized Mobile Ad Hoc Network (MANET) Packet/Message Format".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=5444&eid=1790

--------------------------------------
Type: Editorial
Reported by: Yannick Lacharit <[email-masked]>

Section: Appendix E

Original Text
-------------
[...]

The packet contains a single message with length 54 octets.
                                                  ^
[...]

      0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     |0 0 0 0 1 0 0 0|    Packet Sequence Number     | Message Type  |
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     |1 1 1 1 0 0 1 1|0 0 0 0 0 0 0 0 0 0 1 1 0 1 1 0|   Orig Addr   |
                                                    ^

Corrected Text
--------------
[...]

The packet contains a single message with length 55 octets.
                                                  ^
[...]

      0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     |0 0 0 0 1 0 0 0|    Packet Sequence Number     | Message Type  |
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     |1 1 1 1 0 0 1 1|0 0 0 0 0 0 0 0 0 0 1 1 0 1 1 1|   Orig Addr   |
                                                    ^

Notes
-----
Correction to the message length, which is 55 instead of 54.

Instructions:
-------------
This errata is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party (IESG)
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC5444 (draft-ietf-manet-packetbb-17)
--------------------------------------
Title               : Generalized Mobile Ad Hoc Network (MANET)
Packet/Message Format
Publication Date    : February 2009
Author(s)           : T. Clausen, C. Dearlove, J. Dean, C. Adjih
Category            : PROPOSED STANDARD
Source              : Mobile Ad-hoc Networks
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: RFC Errata System <[email-masked]>
Date: Tue, 2 Jun 2009 11:55:56 -0700 (PDT)

--------------------------------------
Type: Editorial
Reported by: Yannick Lacharité <[email-masked]>

Section: Appendix E

Original Text
-------------
[...]

Corrected Text
--------------
[...]

Notes
-----

Instructions:
-------------

Title               : Generalized Mobile Ad Hoc Network (MANET) Packet/Message Format