Subject: [manet] AODV implementation doubts

From: Deepak Gopalakrishnan <[email-masked]>
Date: Thu, 9 Jul 2009 16:14:22 +0530

I have started to implement the AODV algorithm and i am facing hell lot of 
problems. 

I want to know how the reverse path and forward path maintained.
Is it that there is one route table and there is one entry for forward 
path and one for reverse path...?
or is it like there is a route table for forward path and another for 
reverse path.?

also in this concept of precursor...if i have to forward a RREP packet 
from a intermediate node to the precursor...im not able to decide which 
precursor i have to send because in my route table there are multiple 
precursors....

i am totally stuck in this... 
Regards,
Deepak Gopalakrishnan

---

From: Bringo Shawn <[email-masked]>
Date: Mon, 13 Jul 2009 06:46:50 -0700 (PDT)

To maintain forward and reverse paths, both of your suggestions are applicable but the former should be preferred as it demands only one table.
For the precursor, as for as I know, a list of precursor nodes is maintained at every node and you should send to the whole precursor list.

IMPORTANT:  Please DO INFORM me if you get any better solutions OR you or any one else thinks me wrong.

Regards