Subject: [manet] A view on packet-BB

From: "Charles E. Perkins" <[email-masked]>
Date: Thu, 29 Mar 2012 07:31:06 -0700

Hello folks,

I have not participated very much in any discussions about
packet-BB other than to encourage header size reduction and
offer a few suggestions about how to achieve it.  During that
time, it was claimed that for many networks of interest, the
use of packet-BB would *decrease* header size, perhaps
especially for proactive protocols.  This is a question
very suitable for resolution by way of simulation.

If, as I suspect, packet-BB does (on average) introduce
header enlargement on some networks that cannot afford it,
I would be in favor to introduce the option to run AODV
(or OLSR, for that matter) with some sort of "reduced"
header.  This should only be deployed in networks where
otherwise there would be no feasible deployment of an
ad-hoc networking protocol.  From that perspective, it's
almost a no brainer -- either deploy the standard stripped-
down version, or deploy something else nonstandard that
looks exactly like the stripped-down version.

In summary, if there are cases where the [manet] protocols
can only be deployed without packet-BB header overhead,
then I think we should provide a solution for those cases.

To be clear, I am happy either way, whether or not packet-BB
headers are mandates in all cases.

Also, to be clear, we can standardize AODVv2 *with* packet-BB
right now, and submit for consideration another document for
AODVv2 that does not require packet-BB.  Or, we can enable both
ways in the next revision.  Or, we can standardize AODVv2
that does NOT use packet-BB, and then submit for consideration
another document that DOES use packet-BB.  All cases are just
fine with me, depending on what the working group wants.

Regards,
Charlie P.

---

From: Henning Rogge <[email-masked]>
Date: Thu, 29 Mar 2012 18:33:28 +0300

PacketBB (RFC 5444) is always a balance between flexibility (being
able to add new TLVs without breaking compatibility and being able to
mix messages) and overhead. It partly compensates the overhead by
address compression (especially for IPv6).

If you don't care for extensibility, especially in IPv4 networks, you
most likely raise the overhead with PacketBB. Depends on the message
format and its encoding into TLVs.

Henning Rogge

On Thu, Mar 29, 2012 at 17:31, Charles E. Perkins <[email-masked]> wrote:
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

-- 
Steven Hawkings about cosmic inflation: "An increase of billions of
billions of percent in a tiny fraction of a second. Of course, that
was before the present government."