Subject: Re: [manet] MANET Protocol Applicability

From: "John Dowdell" <[email-masked]>
Date: Fri, 8 Jun 2012 11:00:00 +0100

I must say I agree with Chris. Even in my limited experience, the point of MANETs is that you should be able to use whatever you need as the L1/L2 transport. IP over anything that will take it; HF using STANAG 5506, satcom, 802.11, proprietary mesh networking, to name but a few. Each has its own strange foibles and it's up to the integrator to decide what is best for the task in hand. This is in the same vein as the subnet discussion earlier; MANET WG should not (IMHO) seek to define a policy because it will not fit every eventuality, of which there will be many and legion.

Having said that, some comments from clever people familiar with the current state of the art of implementation of MANETs for multi-agency disaster relief would be welcome, if any care to give them.

John

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Dearlove, Christopher (UK)
Sent: 08 June 2012 09:58
To: Abdussalam Baryun; manet
Subject: Re: [manet] MANET Protocol Applicability

Being explicit about L2 technologies is exactly what MANET should not do. At least not in any limiting way. Of course if someone were to write an informative draft about (say) using OLSRv2 over IEEE 802.11 that would be fine. Though it would run the risk of suggesting to some that that is the only L2 suggested,, so I'd want the draft to make it clear that wasn't so. And anything that said OLSRv2 was intended for use over the following L2 protocols would be completely wrong. The point of routing at L3 is to be as L2 independent as possible.

If I've read the draft you mention it was a long time ago. Digging up 1998 drafts to reissue doesn't strike me as the most productive possible exercise.

-- 
Christopher Dearlove
Senior Principal Engineer, Communications Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked] | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Abdussalam Baryun
Sent: 08 June 2012 04:42
To: manet
Subject: [manet] MANET Protocol Applicability

----------------------! WARNING ! ----------------------
This message originates from outside our organisation,
either from an external partner or from the internet.
Keep this in mind if you answer this message.
Follow the 'Report Suspicious Emails' link on IT matters
for instructions on reporting suspicious email messages.
--------------------------------------------------------

Hi Folks

I have read two important inputs and want to share my opinion,

============  point 1  ============

In one work in progress ietf-draft (expired):  draft-ietf-manet-appl-00.txt,
Corson, (1998)mentioned in Abstract and Introduction:

Abstract> The intent of this 'Applicability Section' is to
aid readers unfamiliar with the details of each protocol's design in
understanding the protocol's basic characteristics, functioning and
mechanisms, as well as to provide a general description of the
networking context for which the protocol was designed, and in which
it is expected to perform well.

Introduction> The set of applications for which the use of MANET
technology envisioned is diverse, ranging from small,
energy-constrained nearly
static networks to large-scale, mobile, highly-dynamic networks. The
combinations of network size, topology composition and dynamics,
bandwidth and energy availability, physical and link-layer
technologies, intended application usages, etc. are many, and it seems
 unlikely that a single protocol will function superiorly over this
wide range of networking contexts. Thus a given protocol is likely to
be well-suited for operation in those networks whose characteristics
match well with the combination of mechanisms employed by the
protocol.
============  point 2  ==============
In the MANET WG 77 meeting minutes, Mr.Clausen mentioned that it is
important to be explicit about assumptions/conditions before talking
about protocol.
============  opinion  ==============
I agree with both points and approach to solve routing protocols, and
would RECOMMEND either of the following:
1- MANET WG defines (in one informative-draft) intended application
usage, and be explicit about applicable L2 network technologies. So
that each future protocols mentions in their applicability statement
section the usual use-case for such protocol, OR
2- MANET WG renews the I-D expired of Corson (1998) and adds more
issues so it can become an RFC in future,

Thanking you,
Abdussalam Baryun
=========================
_______________________________________________
manet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/manet

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

_______________________________________________
manet mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/manet

---

From: Teco Boot <[email-masked]>
Date: Fri, 8 Jun 2012 12:58:32 +0200

> Having said that, some comments from clever people familiar with the current state of the art of implementation of MANETs for multi-agency disaster relief would be welcome, if any care to give them.
As dummy, I didn't feel addressed. But struggling with getting things done for multi-agency disaster relief, I can tell that I am not interested in discussions for finding best solutions for undefined scenario's. Improved interoperability is what I am looking for. Using IP helps, using proprietary sub-IP technology does not. It gets worse when security and apps get in scope.

With some experience from the customer side of the table, I say it is _not_ up to the integrator to decide what technology to use. I have to deal with multiple, making their own decisions. This needs to be standardized.

Teco