Subject: [manet] There is no document submitted so far to WG stating an update request for RFC3626

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 8 Jun 2012 19:25:08 +0200

Hi Teco,

> More precisely, we work on a replacement for the initial experimental
> version.

you mean that there is a work for replacement, I don't see any
discussion befor about that, please advise,

> RFC 3626 is not updated. It could get historic one day.
>

same what I thought, but one author of OLSRv2 mentioned that I may
misunderstood the process of OLSRv2, even though the authors don't
specify what will happen to RFC3626 when OLSRv2 is an RFC. I seen
other I-D when submitted for IESG they put inside the draft what the
draft authors intention if they obslete another documents or if their
new draft is updating any thing,

OLSRv2 does not mention the process of update, which IMHO it should if
authors want to update RFC3626,

I may be wrong, but I hope the chair updates me with the status, may
be he received a private request of update out of the discussion list,
please advise,

Regards

AB
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

On 6/8/12, Teco Boot <[email-masked]> wrote:
>
> Op 8 jun. 2012, om 14:31 heeft Henning Rogge het volgende geschreven:
>
>> On Fri, Jun 8, 2012 at 1:44 PM, Abdussalam Baryun
>> <[email-masked]> wrote:
>>> Hi Chris,
>>>
>>> Please note that MANET WG is doing OLSRv2 without updating RFC3626
>>> which make people think why?
>>
>> This sentence doesn't make sense.
>>
>> OLSRv2 IS the update of RFC 3626.
> More precisely, we work on a replacement for the initial experimental
> version.
> RFC 3626 is not updated. It could get historic one day.
>
> Teco
>
>>
>> Are you sure you understand how the IETF works to update existing
>> protocols?
>>
>> Henning Rogge
>>
>> --
>> Steven Hawkings about cosmic inflation: "An increase of billions of
>> billions of percent in a tiny fraction of a second. Of course, that
>> was before the present government."
>> _______________________________________________
>> manet mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/manet
>
>

---

From: Teco Boot <[email-masked]>
Date: Fri, 8 Jun 2012 20:13:04 +0200

> discussion befor about that, please advise,

I guess you can find it in the archives. 

> new draft is updating any thing,
I have confidence in authors' knowledge on the proces. Dito for chairs. 

> authors want to update RFC3626,

I believe they don't. 
Same for workgroup. 

> be he received a private request of update out of the discussion list,

I guess you misunderstood him. 

Enjoy your weekend. 
Teco

---

From: Stan Ratliff <[email-masked]>
Date: Fri, 8 Jun 2012 14:33:33 -0400

Abdussalam,

The first paragraph of the "Introduction" section of OSLRv2 states: 

"The Optimized Link State Routing protocol version 2 (OLSRv2) is the
 successor to OLSR (version 1) as published in [RFC3626]."

As such, I'm assuming that no additional work to RFC 3626 is expressed or implied - OLSRv1 is documented in RFC 3626; OLSRv2 is, for all intents and purposes, a new protocol documented by this new RFC. 

Regards,
Stan