Subject: Re: [manet] Updating or replacing RFC 3626

From: Abdussalam Baryun <[email-masked]>
Date: Sat, 9 Jun 2012 08:11:16 +0200

Hi Adrian,

I understood that there was no replace/update/obsolete, but some
author thought that I didn't know the system/process, I hope that
Chairs and author get to know the system,

Comments in Line:

>There is a whole range of options, and what you choose depends largely on what >future exposure you think OLSRv1 should have. You could:

- Move RFC 3626 to Historic
- Obsolete RFC 3626 with OLSRv2
- Leave RFC 3626 in place for further experimentation
- Update RFC 3626 as a separate activity to advance the experiment

>What I don't think you are doing with OLSRv2 is Updating RFC 3626.

If WG undertaking one of options excluding the third, I think a
document needs to be produced and submitted to the WG, IMHO we cannot
do such thing until the submission is announced, and consesus
collected. It has not been announce yet,

Best Wishes,

Abdussalam Baryun
Univeristy of Glamorgan, UK.

Regarding the

---

From: Abdussalam Baryun <[email-masked]>
Date: Sat, 9 Jun 2012 08:16:08 +0200

+1 with Thomas,

also we should also define network technologies to know how to use
OLSRv1 and OLSRv2, which I RECOMMEND to make a draft for definition L2
technology,

AB
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
On 8 Jun 2012, at 23:05, Henning Rogge <hrogge at googlemail.com> wrote:

> Obsoleting RFC 3626 would make sense.
>
> There will be quite a few deployments with OLSR (v1) for a long time,
> but OLSRv2 (because of RFC 5444) is a much better base for
> experiments.

The existence of "quite a few deployments with OLSR (v1)" is, to me, a
very good reason for not obsoleting OLSRv1 with the publication of
OLSRv2 - I would be very much against that, especially as OLSRv2 isn't
"broken" per se.

I would vote for "Leave RFC 3626 in place for further
experimentation", for the time being; eventually, it may make sense to
mark it as "Historic", but I do not think that we are there yet.

[We've got a proud history of co-existence when protocol versions are
still in use: OPSFv2/OSPFv3; IPv4/IPv6, ....]

Best,

Thomas

> Henning Rogge
>
> On Fri, Jun 8, 2012 at 10:34 PM, Stan Ratliff <sratliff at cisco.com> wrote:
>> Adrian,
>>
>> In that case, my vote as a WG member would be to obsolete RFC 3626.
>>
>> Other WG members? Please jump in.
>>
>> Regards,
>> Stan
>>
>> On Jun 8, 2012, at 3:57 PM, Adrian Farrel wrote:
>>
>> PMFJI
>>
>> This thread has brought up a question that I need to ask as I review OLSRv2
>> which you have requested goes for publication.
>>
>> In what way does the WG intend OLSRv2 to replace/update/deprecate OSLRv1?
>>
>> There is a whole range of options, and what you choose depends largely on
>> what future exposure you think OLSRv1 should have. You could:
>>
>> Thanks,
>> Adrian
>> From: manet-bounces at ietf.org [mailto:manet-bounces at ietf.org] On Behalf
>> Of Stan Ratliff
>> Sent: 08 June 2012 19:34
>> To: Teco Boot
>> Cc: Dearlove, Christopher (UK); manet; Abdussalam Baryun
>> Subject: Re: [manet] There is no document submitted so far to WG stating an
>> update request for RFC3626
>>
>> Abdussalam,
>>
>> The first paragraph of the "Introduction" section of OSLRv2 states:
>>
>> "The Optimized Link State Routing protocol version 2 (OLSRv2) is the
>> successor to OLSR (version 1) as published in [RFC3626]."
>>
>>
>>
>>
>> As such, I'm assuming that no additional work to RFC 3626 is expressed or
>> implied - OLSRv1 is documented in RFC 3626; OLSRv2 is, for all intents and
>> purposes, a new protocol documented by this new RFC.
>>
>> Regards,
>> Stan
>>
>>
>> On Jun 8, 2012, at 2:13 PM, Teco Boot wrote:
>>
>>
>>
>> Op 8 jun. 2012 om 19:25 heeft Abdussalam Baryun <abdussalambaryun at gmail.com>
>> het volgende geschreven:
>>
>>
>> Hi Teco,
>>
>>
>>
>> More precisely, we work on a replacement for the initial experimental
>>
>> version.
>>
>>
>>
>> you mean that there is a work for replacement, I don't see any
>>
>> discussion befor about that, please advise,
>>
>>
>> I guess you can find it in the archives.
>>
>>
>>
>>
>> RFC 3626 is not updated. It could get historic one day.
>>
>>
>>
>>
>>
>> same what I thought, but one author of OLSRv2 mentioned that I may
>>
>> misunderstood the process of OLSRv2, even though the authors don't
>>
>> specify what will happen to RFC3626 when OLSRv2 is an RFC. I seen
>>
>> other I-D when submitted for IESG they put inside the draft what the
>>
>> draft authors intention if they obslete another documents or if their
>>
>> new draft is updating any thing,
>>
>>
>>
>> I have confidence in authors' knowledge on the proces. Dito for chairs.
>>
>>
>>
>> OLSRv2 does not mention the process of update, which IMHO it should if
>>
>> authors want to update RFC3626,
>>
>>
>> I believe they don't.
>> Same for workgroup.
>>
>>
>>
>>
>> I may be wrong, but I hope the chair updates me with the status, may
>>
>> be he received a private request of update out of the discussion list,
>>
>> please advise,
>>
>>
>> I guess you misunderstood him.
>>
>> Enjoy your weekend.
>> Teco
>>
>>
>>
>>
>> Regards
>>
>>
>>
>> AB
>>
>> +++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
>>