Subject: Re: [manet] Discussing LOADng suggestions

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 1 Aug 2012 09:41:51 +0200

Hi Ulrich,

comments in lines:
>> >According to MANET charter,
>> >
>> >The purpose of the MANET working group is to standardize IP routing
>> >  protocol functionality suitable for wireless routing application
>> > within
>> >  both static and dynamic topologies with increased dynamics due to node
>> >  motion or other factors.
>>
>> Strange wording, in my opinion. It seems to me that if the network
>> _topology_ is truly static, you do not need a routing protocol at all.
>
> I agree.
>

I like the wording in the charter, but it MAY need to be more clear to
distinguish between ROLL and MANET charters I think the AD can help us
in this matter.

>
>
>> (Note that just as the absence of movement does not imply a static
>> topology, a static topology does not imply stationary nodes).
>>
>> >
>> >So I don't think MANETs are defined by mobility, but by "increased
>> >dynamics",which can be due to motion, but also to lossy links.
>>
>> So why aren't they called ANETs?
>
> Or DANET ("dynamic"). It just did not sound as nice when the term was
> created.
>

I like that *dynamic* word, I agree with it, but we don't forget that
ROLL or LLNs are also DANETs so there SHOULD be differences when we
read through their documents and also in MANET documents which I am
trying to solve by my drafts [1] and [2].

I agree that Mobility is the Mostly the concern of MANET (use cases
and applicability), so the *dynamic* is mostly caused by Mobility in
MANET, but in LLNs the *dynamic* is Mostly caused by the Losses or Low
power. I will put that in my terminology draft :)

[1] http://www.ietf.org/id/draft-baryun-manet-terminology-00.txt
[2] http://www.ietf.org/id/draft-baryun-manet-technology-00.txt

Best Regards

Abdussalam Baryun
University of glamorgan, UK

===============================
>
>
>
>>
>> Ronald
>> >
>> >2012/7/31 Ulrich Herberg <[email-masked]>:
>> >> MANETs are not defined by mobility. It is rather about very dynamic
>> >> topologies. Otherwise, community networks such as FunkFeuer would also
>> >> not be qualified as MANETs.
>> >>
>> >> Ulrich
>> >>
>> >>
>> >> On Tue, Jul 31, 2012 at 10:32 AM, Mukul Goyal <[email-masked]> wrote:
>> >>>
>> >>> The wireless network of "fixed" temperature monitoring sensors and
>> >>> HVAC controllers in a building. This network is an LLN. Not sure if
>> >>> it qualifies as a MANET (since nothing is mobile).
>> >>>
>> >>> Thanks
>> >>> Mukul
>> >>>
>> >>> ----- Original Message -----
>> >>> From: "Henning Rogge" <[email-masked]>
>> >>> To: "Abdussalam Baryun" <[email-masked]>
>> >>> Cc: "manet" <[email-masked]>
>> >>> Sent: Tuesday, July 31, 2012 8:49:08 AM
>> >>> Subject: Re: [manet] Discussing LOADng suggestions
>> >>>
>> >>> On Tue, Jul 31, 2012 at 6:45 AM, Abdussalam Baryun
>> >>> <[email-masked]> wrote:
>> >>> > IMHO this protocol was intended as for ROLL WG not for MANET WG,
>> >>> > but then changed its direction to MANET [3]. However, please note
>> >>> > that
>> >>> > *ONLY* some LLNs are MANETs, and *ONLY* some MANETs are LLNs.
>> >That
>> >>> > said, LOADng SHOULD specfy where is its limits. Then we can discuss
>> >>> > adoption.
>> >>>
>> >>> Could you state an example what would be considered a LLN but not a
>> >>> MANET. I normally consider LLNs a subset of what we call MANETs.
>> >>>
>> >>> Henning Rogge
>> >>>
>> >>> --
>> >>> Steven Hawkings about cosmic inflation: "An increase of billions of
>> >>> billions of percent in a tiny fraction of a second. Of course, that
>> >>> was before the present government."
>> >>> _______________________________________________
>> >>> manet mailing list
>> >>> [email-masked]
>> >>> https://www.ietf.org/mailman/listinfo/manet
>> >>> _______________________________________________
>> >>> manet mailing list
>> >>> [email-masked]
>> >>> https://www.ietf.org/mailman/listinfo/manet
>> >>
>> >>
>> >>
>> >> _______________________________________________
>> >> manet mailing list
>> >> [email-masked]
>> >> https://www.ietf.org/mailman/listinfo/manet
>> >>
>> >_______________________________________________
>> >manet mailing list
>> >[email-masked]
>> >https://www.ietf.org/mailman/listinfo/manet
>> This e-mail and its contents are subject to the DISCLAIMER at
>> http://www.tno.nl/emaildisclaimer
>>
>>
>

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Wed, 1 Aug 2012 08:58:58 +0000

Probably not called ANETs because there wasn't a French Impressionist painter of that name. There is a tendency towards overloaded names in at least parts of the IETF.

The first ad hoc network I ever worked on that got out of a laboratory had non-moving nodes but variable routing as radio waves do not propagate well through large metal vehicles, and those moved.

-- 
Christopher Dearlove
Senior Principal Engineer, Communications Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked] | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Velt, R. (Ronald) in 't
Sent: 31 July 2012 19:23
To: Antonin Bas; Ulrich Herberg
Cc: manet; Abdussalam Baryun
Subject: Re: [manet] Discussing LOADng suggestions

----------------------! WARNING ! ----------------------
This message originates from outside our organisation,
either from an external partner or from the internet.
Keep this in mind if you answer this message.
Follow the 'Report Suspicious Emails' link on IT matters
for instructions on reporting suspicious email messages.
--------------------------------------------------------

>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]] On Behalf
>Of Antonin Bas
>Sent: dinsdag 31 juli 2012 19:44
>To: Ulrich Herberg
>Cc: manet; Abdussalam Baryun
>  protocol functionality suitable for wireless routing application within

Strange wording, in my opinion. It seems to me that if the network _topology_ is truly static, you do not need a routing protocol at all. (Note that just as the absence of movement does not imply a static topology, a static topology does not imply stationary nodes).

Ronald
>>> MANET. I normally consider LLNs a subset of what we call MANETs.
This e-mail and its contents are subject to the DISCLAIMER at http://www.tno.nl/emaildisclaimer

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Wed, 1 Aug 2012 09:04:04 +0000

If a network is static, but not preconfigured, then you may still want to run a proactive routing protocol up to the point where you have established the topology, then turn it off. Or if there's a reason not to want to do that, you could run a reactive routing protocol, with anything up to infinite expiry time on discovered routes.

And one more scenario. Your nodes are all stationary, your propagation is stationary. You have no moving obstacles. But things are still (sporadically) dynamic when your nodes fail (battery exhaustion, accident, enemy action).

[email-masked]<mailto:[email-masked]> | http://www.baesystems.com

From: [email-masked] [mailto:[email-masked]] On Behalf Of Ulrich Herberg
Sent: 31 July 2012 19:26
To: Velt, R. (Ronald) in 't
Cc: manet; Abdussalam Baryun
Subject: Re: [manet] Discussing LOADng suggestions

*** WARNING ***
This message originates from outside our organisation, either from an external partner or the internet.
Keep this in mind if you answer this message.
Please see this process<http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Dealing%20With%20Suspicious%20Emails.pdf> on how to deal with suspicious emails.
Ronald,
On Tue, Jul 31, 2012 at 11:23 AM, Velt, R. (Ronald) in 't <[email-masked]<mailto:[email-masked]>> wrote:

>From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>] On Behalf
>Of Antonin Bas
Strange wording, in my opinion. It seems to me that if the network _topology_ is truly static, you do not need a routing protocol at all.

I agree.

(Note that just as the absence of movement does not imply a static topology, a static topology does not imply stationary nodes).

Or DANET ("dynamic"). It just did not sound as nice when the term was created.

Best
Ulrich

Ronald
>
>2012/7/31 Ulrich Herberg <[email-masked]<mailto:[email-masked]>>:
>> On Tue, Jul 31, 2012 at 10:32 AM, Mukul Goyal <[email-masked]<mailto:[email-masked]>> wrote:
>>>
>>> From: "Henning Rogge" <[email-masked]<mailto:[email-masked]>>
>>> To: "Abdussalam Baryun" <[email-masked]<mailto:[email-masked]>>
>>> Cc: "manet" <[email-masked]<mailto:[email-masked]>>
>>> <[email-masked]<mailto:[email-masked]>> wrote:
>>> [email-masked]<mailto:[email-masked]>
>>> [email-masked]<mailto:[email-masked]>
>> [email-masked]<mailto:[email-masked]>
>[email-masked]<mailto:[email-masked]>

---

From: Dr John P Mullen <[email-masked]>
Date: Wed, 1 Aug 2012 11:29:24 -0600

Hi,

A network can appear stationary to the naked eye, but quite dynamic to the transceivers in it. Vehicles, people, air temperature storms, etc., will affect propagation paths. If there are multipath possibilities, the potential for disruption is much greater.  Also, as Chris points out, things happen to the equipment.

Even a small change in the local environment can have a profound change in the radio world. I've talked to tank commanders who could see their wingman, but not communicate. Move one tank or the other just a couple of feet, wait a few minutes, etc., and the problem clears up.

Unless the MANET is in a location in which no one or nobody moves and absolutely nothing changes, there could be changes that would require updating of the routing.

Ah, but what's the fun in that?

John Mullen

From: [email-masked] [mailto:[email-masked]] On Behalf Of Dearlove, Christopher (UK)
Sent: Wednesday, August 01, 2012 3:04 AM
To: Ulrich Herberg; Velt, R. (Ronald) in 't
Cc: manet; Abdussalam Baryun
Subject: Re: [manet] Discussing LOADng suggestions

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]<mailto:[mailto:[email-masked]]> On Behalf Of Ulrich Herberg
Sent: 31 July 2012 19:26
To: Velt, R. (Ronald) in 't
Cc: manet; Abdussalam Baryun
Subject: Re: [manet] Discussing LOADng suggestions

*** WARNING ***

I agree.

Best
Ulrich

Ronald

---

From: Jiazi YI <[email-masked]>
Date: Wed, 1 Aug 2012 11:53:13 -0700

Hi, 

please check inline:

> power. I will put that in my terminology draft :)

I don't think we can distinguish LLN and MANET by *mobility*. In LLNs, the mobility can be not only caused by radio, but also physical movement, such as in wildlife monitoring, water monitoring, etc. You can find a lot of examples of that. 

The key point of LLN is "low power", i.e., resource constrained. A vehicle network is a MANET, but we won't say it's a LLN. 

Therefore, I would rather say LLN is resource constrained MANET.

---

From: C Chauvenet <[email-masked]>
Date: Wed, 1 Aug 2012 19:58:24 +0000

Hi,

The key point of LLN is "low power", i.e., resource constrained.

Agree. I tried to make the difference clear in a previous mail when parsing the constraints of LLN Vs MANET.

A vehicle network is a MANET, but we won't say it's a LLN.

Agree.

I think most of people on the list agree that LLN and MANET are not identical, and that, as you mentioned, LLN are more resource constrained.

That's why IETF created ROLL in the routing area for these specific needs.

http://tools.ietf.org/html/draft-clausen-lln-loadng-05#section-3 states that it target LLN.

So I'm a little bit surprised about this submission in MANET.

Could you clarify the scope of LOADng regarding the MANET scope ?

Cédric.

Le 1 août 2012 à 20:53, Jiazi YI a écrit :

Hi,

please check inline:

On Aug 1, 2012, at 12:41 AM, Abdussalam Baryun <[email-masked]<mailto:[email-masked]>> wrote:

Hi Ulrich,

comments in lines:

I agree.

Best Regards

Abdussalam Baryun

Ronald

Ulrich

Thanks
Mukul

----- Original Message -----
From: "Henning Rogge" <[email-masked]<mailto:[email-masked]>>
To: "Abdussalam Baryun" <[email-masked]<mailto:[email-masked]>>
Cc: "manet" <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, July 31, 2012 8:49:08 AM
Subject: Re: [manet] Discussing LOADng suggestions

Henning Rogge

---

From: Jiazi YI <[email-masked]>
Date: Wed, 1 Aug 2012 13:31:59 -0700

Hi, 

LOADng is a MANET routing protocol, and therefore can be applied to LLN. 
The authors are discussing about rephrasing some of the text in abstract/introduction/applicability statement  based on the feedback from the WG. 

regards

Jiazi

---

From: C Chauvenet <[email-masked]>
Date: Wed, 1 Aug 2012 20:48:32 +0000

Hi,

Thank you for the clarification.

Not sure that this statement is true, otherwise all MANET protocols can be applied to LLN, and as we agreed before, they have different constraints.

I agree that the LOADng draft would need some rewording regarding the applicability, but I think that changing such an important thing will  impact the protocol itself.

Cédric.

Le 1 août 2012 à 22:31, Jiazi YI a écrit :

Hi,

regards

Jiazi

On Aug 1, 2012, at 12:58 PM, C Chauvenet <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

Agree.

Cédric.

Hi,

please check inline:

Hi Ulrich,

comments in lines:

I agree.

Best Regards

Abdussalam Baryun

Ronald

Ulrich

Thanks
Mukul

----- Original Message -----
From: "Henning Rogge" <[email-masked]<mailto:[email-masked]>>
To: "Abdussalam Baryun" <[email-masked]<mailto:[email-masked]>>
Cc: "manet" <[email-masked]<mailto:[email-masked]>>
Sent: Tuesday, July 31, 2012 8:49:08 AM
Subject: Re: [manet] Discussing LOADng suggestions

Henning Rogge

---

From: Antonin Bas <[email-masked]>
Date: Wed, 1 Aug 2012 22:58:11 +0200

Hi,

The LOADng draft indeed need some rewording.
And you are right, all MANET protocols cannot be applied to LLNs.
LOADng is a MANET routing protocol which has been found to perform
well even with LLNs. It is for instance more energy efficient than
AODV, which make it more adapted for the resource constrained nature
of LLNs.

Antonin

2012/8/1 C Chauvenet <[email-masked]>:
> Not sure that this statement is true, otherwise all MANET protocols can be
> applied to LLN, and as we agreed before, they have different constraints.
>
> I agree that the LOADng draft would need some rewording regarding the
> applicability, but I think that changing such an important thing will
> impact the protocol itself.
>
> Cédric.
>
> The authors are discussing about rephrasing some of the text in
> abstract/introduction/applicability statement  based on the feedback from
> the WG.
>
> regards
>
> Jiazi
>
>
> I think most of people on the list agree that LLN and MANET are not
> identical, and that, as you mentioned, LLN are more resource constrained.
>
> I don't think we can distinguish LLN and MANET by *mobility*. In LLNs, the
> mobility can be not only caused by radio, but also physical movement, such
> as in wildlife monitoring, water monitoring, etc. You can find a lot of
> examples of that.
>
> The key point of LLN is "low power", i.e., resource constrained. A vehicle
> network is a MANET, but we won't say it's a LLN.
>

---

From: C Chauvenet <[email-masked]>
Date: Wed, 1 Aug 2012 21:18:16 +0000

Hi, 

In my view things are simple.

According to the (new ?) LOADng scope (a MANET routing protocol applicable to LLN), there are 2 places possible :

	- A place for a routing protocol in LLN, which is already taken by RPL, designed in ROLL.
 	- A place for a reactive protocols in MANET, still to be attributed, and I understood that it was the intend of DYMO.

I'm simply wondering where is the place for LOADng ?

Cédric.

---

From: Jiazi YI <[email-masked]>
Date: Wed, 1 Aug 2012 14:48:57 -0700

Hi,

> I agree that the LOADng draft would need some rewording regarding the applicability, but I think that changing such an important thing will  impact the protocol itself.

I don't think so. LOADng doesn't assume any specified traffic pattern, so it can be applied in general MANET scenarios. 

> I'm simply wondering where is the place for LOADng ?

You are right that MANET is charted to have a reactive routing protocol, and my understanding is that IETF believes in running code. 

best

Jiazi

---

From: Abdussalam Baryun <[email-masked]>
Date: Thu, 2 Aug 2012 09:39:57 +0200

Hi Jiazi

> as in wildlife monitoring, water monitoring, etc. You can find a lot of

The Low power is in the LLN abbreviation, and Mobile is in MANET. so
it is simple for many, but what you understand from the word mobile
attached to MANET, please explain, is it like some say its dynamic as
DANET,

> network is a MANET, but we won't say it's a LLN.

I think the key point is low power and lossy node as simply mentioned
and its a DANET also. But I can add that not all LLN are Ad-Hoc ( is
the "A" in MANET).

> Therefore, I would rather say LLN is resource constrained MANET.

LLN is not only about resources it may have situations like MANET, so
I hope that IETF solves this issue before its solved else where.

AB