Subject: [manet] OLSR deployments

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 12 Dec 2012 18:40:42 -0000

Hi,

Could people (on or off list) let me know of any OLSR deployments (carrying live
traffic) of which they are aware.

These may be long-term (as community networks) or short-term (as disaster
relief).

I would also like to know whether they are self-contained networks or allow
access (through some kind of gateway) to the Internet.

Thanks,
Adrian

---

From: Teco Boot <[email-masked]>
Date: Wed, 12 Dec 2012 20:12:16 +0100

I'm involved in a operational pilot network for public safety, that uses olsr.org code. It runs ETX, thus non-RFC-compliant mode. Network is rather small (~30 nodes). There are more links to the Internet than the number of nodes. That is because nodes have at least one link to the Internet. Some have multiple.
Without ETX, it didn't work well. Better link metrics is work in progress.
Peer discovery (similar to mdns) is supported.
Implementing SmartGateway (the enhanced version) is work in progress.
Follow-up expanding the network will come. Takes time.
Update to olsrv2 is not a short term goal. Same for IPv6.

Teco

Op 12 dec. 2012, om 19:40 heeft Adrian Farrel het volgende geschreven:

> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

---

From: "L. Aaron Kaplan" <[email-masked]>
Date: Wed, 12 Dec 2012 23:13:14 +0100

Adrian,

   I can only talk about wireless *community* networks. There are lots of other OLSR deployments in the military and in other contexts.

to the best of my knowledge, most community wireless *mesh* (in the sense of MANET) networks use OLSR.org's OLSR implementation.
This has a couple of reasons:
  * it was the first working mesh protocol and in ~ 2003 when most community wireless networks got started and ant to full speed, that was the only solid solution we had
  * the community wireless networks (Funkfeuer, Freifunk) invested lots of time and money to turn OLSR.org's implementation into a "product"-grade solution (read: it does not suck that much anymore)
  * our results were published as open source on wikis, hence people copied and adapted our work.

I am aware that there are large wireless community Wi-Fi networks which mainly use BGP (internal BGP). Usually the reason for this is that the Mikrotik platform has a BGP implementation but no well rounded "mesh" implementation (at least multiple people who tried it were not happy with that implementation).
Mikrotik is pretty much a turn key solution and wide spread in the WISP scene.

Please also have a look at (the incomplete list at):
http://en.wikipedia.org/wiki/List_of_wireless_community_networks_by_region
https://personaltelco.net/wiki/WirelessCommunities

I hope this answers some of your questions. 
 
Aaron.