Subject: [manet] Fwd: I have some questions about AODV in MANET!

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Fri, 7 Dec 2012 17:59:50 +0000

Forwarding something I just got offline to the larger community.

Regards,
Stan

Begin forwarded message:

From: 이윤경 <[email-masked]<mailto:[email-masked]>>
Subject: I have some questions about AODV in MANET!
Date: December 7, 2012 12:53:59 PM EST
To: <[email-masked]<mailto:[email-masked]>>

[http://ccmail.sookmyung.ac.kr/mail/webmailreconf.public.do?7195730]

Hello, I'm Yuni in Seoul, Korea and being in doctorial course.

I have some questions about the default value of hello message interval in AODV.

First, why did you set this value at 1000 ms? Is this value selected from various performance test?

(Because my current research tells some other optimal value of hello period.)

Next, what should be considered when I use other value(compared to yours) of hello message interval.

Your responses will be greatly appreciated

Thank you.

from Yuni.

---

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 7 Dec 2012 20:10:58 +0100

yes I recommend it was selected by test of general use cases, if other
cases then you will need to test best performance by changing
parameters.

AB

---

From: "Charles E. Perkins" <[email-masked]>
Date: Fri, 07 Dec 2012 11:42:11 -0800

Hello Yuni,

Hello messaging in AODV has been the source of numerous
controversies.  For one thing, it's not "reactive".  For another,
there are many "better" neighbor discovery protocols available.
As an aside, now (nearly twenty years after first including the
Hello messages as part of AODV) I believe that most such
neighbor discovery protocols "should" also work as part of
a multicast-backbone creation protocol, simply in order to
reduce the amount of periodic signaling in the network.

The 1000 ms value was selected as a tradeoff between
a) the amount of time needed to detect a broken link
b) the number of "typically useless" protocol messages
      interfering with actual data packet transmission.
This value seriously needs adjustment depending on the
nodal degree of the network.  If the degree is small, the
value can be less than 1000ms.  If the degree is large, the
value should be more than 1000ms.

It also needs adjustment based on the bandwidth of the
underlying physical medium.  If you've got 55 Mb/sec
WiFi, you don't have too much to worry over, no matter
how dense the network is.  In the mid 1990's, we were
lucky to have even 100 Kb/sec.

Anyway, bottom line:
- AODV is Experimental and many decisions made in the
    late 1990's are often irrelevant nowadays
- It was always expected that people would adjust these
    parameters based on particular network requirements.
- Please look at alternate neighbor discovery methods.

Regards,
Charlie P.

On 12/7/2012 9:59 AM, Stan Ratliff (sratliff) wrote:
>> *From: *??? <[email-masked] <mailto:[email-masked]>>
>> *Subject: **I have some questions about AODV in MANET!*
>> *Date: *December 7, 2012 12:53:59 PM EST
>> *To: *<[email-masked] <mailto:[email-masked]>>
>>
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

-- 
Regards,
Charlie P.