Subject: [manet] LOADng (was Re: I-D Action: draft-ietf-manet-dymo-24.txt)

From: Abdussalam Baryun <[email-masked]>
Date: Mon, 10 Dec 2012 11:51:24 +0100

On 12/7/12, Stan Ratliff (sratliff) <[email-masked]> wrote:
>
> My feeling, FWIW, is that ingress/egress SHOULD be a part of the base
> document. However, I understand the concerns of people that say it might be
> a problem (or extend ratification time, etc etc). So, I'm interested in
> hearing other, interested opinions - both for
> DYMO/AODVv2/Whatever-we're-calling-it-this-week, as well as with regard to
> the LOADng spec.

I know from my efforts that LOADng team are not welling to discuss, or
reply to questions/comments, so I want to know your opinion of the
status on this LOADng draft as you brought it to the list; Is it a WG
draft? should we discuss individual or private work now?

I remember that we answered chair questions and options given. Not
sure what the chair of WG wants us to do so far, please advise,

AB

>
> And lastly….. if the 5 guys were *that* important, they most likely wouldn't
> be *playing* black-ops… ;-)
>
> Stan
>
>

---

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Mon, 10 Dec 2012 14:58:09 +0000

Abdussalam, 

> sure what the chair of WG wants us to do so far, please advise,

It wasn't clear to me what the consensus was in Atlanta vis-a-vis the two reactive protocol documents. Presently, DYMO is the working group accepted reactive protocol document. However, there was a 2-year period of time when DYMO was inactive, and the document was "parked". As a result of that, the effort to create LOADng sprang up. 

So now, we have two documents to consider. In the charter, the WG is "on the hook" for 1 (and only 1) reactive protocol. So the current options are: 
1. Recognize that we cannot reach consensus with the two documents, and remove the charter item for reactive protocols. To be frank, this is my preferred option. 
2. Accept one of the two documents (either LOADng or DYMO), and press forward
3. Perhaps alter the charter item, and produce 2 reactive protocols, both in "experimental" state. 

Now, you mentioned "Not sure what the chairs of WG want us to do so far"…. the best answer I can give you on that is "reach consensus on an approach".  We as a working group haven't done that yet. There are people advocating for DYMO, others advocating for LOADng, and some that want to "merge" the technology of the two together. A "merge" was something we tried in the Vancouver timeframe, but that effort failed. 

As to your statement that the LOADng team is not willing to discuss - I haven't seen that, do not agree with it, and would ask you to cite *specific* examples if you have them. I've found the LOADng team to be reasonable in their dealings with the WG. There is the issue of re-spinning the LOADng document without the copyright statement - The LOADng authors and the chairs have reached an understanding about that issue, so I no longer have a problem with moving forward on that front. 

Again, as a working group - we *MUST* either reach a consensus, or the work item will be removed *for us*. If we do not show progress towards a goal, it is within the power of the IESG to stop work on the issue.

Regards,
Stan

> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

---

From: Don Sturek <[email-masked]>
Date: Mon, 10 Dec 2012 07:26:14 -0800

+1, agree with Stan that what is captured below is the current predicament
in MANET with regard to DYMO and LOADng.....

Stan:  What do you think the timeframe should be for choosing one of the 3
paths you enumerated below?

Don

On 12/10/12 6:58 AM, "Stan Ratliff (sratliff)" <[email-masked]> wrote:

>It wasn't clear to me what the consensus was in Atlanta vis-a-vis the two
>reactive protocol documents. Presently, DYMO is the working group
>accepted reactive protocol document. However, there was a 2-year period
>of time when DYMO was inactive, and the document was "parked". As a
>result of that, the effort to create LOADng sprang up.
>
>So now, we have two documents to consider. In the charter, the WG is "on
>the hook" for 1 (and only 1) reactive protocol. So the current options
>are: 
>1. Recognize that we cannot reach consensus with the two documents, and
>remove the charter item for reactive protocols. To be frank, this is my
>preferred option. 
>Now, you mentioned "Not sure what the chairs of WG want us to do so
>far"Š. the best answer I can give you on that is "reach consensus on an
>approach".  We as a working group haven't done that yet. There are people
>advocating for DYMO, others advocating for LOADng, and some that want to
>"merge" the technology of the two together. A "merge" was something we
>tried in the Vancouver timeframe, but that effort failed.
>
>As to your statement that the LOADng team is not willing to discuss - I
>haven't seen that, do not agree with it, and would ask you to cite
>*specific* examples if you have them. I've found the LOADng team to be
>reasonable in their dealings with the WG. There is the issue of
>re-spinning the LOADng document without the copyright statement - The
>LOADng authors and the chairs have reached an understanding about that
>issue, so I no longer have a problem with moving forward on that front.
>
>Again, as a working group - we *MUST* either reach a consensus, or the
>work item will be removed *for us*. If we do not show progress towards a
>goal, it is within the power of the IESG to stop work on the issue.
>
>Regards,
>Stan
>
>
>> 
>> AB
>> 
>>> 
>>> And lastlyŠ.. if the 5 guys were *that* important, they most likely
>>>wouldn't
>>> be *playing* black-opsŠ ;-)
>>> 
>>> Stan
>>> 
>>>

---

From: Teco Boot <[email-masked]>
Date: Mon, 10 Dec 2012 16:40:58 +0100

Op 10 dec. 2012, om 15:58 heeft Stan Ratliff (sratliff) het volgende geschreven:
> There is the issue of re-spinning the LOADng document without the copyright statement - The LOADng authors and the chairs have reached an understanding about that issue, so I no longer have a problem with moving forward on that front.
Can something be exposed to us?

Teco

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Mon, 10 Dec 2012 18:08:16 +0000

Stan Ratliff (sratliff) <[email-masked]>
> It wasn't clear to me what the consensus was in Atlanta vis-a-vis the two reactive protocol documents.

It was clear to me that there was no consensus. Except that abandoning the work item was not favoured.
But I also don't believe that the meeting was offered any opportunity to either make that clear or show me
I was wrong in that assessment.

> There are people advocating for DYMO, others advocating for LOADng, and some that want to "merge"
> the technology of the two together.

I would like to point out that my proposal, which I believe would have been the best to adopt then,
doesn't neatly fit in any of those three categories.

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Mon, 10 Dec 2012 18:25:35 +0000

The content of the document would be unchanged, with the exception of removing the copyright. 

Regards,
Stan

---

From: Jiazi YI <[email-masked]>
Date: Tue, 11 Dec 2012 00:02:08 +0100

Hi, 

Given the fact that DYMO is moving closer and closer to LOADng (the modular approach, handling of RREP, sequence numbers, handling of RERRs, etc...), I feel that we have already consensus on those general design issues. 

The next question is which is the one we should begin with. For me, it's nature to start with the one with more operational experiences and running code. 

Note: I'm not saying taking one and abandoning the other. We just need to take the one with better shape to begin with, and integrate ideas from the other one based on WG consensus. 

best

Jiazi

---

From: "JP Vasseur (jvasseur)" <[email-masked]>
Date: Tue, 11 Dec 2012 02:15:40 +0000

don't you have the impression that we go into circles at the risk of having the same discussion that we had 3 months ago ?

On Dec 10, 2012, at 3:02 PM, Jiazi YI wrote:

Hi,

best

Jiazi

On Dec 10, 2012, at 7:08 PM, "Dearlove, Christopher (UK)" <[email-masked]<mailto:[email-masked]>> wrote:

Stan Ratliff (sratliff) <[email-masked]<mailto:[email-masked]>>
It wasn't clear to me what the consensus was in Atlanta vis-a-vis the two reactive protocol documents.

_______________________________________________
manet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/manet

_______________________________________________
manet mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/manet

---

From: "JP Vasseur (jvasseur)" <[email-masked]>
Date: Tue, 11 Dec 2012 02:19:56 +0000

Hi Stan,

> 3. Perhaps alter the charter item, and produce 2 reactive protocols, both in "experimental" state. 

JP> What about putting a hard dead-line and if there is no consensus fall back to 1 ?

---

From: "Charles E. Perkins" <[email-masked]>
Date: Mon, 10 Dec 2012 22:34:12 -0800

Hello Jiazi,

On 12/10/2012 3:02 PM, Jiazi YI wrote:
>
> Given the fact that DYMO is moving closer and closer to LOADng (the 
> modular approach, handling of RREP, sequence numbers, handling of 
> RERRs, etc...), I feel that we have already consensus on those general 
> design issues.

I find this to be an unusual comment, since the explicit goal was
to be inclusive and compatible with LOADng.  Moreover, I have for
a long time been pointing out that it would not be difficult to produce
this compatibility.

>
> The next question is which is the one we should begin with. For me, 
> it's nature to start with the one with more operational experiences 
> and running code.

As I understand it, most of the operational experience was with
non-mobile networks.   I guess there has been some more recent
work with mobile networks?

Given that LOADng can be viewed as a set of mandatory features
from the WG document along with, possibly, some optional
features, and since the WG document has all along been designed
for mobile networks, and to have certain scalability features, it
seems natural to continue with the WG document and to take
care for the needs of LOADng as well.

>
> Note: I'm not saying taking one and abandoning the other. We just need 
> to take the one with better shape to begin with, and integrate ideas 
> from the other one based on WG consensus.

Well, after recent efforts I think the WG document is really
in pretty good shape.   In the near future, I'll try to suggest some
various points where the LOADng document should be moved
closer to where the WG document is now -- I hope to do this
before Christmas.

-- 
Regards,
Charlie P.

---

From: Jiazi YI <[email-masked]>
Date: Tue, 11 Dec 2012 12:17:05 +0100

Hi Charlie, 

> a long time been pointing out that it would not be difficult to produce

I didn't find any controversial between what you said (the *goal*) and what I mentioned (the *result*). 
I think to be *compatible* with LOADng, the fact is that DYMO is getting more closer to LOADng. I made a small list after comparing dymo-21 and dymo-24, it's not hard to have this conclusion. 
In the meantime, even dymo and LOADng are having the similar approaches, as one who participated in most interop events of LOADng, I find it's hard to have dymo compatible with LOADng, without significant changes of DYMO (packet format, flags, message processing...)

> work with mobile networks?

I have to say, I didn't mention which one is the protocol that has more operational experiences and running code. Because I'm only familiar with the situation of LOADng (interop events, large implementation, etc...)
I believe when you are saying above, you admit that LOADng is having more operational experiences? Or can you share some of dymo (either non-mobile, or mobile)?

> care for the needs of LOADng as well.

As a lot of people have mentioned, because DYMO and LOADng generally share the same mechanism, they won't have significant difference in performance. That's why I said we should begin with the one with more operational experience. 
Personally, I'm very careful when making assessment. When I'm saying LOADng has scalability features, and can have interoperable implementations, there is running code to prove that.
I think it's the "running code",  which is believed in IETF, am I wrong? So if I need to choose between the "running code", and "some optional features that are not verified", my choice is quite clear, especially for a standard track protocol. 

> closer to where the WG document is now -- I hope to do this

I'm aware that there are some issues still need to addressed for LOADng, and there are still a lot of tickets under active discussion in the LOADng bugtracker. Any comments that can be helpful to improve the existed tickets, or new issues of LOADng, are welcome. 

best

Jiazi

---

From: Jiazi YI <[email-masked]>
Date: Tue, 11 Dec 2012 12:51:43 +0100

Hi JP,

> don't you have the impression that we go into circles at the risk of having the same discussion that we had 3 months ago ?

That's what I'm afraid of. That's why LOADng authors are relatively quiet in the last several months after the IETF meeting, as the WG chairs suggested, to wait for a response about how to go forward. 
However, there is comment to LOADng authors on this issue (and be blamed for not willing to discuss) now, I think we should reply, no?

I would like some advices from WG chairs, to avoid having the same discussion again. Because the situation is generally the same with 3 months ago. 

best

Jiazi

---

From: C Chauvenet <[email-masked]>
Date: Tue, 11 Dec 2012 12:37:24 +0000

Hi,

See inline.

Le 11 déc. 2012 à 12:17, Jiazi YI a écrit :

Hi Charlie,

On Dec 11, 2012, at 7:34 AM, Charles E. Perkins <[email-masked]<mailto:[email-masked]>> wrote:

Hello Jiazi,

I guess that was the point of charlie above : if there was some other experiences than the PLC deployment *mentioned* on this list (no publication or official material was shared about it).

If "running code" is a good metric (chairs may have an opinion on how much "running code" is needed for a standard track), then the WG should be aware of existing deployments, for both protocols. For now, I can just count 1 deployment of LOADng, and did not see material yet on an DYMO/AODVv2 deployment. Charlie, do you have some or I missed something ?
If there are some confidentiality or restriction around theses deployments and no material can be provide or share, then it seems hard to rely on this parameter...

My opinion is that such a parameter is fairly hard to evaluate because people don't want to share so much on their secret sauce, so we may end up with some pieces of informations that are hard to evaluate.

Best,

Cédric.

best

Jiazi

--
Regards,
Charlie P.

---

From: Abdussalam Baryun <[email-masked]>
Date: Tue, 11 Dec 2012 14:56:32 +0100

Hi Stan,

I thank you for the explaination because we need that from time to
time to understand how the discussion will go forward without waste of
efforts. Regarding the examples I will provide you when I got
available time to report them. Regarding LOADng my questions are; 1)
why there was a discussion off the list or off the meeting about
removing the copyright of this  proposing WG document. 2) Why the
LOADng team didn't mention that while their proposal or does that mean
that we have no right to update the document if we adopt it. 3) Is it
possible for the document to mention a section of such authors rights
and rights of the WG that are applied by the document, because if we
just accept to remove copyright what does that mean (I think it means
accepts me without clear rights)? 4) will this copyright issue affect
the choose of the WG participants regarding DYMO or LOADng as I think
the DYMO did not remove copyrights to IETF-WG?

Finally, now I understand the position of the WG regarding the future
WG discussions about reactive protocol. Thanking you.

AB

On 12/10/12, Stan Ratliff (sratliff) <[email-masked]> wrote:
> reactive protocol documents. Presently, DYMO is the working group accepted
> reactive protocol document. However, there was a 2-year period of time when
> DYMO was inactive, and the document was "parked". As a result of that, the
> effort to create LOADng sprang up.
>
> So now, we have two documents to consider. In the charter, the WG is "on the
> hook" for 1 (and only 1) reactive protocol. So the current options are:
> Now, you mentioned "Not sure what the chairs of WG want us to do so far"….
> the best answer I can give you on that is "reach consensus on an approach".
> We as a working group haven't done that yet. There are people advocating for
> DYMO, others advocating for LOADng, and some that want to "merge" the
> technology of the two together. A "merge" was something we tried in the
> Vancouver timeframe, but that effort failed.
>
> reasonable in their dealings with the WG. There is the issue of re-spinning
> the LOADng document without the copyright statement - The LOADng authors and
> the chairs have reached an understanding about that issue, so I no longer
> have a problem with moving forward on that front.
>
> Again, as a working group - we *MUST* either reach a consensus, or the work
> item will be removed *for us*. If we do not show progress towards a goal, it
> is within the power of the IESG to stop work on the issue.
>
> Regards,
> Stan
>
>
>>
>> AB
>>
>>>

---

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Tue, 11 Dec 2012 19:03:45 +0000

JP, 

> JP> What about putting a hard dead-line and if there is no consensus fall back to 1 ?

There's only one problem with that - It's already happened, and the deadline has already passed without conclusion… ;-)  It happened in Vancouver, with a deadline of Atlanta. 

To the working group at large - 

I'm not seeing a high level of interest here. People seem to only have "passing interest" - enough to keep the efforts on life support, but not enough to really progress things. By and large, only the authors have the inclination to push their respective opinions, and nothing has really changed. 

So, I call once again - I think it's time to remove the work item from the charter, and recognize that we're not going to be able to work together on this issue. After more than a year of trying to get people to work together to make the technology better,  just don't see it happening. It's time to end the misery.

Regards,
Stan

---

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Tue, 11 Dec 2012 19:16:54 +0000

Abdussalam, 

So, it would appear to me that your concerns are summed up with the copyright statement. Understood. It's not that the LOADng team was being unresponsive, there were other issues in play. Due to the nature of those issues, I do not feel as though I should release any details - but IMHO, the LOADng authors have acted with the utmost of professionalism throughout. I understand the rationale for the current verbiage, and as far as I'm concerned, the issue is closed - if the WG accepts LOAD as a working group document (see my earlier email for my thoughts on that), the copyright will be removed.

Regards,
Stan

---

From: Axel Colin de Verdière <[email-masked]>
Date: Tue, 11 Dec 2012 15:01:25 -0800

Hi Stan,

> I'm not seeing a high level of interest here. People seem to only have "passing interest" - enough to keep the efforts on life support, but not enough to really progress things. By and large, only…

I'm a bit surprised here: it seems weird to me that you can just dismiss a 10 people behind a document, with strong industrial support (including actual deployments) as "passing", or even "not enough" interest. Furthermore, I've seen that we (the LOADng authors) are far from the only ones participating on this topic.

> So, I call once again - I think it's time to remove the work item from the charter, and recognize that we're not going to be able to work together on this issue. After more than a year of trying to…

I understand your position, I think you made that clear relatively early in the process, but I don't think "not enough interest" is really a good reason here.

Best,

Axel

---

From: "JP Vasseur (jvasseur)" <[email-masked]>
Date: Wed, 12 Dec 2012 03:44:52 +0000

On Dec 11, 2012, at 4:37 AM, C Chauvenet wrote:

Hi,

See inline.

Hi Charlie,

Hello Jiazi,

Agree with Cedric and we do not have details about the one deployment.

Best,

Cédric.

best

Jiazi

--
Regards,
Charlie P.

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Wed, 12 Dec 2012 10:18:53 +0000

Can I just say that as no contributions are marked, I find this an impossible posting to work out who said what.

Hi,

See inline.

Hi Charlie,

Hello Jiazi,

Best,

Cédric.

best

Jiazi

--

Regards,

Charlie P.

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Wed, 12 Dec 2012 10:19:44 +0000

We have two drafts, and people who seem prepared to work on them. To suggest that neither should proceed because we are having difficulties deciding which seems entirely wrong.

-- 
Christopher Dearlove
Senior Principal Engineer, Communications Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked] | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Stan Ratliff (sratliff)
Sent: 11 December 2012 19:04
To: JP Vasseur (jvasseur)
Cc: <[email-masked]>
Subject: Re: [manet] LOADng (was Re: I-D Action: draft-ietf-manet-dymo-24.txt)

----------------------! WARNING ! ----------------------
This message originates from outside our organisation,
either from an external partner or from the internet.
Keep this in mind if you answer this message.
Follow the 'Report Suspicious Emails' link on IT matters
for instructions on reporting suspicious email messages.
--------------------------------------------------------

JP, 

> JP> What about putting a hard dead-line and if there is no consensus fall back to 1 ?

There's only one problem with that - It's already happened, and the deadline has already passed without conclusion. ;-)  It happened in Vancouver, with a deadline of Atlanta. 

Regards,
Stan

> 
>> Now, you mentioned "Not sure what the chairs of WG want us to do so far".. the best answer I can give you on that is "reach consensus on an approach".  We as a working group haven't done that yet. There are people advocating for DYMO, others advocating for LOADng, and some that want to "merge" the technology of the two together. A "merge" was something we tried in the Vancouver timeframe, but that effort failed. 
>> 
>>>> And lastly... if the 5 guys were *that* important, they most likely wouldn't
>>>> be *playing* black-ops. ;-)
>>>> 
>>>> Stan
>>>> 
>>>>

---

From: "JP Vasseur (jvasseur)" <[email-masked]>
Date: Wed, 12 Dec 2012 10:30:55 +0000

the point was that there is (no, little ?) progress in converging toward of the two options ..

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 12 Dec 2012 14:16:27 +0100

That is why I asked questions to know the position of such
discussions. Seems that management want that any of both work should
proceed at authors' end and stop at the WG until cooperation.

I think the issue was/is, that both drafts were to be merged and
something happend made the difficulty to work together, and all WG
want a reactive protocol even if the authors of both drafts could not
work together. I recommended that we should add more author team into
the drafts.

I read the situation that the IETF management wanted the DYMO and
LOADng merge but could not make it progress so far, and now pushing
for removing from charter, while the community don't want that. In the
last meeting their was signs of changing minds. I hope some party
(drafts' authors, management, community) changes their mind or
cooperate for all the WG best. IMHO only the community should make the
final decision of such item-removal of charter.

AB

On 12/12/12, Dearlove, Christopher (UK) <[email-masked]> wrote:
> We have two drafts, and people who seem prepared to work on them. To suggest
> that neither should proceed because we are having difficulties deciding
> which seems entirely wrong.
>
> --
> Christopher Dearlove

---

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Wed, 12 Dec 2012 15:58:04 +0000

Axel, 

> I understand your position, I think you made that clear relatively early in the process, but I don't think "not enough interest" is really a good reason here.

To the contrary, "Not enough interest" is a perfectly good reason for stopping work. So is "we can't agree on an outcome". IMHO, *both* of these situations are in effect here. Compared to the WG as a whole, there is a small set of people whirring and spinning on a couple of documents. Outside of that small clique, we're not seeing a lot of interest (activity) on the mailing list. To simply state that "…we (the LOADng authors) are far from the only ones participating…", without examples, is not proof - it's merely an assertion. The call of whether there is "sufficient support" in the WG is admittedly subjective. However, given the amount of strife on the topic, the likelihood that the WG will reach consensus, and the level of interest that I gauge - I stand by my position. IMO, as co-chair, this work should be terminated. 

Stan

---

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 12 Dec 2012 09:10:22 -0800

Hello folks,

> the point was that there is (no, little ?) progress in converging toward of the two options ..

To be clear, I am now and always have been in favor of
converging these two drafts.  After many months and
two unsatisfactory "maintenance" releases of the WG
document, I finally took unilateral action to the WG
document to be fully RFC 5444 compliant as well as
compatible with the design needs of LOADng, as I have
discussed before.

I hope that, technically at least, this process will be
viewed as progressing.  I remain quite open to further
evolution of the draft as may be needed, but by now
i hope that at least the feature set will be viewed as
complete.  Then what remains is resolving whatever
technical difficulties remain with the existing features,
and wordsmithing.  Bottom line: in most technical
aspects, I view that that process of convergence has
gotten to a pretty good state.

-- 
Regards,
Charlie P.

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Wed, 12 Dec 2012 18:03:46 +0000

I think given that there was discussion just in the last week or two on the status of gateways, that's just one example where features aren't stable. And I don't believe the WG has actually expressed a view on much of what's in or not in the document.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Charles E. Perkins
Sent: 12 December 2012 17:10
To: JP Vasseur (jvasseur)
Cc: <[email-masked]>
Subject: Re: [manet] LOADng (was Re: I-D Action: draft-ietf-manet-dymo-24.txt)

Hello folks,

-- 
Regards,
Charlie P.

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Wed, 12 Dec 2012 18:10:54 +0000

I think this is self-contradictory. It says there's a lot of strife but no interest. Strife does tend to happen more when there is interest.

I think the limited amount of technical discussion on the drafts is significantly in part because people are waiting to work out which draft they should comment on. (And it's also not a great time of year.) And even so today I see at least two people who are not authors making technical points (and there were more over the last few days). And some points (common to both drafts) a week or two ago from people who aren't regulars, let alone authors.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Stan Ratliff (sratliff)
Sent: 12 December 2012 15:58
To: Axel Colin de Verdière
Cc: <[email-masked]>
Subject: Re: [manet] LOADng (was Re: I-D Action: draft-ietf-manet-dymo-24.txt)

Axel, 

> I understand your position, I think you made that clear relatively early in the process, but I don't think "not enough interest" is really a good reason here.

To the contrary, "Not enough interest" is a perfectly good reason for stopping work. So is "we can't agree on an outcome". IMHO, *both* of these situations are in effect here. Compared to the WG as a whole, there is a small set of people whirring and spinning on a couple of documents. Outside of that small clique, we're not seeing a lot of interest (activity) on the mailing list. To simply state that ".we (the LOADng authors) are far from the only ones participating.", without examples, is not proof - it's merely an assertion. The call of whether there is "sufficient support" in the WG is admittedly subjective. However, given the amount of strife on the topic, the likelihood that the WG will reach consensus, and the level of interest that I gauge - I stand by my position. IMO, as co-chair, this work should be terminated. 

Stan

---

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 12 Dec 2012 10:39:49 -0800

Hello Chris,

Yes, if the WG decides to put in something about gateways in the
document, that will require more work.  I don't know if you had
a look at the expired document that I posted a few days ago on
the subject of gateways, but the discussion on the list also in my
opinion shows that the matter is not settled for OLSRv2 either.
I'm sure you can sift through the emails and find various points
that are not settled and still worthy of discussion.

I strongly believe that the subject is important enough to merit
a separate effort.  And, while it is true that proactive is easier,
there are many design issues in common, so that a separate
document could be made to apply to both proactive and reactive.

Perhaps after my local fires (IEEE, etc.) have died down in a few
more days, I'll write up a requirements draft for Gateways that
enumerates the issues raised here on the list as well as others
discussed in the past.  It's not as easy as just saying "0/0".

-- 
Regards,
Charlie P.

---

From: Henning Rogge <[email-masked]>
Date: Thu, 13 Dec 2012 08:39:44 +0100

> that are not settled and still worthy of discussion.

The difference is that OLSRv2 (and OLSRv1) contains the tool to handle 
all kind of network situations be propagating any kind of prefix through 
the network. This is the basis of internet uplinks and attached networks.

AODVv2 does not.

Henning Rogge

-- 
Diplom-Informatiker Henning Rogge , Fraunhofer-Institut für
Kommunikation, Informationsverarbeitung und Ergonomie FKIE
Kommunikationssysteme (KOM)
Fraunhofer Straße 20, 53343 Wachtberg, Germany
Telefon +49 228 9435-961,   Fax +49 228 9435 685
mailto:[email-masked] http://www.fkie.fraunhofer.de

---

From: Abdussalam Baryun <[email-masked]>
Date: Fri, 14 Dec 2012 00:40:38 +0100

I agree that there are interets in both drafts, but the interest is
more about a reactive protocol that WG progresses in. The problem was
that some participants changed their interest now to support another
draft than the WG work in progress, just because WG draft was parked.
I see that we stick with our interest of reactive protocol, but just
we need to find a way to discuss good/technical reasons (e.g. the
reason of the WG-draft was parked is not a good reason, but it was all
our responsibility or failure to proceed) for such support choice .

AB

On 12/12/12, Dearlove, Christopher (UK) <[email-masked]> wrote:
> I think this is self-contradictory. It says there's a lot of strife but no
> interest. Strife does tend to happen more when there is interest.
>
> I think the limited amount of technical discussion on the drafts is
> significantly in part because people are waiting to work out which draft
> they should comment on. (And it's also not a great time of year.) And even
> so today I see at least two people who are not authors making technical
> points (and there were more over the last few days). And some points (common
> to both drafts) a week or two ago from people who aren't regulars, let alone
> authors.
>
> --
> Christopher Dearlove
>>>>> It wasn't clear to me what the consensus was in Atlanta vis-a-vis the
>>>>> two reactive protocol documents. Presently, DYMO is the working group
>>>>> So now, we have two documents to consider. In the charter, the WG is
>>>>> "on the hook" for 1 (and only 1) reactive protocol. So the current
>>>>> options are:
>>> There's only one problem with that - It's already happened, and the
>>> deadline has already passed without conclusion. ;-)  It happened in
>>> Vancouver, with a deadline of Atlanta.
>>>
>>> I'm not seeing a high level of interest here. People seem to only have
>>> "passing interest" - enough to keep the efforts on life support, but not
>>> enough to really progress things. By and large, only the authors have the
>>> inclination to push their respective opinions, and nothing has really
>>> changed.
>>
>> I'm a bit surprised here: it seems weird to me that you can just dismiss a
>> 10 people behind a document, with strong industrial support (including
>> actual deployments) as "passing", or even "not enough" interest.
>> Furthermore, I've seen that we (the LOADng authors) are far from the only
>> ones participating on this topic.
>>
>>>
>>> So, I call once again - I think it's time to remove the work item from
>>> the charter, and recognize that we're not going to be able to work
>>> together on this issue. After more than a year of trying to get people to
>>> work together to make the technology better,  just don't see it
>>> happening. It's time to end the misery.
>>
>> I understand your position, I think you made that clear relatively early
>> in the process, but I don't think "not enough interest" is really a good
>> reason here.
>
> To the contrary, "Not enough interest" is a perfectly good reason for
> stopping work. So is "we can't agree on an outcome". IMHO, *both* of these
> situations are in effect here. Compared to the WG as a whole, there is a
> small set of people whirring and spinning on a couple of documents. Outside
> of that small clique, we're not seeing a lot of interest (activity) on the
> mailing list. To simply state that ".we (the LOADng authors) are far from
> the only ones participating.", without examples, is not proof - it's merely
> an assertion. The call of whether there is "sufficient support" in the WG is
> admittedly subjective. However, given the amount of strife on the topic, the
> likelihood that the WG will reach consensus, and the level of interest that
> I gauge - I stand by my position. IMO, as co-chair, this work should be
> terminated.
>
> Stan
>
>
>
>>
>> Best,
>>
>> Axel
>>
>>>
>>> Regards,
>>> Stan
>>>
>>>
>>>
>>>>
>>>>> far".. the best answer I can give you on that is "reach consensus on an
>>>>> approach".  We as a working group haven't done that yet. There are
>>>>> people advocating for DYMO, others advocating for LOADng, and some that
>>>>> want to "merge" the technology of the two together. A "merge" was
>>>>> something we tried in the Vancouver timeframe, but that effort failed.
>>>>>
>>>>>
>>>>> work item will be removed *for us*. If we do not show progress towards
>>>>> a goal, it is within the power of the IESG to stop work on the issue.
>>>>>
>>>>> Regards,
>>>>> Stan
>>>>>
>>>>>
>>>>>>
>>>>>> AB
>>>>>>
>>>>>>>

---

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Fri, 14 Dec 2012 15:19:56 +0000

Chris, 

> I think this is self-contradictory. It says there's a lot of strife but no interest. Strife does tend to happen more when there is interest.

Fair point. Let me see if I can clarify. I liken this to 10 guys in a Pub brawl. They are fighting over who should lead the government, whilst 150 (or so) other Pub-goers are standing around, watching the melee. In that situation, I'd say there's a lot of strife, but not a lot of interest in mounting a revolution…. ;-)

Regards,
Stan

---

From: Henning Rogge <[email-masked]>
Date: Fri, 14 Dec 2012 16:36:36 +0100

> Fair point. Let me see if I can clarify. I liken this to 10 guys in a Pub brawl. They are fighting over who should lead the government, whilst 150 (or so) other Pub-goers are standing around, watch…

But at least 120 of your pub-goers have been asleep for a few years.

Henning Rogge
-- 
Steven Hawkings about cosmic inflation: "An increase of billions of
billions of percent in a tiny fraction of a second. Of course, that
was before the present government."

---

From: Ulrich Herberg <[email-masked]>
Date: Fri, 14 Dec 2012 09:44:06 -0800

Stan,

I think the argument could not be further from the truth. There are many
active authors on the LOADng draft, from many different companies /
universities, with many interoperable implementations (documented in an
I-D), deployments, strong interest to drive the work forward. Moreover,
other people were very actively discussing on the list and in the last
meeting. We discussed for 1 hour 20 minutes! How can you say that there is
no interest?
For me, what we propose represents "rough consensus and running code". If I
remember correctly, that is something the IETF supports very much.

Best regards
Ulrich

On Fri, Dec 14, 2012 at 7:36 AM, Henning Rogge <[email-masked]>wrote:

> >> I think this is self-contradictory. It says there's a lot of strife but
> no interest. Strife does tend to happen more when there is interest.
> >
> > Fair point. Let me see if I can clarify. I liken this to 10 guys in a
> Pub brawl. They are fighting over who should lead the government, whilst
> 150 (or so) other Pub-goers are standing around, watching the melee. In
> that situation, I'd say there's a lot of strife, but not a lot of interest
> in mounting a revolution…. ;-)
>

---

From: "JP Vasseur (jvasseur)" <[email-masked]>
Date: Sat, 15 Dec 2012 20:57:22 +0000

Hi Ulrich,

Let's try to stick the technical discussion and not restart a "marketing" war, … these arguments have been spelled out on this list at least a hundred of time.
Let's go back to the technical arguments of AODV2 and Load-ng and see if we can converge.

Thanks.

JP.

On Dec 14, 2012, at 6:44 PM, Ulrich Herberg wrote:

Stan,

I think the argument could not be further from the truth. There are many active authors on the LOADng draft, from many different companies / universities, with many interoperable implementations (documented in an I-D), deployments, strong interest to drive the work forward. Moreover, other people were very actively discussing on the list and in the last meeting. We discussed for 1 hour 20 minutes! How can you say that there is no interest?
For me, what we propose represents "rough consensus and running code". If I remember correctly, that is something the IETF supports very much.

Best regards
Ulrich

On Fri, Dec 14, 2012 at 7:36 AM, Henning Rogge <[email-masked]<mailto:[email-masked]>> wrote:
On Fri, Dec 14, 2012 at 4:19 PM, Stan Ratliff (sratliff)

Henning Rogge

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Mon, 17 Dec 2012 10:24:05 +0000

Our WG co-chair has explicitly raised non-technical issues of participation, so I'm afraid your wrong here JP. Much as I would like to just do the technical thing.

But to be honest, I doubt anyone is participating much right now, especially anyone with a business year than is the calendar year. I would expect we may come back to this in the new year.

[email-masked]<mailto:[email-masked]> | http://www.baesystems.com

From: [email-masked] [mailto:[email-masked]] On Behalf Of JP Vasseur (jvasseur)
Sent: 15 December 2012 20:57
To: Ulrich Herberg
Cc: Dearlove, Christopher (UK); <[email-masked]>; Stan Ratliff (sratliff)
Subject: Re: [manet] LOADng (was Re: I-D Action: draft-ietf-manet-dymo-24.txt)

*** WARNING ***
This message originates from outside our organisation, either from an external partner or the internet.
Keep this in mind if you answer this message.
Please see this process<http://intranet.ent.baesystems.com/howwework/security/spotlights/Documents/Dealing%20With%20Suspicious%20Emails.pdf> on how to deal with suspicious emails.
Hi Ulrich,

Let's try to stick the technical discussion and not restart a "marketing" war, ... these arguments have been spelled out on this list at least a hundred of time.
Let's go back to the technical arguments of AODV2 and Load-ng and see if we can converge.

Thanks.

JP.

Stan,

Best regards
Ulrich

On Fri, Dec 14, 2012 at 7:36 AM, Henning Rogge <[email-masked]<mailto:[email-masked]>> wrote:
On Fri, Dec 14, 2012 at 4:19 PM, Stan Ratliff (sratliff)
<[email-masked]<mailto:[email-masked]>> wrote:
> Fair point. Let me see if I can clarify. I liken this to 10 guys in a Pub brawl. They are fighting over who should lead the government, whilst 150 (or so) other Pub-goers are standing around, watching the melee. In that situation, I'd say there's a lot of strife, but not a lot of interest in mounting a revolution.... ;-)

Henning Rogge

---

From: Abdussalam Baryun <[email-masked]>
Date: Mon, 17 Dec 2012 16:03:13 +0100

Hi Stan,

I agree that there are alot not interested in mounting a revolution,
but I think there is no doubt we need leadership (not government) to
solve our problems, but only reasonable/technical discussions used by
leaders can convince the 150 :)

AB

On 12/14/12, Stan Ratliff (sratliff) <[email-masked]> wrote:
> Fair point. Let me see if I can clarify. I liken this to 10 guys in a Pub
> brawl. They are fighting over who should lead the government, whilst 150 (or
> so) other Pub-goers are standing around, watching the melee. In that
> situation, I'd say there's a lot of strife, but not a lot of interest in
> mounting a revolution…. ;-)
>
> Regards,
> Stan
>
>
>>
>> points (and there were more over the last few days). And some points
>> (common to both drafts) a week or two ago from people who aren't regulars,
>> let alone authors.
>>
>> --
>> Christopher Dearlove
>>>>>> accepted reactive protocol document. However, there was a 2-year
>>>>>> period of time when DYMO was inactive, and the document was "parked".
>>>>>> As a result of that, the effort to create LOADng sprang up.
>>>>>>
>>>>>> 1. Recognize that we cannot reach consensus with the two documents,
>>>>>> and remove the charter item for reactive protocols. To be frank, this
>>>>>> is my preferred option.
>>>> enough to really progress things. By and large, only the authors have
>>>> the inclination to push their respective opinions, and nothing has
>>>> really changed.
>>>
>>> I'm a bit surprised here: it seems weird to me that you can just dismiss
>>> a 10 people behind a document, with strong industrial support (including
>>>> together on this issue. After more than a year of trying to get people
>>>> to work together to make the technology better,  just don't see it
>> small set of people whirring and spinning on a couple of documents.
>> Outside of that small clique, we're not seeing a lot of interest
>> (activity) on the mailing list. To simply state that ".we (the LOADng
>> authors) are far from the only ones participating.", without examples, is
>> not proof - it's merely an assertion. The call of whether there is
>> "sufficient support" in the WG is admittedly subjective. However, given
>> the amount of strife on the topic, the likelihood that the WG will reach
>> consensus, and the level of interest that I gauge - I stand by my
>> position. IMO, as co-chair, this work should be terminated.
>>
>> Stan
>>
>>
>>
>>>
>>> Best,
>>>
>>> Axel
>>>
>>>>
>>>> Regards,
>>>> Stan
>>>>
>>>>
>>>>
>>>>>
>>>>>> far".. the best answer I can give you on that is "reach consensus on
>>>>>> an approach".  We as a working group haven't done that yet. There are
>>>>>> people advocating for DYMO, others advocating for LOADng, and some
>>>>>> that want to "merge" the technology of the two together. A "merge" was
>>>>>> As to your statement that the LOADng team is not willing to discuss -
>>>>>> I haven't seen that, do not agree with it, and would ask you to cite

---

From: Abdussalam Baryun <[email-masked]>
Date: Mon, 17 Dec 2012 16:15:37 +0100

Hi JP
I agree with you to focus on the documents and technical issues. also
hope that we find a reasonable way to solve this issue as soon as
possible. I hope this issue does not happen in the future with another
parking WG document.

 I recommend the chairs and AD advise the authors of both document and
then report to us why there is no end in this issue (the merge idea
was agreed by one party but then changed). Really I think the authors
already went through discussing the merge under the chair request off
the list (without 150 monitoring, an example mentioned before of other
participants). The problem was they discussed the merge technical
issues off the list, so we cannot know the reasons why we are in this
problem. Problems/confusions only happen when there is no clear/traced
discussions.

AB

On 12/15/12, JP Vasseur (jvasseur) <[email-masked]> wrote:
> Hi Ulrich,
>
> Let's try to stick the technical discussion and not restart a "marketing"
> war, … these arguments have been spelled out on this list at least a hundred
> of time.
> On Fri, Dec 14, 2012 at 7:36 AM, Henning Rogge
> <[email-masked]<mailto:[email-masked]>> wrote:
>> brawl. They are fighting over who should lead the government, whilst 150
>> (or so) other Pub-goers are standing around, watching the melee. In that

---

From: Abdussalam Baryun <[email-masked]>
Date: Wed, 19 Dec 2012 01:59:05 +0100

On 12/11/12, Stan Ratliff (sratliff) <[email-masked]> wrote:
>- if the WG accepts LOAD as a working group
> document (see my earlier email for my thoughts on that), the copyright will
> be removed.

If this input-document (draft-clausen-lln-loadng-06) was chosen as WG
darft and removing IETF copyright, how do I make advise/input to such
document that does not give its copyright to IETF and while any of
participants input has copyright of IETF. I don't understand how can I
spend time on such document that does not give equality to any input.
Sorry if my question is crazy but I trying to understand these things
in IETF.

AB

---

From: Henning Rogge <[email-masked]>
Date: Thu, 20 Dec 2012 17:44:16 +0100

> Sorry if my question is crazy but I trying to understand these things

Stan talked about the copyright part of LOADng that prevents other
protocols from copying parts of it. As soon as LOADng would be a
workinggroup draft, it would have the NORMAL IETF copyright notice as
every other normal workinggroup draft. At least thats MY
understanding.

Henning Rogge

---

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Thu, 20 Dec 2012 17:25:21 +0000

> every other normal workinggroup draft. At least thats MY

Correct. 

Regards,
Stan

---

From: "Timothy J. Salo" <[email-masked]>
Date: Thu, 20 Dec 2012 22:08:15 -0600

> protocols from copying parts of it.

My understanding of copyright law is that a copyright might prevent
others from copying the LOADng _document_, but copyright cannot protect
the protocol itself.

(This topic pops up every few years.  It would be nice if the IETF had
an FAQ that covered this topic...)

-tjs

---

From: Henning Rogge <[email-masked]>
Date: Sat, 22 Dec 2012 09:29:46 +0100

> others from copying the LOADng _document_, but copyright cannot protect

And thats exactly what the copyright notice on LOADng is about if I
remember it correctly. It prevents people from taking parts of the
draft text.

Henning Rogge

---

From: Abdussalam Baryun <[email-masked]>
Date: Sat, 22 Dec 2012 14:51:45 +0100

> remember it correctly. It prevents people from taking parts of the

I understood from you that it tries to prevent ietf participants from
using its text parts in another ietf draft, which is new rights
introduced from my understanding, but happy to learn :)

So if I have an input on the list I can prevent others to use as to
write within my input:
<This message removes copyrights, no participant allowed to use the text > or
<This message removes copyrights, only draft-xxx allowed to use the text >

Regards
AB

---

From: Daniel He <[email-masked]>
Date: Sat, 22 Dec 2012 14:57:15 +0000

It is the meaning what copyright is to prevent the others to take any part
from the text (particularly for the draft). It is not new right.

But as I understood, as long as the draft becomes a standard, all materials
have been surrended to IETF copyright.

Cheers,
Dan

-- 
Dan He
---------------------
openstack contributor
GPU stream programming

http://wiki.openstack.org/Contributors

Tel: +44-788-686-3428