Subject: [manet] Resolving the Reactive Protocol issue

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 17 Dec 2012 18:55:34 -0000

Hi MANET,

In the spirit of all good examination papers, please read all the way to the end
of this email before starting to write your response.

I have been watching the discussions on the MANET list with care and talking
with the chairs. All three of us have, I know, received plenty of private emails
on the subject as well.

In my opinion, the debate about documents has almost (but not completely)
obscured the technical work. This is neither helpful nor in the spirit of an
engineering organisation.

As AD it falls to me to unblock this log jam and enable the working group to do
useful work. I think I see people explicitly asking for AD intervention.

In Atlanta, there remained interest in having a reactive protocol produced by
the working group. There is clearly still some interest on the list. But it is
not clear to me how the WG feels on this since there may be many who are
watching and wishing they could get on with other work in a quieter environment.
Therefore: 

=====
Question 1 to the working group: Would you prefer to have "Standards track
Reactive protocol" removed from the charter? A "yes/no" answer is all that I
want to hear.
=====

It is clear to me that attempts to merge or choose documents have failed. There
is no value in discussing how or why, nor to what extent they might be partially
successful, or how resolution could be potentially reached. Therefore:

=====
Question 2 to the working group: Would you like the AD to select one of the
documents (and, obviously, I will not tell you in advance which I might select!)
and require that the WG works on that one document? In this case, publication of
the other document with AD sponsorship or through the ISE is unlikely. Again, a
"yes/no" answer is all I want to hear, but respondents must understand that
saying "yes" implies a willingness to cooperate, to provide text, and to have
the WG make any modifications to the document all in the normal IETF way.
=====

Failing the selection of just one document, and absent abandoning the work item,
there remains the possibility of progressing both documents within the working
group. As AD I will not allow the working group to produce two standards track
RFCs for reactive protocols, and I therefore see no benefit in having two
working group drafts claiming to be intended for standards track publication. So
this leads to:

=====
Question 3 to the working group: Would you be prepared to work on two documents
describing reactive protocols that are intended for publication as Experimental
RFCs? Yet again, a "yes/no" answer is what I want to hear, but respondents need
to understand that saying "yes" implies a willingness to see both documents
published as Experimental RFCs and that, owing to the lower bar on Experimental
work, it would not be acceptable to attempt to block the progress of either
document with protracted technical discussions. We might (in the operational
spirit of the MANET working group) come back after some time and experience with
the RFCs to re-charter and select just one solution for the standards track, but
that is for the distant future.	
=====

I need to explain to the working group that the default position will be to
remove this item from the WG charter. That is, if the WG overwhelmingly says
"no" to both Q2 and Q3, I will work with the IESG to remove reactive protocols
from the MANET charter regardless of the answer to Q1.

How to answer this email: Send responses in the form of
1 [yes/no]
2 [yes/no]
3 [yes/no]
This is not a vote, but I am taking the mood of the working group in order to
inform my decision.
Conditional answers such as "yes, but only if foo" are within your rights, but
will not be very helpful to me, 

I know that many people are busy with work or enjoying themselves at this time
of year, but this decisions needs to be made soon. I am inclined to make my
decision before the end of 2012, but in deference to the festivities, I will
announce it in the week of January 7th.

Thanks,
Adrian

---

From: Abdussalam Baryun <[email-masked]>
Date: Tue, 18 Dec 2012 14:53:48 +0000

Hi Adrian,
The WG AD

my answers as per your request;

Q1 [no]
Q2 [yes]
Q3 [no]
Thank you for the solution and help for WG progress, wishing you and all WG
participants a happy new year :)

Best Regards
AB

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 18 Dec 2012 16:57:41 -0000

Since I have now had 6 responses and only 1 was on the list, can I just say:
that's OK.

Reponses in private are just fine. I am not trying to build WG consensus, but
(as the ITU might say) take the mood of the room.

Thanks,
Adrian

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Adrian Farrel
> Sent: 17 December 2012 18:56
> To: [email-masked]
> Subject: [manet] Resolving the Reactive Protocol issue
> 
> Hi MANET,
> 
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet

---

From: Henning Rogge <[email-masked]>
Date: Tue, 18 Dec 2012 18:01:00 +0100

> (as the ITU might say) take the mood of the room.

Does this mean this "taking the mood" will turn into a vote later? ;)

Yes, I am also for getting a reactive protocol done. I think AODV2 and
LOADng are not that far from each other, but the LOADng draft is much
easier to read and to implement.

Henning Rogge
-- 
Steven Hawkings about cosmic inflation: "An increase of billions of
billions of percent in a tiny fraction of a second. Of course, that
was before the present government."

---

From: "Charles E. Perkins" <[email-masked]>
Date: Tue, 18 Dec 2012 10:05:43 -0800

Hello Adrian,

1[removed from the charter ]:     no
2[AD select one ]:                           yes
3[publication as Experimental ]:   no

Regards.
Charlie P.

-- 
Regards,
Charlie P.

---

From: "Charles E. Perkins" <[email-masked]>
Date: Tue, 18 Dec 2012 10:17:54 -0800

Hello folks,

I can't change the past events that have brought us to this
point.  But I'd at least like to encourage optimism about the
progress of the existing WG document.  Here is why:

- The last WG document revision submitted is also the first
    one which logistically I was able to bring up to a good
    standard of correctness, and readability.  It shows my
    commitment to produce a high-quality document.

- I reiterate that LOADng should be supported as a set of
   choices from among the optional features of the WG reactive
   protocol specification.  While I was not able to accomplish
   this by working with the other LOADng authors to merge
   the documents, I have always been explicit that this was the
   desired outcome.

Well, that's about as far as I know how to get into the political
waters.  I've always set about doing the things I promised to
do, and so far during the last year I have done so.  That also
includes to make a consensus and good quality WG document.

Regards,
Charlie P.

-- 
Regards,
Charlie P.

---

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Tue, 18 Dec 2012 19:06:23 +0000

Speaking as a WG participant: 

Question 1:   Yes
Question 2:   No   (But this is a reasonable "Plan B")
Question 3:   No

Regards,
Stan

---

From: "JP Vasseur (jvasseur)" <[email-masked]>
Date: Thu, 20 Dec 2012 11:32:03 +0000

Hi Adrian,

As requested here are my answers (with no more than Yes/No):

Question 1: No
Question 2: Yes
Question 3: No

Happy holidays to all of you !

JP.

---

From: Brian Adamson <[email-masked]>
Date: Thu, 20 Dec 2012 10:33:50 -0500

My input to you questions:

Question 1: no

Question 2: yes

Question 3: yes,  but this is not independent of Question #2 (a single specification here is preferable to me given their functional similarity), and I think the documents' statuses (Experimental vs. Proposed Standard) for each respective protocol should be assessed on each individual protocol's maturity with respect to experience, deployment, etc. 

Brian Adamson
[email-masked]

---

From: "Dearlove, Christopher (UK)" <[email-masked]>
Date: Thu, 20 Dec 2012 17:07:30 +0000

I've given my answers to Adrian privately (I had assumed that was the requirement).

I will note here what I said in that, which is that Q3 has a slightly different nature. Q1 and Q2 ask about what should happen. Q3 asks would I work on two documents.

(I will note that as I'm an author on six WG documents, even if I say no to Q3 I think no one could say I'm not doing my bit here.)

-- 
Christopher Dearlove
Senior Principal Engineer, Communications Group
Communications, Networks and Image Analysis Capability
BAE Systems Advanced Technology Centre
West Hanningfield Road, Great Baddow, Chelmsford, CM2 8HN, UK
Tel: +44 1245 242194 |  Fax: +44 1245 242124
[email-masked] | http://www.baesystems.com

BAE Systems (Operations) Limited
Registered Office: Warwick House, PO Box 87, Farnborough Aerospace Centre, Farnborough, Hants, GU14 6YU, UK
Registered in England & Wales No: 1996687

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: 17 December 2012 18:56
To: [email-masked]
Subject: [manet] Resolving the Reactive Protocol issue

----------------------! WARNING ! ----------------------
This message originates from outside our organisation,
either from an external partner or from the internet.
Keep this in mind if you answer this message.
Follow the 'Report Suspicious Emails' link on IT matters
for instructions on reporting suspicious email messages.
--------------------------------------------------------

Hi MANET,

=====

=====

=====

Thanks,
Adrian

********************************************************************
This email and any attachments are confidential to the intended
recipient and may also be privileged. If you are not the intended
recipient please delete it from your system and notify the sender.
You should not copy it or use it for any purpose nor disclose or
distribute its contents to any other person.
********************************************************************

---

From: Philippe Jacquet <[email-masked]>
Date: Sat, 22 Dec 2012 23:03:08 +0100 (CET)

Dear Adrian,
My input:
1 : no
2 : no
3 : yes

Philippe

----- Mail original -----
De: "Adrian Farrel" <[email-masked]>
À: [email-masked]
Envoyé: Lundi 17 Décembre 2012 19:55:34
Objet: [manet] Resolving the Reactive Protocol issue

Hi MANET,

=====

=====

=====

Thanks,
Adrian

---

From: Philippe Jacquet <[email-masked]>
Date: Sun, 23 Dec 2012 11:30:18 +0100 (CET)

Hello folks,
Some bit of explanations about my vote, since I didn't participate to the discussions.

I would have voted "yes" to the first question, if I had the feeling that the reactive protocols would become a blocking issue for the whole Manet WG. I assume no (I hope I am right).

I have voted "no" to the second question because I think that none of the proposals are presently meeting all Manet standards. One proposal seems with the time to have partially lost some of his quality edges, and the second proposal seems, at least partially, not right in the scope of Manet focus. 

Therefore I voted "yes" to the third question, although I totally agree that this may lead to further frustrations. But it is already very frustrating that two not that far proposals with so much potentials could not benefit from each other.

Merry X-mas and happy New Year,
Philippe

----- Mail original -----
De: "Philippe Jacquet" <[email-masked]>
À: [email-masked]
Cc: [email-masked]
Envoyé: Samedi 22 Décembre 2012 23:03:08
Objet: Re: [manet] Resolving the Reactive Protocol issue

Dear Adrian,
My input:
1 : no
2 : no
3 : yes

Philippe

----- Mail original -----
De: "Adrian Farrel" <[email-masked]>
À: [email-masked]
Envoyé: Lundi 17 Décembre 2012 19:55:34
Objet: [manet] Resolving the Reactive Protocol issue

Hi MANET,

=====

=====

=====

Thanks,
Adrian

---

From: Jiazi YI <[email-masked]>
Date: Mon, 24 Dec 2012 14:55:39 +0100

Dear Adrian, all:

Here is my opinion on those questions:

1) Would you prefer to have "Standards track Reactive protocol" removed from the charter?
	NO
	But it's not something I'll fight for. Therefore, I voted "yes" to 3) also. 

2) Would you like the AD to select one of the documents?
	NO
 	I would say "YES" if I know what's the considerations when making those selections. If it's based on IETF's "running code" and "rough consensus", or at least either of them, I'm totally OK.  But without further information, I can only say NO. 

3)  Would you be prepared to work on two documents describing reactive protocols that are intended for publication as Experimental RFCs?
	YES
	It's not the best choice, but it's acceptable for me if there is no consensus in the WG. 

best
Merry Christmas. 

Jiazi