Subject: Re: [manet] I-D Action: draft-ietf-manet-dlep-04.txt

From: Vigneswaran R <[email-masked]>
Date: Thu, 02 May 2013 16:22:13 +0530

Hello,

Below are some minor things I noticed while going through the dlep-draft-04,

id> 9. DLEP Data Items
     <snip>
     one of the Signal TLVs, documented in section [INSERT REFERENCE
     HERE].

suggestion> replace [INSERT REFERENCE HERE] with 10.1.

id> 9.9  Current Data Rate (Transmit)

     The Current Data Rate Receive (CDRT) TLV is used in Neighbor Up,

suggestion> change "Current Data Rate Receive" into "Current Data Rate 
Transmit"

Regards,
Vignesh

On 03/25/2013 10:53 PM, Stan Ratliff (sratliff) wrote:
> WG -
>
> As promised, DLEP-04. As I mentioned in Orlando, the changes are:
> 1. Went back to modem-initiated discovery
> 2. Inbound and outbound metrics
>
> I'm sure something got missed, so your review & comments are appreciated.
>
> Regards,
> Stan
>
>
> On Mar 25, 2013, at 1:21 PM, <[email-masked]>
>   wrote:
>
>> A New Internet-Draft is available from the on-line Internet-Drafts directories.
>> This draft is a work item of the Mobile Ad-hoc Networks Working Group of the IETF.
>>
>> 	Title           : Dynamic Link Exchange Protocol (DLEP)
>> 	Author(s)       : Stan Ratliff
>>                           Bo Berry
>>                           Greg Harrison
>>                           Darryl Satterwhite
>>                           Shawn Jury
>> 	Filename        : draft-ietf-manet-dlep-04.txt
>> 	Pages           : 48
>> 	Date            : 2013-03-25
>>
>> Abstract:
>>    When routing devices rely on modems to effect communications over
>>    wireless links, they need timely and accurate knowledge of the
>>    characteristics of the link (speed, state, etc.) in order to make
>>    forwarding decisions. In mobile or other environments where these
>>    characteristics change frequently, manual configurations or the
>>    inference of state through routing or transport protocols does not
>>    allow the router to make the best decisions. A bidirectional, event-
>>    driven communication channel between the router and the modem is
>>    necessary.
>>
>>
>> The IETF datatracker status page for this draft is:
>> https://datatracker.ietf.org/doc/draft-ietf-manet-dlep
>>
>> There's also a htmlized version available at:
>> http://tools.ietf.org/html/draft-ietf-manet-dlep-04
>>
>> A diff from the previous version is available at:
>> http://www.ietf.org/rfcdiff?url2=draft-ietf-manet-dlep-04
>>
>>
>> Internet-Drafts are also available by anonymous FTP at:
>> ftp://ftp.ietf.org/internet-drafts/
>>
>> _______________________________________________
>> manet mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/manet
> _______________________________________________
> manet mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/manet
>

---

From: vignesh <[email-masked]>
Date: Fri, 03 May 2013 16:59:06 +0530

> suggestion> change "Current Data Rate Receive" into "Current Data Rate 

A few more,

id> 9.15  Relative Link Quality (Transmit)

     The Transmit Link Quality Receive (RLQT) TLV is an OPTIONAL data

suggestion> change "Transmit Link Quality Receive" into "Relative Link 
Quality Transmit"

id> 9.15  Relative Link Quality (Transmit)
     <snip>
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     |TLV Type =TBD  |Length = 1     |XMT Rel. Link  |
     |               |               |Quality (RLQR) |
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

suggestion> change "(RLQR)" into "(RLQT)"

id> 9.17  Heartbeat Interval/Threshold
     <snip>
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     |TLV Type =TBD  |Length = 1     | Interval      |  Threshold    |
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     <snip>
     Length           - 1

suggestion> change the value for Length to 2, in both places

id> 9.21  Credit Request
     <snip>
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     |TLV Type =TBD  |Length = 0     | Reserved, MUST|
     |               |               | be set to 0   |
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     <snip>
     Length       - 0

comment> I think, the Length should be 1

id> 10. DLEP Protocol Messages
     <snip>
     signal, as defined in section 11.1 of this document. The second TLV
     MUST be the Identification data item, defined in section 10.1

comment> It seems, Signals and Data Items are defined under section 
10.1 and section 9 respectively.

id> 10. DLEP Protocol Messages
     <snip>
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     | Start of optional DLEP        |
     | TLVs...                       |
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

suggestion> "Start of optional DLEP TLVs..." can be changed to "Start 
of optional and/or mandatory DLEP TLVs..." like the following (as some 
of the signals have mandatory data items).

     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     | Start of optional and/or      |
     | mandatory DLEP TLVs...        |
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

id> 11. Peer Discovery Message
     <snip>
     Given the packet format described in section 11, the initial TLV 
Type

suggestion> change "section 11" into "section 10"

id> 13. Peer Offer ACK Message
     <snip>
     MUST contain an OPTIONAL Status data item, indicating success or

suggestion> "OPTIONAL" can be removed.

Regards,
Vignesh

---

From: "Stan Ratliff (sratliff)" <[email-masked]>
Date: Fri, 3 May 2013 13:50:33 +0000

Vignesh, 

Thank you for the review and comment. 

Regards,
Stan

On May 3, 2013, at 7:29 AM, vignesh wrote:

>> suggestion> change "Current Data Rate Receive" into "Current Data Rate Transmit"
> 
> A few more,
> 
> suggestion> change "Transmit Link Quality Receive" into "Relative Link Quality Transmit"
> 
> comment> It seems, Signals and Data Items are defined under section 10.1 and section 9 respectively.
> 
> suggestion> "Start of optional DLEP TLVs..." can be changed to "Start of optional and/or mandatory DLEP TLVs..." like the following (as some of the signals have mandatory data items).
> 
>    Given the packet format described in section 11, the initial TLV Type
>